17:01:27 <marja> #startmeeting
17:01:27 <Inigo_Montoya> Meeting started Mon Jun 17 17:01:27 2013 UTC.  The chair is marja. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:27 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:01:28 <Kernewes> marja: hi marja :)
17:01:48 <marja> Kernewes: yurchor: so there's at least 3 of us :)
17:02:01 <Kernewes> yurchor: hi :)
17:02:08 <yurchor> Kernewes: Hi!
17:02:24 <marja> #topic current state of moving to the SVN + po workflow for Calenco documentation
17:02:52 <marja> I know lebarhon has been testing Lokalize
17:03:27 <marja> and I tried yurchors instructions to get a .po file for an existing translation
17:03:31 <yurchor> I have finished (almost) a tutorial. So just waiting for lebarhon to follow and report the results.
17:03:43 <marja> ah, nice
17:04:37 <yurchor> Where is the best place for it BTW?
17:04:50 <marja> lebarhon: welcome
17:04:56 <lebarhon> hello
17:04:56 <Kernewes> lebarhon: hello :)
17:05:08 <yurchor> lebarhon: Hi!
17:05:15 <marja> lebarhon: yurchor just asked what would be the best place for his instructions
17:05:42 <lebarhon> Why not the Wiki
17:05:54 <marja> lebarhon: where in the wiki ;-)
17:06:20 <lebarhon> Yurchor has already a page for lokalize
17:06:21 <yurchor> H-m-m, it is already on wiki. But on my own page. Sure, not the best place.
17:06:34 <lebarhon> I think you are talking about lokalize
17:06:55 <yurchor> lebarhon: Yes, we are.
17:06:57 <yurchor> ;)
17:06:58 * marja is not very awake, sorry
17:07:11 <lebarhon> You won't let it in your own page
17:07:32 <marja> yurchor: "Lokalize" or "Translating with lokalize" ?
17:07:45 <yurchor> Ok.
17:07:50 <Kernewes> lebarhon: I believe it's still in draft form until we're happy it's ready to go somewhere else on the wiki
17:08:17 <marja> yurchor: and then a different page for the converter.sh script?
17:08:25 <lebarhon> I think the page is ready to be in the right place
17:08:29 <yurchor> Kernewes: Ok.
17:08:56 * marja thinks the page can move to its final place
17:09:07 <yurchor> marja: It is one time script. No need to stress attention and keep it for a long time.
17:09:17 * lebarhon thinks like Marja
17:09:31 <Kernewes> lebarhon: what do you think is a good place for it?
17:09:32 <marja> yurchor: that is true, but for now it would be nice to easily find it
17:09:42 <marja> yurchor: the page can be deleted when no longer needed
17:09:44 <lebarhon> Translating with lokalize
17:09:50 <grenoya> hi (i'm late, sorry)
17:09:59 <yurchor> grenoya: Hi!
17:09:59 <marja> grenoya: welcome :)
17:10:24 <Kernewes> grenoya: hi :)
17:11:52 <marja> btw, about moving pages, in other cases (when a page is already in the wiki, but has a wrong name)... please choose "Move" from the drop-down menu in the upper right corner
17:12:09 <yurchor> Ok.
17:12:29 <Kernewes> ok
17:12:29 <marja> that will create a redirect, and prevent having a duplicate page that is edited independently of the original
17:13:06 <marja> (one Macxi page was edited by him, and a copy by one of us)
17:13:28 <lebarhon> marja: Is that true from one own page ?
17:13:40 <marja> lebarhon: no, that doesn't count ;-)
17:13:48 <lebarhon> Ok
17:14:02 <marja> lebarhon: only when a page is already "really" in the wiki
17:14:54 <marja> #action When moving a wiki page (other then a draft in someone's user space), select "Move" to move it and don't copy & paste
17:15:41 <marja> yurchor: after I followed the conversion instructions, my pages didn't have the xml:lang="nl" tag
17:15:53 <marja> yurchor: do I only need to add them once
17:16:02 <marja> yurchor: or after every update?
17:16:21 <yurchor> Oops... No They should be added automatically...
17:17:03 <marja> yurchor: np, I need to redo it anyway... I seem to have more lines in the translation than in the original, and I didn't find yet where they are
17:17:07 <yurchor> Need some investigation. Did you convert them back from PO as it was written?
17:17:52 <yurchor> There is a hack to convert. So en folder must be redownloaded.
17:17:55 <marja> yurchor: after I had the po (and the conversion script didn't complain about anything), I generated the new Dutch .xml files
17:18:38 <marja> yurchor: ah, maybe I did it in the wrong order... convert first and then re-download, I don't remember
17:18:41 <yurchor> Or yes, if redownload is skipped that's how it should end. :(
17:19:03 <marja> yurchor: np, I'll do it again :-)
17:19:43 <marja> yurchor: without your comment about how you converted the Dutch files, it would have been too confusing, btw
17:20:15 <yurchor> I know... So what to do?
17:21:37 <yurchor> It is the most confusing part of the whole process.
17:22:33 <marja> yurchor: I intend to learn to do it well, and then do it for at least the languages that don't have a fixed translator(group)
17:22:56 <yurchor> Even a misplaced dot can break the conversion.
17:23:07 <yurchor> Ok.
17:23:17 <marja> yurchor: beginning with Esperanto and Swedish, because they aren't in doc.mageia.org (for Mga 3)
17:23:56 <yurchor> marja: Ok. I will try too after the exams.
17:24:50 <marja> yurchor: thx :)
17:26:16 <marja> yurchor: I just checked my .bash_history ... it seems didn't do that svn up at all :-/
17:26:39 <marja> yurchor: that increases the chance next time will be better :-D
17:27:15 <yurchor> https://wiki.mageia.org/en/Translating_with_Lokalize
17:27:46 <marja> #action when there is time, yurchor and marja try to convert the existing translations (make .po files for use with SVN)
17:28:27 <marja> yurchor: nice, thx a lot for writing that page
17:28:53 <marja> is there anything else on this topic?
17:29:40 <lebarhon> Are further explanations expected about it
17:29:58 <yurchor> lebarhon: Sure. Just ask.
17:29:58 <Kernewes> brb
17:30:00 <marja> lebarhon: ask and you shall receive :-D
17:30:33 <marja> lebarhon: i mean.... I don't understand it all yet, either... I think it is best to just ask when we get stuck
17:30:37 <lebarhon> I meant, in the wiki
17:30:59 <marja> lebarhon: the lokalize page?
17:31:15 <lebarhon> marja: yes
17:31:19 <yurchor> Yes, in the wiki. You can use "Discussion" page for the questions.
17:31:37 <marja> yurchor: good suggestion, thanks :)
17:31:44 <lebarhon> for example of what isn't clear,
17:31:54 <lebarhon> In the newly created svn folder, there is a lot of sub-folders, but anyone that matches a Mageia tool or window or help.
17:32:08 <Kernewes> back
17:32:12 <lebarhon> I could find Installer help but without French one and nothing about MCC help.
17:32:12 <lebarhon> How to get them ?
17:32:25 <marja> #action questions about using lokalize can be put in the "discussion" page for https://wiki.mageia.org/en/Translating_with_Lokalize
17:32:53 <marja> lebarhon: MCC still needs to be done
17:33:08 <lebarhon> marja: and the installer help ?
17:33:20 <marja> lebarhon: and the existing French installer translation needs to be converted
17:33:25 <yurchor> lebarhon: Heh... It is not the IRC question. It is better to think it over and give a useful and compehensive answer on the Discussion page.
17:33:42 <marja> lebarhon: yurchor wrote a script for that
17:33:48 <lebarhon> It was examples
17:34:29 <marja> lebarhon: I'll work on learning to do a conversion well, when I do it well, I can help wiht the French conversion
17:34:58 <yurchor> lebarhon: Ok, sure. So what about some discussion branch on mailing list or wiki?
17:35:00 <marja> lebarhon: the instructions were in a mail by yurchor on our ml on 11/05/13 14:36
17:35:42 <marja> (CET/CEST)
17:35:43 <yurchor> Everybody can ask their questions and we can do the process well-documeted and easy to follow.
17:36:50 <marja> maybe both..... ask on the mailing list, but have the summarized version in the wiki
17:37:20 <marja> in the wiki discuss page, I mean
17:38:37 <marja> lebarhon: wdyt?
17:39:37 <lebarhon> I prefer the wiki discuss page, more easy to find it back
17:40:18 <marja> fine.... let's then just point to that page on our ml
17:41:11 <marja> #action marja write mail after meeting about meeting logs and about asking questions on the discuss page of https://wiki.mageia.org/en/Translating_with_Lokalize
17:41:11 <lebarhon> I also think to Dune and a new one (Jesus !) thew can easily find the wiki pages
17:41:33 <lebarhon> * thew / they
17:41:53 <marja> lebarhon: I thought only Spanish men/boys were called Jesus
17:42:11 <lebarhon> it is his pseudo
17:42:16 <marja> lebarhon: ah
17:42:33 <lebarhon> I would rather have the welknown one :)
17:42:52 <marja> lebarhon: :-D
17:43:01 <marja> can we move on to next topic?
17:45:03 <marja> #topic what is happening in our wiki?
17:45:30 <marja> well, we have a French and a German wiki now, but both show little action
17:45:47 * lebarhon didn't know
17:46:07 <Kernewes> you mean the pages translated into German or another wiki?
17:46:26 <marja> and I'm glad about that, because our German wiki proves it is hard to keep the translations up-to-date
17:46:38 <Kernewes> I was going to try to do some work on that
17:46:43 <marja> Kernewes: yes... and now we have a French wiki too
17:47:32 <Kernewes> I've merged the two pages about installing from a live CD
17:47:59 <marja> #info there is good news, boklm wrote to council ml that mediawiki update is one of the main things sysadmin team has to do
17:48:23 <yurchor> Hooray!
17:48:33 <marja> so it looks like it is coming closer, and then the translate extension can be used :-D
17:48:42 <Kernewes> I see from the last QA team meeting minutes that it's being worked on
17:48:52 <Kernewes> then it can go to QA for testing
17:49:11 <marja> Kernewes: ah, nice I didn't know that
17:49:39 <marja> Kernewes: thanks for merging those pages :)
17:49:45 <Kernewes> marja: yw :)
17:50:01 <Kernewes> I haven't started watching the wiki yet
17:50:15 <Kernewes> I got as far as installing Akregator :)
17:50:24 <marja> Kernewes: perfect :)
17:51:26 <lebarhon> Is the French ready for anyone to add pages ?
17:51:36 <lebarhon> * French wiki
17:52:09 <marja> Kernewes: this page was edited by Macxi after you moved it to "...beginners" https://wiki.mageia.org/en/Install_media_in_Mageia_2_for_beginner
17:52:20 <marja> lebarhon: I think so
17:52:32 * Kernewes goes to look
17:52:56 <lebarhon> There is stil no links between languages
17:53:09 <marja> lebarhon: oops, that needs to be fixed, too
17:53:14 <marja> papoteur: welcome :)
17:53:29 <Kernewes> marja: I just changed the name, so I suppose that leaves two pages, as you were talking about earlier
17:53:35 <lebarhon> Hello papoteur, the French wiki is there ...
17:53:36 <papoteur> Hello docteam.
17:53:59 <lebarhon> https://wiki.mageia.org/fr/Accueil
17:54:01 <marja> Kernewes: yes, the only way that works is chosing "Move" from the drop-down menu
17:54:08 <Kernewes> marja: I suppose that's one where the "2" could be taken out
17:54:26 <Akien> lebarhon: Well yes, there was a request from ennael on the sysadmin ML to have it opened.
17:54:33 <Kernewes> marja: unfortunately I did a few like that :(
17:54:35 <papoteur> Hey, surprising !
17:55:08 <Kernewes> marja: there shouldn't be a link to the old pages though
17:55:10 <marja> Kernewes: yes, I think it is good to move it to https://wiki.mageia.org/en/Install_media_in_Mageia_for_beginners
17:55:17 <Akien> lebarhon, papoteur: But is there a purpose in having the fr wiki if we don't have the Translate extension?
17:56:08 <marja> Kernewes: I think moving one of them is OK, then adding the missed edit(s), and then putting the redirect in the other old page, too
17:56:10 <lebarhon> Akien: that is bad news, they weren't told
17:56:29 <papoteur> Akien: this a first quetion. A second one the articulation with www.mageialinux-online.org
17:56:49 <marja> Kernewes: no, the links should be redone
17:57:08 <marja> Kernewes: and when all the links are good, I can deleted the old pages
17:57:16 <Kernewes> marja: I thought the links had been redone
17:57:29 <Kernewes> marja: I'll have a look at it when I get time
17:57:54 * marja thinks too it is wiser to wait with putting too much in the fr wiki, until the translate extension can be used
17:58:27 <Kernewes> marja: the links look OK
17:58:33 <lebarhon> what will this extension do ?
17:58:54 <lebarhon> except links between pages
17:58:58 <Kernewes> marja: are there other links I don't know about?
17:59:05 <Akien> lebarhon, papoteur: Yes I wasn't particularly happy when I saw this :/
17:59:19 <marja> lebarhon: no, help keep the translations up-to-date for pages that need to be updated
17:59:20 <yurchor> Despite someone told that it is impossible to create locale-only pages with TE, it is not true.
17:59:38 <marja> lebarhon: currently, only one language can be set as "original" language
17:59:48 <Akien> lebarhon: Well, IIUC, it's linking the pages and let you translate the EN content (so EN is reference, and you translate the page in French)
17:59:56 <yurchor> So all the pages with original content can stay where they were.
17:59:58 <Akien> But it stays possible to add independant pages I think
17:59:59 <marja> lebarhon: but there is an upstream ticket about that, so that should hopefully change
18:00:03 <lebarhon> marja: there is no much pages to be sync
18:00:27 <marja> Akien: it is more than just linking..... it gives a very nice report etc.
18:00:38 <lebarhon> Akien: We can do that without extension
18:01:09 <Akien> lebarhon: Add independent pages yes, but not translate the EN content.
18:01:22 <Akien> At least I would not. Managing the release notes and errata is already complicated enough.
18:01:25 <yurchor> lebarhon: Sure. But we cannot do this automagically.
18:01:30 <papoteur> Use the extension somethink like gettext and po files?
18:01:59 <marja> Nikerabbit: sorry, I can't find my link to show the nice KDE translate overview
18:02:08 <yurchor> papoteur: Yes it can be used this way. But it is just one of the alternatives.
18:02:31 <marja> Nikerabbit: I wanted to show it here ;-)
18:02:34 <papoteur> yurchor: What are the others?
18:03:09 <Kernewes> marja: ah I see now, there are other places with links to those pages
18:03:14 <yurchor> papoteur: You can translate online in a wiki manner, in the parallel to other users.
18:03:21 <Nemo_bis> marja: what sort of overview?
18:03:48 <Nemo_bis> http://userbase.kde.org/index.php?title=Special%3ALanguageStats&x=D&language=it&suppresscomplete=1
18:03:53 <[mbot> [ Language statistics - KDE UserBase Wiki ]
18:04:00 <marja> Nemo_bis: thx!!
18:04:02 <Nemo_bis> we have a video https://www.mediawiki.org/wiki/File:Making_Multilingual_Wikis_a_Reality_-_Niklas_Laxstr%C3%B6m_and_Claus_Christensen.ogv
18:07:22 <papoteur> My passage was like a comet. I must leave :/
18:07:25 <papoteur> Bye
18:07:41 <yurchor> papoteur: Bye.
18:08:16 <marja> ouch, that was too fast
18:09:10 * marja suggests that everyone watches the video after the meeting (it takes half an hour)
18:09:41 <lebarhon> no sound, is that normal ?
18:09:52 <marja> Kernewes: if you have problems getting the duplicate pages fixed, please ping me
18:09:56 <marja> lebarhon: I have sound
18:09:59 <Kernewes> marja: thank you
18:10:35 <lebarhon> another codecs problem
18:10:38 <marja> lebarhon: Mga 2, though (I vaguely remember some report about a sound issue in 3)
18:10:50 <lebarhon> I have Mageia é
18:10:59 <lebarhon> *é / 2
18:11:07 <marja> lebarhon: ah, same as here
18:11:34 <yurchor> Mageia 3 and I can here the sound.
18:11:37 <grenoya> sorry, i must go
18:11:44 <yurchor> grenoya: Bye.
18:11:45 <marja> grenoya: have a nice evening
18:11:45 <grenoya> have a good end of meeting :)
18:12:11 <marja> lebarhon: ah, I have tainted enabled on this machine
18:12:30 <lebarhon> So I have
18:12:44 <lebarhon> I will see thet later on
18:13:08 <marja> lebarhon: good luck!
18:13:22 <marja> do we have more on this topic (our wiki) ?
18:13:35 <Kernewes> I'll have to watch the video some other time
18:13:37 <lebarhon> Anyway, I can't understand English spoken by English people :)
18:13:49 <marja> lebarhon: he isn't English ;-)
18:14:01 <lebarhon> Hourra !
18:14:33 <marja> lebarhon: but you can read the presentation :-)
18:14:53 <lebarhon> sure
18:15:06 <marja> #topic Invisible search buttons in WebHelp
18:15:51 <marja> #info for many translations the search button was invisible because of an empty translation of the word "Search"
18:16:05 <marja> #it is OK in MCC help now
18:16:08 <marja> oops
18:16:18 <marja> #info it is OK in MCC help now
18:17:27 <marja> upstream didn't have the translations of "Search" and more related strings for many languages
18:18:07 <marja> I posted the needed strings on i18n-discuss, if you feel like translating them for your language, please don't hesitate
18:18:30 <marja> for French, "Search" was translated, but some other strings aren't
18:19:39 <marja> #info when we have the correct translations, we can ask camil to add them to Calenco.. we don't have access to the calenco files that need to be changed
18:21:47 <Nikerabbit> marja: was your question answered?
18:22:54 <marja> Nikerabbit: yes it was, thanks :-D
18:23:08 <marja> camil: are you around?
18:24:44 <Nikerabbit> good
18:25:24 <marja> #info it would be nice if the installer webhelp on doc.mageia.org could be fixed in a similar way as MCC help, because it'll take time before any upstream improvements will reach us
18:25:52 <marja> Nikerabbit: sysadmin team is now planning on updating the wiki :-)
18:26:27 <Nemo_bis> yayyyyyyy
18:26:33 <Nikerabbit> let me know if I can help
18:26:36 <marja> Nemo_bis: :)
18:27:22 <marja> Nikerabbit: thx, we will :)
18:28:09 <marja> #info Nikerabbit (translate-extension developer) offers to help with the wiki update
18:29:47 <marja> is there anything else on the empty search tab topic?
18:30:54 <marja> #topic anything else?
18:31:03 <marja> about anything ;-)
18:31:09 <yurchor> no.
18:31:37 <Kernewes> no
18:31:46 <marja> #endmeeting