17:01:53 <marja> #startmeeting
17:01:53 <Inigo_Montoya`> Meeting started Mon Jun  3 17:01:53 2013 UTC.  The chair is marja. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:53 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:02:07 <marja> #chair lebarhon yurchor
17:02:07 <Inigo_Montoya`> Current chairs: lebarhon marja yurchor
17:02:28 <marja> does anyone need to leave soon?
17:02:50 <lebarhon> about one hour
17:03:12 <marja> OK, let's start with the SVN + po topic, then
17:03:29 <marja> #topic shifting to SVN + po for docteam translations
17:04:07 <marja> #info on the doc-discuss and i18n-discuss everyone except one person seemed in favour of the change
17:04:33 <marja> lebarhon: IIUC, you were the only one to be reluctant
17:04:46 <marja> lebarhon: did you find time to inquire further?
17:05:01 <marja> #undo
17:05:01 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Info object at 0x849992c>
17:05:09 <lebarhon> Where did you see that ?
17:05:13 <marja> #info on the doc-discuss and i18n-discuss mailing lists everyone except one person seemed in favour of the change
17:05:32 <marja> lebarhon: on one of the mailing lists... but maybe I misunderstood?
17:05:57 <lebarhon> I said I needed a how to and that it was worth a try
17:06:22 <lebarhon> so I am waiting for the How tio
17:07:44 <marja> lebarhon: ah, yurchor offered to do that :-)
17:07:56 <marja> yurchor: do you have an ETA for the how to?
17:08:43 <yurchor> Oops.. Some kind of misunderstanding... Where do you want me to put it and what do you want to know?
17:09:26 <lebarhon> I want to know everything
17:09:46 <lebarhon> what is a ;po file, a .lang file, and so on
17:09:55 <marja> yurchor: in the wiki, with docteam and i18n category
17:10:43 <yurchor> Ok. Not that I feel to write a book but I will try.
17:11:14 <yurchor> BTW Info about what is PO can be found in Wikipedia. ;)
17:11:15 <lebarhon> Everyone said it was a very simple process...
17:11:24 <marja> yurchor: and apart from what lebarhon mentioned, if you don't mind, please add the instructions you put on the ml before to make a po file for an existing translation (I can copy + paste those instructions too, of course)
17:11:50 <yurchor> marja: Ok.
17:12:17 <lebarhon> yurchor: write what you want and if necessary, I will ask
17:12:27 <marja> lebarhon: it is simple once the .po files are there, what complicates it, is when there are already existing translations
17:12:56 <yurchor> I've already start to write a page about Lokalize usage, but I will switch to this as it is important.
17:12:59 <marja> lebarhon: but yurchor has a solution for that too
17:13:07 <marja> yurchor: thx a lot!!
17:13:48 <marja> #action yurchor will write a how to for docteam translators who shift to translating with SVN + po
17:15:02 <yurchor> I've written the similar pages in Ukrainian so it only takes to translate them. ;)
17:15:08 <marja> lebarhon: I suppose you prefer to have the decision (about making this translation method obligatory) postponed ?
17:15:09 <lebarhon> for example, I don't know what to do with this http://www.mageia.org/langs/report.php
17:15:12 <[mbot> [ www.mageia.org translation report ]
17:15:56 <marja> lebarhon: that is about the translations of the website
17:16:04 <yurchor> There is a link on top of the table: https://wiki.mageia.org/en/Internationalisation_Team_(i18n)#Website_translation
17:16:07 <yurchor> ;)
17:16:14 <lebarhon> No problem, it can be mandatory, I think I can adapt
17:16:40 <lebarhon> Moreover, we have time for Mageia 4
17:16:51 <yurchor> Just ask and we will share the most information we can as fast as we can. ;)
17:17:38 <marja> lebarhon: in that case, I'd like to make it mandatory... everybody who knows both methods was very much in favour
17:18:05 <marja> lebarhon: so if you don't object, I'll make that an #agreed
17:18:28 <lebarhon> Ok
17:19:15 <yurchor> lebarhon: There is no mandatory workflow (and will never be). There is effective and not effective workflow at the personal level.
17:20:05 <lebarhon> It's more simple if everybody acts the same way
17:20:40 <marja> yurchor: so you're against making it mandatory (/me is afraid of a mess for some translations)
17:21:25 <marja> yurchor: I was against making it mandatory if I could lose lebarhon or another important contributor by it
17:22:07 <marja> yurchor: but now that we don't seem to lose anyone important, I think the benefits will be much greater than the cons
17:22:13 <yurchor> No need to press on the people. Everybody has his/her habits. Something that is convenient to me can be inconvenient to other, but always worth to try. ;)
17:23:00 <lebarhon> Since the Mageia beginning there was no need of French translation for the web pages, so I didn't spend much time about the process
17:23:36 <marja> yurchor: for languages like German, where we have many different people working on the files, I think it is impossible not to move to SVN + po
17:24:27 <marja> yurchor: especially because we've lost translators for whom our old workflow was a nightmare
17:25:20 <yurchor> That's what I tell. If currently they feel like they will not support the translation in the future, how can we make them to use the efficient toolset?
17:26:40 <marja> yurchor: currently, there is no good way to tell which strings need to be updated, the Calenco translate messages weren't implemented well enough yet, and currently they don't even work at all
17:27:51 <marja> yurchor: and tbh, even if I've been on top of the documentation all the time, even I'm not sure the Dutch translation is up-to-date
17:28:05 <yurchor> So we just have to tell the new translators use PO and fallback into docbook *only* if they cannot use gettext utilities.
17:28:31 <lebarhon> I also heard about a SVN replacement by GIT ? I just printed a book about SVN :(
17:28:40 <marja> yurchor: something along that line
17:28:58 <marja> lebarhon: I think GIT is meant in addition, not as replacement?
17:29:30 <yurchor> lebarhon: No need to learn something for translators. It is enough to know 3 commands.
17:29:42 <marja> papoteur: welcome
17:29:52 <yurchor> 1. Pull: svn up or git pull --rebase
17:30:04 <papoteur> Hello docteam !
17:30:12 <lebarhon> hello papoteur
17:30:20 <yurchor> 2. Commit: svn ci or git commit
17:30:32 <yurchor> 3. Push: git push
17:30:40 <yurchor> papoteur: Hi!
17:31:11 <papoteur> yurchor: Hi, you can continue
17:31:40 <yurchor> I've finished. :)
17:31:58 <lebarhon> yurchor: commands means something if we know how SVN works
17:32:05 <marja> papoteur: we haven't yet decided about making the SVN + po workflow obligatory, yurchor just suggested to allow the old method as fall back
17:32:37 <yurchor> It is not needed to learn how mobile phone works in details to use it. ;)
17:32:51 <marja> yurchor: true :)
17:33:17 <papoteur> marja: OK
17:33:43 <lebarhon> not in details, but if don't even know that people have a phone number ..
17:34:05 <lebarhon> *but if you don't..
17:34:21 <marja> what about deciding: "Docteam translations will be done with SVN + po, however, when needed an exception can be made"
17:34:39 <yurchor> lebarhon: Well... Use GUI. There are plenty of them with a good documentation.
17:36:21 <marja> lebarhon: I've asked things in #mageia-i18n because I'm doing some website translations now, and I received very good help
17:37:33 <marja> no objections and it covers what was said, so:
17:38:10 <marja> #agreed Docteam translations will be done with SVN + po, however, when needed an exception can be made
17:39:04 <marja> is there more on this topic?
17:40:07 <marja> or does anyone think I was wrong to set that #agreed?
17:40:17 <lebarhon> No, go on
17:41:14 <marja> #topic Proposal for wiki page on support of EPSON Perfection V370
17:42:00 <harms_> I suggest a re-name
17:42:10 <harms_> howto on getting Epson scanners work that dont work on Mageia.
17:42:25 <marja> harms_: OK
17:42:31 <marja> #undo
17:42:31 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Topic object at 0x842742c>
17:42:50 <marja> #topic howto on getting Epson scanners work that dont work on Mageia
17:43:17 <harms_> That is flexible, add new approaches as they come,
17:43:25 <harms_> start with what is available
17:44:42 <marja> harms_: maybe you should be chair, I honestly don't know much about scanners, only that one should look whether the SANE project supports them
17:44:55 <marja> harms_: maybe you should lead the meeting now ;)
17:45:04 <marja> #chair harms_
17:45:04 <Inigo_Montoya`> Current chairs: harms_ lebarhon marja yurchor
17:45:16 <harms_> never done this - well
17:45:43 <harms_> ( I know the problem, not about Epson)
17:46:06 <harms_> The problem is simple: there is a proposal for text on
17:46:20 <yurchor> This problem will be fixed in the next release of SANE: http://lists.alioth.debian.org/pipermail/sane-devel/2013-April/031232.html
17:46:21 <[mbot> [ [sane-devel] Scanner Epson V37 under Linux ]
17:46:31 <harms_> making a V370 work, and consensus that this is too specific
17:46:50 <harms_> and something on epson scanners is needed in general
17:47:03 <yurchor> Olaf is AVASYS engineer, developer of iscan.
17:47:47 <marja> harms_: not consensus ... I only proposed the link on a general page, because I wanted to appease the ones who think it is too specific
17:48:21 <harms_> sorry for the word consensus - many voices (including ml input)
17:48:22 <papoteur> The question that I retain is how to organize the documentation on this topic.
17:48:29 * marja thinks a wiki is not the same as official documentation, and we shouldn't be too strict
17:48:59 <papoteur> papoteur: I agree
17:49:21 <papoteur> s/papoteur/marja :)
17:49:25 <marja> papoteur: :-)
17:49:42 <harms_> be pragmatic: there are some known pieces on howto "fix it"
17:50:08 <harms_> practical nothing on "documenting" epson.
17:50:39 <papoteur> marja: I think your proposition is good: a general page on scanners and a specific page on V370
17:50:47 <harms_> suggestion: start with a fixit page
17:51:04 <yurchor> Please just put the release and package info at the top of the page to not confuse future Epson customers.
17:51:28 * gelb5 is late!
17:51:46 * simonnzg1 is late (and using the right ID)
17:52:06 <marja> yurchor: yes ... and probably also in which version of SANE it is fixed (as soon as that is known)
17:53:03 <yurchor> 1.0.24
17:53:09 <lebarhon> Should we have a Harware category ?
17:53:17 <lebarhon> *Hardware
17:53:19 <marja> yurchor: is it already in that version?
17:53:24 <marja> lebarhon: yes
17:53:32 <marja> harms_: sorry for interrupting you
17:53:53 <yurchor> marja: Git/master is for 1.0.24 release.
17:53:55 <harms_> hardware - or hardware specific software?
17:54:09 <marja> harms_: but yes, starting with a fixit page seems good
17:54:35 <harms_> I think there is some need to learn - fixit allows for that
17:54:42 <marja> harms_: is there a shorter name for that? (firmware doesn't really cover it, does it?)
17:54:56 <yurchor> harms_: Can it be general Hardware hub with specific subpages?
17:55:16 <simonnzg1> SIG_Hardware ??
17:55:34 <marja> simonnzg1: ah, sounds nice
17:55:41 <lebarhon> There won't be so much pages, I think hardware is enough
17:56:13 * marja thinks "hardware" is where more users will search
17:56:24 <papoteur> simonnzg1: no, for that don't sound :/
17:56:38 <harms_> how about hardware support (or the other way round)
17:56:46 <simonnzg1> I would hae written the page, called it [[Category:howtos]] and added it to a hardware category if/when we needed one...
17:56:55 <papoteur> marja: lebarhon yes, I agree
17:57:22 <harms_> Ok with me
17:57:43 <papoteur> simonnzg1: Yes, we are not limited to one category per page.
17:57:50 <marja> harms_: the support category could be added, too (I don't think we already have it)
17:57:57 <simonnzg1> The beuty of wiki is that we can move pages around easily.
17:58:33 <papoteur> harms_: your page is better as when I read it first.
17:58:42 <lebarhon> All wiki pages are support or Help, it doesn't mean much
17:58:45 <yurchor> simonnzg1: I thought that only admins can do movement... Is this right?
17:59:14 <simonnzg1> Changing pages, yes, changing categories is just a case of addign or removing it from the page source.
17:59:27 <simonnzg1> Changing page names.. I mean
17:59:33 <yurchor> simonnzg1: Aha... Thanks.
18:00:05 <papoteur> What about the title?
18:00:12 <marja> simonnzg1: yurchor: can't you move a page, then?
18:00:45 <simonnzg1> I can on my own wiki. I have a feeling we can rename a page as users, but not delete it... Not tried for a long time.
18:00:53 <yurchor> marja: Make a symlink, yes, real move - only admins.
18:01:06 <papoteur> "Epson V370 scanner" ?
18:01:22 <lebarhon> or only Scanner
18:01:33 <harms_> Page name: I will draft an alternative in my user space with an alternative name
18:01:46 <harms_> that can be discussed before it is linked into the wiki
18:01:50 <simonnzg1> Yes, I can move a page, which means renaming it.
18:01:54 <yurchor> The full name is Epson Perfection V370 Photo
18:02:06 <yurchor> It's V37 with a slide module.
18:03:33 <harms_> suspend this issue until I have produce and alternative
18:03:46 <harms_> somewhat more general than only v370?
18:04:05 <papoteur> harms_: OK, we wait for your proposition. The change for the title is not simple, thus it's better to go fine at the first shot.
18:04:10 <yurchor> Sure. Your instructions work for V37 too.
18:04:39 <simonnzg1> I have a V1250 photo.  I wonder if it has the same engine/problems?  Never tried it with Mageia, or Linux, actually.
18:05:15 * marja wonders whether a wildcard is allowed in a titel
18:05:22 <harms_> I saw problems with v1250, I have a v1260 tjat works
18:05:32 <papoteur> Thus, this is a family, not just a product.
18:05:34 <simonnzg1> marja: No, ;-)
18:05:40 <yurchor> simonnzg1: No. It's a different chip.
18:05:57 <simonnzg1> harms_: Maybe I should try with it.  I'm not even sure it still works.
18:05:57 <yurchor> simonnzg1: V1250 works out of box.
18:06:04 <marja> papoteur: how is the family called?
18:06:16 <simonnzg1> yurchor: Pity. In a way it would be better if it didn't!
18:06:46 <papoteur> marja: I do not know :/
18:06:59 <marja> maybe Epson V37 family
18:07:31 <papoteur> marja: with scanner somewhere
18:07:56 <yurchor> simonnzg1: Oops, I was wrong... It does not work. It needs iscan driver. So the same procedure as Juergen proposed.
18:08:14 <simonnzg1> yurchor: A winter project for me,then ;-)
18:08:52 <harms_> I really suggest to produce alternative text + titles in my user space.
18:09:04 <papoteur> I think it is better to have a generic page, and page name, which can be completed according to what is discovered.
18:09:11 <harms_> Than you can look a them, and the discussion will be focused
18:09:28 <lebarhon> papoteur: I agree
18:09:31 <papoteur> simonnzg1: yes, for this week ;)
18:09:46 <lebarhon> It was like that in the Mandriva wiki
18:09:53 <harms_> sure
18:10:15 <papoteur> lebarhon: have you a link?
18:10:42 <simonnzg1> How about starting with a procedure for a specific model. If other models need that procedure, put the procedure in a generic page, write a table of model numbers and link to it.
18:10:47 <lebarhon> papoteur: http://wiki.mandriva.com/fr/
18:11:03 <simonnzg1> t's all cut-and-paste.
18:11:34 <papoteur> I found http://wiki.mandriva.com/en/Docs/Hardware/Scanners
18:12:12 <harms_> will have a look at that before I go further.
18:12:17 <yurchor> The list of the models can be taken for epkowa backend here: http://www.sane-project.org/sane-mfgs.html#Z-EPSON
18:12:18 <[mbot> [ SANE: Supported Devices ]
18:12:46 <yurchor> They all has a comment "supported by the epkowa backend plus non-free interpreter"
18:13:00 <marja> and then, since we don't nest pages, there could be a "Scanners" page with the Hardware category, as decided before
18:13:10 <papoteur> I must stop a little...
18:13:29 <marja> yurchor: but I didn't find the V37 in it (or I didn't look good :-/ )
18:13:45 <marja> papoteur: have a nice evening
18:13:54 <yurchor> marja: The list is too old.
18:14:07 <harms_> I think I now have enough material for my next step
18:14:07 <marja> yurchor: ouch
18:14:15 <marja> harms_: great :)
18:14:48 <harms_> am I supposed to close this topic?
18:14:59 <marja> harms_: you can give yourself an #action :-D
18:15:24 <marja> just start a line with #action and say what harms_ is going to do ;-)
18:15:39 <harms_> action harms will draft alternatives for epson doc in his users space
18:15:55 <marja> harms_: add the "#", please :-)
18:16:07 <harms_> #action harms will draft alternatives for epson doc in his users space
18:16:11 <harms_> #action harms will draft alternatives for epson doc in his users space
18:16:19 <marja> harms_: great, thx :)
18:16:30 <yurchor> harms_: Thanks.
18:16:46 <marja> is there anything else for this meeting?
18:17:34 <harms_> where will I find the minutes of this meeting?
18:17:58 <marja> harms_: in meetbot.mageia.org, but you'll see a link when this meeting is ended
18:18:09 <harms_> thanks
18:18:17 <lebarhon> if nothing more, I am leaving. Good night everyone
18:18:29 <marja> thanks all for having contributed to this meeting
18:18:33 <marja> #endmeeting