18:00:54 <marja> #startmeeting
18:00:54 <Inigo_Montoya> Meeting started Mon Mar  4 18:00:54 2013 UTC.  The chair is marja. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:54 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:01 <marja> diogenese: hi :)
18:01:20 <marja> diogenese: I hope your font will be included in Mageia 3 :)
18:01:36 <marja> #topic the actions of last week
18:01:41 <diogenese> :)
18:02:49 <marja> #info the docteam portal has been started
18:02:51 <marja> https://wiki.mageia.org/en/Documentation_Team_Portal
18:03:02 <marja> it looks nice, but isn't finished yet
18:03:18 <Kernewes> good start though
18:03:30 <marja> lebarhon: I think you said something about the two right lists being too much the same
18:03:43 <lebarhon> it's right
18:04:04 <Kernewes> there is some repetition, certainly
18:04:10 <marja> lebarhon: I forgot what you suggested ... merging them, but then
18:04:37 <marja> lebarhon: using one box for a list for new comers, with links to easy things?
18:04:39 <lebarhon> Merge them to have place for the tools
18:04:51 <marja> lebarhon: ah, thx
18:05:15 <marja> lebarhon: you want the tools list to be split?
18:06:34 <lebarhon_> I missed something :(
18:06:58 <marja> lebarhon: I asked whether you wanted the tools list to be split
18:07:13 <marja> lebarhon: one list for wiki tools, and one for Calenco ?
18:07:18 <lebarhon_> No, iit was just an idea to have
18:07:34 <lebarhon_> doc, work, tools and contact
18:08:29 <marja> lebarhon: currently, the list for Doc Team Toolbox is the longest
18:08:53 <marja> yurchor: hi, welcome in the meeting
18:09:13 <yurchor> Hi all :)
18:09:22 <Kernewes> yurchor: hi
18:09:27 * marja thinks the best solution will be easier to see once we have improved our pages
18:10:01 <marja> doesn anyone have anything else on the portal?
18:10:11 <Kernewes> no
18:10:17 <lebarhon_> Some background color may be
18:10:37 <Kernewes> not sure
18:10:59 <marja> lebarhon_: I think simonnzg wanted it to stick out in some way, I think a background colour could do that
18:11:22 <Kernewes> it would have to be very light
18:11:25 <marja> even if I'd go for a light (pastel) color
18:11:27 <marja> yes
18:12:00 <marja> lebarhon_: feel free to experiment with a colour :)
18:12:03 <diogenese> Very slight shades work well on formal documents.
18:12:19 <marja> diogenese: yes, you're right
18:12:22 <Kernewes> best way is to try something and see how we like it
18:12:39 <marja> lebarhon_: can I put that in an action for you?
18:12:56 <marja> lebarhon_: or do you prefer to leave that to someone else :)
18:13:05 <lebarhon_> To add colours, why not
18:13:47 <lebarhon_> whoever want to do it
18:13:47 <marja> #action lebarhon_ add light colours to our team portal, and ask on the ml for feedback
18:14:21 <marja> lebarhon_: so you want me to undo the action? ti seems I misunderstood
18:14:47 <lebarhon_> No you can let it
18:14:51 <marja> lebarhon_: thx :)
18:15:04 <marja> about the other actions of last week
18:16:05 <marja> #info marja did not yet ask camil about the notifications she thinks JohnR gets about all changes in Calenco
18:16:35 <marja> #action marja ask camil about the notifications about *all* calenco changes
18:17:15 <marja> #info marja did write the ml about the extra meeting on Saturday, but then forgot to be there herself
18:17:41 <lebarhon_> :)
18:17:42 <marja> #info ajunior did not propose a new time
18:18:14 * marja thinks there weren't really new people around, apart from ajunior
18:19:32 <marja> #info adding the original-revision tag might be too complicated for people not used to calenco, for translations that are very outdated
18:20:15 <marja> the last item leads to the next topic... but before that, does anyone have anything else on last week's todos?
18:20:27 <Kernewes> no
18:20:59 <marja> #topic finding translators
18:22:07 <marja> #info obgr_seneca gave a lot of room to our team in last i18n meeting, to help give translators a better understanding of what needs to be done
18:23:04 <marja> #info our translations report page has been updated a little, but is not ready yet
18:23:11 <marja> #link https://wiki.mageia.org/en/Calenco_translations_report
18:25:02 * marja considers adding the original-revision tags for languages that weren't touched by a translator for a while, maybe getting the diffs will help to find people daring to start on those files
18:26:12 <marja> and we need to add a table for MCC translations
18:26:34 <yurchor> That's a *huge* work...
18:26:48 <marja> #info camil is working on something in Calenco that will auto-generate such reports
18:26:55 <marja> yurchor: it is :/
18:28:19 <Kernewes> so does the orange mean stuff that needs doing?
18:28:34 <marja> yurchor: well, for the translations that are kept up-to-date, like ukrainian, it isn't badly needed
18:28:57 <marja> yurchor: but for the not up-to-date ones it is
18:29:11 <marja> Kernewes: that the file is not translated at all
18:29:20 <Kernewes> ok
18:29:44 <yurchor> Sure. I just think that until automatic generation is ready, these lists are not of high priority...
18:30:13 <marja9> our tr
18:30:17 <marja> Kernewes: and in the colored bars, orange means: not one page translated
18:30:44 <marja> Kernewes: yellow there means: too many pages not translated (like for Swedish)
18:30:53 <shaunm> are you guys translating entire xml files at a time, not segmenting with something like xliff or po files?
18:30:55 <yurchor> Documentation team time is precious. Please do not get waste it for the things that can be done by the translation teams themseves.
18:31:30 <yurchor> shaunm: I do, but other teams are not...
18:31:37 <marja> shaunm: when a file is first translated, it is the entire file
18:31:41 <yurchor> *do not
18:32:26 <marja> shaunm: and for the updates/changed strings in it, yurchor's method worked well from the beginning
18:33:42 <marja> shaunm: but for all translators who disappeared, we don't really know until which version from the original file the translations were updated
18:34:37 * marja thinks the original-version tags should be set conservatively
18:34:39 <yurchor> marja: This can be guessed by dates.
18:35:22 <marja> yurchor: for the original import that is true (except for Swedish)
18:35:54 <marja> yurchor: I'm not very sure after that all changes in to the translated files reflected changes in the original one
18:36:29 <marja> yurchor: for German, for instance, a lot of people have been language proofreading
18:36:54 <marja> yurchor: and I doubt they all checked against the original en file
18:38:00 <marja> yurchor: and then there are the new files I made from parts of other files
18:38:15 <yurchor> Oops... Ok. Then it will be reasonable to think that the translators know what they are doing. If they are not... It's bad for this language.
18:38:57 <marja> yurchor: I wish all translators had sticked around as well as you :)
18:40:52 <marja> yurchor: do you see anything that could be done to make it easier for a translator to start on a not-well-updated translation of installer help, without us spilling too much energy?
18:42:54 <marja> lebarhon_: do you have the impression installer help has been updated well for French (even if it doesn't show in the table)?
18:43:00 <yurchor> The file are really small. If the formatting is kept (e.g. using text editor autoformatting like in Kate), it is not hard to update the translation.
18:43:17 <yurchor> Regardless to it's current state.
18:43:31 <lebarhon_> marja: I didn't work at all on theses files
18:43:59 <marja> lebarhon_: np .... and thx for working on MCC translations :)
18:44:00 <lebarhon_> I think we could have a look when the english files are ready
18:44:45 <marja> lebarhon_: for installer help, most are ready, there is only the partition-alignment issue, and of course, GRUB2
18:45:54 <lebarhon_> I almost end up with MCC, I can have a lookon the installer and add the tags
18:46:19 <lebarhon_> Promise me not to modify them :)
18:46:19 <marja> lebarhon_: btw, when I start gparted, it looks different than described in disdrake.xml :/
18:46:30 <marja> lebarhon_: thx a lot
18:47:18 <lebarhon_> Could we add "frozen" on the wiki table ?
18:47:27 <marja> lebarhon_: if you want, there is an e-mail address you can share between translators (I can give you the logins), i18n-fr@mageia.eu (not a ml)
18:48:00 <marja> lebarhon_: yes, for all files, except for bootloader ones and diskdrake
18:48:03 <lebarhon_> Why not use the ML ?
18:48:55 <marja> lebarhon_: because the translate notifications are repeated every night, if the translation wasn't fixed (or if someone changed the original without bumping version)
18:49:26 <lebarhon_> that means yet another mailbox!
18:49:45 <marja> lebarhon_: and moreover, I didn't manage to get a reply to my question whether the bot that sends those mails, could be whitelisted for the mls
18:50:24 <marja> lebarhon_: I don't know of a way to make a mailing bot a member of a ml, other than a sysadmin allowing it
18:51:46 <marja> lebarhon_: I don't mind forwarding those mails to you
18:52:14 <lebarhon_> Do you think I need them ?
18:52:53 <marja> lebarhon_: Not if someone else keeps an eye on them
18:53:25 <lebarhon_> There is something I don't understand, I receive the bot messages
18:54:00 <marja> besides, once all translations are up-to-date, the original diffs will be the same for all languages
18:54:36 <marja> lebarhon_: do you already receive them? so you put your e-mail address in the <othercredit> part?
18:54:55 <lebarhon_> Yes, why not
18:55:08 <marja> lebarhon_: that is how the bot found you :)
18:56:02 <marja> lebarhon_: btw, we haven't found a way yet to remove name + e-mail address before packaging MCC help (for inline installer help there is no problem)
18:56:48 <marja> lebarhon_: for that reason, I replaced my name with  a space, and I use i18n-nl@mageia.eu for the Dutch translations
18:57:11 <lebarhon_> I can delete them mysellf when you say you are ready to package
18:58:09 <lebarhon_> There is already so many ML, adresses and forum tha I spend more time to reas them than to work for Mageia
18:58:26 <marja> lebarhon_: or use the other address... it might even attract translators, when they see an i18n-fr mail address
18:58:46 <marja> pasmatt: hi :)
18:59:40 <pasmatt> marja: hi
19:00:07 <marja> pasmatt: I know you're busy... but should someone ping about the mageia-doc package?
19:00:20 <marja> pasmatt: I mean, ping tmb or so?
19:01:39 <pasmatt> I was thinking to ping someon from sysadm team because I'm still not able to upload the mageia-doc srpm :-/
19:02:05 <marja> pasmatt: i think pinging tmb (when he's around) would be best
19:02:16 <Kernewes> simonnzg: hi
19:02:16 <diogenese> He just came into #mageia
19:02:32 <marja> pasmatt: and maybe he knows what should go in svn/soft
19:03:06 <marja> pasmatt: something should go there, because we'll be our own upstream for it, just like with drakx-installer-help
19:03:32 <pasmatt> yeap, exactly :)  As you already suggested, we need to import the documentation into the svn to be able to version it
19:04:02 <marja> pasmatt: oops. sorry for repeating myself (I'm starting to be really old :-/ )
19:04:09 <pasmatt> no no, don't worry
19:04:15 <marja> pasmatt: thx :)
19:04:29 <pasmatt> I was just thinking loud :)
19:04:49 <marja> pasmatt: do you think you'll find a way to remove the person names and e-mail addresses?
19:04:56 <marja> pasmatt: auto-remove
19:06:45 <marja> pasmatt: we didn't find a way to do it in Calenco, even if it should be possible with correct setting for the used .xsl file :(
19:08:15 <marja> lebarhon_: I don't think manually removing each time it gets packaged, and then adding it back again, will be an easy solution
19:09:07 <pasmatt> yes I think I can find a way to resolve that "issue" but I would postpone it (i.e. once we have properly imported the documentation and the srpm into the svn repo)
19:09:07 <lebarhon_> Only a very few will be added back again, I hope
19:09:49 <marja> pasmatt: yes, you're right, it deosn't have the highest priority
19:10:13 <marja> lebarhon_: well, the translate notifications don't work without e-mail address
19:11:06 <marja> lebarhon_: and at least a space instead of a name is needed (else the e-mail address will be printed too bold)
19:11:07 <lebarhon_> Marja: I don't follow you
19:12:00 <pasmatt> marja: I had no time to investigate it deeply but if we have a specific field to search for into the documentation sources, I can write for sure some script to wipe it out automatically
19:12:33 <marja> lebarhon_: languages like German really need the translate notifications
19:12:46 <marja> pasmatt: great :)
19:13:28 <marja> lebarhon_: you and papoteur are around all the time, you know what happens, so if you don't want those notifications: fine
19:14:20 <pasmatt> fine, let me eat something then I'll ping (kindly) sysadm for the mageia-doc pkg issue ;-)
19:14:26 <marja> lebarhon_: but for translations for which the translators come and go, I don't see how we can do without them
19:14:36 <marja> pasmatt: perfect :)
19:16:25 <marja> lebarhon_: can you follow me now, or are you still puzzled?
19:17:00 <lebarhon_> I try to guess what you are saying
19:17:09 <marja> lebarhon_: lol
19:17:18 <lebarhon_> I have no problem with notifications
19:17:47 <marja> lebarhon_: I responded to what you said here 2013:03:04:20:09 < lebarhon_> Only a very few will be added back again, I hope
19:18:06 <marja> lebarhon_: maybe I misunderstood you
19:18:25 <lebarhon_> Yes, I hope we won't rewrite all the help for each new mageia release
19:19:10 <lebarhon_> Today we have about 60 xml files for the MCC
19:19:11 <marja> lebarhon_: no, surely not all, but a sentence can be rephrased
19:19:32 <marja> lebarhon_: I think there can be small changes
19:19:49 <marja> lebarhon_: like an extra screenshot to make something more clear
19:20:07 <lebarhon_> we can follow the english files that will be modified
19:20:45 <marja> lebarhon_: yes, once the files are up to date, in fact only for one translation the diffs are needed
19:20:58 <lebarhon_> and I think, in the future we don't have any more the English writing/modifying and translating at the same time
19:21:01 <marja> they can then be shared with all translations
19:21:27 <marja> lebarhon_: that would be great :)
19:21:46 <lebarhon_> it's our goal ? No
19:21:55 <marja> lebarhon_: it sure is!!
19:22:38 * marja is there more on this topic?
19:22:56 <lebarhon_> dune received his credentials but they don't work
19:23:32 <lebarhon_> he wanted proofread the installer and MCC help files
19:23:38 <marja> did you try with his own e-mail address as login name?
19:23:49 <lebarhon_> Yes, I confirm
19:24:03 <marja> lebarhon_: ouch
19:24:28 <marja> lebarhon_: camil isn't around :/
19:25:03 <marja> lebarhon_: did you paste the password, or type it? (tmb had a problem with pasting a password somewhere today)
19:25:20 <lebarhon_> I copied it
19:25:42 <lebarhon_> I typed it
19:26:09 <marja> lebarhon_: OK, so no invisible spaces were added
19:26:26 <lebarhon_> I don't think so
19:26:48 <marja> lebarhon_: we'll have to wait for camil
19:26:54 <lebarhon_> OK
19:28:44 <marja> lebarhon_: but I'm very glad wiht dune's help.. I hope he can start soon
19:29:01 <marja> #topic anything else?
19:29:15 <marja> ah, I forgot
19:29:16 <lebarhon_> We need him now, before the Mageia 3 release
19:29:26 <marja> yes, we do
19:30:58 <marja> can we end the meeting?
19:31:38 <lebarhon_> Yes for me
19:31:41 <Kernewes> yes
19:32:08 <marja> #endmeeting