18:05:23 <marja> #startmeeting
18:05:23 <Inigo_Montoya> Meeting started Tue Jul  3 18:05:23 2012 UTC.  The chair is marja. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:05:23 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:05:27 <marja> Kernewes: no :)
18:05:28 <sebsebseb> hi
18:05:37 <marja> #chair obgr_seneca
18:05:37 <Inigo_Montoya> Current chairs: marja obgr_seneca
18:05:38 <sebsebseb> oh Kernewes is here :)
18:05:44 <marja> #chair grenoya
18:05:44 <Inigo_Montoya> Current chairs: grenoya marja obgr_seneca
18:05:56 <obgr_seneca> I see some new faces, hi there
18:06:02 <marja> #topic the wiki translate extension
18:06:09 <Kernewes> obgr_seneca: for one week only, can't usually make it
18:06:25 <obgr_seneca> Kernewes: sad to here that
18:06:26 <marja> obgr_seneca: do you want to do this part of the meeting?
18:06:35 <obgr_seneca> ok
18:07:09 <obgr_seneca> if I remember correctly, Nikerabbit is upstream developer of the extension?
18:07:23 <marja> obgr_seneca: yes
18:07:29 <Nikerabbit> yup
18:07:49 <obgr_seneca> ok first, we have two options for the wiki translation
18:08:10 <obgr_seneca> first: do it like mdv and wikipedia with single wikis and translating manually
18:08:21 <obgr_seneca> second: use the translation extension
18:08:24 <Nikerabbit> what is mdv?
18:08:30 <obgr_seneca> Mandriva
18:08:52 <Nikerabbit> ok
18:09:22 <obgr_seneca> If I understand correctly, we can "mark" pages as "translatable" and others as non translatable using the extension?
18:09:49 <Nikerabbit> obgr_seneca: you don't need to do anything special to pages you don't want to translate
18:10:10 <Nikerabbit> for the pages you do, there are some steps how it is done
18:10:14 <obgr_seneca> and we can add pages to say the German wiki, that are not on the English one?
18:11:02 <Nikerabbit> if you are using Translate extension, everything would be inside single wiki
18:12:08 <marja> Nikerabbit: do you consider our /de/ and /en/ wikis to be two wikis or a single wiki?
18:12:22 <obgr_seneca> could we still have wiki.mageia.org/en/ wiki.mageia.org/de/ and so on or would all be in the same url?
18:12:22 <Nikerabbit> marja: do you have link?
18:12:42 <marja> Nikerabbit: the ones of obgr_seneca ^^^
18:12:52 <obgr_seneca> Nikerabbit: at the moment, they use the same code, but different databases
18:13:39 <Nikerabbit> yes, those would be separate wikies
18:14:09 <Nikerabbit> Translate doesn't support that (if you are really fond of the url scheme you can keep that however)
18:14:19 <obgr_seneca> ok
18:14:54 <obgr_seneca> so is there a way to transform our existing wiki to one using the translate extension? at least the English one?
18:15:29 <Nikerabbit> obgr_seneca: yes, but it needs manual work, the amount depending on how many pages and existing translations there are
18:15:52 <obgr_seneca> ok
18:16:01 <marja> for the German pages, we have Workaholic :-D
18:16:16 <Workaholic> majr: 121
18:16:35 <marja> Workaholic: you're not afraid of manual work on the wiki, are you?
18:16:51 <obgr_seneca> Actually, if the translate extension does simplify life for the translators (which I asume it does) and if it does allow us to keep the English wiki as basis
18:17:16 <obgr_seneca> And if it does allow us to keep our url scheme, I would be in favour of it
18:17:22 * marja too
18:17:41 <Workaholic> marja; no, I have time enough :)
18:17:45 <Nikerabbit> the major point of Translate extension is that it keeps track of changes, so that users and translators know what is out of date
18:17:59 <Nikerabbit> in addition it comes with nice web based translation interface
18:18:00 <obgr_seneca> yep, I understood that much
18:18:11 <obgr_seneca> and it's a very important point for the translators
18:18:21 <marja> #info Translate extension keeps track of changes, so that users and translators know what is out of date
18:18:42 <obgr_seneca> #info Translate extension does allow us to keep our url scheme
18:19:06 <obgr_seneca> #info transforming the existing wiki into one using the extension does need some manual work
18:19:10 <Nikerabbit> I expect that there will be users who do not want to use the web interface... for that there is possibility to download the page in Gettext format, translate offline and send them back
18:19:13 <marja> #link http://docteam.mageia.nl/translate/language_stats.png  <---- example
18:19:35 <Nikerabbit> but I recommend working with the web interface
18:19:38 <marja> #link http://docteam.mageia.nl/translate/messages.png <---- another example
18:19:40 <obgr_seneca> Nikerabbit: that's very good because it does allow translators to use known tools
18:20:53 <obgr_seneca> Nikerabbit: would you be available to discuss the technical side with me? about setting it up and about how to transform the existing English wiki?
18:21:17 <Kernewes> Would using the Translate extension for the wiki free up people's time to work on the official documentation?
18:21:26 <Kernewes> Or are there different people working on those?
18:21:42 <Nikerabbit> obgr_seneca: yes, but we need to find slot for that
18:21:46 <marja> Kernewes: no, many people work on both
18:21:51 <obgr_seneca> Kernewes: it's more something making it easier for the translators
18:22:01 <Kernewes> I see
18:22:05 <obgr_seneca> Nikerabbit: I'm sure we can find some time
18:22:50 <obgr_seneca> Kernewes: and it would give us some means to keep the wiki documentation in sync in the different languages
18:22:58 <obgr_seneca> something that did never work at Mdv
18:23:02 <Kernewes> yes I can see that
18:23:42 <obgr_seneca> ok, are there any comments? from other people?
18:24:00 <marja> I already said I'm for having the extension
18:24:09 <obgr_seneca> marja: yep I saw
18:24:18 <marja> and on the ml I remember dglent was all for it
18:24:22 <obgr_seneca> yurchor: here?
18:24:29 <yurchor> yes.
18:24:43 <obgr_seneca> you do work on kde wiki as well?
18:24:54 <obgr_seneca> So you could be of help to us?
18:25:11 <yurchor> Yes, I am.
18:25:23 <marja> Nikerabbit: are you still there?
18:25:27 <Nikerabbit> yup
18:25:30 <obgr_seneca> great!
18:25:30 <yurchor> What kind of help is needed?
18:25:55 <marja> Nikerabbit: sometimes there is French documentation, that doesn't exist in English yet
18:26:25 <marja> Nikerabbit: is it possible to change the "first" language of a document?
18:26:49 <obgr_seneca> yurchor: I will work on the setup with Nikerabbit, since you know how to work with it, you could sum it up for i18n team in next meeting?
18:27:13 <yurchor> obgr_seneca:  Yes, sure.
18:27:13 <Nikerabbit> marja: we've been working towards that (it needs changes in MediaWiki and Translate), but we are still missing some pieces like ability to specify the language
18:27:32 <marja> Nikerabbit: np, nice that you've been working on it
18:28:05 <marja> Nikerabbit: of course I hope you'll find a way to do it ;)
18:28:07 <obgr_seneca> So we could use some "staging wiki" for those foreign language  texts until someone translates them into English
18:28:50 <marja> obgr_seneca: until now the pages were sometime imported in French into the EN wiki, and translated there
18:29:09 <yurchor> obgr_seneca: What if just add the to Category:Needs_Translation and keep in one wiki?
18:29:18 <obgr_seneca> Nikerabbit: at the moment we are having a 1.16.x mediawiki, do you recommend upgrading it to 1.19.x (aside from the usual reasons)?
18:29:21 <marja> yurchor: sounds good
18:29:29 <obgr_seneca> yurchor: we could create some template for that
18:30:07 <Nikerabbit> obgr_seneca: yes I do, Translate supports development version + one or two latest stable versions
18:30:20 <obgr_seneca> I see
18:30:34 <obgr_seneca> I will have to work on the package upgrade then
18:30:52 <Nikerabbit> currently 1.18 is minimum
18:31:16 <obgr_seneca> I'm planing to upgrade the package soonest
18:31:27 <marja> obgr_seneca: great :)
18:31:27 <obgr_seneca> #action obgr_seneca work on mediawiki upgrade
18:31:35 <Nikerabbit> MediaWiki 1.19 has switched to git btw, if it matters
18:31:48 <obgr_seneca> #action obgr_seneca Nikerabbit find some time slot to work on the translate extension setup
18:31:54 <Nikerabbit> that's also delaying mediawiki upgrade on userbase a bit
18:32:14 <obgr_seneca> #info mediawiki has switched to git since 1.19
18:32:54 <obgr_seneca> ok, that's it from my place for now
18:33:02 <obgr_seneca> anything else on this topic?
18:33:51 <marja> not here
18:34:34 <Nikerabbit> do you have any idea about the time frame?
18:36:46 <obgr_seneca> Nikerabbit: let's say until beginning of august?
18:36:55 <obgr_seneca> If you have some time for me?
18:37:44 <Nikerabbit> Wikimania is next week, that's probably very busy. After that I have time
18:38:14 <obgr_seneca> ok
18:38:30 <obgr_seneca> #info Wikimania is next week, work on our wiki begins after it
18:39:04 <obgr_seneca> so, we can close this topic then?
18:39:15 <marja> yes
18:39:26 <obgr_seneca> ok, marja your turn then
18:39:33 <marja> thx obgr_seneca and Nikerabbit and all :)
18:39:41 <marja> #topic missing information about MCC (needed to make official help)
18:39:46 <marja__> the help files in Mdv MCC come from /usr/share/doc/mandriva/en/Drakxtools-Guide/Drakxtools-Guide.html
18:40:03 <obgr_seneca> marja: I'll be here, but reading up some stuff, just ping me
18:40:51 <marja> the tools in MCC are grouped, usually for every group only the relevant index page for that chapter is given
18:41:24 <marja> and for one group the links don't work
18:42:04 <marja> what I don't know yet, is whether our helpfiles are supposed to go in /usr/share/doc/mageia/en/Drakxtools-Guide/Drakxtools-Guide.html
18:42:44 <marja> blino couldn't tell anything about which help file names are expected......
18:43:37 <marja> He doesn't seem to think he'll have time to change tools
18:43:51 <marja> I'll write Thierry again
18:45:26 <marja> grenoya: obgr_senecado: I understand that the UiAbstraction4mcc feature proposal won't affect what we are doing, or am I wrong about that
18:45:38 <marja> ?
18:46:18 <grenoya> actually, i don't really understand what it is :/
18:46:44 <grenoya> i think it's about the graphical interface
18:47:28 <grenoya> but them, *maybe* the file format for the help will have to be different
18:47:31 <marja> boklm: am I correct to think that the UiAbstraction4mcc feature proposal won't affect how menu help is linked to help text?
18:47:36 <marja> grenoya: ouch
18:48:00 <grenoya> but as long as the tools are not touched, the text can be the same
18:48:34 <marja> grenoya: thx :)
18:48:38 <grenoya> just a reformatting, if necessary (and i hope scriptable)
18:49:12 <marja> grenoya: and I hope it can be generated from Calenco, if the file format changes
18:50:39 <marja> grenoya: are you willing to contact anaselli and tuxta2 about this?
18:51:08 <grenoya> marja: or we could expicitely ask the dev to respect the actual format (or one that can go out of calenco)
18:51:25 <marja> grenoya: that would be even better
18:51:34 <obgr_seneca> marja: grenoya: as I understand it, it will only affect the technical side, not the doc
18:51:54 <obgr_seneca> some xml based format should do
18:52:05 <grenoya> obgr_seneca: yes, but maybe the technical way to insert our texts :/
18:52:10 <obgr_seneca> you can do wonders using xslt, if you know how to do it
18:52:21 <marja> obgr_seneca:  atm it is html, but docbook xml would be OK, too
18:52:36 <obgr_seneca> you can do that xml file like a database and fetch the content in any format you like
18:52:56 <obgr_seneca> may need some clever scripting, but what do we have devs for :D
18:53:31 <grenoya> as i did not understand every thing about what they're doing, i may not be the good one to send a mail /o\
18:53:56 * obgr_seneca has to read those mails, I was not that much interested in the topic
18:54:37 <marja> grenoya: np, I can ask them....... and ask them to explain in a way that a non-developer understands :)
18:54:55 <obgr_seneca> :)
18:54:57 <grenoya> :)
18:55:23 <marja> #action marja ask anaselli and tuxta2 about the consequences of the UiAbstraction4mcc feature proposal for the help texts in MCC
18:56:20 <marja> #action marja ping thierry about whether the help files should have the same names and the same path as in Mdv, except s/mandriva/mageia/
18:56:49 <marja> do we have more about this topic?
18:58:08 <marja> apparently not :รพ
18:58:23 <marja> #topic needed improvements for existing online help
18:59:04 <grenoya> marja: what kind of online help are you talking about ?
18:59:10 <marja> we didn't add the licence yet
18:59:12 <grenoya> doc.mageia.org ?
18:59:39 <marja> grenoya: the one that is (going to go) there and that is in docteam.mageia.nl
18:59:51 <marja> it is possible to add a footer
19:00:06 <marja> but I haven't found time yet to really look into that
19:00:29 <marja> I'm just mentioning it to avoid forgetting it altoghether
19:00:39 <grenoya> so the licence has to be added also on the index.html ?
19:00:50 <grenoya> (when done /o\)
19:01:18 <marja> grenoya: is that easier... to do it there instead of in a footer for every page?
19:01:40 <grenoya> i think both at to be done
19:01:50 <marja> grenoya: and credits.... I think we should at least credit calenco
19:02:34 <grenoya> if you prepare me the text i add it
19:02:38 <marja> and well, maybe just use the same list as in the readme (and adjust per language)
19:03:12 <marja> grenoya: I'll mail the COPYING and READMEs to you :)
19:03:24 * grenoya is working on doc.mageia.org right now, but can't promise to finish before 15 of july
19:03:37 <grenoya> tanks :)
19:03:39 <marja> grenoya: don't work too hard!
19:03:53 * marja wonders whether that footer is still needed
19:04:02 <marja> not really, I guess
19:04:08 <grenoya> i'll be at FSM from friday to next friday
19:04:15 <marja> very good
19:04:26 <marja> grenoya: there's only you and Jehane?
19:04:55 <marja> grenoya: in Geneva, I mean
19:05:03 <grenoya> for the booth, it seems
19:05:06 <marja> ouch
19:05:21 <grenoya> and Nanar, but he promises nothing
19:06:01 <grenoya> we are going a bit out of topic, aren't we ? :)
19:06:07 <marja> yes, we are
19:07:31 <marja> grenoya: do you think having the license on the index page is enough?
19:07:51 <grenoya> no, it has to be on every page i think
19:08:38 <marja> #action marja look into how to add a footer for our online help, to add a notice about the license
19:09:30 <yurchor> Can this footer be added as a part of CSS? Fedora do not have a legal notice on every page, just at the beginning... Ex.: http://docs.fedoraproject.org/en-US/Fedora/17/html/FreeIPA_Guide/index.html
19:09:31 <[mbot> [ FreeIPA: Identity/Policy Management ]
19:09:33 <marja> #action marja mail the relevant COPYING and README's to grenoya, to be added on the doc.mageia.org index page
19:10:56 <marja> yurchor: I'll look into that, too
19:11:57 <marja> yurchor: but because many people follow links to another page than the first one, it seems better to include a small footer on every page
19:12:03 <marja> yurchor: like in the wiki
19:12:06 <grenoya> yurchor: yes, it's also a possibility, i need to look correctly what is already here and what is not
19:12:31 <yurchor> Ah, Ok. Thanks for the explanation.
19:13:17 <marja> do we have more on this topic?
19:14:54 <marja> can we close this topic?
19:14:57 <grenoya> after putting all the languages,
19:15:21 <grenoya> i will try to change a bit the CSS to have a better look
19:15:38 <marja> grenoya: thx :)
19:16:05 <grenoya> this will be part of atelier work, but you agreement will be ask :)
19:16:16 <marja> thanks :)
19:16:51 <marja> #topic anything else that needs to be said
19:17:00 <marja> lebarhon: welcome to the meeting, btw ;)
19:17:07 <marja> ouch, he is gone again
19:17:21 <marja> oh, changing identity
19:17:33 * marja does anyone have anything to say or ask?
19:19:02 <lebarhon_> hello Marja, I don't understand these disconnexions
19:19:27 <marja> lebarhon_: np, I have them a lot with wireless
19:19:41 <marja> lebarhon_: but for some reason not when wired
19:20:05 <lebarhon_> i am wired at the moment
19:20:10 <marja> let's close the meeting
19:20:17 <marja> #endmeeting