18:00:37 <marja> #startmeeting
18:00:37 <Inigo_Montoya> Meeting started Tue Jun 26 18:00:37 2012 UTC.  The chair is marja. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:37 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:44 <JohnR> grenoya: looking for hicups? :-)
18:00:47 <marja> #chair grenoya
18:00:47 <Inigo_Montoya> Current chairs: grenoya marja
18:01:08 <marja> #topic Agree to have the "Testing_procedure:" space in the wiki
18:01:22 <marja> did everyone read the related thread in our ml?
18:01:31 <JohnR> yep
18:01:36 <Workaholic> yep
18:02:01 <The_Loko> yes
18:02:40 <marja> #info QA has many pages about testing procedures, there'll be hundreds of those pages in the end
18:02:41 <yurchor> yes.
18:03:01 * marja do we all agree on creating that space?
18:03:17 <MrsB> hi
18:03:21 <grenoya> yes
18:03:22 <marja> MrsB: hi
18:03:28 <grenoya> marja: hi
18:03:32 <grenoya> oops
18:03:34 <marja> MrsB: do you agree?
18:03:35 <JohnR> I do, however there should some automated method to have them proofread too
18:03:36 <grenoya> MrsB: hi
18:03:38 <The_Loko> yes
18:03:43 <MrsB> what does it mean to have the namespace?
18:03:43 <Workaholic> yes
18:04:08 <marja> MrsB: it's your own little corner of the wiki
18:04:12 <MrsB> lol
18:04:21 <marja> MrsB: it makes those pages easier to find if you need them
18:04:35 <MrsB> in what way, sorry just need to get my hear around it
18:04:38 <marja> MrsB: and less chance someone who doesn't need them ends up on them
18:04:40 <MrsB> head
18:05:41 <marja> anyway, no one opposes, only votes for
18:05:51 <JohnR> These pages should be 'inside' the QA area? yes?
18:06:18 <marja> #agreed we'll have the "Testing_procedure:" space in the wiki
18:06:31 <marja> JohnR: ?
18:06:58 <marja> there'll be links from QA portal and such
18:07:22 <JohnR> marja: ok, that answers it :-)
18:07:34 <marja> JohnR: great :)
18:07:38 <marja> anything else on this topic?
18:08:16 <JohnR> not here
18:08:41 <marja> #topic Translating the wiki
18:09:07 <marja> Does anyone know whether Oliver has been in touch with Nikerabbit?
18:09:33 <JohnR> nope, Nikerabbit ?
18:10:11 <marja> simonnzg: hi :)
18:10:19 <JohnR> simonnzg: 'ning
18:10:19 <simonnzg> marja: SRI I'm late..
18:10:29 <simonnzg> JohnR: Evening.
18:10:46 <marja> simonnzg: do you happen to know whether obgr_seneca has been in touch with nikerabbit?
18:10:51 * JohnR admires simonnzg's newly forified belly ...
18:11:26 <simonnzg> marja: No, I haven't seen Oliver on here for a bit.  JohnR: Not eaten anything (yet)
18:11:33 <JohnR> lol
18:11:41 <simonnzg> JohnR: Tennis
18:11:43 <marja> boklm: are you around?
18:12:33 <marja> it seems we'll have to use the ml to discuss this topic
18:13:14 <marja> shall we go on to next topic?
18:13:45 <JohnR> seems sensible
18:14:12 <marja> #topic moving stuff from docteam.mageia.nl to doc.mageia.org
18:14:19 <marja> I have failed, there
18:14:47 <JohnR> Failed? You've not been well!!
18:14:54 <marja> only the english installer help is on doc.mageia.org
18:15:06 <marja> JohnR: I got commit rights, never used them
18:15:17 <JohnR> ne neither :-)
18:15:24 <marja> JohnR: btw, you have commit rights too, now, and so does simonnzg :þ
18:15:37 <marja> grenoya: what did you want to say about this topic?
18:16:27 <grenoya> i have discussed with Romain, because now a day, someone who does not know doc.mageia.org can not reach it through Mageia website
18:16:56 <grenoya> he said that for him it was not yet clear if we want it visible or not
18:16:59 <marja> grenoya: you're right, it is impossible to find a link
18:17:13 <grenoya> ok
18:17:30 * grenoya put her hat of "atelier-padawan"
18:17:31 <marja> yes, we want the help files to be visible
18:17:42 <JohnR> Yes, it should be visible, but probably not until we have everything moved across - yes?
18:17:42 <grenoya> i'll take care of this particular point
18:17:50 <marja> so the ones in doc.mageia.org
18:18:14 <marja> but there'll be another space to use for files we work on
18:18:20 <grenoya> what is missing actually ?
18:18:35 <grenoya> on the public part i mean
18:18:35 <marja> grenoya: all the translated files
18:18:38 <JohnR> grenoya: Languages other than EN
18:18:50 <grenoya> oh, yes, it's important !
18:19:07 <grenoya> who did put the EN pages ?
18:19:13 <marja> grenoya: and the way we generated the EN one from Calenco, wasn't perfect
18:19:17 <marja> grenoya: barjac
18:19:37 <marja> grenoya: I now prefer to copy the files from docteam.mageia.nl
18:19:59 <JohnR> freedomrun: Is Romain amenable to adding a "Documentation" link to landing page of the website?
18:20:08 <marja> grenoya: only I think it would be better to move the English file into an /en/ space
18:20:20 <grenoya> #action grenoya will put link(s) in the website for people to find doc.mageia.org
18:20:30 <marja> grenoya: great :)
18:20:55 <marja> grenoya: can we leave the index.html in doc.mageia.org to you, too?
18:21:29 <grenoya> marja: i'll see if i have commits right
18:21:45 <grenoya> but yes, i can take care of doc.
18:22:21 <JohnR> opps wrong nick above;
18:22:22 * marja what do you all think, wouldn't it be better to have the English files in http://doc.mageia.org/en/
18:22:33 <JohnR> grenoya:  Is Romain amenable to adding a "Documentation" link to landing page of the website?
18:22:41 <grenoya> marja: do you want the index.html to be the choice between languages ?
18:22:52 * marja because all the other languages will be in http://doc.mageia.org/fr/ etc,
18:23:03 <grenoya> JohnR: i'll do it (i'm is web padawan)
18:23:12 <JohnR> marja: Yes, the lanuage is (should be) picked up from browser language
18:23:22 <marja> grenoya: I think that would be best
18:23:43 <marja> grenoya: or is it better to have the choice for different publications there?
18:23:54 * marja never did this before
18:24:10 <grenoya> if i manage to to it like JohnR think, it would be better, but maybe in the first time, index could be the choice
18:24:25 <JohnR> grenoya: ok, that makes good sense
18:24:39 <grenoya> marja: what do you mean by "different publications" ?
18:24:53 <marja> grenoya: like mdv does http://doc.mandriva.com/index.php
18:24:54 <[mbot> [ Mandriva Official Documentation ]
18:25:26 <sebsebseb> oh yeah docs meeting
18:25:37 <marja> grenoya: you can choose between several guides or manuals, including previous versions
18:25:45 <JohnR> Ummm, that will come later because for the time being we only have the installer docs
18:25:46 <sebsebseb> started doing something so forgot
18:25:47 <marja> grenoya: and you can change the language there
18:26:02 <grenoya> marja: yes, it's a good idea, but we don't have several publications yet :)
18:26:19 <marja> grenoya: no, but we'll be working on the next one, soon :)
18:26:36 <grenoya> but it can be design to be like that and with the time, it will be completed
18:26:40 * JohnR is working (slowly on doc'ing the current mcc
18:27:03 <JohnR> +)
18:27:13 * marja is proud of doc team that we have the online installer help in many more languages than Mdv :)
18:27:36 <grenoya> #action grenoya will had the other languages on doc.mageia.org
18:27:36 * JohnR thinks marja can be blamed for that! :-)
18:28:00 <grenoya> #action grenoya will do a index page for publication and language selection
18:28:14 <marja> grenoya: thx a lot :)
18:29:04 <grenoya> anything else on this topic ?
18:29:08 <marja> grenoya: both the favicon and the logo are correct in the help in docteam.mageia.nl
18:29:09 <grenoya> marja: yw
18:29:37 <marja> grenoya: I think it is maybe better to copy the files from there to doc.mageia.org
18:30:24 <marja> because generating and downloading them in Calenco left them with missing favicon and icon
18:30:28 <grenoya> marja: to copy them in a /mageia2/ folder ?
18:30:46 <marja> grenoya: yes, it would be best to have them in a mageia2 folder
18:30:47 <JohnR> marja: Mabe we can ask Remmy(?) to do a tarball of the doc space on his server?
18:31:00 <grenoya> so that we consider it as a finished work
18:31:02 <marja> JohnR: only the en files will move
18:31:18 <marja> grenoya: yes, only the Spanish files will be added later
18:31:32 <JohnR> marja: So how do the other langs get there?
18:31:33 <grenoya> why only the english files ?
18:32:02 <marja> grenoya: move to the /en/ folder, I mean
18:32:13 <grenoya> yes
18:32:19 <JohnR> ahh, ok
18:32:22 <marja> grenoya: they are not in the /en/ folder now
18:32:36 <grenoya> but i think JohnR was talking about the other languages, no ?
18:32:48 <grenoya> for migration
18:32:52 <marja> grenoya: yes, the other languages need to be copied
18:33:10 * JohnR thinking of translations, the Swedish files were due here 4 days ago ....
18:33:11 <grenoya> is Remmy availlable to do a tarball of them ?
18:33:20 <marja> grenoya: I have them all, except for the spanish and most recent Esperanto one
18:33:34 <grenoya> marja: ok, perfect :)
18:34:01 <marja> grenoya: I only need to learn to commit
18:34:07 <grenoya> :))
18:34:26 <The_Loko> I'll start with the spanish tomorrow
18:34:35 <marja> The_Loko: great, thanks a lot :)
18:35:08 <marja> The_Loko: ping me to make a publication for you, so you can check online how it looks like
18:35:58 <JohnR> The_Loko: Do you have someone who can proofread for you?
18:36:31 <JohnR> The_Loko: To check spelling etc :-)
18:36:53 * simonnzg returns
18:36:57 <The_Loko> no... i'll try to take here ppl from the spanish i18n team
18:37:09 <JohnR> The_Loko: ok, good
18:37:33 <freedomrun> JohnR, no clue
18:37:55 <JohnR> freedomrun: sorry that was a mis-typed nick
18:38:26 <grenoya> marja: next topic ?
18:38:28 <freedomrun> np
18:38:34 <marja> yes
18:38:53 <grenoya> you wanted t talk about doc team objectives for Mga3 ?
18:39:16 <JohnR> me too
18:39:24 <marja> grenoya: yes, thx
18:39:28 <marja> #topic
18:39:35 <marja> #undo
18:39:35 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Topic object at 0x83c380c>
18:39:56 <marja> #topic specifications and planning for Mageia 3
18:40:34 <marja> what is most urgent now, is making documentation for MCC and all the tools in it
18:40:42 <marja> however, we have a problem
18:41:16 <marja> there are plans to improve and modernise several of those tools
18:41:25 <marja> we don't know what will be done
18:41:29 <JohnR> 1st question: Is mcc going to changed in any major way? tv doesn't answer to mail requests for info?
18:41:29 <marja> nor when
18:41:40 <marja> JohnR: tv didn't reply
18:41:48 <JohnR> marja: I know
18:41:54 <marja> last night in the meeting I was told to ask blino
18:41:55 <grenoya> JohnR: i don't think
18:42:13 <JohnR> grenoya: re-phrase pleae?
18:42:30 <marja> I forgot to mail him, but pinged him 1½ hr ago
18:42:54 <marja> he didn't respond to my ping yet
18:43:10 <JohnR> marja: He's marked away :-(
18:43:20 <grenoya> i don't think it will change in a major way because 1) we are missing arms for that 2) not everybody seams to agree
18:43:31 <marja> JohnR: he wasn't when I pinged
18:43:43 <JohnR> marja: ok
18:43:59 <JohnR> grenoya: Ok, then I should continue what I'm doing?
18:44:04 <marja> I'd like to be sure there are no major changes, I want to avoid getting into the same situation as we did with installer
18:44:37 <marja> that we finished half or more of the pages and need to start all over again
18:44:38 <JohnR> marja: Are we talking about different things here?
18:45:07 <JohnR> marja: I think you are talking about inline help in mcc - yes?
18:45:10 <marja> JohnR: we are talking about all drak*
18:45:41 <grenoya> i think the point are : we need to rewrite the doc (to be completly delivered from the licence) and some things will move
18:46:02 <marja> grenoya: yes, we need to start from scratch
18:46:05 <JohnR> I'm doing a "HOWTO us Mageia Control Centre" for Documentation pages
18:46:28 <JohnR> us>use
18:46:32 <grenoya> marja: i don't thing will have *every* thing to rewrite (after the first path on it)
18:46:36 <marja> JohnR: that is great...... we can use it when writing in Calenco
18:46:55 <simonnzg> JohnR: Probably better to write a "How to keep Doc Team happy by telling them what you're going to do with MCC" page..
18:47:11 <JohnR> simonnzg: true
18:47:39 <grenoya> :)
18:47:40 <marja> grenoya: yes, the changes can't be so big that we can't use anything anymore
18:47:44 <marja> simonnzg: lol
18:48:20 <simonnzg> marja: So long as the title of the updates page doesn't say "Packages Updates" any more, I'll be happy.
18:48:53 * marja maybe if we know we can have to rework some pages, it'll be less bad when it happens that tools change
18:49:17 <marja> simonnzg: that'll stay like that for ever!
18:49:23 <JohnR> WE have three types of Documentation to deal with: 1) inline help for application, 2) Wiki pages and 3) Official docs to published in doc.mageia.org - please can we keep this in mind when discussing docs ? :-)
18:49:31 <simonnzg> The problem is that MCC is looking very, very OLD nowadays.  It's desperate for a complete revamp.
18:49:51 <marja> JohnR: you're right
18:50:08 <grenoya> JohnR: for me the Official doc is made from the inline doc, am i wrong ?
18:50:16 <marja> so we need inline help for those tools/MCC
18:50:17 <JohnR> simonnzg: To fix "Packages Installaions" you need to ask in Breton ....
18:50:21 <marja> grenoya: you're right
18:50:32 <marja> grenoya: we add screenshots to the inline doc
18:50:39 <marja> grenoya: and that's about it :)
18:50:42 <JohnR> grenoya: No it should be other way round :-)
18:50:50 <simonnzg> JohnR: Franglais is the best I can manage. I *may* be able to go as far as broken Gaelic.
18:51:14 <JohnR> simonnzg: At least that's similar to Breton :-)
18:52:03 <simonnzg> JohnR: They're all variants of a trading language used along the Atlantic coast in the Bronze Age. Off Topic, though ;-)
18:52:08 <marja> you can listen to Breton radio to get some inspiration http://www.radiobreizh.net/fr/index.php
18:52:09 <[mbot> [ Radio Breizh - Le portail des radios en breton ]
18:52:22 <JohnR> Inline help for applications should(tm) refer to official docs for that app
18:52:34 <simonnzg> Ah, Alan Stivell..
18:53:22 <simonnzg> JohnR: Are doing an Official Doc or a Wiki page for MCC??
18:53:22 <marja> my brain is taking off
18:53:39 <simonnzg> marja: If you're quick, you'll see mine going the otehr way.
18:53:43 <marja> :)
18:53:51 <JohnR> simonnzg: I'm doing an Official-type
18:53:52 <grenoya> simonnzg: Official and inline, no ?
18:54:04 <simonnzg> JohnR: Ach, so.
18:54:16 <marja> grenoya: simonnzg: yes, official and inline
18:54:43 <marja> the wiki is OK to get going, and we can use what is written in the wiki
18:54:54 <marja> but it is fine to work directly in Calenco
18:55:15 <grenoya> so, what can we propose as goals for doc team in Mga3 ?
18:55:22 * JohnR does not think that a wiki is a suitable place for so-called Official Docs
18:55:37 <Nikerabbit> marja: hi
18:55:48 <JohnR> but yes we can use what's in the wiki to help it along
18:55:57 <JohnR> Nikerabbit: hi
18:55:57 <marja> Nikerabbit: hi
18:56:17 <marja> Nikerabbit: do you mind if we finish this topic and come back to you then?
18:56:33 <JohnR> marja: no problem here
18:56:53 <marja> grenoya: official inline and online help for MCC and all the drak* tools in it
18:56:54 <JohnR> opps misread
18:57:30 <JohnR> marja: No, can't be like that, it doesn't make sense :-)
18:57:47 <JohnR> inline= help within the application
18:57:55 <marja> grenoya: and also an official online help for the LiveCD
18:58:20 <Nikerabbit> marja: how long does it take?
18:58:28 <grenoya> do we but that in #info or #action ?
18:58:29 <marja> JohnR: I mean the help you get when clicking help in the drop down menu in MCC
18:58:51 <JohnR> marja: yes, that is inline - part of the application
18:59:19 <grenoya> JohnR: it's not help buttons like in installer ?
18:59:24 <JohnR> marja: that needs to be done in colalaboration with the developer/coder
18:59:48 <JohnR> grenoya: Yes, that's correct
18:59:58 <marja> #action for Mageia 3 docteam will work on official inline and online help for MCC and all the drak* tools in it
19:00:13 <marja> is that OK like this?
19:00:20 <JohnR> marja: yup
19:00:36 <marja> Nikerabbit: just a minute
19:01:02 * marja everybody else OK with this?
19:01:12 <grenoya> #action for Mageia 3 docteam will update installer help and add new languages if possible
19:01:24 <JohnR> bear in mind there are 88 drak packages to be done too :-)
19:01:25 <grenoya> marja: are you ok with this ?
19:01:27 <marja> grenoya: great, thx :)
19:02:10 * marja can we switch back to the wiki-translate topic?
19:02:15 <grenoya> ok, back to the wiki translation topic ?
19:02:17 <JohnR> go
19:02:18 <grenoya> :)
19:02:30 <marja> #topic wiki translation
19:02:48 <marja> Nikerabbit: did obgr_seneca get in touch with you?
19:03:55 <marja> Nikerabbit: obgr_seneca aka Oliver Burger
19:06:14 <Nikerabbit> marja: nope
19:06:20 <marja> Nikerabbit: ouch
19:07:10 <marja> Nikerabbit: sorry for having you wait here for all that time
19:08:30 * marja thinks it would be really good to have Nikerabbit's extension
19:08:51 * marja will write Oliver
19:09:34 <marja> #action marja write oliver about the Nikerabbit's tranlation extension
19:09:52 <marja> Nikerabbit: thx for your patience
19:10:33 * marja is there anything else we need to discuss?
19:11:06 <Nikerabbit> marja: oh right it's tuesday again
19:11:17 <JohnR> I wanted to discussion the use of a translation engins of some kind for the OFFICIAL docs
19:11:19 <Nikerabbit> marja: I wasn't actually paying attention, so no problems
19:11:33 <marja> Nikerabbit: :)
19:11:54 <marja> JohnR: now?
19:12:06 <marja> JohnR: the Calenco translations?
19:12:28 <JohnR> Soon :-) No, all translations OTHER THAN wiki
19:12:58 <marja> JohnR: please start a discussion on the ml :)
19:13:11 * marja can we end the meeting?
19:13:20 <JohnR> However, I'm not keen that a potfile system be used
19:13:40 <JohnR> marja: ok
19:14:15 <Nikerabbit> btw my extension can also be used to translate common file formats like gettext or properties
19:14:53 <marja> Nikerabbit: ah, that sounds interesting :)
19:14:56 <JohnR> Nikerabbit: Stand alone? as in not linked to wiki software?
19:15:27 <Nikerabbit> JohnR: not standalone, the translation would happen inside the wiki
19:15:31 <JohnR> Nikerabbit: Which translation engine is used please?
19:16:20 <Nikerabbit> well since we started the discussion anyway, let me give few links
19:16:32 <JohnR> You extension can produce printer-ready pdfs?
19:16:40 <JohnR> you>your :-)
19:16:40 <Nikerabbit> hmm not really
19:16:42 <Nikerabbit> https://www.mediawiki.org/wiki/Help:Extension:Translate
19:17:04 <Nikerabbit> I was thinking of software translation, not document translation
19:17:10 <JohnR> Then I don't think it can be useful for the purpose we need :-)
19:17:25 <Nikerabbit> okay
19:17:39 <Nikerabbit> the KDE folks are exploring how to export the wiki pages into docbook format
19:17:43 <JohnR> That being said, I do like what I see :-)
19:18:00 <yurchor> JohnR: What is in common with translation and pdf?
19:18:12 <Nikerabbit> hi yurchor
19:18:12 <marja> Nikerabbit: JohnR: my brain can't follow the discussion anymore
19:18:22 <JohnR> They need to me printer-ready
19:18:30 <JohnR> me>be
19:18:31 <marja> Nikerabbit: is it possible to become a member of our  mailing list?
19:18:49 <yurchor> It's the other extension, completely independent.
19:18:52 * marja and can we  please continue this discussion on the ml?
19:19:34 <grenoya> and speak about it again at the next meeting ?
19:19:38 <JohnR> yurchor: I know you are keen to use pot files, but they don't really fit the end result - we tried it at mdv in the early 2000s
19:19:48 <marja> Nikerabbit: https://ml.mageia.org/wwsympa-wrapper.fcgi/info/doc-discuss for our mailing list
19:19:49 <[mbot> [ doc-discuss - Discussions about Mageia documentation - info ]
19:20:00 <Nikerabbit> marja: depends on how much traffic it has
19:20:11 <JohnR> Nikerabbit: not high :-)
19:20:17 <Nikerabbit> marja: and I'd like to have an explanation of what you want, so I can tell you how we can help or not
19:20:51 <marja> Nikerabbit: for the wiki, you know, I think
19:21:03 <yurchor> JohnR: pot filesare just a useful feature. It is not an obligatory in any way.
19:21:21 <Nikerabbit> marja: subscribing requires an account, and I don't see way to create one
19:21:27 <JohnR> yurchor: Yes, I know :-)
19:21:55 <marja> Nikerabbit: https://identity.mageia.org/
19:21:56 <[mbot> [ Mageia Identity Management ]
19:23:24 <Nikerabbit> done
19:23:30 <marja> thx
19:24:01 <marja> JohnR: can you write to the ml what you wanted to say about translating "other than in the wiki"?
19:24:23 * marja can we please end the meeting?
19:24:39 <grenoya> yes
19:24:48 <JohnR> marja: doingf that now and yes :-)
19:24:57 <marja> #endmeeting