18:03:58 <marja> #startmeeting
18:03:58 <Inigo_Montoya> Meeting started Tue Jun  5 18:03:58 2012 UTC.  The chair is marja. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:58 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:04:02 <grenoya> hi
18:04:22 <marja> grenoya: I didn't dare to ping you
18:04:29 <marja> are you alright?
18:04:38 <grenoya> medical drugs :)
18:04:47 <Tobi_> hello, I'm here
18:05:00 <marja> Tobi_: nice
18:05:04 <pasmatt> marja: hi, I'm matteo
18:05:07 <grenoya> it stops the migraine, but not much neurones, will try to participate...
18:05:13 <marja> pasmatt: ah, good :)
18:05:17 <marja> grenoya: OK, thx
18:05:47 <marja> #topic post-mortem Mageia2 https://wiki.mageia.org/en/Mageia2_Postmortem#Documentation
18:06:06 <marja> thanks a lot everybody who has given input
18:06:25 <marja> if you think something is still missing: it isn't too late to add it
18:07:06 <marja> but this week we should focus on discussing it and making it ready to present to council next week
18:07:31 <marja> does anyone have a question about it?
18:08:32 <grenoya> i don't anderstand the last point
18:08:58 <marja> the one that was added by scsijon ?
18:09:02 <grenoya> yes
18:10:26 <marja> I'm not 100% sure I understand, either, but if I do, it is an awful lot of work
18:10:33 <JohnR> Is that last point really a Documentation function? It seems to me it should be a Packager job
18:10:52 <grenoya> JohnR: i agree with you
18:10:52 <Tobi_> i thinkt that it meant that we should make a list, where it is possible to see changed packages...
18:11:05 <marja> JohnR: I think it is about "what is replaced by mariadb" and things like that
18:11:19 <grenoya> and that a monster task (look at sophie...)
18:11:37 <grenoya> marja: so it's packager's task
18:11:39 <JohnR> grenoya: yes, exactly :-)
18:11:41 <marja> grenoya: yes, not a task for us
18:13:02 <JohnR> Details such as that do belong in Release notes, but our job there is surely only to make the notes readable :-)
18:14:04 <marja> added a line to scsijon's comment
18:14:32 <grenoya> marja: perfect :)
18:14:34 <marja> are there more questions...... to me it was a little confusing that we mix wiki and Calenco issues
18:15:19 <JohnR> marja: Yes, they are separate areas, but at this point it's pretty hard to separate them too :-)
18:16:06 <marja> JohnR: maybe I should just learn to read better, when reading the items it is clear what they are about
18:16:44 * marja btw, Thierry didn't reply to my mail about MCC yet, but I was very late to send it
18:16:52 <JohnR> A major problem we have (wiki and formal docs) is that developers in general are pretty slack when it comes to describibing what their applications do - Go read the code is a cop-out! :-)
18:17:40 <marja> JohnR: it boils down to trying what happens if you do this or that, and finding experts, like barjac for bootloader
18:18:11 <JohnR> At the same time I know just how difficult it is to get Thierry do explain or change something :-)
18:18:34 <marja> JohnR: he should be given the chance to explain in French ;)
18:18:55 <marja> that'll take a lot less energy of him
18:19:00 <grenoya> that's why i proposed to investigate ourself in MCC and installer
18:19:00 <JohnR> Good Idea :-) Volunteer?? :-)
18:19:08 <Tobi_> maybe we could make a template for the developers
18:19:14 * simonnzg is late again...
18:19:21 <marja> simonnzg: welcome https://wiki.mageia.org/en/Mageia2_Postmortem#Methodology
18:19:48 <marja> Tobi_: sounds good, but I wouldn't be able to make a good one...... do you have something in mind?
18:19:49 <simonnzg> marja: Morning. Just having a read.
18:19:56 <grenoya> JohnR: i can do the translation between him and my frenglish, but i'm not sure it'll help
18:20:04 <JohnR> I've started documenting MCC, but it will/is only from the users viewpoint - the details of how it works will not be done :-)
18:20:07 <JohnR> I simonnzg
18:20:21 <marja> JohnR: thanks :)
18:20:24 <JohnR> grenoya: ;-) I do understand :-)
18:20:42 <Tobi_> marja: I also have to think a while, but maybe we could write it down and work on it....
18:21:09 <Tobi_> that hasn't to be completed till next week ;)
18:21:38 <simonnzg> JohnR: Hi
18:21:38 <marja> Tobi_: do you mind adding that to the Methodology part of the post mortem..... so just the idea
18:22:01 <Tobi_> no problem
18:22:07 * marja does anyone here have Mandrive 2010.x installed?
18:22:16 <JohnR> If you look at the installer code (for example) it's a number od sub-modules - but I certainly can't find the connections between those bits - It's the same when looking at MCC
18:22:33 <JohnR> marja: Why?
18:23:00 <marja> JohnR: I was thinking at clicking the help in the menu in several different MCC screens in Mandriva
18:23:19 <marja> and looking which pages are opened
18:23:36 <marja> and noting the file names of those pages
18:23:44 <marja> because we'll need those file names
18:24:01 <JohnR> marja: from where I'm at, I don't see any point in doing so. Most of us here, know what to do, the help isn't really much help :-)
18:24:07 * Led43_mag2 is here and caught up!
18:24:36 <JohnR> the various delevopers of the MCC modules need to address that :-)
18:24:37 <marja> JohnR: if in Mageia MCC you choose the help from the menu
18:24:51 <marja> you don't get anything, because the file isn't there
18:25:00 <JohnR> marja: exactly :-)
18:25:05 <marja> but link is still there
18:25:13 <marja> just like we had in installer
18:25:17 <JohnR> link or button?
18:25:34 <marja> you choose help from the menu
18:26:03 <marja> but it links to different parts of some manual
18:26:17 <marja> depending on the screen you're in
18:26:27 <marja> at least, that is the impression I got
18:27:10 <Tobi_> i think that I've heard one time, that in BSD any change on Code has to be documentated completely, maybe that could also be a possibility....
18:27:21 <marja> yes, for instance "mcc-localdisks"
18:27:27 <Tobi_> (only a brainstorming idea)
18:27:42 <JohnR> Tobi_: In the best of all worlds :-)
18:27:59 <marja> Tobi_: you mean...... go look if that was done
18:28:10 <marja> Tobi_: or have our developers do that ?
18:28:19 <grenoya> i can give a try onMCC code (just give my 1 month before strting)
18:28:32 <marja> grenoya: thx :)
18:28:37 <grenoya> (sorry for the latence, network problem :\)
18:28:51 <marja> grenoya: but watch the ml, in case tv comes up with a lot of information
18:29:02 <grenoya> marja: ok :)
18:29:04 <JohnR> grenoya: Start with drakconf, but I suspect it's only a wrapper :-)
18:29:26 <Tobi_> it was only an idea :D
18:29:41 <JohnR> Tobi_: It's a good one though :-)
18:30:34 <marja> Tobi_: yes, it is
18:30:51 <Tobi_> ok, who wants to convince the developers ;)
18:30:55 <marja> JohnR: do you happen to be in Calenco?
18:31:01 <marja> Tobi_: you ;)
18:31:01 <JohnR> marja: no
18:31:33 <marja> I started to wonder wether all the needed filenames start with "mcc"
18:32:23 <marja> #action marja look for old filenames starting with "mcc" in Calenco
18:32:27 <JohnR> marja: no, mostly with drak
18:32:35 <marja> JohnR: OK
18:33:44 <marja> grenoya: would you be OK with working directly in Calenco, instead of on some pad or in the wiki?
18:34:45 <grenoya> marja: i don't really like it, but a can do some effort
18:35:08 <grenoya> s/but a can/but I can/
18:35:10 <marja> grenoya: OK, if it doesn't work, we'll find a solution
18:35:31 <JohnR> marja: think of Calenco as a publishing tool, do your text outside then import - it's an easier way to work in my view
18:35:47 <grenoya> so do i /o\
18:36:27 <marja> JohnR: grenoya come to think of it, that is how I worked, too... I first did the text in kwrite
18:37:04 <JohnR> xxe is probably the best tool to do the intital formatting and some other text editor to start with
18:37:14 <grenoya> marja: so english proofreading in calenco ?
18:37:32 <marja> grenoya: yes, that is what was done for the 2nd installer help
18:37:37 <JohnR> grenoya: That's where I do it
18:38:15 <grenoya> ok, so i'll do this way
18:38:30 <marja> grenoya: and with the xxe addon it is possible to do some technical edits, but if you prefer downloading and uploading again, that is fine, too
18:38:31 <JohnR> I suggest that that's the best way for otherv languages too
18:39:08 <marja> our translators have different ways of working
18:39:19 <JohnR> marja: yes, I know :-)
18:39:31 <marja> is there anything else on the post mortem?
18:39:58 <JohnR> not here
18:40:45 <marja> #topic Mageia 3 Features https://wiki.mageia.org/en/Features_policy
18:40:58 <marja> any team can come up with proposals
18:41:58 <marja> If you see something that is in accordance with the features policy, feel free to add it
18:42:12 <marja> if you want to discuss your idea here first: fine
18:42:16 <marja> you can do that now
18:42:24 <marja> or later on the mailing list
18:42:39 <doktor5000_> anyone knows what the default user in live is called? live?
18:42:49 <doktor5000_> s/live/live-cd/
18:43:19 <marja> doktor5000_: no, sorry..... and you're disturbing a meeting :รพ
18:43:59 <marja> doesn anyone have anything on that topic?
18:44:10 * Led43_mag2 not here
18:44:14 <JohnR> not here
18:44:52 <simonnzg> I found that my DV camera wouldn't work in MGA2B2 - if it still doesn't work, maybe 'll suggest Firewire support goes into the kernel.. ;-)
18:44:52 * doktor5000_ forgot and is sorry and runs :(
18:45:26 <Tobi_> redesign of package-installation....maybe....
18:45:32 <marja> simonnzg: I thought firewire *was* supported
18:45:52 <marja> Tobi_: like?
18:46:13 <simonnzg> marja: Maybe it *was* ...  I haven't checked since B2 - I installed Mint to get my work done..
18:46:20 <marja> simonnzg: oops
18:47:13 <simonnzg> MGA2 still lacks a couple of packages I use. I need to get down to Bugging for them to be included..
18:47:18 <Tobi_> for example... don't show any software twice (one time as main-package and as update-package)....go a bit away of package centration....
18:48:23 <marja> Tobi_: there are some vague plans to change MCC, I agree seeing the software twice is annoying......
18:48:27 <simonnzg> Tobi_: Or NOT telling you that it's downloading some description file (by name) when you click on a package name when choosing to install
18:48:28 <JohnR> Tobi_: I agree that needs looking at, but is it a function of our team?
18:49:07 <marja> JohnR: Maybe I misunderstood (or read over it) but I think proposals are open for anyone
18:49:09 <grenoya> Tobi_: it's packager/dev team work
18:49:38 <marja> JohnR:  and we can do our part by writing the needed documentation for it
18:49:38 <grenoya> marja: yes, but doc team should propose doc propositions :)
18:49:52 <marja> grenoya: that would be most logical :)
18:49:59 <JohnR> marja: you mean the Features?, I thought we had moved on :-(
18:50:33 <Tobi_> but it is really logical, that have to be in the packager-team to make proposals?
18:50:38 <Tobi_> *you
18:50:57 <grenoya> Tobi_: i don't understand ?
18:50:59 <JohnR> Tobi_: No not at all
18:51:13 <marja> grenoya: however, in the policy it says: "Everybody is free to propose new features for coming releases but this will have to be done using the following procedure"
18:51:45 <marja> and after that, people who think a proposal is interesting, can add that they want to work on it
18:51:49 <grenoya> marja: yes, but propositions must have people to implement them
18:51:57 <marja> grenoya: of course
18:52:16 <marja> nothing will be done if there is no one to implement them
18:52:19 <grenoya> and what Tobi_ is proposing is controversal...
18:52:36 <Tobi_> what?
18:52:42 * JohnR needs to go drag out his COBOL manuals and relearn coding :-)
18:52:44 <grenoya> the discussion will take place in -dev@ or -discuss@ MLs imho
18:52:53 <marja> controversial in the meaning that there is disagreement
18:52:54 <marja> ?
18:52:59 <JohnR> I agree with gre
18:53:02 <JohnR> I agree with grenoya
18:53:17 <grenoya> Tobi_: if i don't whant updates to be installed, mcc should show both, for example
18:53:48 <JohnR> s/mcc/rpmdrake ?
18:54:05 <Tobi_> but that shouldn't be shown in the installation/deinstallation area...
18:54:07 <grenoya> yes (/me never knows the good names /o\)
18:54:16 <grenoya> Tobi_: why not ?
18:54:17 * marja now remembers a few times she had reason to choose for an older package instead of the update
18:54:34 <Tobi_> therefore you have the update dialog as an additional area
18:55:18 <simonnzg> In my nice Minty fresh Mint installation there is Synaptic (for those that like a proper installer) and a PackageKit tool for simple stuff.  MCC only has MCC.
18:55:27 <grenoya> Tobi_: you can add the proposal, but it will be discuss on Mls
18:55:50 <marja> grenoya: like with all proposals
18:56:06 <Tobi_> grenoya: I know ;)
18:56:13 <grenoya> marja: yes, but here we should talk about proposals for doc team :)
18:56:25 <marja> grenoya: you're right, sorry
18:56:44 * marja can we move this discussion to the ml?
18:56:47 <JohnR> Tobi_: A suggestion; Write up your proposal as an [RFC} and post to @discuss
18:56:54 <marja> I have another meeting in 4 minutes
18:57:06 <Tobi_> JohnR: ok
18:57:28 <JohnR> next topic?
18:57:43 <marja> Are you all OK with ending this meeting, or does someone have a next topic?
18:57:54 <JohnR> not here
18:58:03 <simonnzg> Nothing
18:58:05 <grenoya> ok for me
18:58:10 <Tobi_> marja: nothing
18:58:29 <marja> thanks a lot for being here and for working so hard :)
18:58:32 <marja> #endmeeting