18:01:30 <marja> #startmeeting
18:01:30 <Inigo_Montoya`> Meeting started Tue Apr 10 18:01:30 2012 UTC.  The chair is marja. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:30 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:40 <grenoya> i, sorry i'm late
18:01:44 <marja> #topic the wiki
18:01:50 <sebsebseb> grenoya: just started :)
18:01:54 <marja> grenoya: np :)
18:02:10 <marja> obgr_seneca: is there anything you'd like to say about the wiki?
18:02:31 <marja> obgr_seneca: if not I have a little something ;)
18:02:37 <obgr_seneca> as the last weeks I must say, I have not much to tell
18:02:52 <marja> obgr_seneca: OK
18:02:55 <obgr_seneca> I'm too busy with all other things :/
18:03:06 <marja> I know the problem
18:03:13 <marja> we probably all do
18:03:19 <sebsebseb> marja: I tried to get someone interested in docs last night :)
18:03:57 <marja> anyway.... I have a question about the pages for the help for installer.... those with the screenshots
18:04:06 <marja> do we still need them?
18:04:42 <JohnR> marja: shhots? in installer? no
18:04:45 <marja> led43: you have access to calenco too, don't you?
18:04:52 <obgr_seneca> that's for you to decide
18:05:02 <marja> JohnR: no, I'm talking about the wiki pages we used to write the help in
18:05:21 <sebsebseb> marja: yep Led43_mag2 has access to Calenco now I think :)
18:05:27 <marja> JohnR: does led43 have access to Calenco?
18:05:38 <JohnR> not sure looking
18:05:47 <marja> JohnR: thx :)
18:06:43 * JohnR is in caldron, can't tell
18:07:21 <JohnR> rebooting, bbs
18:07:29 <sebsebseb> JohnR: ok
18:07:29 <marja> JohnR: OK, thx
18:07:55 <marja> anyway, no one opposed
18:08:48 <simonnzg> I expect that, since thsoe pages are in :Doc and not :Documentation, that we can just remove them all.
18:08:56 <simonnzg> thsoe : those
18:09:00 <marja> I suppose we agree on removing those pages and  replacing them with a link to that mirror of our help files for installer
18:09:18 <Led43_mag2> marja: yes i have calenco account
18:09:21 <simonnzg> Good idea, except that the links needs to be in Documentation and not the Doc Team area.
18:09:28 <marja> Led43_mag2: great
18:09:38 <marja> simonnzg: OK
18:09:59 <simonnzg> marja: Just remembered that I said I was going to add a link at the last meeting.
18:10:40 <marja> #agreed we remove the content of Help buttons in DrakX-installer pages and replace them with a link to the online help for installer, and put the page in Documentation
18:11:07 <marja> simonnzg: I saw it yesterday or sunday, I did the link ;)
18:11:10 <JohnR> marja: answer is yes
18:11:18 <marja> JohnR: thanks :)
18:11:59 <simonnzg> marja: Just found your link. It's in "Advanced" -
18:12:02 <marja> simonnzg: can I trust you with doing what we just agreed on?
18:12:29 <simonnzg> marja: I'm good at removing content. ;-)
18:12:55 <marja> #action simonnzg will carry out what we agreed on just now :)
18:13:03 <obgr_seneca> If you need me, please ping...
18:13:05 <obgr_seneca> sorry
18:13:38 <marja> grenoya: can you already report something?
18:13:58 <marja> if so I need to set the topic.... but I forgot the name of the tool
18:15:05 <marja> grenoya: Spinx
18:15:13 <marja> sphinx
18:15:50 <marja> maybe that topic later
18:16:04 <marja> # Calenco and the xxe add-on
18:16:12 <marja> #topic Calenco and the xxe add-on
18:17:02 <marja> who have been using the add-on? barjac, johnR, more?
18:17:16 <simonnzg> marja: Not me.
18:17:29 <JohnR> me
18:17:32 <barjac> me
18:17:38 * Led43_mag2 no waiting for ever one else to iron out the problems
18:17:50 <Led43_mag2> *every
18:18:08 <marja> JohnR: you first: how do you like it?
18:18:32 <JohnR> I've used xxe for years, I have no problems in it's use
18:18:44 * grenoya back
18:18:56 <marja> JohnR: so the add-on works as you expect it to work?
18:19:02 <marja> grenoya: thx :)
18:20:21 <marja> JohnR: sorry, I take that "I have no problems in it's use" refers to the add-on, too?
18:20:39 <JohnR> yes
18:20:43 <marja> JohnR: thx
18:20:50 <marja> barjac: how do you like it?
18:21:46 <barjac> Well I don't fully understand it (or xml) yet - but it seems OK.
18:21:54 <marja> barjac: thx
18:22:51 <marja> JohnR: do you mind helping people (that is: everybody, I suppose) who has questions about using xxe or the plugin?
18:23:00 <JohnR> np
18:23:05 <marja> thx :)
18:23:41 <marja> #info JohnR is willing to help anyone with questions about xxe and the xxe add-on for Calenco
18:24:17 <marja> for me the xxe add-on is great, because it helps to find errors in publications very well
18:24:42 <marja> #topic Stop using "xml:id"'s everywhere in Calenco, only use them where they are really needed
18:25:01 <marja> I already saw on the ml that John doesn't agree
18:25:11 <JohnR> Is the a definition for "really needed"?
18:25:24 <JohnR> is there ...
18:25:33 <marja> JohnR: really needed is for all segments
18:25:58 <marja> JohnR: and additionally for anything that is being linked to
18:26:30 <marja> JohnR: I even gave a xml:id to a <note> tag
18:26:58 <marja> JohnR: and at least one screenshot has an xml:id
18:27:45 <marja> JohnR: in the Mdv documentation I saw pages with <para> tags that had xml:id's ...
18:28:23 <JohnR> remember that the mdv documentation was aimed at printed documentation as well
18:28:25 <marja> but the paragraphs had been put in other places, so the order wasn't 1..2..3..etc anymore
18:28:57 <JohnR> the order is not important
18:29:00 <simonnzg> My editor adds ID tags by default, I think. I'd better look and make sure.  Installed Help pages have been truncated. I have the full history in XML Export format.
18:29:09 <marja> anyway, we had several errors because paragraphs had been copied and then filled with different content
18:29:56 <JohnR> Then the author of that parra should be told to fix it :-) Even if it was me :-)
18:30:02 <marja> simonnzg: JohnR OK, if they ar added by default, it would be foolish to remove them
18:30:21 <JohnR> THat's why I disagree with their removal
18:30:42 <marja> JohnR: simonnzg: OK I agree with that....
18:31:08 <marja> do you mind letting the ones that have been removed at rest?
18:31:17 <marja> and just not removing any more?
18:31:30 <JohnR> That seems sensible
18:32:02 <barjac> simonnzg: which editor adds them by default?
18:32:18 <JohnR> oxygen and xxe
18:33:01 <simonnzg> barjac: Just checked. Mine doesn't, but it can add the tag...  oXygen XML Editor.
18:33:26 <marja> #agreed because xxe adds xml:id's by default to <para>'s, we won't remove them
18:33:53 <marja> #topic the translation of the installer help
18:33:54 <simonnzg> I would NOT advocate removing ID tags.
18:34:29 <marja> JohnR: thanks  for adding this topic
18:34:42 <JohnR> np
18:35:11 <marja> obgr_seneca: do you already happen to have any idea's about how the help texts are going to be translated...
18:35:22 <obgr_seneca> nope
18:35:32 <obgr_seneca> I wanted to consider that after Mga2 release
18:35:51 <obgr_seneca> i18n has much to decide then anyway
18:35:56 <marja> obgr_seneca: I'd be very happy if we can postpone this until after that
18:36:04 <JohnR> Previously, it's been done at the same time as the EN pages, just slightly behind
18:36:40 <obgr_seneca> JohnR: Yes but that woul mean giving loads of people Calenco access
18:36:47 <JohnR> No xlates mans non-en installers get no help?
18:36:59 <marja> lebarhon: have you seen the help from scratch for installer? so the beta 3 one?
18:37:12 <JohnR> obgr_seneca: that's not a major problem - it can be controlled
18:37:15 <obgr_seneca> I'd rather go with untranslated help texts in 2 and do it right for Mga3
18:37:29 <lebarhon> I didn't
18:38:00 <obgr_seneca> But I may chicken out right now because of my personal workload
18:38:09 <marja> lebarhon: what we have now is this (but for installer without screenshots) http://waesvanm.home.xs4all.nl/webhelp/content/
18:38:10 <Magbot> [ Installation with DrakX ]
18:38:53 <marja> JohnR: obgr_seneca: if lebarhon has time and wants to try, I think it is OK to let him work on the French translation
18:38:58 <JohnR> I'm happy to help translators to use calenco/xxe for this
18:39:07 <marja> the French community is very large
18:39:19 <obgr_seneca> JohnR: I will send a mail to i18n and ask them
18:39:36 <lebarhon> why the screenshots with the beta title ?
18:39:40 <obgr_seneca> those wanting to do it can contact you
18:39:45 <JohnR> The main thing is not to let the other languages deviate from the EN Master
18:40:01 <obgr_seneca> ?
18:40:05 <JohnR> lebarhon: that gets fixed at last moment
18:40:16 <marja> lebarhon: the screenshots won't go in installer..... and they'll be replaced when Mga2stable is out
18:40:18 <JohnR> ob yep
18:40:41 <marja> JohnR: if we don't want any deviation, no text can be translated yet
18:40:43 <JohnR> marja: no, when the isos are being prepared is better
18:41:11 * marja thinks translation can't be done before we are sure the pages are correct
18:42:09 <JohnR> marja: that dpends on what the developers of drakx do in the next 3 weeks ;-) - They change something and we have to catch up (yet again) :-)
18:42:10 * marja wanted to let lebarhon start with it, because he'll know when something is wrong and won't translate a mistake
18:42:40 <leuhmanu> JohnR: we are in devlopment freeze :)
18:42:46 <lebarhon> so much nonor !
18:42:52 <JohnR> It has always been very difficult to freeze drakx
18:43:09 <JohnR> lebarhon: nonor?
18:43:19 <marja> JohnR: honor ;)
18:43:19 <lebarhon> honor, sorry
18:43:26 <JohnR> :-)
18:43:56 <JohnR> marja: we have to assume drakx will not change and carry on regardless,
18:44:00 <marja> OK, so what do we do.... obgr_seneca you're going to mail i18n anyway, I think?
18:44:50 <obgr_seneca> You tell me :D
18:45:07 <obgr_seneca> I can mail them and ask to contact John, if they want to work on it
18:45:08 <obgr_seneca> Ok?
18:45:24 <JohnR> I suggest we concentrate on the major languages, en, fr, nl, es and de
18:45:35 <marja> obgr_seneca: good idea, but please add that the pages can still be changed
18:45:47 <obgr_seneca> will do
18:46:04 <marja> obgr_seneca: they haven't been proofread yet, and some haven't been written or aren't finished
18:46:07 <marja> obgr_seneca: thx
18:46:24 <JohnR> I'm prrofing as I see them updated
18:46:30 <JohnR> proofing ..
18:46:58 <marja> #action obgr_seneca will mail i18n about translating
18:47:01 <lebarhon> I can have a look
18:47:01 * obgr_seneca hates release...
18:47:10 <marja> #undo
18:47:10 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Action object at 0x839d5ec>
18:47:13 <JohnR> Please people if you update a module do increment the revision flags
18:47:20 <marja> #action obgr_seneca will mail i18n about translating the help files for installer
18:48:10 <marja> #info JohnR is willing to help the translators get used to xxe/calenco
18:48:33 <JohnR> obgr_seneca: in you mail please ask them to join doc ml as well - this keeps everyone on the same page :-)
18:48:56 <marja> #action obgr_seneca will also tell the translators that the EN pages are still under construction
18:48:59 <obgr_seneca> ok
18:49:08 <marja> #chair obgr_seneca
18:49:08 <Inigo_Montoya`> Current chairs: marja obgr_seneca
18:49:48 <marja> #action obgr_seneca will also ask the translators to join doc-discuss ml
18:50:00 <barjac> JohnR: How is that done (rev flag)- I notice mine seem to be but I didn't do anything to ensure it ?
18:50:13 <marja> any more about this subject?
18:50:50 <JohnR> barjac: just increment the "revision="x" to x+1
18:51:08 <marja> #topic How formal or informal should our official documentation be
18:51:40 <marja> I just saw there was a reply from kbulgrien on the ml, but I didn't find time yet to read it
18:51:52 <marja> did anyone else read it?
18:52:08 <lebarhon> yes, it is sensible
18:52:35 <JohnR> marja: I'm not sure 'formality" is needed for the installer help - it needs to simple - as per kbulgriens mail
18:52:43 <barjac> yes I agree
18:52:53 <marja> lebarhon: JohnR barjac thx :)
18:53:07 * marja will read it tomorrow
18:53:10 <simonnzg> Yes. My observation is: How much like "Technical Documentation" do we what the XML documentation to be?
18:53:33 <JohnR> kiss :-)
18:53:39 <marja> simonnzg: thx
18:54:02 <simonnzg> I have no objection to Kevin's suggestions, but I also rather like a relaxed style. Not TOO relaxed, but referring to one's installation as "your Mageia" strikes me as acceptable.
18:54:02 * Led43_mag2 agrees with KISS
18:54:15 <JohnR> echo
18:54:20 <simonnzg> :-x
18:54:42 <marja> nice, everyone agrees :)
18:55:13 <simonnzg> Just so longas NOBODY starts a paragraph with "It is foreseen that..."
18:55:28 <JohnR> lol!
18:55:47 <marja> who can write a nice simple summary of what is decided?
18:55:59 <JohnR> simonnzg: You expect that maintainer to write docs as well ? :-)
18:56:29 * JohnR tries
18:56:35 <marja> JohnR: thx :)
18:56:52 <simonnzg> It never ceases to amaze me that a programmer is sometimes almost incapable of expressing himself in writing.
18:57:07 <marja> JohnR:  where are you going to write it?
18:57:41 <JohnR> "Help texts should be written in a simple direct manner so that the user is given sufficent information to continue with his/her install"
18:57:53 <marja> great :)
18:58:02 <simonnzg> Didn't Oliver write something on the wiki about how wiki documents will be written? Isn't that a good place to go?
18:58:28 <marja> #agreed Help texts should be written in a simple direct manner so that the user is given sufficent information to continue with his/her install
18:58:38 <simonnzg> 'Just press "OK" and don't worry about all the words an' stuff..'
18:58:53 <barjac> hehe :)
18:58:54 <marja> simonnzg: ouch, I forgot.... obgr_seneca?
18:59:04 <JohnR> simonnzg: I think the wiki addresses different "clients" - yes?
18:59:06 <marja> simonnzg: lol
18:59:39 <simonnzg> The wiki MUST be relaxed and even irreverent..
18:59:40 <obgr_seneca> oups?
18:59:46 <obgr_seneca> did I miss anything?
18:59:58 <JohnR> My point is that you can't easily look at the wiki while installing?
19:00:09 <obgr_seneca> I'm doing about four things in parallel right now, and I am a man...
19:00:18 <marja> obgr_seneca: simonnzg thought you had written something in the wiki about how documents should be written
19:00:25 <obgr_seneca> I did?
19:00:25 <simonnzg> https://wiki.mageia.org/en/Wiki_and_Documentation
19:00:33 <Led43_mag2> JohnR: not if you are installing on your only pc
19:01:04 <marja> obgr_seneca: apparently not ;)
19:01:06 <JohnR> led43: yes, that's what I meant too :-)
19:01:40 <marja> anything more about this subject?
19:01:58 <JohnR> no here
19:02:48 <JohnR> I have a question though :-)
19:02:54 <simonnzg> All very hard as I'm also watching TV - programme about Pub Archaeology. Two things I like in one programme!
19:02:55 <marja> simonnzg put the link to the installer help here https://wiki.mageia.org/en/Installing_Mageia#Traditional_installer
19:03:05 <marja> JohnR: OK, go ahead
19:03:35 <simonnzg> I have an XML Export of the original installer help from the wiki. I truncated the page and added a link to Maja's pages there as well.
19:04:04 <JohnR> Camille posted about an update to Calenco on Monday, did everyone understand about clearing their caches?
19:04:37 <simonnzg> JohnR: In about 11 hours, I'll ask you about that.
19:04:45 <JohnR> ;)
19:04:54 <marja> good question... I didn't understand half of it, but I use a different java
19:05:55 <marja> #info there was a calenco update last monday, if you are having problems using calenco since then, make sure you clear your caches
19:05:56 <JohnR> ahhh, those of you having some hassles with xxe addon - you really do need to be using sun-java not openjdk
19:06:42 <JohnR> yes, Iknow it's messing getting rid of icedtea ... :-)
19:06:50 <JohnR> bah!!
19:07:02 <JohnR> yes, I know it's messy getting rid of icedtea ... :-)
19:07:07 <JohnR> better!
19:07:30 <marja> grenoya: should I set the topic to sphinx?
19:07:42 <grenoya> I did nothing /o\
19:07:52 <barjac> JohnR Does everyone else get 2 java log-in dialogs and then another log-in when starting xxe from Calenco
19:07:55 <simonnzg> Aaargh! Another markup to learn!
19:08:14 <JohnR> barjac: yes, that's kinda normal - it's a pain
19:08:24 <marja> grenoya: no problem... and we have the xxe add-on now, maybe thanks to your proposal to test sphinx :)
19:08:25 <barjac> JohnR: OK ;)
19:08:26 <grenoya> simonnzg: for sphinx ?
19:08:34 <simonnzg> grenoya: Yes
19:08:41 <marja> barjac: often
19:08:49 <grenoya> I feel it easier than any wiki markup
19:09:35 <grenoya> simonnzg: and nothing has been decided yet (has I still have nothing to show)
19:09:36 <simonnzg> grenoya: I'm waiting for the Sphinx add-on for Mediawiki. ;-)
19:09:44 <marja> grenoya: simonnzg  camil said sphinx is easy to use, but then making the publications is more of a hassle
19:10:00 <JohnR> I'll be testing spinx this weekend with a 22000-word RST document
19:10:05 <simonnzg> marja: What's wrong with Tex?
19:10:07 <grenoya> i used it for other things
19:10:07 <Led43_mag2> got an url for sphinx
19:10:17 <JohnR> simonnzg: 350mb
19:10:30 <grenoya> and I want to do a test and show you before any decision
19:10:41 <simonnzg> JohnR: Ouch.
19:10:51 <marja> JohnR: test history too, please..... the history in calenco saved us already a few times so far
19:10:54 <JohnR> led43: http://sphinx.pocoo.org/intro.html
19:10:55 <Magbot> [ Introduction Sphinx 1.1.3 documentation ]
19:11:14 <Led43_mag2> JohnR: ta
19:11:26 <marja> can we end the meeting?
19:11:34 <simonnzg> marja: Yes.
19:11:57 <JohnR> at this time I don't see any advantage over calenco/xxe and xml :-)
19:11:58 <Led43_mag2> ok here
19:12:17 <marja> #endmeeting