19:02:36 <obgr_seneca> #startmeeting
19:02:36 <Inigo_Montoya> Meeting started Tue Dec 13 19:02:36 2011 UTC.  The chair is obgr_seneca. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:36 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:39 <obgr_seneca> Hi all
19:02:50 <marja> hi :)
19:03:04 <obgr_seneca> #topic calenco and installer docs
19:03:09 <JohnR> greetings all, sorry I'm late
19:03:12 <obgr_seneca> #chair marja
19:03:12 <Inigo_Montoya> Current chairs: marja obgr_seneca
19:03:57 <obgr_seneca> Hi JohnR
19:04:08 <marja> JohnR: hi :)
19:05:03 <obgr_seneca> So, I did send mails to wobo, thierry and blino about the installer docs
19:05:23 <obgr_seneca> and as you might have seen, I invited wobo and blino to tonight's meeting
19:06:12 <obgr_seneca> Now here are the answers:
19:06:42 <obgr_seneca> Thierry and wobo said, it would be best to install into a virtual machine and look what needs to be documented
19:06:48 <obgr_seneca> And then just do it :/
19:07:11 <simonnzg> Helpful!
19:07:11 <obgr_seneca> Now, that is an answer I could have given myself :(
19:07:49 <marja> and what did blino say?
19:07:53 <simonnzg> JohnR and I played with MDV2005 and the install help is compiled into the installer somewhere. Nothing to do with the docs we have.
19:08:02 <obgr_seneca> I will ennael if she can provide us with an iso where the "help" buttons are not disabled so we can at least look, what needs to be done
19:08:08 <obgr_seneca> But after alpha2
19:08:14 <obgr_seneca> marja: no answer from him
19:08:20 <marja> :(
19:08:56 <obgr_seneca> simonnzg: so you are saying, we don't have anything to work with?
19:09:01 <JohnR> I tried installing 2005le in vm, failed, ide interfaces not recognised - I'm looking for an old machine
19:09:27 <simonnzg> No. I'm saying what we have to work with isn't the help that pops up if you press the "Help" button whilst installing...
19:09:29 <JohnR> I do have sshots of first 2 help screens
19:10:10 <obgr_seneca> Hmpf
19:10:40 <obgr_seneca> So we do need some up to date installer that does have the help buttons
19:10:42 <simonnzg> All we need is the source code for the MAG2a installer!
19:10:53 <JohnR> During my discussion with Wobo, we established that the content of the Quick Start booklet could be used as a basis for the help screens
19:10:54 <simonnzg> I'm sure all the hooks are there
19:11:04 <obgr_seneca> simonnzg: That's in svn
19:11:23 <simonnzg> I'll have to go and take a look. See what I can find.
19:11:27 <obgr_seneca> but there's much in svn and I wouldn't know, where to look exactly
19:11:37 <simonnzg> I would. ;-)
19:11:48 <marja> simonnzg: great :)
19:11:52 <obgr_seneca> http://svnweb.mageia.org/soft/
19:11:53 <Magbot> [ [soft] Index of / ]
19:14:07 <marja> simonnzg: you need the source code for the Mga2alpha installer + you need to know where the hepl buttons were?
19:14:22 <marja> s /hepl /help
19:14:39 <doktor50001> sorry for the interruption, pidgin is behaving a little bit weird under windows
19:15:05 <obgr_seneca> windows, you mean that unos?
19:15:12 <doktor50001> marja: no, we need to know where the help in the installer comes from, IIUC?
19:15:18 <marja> doktor50001: is OK, as long as you are doktor5000
19:15:32 <simonnzg> It's not going to take long to find.  Whilst I'm no programmer, I can usually find what I want.  Maybe not now - later.
19:15:46 <obgr_seneca> ok
19:16:07 <obgr_seneca> #action simonnzg find the relevant parts in the installer for the help buttons
19:16:37 <simonnzg> OK
19:17:38 <obgr_seneca> so, I have to admit, I still didn't really look into calenco
19:17:47 <obgr_seneca> I have to find some more hours a day
19:18:21 <JohnR> obgr_seneca: Here, have a bunch of mine :-)
19:18:29 <marja> :)
19:18:37 <obgr_seneca> JohnR:
19:19:01 <obgr_seneca> Perhaps I should move to the polar regions, there the day is half a year
19:19:06 <obgr_seneca> at least in summer
19:19:11 <marja> :)
19:19:16 <JohnR> :-)
19:20:09 <obgr_seneca> And I'll sleep all winter :D
19:20:31 <marja> hibernate :) :)
19:21:19 <obgr_seneca> ok, JohnR wobo said he talked to you about all that stuff?
19:21:28 <JohnR> obgr_seneca: yes
19:21:50 <JohnR> Question?
19:22:24 <marja> JohnR: wobo mailed that he had told you his ideas
19:22:26 <obgr_seneca> I don't know, I've never worked on something like that and feel a bit stupid
19:22:54 <obgr_seneca> I wouldn't know, where to start, what to do and so on...
19:23:05 <JohnR> ok, let me try to explain:
19:24:23 <JohnR> Calenco is basically like a svn repository, where all the files are stored with versionning so you can track changes
19:24:41 <JohnR> bear with me - slow typer this morning'
19:24:47 <obgr_seneca> ok
19:24:52 <obgr_seneca> slow reader this evening
19:24:58 <marja> :)
19:25:51 <grenoya> :)
19:26:15 <grenoya> (and slow reacting /o\)
19:26:21 <marja> ginz
19:26:28 <marja> s /ginz /grinz
19:26:42 <JohnR> All the files on there are text files or image files, Each "manual" file collects the various "segments' and joins then together to produce the final document in a variety of formats (pdf, html etc)
19:27:59 <obgr_seneca> So we would have to replace the old images by new ones and adapt the texts?
19:28:02 <JohnR> the segments or modules are the bits we write or modify, You may use any text editor to do this, I used vi for the first 6 or so years, now I use xxe
19:28:12 <JohnR> obgr_seneca: yes, exactly
19:28:27 <obgr_seneca> ok
19:28:44 <obgr_seneca> i think we should use screenshots from alpha2 as soon as it's released
19:28:55 <marja> yep
19:29:04 <obgr_seneca> but we must replace them once artwork came up with something new :/
19:29:16 <JohnR> Calenco is webdav enabled so if you have a webdav ebabled editor it makes things a lot easier
19:30:11 <JohnR> Ok, sidetrack - Images need to be taken (or massaged) into 1024x768 maximum sizes
19:30:48 <JohnR> and you can use gimp etc for that
19:30:53 <marja> #info  Images need to be taken (or massaged) into 1024x768 maximum sizes
19:30:54 <obgr_seneca> #action replace image files on calenco by alpha2 ones, as soon as released
19:31:04 <obgr_seneca> #action adapt texts to those new images
19:31:12 <grenoya> obgr_seneca: for what I see, we also will have to write new things
19:31:15 <JohnR> best you all ask me questions :-)
19:31:18 <obgr_seneca> #action replace images again, when new artwork is there
19:31:35 <JohnR> grenoya: yes, more than likely
19:31:55 <grenoya> I saw a module "IRC" but behind, it was only talking about xchat !
19:31:58 <obgr_seneca> #info images may be 1024x768 maximum
19:32:25 <obgr_seneca> grenoya: yes, we should talk about quassel at least
19:32:59 <grenoya> and irssi :D
19:33:15 <marja> obgr_seneca: can I undo my info tag?
19:33:15 <JohnR> grenoya: If you can locate a copy of Mandriva/Mandrake Definative Guide, it will you a very good idea of what is actually available to us
19:33:23 <grenoya> irc was just an example of what I saw
19:33:29 <obgr_seneca> grenoya: not the target group for such manuals, don't you think :D
19:33:52 <sebsebseb> hi
19:33:56 <marja> hi sebsebseb
19:33:58 <grenoya> obgr_seneca: I was joking :)
19:33:59 <JohnR> We really need to concentrate on the installer at this point :-)
19:34:00 <sebsebseb> marja: hi
19:34:13 <obgr_seneca> marja: if I hadn't posted so many actions after it yes
19:34:15 <obgr_seneca> sorry
19:34:15 <grenoya> JohnR: you're true.
19:34:22 <obgr_seneca> but we can undo mine
19:34:23 <sebsebseb> Hi everyone a bit late here, but hi
19:34:37 <obgr_seneca> #undo
19:34:37 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x84f122c>
19:34:39 <JohnR> obgr_seneca: don't undo - it's all useful
19:34:52 <JohnR> too late :-)
19:34:54 <marja> JohnR: it was already there ;)
19:35:30 <obgr_seneca> JohnR:  <marja> #info  Images need to be taken (or massaged) into 1024x768 maximum sizes
19:36:14 <grenoya> would it be possible to split the work between us once we will have list the work to do?
19:36:37 <obgr_seneca> grenoya: would be a good idea I think
19:36:58 <grenoya> because as long as I'll have internet just during week-end, it'll help me to have a todolist to concentrate on :)
19:37:01 <JohnR> So I think the best scheme for a start is to run thru theinstaller and note what needs to be documented, (Seriously _ don't think the basic installer has changed much in several years)
19:37:15 <JohnR> gre YES!!!
19:38:03 <obgr_seneca> JohnR: I use Mandrake since 7.2 I know, there weren't that many fundamental changes
19:38:25 <JohnR> BTW if you haven't emailed me for credentials - ......
19:38:52 <JohnR> obgr_seneca: yes exactly
19:38:55 <obgr_seneca> #action anyone who hasn't emailed John for calenco credentials, do so
19:39:07 <sebsebseb> JohnR: yep I think I'll email you now for access, hadn't done it already for whatever reasons
19:39:35 <obgr_seneca> #info john at neodoc dot biz
19:40:27 <JohnR> simonnzg: I saw you had modified one file (at least) on Calenco, did you have any hassles?
19:40:41 <simonnzg> No.
19:40:50 <JohnR> easy enough?
19:41:11 <simonnzg> Mind you, I think all I did was stab at changing Mandriva to Mageia and added a missing word on one page.
19:41:28 <simonnzg> It's just like using an HTML editor.
19:41:28 <marja> :)
19:43:12 <JohnR> We may need to be a bit careful using s/<smtg>/that/g    without looking at what's around it, but we should all be aware of copyright attributions :-)
19:43:25 <obgr_seneca> yep
19:43:53 <obgr_seneca> Please do remember: Copyright notes MUST stay as they are
19:44:16 <marja> #info Copyright notes MUST stay as they are
19:44:21 <obgr_seneca> The GPL explicitely states that (among other judicial requirements)
19:44:53 <obgr_seneca> I already had a hard time last year explaining the i18n folks they were not to replace those in their languages :/
19:45:09 <marja> lol
19:45:58 <JohnR> At some point we need to determine which languages we'll produce for the ISOs too
19:46:04 <marja> simonnzg: did you use an XML editor?
19:46:26 <grenoya> JohnR: btw who will do the translations ?
19:46:36 <obgr_seneca> JohnR: we can begin with the ones we have available in doc team or ask i18n for help
19:47:12 <simonnzg> marja: Yes, XXE
19:47:22 <obgr_seneca> I'd say, german, french, spanish, portuguese (pt_BR) and perhaps greek i18n teams should be up to it
19:47:27 <JohnR> grenoya: that's a good question :-) At Mandriva, we had a whole team of people from various locales
19:48:03 <obgr_seneca> JohnR: the idea was not to have several independent translator teams but use the existing i18n people
19:48:04 <simonnzg> If you're just chaning ing a bit of text you can use the Calenco source viewer, but you have to be careful not to add or edit markup if you don't know exacly what you're doing.
19:48:29 <JohnR> I think Calenco has source for EN, ES, DE, FR, and PT - I need to look
19:50:34 <JohnR> I'll take a look thru my old mdk/mdv archives and see who else, and which languages got covered, but only a select few got docs in rpm formats
19:51:09 <obgr_seneca> All: @translations: In my eyes it would be best, first to have an English master version before starting on localized ones
19:51:42 <marja> I agree
19:52:04 <JohnR> as a side note, I was/am an EN language proofreader - the intracacies of XML are beyond me :-)
19:52:20 <grenoya> obgr_seneca: ok for me
19:52:26 <JohnR> obgr_seneca: yes
19:53:28 <marja> JohnR: intricaties?... complexity?
19:53:59 <obgr_seneca> #info let's first concentrate on the English docs, localized versions may come later
19:54:06 * JohnR has an appointment 45km away at 2100UTC, so I can't be here too much longer :-)
19:54:12 <JohnR> marja: yes
19:54:23 <obgr_seneca> JohnR: Ok, thanks for being here then
19:54:39 <marja> JohnR: have a nice day
19:54:55 <JohnR> not going just yet - 15 mins or so :-)
19:55:01 <obgr_seneca> ok
19:55:44 <simonnzg> JohnR: I think /drakx/trunk/perl-install/install/help is the directory we're looking for.
19:56:18 <JohnR> OK, another suggestion, let's place questions, hints etc on doc-discuss ML so's everyone can see what and how things get achieved :-)
19:56:23 <JohnR> simonnzg: looking
19:56:27 <simonnzg> Just found a note in help_xml2pm.pl : # IMPORTANT: Do not edit this File - It is automatically generated
19:56:27 <simonnzg> 79     # from the manuals !!!
19:56:27 <simonnzg> 
19:56:34 <obgr_seneca> JohnR: yep
19:57:08 <JohnR> simonnzg: yes, I think you got it :-)
19:57:32 <simonnzg> It's in PERL.  Awww. Sweeet.
19:57:51 <obgr_seneca> So, what about the following suggestion:
19:58:25 <obgr_seneca> Directly after alpha2 I'll ask for  some iso _WITH_ the help buttons
19:58:37 <obgr_seneca> so we can start with those installer helps
19:58:44 <JohnR> yes!!!!!!!!
19:58:45 <obgr_seneca> and
19:59:08 <obgr_seneca> after alpha2 we are beginning the replacing of the images with new ones from alpha2
19:59:18 <obgr_seneca> coordinating this on the ml
19:59:19 <marja> OK
19:59:32 <JohnR> yes!!!!!!!! :-)
19:59:38 <grenoya> ok :)
19:59:39 <obgr_seneca> then we can create a wiki page for those todo lists, grenoya was talking about
19:59:53 <JohnR> good idea
19:59:55 <marja> :)
19:59:58 <grenoya> :)
20:00:17 <obgr_seneca> I'm always astonished about my ideas myself :D
20:00:27 <JohnR> :-)
20:00:39 <simonnzg> Here's one:  The help.pl source says at the beginning:
20:00:46 <simonnzg> # IMPORTANT: Do not edit this File - It is automatically generated
20:00:46 <simonnzg> #            from the manuals !!!
20:00:46 <simonnzg> #            Write a mail to <contact@mageia.org> if
20:00:46 <simonnzg> #            you want it changed.
20:00:55 <obgr_seneca> #agreed directly after alpha2 ask for an iso with the help buttons
20:01:05 <simonnzg> Now... Do we wnat that address changed to Doc Team??
20:01:20 <obgr_seneca> #agreed after alpha2 replace images in calenco by new ones, coordinate on the ml
20:01:28 <JohnR> simonnzg: yes, I think so
20:01:46 <obgr_seneca> #agreed after that create a wiki page with todos for everyone so we don't do the same work twice
20:02:12 <obgr_seneca> Did I forget anything?
20:02:42 <marja> last week we were talking about looking for another XML editor
20:03:04 <marja> did anybody find something better than we have?
20:04:01 * grenoya did not look for it /o\
20:04:21 <simonnzg> Well, there's <oXygen/>
20:04:27 <JohnR> in my view the best is xxe, but the problem is that we really need the professional version with it's extras ....
20:04:29 * obgr_seneca neither, sorry
20:04:59 <JohnR> And the pro-version comes at a cost :-((((((((((((
20:05:46 <obgr_seneca> JohnR: There isn't any good open source one?
20:05:49 <simonnzg> Oygen is hundreds and hundreds of $$$, but the Acedemic non-Commercial version is a mere $64
20:06:14 <simonnzg> No. There are no good open source ones I've found.  I did find one that looked promising. MM. where did I put it..
20:06:38 <obgr_seneca> Aren't the big IDEs capable of xml?
20:06:44 <obgr_seneca> netbeans or eclipse?
20:07:17 <JohnR> The personal version of xxe will do what we want, however it means there has to be some double handling
20:07:29 <simonnzg> EditX is available. There's a free version: http://free.editix.com/ it *seems* to support WebDAV
20:07:31 <Magbot> [ Free XML Editor ]
20:08:00 <obgr_seneca> JohnR: What do you mean by double handling?
20:08:16 <JohnR> BTW - I confirm that Calenco IS webdav enabled
20:08:32 <JohnR> ob, download. edit upload
20:08:37 <obgr_seneca> ah, ok
20:08:44 <simonnzg> If you use the personal version of XXE, then you need to mount the Calenco repository as a WebDAV share on YOUR file system.  Of course, if you accidentally delete things you delete it off the repository as well and Calenco may not be able to version it so it's gone.
20:09:01 <obgr_seneca> oups
20:09:05 <JohnR> simonnzg: exactly
20:09:29 <grenoya> :\
20:09:32 <simonnzg> You have to be VERY careful or Oliver will be around with his box of matches... :-)
20:09:43 <obgr_seneca> it's not mine
20:09:58 <obgr_seneca> I borrowed it from ennael
20:10:04 * JohnR close behind with a BIG whip
20:10:31 <marja> JohnR: isn't it possible to copy it to a new version before editing?
20:11:12 <JohnR> marja: the versioning is internal to Calenco, but yes I think it's possible
20:11:24 <sebsebseb> JohnR: Ok email sent :).
20:11:42 <JohnR> sebsebseb: ok, thx, I'll sort it later today
20:12:16 <obgr_seneca> JohnR: whiping burning people seems a bit inhuman to me :D
20:12:24 <JohnR> ok, folks, time I hit the road, I'll leave this channel open and read back later,
20:12:37 <marja> JohnR: would it be possible to copy everything to a new version before we start to work on it, so the original is untouched
20:12:39 <marja> OK
20:12:48 <marja> JohnR: see you later
20:12:49 <JohnR> marja: yup
20:12:56 <JohnR> bye all
20:13:01 <obgr_seneca> see you
20:13:16 <simonnzg> You know: I think we need to ask if anyone is willing to maintain an XML editor for Magea.
20:13:18 <obgr_seneca> ok
20:13:32 <obgr_seneca> simonnzg: as a package?
20:13:35 <simonnzg> JohnR: Have a good day.
20:14:07 <simonnzg> obgr_seneca: Yes.  Perhaps.  I looked for XML editors and not a lot sprung out of the woodwork except EMACS.
20:15:06 <obgr_seneca> emacs is not an editor, it's hell
20:15:13 <grenoya> :))
20:15:16 <marja> simonnzg: what does "spring out of the woodwork" mean
20:15:32 <obgr_seneca> simonnzg: There are two packagers among you, just find one, that is redistributable...
20:15:37 <simonnzg> EMACS is you FRIEND (or is that FIEND)
20:16:01 <grenoya> obgr_seneca: only 2 ?
20:16:16 <obgr_seneca> you and me
20:16:22 <obgr_seneca> who else in doc team?
20:16:25 <grenoya> and doktor50001
20:16:33 <marja> and akien
20:16:42 <obgr_seneca> oups
20:16:47 <simonnzg> marja: Aha. It means that I checked very hard and only one worm was visible...
20:16:50 <grenoya> marja: i'm not sure for akien
20:16:53 <obgr_seneca> I know Florian for so long, I forgot abbout him
20:17:12 <obgr_seneca> akien is my newest padawan
20:17:13 <marja> akien is learning, I think
20:17:29 <grenoya> obgr_seneca: ah ok, ididn't know :)
20:17:55 <grenoya> so he did not asked his own brother :)
20:18:10 <marja> grenoya: of course not!
20:18:15 <obgr_seneca> we were talking about it and so it came to being me
20:18:36 <obgr_seneca> as he is also i18n deputy leader we do "know" each other
20:18:39 <simonnzg> marja: Etymology: based on the idea of insects that suddenly come out from under boards in a house where they have been hidden
20:18:51 <marja> simonnzg: thx
20:19:17 <obgr_seneca> ok
20:19:27 <obgr_seneca> so let's do one more action and end the meeting?
20:19:39 <marja> fine with me
20:19:42 <simonnzg> marja: I have a feeling that there's an equivalent in some languages to do with mice and wood stores!
20:20:01 <obgr_seneca> #action all: tell one of the packagers among you about a good redistributable xml editor
20:20:23 <obgr_seneca> #info and they will package it
20:20:28 <grenoya> simonnzg: for packaging, it will depend of the language used to code the editor
20:21:08 <obgr_seneca> #endmeeting