19:14:07 <obgr_seneca> #startmeeting
19:14:07 <Inigo_Montoya> Meeting started Tue Dec  6 19:14:07 2011 UTC.  The chair is obgr_seneca. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:14:07 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:14:17 <obgr_seneca> Good evening ladies and gentlemen
19:14:41 <simonnzg> Good evening Mr. Chairman.
19:14:45 <obgr_seneca> First of all let's ping a few people:
19:15:01 <sebsebseb> Hello
19:15:19 <obgr_seneca> doktor5000: grenoya: JohnR: leuhmanu: Skiper: anybody here for the meeting?
19:15:28 <leuhmanu> hello
19:15:33 <grenoya> obgr_seneca: hi :)
19:15:33 <leuhmanu> yes and no :)
19:15:49 * sebsebseb will be a new member of this team :)
19:15:51 <obgr_seneca> leuhmanu: I take the first half of your answer :D
19:15:56 <marja> lol
19:16:14 <obgr_seneca> #topic team status
19:16:16 <sebsebseb> marja: at me? :D
19:16:25 <obgr_seneca> so, we have a new guy joining doc team
19:16:35 <obgr_seneca> sebsebseb: welcome aboard
19:16:44 <sebsebseb> obgr_seneca: Thanks :)
19:16:49 <marja> sebsebseb: no, at "I take the first half of your answer :D"
19:16:55 <sebsebseb> ok
19:16:59 <obgr_seneca> marja: now about you
19:17:12 <marja> I'm here
19:17:54 <obgr_seneca> As I understood you in one of our last conversations you want to draw back from doc team, at least partly?
19:17:55 <marja> but I feel I can't do much for the new documentation, without having a good idea of what was in it before
19:18:52 <leuhmanu> (/me is not really in the doc team)
19:18:56 <marja> I can't help with the new documentation, if I don't learn the old documentation first... it is too new for me
19:19:09 <sebsebseb> leuhmanu: Oh?
19:19:25 <obgr_seneca> leuhmanu is a spy from qa team
19:19:40 <leuhmanu> spy ?
19:19:41 <marja> I've never known it existed, all I had was an book that came with Mandrake 9
19:19:53 <sebsebseb> obgr_seneca: heh
19:20:07 <marja> so I'm overwhelmed by all the information there is
19:20:20 <obgr_seneca> leuhmanu: ok, not spy, let's say qa team rep?
19:20:20 <marja> I need to let that sink in, before I can help
19:20:33 <obgr_seneca> marja: as I told you, it's ok
19:20:46 <sebsebseb> marja: oh Mandriva documentation never seen any of that or not much
19:20:46 <leuhmanu> obgr_seneca: more bugsquad :)
19:21:11 <marja> sebsebseb: no, I didn't know it was there
19:21:16 <obgr_seneca> leuhmanu: oh yes, I mixed them up
19:21:24 <obgr_seneca> ok
19:21:35 <grenoya> marja: I did not either, but I am not sure it is a problem, because we have another pov
19:21:48 <sebsebseb> there doesn't seem to be much documentation for Mageia at the moment
19:22:07 <obgr_seneca> sebsebseb: actually almost none
19:22:09 <marja> grenoya: what is "pov"
19:22:16 <grenoya> point of view
19:22:36 <grenoya> marja: we both have a 'new eye'
19:22:44 <sebsebseb> Ubuntu has very good help pages for example, altough I think quite a few are a bit outdated now, but still.
19:22:53 * grenoya has very poor english tonight /o\
19:22:56 <obgr_seneca> we have some old Mdv doc we can use, but it's from 2007 or 2008 because the newer Mdv doc is under another license
19:23:02 <marja> grenoya: my "new eye" sees less then there is to see
19:24:10 <obgr_seneca> marja: It#s ok, if you do less, if you try to leave us, a certain president of the foundation did give me the matches...
19:24:25 <obgr_seneca> ...and we could make a wonderfull big fire to burn you :)
19:24:38 <simonnzg> First job with the documentation is to understand what it is.
19:24:56 <sebsebseb> simonnzg: Indeed
19:24:59 <simonnzg> Next job is to remove what isn't necessary (a lot of it, actually)
19:25:10 <leuhmanu> well anyone can make doc
19:25:29 <leuhmanu> and I have see a lots a one on the english forum tonight
19:25:33 <obgr_seneca> ok
19:25:40 <obgr_seneca> #topic calenco
19:25:43 <simonnzg> The documentation on the Calenco server is, for wnat of a better name, source code used to create documenation in  various formats.
19:26:03 <obgr_seneca> simonnzg: exactly
19:26:13 <sebsebseb> obgr_seneca: simonnzg Yeah what is the documentation team? Making the help pages for the distro? Right?
19:26:28 <simonnzg> Not really.
19:26:31 <sebsebseb> for the website and so on?
19:26:31 <obgr_seneca> sebsebseb: we have two jobs
19:26:52 <simonnzg> All documentation, not just help pages. Mind you, most of it IS help pages.
19:27:13 <obgr_seneca> first: create (or adapt) the partly existing installer documentation
19:27:23 <obgr_seneca> second: create documentation in the wiki
19:27:42 <obgr_seneca> and third: (I forgot that) keep the wiki "clean"
19:27:47 <sebsebseb> ok :)
19:28:18 <marja> obgr_seneca: fine... did you talk to Thierry about the help in installer?
19:28:47 <obgr_seneca> To be honest, I didn't find the time to look into the stuff at calenco
19:29:06 <obgr_seneca> did anyboday else?
19:29:20 <marja> a very little bit
19:29:27 <simonnzg> Well, of course.
19:29:45 <obgr_seneca> simonnzg: I name you todays's expert
19:29:56 <marja> I tried something that didn't work.. I wanted to see a printable  version
19:30:16 <marja> not the code, but what it would look like
19:31:28 <marja> "
19:31:29 <marja> No publications for the selected file.
19:31:31 <marja> Please ask an administrator to create publications for this file.
19:31:32 <simonnzg> Aha, that's the problem (or the advantage) of XML. It looks like what you wnat it to look like, therefore there's no need to see it like that.
19:31:35 <sebsebseb> I think there should be some documentation for people who want to  for example dual boot Mageia so with Grub 0.97 (and distros patches), and Grub 2 so Ubuntu for example, something I been thinking about testing out soon, and then maybe start work on some sort of documentation between the two versions, becasue I know there can be issues between the two versions, and I can see many people wanting to do this kind of thing in the future.
19:31:47 <sebsebseb> and now going back more on topic, what's Calenco?
19:32:26 <simonnzg> Calenco is a sort-of collaborative, web based XML repository. A bit like an XML WKi engine.
19:33:05 <obgr_seneca> sebsebseb: you can always put documentation like that in the wiki
19:33:25 <simonnzg> Imagine a directlry full of XML documents, snippets, paragraphs, plus pictures and other stuff.  Calenco allows you to organise this into books and manuals or other documents, reusing things as you go along. Bad description.
19:33:30 <obgr_seneca> Calenco is the software neodoc is using to create documentation
19:34:02 <sebsebseb> obgr_seneca: Yep thought so :) cool :)
19:34:19 <obgr_seneca> They did the mandriva documentation for years and since at least three neodoc people are Mageia members, we can use it for free
19:34:29 <simonnzg> Try www.neodoc.biz it's all there.
19:34:32 <simonnzg> -ish
19:35:22 <simonnzg> That's me in the orange chair on the home page.  Not really. But I feel like that sometimes.
19:35:50 <simonnzg> Actually, it may be Oliver.
19:36:41 <obgr_seneca> ok
19:36:53 <obgr_seneca> I had hoped john would be here
19:37:10 <obgr_seneca> to tell us a bit more about working with calenco
19:37:22 <sebsebseb> Which John?
19:37:29 <simonnzg> I'm assuming he's finally getting some sleep.
19:37:59 <simonnzg> I can tell you a little.
19:38:01 <marja> sebsebseb: JohnR, he helped to make the Mandriva documentation
19:38:07 <obgr_seneca> Only because he's on the other side of the world :D
19:38:36 <sebsebseb> thought it was the UK John
19:38:40 <sebsebseb> or well yeah JohnR
19:38:56 <simonnzg> That's how yourun a 24/7 operation. It's cheaper than paying people to do night shift.
19:38:57 <sebsebseb> anyway the sleep thing gave it away that it was probably JohnR :D
19:39:26 <sebsebseb> simonnzg: Maybe he's waking up it's early morning there.
19:39:47 <sebsebseb> simonnzg: heh yeah
19:39:54 <simonnzg> sebsebseb: Maybe. I'm usually at work at 7am!
19:40:36 <marja> Akien: hi :)
19:40:38 <obgr_seneca> simonnzg: so what can you tell us?
19:40:40 <obgr_seneca> hi remi
19:41:11 <Akien> Hi :)
19:41:53 <simonnzg> Well, what do you want to know? I have to say that it's best if you have a look at the same time.
19:42:00 <simonnzg> Can you all log in?
19:42:12 <sebsebseb> to what calenco?
19:42:22 <sebsebseb> Is Calenco open source by the way?
19:42:29 <simonnzg> Only JohnR can create users, so some of you without logins may have to imagine you're logged in.
19:42:46 <simonnzg> Calenco isn't absolutely open, no.
19:42:48 <sebsebseb> simonnzg: yep I won't have an account yet obviously
19:43:08 <simonnzg> sebsebseb: Absolutely. You're not missing much, though.
19:43:43 * obgr_seneca is logged in
19:44:07 <sebsebseb> So Calenco helps make docuntation pages for?  the man pages of the software?  or the wiki pages? or?
19:44:53 <simonnzg> Not the WiKi
19:44:59 <grenoya> are the screenshot on the neodoc page enought ?
19:45:11 <simonnzg> grenoya: yes.
19:45:36 <grenoya> cool :) I can't do best
19:45:45 <marja> grenoya: simonnzg: I think a lot of screenshots need to be made again for mageia
19:45:59 <sebsebseb> well it says on the  page really what it does I guess, but how would Mageia use it?
19:46:13 <marja> to make the new documentation
19:46:20 <simonnzg> I'm still diggin ghtrough the archive we've inherited. It looks like the complete manual.  There are collections, like the Mandrake Move manual, sections on using
19:46:45 <sebsebseb> marja: yeah
19:46:55 <simonnzg> gnumeric, diskdrake, all that stuff. VERY detailed.
19:47:41 * marja c&p'd the source of a document to a file, first to a html file, later to xml..... but FF only makes a readable document when it is html
19:47:58 <simonnzg> I'm currently moving the defined manuals into an area called MANUALS.  This is the first thing about Calenco: you're not moving anything, just classifying it as something.
19:48:01 * marja is talking about a neodoc page
19:48:54 <simonnzg> XML is sort-of HTML anyway. HTML is a subset of SGML and XML is part of the same family. It's more akin to a typsetting language, though. You can output the XML as all sorts of stuff.
19:48:58 <simonnzg> HTML or PDF
19:49:48 <obgr_seneca> actually xhtml is a subset of html
19:50:08 <simonnzg> The thing about XML is that it's very structured.  HTML allows all sorts of floppy things to be input. XML is strict.
19:50:25 <sebsebseb> yep XML is more strict
19:50:26 <simonnzg> XHTML is Extensible HTML -
19:50:32 <sebsebseb> hence XHTML for example
19:50:48 <simonnzg> I always write my web pages in XML.
19:50:54 <sebsebseb> Oh?
19:50:57 <simonnzg> ;-)
19:51:00 <marja> I did know some html4/xhtml... but didn't use it in two years
19:51:02 <sebsebseb> XML not XHTML?
19:51:25 <simonnzg> XML. You can do it. HTML tags are valid XML
19:52:12 <simonnzg> That's really how you have to think about it when looking through the manuals on Calenco. IT's just a bunch of hideously complex web pages written in a language you think you know, but don't entirely understand.
19:52:37 <obgr_seneca> :D
19:52:40 <simonnzg> Unbreaking it isn't too much fun, either.
19:52:57 <sebsebseb> I have done website coding here and there as well :) coded a few sites, spent all the tiem coding that :D HTML and CSS, and converting HTML to XHTML even
19:53:34 <simonnzg> sebsebseb: You'll probably get the hang of XML, then. Very similar.
19:53:55 <sebsebseb> So Calenco uses XML for something, and Calenco users should know XML as a result?
19:54:20 <marja> obgr_seneca: did you find time to ask wobo?
19:54:40 <simonnzg> Now, JohnR is trying to get us to use a particular XML editor called XMLMind.  It's WYSIWYG-ish, so it should help those who simply can't apply stylesheets in their heads.
19:54:54 <marja> lol
19:54:55 * obgr_seneca forgot
19:54:56 <sebsebseb> simonnzg: yep sure with good enough reason I could learn XML
19:55:10 <simonnzg> sebsebseb: Yes, Calenco does everything in XML. Not my preference, but...
19:55:15 <marja> obgr_seneca: is OK, you'll get a new chance :)
19:55:44 <obgr_seneca> #action obgr_seneca ask wobo!
19:55:46 <sebsebseb> simonnzg: well I suppouse at  east it's a mark up language, not some sort of programming language :D so easier to do stuff with
19:56:06 <simonnzg> XML is markup. Extensible Markup Language!
19:56:21 <sebsebseb> yep exactly :)
19:56:46 <sebsebseb> anyawy at least we don't have to learn Javascript or PHP or something like that for Calenco :D
19:56:59 <simonnzg> sebsebseb: Next time you find JohnR ask him what you need to do to get a login.
19:57:02 <marja> simonnzg: thx for reminding about John's editor, I had forgotten about it
19:57:19 <sebsebseb> simonnzg: yep ok :)
19:58:28 <simonnzg> These editors are wonderful. You look at the markup and then think "I'd like this bit to be <address>" and then you find the editor won't let you do it. Grr.
19:58:49 <simonnzg> Well-formedness.
19:58:49 <marja> http://www.xmlmind.com/xmleditor/download.shtml
19:58:50 <Magbot> [ XMLmind XML Editor: Download Personal Edition ]
19:59:09 <marja> http://www.xmlmind.net/xmleditor/_download/xxe-perso-5_1_0.tar.gz
19:59:26 <simonnzg> Now, the Personal Edition will do everything except allow you to access the Calenco repository via WebDAV.
19:59:41 <Akien> This should be packaged for Mageia :)
19:59:54 <simonnzg> This MIGHT turn out to be a problem.
19:59:56 <marja> Akien: yes, pleas do it :)
20:00:03 <marja> simonnzg: why?
20:00:09 <simonnzg> I don't think we can package it for Mag. It would be nice, though!
20:00:09 <obgr_seneca> #action Akienpackage that editor for Mageia
20:00:37 <obgr_seneca> simonnzg: Why can't we?
20:00:50 <sebsebseb> Akien: looks like you just voluntered to do so :D
20:01:09 <obgr_seneca> #undo
20:01:09 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x8508bec>
20:01:12 <obgr_seneca> #action Akien package that editor for Mageia
20:01:32 <simonnzg> Imagine an editor where it expects to see the whole document, pictures, paragraphs, sections all in one place.  Calenco seems to expect to be allowing editors to use WebDAV to see the directory.  Without it I don't know what will happen.
20:01:51 <obgr_seneca> hm
20:01:59 <obgr_seneca> We have to ask JohnR about it
20:02:39 <simonnzg> I opened the repository using Oxygen (another XML editor), that supports WebDAV and the result was rather good.  I had problems doing the same with XMLMind.
20:03:08 <simonnzg> John's looking into it. Oxygen is another pay for me package. V nice. Too many buttons.
20:04:03 <simonnzg> For instance, I opened the root document for the Move manual and the whole manual arrived in WYSIWYG editable mode complete with pictures. Nice.
20:05:30 <simonnzg> I can explain how to do that in a DAV-enabled editor if you like.
20:05:52 <simonnzg> There MUST be an open XML editor out there.
20:06:15 <obgr_seneca> #action everybody find an open xml editor
20:06:24 <simonnzg> JohnR: Have you woken up yet?
20:06:31 <Akien> #summon JohnR
20:06:50 <obgr_seneca> Akien: I'm afraid he's asleep
20:07:06 <obgr_seneca> It's in the middle of the night in NZ after all
20:07:19 <Akien> #wake JohnR up
20:07:20 <Akien> :p
20:07:21 <simonnzg> 8am. Should be having breakfast.
20:07:55 <obgr_seneca> If he didn't stay up the whole night :D
20:08:05 <simonnzg> Probably hasn't slept all week.
20:08:10 <grenoya> simonnzg: you mean a open WYSIWYG XML editor ?
20:08:45 <simonnzg> grenoya: Well, I suppose so. I wasn't expecting one so I just said XML and left the WYSIWYG out.
20:09:16 * grenoya write HTML directly in vim :)
20:10:01 <marja> grenoya: in vim?
20:10:19 <simonnzg> In Calenco, when you wnat to edit a document, you highlight it and then using the "File" menu, select "DAV Link" - thatserves up a box with a URI in it that you can enter into the File Open dialogue of a suitably WebDAV enabled editor.
20:11:01 <simonnzg> grenoya: I write HTML in VIM. It has all the correct highlighting.
20:11:31 * marja never thought of that, always used kwrite for html
20:11:33 * obgr_seneca writes almost everything in vim...
20:11:56 <simonnzg> Bluefish is good for HTML
20:12:07 <grenoya> marja: I'm using vim for every thing (.bashrc, python, fortran, html, latex...)
20:12:20 <marja> grenoya: wow :)
20:12:45 <simonnzg> I wouldn't know what to do without Vim.
20:12:47 <obgr_seneca> spec files, php,...
20:13:00 <obgr_seneca> but that's not our topic :/
20:13:38 * Akien hides: using nano seems to be an heresy here. :p
20:13:45 <marja> lol
20:13:53 * obgr_seneca is fetching the matches...
20:14:38 <simonnzg> I think you people need to go and log into Calenco and see what you've let yourselves into.
20:14:51 <simonnzg> It's pretty daunting.
20:14:59 <obgr_seneca> ok, shell we end the meeting?
20:15:05 <simonnzg> Even for those of us that use Vim.
20:15:07 <obgr_seneca> before anyone runs away crying
20:15:31 <simonnzg> Screaming...
20:16:51 <marja> simonnzg: do you need to do that "DAV Link" step for every document, or does a good WebDAV enabled editor make it possible to jump from one document to the other without taking this step again?
20:17:08 <obgr_seneca> #action obgr_seneca write mails to wobo and JohnR
20:17:43 <sebsebseb> simonnzg: I am wondering what I have let myself into by joining this team :D, but well seems I am going to have an excuse to learn XML now, and that I could find quite fun.
20:17:56 <simonnzg> I don't know. I would expect it to be fine once it knows where you are. Then again, XML edirors never do what I expect them to do.
20:18:11 <obgr_seneca> #action marja remind obgr_seneca about contacting those too
20:18:16 <marja> sebsebseb: that's the spirit!
20:18:33 <simonnzg> sebsebseb: Don't forget that the Calenco documentation is not the WiKi.
20:18:44 <marja> obgr_seneca: OK, and what do you want me to do about Thierry? Remind you?
20:18:50 <sebsebseb> marja: well I used to completly hand code some basic websites before, HTML, and CSS, and well maybe convert the HTML to XHTML a little bit.
20:19:05 <marja> sebsebseb: great :D
20:19:19 <sebsebseb> simonnzg: yeah Calenco is for other stuff, not the Mageia wiki
20:19:27 <obgr_seneca> #undo
20:19:27 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x859b2ac>
20:19:37 <obgr_seneca> #action marja remind obgr_seneca about contacting those two (wobo and JohnR)
20:19:45 <sebsebseb> marja: can be fun to do stuff with mark up langauges, with proper reason, for people like me :D
20:19:48 <obgr_seneca> marja: and thierry as well
20:20:11 <marja> obgr_seneca: you didn't put thierry in the action :)
20:21:04 <marja> obgr_seneca: but I don't mind, I'll remind you of contacting all three, if you don't hide too much ;)
20:21:18 <obgr_seneca> I won't
20:21:29 <marja> obgr_seneca: great :)
20:22:48 <obgr_seneca> #action everybody look into calenco a bit more
20:23:16 <obgr_seneca> #action obgr_seneca write a mail to JohnR about getting an account for sebsebseb
20:23:24 <obgr_seneca> ok, anything else
20:23:37 <grenoya> I don't promise anything until I have a true home and internet conection :)
20:23:42 <sebsebseb> So this going to use Calenco thing for this team, is quite new I guess?
20:23:55 <marja> grenoya: of course!
20:24:01 <grenoya> obgr_seneca: I don't have an account either
20:25:31 <obgr_seneca> #undo
20:25:31 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x85ec46c>
20:25:40 <obgr_seneca> #action obgr_seneca write a mail to JohnR about getting an account for sebsebseb and grenoya
20:25:51 <grenoya> thanks :)
20:26:02 <sebsebseb> obgr_seneca: thanks :)
20:26:05 <obgr_seneca> #action grenoya and sebsebseb write a mail to JohnR because of the account
20:26:25 <obgr_seneca> <john@neodoc.biz>
20:27:24 <obgr_seneca> grenoya: sebsebseb: please write him an email yourself
20:27:26 <sebsebseb> obgr_seneca: oh your not going to do it for us? anyway yeah we can find him on IRC or email I guess
20:27:37 <obgr_seneca> I will then tell him who you are, ok?
20:27:55 <grenoya> that's ok for me :)
20:27:57 <sebsebseb> obgr_seneca: he already has an idea who I am I think :D, but yeah :)
20:28:01 <marja> sebsebseb: the e mail address was just given by obgr_seneca
20:28:07 <sebsebseb> marja: yep :)
20:28:31 <marja> :)
20:28:59 <obgr_seneca> ok, the organisatorial stuff is out of the way
20:29:11 <obgr_seneca> shell we end the meeting?
20:29:18 <marja> OK with me
20:29:19 <sebsebseb> ok with me
20:29:43 <sebsebseb> marja: we both typed same thing at the same time :D
20:29:48 <marja> grinz
20:30:07 <sebsebseb> anyway same time next week I guess?
20:30:08 <obgr_seneca> #endmeeting