18:15:36 <obgr_seneca> #startmeeting
18:15:36 <Inigo_Montoya> Meeting started Tue Oct  4 18:15:36 2011 UTC.  The chair is obgr_seneca. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:15:36 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:15:59 <obgr_seneca> First of all let me welcome all of you here tonight
18:16:07 <ryoshu> hello!
18:16:17 <obgr_seneca> it feels good to have some more people arround then last week :)
18:16:23 <Akien> Hello, and thanks for waiting for me :)
18:16:41 <obgr_seneca> What I wouldn't do for my deputy in i18n :D
18:17:03 <Akien> :P
18:17:14 <obgr_seneca> Ok, the council had a last discussion about the wiki in yesterdays (quite long) meeting
18:17:38 <ryoshu> what are the decisions
18:18:46 <obgr_seneca> We decided on these: http://mageia.org/wiki/doku.php?id=web:wiki#formal_rules as a starting point
18:19:13 <Akien> Oh, so it isn't "Rule 1: Do not talk about the Wiki Club."
18:19:21 <MrsB> :D
18:19:23 <obgr_seneca> basically we want to have as many categories as neccessary and a rather flat structure underneath them
18:20:04 <obgr_seneca> So we will have a category "Contributor." one category "Documentation." one "Planning." and so on
18:20:28 <ryoshu> aha
18:20:41 <obgr_seneca> all the team related stuff aka what we have in temporary wiki now will be put into "Contributors."
18:21:03 <obgr_seneca> All end user docs are going into "Documentation."
18:21:16 <obgr_seneca> Is that o.k.?
18:21:38 <obgr_seneca> (I hope so, because if not, ennael will burn me)
18:21:57 <marja_> so we can't put our own guides in the Documentation category?
18:22:09 <obgr_seneca> own guides?
18:22:20 <marja_> eg triage guide
18:22:43 <MrsB> What we'd like to do with QA is start to create pages for alot of the things we test with testing procedures. Is that going to be possible?
18:22:45 <obgr_seneca> If I understand it correctly, an article can have more then one category
18:23:11 <obgr_seneca> So the triage guide can be in both
18:23:13 <marja_> that's what I understood too
18:23:18 <Akien> MrsB: I guess that will go either under Contributor/QA or Documentation/QA, I don't really know.
18:23:21 <obgr_seneca> boklm: that correct?
18:24:04 <MrsB> It could involve alot of pages, if thats Ok.
18:24:16 <obgr_seneca> trishf42 and I will try and create a nice userfriendly portal page...
18:24:43 <obgr_seneca> MrsB: You are speaking about pages in the contributors corner?
18:25:09 <boklm> obgr_seneca: yes, it can be in more than one category
18:25:09 <MrsB> I'm not sure. Probably, going on what you said about the layout
18:25:26 <obgr_seneca> boklm: thanks
18:25:56 <obgr_seneca> so, the first steps will be something for the teams
18:26:20 <marja_> I understood there is no maximum amount of categories a page can have, is that correct?
18:26:28 <obgr_seneca> almost every team has named someone to coordinate migration from the temporary wiki into the new one
18:26:56 <obgr_seneca> marja_: yes, maybe there is some like 2^64 or something like that, but...
18:27:08 <marja_> lol
18:28:00 <obgr_seneca> http://mageia.org/wiki/doku.php?id=web:wiki#teams_contacts_for_wiki
18:28:13 <obgr_seneca> Here is the list of team contacts for the migration
18:28:42 <obgr_seneca> These people will be responsible for keeping a clean structure of the new wiki (at least in the beginning)
18:28:48 <obgr_seneca> Did we miss any team?
18:29:27 <MrsB> You can add MrsB next to Claire Robinson if you like - same person.
18:29:49 <Akien> MrsB: done.
18:29:55 <MrsB> Thanks :)
18:30:00 <obgr_seneca> whatever you prefer
18:30:32 <obgr_seneca> Akien: I was so kind to add you as second person for i18n and for doc, ok?
18:30:54 <Akien> That's fine by me.
18:31:04 <obgr_seneca> and I added TeaAge for artwork, it's his fault he wasn't in council yesterday :P
18:31:26 <MrsB> Stormi might like to be added to QA too
18:31:41 <Akien> I'll ask him.
18:31:43 <ryoshu> is there going to be a category "Tricks" or "Useful hints" like how to setup a chroot or use urpmi-proxy?
18:31:52 <obgr_seneca> MrsB: I think he added those two personally
18:32:10 <ryoshu> or is this a subdirectory of the Documentation
18:32:14 <obgr_seneca> ryoshu: it will be under Documentation I think
18:32:22 <ryoshu> I see
18:32:24 <obgr_seneca> but we can always add another Category
18:32:35 <obgr_seneca> as long as we stay under the mentioned 2^64
18:32:49 <ryoshu> :)
18:32:55 <obgr_seneca> could be 2^32 as well if it's signed int :)
18:33:08 <ryoshu> it's sufficient
18:33:12 <obgr_seneca> Yes
18:33:17 <simonnzg> Just....
18:33:32 <obgr_seneca> simonnzg: yes?
18:33:47 <simonnzg> I meant: Just sufficient.
18:34:01 <marja_> :)
18:34:12 <obgr_seneca> :D
18:34:36 <obgr_seneca> Ok, one thing we'd like to avoid is a deep nesting of pages into subdirectories
18:34:51 <obgr_seneca> Ok?
18:35:00 <marja_> yes, great :D
18:35:03 <ryoshu> yes
18:35:16 <simonnzg> I was wondering: How about a "Perfect Server"-style page set. Showing people in easy cut-and-paste steps how to achieve common tasks? Is that for here or elsewhere?
18:35:33 <obgr_seneca> I think we can do
18:35:38 <simonnzg> I mean Documentation or elsewhere...
18:35:48 <obgr_seneca> Perhaps add a category "Howtos." or so...
18:36:07 <marja_> yes, would be good
18:36:34 <obgr_seneca> As I said: the first step will be migrating the temporary wiki, this will first of all concern the Contributors. documentation
18:36:45 <obgr_seneca> s/documentation/category/
18:37:00 <Akien> obgr_seneca: So, the wiki will have only two levels of pages? I mean, pages will be like Categray/Page_name but not Category/Subcategory/Page_name?
18:37:14 <Akien> s/Categray/Category/
18:37:16 <obgr_seneca> yes
18:37:21 <Akien> ok
18:37:31 <ryoshu> and the language level!
18:37:44 <Akien> true.
18:38:01 <obgr_seneca> it will be for example "wiki.mageia.org/en/Contributors.i18n"
18:38:08 <Akien> I think having all Howtos in Documentation is fine, as long as the portal is nicely designed.
18:38:35 <Akien> Like with sections about Servers, KDE/Gnome settings, etc., even if those pages are not nested.
18:38:42 <obgr_seneca> or "wiki.mageia.org/en/Contributors.i18n_subteams"
18:40:36 <Akien> So, what will be our job precisely in the migration process?
18:41:21 <Akien> Should we import all pages from the temp wiki under the good categories, or should each team import its pages? (and we import the non-team-related ones)
18:42:03 <marja_> We need to improve some of our pages
18:42:16 <Akien> That's true.
18:42:24 <obgr_seneca> wait for me :D
18:42:25 <marja_> could they be imported to a "work corner"
18:42:55 <marja_> invisible to others until ready
18:42:58 <ryoshu> do we keep infos of developers, maintainers or people who are involved in the i18n teams etc on the Wiki?
18:43:02 <obgr_seneca> each team will import its own pages
18:43:30 <obgr_seneca> about invisibility, I don't know, honestly
18:43:49 <obgr_seneca> ryoshu: yes, I would keep those informations there
18:43:51 <marja_> I read something in the documentation, I'll try to find it
18:43:52 <MrsB> Will the new wiki run alongside the old wiki or will we need to save our pages from the old wiki?
18:44:18 <obgr_seneca> The old one will be kept up readonly for some time
18:44:28 <MrsB> Ok good, thanks :)
18:45:10 <obgr_seneca> so, let me do a little monologue? I'm not that fast at typing...
18:45:26 <simonnzg> I suppose you could keep pages in a sandbox until it's ready to show. Looks like the instructions allow for that.
18:45:39 <Akien> obgr_seneca: We're listening :)
18:45:47 <Akien> s/listening/reading/ :P
18:45:59 <obgr_seneca> In the first migration job process docteam will have little work.
18:46:09 <obgr_seneca> First the teams will import their pages
18:46:24 <obgr_seneca> And I think that's good, so we can use that time for all discussions
18:46:54 <obgr_seneca> ok?
18:47:19 <obgr_seneca> I'd like to invite all of you to join the doc-discuss mailinglist
18:47:39 <simonnzg> I'm there.
18:47:54 <obgr_seneca> we have about 1 or two weeks to decide all things related to documentation/howtos/whatever
18:48:27 * obgr_seneca would prefer the ml for that, because it's easier to read up on it
18:48:41 <obgr_seneca> irc  meetings tend to get chaotic after a while, ok?
18:48:58 <marja_> I prefer ml, too
18:49:06 <obgr_seneca> It would just be neccessary for everyone to really voice his/her ideas
18:49:19 <grenoya> obgr_seneca: where can we find that ML ?
18:49:38 <ryoshu> obgr_seneca: I think the genaral related things to Mageia, Howtos and organisational like teams should be separated more then just 1 click on a category. users don't need it
18:49:55 <obgr_seneca> ml.mageia.org
18:50:02 <MrsB> https://ml.mageia.org/wwsympa-wrapper.fcgi/info/doc-discuss
18:50:42 <obgr_seneca> ryoshu: we will have a (hopefully) well done portal leading the users in the right direction
18:50:45 <Akien> BTW, I would ask all team members and afficionados to put their name in the new members list here: http://mageia.org/wiki/doku.php?id=documentation
18:50:59 <Akien> I posted a mail about it on the ML but there weren't much new names after that.
18:51:07 <grenoya> MrsB: thx
18:51:10 <Akien> (except for Matteo who then withdrew).
18:51:15 <MrsB> yw :)
18:51:48 <Akien> (I can write your info on the page if you don't want to create an account on the temp wiki)
18:52:32 <obgr_seneca> Akien: Did Matteo say anything about it?
18:52:32 <marja_> Akien: That feels like joining the documentation team, but I can't do more than work on the BugSquas documentation now
18:52:34 <Akien> This list enables us to keep track of who's contributing to docteam, even not actively (but reading the ML, participating in the discussions, etc.).
18:53:02 <Akien> obgr_seneca: I don't know, I just realised it.
18:53:27 <obgr_seneca> I'll a sk him...
18:53:30 <obgr_seneca> Ok
18:53:39 <Akien> obgr_seneca: An idea about marja_'s remark?
18:54:15 <MrsB> I'll be doing alot of the QA documentation probably but won't be able to go much beyond that.
18:54:20 <obgr_seneca> marja_: You could add your name their saying "qa team contact" or something like taht?
18:54:34 <Akien> Yeah, this way would be great.
18:54:34 <obgr_seneca> s/qa/triage/
18:54:55 <marja_> obgr_seneca: OK, Bug squad contact
18:55:48 <obgr_seneca> As I said before, I myself will be mainly organizing the team building, as I have quite some other things on my hands
18:56:31 <obgr_seneca> So I'd ask you to add your names, even if only as xyz team contact
18:56:48 <obgr_seneca> So we do know, who is there and how many people we do have, ok?
18:57:09 <marja_> OK
18:58:16 <obgr_seneca> ok, is there anybody here I didn't confuse yet?
18:58:27 <MrsB> not me :)
18:58:44 <marja_> lol
18:58:48 <grenoya> I am not a team contact, I have not much time and I am not good in communication, but I am interested in docteam :)
18:58:51 <obgr_seneca> make a note toi myself: work harder on confusing people
18:59:05 <obgr_seneca> grenoya: anyone is welcome
18:59:41 <obgr_seneca> ok
18:59:55 <obgr_seneca> one last thing but this will be more i18n team's work:
19:00:26 <obgr_seneca> we'd like the localized wikis to mirror the structure of the en one
19:01:02 <obgr_seneca> I know, the contents will drift apart, although I would really like to keep them in sync, but...
19:01:05 <obgr_seneca> Hi camil
19:02:26 <Akien> Well, could be set up a system which would mail diffs to the i18n MLs for the languages affected by a modification on an English page? (or something similar)
19:02:32 <Akien> s/be/we/
19:02:43 <Akien> Okay, now I'm starting to sound confusing.
19:02:47 * Akien is Oliver's padawan.
19:04:26 <simonnzg> Maybe it's best to let i18n deal with their own pages and keep sync with the EN pages if they feel it's necessary to do so. After all, it's not just language, but culture as well?
19:04:38 <obgr_seneca> i'm afraid that would produce loads of noise via mail
19:05:25 <obgr_seneca> simonnzg: yep
19:05:42 <obgr_seneca> I would like to see a rather close cooperation between i18n and doc
19:06:02 <obgr_seneca> (and marcomm)
19:06:17 <simonnzg> Yes, but maybe not an e-mail to the translators every time someone swaps a few words around on EN! :-)
19:06:38 <obgr_seneca> simonnzg: yes
19:06:58 <Akien> Hum, is there something like a revision system in MediaWiki ?
19:07:06 <obgr_seneca> I think it is not neccessary to really keep them syncronized
19:07:27 <Akien> Or a page which lists changes chronogically (starting from the latest) with diffs ?
19:07:38 <Akien> This way the translators would just have to keep an eye on it.
19:07:45 <obgr_seneca> but I'd like doc team as well as i18n and perhaps future local doc teams to inform each other about important changes
19:08:13 <Akien> Hum, right.
19:08:16 <simonnzg> The readers would notice first. They would ask for a particular page to be translated/updated and then it would be done?
19:08:16 <obgr_seneca> Yes, there is a versioning
19:08:22 <obgr_seneca> like in dokuwiki
19:08:29 <simonnzg> End-user-driven, as they say.
19:08:30 <Akien> The main purpose will not be translation but adaptation of the content to another locale.
19:08:41 <obgr_seneca> yep
19:08:45 <simonnzg> yes
19:08:54 <Akien> That makes sense :)
19:09:08 <obgr_seneca> and there are special pages
19:09:24 <simonnzg> Localization, or as we say it here: Localisation ;-)
19:09:25 <obgr_seneca> errata and things like that should really be synced
19:09:50 <obgr_seneca> but there may be some docs it makes no sense to translate them at all
19:10:10 <obgr_seneca> in my years in Mandriva i18n I never translated the i18n guides in the wiki
19:10:33 <obgr_seneca> because a translator who can't read that, won't be a good translator...
19:10:39 <marja_> grinz
19:10:43 <Akien> obgr_seneca: But can be a proofreader :)
19:10:53 <obgr_seneca> Akien: :)
19:11:09 <obgr_seneca> simonnzg: You are from the UK?
19:12:15 <simonnzg> Yes.
19:12:27 <MrsB> Me too, Hi neighbour!
19:12:42 <obgr_seneca> Then I excuse myself for my English :D
19:12:44 <simonnzg> I can tell: you put a "u" in Neighbour!
19:12:52 <MrsB> :D
19:13:02 <simonnzg> Ah, English 1776 -
19:13:13 <Akien> Forsooth!
19:13:23 <marja_> ???
19:13:28 <obgr_seneca> Always those native speakers arround...
19:14:10 <ryoshu> :)
19:14:12 <obgr_seneca> ok, let's give meetbot something to work:
19:14:30 <Akien> #action Each team will import its own content to the wiki. Meanwhile, we discuss on the ML about important doc topics.
19:14:45 <Akien> oops, that was useless :p
19:14:52 <obgr_seneca> #info formal wiki structure can be found at http://mageia.org/wiki/doku.php?id=web:wiki#formal_rules
19:15:26 <obgr_seneca> #info team contacts can be found here: http://mageia.org/wiki/doku.php?id=web:wiki#teams_contacts_for_wiki
19:15:53 <obgr_seneca> #action everyone: sign up here: http://mageia.org/wiki/doku.php?id=documentation#members
19:16:07 <obgr_seneca> #action Each team will import its own content to the wiki. Meanwhile, we discuss on the ML about important doc topics.
19:16:17 <obgr_seneca> ok?
19:16:22 <obgr_seneca> Did I miss anything?
19:16:34 <Akien> That's great :)
19:16:42 <obgr_seneca> Akien: I think only chairs can do #action
19:16:51 <obgr_seneca> But anybody can do #info
19:16:54 <Akien> obgr_seneca: Yeah, I noticed it afterwards :)
19:17:07 <obgr_seneca> Ok, comments?
19:17:18 <Akien> Maybe we could list to-be-discussed topics for the ML?
19:17:27 <Akien> To avoid having 0 traffic there.
19:17:36 <obgr_seneca> ok
19:17:46 <obgr_seneca> #chair Akien
19:17:46 <Inigo_Montoya> Current chairs: Akien obgr_seneca
19:17:49 <obgr_seneca> Do!
19:18:03 <Akien> Well...
19:18:54 <Akien> #info ML topic: Which categories should be in the wiki? (separate End-user Howtos, Advanced users hints, or group them in Documentation)
19:19:19 <MrsB> I found it before but where is the documentation on the wiki package please?
19:19:38 <Akien> #info ML topic: What about external Mageia-related docs? (like the localised wiki in MLO)
19:19:43 <obgr_seneca> Ahm...
19:20:08 <MrsB> Is it mediawiki we're using?
19:20:12 <obgr_seneca> MrsB: I know it's somewhere out there...
19:20:18 <obgr_seneca> And yes, it is a mediawiki
19:20:22 <Akien> #info ML topic: How can we sync localised pages? (working with i18n)
19:20:37 <Akien> Do you have other ideas?
19:20:49 <obgr_seneca> Not at the moment
19:21:09 <Akien> Maybe discussing what Neodoc is, what will we done with its content?
19:21:15 <marja_> #link http://www.mediawiki.org/wiki/MediaWiki
19:21:20 <obgr_seneca> after 80 minutes of meeting I'm always running out of ideas :D
19:21:27 <Akien> True :)
19:21:36 <MrsB> Thanks marja_, I knew I'd seen it somewhere
19:21:42 <marja_> :)
19:21:56 <obgr_seneca> Oh yes, there was something about the im/export of wiki content into xml
19:22:20 <obgr_seneca> But I'd say: one thing at a time
19:22:38 <Akien> Yeah, let's deal with the current content, and add new things afterwards.
19:22:46 <obgr_seneca> ok?
19:23:04 <marja_> fine :)
19:23:06 <simonnzg> Yes
19:23:54 <obgr_seneca> #endmeeting