#mageia-dev Meeting

Meeting started by Akien at 20:10:04 UTC (full logs).

Meeting summary

  1. Mageia 7 Feature Review (Son_Goku, 20:12:47)
    1. https://wiki.mageia.org/en/Category:ProposedFeatureMageia7 (Akien, 20:13:09)
    2. https://wiki.mageia.org/en/FeatureMageia7_Review (Akien, 20:13:24)
    3. Proposed feature: https://wiki.mageia.org/en/Feature:MigrateToNetworkManager (Son_Goku, 20:14:39)
    4. Migrate to NetworkManager (Son_Goku, 20:14:46)
    5. AGREED: MigrateToNetworkManager is approved (Son_Goku, 20:21:20)
    6. Proposed feature: https://wiki.mageia.org/en/Feature:Move_to_new_AppStream_Directory (Son_Goku, 20:22:03)
    7. Move to New AppStream Directory (Son_Goku, 20:22:14)
    8. AGREED: Move to new AppStream Directory is approved (Son_Goku, 20:25:41)
    9. Proposed feature: https://wiki.mageia.org/en/Feature:NetworkDrakToolsImprovements (Son_Goku, 20:27:07)
    10. NetworkDrakToolsImprovements (Son_Goku, 20:27:38)
    11. AGREED: NetworkDrakToolsImprovements overlaps with MigrateToNetworkManager, should be partly merged and then re-purposed to track the addition of IPv6 support in drakfirewall (Akien, 20:30:30)
    12. Proposed feature: https://wiki.mageia.org/en/Feature:New_Mgarepo (Son_Goku, 20:31:11)
    13. New MgaRepo (Son_Goku, 20:31:17)
    14. AGREED: New MgaRepo work is mostly done, it's approved as part of Dist-Git migration work (Son_Goku, 20:33:53)
    15. Proposed feature: https://wiki.mageia.org/en/Feature:Offer_services_from_Framasoft (Son_Goku, 20:34:31)
    16. Offer services from Framasoft (Son_Goku, 20:34:39)
    17. AGREED: Offer services from Framasoft is rejected, as we feel this is the wrong place for this and doesn't make sense for Mageia or Framasoft (Son_Goku, 20:39:00)
    18. Proposed feature: https://wiki.mageia.org/en/Feature:Port_installer_to_use_DNF (Son_Goku, 20:39:46)
    19. Port installer to use DNF (Son_Goku, 20:39:56)
    20. realated to https://wiki.mageia.org/en/Feature:Switch_to_DNF (mokraemer, 20:40:02)
    21. related to https://wiki.mageia.org/en/Feature:Switch_to_DNF (Son_Goku, 20:40:13)
    22. and https://wiki.mageia.org/en/Feature:Update_urpmi_to_new_rpm (mokraemer, 20:40:21)
    23. https://gitlab.com/mdklinux/dnf-urpm (anaselli, 20:50:06)
    24. AGREED: A decision needs to be taken on the general direction of the project re DNF vs URPM (as backend, not frontend). New RPM features need to be supported (e.g. rich deps) and this can be done either by porting our tools to a DNF backend, or by improving perl-URPM to bring it in sync with modern features. An email will be sent to describe the two scenarios, with a decision to be taken within 2 weeks. (Akien, 21:20:51)
    25. https://wiki.mageia.org/en/Feature:Provide_an_educationnal_mageia_flavour (Akien, 21:28:56)
    26. Provide an educational mageia flavour (Akien, 21:29:08)
    27. AGREED: Educational spin feature needs to be fleshed out with more details about how it will be done, who will participate, who will do the Q&A, etc. (Akien, 21:44:50)
    28. https://wiki.mageia.org/en/Feature:Python3_as_default (Akien, 21:46:54)
    29. Python3 as default (Akien, 21:46:58)
    30. AGREED: Python 3 as default is agreed upon, the exact changes to do needs to be better defined and discussed. (Akien, 21:57:38)
    31. https://wiki.mageia.org/en/Feature:Support_rEFInd_boot_manager (Akien, 21:59:35)
    32. Support_rEFInd_boot_manager (Akien, 21:59:50)
    33. AGREED: Support rEFInd boot manager is approved (Pharaoh_Atem, 22:01:05)
    34. https://www.freedesktop.org/wiki/Specifications/BootLoaderSpec/ (Pharaoh_Atem, 22:02:32)
    35. https://www.freedesktop.org/wiki/Software/systemd/systemd-boot/ (Pharaoh_Atem, 22:03:36)
    36. : Proposed feature: https://wiki.mageia.org/en/Feature:Use_GRUB2_for_booting_Live_and_Classic_Installer_ISOs (Pharaoh_Atem, 22:05:15)
    37. Use GRUB2 for booting Live and Classic Installer ISOs (Pharaoh_Atem, 22:05:26)
    38. AGREED: Use GRUB2 for booting Live and Classic Installer ISOs is approved as it unifies the experience between UEFI and non-UEFI systems (Pharaoh_Atem, 22:17:10)
    39. https://wiki.mageia.org/en/Feature:Review_mandriva-everytime.service (Akien, 22:18:54)
    40. Review mandriva-everytime.service (Akien, 22:19:03)
    41. AGREED: Review mandriva-everytime.service is approved. Hopefully we can kill some awful legacy beasts! (Pharaoh_Atem, 22:21:16)
    42. https://wiki.mageia.org/en/Feature:Simplify_method_of_updating_.iso_installer_between_releases_and_between_QA_pre-release_testing (Akien, 22:23:13)
    43. Simplify method of updating .iso installer between releases and between QA pre-release testing (Akien, 22:23:16)
    44. AGREED: "Simplify method of updating .iso installer between releases and between QA pre-release testing" needs more fleshing out. QA will discuss this and figure out what it means for further review (Pharaoh_Atem, 22:25:05)
    45. Proposed feature: https://wiki.mageia.org/en/Feature:Use_systemd_presets_for_default_services (Pharaoh_Atem, 22:27:51)
    46. Use systemd presets for default services (Pharaoh_Atem, 22:28:04)
    47. AGREED: Use systemd presets for default services is approved. We should ensure our default service set is sane and reasonable, too! (Pharaoh_Atem, 22:36:51)
    48. Feature proposed: https://wiki.mageia.org/en/Feature:XfceMageiaEnhanced (Pharaoh_Atem, 22:38:35)
    49. XfceMageiaEnhanced (Pharaoh_Atem, 22:38:43)
    50. AGREED: XfceMageiaEnhanced is rejected as is. Making Xfce like Plasma by default doesn't play to Xfce's strengths or target. It may be worth sending along as suggestions to the Xfce maintainer (wally) to improve the default look and feel for the Mageia Xfce flavor (Pharaoh_Atem, 22:45:19)


Meeting ended at 22:47:57 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. Akien (182)
  2. Son_Goku (167)
  3. Pharaoh_Atem (155)
  4. Luigi12_work (110)
  5. martinw (54)
  6. DavidWHodgins (52)
  7. anaselli (45)
  8. Solbu (41)
  9. tmb (37)
  10. mokraemer (24)
  11. kekePower (20)
  12. Kharec (7)
  13. joeghi (5)
  14. wilcal (4)
  15. Inigo_Montoya (4)
  16. [mbot (2)
  17. barjac (1)
  18. ankh (1)
  19. kostuek (1)


Generated by MeetBot 0.1.4.