20:17:23 <stormi> #startmeeting
20:17:23 <Inigo_Montoya> Meeting started Sat Dec  3 20:17:23 2016 UTC.  The chair is stormi. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:17:23 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:18:11 <stormi> We're going to review the blockers assigned to the KDE team, listed at http://madb.mageia.org/tools/blockers
20:18:17 <[mbot> [ Mageia App Db - Current Blockers ]
20:18:59 <stormi> #topic bug 16850
20:19:00 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=16850 normal, release_blocker, kde, NEW , Plasma 5 cannot restore its session (running applications not plasmoids), plasma-workspace-5.8.3, plasma-desktop-5.8.3
20:19:15 <stormi> thanks [mbot that helps
20:20:04 <stormi> So, plasma doesn't restore applications that were running
20:20:28 <stormi> Except a few ones, such as firefox or konqueror
20:21:06 <stormi> Our packagers said it's an upstream bug but there are comments (and actually the bug description itself too) stating that it's specific to Mageia
20:21:48 <stormi> It would not be nice to ship plasma with such a visible regression as compared to KDE4
20:22:26 <stormi> So we need some people to go deeper and actually analyze the issue because for now I doubt it has been done
20:22:50 <stormi> Do you agree with the above statements?
20:22:53 <Luigi12> stormi made a good point yesterday that maybe it is configurable and we have a default setting that's wrong
20:23:22 <Luigi12> so that's worth investigating, and yes I agree
20:23:22 <Akien> Yes, we need to debug this instead of assuming it's an upstream bug, since apparently it is not.
20:23:25 <Pharaoh_Atem> well, fwiw, this feature does work on Fedora
20:23:38 <Pharaoh_Atem> I can personally attest to that, since that's what my work computer runs
20:23:38 <neoclust> stormi: sorry i was outside
20:23:40 <stormi> Pharaoh_Atem: thanks, please add that as a comment
20:23:42 <neoclust> i am here now
20:23:54 <stormi> neoclust: great, thanks for coming
20:24:59 <neoclust> stormi: Akien : we have nothing in our configuration regarding this
20:25:06 <neoclust> we are "upstream"
20:25:28 <Akien> Re configuration, in systemsettings > Startup and Shutdown > Desktop Session, there is an option about session restoring
20:25:30 <stormi> upstream for our configuration you mean?
20:25:44 <Akien> But I have the config "Restore previous session" enabled, and AFAIK, I'm still affected by the bug
20:25:58 <Akien> I had to add an autostart entry for yakuake and redshift-gtk to get them on startup
20:26:18 <stormi> Akien: same here regarding "Restore previous session"
20:26:28 <Luigi12> ok, strange.  So the next thing is to investigate the files where Plasma stores its session information.
20:26:29 <Akien> So it's not just a config issue, the issue is deeper.
20:26:48 <neoclust> maybe we should look to opensuse, to see if they have a patch for this
20:26:54 <neoclust> a "not yet upstreamed" patch
20:27:25 <Luigi12> Plasma 4 uses .kde4/share/config/session/*, not sure about Plasma 5
20:27:33 <Akien> That would be a possibility, if someone is up for auditing other distro's packages to see if they have patches, that would be helpful.
20:27:42 <neoclust> Luigi12: in plasma nothing is in .KDE4/
20:27:46 <neoclust> all is in .config/
20:27:48 <neoclust> now
20:27:50 <Luigi12> I know that
20:27:51 <stormi> And if they haven't then there's a bug specific to Mageia
20:27:53 <neoclust> $HOME/.config
20:27:54 <Akien> The second possibility would be that it affects *only* Mageia, and thus we need to think about what we do differently.
20:28:00 <Akien> Which made me think of... predm :)
20:28:02 <Akien> *prefdm
20:28:13 <neoclust> i think of it too
20:28:14 <neoclust> :(
20:28:16 <Luigi12> how the DM started shouldn't have any impact
20:28:20 <neoclust> who is affected ?
20:28:23 <neoclust> Akien: you ?
20:28:24 <Akien> I wouldn't be so sure.
20:28:25 <Luigi12> how the session is started could
20:28:26 <Akien> Luigi12: $
20:28:28 <stormi> Well, I suppose we can test to start plasma directly and check
20:28:43 <neoclust> stormi: service prefdm stop
20:28:43 <Pharaoh_Atem> well, right now, I'm starting a bunch of random apps and going to attempt a reboot
20:28:47 <Pharaoh_Atem> and see if it comes back
20:28:50 <Luigi12> much more likely you need to look at Xsession and what happens from there, rather than looking backward at prefdm
20:28:52 <stormi> Are there people not affected?
20:28:52 <neoclust> stormi: service sddm start
20:28:55 <neoclust> stormi: and test
20:28:58 <stormi> neoclust: ok
20:28:59 <N9NU> well well
20:29:20 <Luigi12> we have made a lot of changes in our xinitrc package this cycle, including how sessions are configured
20:29:23 <Akien> It might be worth asking KDE devs upstream about what components are involved in session restore
20:29:32 <Akien> To help us debug our issue
20:29:35 <Luigi12> switching from wmsession.d to xsessions, which had a big impact on the code
20:29:35 <neoclust> Akien: yes good idea
20:29:53 <Pharaoh_Atem> actually, it also occurs to me that Plasma may be randomly breaking it
20:30:03 <Pharaoh_Atem> it has, from time to time, stopped working
20:30:21 <N9NU> the driver for the updated Xorg 1.19
20:30:24 <stormi> I suggest we use the kde@ ML to discuss this bug in the coming days and kill it the way we killed the "good luck" one last week
20:30:29 <N9NU> will be out very  soon
20:30:40 <Bequimao> I always use that option, but I save a clean desktop without running applications.
20:31:05 <Pharaoh_Atem> neoclust: so mcc and firefox came back
20:31:12 <Pharaoh_Atem> but systemsettings and konsole did not
20:31:15 <stormi> yeah the GTK applications are restored :)
20:31:22 <stormi> That's the funniest thing ever in this bug report
20:31:27 <neoclust> stormi: :)
20:31:36 <neoclust> so  go for using kde@ ML
20:31:45 <neoclust> to speak about this specific bug
20:32:02 <stormi> Ok. Anyone interested in helping can either follow the bug report or join the kde@ ML to discuss it.
20:32:05 <Akien> Do we have a volunteer to start the discussion and maybe summarize what was said above?
20:32:22 <neoclust> Akien: thanks to offer yourself for this :)
20:32:25 <neoclust> i appreciate :p
20:32:45 <Akien> i.e. 1) check if other distros have related patches. 2) debug the session startup to see if it's DM related. 3) ask KDE devs for ideas
20:32:58 <Akien> Ok I'll take this one, but none other :)
20:32:59 <stormi> I suppose I can
20:33:03 <Akien> Or stormi :)
20:33:20 <stormi> I'm quite annoyed by this bug so motivation is present
20:33:38 <neoclust> stormi: tks;
20:33:40 <Akien> #action stormi starts a commando thread on the kde@ ML to hunt down mga#16850
20:33:41 <neoclust> next :)
20:33:45 <stormi> #action stormi will start a discussion on the kde@ mailing list and keep the bug report updated
20:33:56 <Akien> :p
20:33:57 <stormi> #chair akien
20:33:57 <Inigo_Montoya> Current chairs: akien stormi
20:33:59 <stormi> :)
20:34:04 <Akien> Hehe
20:34:27 <stormi> #topic bug 17528
20:34:28 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=17528 normal, release_blocker, kde, NEW , Qt5/KF5-related package updates for Mageia 6
20:34:50 <stormi> This one is to be brought back from cryogenesis
20:34:50 <Luigi12> still a bunch there that actually have KF5 ports available that haven't been dealt with, last I checked
20:34:55 <neoclust> we need to see the remaining apps that we can't update and close this bug
20:35:06 <Luigi12> I should post another summary
20:35:15 <neoclust> Luigi12: can you on this bugreport add the list of the remaining apps to update ?
20:35:21 <neoclust> i and david_david will do the work
20:35:27 <Luigi12> we've also never made a list of the remaining Qt4/KDE4 apps to see what we will do about those
20:35:41 <Luigi12> neoclust: yeah I'll post another summary
20:35:57 <neoclust> Luigi12: we will keep them if working ( as we have kdebase4-runtime )
20:36:09 <neoclust> Luigi12: as long as we have this kde4 apps will work under plasma
20:36:10 <Luigi12> I'm not sure about that
20:36:18 <Akien> I think upstream has plans to drop support for kde4 libs in ~1 year, will that affect mga6 in updates, or are we safe for this one?
20:36:21 <Luigi12> I mean, it's basically all dead software, which calls into question maintainability
20:36:22 <neoclust> Luigi12: then we need to test them :)
20:36:33 <Luigi12> I'd rather drop and reintroduce into mga6 as an update if/when a KF5 port becomes available
20:36:35 <neoclust> Akien: we are safe for now
20:36:40 <Akien> Ok
20:36:41 <Luigi12> because if one doesn't, it's really dead
20:36:53 <neoclust> Luigi12: then we need a list to see apps by apps what to do
20:37:10 <Luigi12> and yes upstream is planning on dropping more of them in the next KDE Applications update, as far as the official ones go
20:37:18 <Luigi12> so those ones will be officially unmaintained soon
20:37:32 <Luigi12> neoclust: exactly, it'd be nice if someone could generate a list
20:37:47 <neoclust> Luigi12: i will try to do it
20:37:49 <neoclust> "try" ;)
20:37:50 <stormi> I suppose qt4 and KDE4 apps are to be treaded separatedly
20:37:52 <Luigi12> cool, thanks
20:37:56 <neoclust> stormi: yes
20:37:57 <Luigi12> stormi: probably true, yes
20:38:10 <N9NU> QT rules
20:38:16 <Luigi12> QT sucks
20:38:17 <Luigi12> Qt rules
20:38:19 <N9NU> gtk well...heh
20:38:22 <N9NU> blah
20:38:30 <neoclust> Akien: next ? :)
20:38:34 <Luigi12> indeed
20:38:37 <Pharaoh_Atem> Luigi12: I think hardly anyone remembers QuickTime nowadays
20:38:41 <stormi> so Luigi12's giving a list and neoclust is giving a list?
20:38:53 <Luigi12> Pharaoh_Atem: unfortunately that's not true, but I so wish it was
20:38:55 <neoclust> stormi: Luigi  KF
20:38:55 <N9NU> QT5 baby
20:38:57 <neoclust> stormi: Luigi  KF5
20:39:02 <neoclust> neoclust: KDE4
20:39:02 <stormi> I've got troubles writing my action
20:39:02 <Luigi12> Pharaoh_Atem: still so much proprietary codec crap out there :o(
20:39:07 <N9NU> quicktime oh boy...lol
20:39:07 <Pharaoh_Atem> :(
20:39:09 <stormi> neoclust: ok :)
20:39:14 <Luigi12> stormi: I'll be giving a summary
20:39:32 <N9NU> i luv programming in QT
20:39:44 <Luigi12> N9NU: please, it's Qt.  QT is QuickTime
20:39:47 <stormi> #action Luigi12 gives a list of packages that have a Qt5 or KF5 port and neoclust gives a list of existing Qt4 and KDE4 apps
20:39:49 <Luigi12> anyway, next bug
20:40:14 <stormi> #topic bug 17852
20:40:15 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=17852 normal, release_blocker, kde, NEW , [mga6-dev1] initial boot into installed live PLasma5 x86 presents incomplete desktop
20:40:24 <neoclust> stormi: i wait for sta2 isos to test
20:40:33 <stormi> ok next then :)
20:40:36 <neoclust> nothing more to tell
20:40:37 <Luigi12> exactly
20:40:42 <stormi> #action test with sta2 isis
20:40:43 <Luigi12> irrelevant until we have new ISOs
20:40:46 <stormi> isis :)
20:40:56 <neoclust> stormi: i had a girlfriend named isis
20:41:01 <neoclust> stormi: but i don't think this is the same :p
20:41:03 <Luigi12> neat
20:41:21 <stormi> so #action waiting for neoclust's next set of girlfriends
20:41:25 <Akien> sta2 is like 2nd base? :p
20:41:31 <neoclust> stormi: :p
20:41:33 <Pharaoh_Atem> haha
20:41:36 <Luigi12> for next bug 18904, a lot has changed with X.org and nvidia stuff since that was filed, so needs retesting
20:41:37 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=18904 major, release_blocker, kde, REOPENED , Plasma+Nvidia: After resume, Plasma desktop icons text fields and some app is unreadable (OK in other DE, i.e MATE), kwin
20:41:46 <stormi> #topic bug 18904
20:42:02 <stormi> #info a lot has changed so needs retesting
20:42:32 <neoclust> i don't have any nvidia based machine
20:42:32 <Akien> Well last comment is for Nov 22
20:42:46 <stormi> I do but no garbled texts
20:42:50 <Luigi12> I think the xorg 1.19 came after Nov 22
20:42:56 <neoclust> Luigi12: yes
20:42:58 <stormi> oh wait, I don't use the nvidia card actually, only intel :)
20:43:06 <Pharaoh_Atem> it looks like this bug is actually fixed?
20:43:07 <Akien> stormi: yeah optimus doesn't qualify as nvidia-based :)
20:43:11 <Pharaoh_Atem> the comments indicate as much
20:43:15 <Luigi12> cool
20:43:29 <Pharaoh_Atem> or rather, fixed themselves as we updated the world
20:43:32 <Luigi12> might as well close it, someone can reopen if needed
20:43:44 <stormi> Isn't it still valid on one of his computers?
20:43:46 <neoclust> Luigi12: go this way then
20:43:52 <Pharaoh_Atem> stormi: doesn't look like it
20:44:01 <neoclust> Same after updates today including kernel 4.8.10-2 : garbled on "Lillen", OK on "Göran".
20:44:15 <stormi> "garbled" is KO, no?
20:44:17 <neoclust> seems this 2 actions ( i don't understand ) are still broken
20:44:27 <Pharaoh_Atem> gah, missed that bit
20:44:29 <Luigi12> well they'll need to test 4.8.12
20:44:30 <stormi> That's the name of a computer
20:44:41 <Luigi12> think some regressions have been fixed since 4.8.10-2
20:44:50 <neoclust> stormi: garbled => "brouillées"
20:44:51 <stormi> One computer is ok the other still has an issue
20:44:53 <Pharaoh_Atem> these 4.8.x kernels have been nuts :/
20:45:00 <Akien> I'd propose him to reopen a new bug report with just the current issue
20:45:05 <neoclust> we need to ask screenshot too
20:45:06 <Akien> Or change the summary
20:45:18 <Akien> As the bug evolved a lot since the initial status that made it a blocker
20:45:19 <stormi> ok to ask him to reopen a new one
20:45:31 <Akien> Judging by the last comments, I'd say it's no longer a blocker, but still a bug that needs fixed
20:45:43 <Pharaoh_Atem> I would agree with that
20:46:10 <stormi> Ok, demoted to "high"
20:46:37 <stormi> #info no longer a blocker. Situation is better than used to be and needs testing with new XOrg.
20:47:05 <stormi> Akien: can you add a comment suggesting to close this one and open a new bug report?
20:47:17 <neoclust> or change/Fix the summary
20:47:34 <Akien> Yep
20:47:35 <stormi> #topic bug 19097
20:47:36 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=19097 critical, release_blocker, kde, NEW , Amarok crashes, amarok-2.8.90-3.mga6.src.rpm
20:47:57 <stormi> This is Luigi12's bug
20:47:59 <Luigi12> https://bugs.mageia.org/show_bug.cgi?id=19097#c4  if you see the Also, part in Comment 4, that definitely needs to be addressed
20:48:00 <[mbot> Bug 19097: critical, release_blocker, kde, NEW , Amarok crashes, amarok-2.8.90-3.mga6.src.rpm
20:48:05 <neoclust> i can't help, it does not crash for me :/
20:48:10 <Luigi12> as for the rest of it, I need to do some retesting
20:48:13 <neoclust> maybe missing Require ?
20:48:17 <Luigi12> could be
20:48:29 <stormi> Luigi12: where do I check this setting?
20:48:45 <neoclust> Luigi12: test when possible and see with me if still valid ? we will test "live" on irc
20:48:54 <Luigi12> I have an old work computer (where I first saw this issue) at my new work, and I'm hoping to have time next week to play with it to test this (and the next bug on our list), but no promises
20:49:15 <Luigi12> stormi: Settings > Configure Amarok... > Playback > Configure Phonon
20:49:21 <stormi> #action Luigi12 will test again because others have trouble making it crash
20:49:59 <Luigi12> yeah even I can't get it to crash in my VM, so I can hopefully retest on the same type of computer where it did
20:50:06 <Luigi12> but the Phonon bit is still valid
20:50:15 <stormi> Luigi12: the Phonon bit deserves a new bug report
20:50:23 <Luigi12> yes
20:50:23 <stormi> and I think the crash one can be demoted
20:50:32 <Akien> amarok works fine for me, but the Configure Phonon thing just loads forever and nothing happens
20:50:40 <stormi> same as Akien :)
20:50:40 <Luigi12> yeah that's a problem too
20:50:49 <Luigi12> I usually have to go into systemsettings to even fix it
20:51:01 <stormi> Another bug report?
20:51:15 <Luigi12> ok
20:52:11 <Luigi12> for the next bug 19103, it'd be nice if someone could set up a test bed to see if they can reproduce the issue, basically a system where you're using some remote service for user accounts (I was using sssd on the system where I saw the issue)
20:52:13 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=19103 critical, release_blocker, kde, NEW , Plasma screen locker does not let non-local users unlock screen (PAM issue?), plasma-workspace-5.7.2-3.mga6.src.rpm
20:52:35 <neoclust> Luigi12: can you do a complete testcase ? so i will do the complete setup here to test
20:52:36 <Akien> #action Luigi12 opens a new bug report for the phonon issue, amarok crash might be solved already
20:52:41 <Akien> #topic bug 19103
20:52:42 <neoclust> Luigi12: i have some windows for work
20:53:04 <Luigi12> neoclust: oh good, I was using sssd configured agasint Active Directory, so you should be able to reproduce that
20:53:05 <Akien> Inigo_Montoya: hey
20:53:05 <Inigo_Montoya> Akien: Error: "hey" is not a valid command.
20:53:36 <stormi> Akien: let me try
20:53:39 <stormi> #chair Akien
20:53:39 <Inigo_Montoya> Current chairs: Akien akien stormi
20:53:44 <stormi> lol I was right
20:53:52 <Luigi12> and the next bug 19153 neoclust had said he would look into it but I don't know if he got around to it
20:53:53 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=19153 normal, release_blocker, kde, ASSIGNED , Logging into Plasma after upgrade from Mageia 5 results in two Home and Trash icons on desktop, plasma-desktop
20:53:53 <stormi> repeat your action and topic
20:53:58 <Akien> #action Luigi12 opens a new bug report for the phonon issue, amarok crash might be solved already
20:54:00 <Akien> #topic bug 19103
20:54:01 <neoclust> Luigi12: btw amarok is still porting to kf5 ( see https://mail.kde.org/pipermail/amarok-devel/2016-October/014120.html )
20:54:02 <[mbot> [ Review Request 129237: [amarok] Try port services to KF5 ]
20:54:08 <Akien> Luigi is going faster than topics..
20:54:39 <stormi> next time he'll have fixed the bugs before we do the meetings
20:54:40 <Luigi12> yeah sorry I'm leaving soon to go to dinner with my parents
20:54:53 <Luigi12> I have no comments on the last two bugs in our list
20:56:30 <stormi> I have trouble following your previous comments about 19103. Have you agreed on something already?
20:56:36 <Akien> So for bug 19103 I think neoclust will look at it, but needs some help about the testcase from Luigi12, right?
20:56:45 <neoclust> Akien: yes please
20:56:52 <Luigi12> stormi: for 19103, it'd help if someone besides me could test it
20:57:00 <Luigi12> it won't be easy for me to test it again
20:57:08 <Akien> #action neoclust will setup a test environment to reproduce the bug, but needs some help about the testcase from Luigi12
20:57:18 <neoclust> Luigi12: i will but as i hate windows i will need some help on seting up my test machine
20:57:32 <Luigi12> the test case is simple, sssd (against Active Directory, but I doubt that the backend makes a difference), log in as a non-local user
20:57:53 <Luigi12> but I don't have access to the AD at my new work
20:57:59 <stormi> Why is it a release blocker? Is it likely to affect a lot of users if we don't fix it before release?
20:58:06 <neoclust> Luigi12: we will speak of it on irc next week if you agree, will be simpler :)
20:58:10 <Luigi12> stormi: yes it is
20:58:39 <Luigi12> probably will affect anyone using non-local users like LDAP or AD, so any business environment, but nobody has tried to confirm it yet
20:58:56 <stormi> #action neoclust will try to reproduce with Luigi12's help
20:59:02 <Luigi12> neoclust: OK I can help with the sssd config if you need it
20:59:27 <Pharaoh_Atem> Luigi12, neoclust: it should be possible to try to test this with sssd authing against FreeIPA
20:59:31 <Akien> stormi: had already action'ed that ;)
20:59:46 <stormi> Akien: well they'll do it twice as fast now
20:59:57 <neoclust> stormi: we can go to the next bug then
20:59:57 <Luigi12> Pharaoh_Atem: or OpenLDAP, but in any case one would have to set up that backend.  At least he has an existing AD at work, so that should make it easier.
20:59:59 <neoclust> for today :)
21:00:09 <Akien> bug 19153
21:00:10 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=19153 normal, release_blocker, kde, ASSIGNED , Logging into Plasma after upgrade from Mageia 5 results in two Home and Trash icons on desktop, plasma-desktop
21:00:13 <Akien> #topic bug 19153
21:00:19 <neoclust> Akien: this one i will fix
21:00:24 <neoclust> i hope next week
21:00:39 <neoclust> next ? :p
21:00:47 <Luigi12> yep, move it along :o)
21:00:52 <Akien> #action neoclust will fix this one.
21:01:03 <Akien> #topic bug 19799
21:01:04 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=19799 normal, release_blocker, kde, NEW , qt5 stack must be checked for sse2 code in 32bit builds, qt5 stack
21:01:12 <Akien> That's an important one
21:01:22 <Luigi12> maybe
21:01:39 <Luigi12> I wonder if my i586 laptops have sse2, I should check
21:01:55 <Luigi12> they're like 11.5 years old
21:02:07 <neoclust> david_david: can you take this one ?
21:02:13 <Pharaoh_Atem> sse2 has been in computers since late 90s
21:02:21 <Pharaoh_Atem> it's a pre-requisite for i686
21:02:28 <Luigi12> ahh, I'm probably OK then
21:02:29 <Pharaoh_Atem> along with cmov and a few others
21:02:50 <Pharaoh_Atem> I don't know why we're still i586 instead of i686 :/
21:02:54 <Luigi12> gotta go, thanks everyone
21:02:57 <Pharaoh_Atem> maybe something for mga7
21:03:00 <neoclust> Luigi12: bye
21:03:02 <Pharaoh_Atem> Luigi12: thanks for being here :)
21:03:07 <stormi> bye Luigi12
21:03:39 <neoclust> 1163	%ifarch %ix86
21:03:39 <neoclust> 1164	    -no-sse2 \
21:03:39 <neoclust> 1165	%endif
21:03:51 <neoclust> david_david: can you see to add this on other qt5 packages ?
21:05:28 <Akien> Should we add this to %qmake_qt5 ?
21:05:33 <neoclust> stormi: go next, if david_david can't i will try to find time
21:05:37 <stormi> neoclust: ok
21:05:59 <stormi> #topic 19869
21:06:11 <stormi> #topic bug 19869
21:06:12 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=19869 major, release_blocker, kde, NEW , After logging into Plasma from SDDM, the splash screen may freeze (STA1 updated 2016-11-29)
21:06:17 <neoclust> Akien: no because it won't be available on "normal" qt softwares qmake files
21:06:33 <Akien> neoclust: ok
21:06:37 <neoclust> stormi: we need to wait for sta2 and ask for tests
21:06:43 <neoclust> stormi: as i don't reproduce this
21:06:58 <stormi> neoclust: I do, david_david does and the original bug report does too
21:07:08 <neoclust> ah
21:07:13 <neoclust> stormi: so still valid for you ?
21:07:16 <david_david> neoclust: I can look yes, but I don't know what we should do exactly
21:07:21 <Pharaoh_Atem> I'm really starting to think this is some kind of upstream bug
21:07:21 <Akien> I don't reproduce it here
21:07:25 <Pharaoh_Atem> where it's occurring, I don't know
21:07:33 <Pharaoh_Atem> but it happens for me on Fedora with my 3-screen system
21:07:38 <Pharaoh_Atem> but not on my single-screen system
21:07:48 <stormi> Hmm here it's a single screen
21:07:59 <Pharaoh_Atem> the only applications it affects are plasmashell and google-chrome-stable
21:08:08 <Pharaoh_Atem> which *really* makes me think something in the kernel is being screwy
21:08:27 <stormi> neoclust: yes still valid, I had it today
21:08:28 <Pharaoh_Atem> because there's not a lot in common with those two things in terms of libraries
21:08:40 <neoclust> stormi: can you test w/o prefdm ?
21:08:47 <stormi> neoclust: I can
21:08:53 <neoclust> stormi: to see if this is related to it ( or not )
21:08:56 <neoclust> stormi: tks
21:09:07 <Pharaoh_Atem> oh wait, this is from sddm
21:09:11 <Pharaoh_Atem> nvm, I don't have that issue
21:09:18 <Pharaoh_Atem> I do have freezes happening after that
21:09:24 <stormi> Pharaoh_Atem: not just sddm, afterwards too
21:09:32 <stormi> Pharaoh_Atem: you have the same as comment 2?
21:09:42 <Pharaoh_Atem> yes
21:09:53 <Pharaoh_Atem> there's at least one rhbug about it too
21:09:59 <stormi> For some reason, the desktop stops refreshing itself
21:10:11 <stormi> but the applications can still be used
21:10:19 <Pharaoh_Atem> https://bugzilla.redhat.com/show_bug.cgi?id=1399396
21:10:20 <[mbot> Nothing found with the default search.
21:10:22 <stormi> (I can use Ctrl+Fx to change desktops)
21:10:49 <Pharaoh_Atem> we don't have the SDDM issue, but we do have plasmashell itself freezing randomly
21:11:12 <Pharaoh_Atem> based on what people have been seeing (myself included) it looks like something's broken in the kernel
21:11:29 <stormi> We have been supposed it's the same issue because it's similar and showed up at the same time, ie very recently
21:12:03 <stormi> And the workaround is the same too
21:13:21 <stormi> Any ideas how to handle this bug?
21:13:25 <Pharaoh_Atem> I've updated the ticket accordingly
21:14:22 <neoclust> ok we are done with the bugreports ? we can speak of other plasma/KDE issues ?
21:14:41 <Pharaoh_Atem> stormi: someone has apparently seen this issue on single-display systems in Fedora as well
21:14:48 <stormi> well any idea about how to handle bug 19869?
21:14:49 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=19869 major, release_blocker, kde, NEW , After logging into Plasma from SDDM, the splash screen may freeze (STA1 updated 2016-11-29)
21:15:18 <david_david> yes when I got a  freeze here I stop the plasmashell service and restart it again, but when it freezers a login there is nothing to do exept "ctrl+alt+backward"
21:15:18 <Pharaoh_Atem> stormi: *shrugs*, it seems like an upstream bug, but no one has enough info to figure out what's causing it
21:15:55 <stormi> david_david: have you tried Ctrl+Alt+F2 then Ctrl+Alt+F1 instead of Ctrl-Alt-Backspace?
21:16:24 <stormi> The good thing is, since david_david has the issue, he'll maybe be motived to investigate it :)
21:16:34 <Pharaoh_Atem> :D
21:16:37 <david_david> stormi: when it freezes at login?
21:16:40 <stormi> david_david: yes
21:17:02 <stormi> it works for me and Arne and Jüri
21:17:03 <david_david> nop
21:17:59 <stormi> I'll add myself a reminder that if I see no progress within one week, I'll have to create a bug commando
21:18:34 <stormi> #action KDE packagers, investigate, others help, stormi create a bug commando if nothing moves on withing one week
21:18:46 <stormi> #info similar bug at Fedora
21:19:06 <stormi> #topic 18032
21:19:10 <stormi> crap
21:19:12 <stormi> #topic bug 18032
21:19:13 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=18032 critical, High, kde, NEW , sddm fails to register logins in /run/utmp, sddm
21:19:16 <david_david> I think it has come since kernel 4.8.10 series (not before with kernel 4.8.9), but not 100% sure
21:19:29 <Pharaoh_Atem> david_david: it's been this way for me since kernel 4.8.6
21:19:40 <david_david> ah
21:20:15 <Pharaoh_Atem> everything was fine in my tests on Fedora 25 pre-release in Plasma 5 (4.8.0~4.8.4), I think
21:20:25 <stormi> 18032 is not a blocker but is high priority and intended to be fixed before Mageia 6 according to its milestone, so I'd like us to review it too
21:20:36 <stormi> Don't be afraid, it's the last one
21:20:49 <Pharaoh_Atem> I'm not sure I consider this a bug
21:21:32 <Pharaoh_Atem> it might have actually been a design choice
21:21:40 <Akien> stormi: note that you can do #undo when you get the topic wrong :)
21:22:12 <Akien> Should it be cross-posted upstream?
21:22:13 <stormi> Akien: well no one reads the minutes :)
21:22:32 <Pharaoh_Atem> stormi: besides, apparently I have pts/0 now on sddm/Plasma 5 in Fedora
21:22:50 <Pharaoh_Atem> so apparently it registers now...
21:23:49 <stormi> ok, thanks for the comments
21:23:56 <stormi> #topic anything else
21:24:06 <stormi> neoclust: you wanted to discuss other things
21:24:10 <neoclust> stormi: yes
21:24:36 <neoclust> stormi: we have kde apps 16.08.3
21:24:47 <neoclust> i would like a last update to 16.12.*
21:24:53 <neoclust> it improves a lot kdepim
21:24:56 <neoclust> told by laurent
21:25:29 <Pharaoh_Atem> we're very close to kapps 16.12 release, aren't we?
21:26:13 <stormi> Are there regressions? :)
21:26:15 <neoclust> 16.11.90 already available
21:26:22 <neoclust> stormi: of course not, this is kde apps
21:26:23 <neoclust> :p
21:26:35 <stormi> Oh of course
21:26:48 <stormi> If it fixes the recent focus issue in kmail...
21:26:59 <stormi> (no bug report created for now but really annoying)
21:27:13 <neoclust> stormi: lmontel told me he worked a lot on bugfixing on kmail for 16.12
21:27:21 <stormi> \o/
21:27:30 <Pharaoh_Atem> neoclust: did okular get its kf5 port in 16.12?
21:27:39 <neoclust> let me look
21:28:53 <stormi> I really want to avoid delays and regressions, but maybe we could test it thoroughly from updates_testing?
21:29:08 <Pharaoh_Atem> I don't see why we couldn't
21:29:11 <stormi> and even ask QA for tests like they would for a real kde apps update
21:29:12 <neoclust> stormi: i can push all in testing
21:29:17 <neoclust> Pharaoh_Atem: yes for okular
21:29:20 <neoclust> Pharaoh_Atem: this is kf5
21:29:22 <Pharaoh_Atem> \o/
21:29:43 <Pharaoh_Atem> something definitely to look forward to!
21:29:52 <neoclust> stormi: so i update on the svn and i push in updates_testing
21:30:15 <stormi> I think it deserves a mail to dev@ in case someone has a very good reason for us not to do the upgrade
21:30:23 <Akien> Is updates_testing clean?
21:30:28 <stormi> good question
21:30:33 <Akien> After the openssl11 mess, I'm a bit wary of using it
21:30:48 <Akien> We should maybe get it emptied
21:30:49 <neoclust> Akien: i removed openssl11
21:31:11 <neoclust> [root@duvel updates_testing]# ls
21:31:11 <neoclust> media_info/  repodata/
21:31:18 <neoclust> Akien: next subject ? :p
21:31:29 <Akien> Ok, sounds good :D
21:31:40 <Pharaoh_Atem> :D
21:32:16 <Akien> So yeah, I think the update would be nice, but send a mail to dev@ just in case
21:33:00 <stormi> #action neoclust will send a mail to dev@ to propose to upgrade to latest KDE apps and push to updates_testing for us to test
21:33:29 <stormi> Anything else?
21:33:39 <neoclust> me, no :)
21:33:56 <stormi> Thanks for coming on a saturday evening
21:34:01 <neoclust> no pb :)
21:34:02 <stormi> #endmeeting