20:05:28 <Akien> #startmeeting
20:05:28 <Inigo_Montoya> Meeting started Wed Nov 23 20:05:28 2016 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:05:28 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:05:36 <Akien> #chair stormi ennael
20:05:36 <Inigo_Montoya> Current chairs: Akien ennael stormi
20:06:08 <Akien> Ok, welcome everyone for this dev meeting (yeah, those still exist from time to time, though Inigo_Montoya seems startled :p)
20:06:52 <stormi> Could everyone present say hi just so that we get to count ourselves?
20:06:55 <stormi> hi o/
20:07:03 <Akien> The aim is to go together through the list of release blockers (hopefully *quickly*) to ensure they're getting looked at, since on ML calls we're having difficulties getting stuff reviewed (understandbly, we're all busy, thus trying a live meeting approach)
20:07:05 <Akien> hi
20:07:08 <tmb> hi
20:07:48 <Akien> IRC really needs a ping * function. :p
20:08:26 <stormi> 3 of us, that'll be a small meeting
20:08:32 <Akien> Alright, I guess we can start with sysadmin bugs :)
20:08:44 * tmb hides quickly
20:08:47 <Akien> :p
20:09:27 <Akien> #info Blockers: http://madb.mageia.org/tools/blockers
20:09:34 <[mbot> [ Mageia App Db - Current Blockers ]
20:09:37 <Akien> #topic Sysadmin blockers
20:10:07 <Akien> #info https://bugs.mageia.org/show_bug.cgi?id=17072
20:10:09 <[mbot> [ Bug 17072 build system broken in new ways by ARM addition ]
20:10:27 <Akien> That first bug is about the small issues we're having in cauldron with the buildsystem which could be a bother on a stable release
20:10:49 <Akien> The main (blocking) issue being the one in comment 3, the rest is more cosmetic/quality of life
20:11:16 <Akien> Since we can't easily build core and tainted packages with the same rel, that could become a pain to handle in QA advisories
20:12:07 <Akien> I wonder, couldn't we just allow building the same version of a package at the same time in different repos?
20:12:16 <TheSuperGeek> Morning
20:12:17 <tmb> yeah, I'd really like pterjan and/or blino to look on fixing that as they know youri/emi/ulri/... best
20:12:31 <Akien> blino: are you around by any chance?
20:13:44 <Akien> Alright, let's move on, if they're not around there's not much to discuss
20:13:58 <Akien> Hi TheSuperGeek
20:14:00 <Akien> #info #info https://bugs.mageia.org/show_bug.cgi?id=18669
20:14:02 <[mbot> [ Bug 18669 Generate and provide AppStream repodata for GNOME Software and Plasma Discover ]
20:14:23 <Akien> This one is for Pharaoh_Atem's feature
20:14:33 <Akien> Or actually a bit more than that
20:15:18 <Akien> In comment 3 I asked what would be left to do to get this fully implemented, the question still stands :)
20:15:58 <stormi> I also asked on the sysadmin ML but without success for now
20:16:02 * Luigi12 saw Akien's post on bug 17072 and was reminded there's a meeting
20:16:26 <stormi> hi Luigi12
20:16:37 <Luigi12> hi :o)
20:16:39 <stormi> tmb: who among the sysadmin team would be able to address this?
20:17:52 <tmb> stormi, well, pterjad added the other metadata generation stuff, so he would be best... but I guess I could look what he did and replicate it with the added commands
20:18:38 <stormi> I'm ok with either, what's important is that the bug is assigned to someone and that someone commits to do the job :)
20:18:46 <Akien> It looks like Pharaoh_Atem needed some packages backported to infra_5, I'll try to see if he submitted them or just committed to svn.
20:18:59 <stormi> tmb: so maybe you could discuss it with pterjan
20:19:04 <Akien> If the latter, I'll tell him to submit to infra_5.
20:20:50 <tmb> Actually looking at the bug it should not be done as metadata generation as it will slow bs down... It will be better as a separate cron job
20:21:04 <Akien> Sounds better indeed.
20:21:45 <tmb> I'll do a trial run on my local repo to see how much time/cpu it will consume
20:22:26 <stormi> tmb: can we consider you're managing this one, or is that an engagement you can't take?
20:22:27 <tmb> and the packages are not built, but I can manage that
20:23:06 <Akien> (you can also take the engagement that you'll force pterjan to work on it :p)
20:23:37 <tmb> yeah, I'll take it on (and let pterjan fix up any mess later :)...)
20:23:59 <Akien> Nice workflow :D
20:24:25 <Akien> Last sysadmin bug for today:
20:24:27 <Akien> #info https://bugs.mageia.org/show_bug.cgi?id=19432
20:24:29 <[mbot> [ Bug 19432 RPM-MD repodata should always be signed with the Mageia key ]
20:25:04 <Akien> Apparently we sign packages but not the repodata, so that should be fixed before the final core/release repodata are generated
20:25:11 <stormi> This one seems simpler (at first) and kind of related
20:25:15 <david_david> hi all
20:25:34 <stormi> Reading the description, it says it's optional though, for better security.
20:25:39 <Akien> Hi david_david
20:25:44 <stormi> hi david_david
20:25:57 <neoclust> hi
20:26:06 <Akien> Yeah, I guess it wouldn't prevent the release all the way if it can't be fixed, but it's something that should ideally be implemented before the release
20:26:08 <anaselli> hi
20:26:11 <stormi> agreed
20:26:14 <neoclust> stormi: sorry i was at a meeting at the city all
20:26:16 <neoclust> hall
20:26:18 <stormi> hi neoclust and anaselli
20:26:26 <stormi> neoclust: np, thanks for coming
20:26:37 <stormi> this is beginning to look like a meeting
20:26:42 <Akien> :)
20:27:07 <anaselli> actually i was reading... than i realized you asked for a hi password :D
20:27:08 <tmb> well, technically urpmi/rpm will barf if the rpm packages are not signed so security-wise we already get notifications
20:27:50 <anaselli> then
20:28:16 <stormi> tmb: and does it appear to require a lot of work?
20:28:23 <tmb> yeah, and technically we can add signing later on stable repos too
20:29:53 <tmb> stormi, should not be much work, just an additional call to signbot for the metadata... should not slow down the bs
20:30:43 <stormi> tmb: and in terms of "who", I suppose the usual suspects are yourself, pterjan, and maybe someone else?
20:31:06 <neoclust> stormi: i can do it too
20:31:29 <stormi> ok :)
20:31:33 <Akien> neoclust: That would be great if you're up for it
20:31:40 <tmb> neoclust, do you want to do it ? :)
20:31:42 <stormi> so at this stage we need someone who actually says I'll do it :)
20:31:56 <neoclust> tmb: i can help
20:32:04 <neoclust> not right now
20:32:11 <neoclust> i need to fix some stacks first
20:32:12 <stormi> be careful neoclust, there are lots of KDE team blockers too :)
20:32:13 <neoclust> :)
20:32:19 <Akien> Those are for david_david :p
20:33:44 * david_david hides \o/
20:33:46 <Akien> neoclust: Can I assign you to the bug then with the comment that you'll have a look?
20:33:51 <david_david> If I knew how to solve them it would already be done! :(
20:34:07 <neoclust> Akien: show me the bug first :)
20:34:17 <Akien> neoclust: https://bugs.mageia.org/show_bug.cgi?id=19432
20:34:19 <[mbot> [ Bug 19432 RPM-MD repodata should always be signed with the Mageia key ]
20:34:32 <Akien> I'll let you assign yourself if you want to give it a try then, let's move on to discuss another bug
20:34:38 <stormi> ok
20:34:44 <neoclust> Akien: tell i try to take a look :p
20:34:59 <neoclust> Akien: if i don't pass to fix this i will mail tmb and pterjan to have some infos
20:35:05 <Akien> neoclust: Great, thanks
20:35:23 <joeghi> Hi guys
20:35:46 <Akien> Hi joeghi and filip
20:35:46 <stormi> this bug was promoted from "assigned to a team" to "someone will actually look at it", that's the purpose of this meeting and it's great :
20:35:49 <stormi> :)
20:36:12 <marja> :-)
20:36:16 <joeghi> any summary?
20:36:34 <stormi> We've reviewed sysadmin blockers
20:36:39 <anaselli> sysadmin bloker indeed :)
20:36:48 <Akien> Link: http://madb.mageia.org/tools/blockers
20:36:50 <stormi> since when we started only tmb was there with Akien and me
20:36:54 <Akien> Refresh the page btw, there were some updates
20:36:55 <[mbot> [ Mageia App Db - Current Blockers ]
20:37:09 <joeghi> stormi: thanks for the remind
20:37:28 <Akien> I suggest we now go through the pkg-bugs@ bugs, that should be quick (only four of them and two new trackers with not much info, so not much to say)
20:37:41 <Akien> #topic "All packagers" (pkg-bugs@) blockers
20:37:44 <Akien> Hi Donald
20:37:56 <Akien> It's getting crowded here, it's great :)
20:38:08 <Akien> A simple bug to start:
20:38:09 <Akien> #info https://bugs.mageia.org/show_bug.cgi?id=18579
20:38:11 <[mbot> [ Bug 18579 Add the new mageia application menu icon to all DE ]
20:38:38 <Akien> This one is just about branding, and the current status is that the new Mageia "menu" icon needs to be implemented for MATE and Enlightenment
20:38:41 <Akien> Volunteers? :)
20:39:01 <stormi> That's what we need here indeed, a volunteer
20:39:32 <Akien> It should be quite simple, find out how the DE configures its menu icon, and make it use /usr/share/icons/hicolor/scalable/apps/mageia-menu.svg (or a png variant if needed)
20:39:46 <Akien> Hi AlexL
20:40:02 <AlexL> Hi Akien
20:40:23 <Akien> Anyone familiar with either MATE or Enlightenment, or willing to try them?
20:40:34 <stormi> if we can't find a volunteer for this one, then we're doomed :)
20:40:54 <stormi> because it means it will be even harder for the other ones
20:40:54 <anaselli> which is the mate metapackage?
20:41:08 <Akien> $urpmq -Y mate
20:41:11 <Akien> :)
20:41:15 <Akien> task-mate
20:41:39 <anaselli> let's have a look at it... but i will ping you when and if i understand how to...
20:41:43 <Akien> There's a matemenu-mageia-layout, sounds like a good candidate
20:42:13 <stormi> and for enlightenment the maintainer, trem, has told me he probably will be too busy for doing it
20:42:18 <Akien> anaselli: Can we appoint you as "bug watcher"? i.e. you'll ensure that the bugs gets worked on and fixed (even if not by you)
20:42:28 <Akien> *the bug
20:42:41 <anaselli> 18579?
20:42:48 <stormi> yes
20:42:49 <Akien> Yeah
20:43:09 <Akien> I'm already registered as the "watcher" for this, but I'm not against delegating a bit :)
20:43:46 <anaselli> no i will try to fix mate, i cannot test all
20:44:06 <Akien> anaselli: ok, that's fine already :)
20:44:14 <Akien> david_david: up to test enlightenment? :)
20:44:57 <david_david> Akien: I'll try this week-end if I can/found something :)
20:45:01 <Akien> Thanks :)
20:45:43 <Akien> Next bug
20:45:46 <stormi> #info anaselli looks at mate and david_david looks at enlightenment
20:45:48 <Akien> #info https://bugs.mageia.org/show_bug.cgi?id=18890
20:45:50 <[mbot> [ Bug 18890 [6sta1]partway through upgrade from Mga5 to Mga6 "Error: 'script' failed for GConf2-3.2.6-8mga5.i586...." ]
20:46:04 <stormi> oops that was #action actually
20:46:34 <Akien> Given the age of this bug, I think that the main step needed would be to attempt an urpmi upgrade from mga5 to cauldron and see if there are still scriplet failures
20:46:40 <Akien> If there are, they need to be debugged :)
20:46:54 <Akien> Anyone with a mga5 VM at hand?
20:47:08 <filip> hi Akien
20:49:23 <Akien> Well, let's say bug 18890 will have to wait for the new ISOs and some QA lobby to grab your attention :)
20:49:28 <stormi> I could test but I'd rather someone else to do it since I was wanting to give a hand on other bugs
20:49:57 <stormi> but yeah QA will catch it, so fixing the issues before could speed the ISO testing phase up
20:49:59 <Akien> For info btw, we should have new ISOs for Mageia 6 sta2 relatively soon
20:50:25 <Luigi12> I looked at 18890 and don't understand how it could be happening
20:50:26 <Akien> If you're not in the QA ISO testing list, it's the right moment to get in it to try the new ISOs
20:50:42 <Akien> I expect that the new ISOs will need at least as many dev eyes as QA
20:51:08 <Akien> #info Add yourself to https://wiki.mageia.org/en/QA_ISO_testers to get the link and download info for testing ISOs of 6 sta2
20:52:13 <Luigi12> ben used to keep reminding us about 18890 that he was still seeing it in his repeated upgrade tests, but I don't think he's mentioned it (certainly not on the bug, but also on qa-discuss) in a while, so maybe it resolved itself
20:52:46 <Akien> Right, will comment that on the bug
20:53:13 <stormi> Maybe he stopped testing because of lack of ISOs and the fact that the QA team mindset switched to "5.1" mode for a whie
20:53:16 <stormi> while*
20:53:21 <stormi> but better ask him
20:53:23 <Luigi12> could be
20:53:27 <Akien> I commented that it needs retesting
20:53:39 <stormi> anyways, will report.bug.xz give any useful information?
20:53:48 <Akien> The next two bugs assigned to pkg-bugs@ are trackers for "Good luck" failures (at the sddm step if I understood correctly)
20:54:01 <Akien> Yes, it should at list pinpoint packages that triggered the problem
20:54:06 <stormi> ok
20:54:10 <tmb> well, wothout looking closer right now the fix for 18890 might need to be fixed in mga5 (as mga6 package might already be fixed)...
20:55:41 <tmb> or just add an upgrade trigger in mga6 doing the stuff the mga5 package uninstall fails to do...
20:56:01 <Akien> Thanks, will comment that on the bug too to help with debugging
20:56:48 <Akien> I'm not sure of the status of those "Good luck" issues, but they're bound to be as annoying as the "Oh no" GDM bugs in Mageia 5
20:56:57 <stratocaster7hom> Did you notice https://bugs.mageia.org/show_bug.cgi?id=19834 which is blocking 19782 re: prefdm and sddm
20:56:59 <[mbot> [ Bug 19834 prefdm breaks sddm in KVM ]
20:57:05 <tmb> anyway I think tv fixed urpm* to be more verbose/specific about the "script" failures
20:58:09 <Akien> stratocaster7hom: Right, that one should maybe be promoted to release_blocker (at least until further debugged, so that we don't overlook it)
20:58:12 <Luigi12> tmb: yeah it hypothetically could be a mga5 package problem, we've had that happen before, but I looked at it and don't see what could be wrong :o(
20:59:15 <stormi> about that prefdm vs sddm bug, I admit I haven't read all the comments, but my impression was that we haven't done more (as packagers) than scratch the surface a little
20:59:38 <stormi> I'm quite sure that one person focused on it with tenacity would find a solution
21:00:08 <Akien> I think joeghi and Pharaoh_Atem have been digging into this stuff recently
21:00:10 <Luigi12> I guess update-alternatives could be misbehaving somehow
21:00:23 <stormi> Luigi12: could be indeed
21:00:31 <stormi> (about the previous bug, isn't it?)
21:00:39 <Luigi12> yep
21:00:50 <Luigi12> we did change the update-alternatives implementation during this cycle after all
21:00:57 <Akien> True
21:01:57 <stormi> so back to prefdm vs sddm
21:02:42 <Luigi12> we could possibly change gconftool to just be a direct symlink to gconftool-2 and drop the alternatives stuff, since there doesn't seem to be another alternative for it anymore (probably hasn't been since the gtk+1 days)
21:03:55 <Akien> Do we have a volunteer to do some debugging on this prefdm stuff and document their findings in the appropriate bug report and/or the dev ML? :)
21:04:04 <Akien> Right now we lack an overview of what the problem(s) are I think
21:04:11 <stormi> Indeed
21:04:20 <Akien> joeghi: As you got started IIRC, that would be nice if you could lead that further
21:04:43 <stratocaster7hom> I plan on doing some testing when I get to work on Monday but I'm still a novice so I don't know how much that will help.
21:04:58 <Akien> stratocaster7hom: Like a lot :D Most of us are novices hehe
21:05:16 <Akien> *Likely
21:05:28 <Luigi12> stratocaster7hom: yeah it'll definitely help
21:05:46 <Akien> #action stratocaster7 will do some initially digging in the prefdm/sddm issue(s)
21:06:02 <Akien> stratocaster7hom: Ask for help when needed and don't hesitate to say it if you're hitting a wall :)
21:06:11 <stratocaster7hom> Akien: I will.
21:06:17 <Akien> Thanks
21:06:53 <Akien> Next in the list, we have an mcc on wayland issue
21:06:59 <Akien> #info https://bugs.mageia.org/show_bug.cgi?id=19498
21:07:01 <[mbot> [ Bug 19498 mcc doesn't start on Wayland ("No protocol specified") ]
21:07:22 <Akien> (Just to reassure you, we won't go through the *whole* list. I think we'll leave at least the KDE bugs for a KDE-focused meeting)
21:07:54 <stormi> And maybe a mageia tools meeting likewise
21:08:54 <Akien> Yeah
21:08:57 <stormi> so about bug 19498 I put a status comment saying it's upstream
21:09:07 <stormi> and that fedora has the same issue
21:09:27 <stormi> how "much" do we support gnome on wayland in Mageia 6?
21:09:28 <Akien> Someone mentioned a fix in Arch but I don't see any link to the bug report as was asked
21:09:36 <stormi> yeah there's no fix in arch
21:09:38 <Akien> I think GNOME on wayland is the default for GNOME
21:09:48 <Akien> So it should ideally work well.
21:09:50 <joeghi> Akien: I'm little lagged in reading...
21:09:51 <Luigi12> even for Mageia?
21:10:40 <Akien> At least I think GNOME starts with the wayland flavour by default
21:10:54 <Luigi12> if so, maybe we could change it to default to use X, since we have put no work into Wayland specifically beyond packaging it, unlike Fedora which has tested and worked it extensively for a couple yars
21:10:56 <Luigi12> years
21:11:00 <joeghi> many of the bugs of the display manager have a common root in xinitrc
21:11:16 <Luigi12> joeghi: well step 1 is identifying , step 2 is fixing
21:11:37 <joeghi> Luigi12: there is already a bug report, I posted a solution, let me find the bug #
21:11:43 <Luigi12> I think I might have diagnosed the 18890 issue and posted on that bug, BTW
21:11:44 <Akien> joeghi: Could you ensure that your findings are properly documented in a relevant bug report?
21:11:45 <Akien> Ah nice
21:12:35 <Pharaoh_Atem> yo
21:12:37 <Pharaoh_Atem> I'm here
21:12:38 <stormi> hi Pharaoh_Atem
21:13:05 <joeghi> #18199 for instance.
21:13:23 <Pharaoh_Atem> I know you're on another topic, but just going quickly back to the prefdm thing
21:13:34 <Pharaoh_Atem> I was able to reproduce the working solution on real hardware as well
21:13:45 <Luigi12> actually we are on that topic
21:13:48 <Pharaoh_Atem> so killing prefdm and using the service directly fixed it for me completely
21:13:55 <Luigi12> well that's just a workaround :o(
21:14:07 <Luigi12> but it confirms (probably) the source of the issue
21:14:11 <Luigi12> so it should be fixable
21:14:11 <Pharaoh_Atem> well, prefdm was a workaround to begin with
21:14:30 <stormi> well we had started to address another bug but since joeghi an Pharaoh_Atem are here or back, let's try to continue on the prefdm / sddm issue
21:14:38 <Pharaoh_Atem> okay
21:14:52 <stormi> aka pain-in-the-***-number-1-for-mageia-6
21:14:56 <Pharaoh_Atem> haha
21:15:01 <Luigi12> joeghi: if you think you have a fix, don't be afraid to commit it
21:15:05 <Pharaoh_Atem> so, prefdm keeps whacking sddm to start until it dies completely
21:15:27 <Luigi12> stormi: oh yeah, the Wayland thing, I forgot already :o)
21:15:32 <Akien> Basically coling is MIA, so we can't count on his expertise on systemd stuff sadly.
21:15:42 <neoclust> yes please commit and we will reviex / test
21:15:43 <joeghi> Luigi12: I posted more than one solution but the only comment was that it has been already fixed, while indeed doesn't work. My solution also fixes the gnome-classic.
21:15:45 <Akien> So yeah, feel free to do fixes for the prefdm stuff if you have a good lead.
21:15:46 <neoclust> review
21:15:49 <Pharaoh_Atem> whereas, when sddm is started naturally through the display-manager.service target (done with systemctl enable sddm), it works
21:16:14 <Luigi12> joeghi: ok, please commit your fix, even if it turns out to be wrong, we can continue to work it
21:16:28 <joeghi> ok.
21:16:45 <stormi> can we appoing joeghi + Pharaoh_Atem prefdm fixers?
21:16:49 <stormi> appoint*
21:16:55 <Akien> + stratocaster7hom as tester :)
21:17:06 <neoclust> nice
21:17:07 <stormi> It's important to me that who's working on it is identified at this stage
21:17:13 <Akien> +1
21:17:28 <Pharaoh_Atem> I'm not sure how to fix prefdm itself, though
21:17:30 <stormi> ideally people who really want to kill that bug for godd
21:17:32 <stormi> good
21:17:42 <Akien> For god too if you're into that :p
21:18:03 <stormi> trying seriously would be great already
21:18:05 <joeghi> Indeed for Virtualbox, another common solution (at least for 64bit) is to boot adding "nomodeset iomem=relaxed"
21:18:05 <Pharaoh_Atem> if we want to keep using it, I'm not sure how to fix it, since I'm not sure why it keeps spawning the display manager instead of letting it start
21:18:19 <Pharaoh_Atem> nothing in the prefdm script indicates it should do that
21:18:29 <joeghi> to boot cmdline. without that no correct boots.
21:18:42 <joeghi> I mean running mga6 inside VBox.
21:19:17 <stormi> so are you our killer team (while still not hesitating to call for help)?
21:19:37 <stratocaster7hom> Pharaoh_Atem: Last I looked I thought systemd was poking prefdm (which might in turn poke sddm).
21:19:47 <stormi> I think I could help debugging sddm if that can help
21:19:56 <stormi> I'm developing daily with Qt
21:20:22 <stormi> ok new dream team: Pharaoh_Atem + joeghi + stratocaster7hom + stormi?
21:20:38 <Akien> I'd bet on that one :)
21:20:45 <tmb> going once ... going twice ... sold
21:20:47 <Pharaoh_Atem> stormi: maybe, the "Restart=always"
21:20:50 <stormi> + anyone who wants
21:20:56 <Pharaoh_Atem> and the lack of the RestartSec delay
21:21:03 <Luigi12> FYI stratocaster7hom will soon be a full-blown member of the packaging team too :o)
21:21:08 <Pharaoh_Atem> awesome
21:21:09 <stormi> great :)
21:21:09 <Akien> \o/
21:21:13 <Pharaoh_Atem> more packagers! :D
21:21:38 <Akien> stormi: I'd appoint as team secretary, to make sure the hackers findings are properly routed to the relevant bug reports
21:21:53 <stormi> Ok for tonight I think it's enough regarding this bug, since we have others to review, but we'll work on it
21:22:14 <Akien> stormi: The hardest part of those prefdm issues is that they seem to affect different other bugs (e.g. sddm segfault on accented characters could very well be linked)
21:22:20 <Pharaoh_Atem> joeghi, stormi: a hint might be to add a restartsec delay greater ~5 sec or more
21:22:29 <Akien> So this prefdm stuff definitely needs a bugsquad guru :D
21:22:44 <stormi> I'll add marja then :)
21:22:49 <stormi> It needs QA testers too
21:22:57 <Pharaoh_Atem> because one of the errors is "start request repeated too quickly"
21:23:08 <Luigi12> bingo
21:23:15 <stormi> Pharaoh_Atem: that could be as simple as that
21:23:35 <Akien> Don't hesitate to document the various things on a dev@ email, it's a lot of info :D
21:23:40 <stormi> Ok, in the coming week we squash this bug
21:23:52 <stormi> we let it survive far too long
21:23:54 <Akien> It's hard (for me at least) to keep a good overview of this prefdm stuff
21:24:37 <Akien> Shall we move on?
21:24:41 * stormi nods
21:24:51 <Luigi12> so we can switch Gnome back to Xorg?
21:25:02 <stormi> back to that gnome + wayland issue
21:25:09 <Akien> Luigi12: I proposed that on the bug report, asking the gnome maintainers to complain if they don't agree :)
21:25:13 <Luigi12> ok cool
21:25:27 <Luigi12> maybe revisit Wayland for mga7 when KDE/Plasma will probably support it fully too
21:25:32 <Akien> But as immediate solution that sounds good, + errata entry for GNOME on Wayland
21:25:39 <Luigi12> sure
21:25:50 <stormi> not drawbacks in using Xorg?
21:25:56 <stormi> no*
21:26:04 <Luigi12> not really, that's basically just status quo
21:26:05 <stormi> I mean, expected breakages
21:26:10 <stormi> good
21:26:19 <stormi> Seems the way to go
21:26:27 <Luigi12> long-term the benefit of Wayland (one of them) is the better separation wrt to security concerns, but only flatpak fully takes advantage of that
21:26:35 <Luigi12> but no, no breakages for using Xorg
21:26:46 <stormi> Since gnome maintainers are not always responsive, does someone volunteer to do the switch?
21:26:53 <Akien> Was about to ask that :)
21:26:59 <Pharaoh_Atem> woo, fixed
21:27:08 <stormi> Pharaoh_Atem: prefdm?
21:27:15 <Pharaoh_Atem> I think so
21:27:16 <Akien> That was fast :D
21:27:21 <stormi> We'll have to test that then
21:27:22 <Pharaoh_Atem> I'm doing a few reboots to be sure
21:27:22 <Luigi12> these meetings are great
21:27:26 <Akien> :D
21:27:26 <Pharaoh_Atem> but yeah, I think I just got it
21:27:52 <tmb> by this rate we'll release mga6 by the end of this week :)
21:27:54 <Pharaoh_Atem> adding a drop-in conf to bump restartsec=5s
21:27:56 <Luigi12> haha
21:27:58 <Pharaoh_Atem> that made it work
21:28:09 <Pharaoh_Atem> it briefly shows the good luck message, but then sddm starts
21:28:15 <Pharaoh_Atem> I'm going to see if I can make it tighter
21:28:23 <stormi> oh, it still shows the good luck message though
21:28:24 <Pharaoh_Atem> yep, five reboots and it works
21:28:29 <Pharaoh_Atem> briefly, but it goes away
21:28:31 <Luigi12> maybe joeghi's fix will get rid of good luck completely
21:28:38 <joeghi> stormi: latest git sddm has a series of fix like the following fix: https://github.com/sddm/sddm/commit/5fc7044ac1f3e32c9243e61732215576eea389e3, could that fix the problem with accented chars someone spotted?
21:29:01 <Luigi12> looks likely
21:29:04 <Luigi12> worth adding the patch
21:29:04 <Pharaoh_Atem> neoclust: is Plasma desktop supposed to be using Oxygen and really old looking icons?
21:29:16 <stormi> I do reproduce the accented chars issue so I can test
21:29:17 <Luigi12> thought we were going with Breeze?
21:29:23 <Akien> Pharaoh_Atem: I don't think so, it's Breeze normally
21:29:24 <Pharaoh_Atem> that's what I thought too
21:29:28 <neoclust> Pharaoh_Atem: no, it is supposed to use breeze
21:29:33 <Pharaoh_Atem> but the fresh netinstall was oxygen :(
21:29:40 <Pharaoh_Atem> everything looks old :(
21:29:49 <neoclust> Pharaoh_Atem: screenshot please
21:30:03 <Pharaoh_Atem> one sec
21:30:06 * Luigi12 would like choices of the KDE1 and KDE2 Crystal icon sets :D
21:30:27 <Akien> neoclust: BTW would be nice to check meta-task and ensure that oxygen is not force pulled-in on ISOs
21:30:39 <Akien> Since we don't use it anymore, we don't need to bloat ISOs with it and risk it being used :)
21:30:56 <Luigi12> yeah tv and I did some cleaning in meta-task, but maybe it could use more
21:31:32 <tmb> no references to oygen in meta-task
21:31:40 <Akien> Nice
21:31:40 <tmb> *oxygen
21:31:49 <Pharaoh_Atem> neoclust: http://i.imgur.com/fUPWkrZ.png
21:31:51 <stormi> joeghi: please reference this patch in bug 18822
21:31:53 <joeghi> Akien: speaking of ISOs, can we have more transparency on how it's built? What is included, the scripts, etc.
21:32:18 <Luigi12> we have a ISO builder group, it's new
21:32:19 <Akien> joeghi: That's planned, or more specifically, the plan is to setup a real ISO building team
21:32:21 <neoclust> Pharaoh_Atem: where is it old ?
21:32:29 <stormi> joeghi: we intend to do an ISO builders team startup meeting soon
21:32:41 <Pharaoh_Atem> instead of the breeze and new-style icons, I'm seeing Oxygen ones
21:32:56 <Luigi12> Pharaoh_Atem: do you mean the Dolphin and systemsettings icons?
21:32:58 <Pharaoh_Atem> for example, look at Konsole, Dolphin, Konqueror, System Settings
21:33:00 <Pharaoh_Atem> yes
21:33:00 <tmb> joeghi, bcd in git for CI, draklive-config for live medias (and both following meta-task)
21:33:14 <neoclust> Akien: what is the new one ?
21:33:16 <Akien> Hi pterjan
21:33:25 <Pharaoh_Atem> incidentally, I originally set up this VM so that I could start spinning mga6 ISOs
21:33:28 <pterjan> Hi
21:33:36 <Pharaoh_Atem> I just don't know how :(
21:33:46 <Akien> neoclust: what do you mean?
21:33:58 <Luigi12> Pharaoh_Atem: we really need to investigate proyvind's alternative to bcd
21:34:15 <neoclust> Pharaoh_Atem: what is the new one ?
21:34:18 <neoclust> Akien: wasn't for you :)
21:34:19 * stormi tries to remember what the current bug report being discussed was
21:34:36 <Luigi12> stormi: I think we finished with the Wayland one, other than wondering who'd commit the change
21:34:40 <Akien> stormi: it was "next bgu" :p
21:34:44 <Akien> *bug
21:34:45 <Luigi12> so we were about to move on to 18978 I think
21:34:50 <Akien> Yeah
21:34:58 <stormi> Well we don't know who commits the change
21:34:58 <Luigi12> which ties into the meta-task discussion actually
21:35:10 <stormi> so the bug risks just wait
21:35:34 <neoclust> Luigi12: all is OK on the meta task part
21:35:40 <Akien> Well I volunteer not to implement it, but to ensure we get an answer from Olav
21:35:41 <stormi> give me a name and I don't kill your beloved ones
21:35:44 <Luigi12> neoclust: yeah it appears so
21:35:48 <Luigi12> strange
21:35:51 <neoclust> Luigi12: i did some QA and CAT_X is not used on the installer
21:35:54 <stormi> Akien: pterjan, here present, is in the gnome group too
21:36:01 <Akien> I don't want us to change the default GNOME without at least trying to get his opinion
21:36:09 <Akien> Or we give the bug to pterjan then :D
21:36:24 <Luigi12> hot potato
21:36:25 <neoclust> tmb: maybe you can have an idea, but if  i look on the debug ddebug.log, i don't see CAT8X at all on current cauldron install
21:36:28 <Pharaoh_Atem> neoclust: give me a sec
21:36:36 <Akien> Since he skillfully timed out before we discussed sysadmin bugs :p
21:37:05 <Akien> pterjan: Would you agree to have a closer look to https://bugs.mageia.org/show_bug.cgi?id=19498 ?
21:37:07 <[mbot> [ Bug 19498 mcc doesn't start on Wayland ("No protocol specified") ]
21:37:15 * pterjan just arrived home and has no idea what is being talked about
21:37:19 <joeghi> stormi: done.
21:37:33 <Luigi12> pterjan: we assigned you 15 bugs in the last hour
21:37:35 <pterjan> I can probably look but my mageia has no X
21:37:45 <Akien> pterjan: Good, it's wayland :p
21:37:48 <pterjan> (well also, no monitor)
21:38:01 <Luigi12> pterjan used the guillotine
21:38:46 <Pharaoh_Atem> neoclust: http://i.imgur.com/3dmHbiE.png
21:39:20 <pterjan> I see, I'll have a look
21:39:24 <Akien> pterjan: Well, don't want to jump at your throat when you're just arriving home. If you can have a look at https://bugs.mageia.org/show_bug.cgi?id=19498 at some time, would be great (especially if you agree with our current idea to default GNOME to X11 instead of Wayland, as a workaround)
21:39:26 <[mbot> [ Bug 19498 mcc doesn't start on Wayland ("No protocol specified") ]
21:39:27 <neoclust> Pharaoh_Atem: i will take a look then
21:39:28 * pterjan has never seen wayland :)
21:39:28 <stormi> Pharaoh_Atem: neoclust: try to do it in private messages to help us keep the flow :)
21:39:29 <Akien> Thanks :)
21:39:34 <Luigi12> neoclust: doesn't compssUsers.pl or something like that determine which categories from rpmsrate are used?
21:39:43 <Akien> #action neoclust and pterjan will have a look at https://bugs.mageia.org/show_bug.cgi?id=19498
21:39:45 <[mbot> [ Bug 19498 mcc doesn't start on Wayland ("No protocol specified") ]
21:39:50 <pterjan> I'll try to learn more about it before commenting
21:40:04 <Akien> Perfect.
21:40:11 <stormi> Akien: neoclust was talking about a different bug
21:40:21 <neoclust> sorry
21:40:23 * neoclust hides
21:40:27 <Akien> Ah :D
21:40:29 <Akien> #undo
21:40:29 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0xb69e68ac>
21:40:36 <Akien> I thought it weird too that neoclust volunteers for a gnome bug :p
21:40:45 <Pharaoh_Atem> haha
21:40:46 <neoclust> Akien: never :p
21:40:46 <Akien> #action pterjan will have a closer look at https://bugs.mageia.org/show_bug.cgi?id=19498
21:40:48 <[mbot> [ Bug 19498 mcc doesn't start on Wayland ("No protocol specified") ]
21:41:00 <Luigi12> neoclust: wrt to 18978 have you looked at compssUsers.pl?
21:41:03 <stormi> I guess your plan to ask olav about his opinion is good too and should be done in paralell
21:41:10 <Akien> #action neoclust will have a look at an issue of mixed oxygen/breeze icons in plasma
21:41:15 <Akien> Yeah
21:41:17 <tmb> neoclust would probably fix gnome with a lot of obsoletes in task-plasma*
21:41:21 <Akien> :p
21:41:22 <stormi> :)
21:41:23 <Luigi12> :D
21:41:24 <neoclust> tmb: :)
21:41:38 <neoclust> i am neoclust
21:41:42 <neoclust> and i approve this message
21:41:44 <stormi> the kind of joke I'll have trouble repeating to my wife
21:41:46 <Akien> Ok, I have only two bugs left on schedule
21:41:48 <Pharaoh_Atem> hah
21:41:55 <neoclust> stormi: :)
21:42:14 <Luigi12> stormi: just tell her he got tired of gnomes stealing his underpants
21:42:21 <Akien> So I propose we go quickly through them, and then you guys can continue discussing the current hot topics if you want, but the meeting will be formally ended for those who need a break :)
21:42:25 <Luigi12> (show her the South Park if she doesn't get that either)
21:42:57 <Akien> #info https://bugs.mageia.org/show_bug.cgi?id=18978
21:42:59 <[mbot> [ Bug 18978 Firefox missing from classic installs ]
21:43:02 <Akien> So this one was already mentioned above
21:43:19 <Akien> ennael said it was fixed on 5.1 ISOs, but we don't know the status for cauldron
21:43:30 <Luigi12> last someone checked it was still a valid bug
21:43:42 <Luigi12> but that was at least a month ago I think
21:43:48 <Akien> Yep, valid on Nov 6th
21:43:55 <Luigi12> oh ok, less than a month
21:43:58 <Akien> So that's likely not fixed yet.
21:44:03 <Luigi12> indeed
21:44:21 <Luigi12> and the corollary is that chromium-browser *was* getting installed and it wasn't apparent why
21:44:32 <stormi> where does that kind of bug get fixed?
21:44:42 <Akien> meta-task or bcd?
21:44:43 <stormi> deps? metatask?
21:44:52 <Luigi12> probably meta-task or bcd or the installer
21:45:05 <Luigi12> well probably not bcd
21:45:14 <Akien> Does someone know how it could be debugged during a netinstall?
21:45:16 <Luigi12> since it affects installs via boot.iso too
21:45:41 <Luigi12> Akien: the logs in /root/drakx might have a hint
21:45:48 <stormi> if it was fixed in mga 5.1 ISOs maybe the cause in cauldron is the same,
21:45:50 <stormi> ?
21:45:55 <neoclust> stormi: no
21:45:59 <neoclust> stormi: not the same issue
21:46:02 <Akien> My gut feeling is that it was different on mga5
21:46:02 <stormi> too bad
21:46:03 <Luigi12> I don't remember it affecting mga5
21:46:05 <neoclust> was http://gitweb.mageia.org/software/drakx/commit/?h=distro/mga5&id=9303e5cffffac9fb5e470ab8cfd5eadf3912c342
21:46:06 <[mbot> [ drakx - Mageia Installer and base platform for many utilities ]
21:46:08 <neoclust> for mga5
21:46:12 <stormi> ok
21:46:20 <Akien> Thanks for the info :)
21:46:24 <neoclust> stormi: here i don't see the CAT_X called
21:46:30 <neoclust> i think this is why
21:46:40 <Luigi12> neoclust: then maybe compssUsers.pl has the answer for fixing it
21:46:41 <neoclust> but i didn't found why CAT_X isn't called
21:46:53 <neoclust> Luigi12: i looked but didn't found anything
21:46:55 <Luigi12> ok
21:47:08 <Akien> neoclust: maybe add this info to the bug report and reping tv
21:47:32 <tmb> neoclust, iirc if there are duplicated CAT_* at wrong places, they will be ignored
21:48:08 <tmb> IIRC I fixed a similar bug for mga5...
21:48:32 <neoclust> tmb: in meta-task ?
21:49:13 <stormi> is someone volunteer for being this bug's "watcher" and ensure it gets worked on, either by themselves or someone else?
21:49:47 <tmb> neoclust, yeah, iirc in rpmsrate-raw
21:50:32 <anaselli> Akien: mate start menu icon should be fixed but.... argh... for me https://bugs.mageia.org/show_bug.cgi?id=19467 is blocker also :(
21:50:34 <[mbot> [ Bug 19467 since vim-8.0.3, it is impossible to copy from view in konsole and gnome-terminal to another application ]
21:50:43 <Akien> anaselli: Awesome, and lol :D
21:51:08 <stormi> anaselli: just fix it too :P :)
21:51:08 <neoclust> Akien: please test next vim
21:51:17 <anaselli> Akien: though we added a tarball with our icons... maybe that should be managed better...
21:51:30 <anaselli> stormi: awensome
21:51:40 <stormi> not me, neoclust
21:51:57 <neoclust> anaselli: please test next vim
21:52:08 <Pharaoh_Atem> stormi: quick aside, I threw an update into bug 19432 with my findings, maybe we can do something about it with the info
21:52:13 <Akien> neoclust: So can we appoint you as bug watcher for that firefox issue?
21:52:15 <Pharaoh_Atem> gah
21:52:17 <Pharaoh_Atem> not 19432
21:52:18 <Luigi12> yeah I thought 19467 was fixed on the 8th
21:52:30 <neoclust> Akien: i can QA but i won't fix :)
21:52:32 <Luigi12> neoclust: thanks for the security update
21:52:33 <Pharaoh_Atem> stormi: I mean bug 19834
21:52:36 <Akien> neoclust: yeah that's the idea :)
21:52:56 <neoclust> Akien: ok then
21:53:27 <Akien> Last blocker for today:
21:53:28 <Akien> #info https://bugs.mageia.org/show_bug.cgi?id=18976
21:53:30 <[mbot> [ Bug 18976 6RC Live 64-bit isos fail to boot on NVidia machines because of graphics problems ]
21:53:51 <neoclust> Akien: i don't use nvidia, so don't look me this way :)
21:53:53 <stormi> (I would just add another one after that if tmb is still there)
21:53:55 <Akien> That's typically in tmb's expertise
21:54:24 <david_david> hmmmm!
21:54:26 <david_david> $ mgarepo co task-enlightenment
21:54:26 <Akien> We might want to have the new lives Martin is preparing first though
21:54:27 <david_david> ssh: Could not resolve hostname svn.mageia.org: Name or service not known
21:54:40 <Akien> david_david: Too much dev activity tonight :p
21:54:45 <neoclust> david_david: works for me
21:55:12 <Luigi12> Akien: did we do 19826 and 18669 already?
21:55:36 <Akien> Luigi12: We did 18669
21:55:42 <Akien> Luigi12: I don't see 19826 in the list
21:55:53 <joeghi> Akien: As for 18976 weren't nvidia proprietary drivers built on the fly with dkms for Live ISO, I read this was also added for 5.1
21:55:58 <Luigi12> Akien: 19826 is under Anne
21:56:04 <tmb> well 18976 could partly be due to prefdm thingie so it needs to be re-tested with new isos
21:56:22 <neoclust> Luigi12: yes for 18669
21:56:26 <Akien> Luigi12: That's a 5.1 bug
21:56:37 <Luigi12> haha, oops
21:56:46 <Akien> Luigi12: If you refresh the list it goes away :p
21:56:52 <Luigi12> ahh
21:56:54 <anaselli> brb
21:57:08 <tmb> stormi, what would you add ?
21:57:08 <Akien> tmb: ok, thanks
21:58:31 <Luigi12> stormi: was not listing the security tool under tools in the left column on purpose?
21:58:52 <Akien> Luigi12: Yeah, because users could see it and think "shit, Mageia is so unsecure!!"
21:59:01 <Luigi12> Akien: I thought that might be why
21:59:13 <Luigi12> that's fine with me then :o), just wanted to make sure
21:59:18 <Akien> Luigi12: We should put it on pkgsubmit instead IMO :)
21:59:21 <Akien> I mean a link
21:59:28 <stormi> tmb: the SSE issue, but we haven't finished the current one yet, have we?
21:59:39 <Akien> tmb: Statuquo is "let's test the next ISOs"
21:59:41 <Luigi12> part of the mentoring process is when we give you submit rights we stamp it on your forehead
21:59:43 <Akien> s/tmb/stormi/
21:59:46 <Akien> stormi: so go on
22:00:06 <stormi> Luigi12: yes, since madb is firstly targeted at users, it could frighten them... But it would deserve a nice place as a link in pkgsubmit
22:00:11 <stormi> and/or bugzilla
22:00:17 <Luigi12> yeah
22:00:18 <stormi> Luigi12: let's discuss afterwards
22:00:21 <Luigi12> sure
22:00:41 <stormi> #info https://bugs.mageia.org/show_bug.cgi?id=19799
22:00:43 <[mbot> [ Bug 19799 qt5 stack must be checked for sse2 code in 32bit builds ]
22:01:01 <Akien> FYI: We're leaving out the mageiatools@ and kde@ bugs for tonight, since it was a long meeting already. We'll likely plan one meeting for each of those subteams (with all packagers invited of course) in the coming week
22:01:32 <stormi> not likely, we'll do
22:01:38 <neoclust> Akien: will be quick for KDE Team :p
22:01:41 <stormi> and even select volunteers to organize those
22:01:54 <Akien> neoclust just volunteered for the kde team :D
22:02:27 <Pharaoh_Atem> unfortunately, the rpmstack team wouldn't be much of a meeting, since tv is never around
22:02:31 <stormi> back to our last bug for tonight
22:02:35 <neoclust> Akien: of course i am
22:02:52 <stormi> Pharaoh_Atem: yeah that's an issue... maybe we can convince him to join once
22:03:07 <stormi> so back again to bug 19799
22:03:22 <Akien> Pharaoh_Atem: for the mageiatools@ meeting, I would ask tv to join
22:03:33 <Luigi12> 19799 should probably go to the KDE team
22:03:34 <Akien> We can't do much if he's not around
22:04:07 <joeghi> As for #19799 isn't there a tool which analyze binaries for SSE2 instructions? sort of disassemble/objdump?
22:04:07 <stormi> Luigi12: it's already but since tmb created it I'd just like a quick exchange between neoclust and tmb
22:04:07 <Pharaoh_Atem> I recall Kevin Kofler in Fedora saying he's done some work on this, so it might be worth poking him to ask about how he got SSE2 not mandatory across Qt5
22:04:13 <Luigi12> ok
22:04:15 <Akien> Bug 19799 is assigned to kde@ already, but it might be worth discussing quickly all together now ♫
22:04:33 <neoclust> Luigi12: yes
22:04:48 <tmb> yeah, so for bug 19799 we need to review the QT stack...
22:04:52 <joeghi> the first would be to check binaries with that tool and then look at the source patch.
22:05:26 <stormi> Since it's a late-in-the-process blocker I just wanted to make sure that everyone agrees about what needs to be done
22:05:49 <tmb> as shown with chromium many now assumes sse2 even on 32bit... and going by https://bugreports.qt.io/browse/QTBUG-35430 atleast qtdeclarative is defaulting to it
22:05:50 <[mbot> [ [QTBUG-35430] qt5-qtdeclarative requires SSE2 on i686 - Qt Bug Tracker ]
22:05:55 <stormi> and Pharaoh_Atem, having fedora's insights might help if neoclust thinks so
22:06:50 <tmb> or qt5core seems to be fixed by doktor5000 but I think we need to review them all to avoid weird crashes
22:07:26 <stormi> neoclust: can you confirm it's ok for you?
22:07:47 <joeghi> https://bugs.chromium.org/p/chromium/issues/detail?id=348761 <- upstream seems said to drop support for non-sse2
22:07:48 <[mbot> [ 348761 - Chrome Linux 32bit should drop support for P3 and all ia32 targets should always build with -msse2 -mfpmath=sse for doubles to make sense - chromium - Monorail ]
22:08:18 <neoclust> stormi: gogogo
22:08:19 <neoclust> :)
22:08:21 <tmb> joeghi, yeah, but cjw patched sse2 call out
22:08:24 <joeghi> so we have to revert that.
22:08:29 <joeghi> tmb: ah, great.
22:08:47 <stormi> Ok, we're near to the end for tonight
22:09:33 <stormi> I will see with neoclust and the rest of KDE team for a review of their bug reports. Everyone will be invited to take part in the meeting.
22:09:55 <stormi> Akien will organize one for the Mageia Tools group, the other "big" list of blockers
22:10:12 <stormi> Members of that group don't hesitate to already review those bug reports, comment, fix, whatever
22:10:31 <stormi> Is that plan ok?
22:10:55 <stormi> Akien had to go so I'm ending the meeting for him :)
22:11:13 <tmb> sounds good
22:11:27 <stormi> Thanks everyone for coming, it has been a useful meeting
22:12:20 <stormi> Anyone who's got nothing to work on and has some time, just tell me or akien or the dev@ mailing list and we'll find something important to do!
22:12:30 <tmb> :)
22:12:34 <ennael> argh I tried but too late
22:12:35 <joeghi> stormi: you asked about nvidia-prime. I hadn't then opened yet a new bug. Indeed I was working on it. Adding is really trivial (I'm using the tmb's 375.20 on a Skylake  and GTX950). The difficult is to write something decent that not sucks. The best would be that tv would add a few stuff to xfdrake, as 90% of the job is to setup as a plain nvidia proprietary card.
22:13:16 <stormi> joeghi: well, I still think all this would be good in a separate bug report so that we can move on
22:13:24 <stormi> hi ennael
22:13:38 <joeghi> stormi: will add it
22:13:40 <stormi> well, meetboot will have logs for you :)
22:13:52 <stormi> or meatbot
22:14:18 <Luigi12> das meet boot
22:14:22 <ennael> ok bye
22:14:22 <stormi> Countdown before ending the meeting unless there's a topic to discuss
22:14:37 <tmb> just a small update
22:14:46 <Luigi12> have a good holiday for those celebrating
22:14:47 * stormi stops the counter
22:15:05 <joeghi> tmb: will you switch to llvm 3.9 soon?
22:15:24 <Luigi12> are the software depending on it compatible now?
22:15:29 <stormi> joeghi: let him tell his update first :)
22:15:31 <Luigi12> last we discussed it, that was the issue
22:15:34 <joeghi> ah, ok.
22:15:47 <tmb> pterjan (& maat iirc) will go to DC for maintenance this friday, so hopefully I can get my pending infra work done after that :)
22:15:55 <Luigi12> nice!
22:15:59 <Pharaoh_Atem> tmb: mirrorbrain plz?
22:16:07 <tmb> Pharaoh_Atem, yep
22:16:08 <stormi> bugzilla upgrade
22:16:15 <Pharaoh_Atem> \o/
22:16:29 <stormi> so that I can make lpsolit work on my shiny mockups
22:16:45 <Luigi12> and then Koji!  :D
22:16:55 <stormi> 5
22:16:58 <Pharaoh_Atem> Yes!
22:17:00 <Pharaoh_Atem> Koji!
22:17:00 <stormi> 4
22:17:08 <stormi> 3
22:17:13 <stormi> 2
22:17:16 <stormi> 1
22:17:21 <stormi> #endmeeting