19:39:48 <ennael> #startmeeting
19:39:48 <Inigo_Montoya> Meeting started Thu Feb  5 19:39:48 2015 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:39:48 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:39:49 <marja11> :-)
19:39:51 * Akien imagines coling with a beret and baguette.
19:39:55 <marja11> lol
19:39:57 <ennael> #chair MrsB coling tmb
19:39:57 <Inigo_Montoya> Current chairs: MrsB coling ennael tmb
19:40:00 <MrsB> uh oh
19:40:06 <ennael> Akien: coling drinks water
19:40:11 * ennael has some proof
19:40:15 <coling> Haha :)
19:40:18 <ennael> :p
19:40:20 <ennael> ok
19:40:23 <pterjan> are other people standing ? /o\
19:40:38 <ennael> pterjan: indeed :)
19:41:07 <anaselli> o/
19:41:26 <ennael> pterjan: how do you say coup de gueule in english ?
19:42:14 <vzawalin1> smack across the face?
19:42:22 <ennael> woot
19:42:24 <ennael> not sure :)
19:42:29 <pterjan> rant ?
19:42:39 <tmb> "face lift"
19:42:42 <marja11> lol
19:42:43 <lebarhon> ennael: to kick up a real fuss (according to my dictionnary)
19:42:55 <ennael> rant ?
19:42:57 <ennael> ok :)
19:43:11 <ennael> so this mail about tonight's meeting was a big rant
19:43:24 <ennael> and tmb also had his own rant with some guys
19:43:34 <brian_> is this list only Sev 1/2 or all?
19:43:47 <ennael> we are really worried about the current state of mageia before final release
19:44:15 <ennael> we did already postpone the final one and that's not a pb if this extra time allows us to fix bugs
19:44:28 <ennael> but basically very few improvements in between
19:44:46 <ennael> if we do postpone once more we will loose interest of our users but also all contributers
19:44:51 * coling feels somewhat guilty here as I've really not had the same kind of time as previous releases.
19:45:07 <ennael> the point is not  to speak one or another guy :)
19:45:13 <MrsB> it's frustrating for QA also to see no changes between releases, bit of a waste of time
19:45:15 <dvg_i> i am wondering if this adwaita theme is not good enough, can we get another, or maybe patch it to work as it should?
19:45:24 <ennael> just find a way to release this mageia 5
19:45:32 <ennael> and then find a better way to work togetyher
19:45:48 <ennael> so I'd like this meeting not to be a way to think about what we should have done
19:45:58 <ennael> or what should mageia after mageia 5
19:46:07 <tmb> that's for post-mortem
19:46:09 <coling> ennael, yeah fair enough
19:46:09 <ennael> and then avoid endless discussion
19:46:15 <ennael> yep
19:46:30 <ennael> so thanks all for being there tonight and let's start :)
19:46:40 <coling> dvg_i, any adwaita discussions etc. should really be upstream in GNOME.
19:46:50 <brian_> What is consuming the most time?  I see a lot of energy going into UEFI from my perspective.  Is that pulling us away from fixing other things?
19:46:58 <ennael> for new comers, we are going to review  release critical bugs
19:47:09 <ennael> https://bugs.mageia.org/buglist.cgi?cmdtype=runnamed&namedcmd=release_blocker&list_id=40771
19:47:26 <MrsB> bad link
19:47:29 <dvg_i> yeah but we have it here and now. if we keep it beta3 is not good enough, IMHO, so what can we do? see above
19:47:33 <Akien> lstu.fr/Mga5ReleaseBlockers
19:47:47 <coling> dvg_i, I will discuss it with you later if you like.
19:47:55 <ennael> yerk
19:47:57 <dvg_i> fine
19:47:59 <Akien> Sorry for the noise, my link should work
19:48:02 <anaselli> The search named release_blocker does not exist.
19:48:09 <Akien> #link lstu.fr/Mga5ReleaseBlockers
19:48:20 <ennael> thanks akien the one I gave was mine...
19:48:26 <anaselli> ok
19:48:33 * coling uses Akien's link
19:48:50 <ennael> so i'm filtering them by assignee
19:49:12 <coling> I'll take the User in GNOME after live one.
19:49:15 <ennael> https://bugs.mageia.org/show_bug.cgi?id=15113
19:49:17 <[mbot> [ Bug 15113 5beta2: After install from Gnome LiveCD created user is not shown in GDM ]
19:49:23 <ennael> so first one
19:49:36 * anaselli needs 3 monitors :D
19:49:40 <ennael> looks like it happens with live CD
19:49:46 <coling> ennael, I'll take it.
19:49:47 <ennael> MrsB: any input on that one ?
19:50:14 <MrsB> not other than what's on the bug report
19:50:23 <MrsB> I'll try the new ISOs that landed tonight
19:50:35 <vzawalin1> What proportion of downloads is live-cd?
19:50:53 <pterjan> I doubt we can know
19:50:59 <vzawalin1> ok
19:51:08 <MrsB> #action coling takes Bug 15113 5beta2: After install from Gnome LiveCD created user is not shown in GDM
19:51:10 <coling> vzawalin1, we can perhaps revisit what media we provide in the post-mortem
19:51:13 <lewyssmith> Sorry for being late; have visitors.
19:51:13 <ennael> ok
19:51:21 <MrsB> morning lewis
19:51:24 <vzawalin1> point taken
19:51:27 <ennael> https://bugs.mageia.org/show_bug.cgi?id=15032
19:51:29 <[mbot> [ Bug 15032 5beta2 upgrade: urpmi error: ERROR: 'script' failed for an rpm which is not installed ]
19:51:30 <ennael> second one
19:52:29 <Akien> So in the end is it an RPM bug or a bug in adwaita-icon-theme?
19:52:42 <coling> I suspect this is a dupe.
19:52:45 * coling finds the other one
19:53:05 <MrsB> It's perl-URPM IIUC
19:53:29 <coling> https://bugs.mageia.org/show_bug.cgi?id=14971
19:53:31 <[mbot> [ Bug 14971 gtk-update-icon-cache run from scriplets and triggers has errors during upgrade ]
19:53:52 <coling> There is certainly a bug in the gnome-themes-* scripts in MGA4
19:54:04 <MrsB> the bug is that it's reporting a script failure for packages which are not installed though
19:54:06 <coling> (the update macro runs on uninstall (which is triggered by the package rename in MGA5)
19:54:24 <pterjan> I guess this one is more for the script
19:54:33 <coling> which package specifically?
19:54:34 <pterjan> the first one more for urpm
19:54:36 <pterjan> i
19:54:47 <pterjan> failing to give package name
19:54:55 <pterjan> https://bugs.mageia.org/show_bug.cgi?id=15032#c14
19:54:57 <[mbot> [ Bug 15032 5beta2 upgrade: urpmi error: ERROR: 'script' failed for an rpm which is not installed ]
19:54:57 <tmb> that is an rpm bug returning random state so perl-URPM returns name of what name happends to be in "buffer"
19:55:07 <coling> Ahh right
19:55:29 <ovitters> so dupe it?
19:55:44 <pterjan> ovitters: not really, there is also a script to fix
19:55:53 <pterjan> but fixing the rpm first will help
19:56:03 <MrsB> any volunteers?
19:56:10 <pterjan> I can have a look
19:56:15 <MrsB> at rpm?
19:56:16 <pterjan> tv gave a good explanation
19:56:18 <pterjan> yes
19:56:22 <MrsB> great \o/
19:56:24 <coling> Cool, thanks.
19:56:36 <ennael> #info pterjan looks at 15032
19:56:39 <Akien> I linked the two bugs with "see also"
19:56:43 <coling> Should I also fix the MGA4 gnome-themes package (to make upgrade slightly smoother and less full of warnings?
19:56:53 <MrsB> the actual script failing is adwaita-icon-theme
19:56:55 <coling> on a good deay)
19:57:07 <pterjan> that's less important but would be good :)
19:57:24 <ennael> great :)
19:57:27 <ennael> https://bugs.mageia.org/show_bug.cgi?id=15014
19:57:29 <[mbot> [ Bug 15014 [TRACKER] EFI issues ]
19:57:32 <ennael> EFI hell !
19:57:41 <ennael> tmb: some words about your work?
19:57:42 <coling> We can probably kill the scripts in adwaita-icon-theme package... the filetriggers should take care of it.
19:57:59 <Akien> Kudos to tmb for his long running work on that!
19:59:02 <tmb> Actually with the help of pterjan fixing drakx handling of gpt partitioning we should be good to go (famous last words...)
19:59:15 <MrsB> we'll soon know :)
19:59:22 <ennael> at least first try with iso is working on vbox
19:59:34 <pterjan> tmb: I think I added the broken code in 2009 /o\
19:59:39 <DavidWHodgins> So diskdrake will now be able to create gpt partitions?
19:59:39 <ennael> I was able to finalize installation
19:59:46 <MrsB> yes dave
19:59:52 <ovitters> coling: it also installs some filetriggers
20:00:11 <ennael> ok so tests will start soon
20:00:16 <tmb> both classical installer and live medias now boot properly in graphical mode both in vbox and on real hw for me
20:00:17 <MrsB> at least diskdrake as it is in the installer
20:00:18 <ennael> feedbacks needed on that one
20:00:34 <wilcal> isos when?
20:00:42 <ennael> last test in progress
20:00:45 <ennael> so tonight
20:00:56 <wilcal> I've a pretty open weekend ahead of me
20:00:57 <tmb> wilcal, live medias landed when this meeting started
20:01:02 <lewyssmith> I can try tomorrow then, at last.
20:01:13 <MrsB> ahh good, welcome home then lewis
20:01:32 <ennael> #info EFI integration to be tested with isos
20:01:32 <tmb> and boot.iso and boot-nonfree.iso on public mirrors are also booting in efi mode
20:01:43 <ennael> great
20:01:55 <ennael> https://bugs.mageia.org/show_bug.cgi?id=15013
20:01:57 <[mbot> [ Bug 15013 [TRACKER] Upgrade issues mga4 to mga5 ]
20:02:20 <ennael> so here we have several of them
20:02:21 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14476
20:02:23 <[mbot> [ Bug 14476 gdm and gnome fail to use the right keyboard layout ]
20:02:36 <MrsB> that affects installs and upgrades
20:02:38 <Akien> Two of them we already discussed
20:02:57 <coling> Assign to me. I'll sort it out on Sunday one way or another
20:03:00 <Akien> There is a bunch of bugs related to GNOME/GDM vs localisation
20:03:17 <MrsB> #action coling will look at Bug 14476 gdm and gnome fail to use the right keyboard layout
20:03:20 <tmb> pterjan, oh, well you are redeemed now then :)
20:03:35 <lewyssmith> Dare one ask how these have arisen?
20:03:48 <coling> Well there are a few reasons....
20:04:04 <coling> One is changes in upstream GDM and us not writing as much conf as we should.
20:04:16 <anaselli> are all gnome based?
20:04:16 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14971
20:04:18 <[mbot> [ Bug 14971 gtk-update-icon-cache run from scriplets and triggers has errors during upgrade ]
20:04:26 <coling> Partly related to the fact we have weird and bizarre DE launching .desktop files and xinit.d stuff going on.
20:04:48 <Akien> anaselli: no trolling ;-)
20:04:56 <coling> ennael, I think that one is bascially fixed
20:05:05 <anaselli> Akien: because if there are kde ones i can help :p
20:05:13 <anaselli> maybe
20:05:16 <coling> ennael, the "error" was just a warning printed out and I've suppressed that now (I added it in in the first place)
20:05:43 <ennael> ok can you just complete it and close it.
20:05:44 <ennael> ?
20:06:01 <coling> I think so, but have not tested it.
20:06:16 <ennael> MrsB: can this be confirmed for next isos.
20:06:16 <coling> Actually looking further, even the theme stuff should be fixed too.
20:06:17 <ennael> ?
20:06:21 <MrsB> we'll be testing upgrades as we get time
20:06:25 <ennael> ok
20:06:43 <ennael> #info QA will test and eventually close #14971
20:06:43 <MrsB> i'll do a gnome based upgrade tomorrow
20:06:56 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14980
20:06:58 <[mbot> [ Bug 14980 installer removes third-party sources/media from urpmi.cfg when upgrading ]
20:06:59 <coling> Thanks MrsB.
20:07:03 <anaselli> hmm https://bugs.mageia.org/show_bug.cgi?id=14980 this is almost non sense
20:07:21 <anaselli> there third party sw that could depend on release
20:07:38 <anaselli> so how can we distinguish which one have to survicve?
20:07:50 <tmb> yeah, I think 14980 is a WONTFIX or we dont ever know what happends during upgrades
20:08:07 <MrsB> IIUC it removes any non mageia sources, could be made to disable them instead
20:08:14 <anaselli> yes
20:08:27 <coling> It's probably not super critical either. Not nice perhaps, but no kittens will die.
20:08:31 <Akien> Luigi's main concern was about keeping the Google repos so that Chrome stays up to date after an upgrade (also for security matters to some extent)
20:08:33 <anaselli> no it deletes all medias
20:08:35 <anaselli> iirc
20:08:36 <Akien> (I guess)
20:09:06 <leuhmanu> (do we support upgrade with third-party rpm / media ? )
20:09:15 <anaselli> good point!
20:09:15 <coling> Akien, yeah that's certainly valid to be fair, but doesn't chrome doe evil cron related stuff to add it's media back in anyway? Perhaps that's just a one-shot tho'.
20:09:18 <tmb> well, the hard part is doing the matching of what to remove and what to disable
20:09:49 <anaselli> tmb: agree
20:09:49 <ovitters> not possible to disable during upgrade, then enable after upgrade is done?
20:10:12 <pterjan> I was about to suggest disabling, not re-enabling :)
20:10:18 <pterjan> better than removing
20:10:20 <tmb> ovitters, same issue, how do you know what media
20:10:31 <Akien> if we can find an expression that matches official Mageia repos, we could remove Mageia repos, and disable the rest
20:10:40 <pterjan> yes
20:11:09 <Akien> As I suggested, something like grep "distrib/$initialversion"
20:11:10 <anaselli> our cli upgrade documentation say to remove all the media
20:11:10 <tmb> well, you cant :/
20:11:19 <Akien> But that's a bit dirty :)
20:11:19 <anaselli> how can we disable some there?
20:11:43 <ovitters> maybe fix it for Mageia 6? for now add something like "distro-media" or something so you know you can remove it for M5->M6?
20:11:58 <hviaene> You're trying to be too smart
20:12:01 <anaselli> imo is a wont fix
20:12:03 <tmb> I know several 3rd-party repos that use the same "mageia/3" ...
20:12:09 <anaselli> we cannot manage 3 party media
20:12:18 <coling> There are lots of tricks you could do avoid this, e.g. bind mount a "clean" urpmi.cfg over the top of the file for the duration of the ugprade.
20:12:18 <MrsB> couldn't it just atch media name?
20:12:21 <MrsB> match*
20:12:30 <anaselli> we have enough of ours... with bp also ;)
20:12:34 <hviaene> You'll always have unwanted side effects
20:12:34 <DavidWHodgins> I think it might be better to just add a warning that third party repos will have to be manually re-added after the upgrade.
20:12:48 <filipesaraiva> I agree with anaselli
20:13:22 <pterjan> DavidWHodgins: but disabling instead or removing would allow people to have the list available
20:13:32 <anaselli> i have 3 external repos... do you want to check them also?
20:13:33 <pterjan> we could also save the list somewhere
20:13:33 <anaselli> :p
20:13:53 <pterjan> like having a urpmi.cfg.BAK
20:13:55 <pterjan> :P
20:13:59 <Akien> Well yes in the end I think it's better to clean up everything
20:14:13 <MrsB> perhaps we could add a stanza in urpmi.cfg for official media = yes
20:14:19 <Akien> I can already see hundreds of users on forums with 70 repos configured, some enabled, some not
20:14:25 <tmb> hm, we do have in media.cfg: media_type=official:free:release
20:14:47 <tmb> maybe we could tracj the media_type ?
20:14:48 <pterjan> tmb: yes all those tags were added but we don't copy them to the config
20:15:22 <ovitters> key-ids: 80420f66 ?
20:15:33 <pterjan> (they were added at the wrong time in 2009/2010, too late to be used before many people left)
20:15:38 <ovitters> that's a nice hack ;)
20:15:40 <coling> ovitters, not a bad idea....
20:15:44 <coling> :)
20:15:45 <pterjan> ovitters: quite a hack but would work
20:16:07 <ennael> question is: are we able to implement this quickly?
20:16:08 <tmb> pterjan, well, then it's "easy"... we start tracking them in mga5, and set this bug milestone to mga6  :)
20:16:26 <MrsB> that'll work i think tmb
20:16:40 <Akien> Sounds good yes.
20:16:51 <MrsB> it'll be more of a problem as more people use chrome for flash etc
20:17:37 <anaselli> MrsB: but you should allow to edit a list of them then...
20:17:58 <anaselli> but i see people adding wrong things :)
20:18:13 <anaselli> anywat managing it after5 is good for me
20:18:16 <MrsB> we'll need to make people aware of the problem anyway as Dave said, in the release ntoes
20:18:24 * pterjan will be leaving soon
20:18:26 <MrsB> notes*
20:18:30 <olivier_cc> what about pterjan's proposition in the meantime (urpmi.cfg.bak) ?
20:18:35 <ennael> ok so status for that one?
20:18:47 <anaselli> Warning: upgrade removes all the repositories media
20:19:06 <neoser10> but creates a backup in the user's  home
20:19:09 <MrsB> volunteers?
20:19:17 <coling> If someone can point me at the approximate code that removes them, I can take a look at doing some hack
20:19:42 <MrsB> #info coling volunteers :)
20:19:44 <DavidWHodgins> neoser10: The backup should be in /etc/urpmi/
20:20:04 <ennael> ok
20:20:27 <anaselli> i don't know that much of installer... but i can try to find where the media are removed..
20:20:34 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14674
20:20:36 <[mbot> [ Bug 14674 [Tracker] Security updates for Mageia 5 final release ]
20:20:37 <neoser10> i agree with you davidhodgins
20:20:42 <Akien> Ah a .rpmsave could be good yes
20:20:47 <ennael> this tracker is in progress until very last days before release
20:20:52 <MrsB> Luigi12 couldn't be here tonight
20:20:52 <ennael> so nothing to do really here
20:20:58 <ennael> yep no pb
20:21:08 <coling> #info coling will try and look at https://bugs.mageia.org/show_bug.cgi?id=14980
20:21:10 <[mbot> [ Bug 14980 installer removes third-party sources/media from urpmi.cfg when upgrading ]
20:21:22 <coling> (just for more context in the logs)
20:21:26 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14476
20:21:28 <[mbot> [ Bug 14476 gdm and gnome fail to use the right keyboard layout ]
20:21:31 <ennael> was already checked
20:21:34 <coling> Indeed
20:21:50 <ennael> https://bugs.mageia.org/show_bug.cgi?id=13687
20:21:53 <[mbot> [ Bug 13687 5a2: GDM fails, but succeeds when then doing "systemctl restart prefdm.service" ]
20:22:12 <ennael> is it still happening?
20:22:21 <anaselli> coling: i will give you a hand there 14980
20:22:29 * anaselli is adding there
20:22:35 <coling> thank you anaselli that's really appreciated :)
20:23:10 <MrsB> I think it's fixed
20:23:11 <coling> I suspect the gdm thing must be some transactional thing
20:23:28 <MrsB> maybe hw dependent
20:23:35 <coling> Perhaps in systemd transactions
20:23:43 <coling> Hard to say without being able to reproduce tho'.
20:23:45 <ennael> can you please add it to the "to be checked one" ?
20:23:53 <ennael> MrsB: ^^
20:23:56 <MrsB> marja11: any update?
20:23:57 <Akien> I guess QA will have to keep an eye open for it when testing the new round
20:23:58 <MrsB> yep
20:23:59 <coling> If someone can make it happen in VBox that would be good.
20:24:31 <coling> @qateam: Feel free to ping me directly if there are reliable reproducers
20:24:50 <ennael> #info #13687 should be checked by QA on last isos
20:24:58 <marja11> MrsB: sorry, haven't checked for it recently
20:25:03 <MrsB> I didn't see this in beta 3 round 2
20:25:08 * anaselli has to leave for a while
20:25:09 <anaselli> brb
20:25:11 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14627
20:25:12 <MrsB> or round 1 wasn't it
20:25:12 <[mbot> [ Bug 14627 gpg-agent prevents login sessions to be closed ]
20:25:30 <ennael> (thanks Akien :) )
20:25:40 <marja11> brian_: did you see bug 13687 recently?
20:26:04 <lewyssmith> It doesn't look as if I can contribute much tonight, so I might as well rejoin my vistors. Bonsoir all.
20:26:05 <brian_> no
20:26:17 <ovitters> for that bug, gnome-session runs under all kinds of scripts, one runs gpg-agent.. KDE seems to be started directly
20:26:20 <coling> ennael, the gpg-* one is it a big issue?
20:26:25 <DavidWHodgins> lewyssmith: Have a good night.
20:26:37 <coling> It's kinda just "how it works" for now
20:26:55 <brian_> last install - went to an earlier reported bug.  I had to type my signon and things worked versus locking
20:26:56 <coling> In the long term, gpg-agent has to be fixed... (as with ssh-agent).
20:27:09 * coling has plans for that when we switch to user-bus (away from session bus)
20:27:16 <ennael> mayve release critical tag can be removed and fixed as soon as possible
20:27:20 <coling> It can then be socket activatable and have a built in self-destruct timer.
20:27:34 <coling> Other distros are generally agreed on this approach.
20:27:35 <brian_> I'll reinstall gnome live tonight - downloading now
20:27:47 <marja11> brian_: thx
20:28:27 <coling> I don't see it as super critical personally.
20:28:41 <brian_> me either
20:29:02 <ennael> ok
20:29:06 * coling looks forward to a user-bus world :)
20:29:10 <ennael> coling: can you remove it?
20:29:18 <coling> ennael, will do
20:29:21 <ennael> thanks
20:29:28 <ennael> about KDE tracker
20:29:34 <ennael> only one bug left https://bugs.mageia.org/show_bug.cgi?id=14627
20:29:36 <[mbot> [ Bug 14627 gpg-agent prevents login sessions to be closed ]
20:29:37 * tmb sees coling do rm -rf on bugs.mageia.org :)
20:29:41 <ennael> :)
20:29:45 <Akien> :-D
20:29:49 <ennael> it seems it goes to errata
20:29:55 * MrsB fills it up again
20:30:03 <Akien> Correct link: https://bugs.mageia.org/show_bug.cgi?id=11975
20:30:05 <[mbot> [ Bug 11975 qtatspi-plugin causes delay opening KDE GUI applications as root ]
20:30:39 <ennael> so it was added in errata and we wait for upstream fix
20:30:45 <ennael> so I remove release critical tag
20:30:50 <dvg_i> Sorry but I dont like the fact we are discussing only release blocking bugs. The fact that we have all of these "small" graphical issues together: 12369, 13894, 14355, 14838, 14840, 14843, 14844, is a showstopper for me. individually they may be small, releaseblocker or not, together makes them major, IMHO
20:31:14 <MrsB> Yes I agree dvg
20:31:34 <dvg_i> The installer all over looks bad these days,sorry
20:31:37 <MrsB> things can't be fixed in installer after release anyway
20:31:46 <ennael> wait we have some bugs coming
20:31:53 <ennael> it can be discussed there
20:32:08 <ennael> so KDE tracker is empty for now
20:32:19 <Akien> dvg_i: Maybe a "[TRACKER] Graphical glitches" bug could be created, and set a release blocker
20:32:26 <Akien> s/a/as/
20:32:36 <ennael> https://bugs.mageia.org/show_bug.cgi?id=11979
20:32:37 <MrsB> Installer issues really Akien
20:32:39 <[mbot> [ Bug 11979 [TRACKER] Upgrade issues mga3 to mga4 ]
20:32:40 <coling> tmb, :)
20:32:45 <ennael> so upgrade issues
20:32:54 <dvg_i> Akien: thanks
20:33:06 <ennael> https://bugs.mageia.org/show_bug.cgi?id=11827
20:33:08 <[mbot> [ Bug 11827 initrd missing for newest kernel after upgrading with classical iso (was: kernel panic when booting into 4beta-pre2 upgraded system) ]
20:33:13 <anaselli> mga3 to mga4?
20:33:16 <coling> re 11975 opening GUI applications as root is bad practice anyway... bad use case :D
20:33:56 <marja11> anaselli: also 4 to 5beta
20:34:16 <marja11> anaselli: 5beta2
20:34:18 <anaselli> ok sorry i thought i missed something :)
20:36:09 <ennael> ok so missing initrd
20:37:00 <neoser10> coling: the pseudo admins as me every day execute dolphin from MCC root console to edit config files without "problem"
20:37:22 <neoser10> bad practice I agree
20:37:37 <coling> neoser10, still a bad practice. There are many bad things that happen. So many modules and libraries and plugins suddenly get elevated privs.
20:37:51 <doktor5000__> Luigi12: you may be remotely interested in https://forums.mageia.org/en/viewtopic.php?p=54319#p54319 - just FWIW
20:37:52 <[mbot> [ Mageia forum View topic - ghost on mageia 3 ]
20:37:58 <marja11> anyway, it seems this missing initrd only occurs on systems where grub2 is the bootloader
20:38:04 <ennael> marja11: about that one ?
20:38:04 <MrsB> not seen this, yet at least. Our upgrade testing is limited by the extended ISo testing periods though.
20:38:50 <marja11> ennael: I don't know why it occurs sometimes, and not on other occasions, only know that it only occurs when a grub2 system is upgraded
20:39:13 <ennael> can you reproduce it?
20:39:16 <marja11> ennael: and I just don't understand how grub2 can keep an initrd from being generated
20:39:28 <MrsB> one to add to the testing list i think
20:39:30 <marja11> ennael: haven't upgraded in a while, will do one soon
20:39:50 <marja11> ennael: last one who reported it was linuxero on January 18th
20:40:14 <ennael> ok so to be checked in coming tests
20:40:37 <ennael> https://bugs.mageia.org/show_bug.cgi?id=12012
20:40:40 <[mbot> [ Bug 12012 Upon upgrade, free space on partition for separate /boot should be checked... ]
20:40:58 <coling> Yeah we should do that... but we've not done it the last x years...... so
20:41:28 <coling> Unless Santa or the Easter bunny comes along to hack on perl, it'll just have to be bumped again.
20:41:32 <ennael> so errata notes is enough ?
20:41:54 <ennael> and let see that for mageia6 specs for installer
20:42:09 <coling> It's not a new problem, so what ever we've done about it in pervious releases should be just as sufficient as last time.
20:43:06 <anaselli> coling: that should be a problem for kernel update also no?
20:43:16 <coling> anaselli, yeah.
20:43:46 <coling> anaselli, tho' less fatal there, as we tend to "fill up" /boot on upgrade with *.bak files of old initrds...
20:43:54 <coling> (mainly due to themes regenerating them)
20:44:20 <ennael> https://bugs.mageia.org/show_bug.cgi?id=12305
20:44:21 <Akien> And I guess nowadays people can space more than 40 MB for /boot no? :)
20:44:21 <[mbot> [ Bug 12305 System crashed after upgrading from Mga3 to Cauldron. Stops after splash screen with message, /dev/resume does not exist. ]
20:44:42 <brian_> that's the one that  skipped mga4 correct?
20:44:46 <anaselli> well i think a check should be performed befor updating and another when kernel is installed in the spec tmb wdyt?
20:44:49 <ennael> well mageia3 is not supported anymore
20:44:54 * coling is my 512MB ESP partition (as I feel everyone using GPT should do)
20:45:18 <MrsB> should we force N => N+1
20:45:23 <ennael> ?
20:45:23 <coling> That is technically a dracut bug tho'
20:45:31 <coling> So it should be assigned to me.
20:45:37 <ennael> does it happen with mageia4 ??
20:46:46 <ennael> ok assigned to coling anyway
20:46:56 <coling> Dunno, there are lots of ways in which it could occur.
20:47:00 <tmb> anaselli, well it could be done in %pretrans and bail out
20:48:01 <Akien> IMO we don't have to support mga3 -> mga5 upgrades. Now as tv said it a while ago, if we can make it work (or prevent it from breaking by removing old obsoletes), it's for the best.
20:48:13 <anaselli> even if during upgrade by cli tmb urpmi does not install kernel first... so maybe it's late anyway but yes that's the point :)
20:48:32 * coling always manually regenerates initrd after cli upgrade has finished.
20:48:38 <coling> It just makes good sense to do so
20:48:49 <tmb> anaselli, well, usually the old kernel should still be bootable
20:48:57 <anaselli> indeed
20:49:08 * coling also disagrees with our theme scripts messing with old initrds
20:49:11 <coling> But that's another story
20:49:14 <anaselli> so that could be at least the first step to fix that bug :)
20:49:45 <tmb> coling, yeah, we should not alter more than running kernel initrd at the most
20:49:59 * coling nods...
20:50:55 <coling> Sadly, distro N-1's bootloader scripts may take care of that before it's updated even if we do change it. Not a reason not to do it tho'
20:51:45 <sander85> hi, i've been reading but can give just my moral support today, too tired to be productive :)
20:51:49 <brian_> translation - MGA3 to MGA4 before going to MGA5
20:52:15 <MrsB> sander85: all helps
20:52:22 <brian_> no jumping from MGA3 to MGA5 which is consistent with most packages
20:52:36 <ennael> 21:44 < ennael> https://bugs.mageia.org/show_bug.cgi?id=12305
20:52:37 <brian_> ?
20:52:38 <[mbot> [ Bug 12305 System crashed after upgrading from Mga3 to Cauldron. Stops after splash screen with message, /dev/resume does not exist. ]
20:53:24 <ennael> this one is also for coling :)
20:53:35 <coling> Yeah, you already assigned it no?
20:53:39 <ennael> yep
20:53:42 <coling> You said so above :)
20:54:00 <MrsB> I think this maybe ties in with  bug 10179
20:54:03 <ennael> oups
20:54:11 <ennael> sorry I'm bugging :)
20:54:14 <ennael> https://bugs.mageia.org/show_bug.cgi?id=12499
20:54:16 <[mbot> [ Bug 12499 Conflict with the Mageia 3 version of task-lxde-minimal. ]
20:54:19 <ennael> that one is an old one
20:54:52 <MrsB> yes, but we'll test lxde upgrades anyway and open a new bug so close that
20:55:14 <hviaene|2> Bye all, I feel too tired to go on
20:55:20 <ennael> ok
20:55:26 <MrsB> nite herman
20:55:44 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14563
20:55:46 <[mbot> [ Bug 14563 Gnome shell failing (when no gdm installed) after online mageia 3-64 to mageia4-64 upgrade ]
20:56:37 <coling> gdm should requrie gnome-shell and vice versa.
20:56:50 <ennael> ovitters: around?
20:56:54 <MrsB> olivier_cc: this one is yours
20:57:00 <ovitters> that's in Cauldron, not mga4
20:57:11 <coling> [colin@jimmy ~]$ rpm -q --requires gdm| grep gnome-shel
20:57:11 <coling> gnome-shell
20:57:12 <coling> [colin@jimmy ~]$ rpm -q --requires gnome-shell | grep gdm
20:57:12 <coling> gdm
20:57:24 <ennael> so it's ok
20:57:26 <olivier_cc> yep, but I do not think it occurs anymore from mga4 to mga5
20:57:41 * coling presumes so
20:57:52 <ennael> ok so closing as OLD then we can reopen if pb
20:57:54 <ovitters> the bug is open because I need to fix mga4
20:58:12 <coling> But yeah the bug is for MGA4
20:58:12 <ennael> ok so rather an update then
20:58:34 <ennael> removed from the tracker
20:58:38 <MrsB> can it be assigned to you Olav?
20:58:41 <ovitters> yes
20:58:44 <coling> I spoke to Ray upstream about it IIRC. They can split stuff out, but not important for this discussion
20:58:46 <Akien> Maybe we can rename the tracker to "Upgrades issues mga4 to mga5" and remove old bugs
20:59:24 <ennael> and that's all for upgrade
20:59:41 <MrsB> there is a track, just move them across Akien
20:59:45 <MrsB> tracker*
20:59:49 <ennael> https://bugs.mageia.org/show_bug.cgi?id=11844
20:59:51 <[mbot> [ Bug 11844 [TRACKER] Bugs related to GNOME ]
21:00:02 <Akien> MrsB: Ok I'll check that later
21:00:23 <ennael> https://bugs.mageia.org/show_bug.cgi?id=11847
21:00:25 <[mbot> [ Bug 11847 gnome live mode doesn't keep the language set before ]
21:00:56 <MrsB> dupe isn't it of the keyboard one
21:00:58 <coling> I'll take a look at all i18n ones
21:01:04 <ennael> and we have several of them about language
21:01:06 <coling> Hopefully with ovitters
21:01:09 <wilcal> we gonna talk about 11969 or was that part of the graphics thingy
21:01:13 <ennael> ok thanks :)
21:01:23 <coling> I suspect one or two fixes will address them all.
21:01:24 <ovitters> coling: yeah Sun
21:01:29 <coling> I will spend SUnday looking at stuff.
21:01:31 <coling> :)
21:01:35 <coling> ovitters, :)
21:01:35 <ennael> #info i18n bugs on GNOME to managed by coling and ovitters
21:01:38 <Akien> MrsB: Not a dupe strictly speaking since this one is about live mode, the other about upgrades. But most likely symptoms of the same problem.
21:01:45 <MrsB> at the end wilcal
21:01:49 <wilcal> k
21:02:09 <coling> ennael, so there is a NM one.
21:02:14 <coling> Did we push NM 1.0?
21:02:28 <coling> ovitters, did you play with that (apologies if there was replies I missed on the list)
21:02:37 <coling> I think everyone agreed it made sense.
21:02:40 <ovitters> coling: didn't
21:02:45 <ovitters> I guess that's Sun as well
21:02:50 <ovitters> I don't have wifi though
21:03:02 <ovitters> my setup is really easy
21:03:03 * coling has been running it for a while and could connect to FOSDEM wifi with it reliably...
21:03:08 <coling> Thtat's a fairly good test :)
21:03:11 <ennael> :)
21:03:25 <tmb> after seeing the info on Fosdem about NM 1.0 I think we should push it for mga5
21:03:44 <tmb> s/info/talk/
21:03:46 <coling> ovitters, only issue is that Network under System settings I only see "Network proxy" option in the list. I don't see list of interfaces.
21:03:49 <ennael> https://bugs.mageia.org/show_bug.cgi?id=7317 so this is about that one ?
21:03:49 <MrsB> can we get it in beta3 then please
21:03:51 <[mbot> [ Bug 7317 GNOME Networkmanager by default but disagrees with MCC ]
21:03:56 <coling> tmp /me agrees
21:04:00 <coling> tmb even.
21:04:02 <coling> :)
21:04:15 <coling> I'm not sure it 100% solves that bug specifically tho'
21:04:25 <ennael> #info NM 1.0 will be pushed to fix some bugs for beta3
21:04:29 <ennael> anybody on this?
21:04:33 <ennael> ovitters: ?
21:04:47 <ovitters> ennael: I'll push
21:04:50 <ennael> thanks
21:05:00 <ennael> #info ovitters will push NM 1.0
21:05:01 <coling> AFAIK, this was a bug last time
21:05:10 <coling> (7317)
21:05:19 <ovitters> we had various related bugs
21:05:21 <coling> We're no worse than last time on that front.
21:05:28 <ennael> yep
21:05:30 <ovitters> originally that NM didn't ignore the interfaces
21:05:37 <ennael> I think that's all for GNOME tracker
21:05:42 <ovitters> now that it ignores while it should not
21:05:45 <ennael> all other one have already been reviewed
21:05:48 <MrsB> it's alot better now than it was then
21:06:03 <coling> I don't like that we don't use NM OOTB for gnome, but it is what it is. I think we *really* do have to nuke our built in tools for next time tho' (we said that this time but sadly it didn't magically happen (where was Santa and the Easter bunny))
21:06:19 <coling> The scripts wont even be supported by upstream initscritps soon enough
21:06:24 <ennael> https://bugs.mageia.org/show_bug.cgi?id=6675
21:06:26 <[mbot> [ Bug 6675 NetworkManager spawns a wpa_supplicant instead even if interface is unmanaged, conflicting with drakx-net tools ]
21:06:28 <anaselli> 7317 should have the same behavior also in kde no?
21:06:29 <ennael> btw another one for NM
21:06:53 <MrsB> i think it's fixed
21:07:00 <coling> anaselli, yeah
21:07:12 <coling> anaselli, but gnome-shell is more designed around NM so it's more obvious
21:07:55 <anaselli> coling: i will add me anyway since i'm trying to work our tools... maybe i can be of help
21:07:58 <coling> Let's just kill it. It's certainly old enough that it didn't really matter for MGA4 anyway.
21:07:59 <ennael> MrsB: so same thing I close it feel free to reopen
21:08:09 <MrsB> yes i guess so
21:08:29 <coling> anaselli, yeah! Ideall draknet center just becomes an NM frontend...
21:08:31 <MrsB> certainly not seen it happen recently and it was a big problem at the time
21:08:43 <philippem> I have to leave now, if anything need to be assigned to me, just mail me
21:08:50 <MrsB> nite philippem
21:08:52 <coling> cya philippem
21:08:54 <coling> :)
21:08:54 <marja11> philippem: good night
21:09:15 <anaselli> i have both in my systems
21:09:40 <anaselli> but using nm only for wireless nw and drakxnet for cable ones
21:09:46 <ennael> https://bugs.mageia.org/show_bug.cgi?id=763
21:09:48 <[mbot> [ Bug 763 libDrakX defaulting background to wrong resolution (also affects mageia-theme-Default and kdm) ]
21:10:04 <ennael> old old one
21:10:19 <coling> :)
21:10:33 <brian_> really?
21:10:35 <brian_> hmm
21:10:36 <anaselli> and the big issu is that in not all configuration we have modes in xorg.conf
21:10:39 <brian_> I didn't notice that
21:10:48 <anaselli> so our backend is wrong
21:10:56 <MrsB> i think this affects grub2
21:11:01 <anaselli> xrand helps
21:11:11 <anaselli> but only when x is running
21:11:13 <MrsB> so plymouth is just 3 bars
21:11:32 <anaselli> AL13N: has some ideas on that
21:11:52 <anaselli> but i don't know well what he would like to change on x startup
21:12:03 <coling> MrsB, if plymouth only has three bars, then likely the correct stuff is not included in initramfs.
21:12:08 <Akien> MrsB: This affects any installation regardless of the bootloader
21:12:30 <Akien> The issue is that libDrakX can't find your screen resolution if it's not in xorg.conf
21:12:31 <anaselli> coling: how's about https://bugs.mageia.org/show_bug.cgi?id=763#c33?
21:12:33 <[mbot> [ Bug 763 libDrakX defaulting background to wrong resolution (also affects mageia-theme-Default and kdm) ]
21:12:38 <Akien> And then it defaults to 1024x768
21:12:43 <MrsB> debugged it to being wrong resolution, just trying to find the bug for it
21:12:50 <anaselli> could the svg a possible solution?
21:13:12 <coling> anaselli, dunno. Would be nice but I don't really know plymouth well enough :(
21:13:31 <Akien> anaselli: For the background? It's not vector graphics.
21:13:46 <anaselli> so the answer is no...
21:13:54 <MrsB> 3 bars one https://bugs.mageia.org/show_bug.cgi?id=9888
21:13:57 <[mbot> [ Bug 9888 Grub2 loading black screen with blue bar ]
21:14:07 <marja11> svg for Mga 6 ;-)
21:14:26 <Akien> MrsB: Ah right I've seen this one
21:14:38 <coling> MrsB, that *shouldn't* (in theory) be directly related to bootloader. Might not pass the right args (vga=) or something tho'.
21:14:50 <MrsB> yes that rings a bell
21:15:00 <anaselli> MrsB: fedora like boot :D
21:15:09 * coling generally avoids grub2 like the plague tho'. gummiboot forever :D
21:15:12 <anaselli> old one though
21:15:26 <Akien> No idea for bug 763?
21:15:28 <ennael> ok so
21:15:33 <MrsB> also our get_edid stuff doesn't work in the installer
21:15:55 <marja11> coling: if you keep saying that I'll install gummiboot.... and then nag you about everything I do wrong with it :-รพ
21:15:58 <Akien> It's not plymouth-related, the question is: how do we find the resolution reliably in libDrakX, or how do we workaround the bug before starting the DM
21:16:05 <coling> marja11, it's super manual right now
21:16:17 <coling> marja11, and GPT only
21:16:32 <marja11> coling: ah, so only for my EFI laptop
21:16:38 <coling> Yup
21:17:41 <Akien> anaselli: Did you find a way to implement AL13N's script workaround?
21:17:54 <anaselli> nope Akien
21:18:08 <Akien> Could we have a systemd service running just before prefdm to run that script maybe?
21:18:11 <anaselli> i tried with hwinfo --framebuffer
21:18:25 <anaselli> but it does not work on my hw, while it does on vbox :/
21:19:59 <MrsB> what's the solution?
21:20:09 <ennael> ok I would like to see that bug not release critical as it happens for a long time now and unfortunately for now no solution
21:20:17 <Akien> ennael: :-/
21:20:44 <Akien> That's really a bad looking bug. And it's affects more than just the DM background
21:21:04 <ennael> but this can be fixed after release is out
21:21:06 <tmb> well then... otherwise... "send patches" ... :)
21:21:12 <coling> :)
21:21:15 <Akien> It also affects any DE or WM that relies on /usr/share/mga/backgrounds/default.jpg
21:21:28 <ennael> so you can start working on it and we can push updates if time is too short
21:21:46 <anaselli> Akien: i will try hwinfo again
21:21:50 <Akien> Well we've been working on it for a while now...
21:21:53 <Akien> But ok
21:21:59 <anaselli> it seesm to work now here :/
21:22:09 <Akien> anaselli: Sounds good
21:22:10 <coling> We should just wait for wayland...
21:22:11 <coling> :p
21:22:22 <tmb> and Santa...
21:22:36 <coling> :)
21:22:40 <brian_> ha
21:24:00 <MrsB> next
21:24:39 <ennael> https://bugs.mageia.org/show_bug.cgi?id=15113
21:24:42 <[mbot> [ Bug 15113 5beta2: After install from Gnome LiveCD created user is not shown in GDM ]
21:24:49 <coling> That was the first one :)
21:24:53 <coling> assigned to me
21:25:05 <ennael> oups ok
21:25:13 <coling> :)
21:25:24 <ennael> https://bugs.mageia.org/show_bug.cgi?id=13829
21:25:26 <[mbot> [ Bug 13829 Hardware detection tool: 'kernel modules' makes a mess of the GUI and hdt stops working ]
21:25:37 <ennael> M. ennael will work on it this we :)
21:25:50 <ennael> Mr
21:26:17 <ennael> https://bugs.mageia.org/show_bug.cgi?id=4042
21:26:19 <[mbot> [ Bug 4042 sshfs (and probably other) filesystems without "noauto" flag will prevent smooth boot with systemd. ]
21:26:36 <coling> Yeah it would be nice but again, it didn't happen last time either.
21:26:53 <ennael> ?
21:27:13 <MrsB> wasn't there a nofail bug too
21:27:21 <coling> Yeah
21:27:45 <coling> ennael, it didn't get fixed the last cycle for MGA4 so IMO it cannot be super-critical for MGA5
21:27:45 <ennael> nofail bug?
21:28:01 <coling> ennael, the nofail bug was about adding nofail to not "critical" filesystems options
21:28:04 <MrsB> https://bugs.mageia.org/show_bug.cgi?id=10179
21:28:06 <[mbot> [ Bug 10179 drakx* should add "nofail" option to "foreign" mountpoints to avoid unwanted recovery mode (was: Can't boot Mageia 3 after complete install) ]
21:28:18 <ennael> oh ok got it
21:28:44 <coling> I'm not 100% sure I agree with that one, but don't disagree that it *could* be a nice thing to do.
21:29:00 <MrsB> we do have issues with swap space causing recovery mode when 2nd hdd removed etc
21:29:34 <coling> MrsB, that shouldn't happen any longer (IIRC)
21:29:48 <MrsB> since mga5 coling?
21:29:49 <coling> I don't think swaps failing are fatal these days
21:29:57 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14269
21:29:59 <[mbot> [ Bug 14269 Missing lib64gcr / lib64gcr-ui dependency ]
21:30:00 <ennael> ovitters: your turn ?
21:30:04 <coling> MrsB, yeah. I can try by adding a dummy swap to my fstab
21:30:11 <coling> And seeing if it fails.
21:30:12 <MrsB> kthx
21:30:20 <ovitters> ennael: I added as blocker, will look at it
21:30:29 <coling> But I remember speaking with upstream about it and I believe it's addressed these days.
21:30:33 <ovitters> ennael: it should have been in the auto requires
21:31:02 <ovitters> at most I can do manual requires, should not be needed though
21:31:04 <ennael> ok so you take that one
21:31:07 <ovitters> yeah
21:31:10 <ennael> thanks
21:31:28 <ennael> https://bugs.mageia.org/show_bug.cgi?id=11969
21:31:30 <[mbot> [ Bug 11969 embedded rpmdrake in MCC is rendering black with some non-english locales ]
21:31:35 <MrsB> wilcal
21:32:05 <wilcalY> Yup removed the two oxygen things and it worked
21:32:10 <Akien> lmenut pushed a patch for this one, and I've already had reports on the MLO forum that it's fixed
21:32:20 <wilcalY> was never anything to do with languages
21:32:22 <ennael> submitted yesterday a patched drakconf (drakconf 12.53-2) that could fix the issue. I'm waiting more feedbacks, but I have quite good hope.
21:32:28 <Akien> Or at the least they can't reproduce the initial bug with the new drakconf
21:32:29 <ennael> from luc
21:32:30 <wilcalY> super deal
21:32:37 <ennael> great news
21:32:45 <MrsB> wilcalY: Akien could you test with beta3 please
21:32:47 <ennael> MrsB: to be added to next tests on isos
21:32:48 <wilcalY> will the fix be in the just released isos
21:32:53 <MrsB> ok yes thanks
21:33:22 <wilcal> silly thing
21:33:52 <wilcal> so it won't be fixed in the just released ISO's?
21:34:09 <tmb> the patched drakconf is in frozen repos so yes
21:34:24 <ennael> https://bugs.mageia.org/show_bug.cgi?id=10179
21:34:26 <[mbot> [ Bug 10179 drakx* should add "nofail" option to "foreign" mountpoints to avoid unwanted recovery mode (was: Can't boot Mageia 3 after complete install) ]
21:34:52 <coling> ennael, done that one.
21:35:02 <ennael> you fixed it ?
21:35:22 <coling> ennael, no we discussed it 5 mins ago.
21:35:25 <anaselli> just talked about i guess
21:35:33 <ennael> outch
21:35:37 * ennael is tired :)
21:35:39 <coling> :)
21:35:47 <ennael> so fix in progress
21:35:47 <MrsB> we have installer to do yet
21:36:11 <anaselli> how many... more?
21:36:19 * anaselli is tired too
21:36:34 * dvg_i tired here
21:36:45 <MrsB> 12369, 13894, 14355, 14838, 14840, 14843, 14844
21:37:03 <ennael> we review the tmb ones
21:37:10 <coling> ennael, for various values of "in progress" yes.
21:37:14 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14584
21:37:16 <[mbot> [ Bug 14584 cpupower defaults to performance in Mag5beta1 ]
21:37:36 <coling> Not release critical - can be fixed after.
21:37:39 <vzawalin1> 11105 is on the blocker list. Is it up for discussion?
21:37:50 <ennael> once at a time :)
21:37:58 <vzawalin1> ok!
21:38:15 <ennael> tmb: ^^
21:38:41 <ennael> this is the only one for you
21:38:47 <ennael> all others were already reviewed
21:40:02 <tmb> yeah, it's on my TODO for finding a clean way without user interaction, but I've been somewhat busy with some uefi stuff lately :)
21:40:21 <ennael> ok :)
21:40:28 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14691
21:40:30 <[mbot> [ Bug 14691 rpm loses setuid and setgid bits ]
21:41:21 <coling> I believe that was patched no? (not looked but from memory)
21:41:42 <ennael> it seems it's a regression after applying a patch
21:41:50 <ennael> but patch is still used and applied
21:42:17 * coling looks quickly
21:43:24 <anaselli> on mga4 the installed ones have it
21:43:37 <tmb> well, packages not defining proper %attr for special files is a packaging bug, regardless of "it worked by mistake before"
21:44:51 <ennael> so rather a bad habit for packagers?
21:45:41 <coling> Yeah I guess so.
21:46:37 <ennael> ok so answer needed here then. I guess it may not be appreciated :)
21:46:51 * coling wonders if it can be scripted.
21:47:21 <coling> rpm -qp on MGA4 RPMS and to find setu/gid files and try and find the same files on MGA5 RPMs to cross reference?
21:47:29 <coling> pterjan, WDYT?
21:47:34 * MrsB adds one to the list
21:47:35 <coling> We can then fix up packages.
21:47:45 <coling> tmb, does this sound plausable
21:48:28 <pterjan> coling: that should be doable from hdlist
21:48:31 <wilcal> i must go. Thanks everyone
21:48:36 <wilcal> cheers
21:48:38 <marja11> wilcal: good night
21:48:38 <MrsB> nite wilcal
21:48:40 <coling> pterjan, nice.
21:48:41 <olivier_cc> bye wilcal
21:48:43 <DavidWHodgins> wilcal: Have a good night
21:48:46 <coling> Can you take a look maybe?
21:48:53 * coling lacks hdlist parsing skills
21:49:00 <pterjan> yeah but probably not tonight :)
21:49:08 <ennael> pterjan: take that one I have one more for coling aside :)
21:49:26 <ennael> #info pterjan will look at 14691
21:49:55 <tmb> not to mention we have not have had much reports of broken stuff even if the issue popped up 2,5+ months ago...
21:50:11 <coling> Yeah I susepct the fallout isn't too massive
21:50:22 <spturtle> we already looked at it, seee list
21:50:26 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14401
21:50:28 <[mbot> [ Bug 14401 5beta2: Shorewall not started - systemd[1]: Job shorewall.service/start deleted to break ordering cycle starting with mandi.service/start. ]
21:50:31 <ennael> just added by MrsB
21:50:37 <MrsB> /o\
21:51:07 <MrsB> it was added to bug 14069 but not release_blocker
21:51:46 <coling> Ohh
21:51:59 <coling> Can you still reproduce that one?
21:52:02 * coling like ordering cycles.
21:52:32 <coling> I can take a look
21:52:34 <MrsB> right up your street
21:52:38 <ennael> thanks :)
21:52:42 <MrsB> :)
21:53:17 <ennael> https://bugs.mageia.org/show_bug.cgi?id=11105
21:53:19 <[mbot> [ Bug 11105 RAID ( ddf / isw ) broken for new install ]
21:53:26 <ennael> we have some supporters here for that one :)
21:53:40 <MrsB> vzawalin1: ^
21:54:39 <vzawalin1> Vled - new nick:  I have spent a bit of tome trying to see where the problem is, mainly in live install
21:55:23 <ovitters> coling: NM@1.0.0, even added a NM-OpenSWAN package
21:55:35 <coling> vzawalin1, what's the summary on that one.
21:55:43 <ovitters> coling: there's also NM-iodine.. TCP/IP over DNS.. but 0.0.4
21:55:47 <coling> vzawalin1, I've not looked for ages and only have swraid h/w
21:55:49 <tmb> well, that's most because we've been relying on dmraid for bios fakeraids, and no-one have had time to adapt for mdadm filtering for isw_
21:56:40 <coling> tmb, so where do we need to fix things? I know we're still doing crappy init of raid stuff (via outdated fedora-storage-init script)
21:56:55 <coling> tmb, I think fedora themselves started doing it all via udev a while back.
21:57:12 <coling> (or maybe I'm confusing that with lvm)
21:57:29 <tmb> vzawalin1, btw, one thing to test... when you boot live media in efi mode, remove the "rd.md=0" part from kernel command line and see if anything changes for you
21:58:03 <vzawalin1> In live install there is a call to blkid with an invalid parameter. This comes from incorrect  parsing (i think) from sdb1 ( a raid member). I think some further debugging and code changes are needed -not yet sure where
21:58:48 <vzawalin1> tmb: I have tried this yesterday, without effect
22:00:11 <tmb> well, now when I have uefi stuff somewhat out of the way, I can start testing the raid stuff... I'll ping folks when I get initial tests / debugging done
22:00:43 * ovitters is off
22:00:43 <MrsB> i can help test that too, it fails with the one i have that has intel bios extensions
22:00:57 <vzawalin1> thank you tmb. Please let me know if/when you need my /more test results
22:01:08 <MrsB> nite ovitters
22:01:33 <ennael> #info tmb may fix #11105 with the help of MrsB and vzawalin1
22:01:40 <marja11> ovitters: good night
22:02:29 <coling> night ovitters speak to you soon
22:03:03 <MrsB> we have a raft of installer gtk issues. Luc had some input on those
22:03:08 <ennael> then we have all the bugs about design of installer
22:03:23 <ennael> I gave a tried to missing icons adding files in list.xml
22:03:38 <ennael> https://bugs.mageia.org/show_bug.cgi?id=13673
22:03:40 <[mbot> [ Bug 13673 5beta2: Installer drop down menu icons are missing ]
22:03:44 <MrsB> annoying one is the installation details screen not scrolling
22:03:45 <ennael> not very successfull for now
22:04:17 <ennael> also with last test on coming iso, install screen is totally broken
22:04:26 <dvg_i> each of these indivually isnt so bad, but all of them together makes it a bad installer, IMHO
22:04:33 <MrsB> yes
22:04:53 <MrsB> we've had them for a number of releases now
22:05:04 <ennael> dvg_i: it has to be fixed
22:05:09 <pterjan> should be broken the same way with drakx in chroot
22:05:12 <ennael> they are all blockers
22:05:25 <pterjan> and would probably be easier to find missing files
22:05:49 <ennael> should be
22:06:08 <vzawalin1> I will test the new classical iso today to see if installer works in Gui.  good day everyone
22:06:14 <MrsB> dvg_i:  could you set them as release blocker so that they are added to the list
22:06:17 <dvg_i> maybe stuid, but i see it like we could either change the theme or make mageia specific patches
22:06:20 <MrsB> nite vlad
22:06:32 <coling> night vzawalin1 :)
22:06:35 <marja11> good night vzawalin1
22:06:49 <ennael> MrsB: most of them are already
22:06:52 <MrsB> ok
22:06:59 <dvg_i> MrsB: i am very short on time, no time tomorrow in the day, dus to family business, sorry
22:07:07 <coling> dvg_i, the installer uses oxygen still?
22:07:22 <dvg_i> coling: AFAIK adwaita
22:07:23 <marja11> coling: I understood it uses Adwaita
22:07:26 <MrsB> it changes to adwaita IINM
22:07:32 <marja11> lol
22:07:38 <MrsB> harmony :)
22:07:40 <coling> :)
22:07:52 <tmb> nope, it's switched to Adwaita but the list for adding icons is not updated to match
22:08:05 <coling> Ahh cool.
22:08:16 <coling> Also perhaps icon names changed? I know some have.
22:08:24 <marja11> :-/
22:08:29 <coling> So perhaps code needs to change to reference names that acutally exist no?
22:08:39 <coling> (just a guess if the main problem is missing icons)
22:08:57 <ennael> (runinstall2:21995): Gtk-WARNING **: Could not find the icon 'pan-down-symbolic-ltr'. The 'hicolor' theme
22:09:00 <coling> (e.g. I know other DEs had issues)
22:09:02 <tmb> Adwaita should in theory work better with the gtk installer as it comes "from the same camp"
22:09:10 <ennael> ok pb with names I guess
22:09:13 <MrsB> it looks nicer
22:09:25 <MrsB> apart from the issues
22:09:47 <coling> ennael, this one should be used: /usr/share/icons/Adwaita/scalable/actions/pan-down-symbolic.svg
22:09:57 <ennael> so we have 2 big pbs: icons and window behavior
22:10:00 <ennael> coling: yep
22:10:04 <coling> ennael, seems odd that the icon theme is set to "hicolor" (which is the fallback)
22:10:26 <ennael> (runinstall2:21995): Gtk-WARNING **: Could not find the icon 'pan-down-symbolic-ltr'. The 'hicolor' theme
22:10:29 <ennael> was not found either, perhaps you need to install it.
22:10:29 <coling> The icon naming spec dictates that it should use the primary icon theme and then fall back to "hicolor" (as a built in default)
22:10:31 <ennael> for the complete message
22:10:51 <ennael> giving a try for that one
22:10:53 <coling> ennael, the icon naming spec also says it will drop parts of the file name until it finds one.
22:11:11 <coling> ennael, e.g. pan-down-symbolic-ltr will be tried, then pan-down-symbolic, then pan-down, then pan
22:11:23 <ennael> oh Luc just said he was also having a look on that one
22:11:48 <coling> So I suspect the gtk preferences might not have specified the correct icon theme dir? Or perhaps just the file lists not being updated as tmb said.
22:12:01 <ennael> https://bugs.mageia.org/show_bug.cgi?id=12422
22:12:02 <coling> either way that's the knowlege I have of how the icon loading logic is implemented.
22:12:03 <[mbot> [ Bug 12422 installer runs in floating window covering the left column ]
22:13:19 <pterjan> this one keeps annoying me each time I want to try in kvm
22:14:02 <ennael> it's worse now
22:14:08 <ennael> just not usable
22:14:54 <brian_> it is when you KVM away from your machine correct?
22:15:11 <MrsB> the window can be dragged in places
22:15:30 <coling> MrsB, ahh yeah that one.
22:15:34 <MrsB> yep
22:15:36 <coling> It's a gtk3 theme feature
22:15:43 <coling> I believe it can be disabled.
22:15:51 * coling searches
22:15:56 <MrsB> a feature :D
22:16:40 <ennael> http://hupstream.com/~ennael/install.png
22:16:46 <ennael> I cannot move it anymore
22:16:56 <ennael> in vbox
22:17:04 <MrsB> oh, not seen that
22:17:27 <ennael> bakcground has moved on the left
22:17:40 <Oro_Valley> I cannot move it either on real HW
22:17:42 <Benmc> the window is about 10% larger than the ' accept licence ' pane
22:18:43 <Oro_Valley> and it has move too the left here too,
22:19:00 <spturtle> moving it would still require a window manager I suppose
22:20:20 <Benmc> for me it starts from "custom disc partitioning"
22:22:10 <MrsB> brb two secs
22:22:18 <brian_> happens only when switching between KVM or other situations?
22:22:32 <spturtle> coling: https://developer.gnome.org/gtk3/stable/GtkWindow.html#gtk-window-set-decorated ?
22:22:32 <brian_> may be a lower priority as 99% of the world doesn't use it
22:22:33 <[mbot> [ GTK+ 3 Reference Manual: GtkWindow ]
22:23:13 <spturtle> (that's old stuff, nm)
22:23:54 <coling> spturtle, no I don't think so.
22:24:21 <coling> spturtle, I remember a while back, that dragging windows was possible by dragging the background of windows - in empty space.
22:24:32 <coling> I just can't remember how to disable it...
22:26:33 <coling> maybe it was a mutter thing...
22:26:55 <brian_> tmb are you still on?
22:27:27 <ennael> ok maybe I can try to ping back tv for this one at least
22:27:33 <ennael> he seems to be active at the moment
22:27:33 <tmb> brian_, yep
22:27:50 <brian_> install livedvd_gnome-i586
22:28:06 <ennael> that's all for my list
22:28:06 <brian_> when I go straight to install it reboots right before it get to partition screen
22:28:12 <Oro_Valley> need to go, i have a dentist appointment
22:28:22 <MrsB> nite Oro_Valley
22:28:23 * coling will have to ask upstream.
22:28:24 <brian_> installs when I"ve gone Live mode then install
22:28:44 <anaselli> i'm really tired
22:28:46 <ennael> questions? comments?
22:28:46 <brian_> or at least installing now
22:28:54 <tmb> brian_, file a bug and assign to me
22:28:58 <brian_> will do
22:29:03 <brian_> I will test it one more time first
22:29:16 <anaselli> i will keep reading blocking bug list
22:29:17 <DavidWHodgins> Should we discuss the schedule today, or leave that for the next council meeting?
22:29:33 <ennael> for now beta 3 is not ready
22:29:34 <anaselli> after have looked at the one taken :)
22:29:34 <brian_> I"m not council, but am brain dead
22:29:41 <ennael> let see what happens after the we
22:29:45 <anaselli> good night
22:29:48 <MrsB> I think tonight has been really productive. It's been a worthwhile exercise.
22:29:48 <ennael> so next council meeting :)
22:29:57 <ennael> thanks all for attending
22:29:58 <MrsB> nite anaselli
22:30:04 <DavidWHodgins> Ok
22:30:15 <Akien> Phew, that was a long one :)
22:30:20 <Akien> Thanks everyone for attending
22:30:27 <ennael> thanks for not snoring too loudly :)
22:30:35 <DavidWHodgins> :-)
22:30:35 * coling asks upstream re the moving windows
22:30:45 <ennael> we will update all this on dev ML
22:30:49 <coling> :)
22:30:52 <ennael> good night / day
22:30:58 <MrsB> do you want to plan next meeting?
22:30:59 <coling> well done ennael
22:31:02 <ennael> #endmeeting