19:37:27 <malo> #startmeeting
19:37:27 <Inigo_Montoya> Meeting started Tue Oct 14 19:37:27 2014 UTC.  The chair is malo. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:37:27 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:37:35 <malo> #chair ennael
19:37:35 <Inigo_Montoya> Current chairs: ennael malo
19:37:46 <malo> morning everyone
19:37:59 <DavidWHodgins> HiYa
19:38:10 <malo> hope you got tea, coffee, breakfast, lunch or dinner in front of you!
19:38:20 <doktor5000__> or beer ...
19:38:37 <malo> #topic anyone new?
19:38:41 <ennael> aspirin
19:38:54 <malo> I don't think new apprentices joined recently
19:39:05 <malo> anyone new in the assistance?
19:39:42 <malo> Lurking people are welcome :-)
19:39:51 <malo> Ok, moving on then.
19:40:01 <malo> #topic Beta 1 status
19:40:13 <malo> ennael: what is the iso situation?
19:40:54 <ennael> well not in a good shape at the moment
19:41:00 <ennael> stage2 is broken
19:41:22 <ennael> there is an issue between rpm and glibc
19:41:34 <ennael> it just kills everything so not usable at all
19:41:42 <ennael> https://bugs.mageia.org/show_bug.cgi?id=14172
19:41:42 <malo> ouch
19:41:58 <ennael> bug was reported upstream, waiting for some inputs
19:42:27 <ennael> I will write a short post about it on blog
19:42:29 <malo> ok, we'll remember for next time: no new rpm so late in the cycle :-P
19:42:58 <ennael> well either rpm or glibc
19:43:00 <sander85> is it new rpm?
19:43:09 <DavidWHodgins> ennael: We should probably put out another blog post about the delay.
19:44:01 <ennael> yep
19:44:05 <ennael> see what I wrote :)
19:44:20 <ennael> doing it at the moment
19:44:47 <ennael> so as soon as this is solved we can release isos for tests
19:45:02 <ennael> at least content of classical iso looks ok, no breakage
19:45:09 <DavidWHodgins> wrote where?
19:45:16 <ennael> 21:42 < ennael> I will write a short post about it on blog
19:45:31 <sander85> well, there should be another mass rebuild before beta, or not?
19:45:50 <philippem> but all python modules still broken https://bugs.mageia.org/show_bug.cgi?id=14137
19:45:57 <ennael> maybe we can do it now as anyway we are just blocked
19:46:13 <ennael> I have to check this with pterjan
19:46:19 <sander85> yep
19:46:31 <sander85> if most packages are fixed then it should be the right time to do it
19:46:39 <ennael> yep
19:47:03 <ennael> #action check with pterjan for the second mass rebuild while stage2 is fixed
19:47:33 <malo> There are still 270 problems at http://check.mageia.org/cauldron/dependencies.html
19:47:35 <DavidWHodgins> If there are changes going to be needed for glibc and/or rpm, it might be better to wait until those are done.
19:47:38 <philippem> but before https://bugs.mageia.org/show_bug.cgi?id=14137 have to be fixed
19:48:14 <malo> but only 510 build failed in latest autobuild
19:48:23 <malo> http://pkgsubmit.mageia.org/autobuild/results.php?run=2014-10-12
19:48:28 <ennael> philippem: any idea on that one ?
19:48:37 <ennael> or do you need somebody to help on that
19:49:30 <philippem> I don't know how findrequires is managed, Perl ?
19:50:04 <ennael> I think so
19:51:19 <philippem> I even don't known at what code to look for and where, so yes need help for sure ;)
19:51:32 <ennael> looks bash
19:51:47 <ennael> /usr/lib/rpm/find-requires
19:52:08 <ennael> at least for main script
19:52:27 <ennael> will send a mail on dev to ask for help
19:54:37 <malo> besides python and rpm, is java in better shape?
19:55:06 <sander85> afaik maven got fixed
19:55:14 <ennael> for what I know dmorgan was waiting for some python deps but solved now
19:55:20 <ennael> I guess wirk is in progress
19:55:22 <ennael> work
19:56:22 <malo> cool
19:57:03 <malo> any other outstanding beta1 / mass rebuild issue?
19:58:06 <malo> seems not :-_
19:58:43 <malo> Ok, this is going to be short meeting then
19:59:37 <malo> Next topic
19:59:51 <malo> #topic security bugs
20:00:11 <ennael> Luigi12_work: you may have seen that one http://www.theregister.co.uk/2014/10/14/nasty_ssl_30_vulnerability_to_drop_tomorrow/
20:00:39 <malo> 2 weeks ago we started an effor to reduce the number of security bugs
20:00:49 <Luigi12_work> ennael: yes I saw it.  I don't know anything about it though.
20:01:10 <Luigi12_work> ennael: all I can say is you can disable sslv3 in your Firefox by setting the minimum tls version to 1 in about:config
20:02:30 <malo> we are now down to 48 from 60 2 weeks ago
20:02:34 <malo> https://bugs.mageia.org/buglist.cgi?quicksearch=comp%3Asecu%20-%40qa-b&list_id=34296
20:03:06 <malo> We need to keep the effort
20:03:32 <ennael> I'm a bit annoyed about the way work is organized
20:04:01 <ennael> as an example I started working on dokuwiki because ldap use case was needed, mentionned it in bugzilla
20:04:10 <ennael> just to discover somebody else did it today
20:04:27 <ennael> so all my tests are just to be throw away
20:04:28 <Luigi12_work> ennael: he didn't complete testing
20:04:48 <Luigi12_work> he made a first attempt at getting it set up, and I don't know if he had it completely working yet
20:04:53 <ennael> would be great to try to organize this at least ask people to warn when they work on it
20:04:57 <Luigi12_work> ennael: any feedback on setting it up would still be helpful
20:05:21 <ennael> I guess having 48 opened issues we should have work for everyone
20:05:52 <ennael> well it's not the first one, and I find it quite frustrating :) was just a comment
20:05:52 <Luigi12_work> yep, lots of work to do
20:06:25 <malo> #action packagers need to step up and help reduce the list of pending security bugs
20:07:24 <filipesaraiva_> Maybe this about polkit-qt1 is fixed to Cauldron https://bugs.mageia.org/show_bug.cgi?id=13792 missing fix to mga3 and mga4.
20:08:36 <Luigi12_work> yep, Luc is aware for that one
20:10:43 <filipesaraiva_> Luc fixed this too https://bugs.mageia.org/show_bug.cgi?id=13545
20:11:30 <filipesaraiva_> "Solution Upgrade to version 4.13.3 or apply the patch... https://www.kde.org/info/security/advisory-20140618-1.txt" we are using 4.14 now.
20:11:50 <filipesaraiva_> Maybe this bug report lists needs some triage...
20:11:56 <Luigi12_work> no
20:12:04 <Luigi12_work> I manage it
20:12:12 <Luigi12_work> that list is ones not assigned to QA
20:12:17 <filipesaraiva_> Ah, sorry Luigi12_work.
20:12:32 <Luigi12_work> 13545 isn't assigned to QA because it's part of the KDE 4.12.5 update for Mageia 4, which is being managed (and QA'd) in Bug 13221
20:13:06 <Luigi12_work> feel free to ask me about the current status of any of the bugs if it's not clear
20:13:23 <filipesaraiva_> Thanks Luigi12_work.
20:13:25 <ennael> Luigi12_work: btw I've added a filter for your mail :)
20:14:52 <Luigi12_work> yay, thanks!
20:16:44 <DavidWHodgins> I check my gmail spam filter at least once a week, and add filters for all of the yahoo.com mailing list posters.
20:17:46 <DavidWHodgins> s /spam filter/spam folder/
20:19:57 <malo> Ok.
20:20:22 <malo> Anything else on security bugs?
20:20:40 <Luigi12_work> FYI, I'm working on a list of new package versions available since the freeze, for ones missed by youri-check.  I hope to have it sent out later today.
20:21:04 <malo> Luigi12_work: freeze means that we don't update anymore
20:21:10 <Luigi12_work> malo: no it doesn't
20:21:15 <Luigi12_work> it means we update only for bugfixes
20:21:28 <Luigi12_work> so yes not all in the list will be desirable, but some may
20:21:33 <malo> ok
20:21:35 <malo> Thanks
20:21:38 <Luigi12_work> doktor5000__: how's the mga3 FF builds coming?
20:22:06 <malo> #topic Any other topic?
20:22:24 <filipesaraiva_> Luigi12_work: I was working in a metapackage to install all KF5 headers. Can I still import it? It is just a metapackage. (task-kf5-devel).
20:22:40 <malo> 5
20:22:42 <malo> 4
20:22:45 <malo> 3
20:22:49 <malo> 2
20:22:54 <malo> 1
20:23:00 <malo> #endmeeting