19:38:08 <ennael> #startmeeting
19:38:08 <Inigo_Montoya`> Meeting started Tue Sep  9 19:38:08 2014 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:38:08 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:38:38 <ennael> so first topic
19:38:43 <ennael> #topic rpm update
19:39:04 <ennael> as you may have seen on -dev there is a proposal to update rpm for Mageia5.
19:39:22 <ennael> tv gave some details about it and now we have to decide wether we go for it or not
19:39:37 <DavidWHodgins> As discussed in yesterday's council meeting, if it's going to go in before Magea 6, it should go in today.
19:39:46 <ennael> indeed
19:41:01 <coling> I know Luigi12 has his reservations, but I figure before a mass rebuild it makes sense to do it now.
19:41:40 <Luigi12_work> but right before?
19:41:45 <Luigi12_work> we're gonna have enough build problems as it is
19:43:23 <Luigi12_work> ennael: BTW this is the build log I get when I try to build proftpd 1.3.5 http://paste.opensuse.org/54104043
19:43:30 <doktor5000> if we drop all that java mess we'll have less problems and less packages maintained by nobody
19:43:39 <Luigi12_work> lol
19:43:53 <Luigi12_work> well unfortunately much of the Java mess is needed by some things (like libreoffice)
19:44:03 <Luigi12_work> it would be nice to get rid of whatever's not needed
19:44:37 <ennael> I've spoke with dmorgan this afternoon
19:44:50 <ennael> he will start fixing java stack this week
19:45:41 <ennael> anyway back on rpm
19:45:48 <ennael> tmb: any opinion?
19:45:53 <ennael> malo: ? (if around)
19:46:19 <Luigi12_work> tmb posted on the ml
19:46:52 <tmb> well, as I stated on the ml, I think it's worth the risk (famous last words)
19:47:17 <ennael> Luigi12_work: just to get all of them tonight before taking decision
19:47:24 <Luigi12_work> ok
19:49:00 <philippem> for rpm I think we should go
19:49:08 <DavidWHodgins> tmb: There has to be something wrong in a beta release. :-)
19:50:18 <Oro_Valley> hello
19:51:05 <ennael> as a reminder http://comments.gmane.org/gmane.linux.mageia.devel/37709
19:51:06 <[mbot> [ Mageia Linux development mailing-list () ]
19:51:18 <ennael> for those who wants to read all the details
19:51:59 <ennael> the thing is we have a detailed proposal to switch and steps for it. Looks reasonable for me even if not confortable :)
19:53:06 <DavidWHodgins> As long as it's done before the mirror used to create beta 1 is created, I'm ok with it.
19:53:26 * anaselli read it now :)
19:53:39 <Oro_Valley> +1
19:54:18 <anaselli> i think we need to take the risk now, later can be hard to fix
19:54:40 <anaselli> i think tv has a good idea for the roadmap
19:54:51 <DavidWHodgins> Version freeze is today, so it should be done today.
19:54:53 <anaselli> certainly we will have problems :)
19:54:58 <ennael> ok let's vote for those around
19:55:08 <ennael> ok for rpm update
19:55:09 <anaselli> version freeze can help
19:55:21 <anaselli> no more packages during the startup phase :)
19:55:24 <tmb> ok for rpm update
19:55:43 <DavidWHodgins> Ok here, as long as it's done very soon.
19:55:43 <anaselli> perl test could be skipped i would add
19:59:37 <ennael> ok looks like most of people ar ok
19:59:58 <ennael> then we will answer on mail thread and see how to proceed to be on time
20:00:40 * anaselli is far next week :D
20:00:47 <ennael> anything else on this ?
20:01:40 <tmb> well, we need to prepare BS first before pushing rpm-4.12 to cauldron... but that can hopefully be done tonight/tomorrow
20:01:53 <ennael> juste after freeze
20:01:59 <ennael> speaking about freeze
20:02:06 <ennael> #topic version freeze
20:02:23 <ennael> so version freeze is planned for tonight
20:02:32 <ennael> tmb will push the red button soon
20:02:43 <ennael> is version freeze clear for everybody here?
20:02:47 <ennael> what it means
20:03:18 * tmb searches for the button... oooohhh found it... shiny...
20:03:18 <Oro_Valley> last 5 minutes are the most productive ones :)
20:04:04 <ennael> as a reminder, version freeze means no new upstream version of software will be allowed until final release
20:04:06 <anaselli> yeah! we have to bother you for pushing our updates :p
20:04:11 <Luigi12_work> ennael: proftpd 1.3.5 builds if mod_time is dropped.  Last upstream release of mod_time is 10 years old.
20:04:31 <ennael> Luigi12_work: outch it's worh submitting it then
20:04:47 <Luigi12_work> ennael: ok, thanks.  I assume that's what you wanted when you pinged me 13 hours ago
20:04:56 <Luigi12_work> sorry I didn't see it, netsplit knocked my laptop off IRC
20:04:58 <ennael> yep I tried to build it also
20:05:04 <ennael> so back on freeze
20:05:22 <ennael> you can ask for freeze push but you should have good reason and mail ot on -dev
20:06:11 <ennael> (and beer is not a good reason :p)
20:07:26 <tmb> wait.... what....
20:07:31 <anaselli> /o\
20:07:43 <anaselli> tmb: beer for you is ok? :D
20:07:49 <ennael> tsss :)
20:08:02 <ennael> anything else on freeze ?
20:08:19 <Luigi12_work> make sure dmorgan has freeze push capabiliity so he can fix the Java stack
20:08:32 <MrsB> morning dev
20:08:33 <Luigi12_work> I think the core packages are in good shape as far as being up to date, so that's really good
20:08:43 <coling> And ovitters too for gnome stuff.
20:08:47 <ennael> yep great work on this
20:08:50 <Luigi12_work> I think some might have started a little late on their leaf packages...maybe you could be more lenient until the mass rebuild starts
20:08:56 <Luigi12_work> other than that, I think we're good
20:08:59 <Oro_Valley> can we still submit new pacakges?
20:09:04 <Luigi12_work> yes
20:09:08 <ennael> tsss :)yep
20:09:10 <ennael> oups
20:09:13 <Luigi12_work> coling: indeed
20:09:17 <Oro_Valley> I am thinking about samba4
20:09:25 * Luigi12_work sees a pie in the sky
20:09:36 <ennael> blingme: around ?
20:10:35 <ennael> ok let see later
20:10:38 <ennael> #topic mass rebuild and non-building packages
20:10:57 <ennael> so after freeze and rpm update, mass rebuild is planned
20:11:04 <ennael> is pterjan taking care of it ?
20:12:01 <tmb> I think so, but iirc he's still travelling for some days...
20:12:17 <DavidWHodgins> Distro rebuild isn't planned until the 15th.
20:12:37 <ennael> tmb: was not sure as I spoke with him today
20:12:48 <Oro_Valley> would be nice to have a few more daus after rebuild to fix builds
20:12:54 <ennael> DavidWHodgins: yep but things need to be setup before
20:12:59 <Oro_Valley> sorry days
20:13:37 <Oro_Valley> do we have enough hardware resources?
20:13:49 <Oro_Valley> (buildnods)
20:14:10 <Luigi12_work> there's 15 days between the mass rebuild and beta 1, hopefully that's enough time to fix most of the builds we can fix
20:14:19 <Luigi12_work> of course the mass rebuild takes a few days
20:14:22 <tmb> And iirc the rebuild script is stored in svn
20:14:31 <Luigi12_work> hopefully we have another build node we can turn on during the mass rebuild, like we usually do
20:14:39 <Luigi12_work> I guess jonund is still under the weather
20:14:43 <DavidWHodgins> Keep in mind, iso testing takes about a week, so the rebuild has to be finished by then.
20:14:53 <Luigi12_work> yep
20:15:18 <tmb> yep, I'll ping maat about going to DC and re-install sucuk so we get atleast 3 servers building
20:15:38 * doktor5000 will ask ennael: and tmb: for an exception for lxqt 0.8 as soon as they got it out the door
20:16:02 <Luigi12_work> yeah that'll be a really good one to have, people will like that
20:16:46 <DavidWHodgins> doktor5000: Procedure for an exception is to ask on the dev mailing list, with a good explanation of why it should be allowed.
20:17:09 <MrsB> replacinf lxde?
20:17:11 <MrsB> -f+g
20:17:46 <Luigi12_work> I hope so
20:17:57 <ennael> #action reinstall sucuck to get enough node for mass rebuild
20:19:15 <Oro_Valley> lunch is ready, see ya later
20:19:57 <ennael> as a reminder we have also http://check.mageia.org/cauldron/dependencies.html to fix
20:19:59 <[mbot> [ dependencies global report ]
20:21:21 <ennael> looking for the url about mass rebuild
20:22:08 <MrsB> the release planning?
20:22:26 <MrsB> https://wiki.mageia.org/en/Mageia_5_Development that one?
20:22:33 <ennael> nope the web site for the report about mass rebuild results
20:22:37 <ennael> broken packages
20:22:40 <MrsB> oh
20:22:50 <ennael> (and a new brain please :p)
20:24:00 <tmb> ennael, you mean this: http://pkgsubmit.mageia.org/autobuild/ ?
20:24:14 <ennael> http://pkgsubmit.mageia.org/autobuild/
20:24:15 <MrsB> i know the one you mean but can't find it either
20:24:20 <ennael> raa :)
20:24:23 <ennael> thanks tmb :)
20:24:58 * pterjan present
20:25:11 <ennael> :) we were speaking about mass rebuild
20:25:18 <ennael> can you handle it for next week ?
20:25:35 <pterjan> probably
20:25:40 <pterjan> flying back on saturday
20:26:04 <ennael> that would be great
20:26:32 <pterjan> one thing I have to mention, I tried getting the java stack updatedas it's quite broken but made slow progress :(
20:27:17 <ennael> as said previously, dmorgan will start on it in coming days
20:27:18 <pterjan> I want to have at least javapackage-tools before the rebuild and currently the tests fail
20:27:22 <pterjan> ok
20:27:37 <Luigi12_work> it's hard to progress quickly when there's what, 2000 of those packages?
20:27:37 <ennael> I'll tell him about javapackage-tools
20:28:05 <tmb> "rm -f" is fast :)
20:28:12 <Luigi12_work> :D
20:28:27 <pterjan> well when the core are fixed, most should rebuild nicely :)
20:29:04 <ennael> ok dmorgan noticed about javapackage-tools
20:29:14 <ennael> anything else on mass rebuild ?
20:29:37 <pterjan> not really, would be great to have sucuk back but not mandatory
20:29:49 <pterjan> also switching to the new valstar would be great but unlikely
20:30:15 <ennael> mail sent by tmb about sucuck to ask maat for it
20:30:25 <pterjan> great
20:31:06 <ennael> ok last topic then
20:31:08 <tmb> pterjan, the other option would then  be to pull new valstar in as a node temporarily
20:31:33 <ennael> what about rabbit ?
20:31:46 <tmb> rabbit is working as a node right now
20:31:50 <pterjan> true
20:31:51 <ennael> ok
20:32:03 <Luigi12_work> slowly
20:32:05 <pterjan> sounds like a good idea
20:33:43 <ennael> next topic ?
20:34:16 <tmb> yep
20:35:05 <ennael> #topic features progress
20:35:24 <pterjan> also just thinking about it, I can run an autobuild on the new valstar today
20:35:38 <pterjan> as current results are quite old
20:35:45 <Luigi12_work> that'd help
20:36:14 <tmb> yeah, lets put new valstar to some good use
20:37:37 <malo> hi, sorry I'm late
20:37:49 <ennael> malo: then you manage the last topic :)
20:37:54 <malo> was having lunch with pterjan
20:38:04 <malo> he talks so much :-)
20:38:10 <pterjan> :)
20:38:31 <ennael> (pb is not talking it's joking)
20:38:43 <malo> ennael: give me a minute to read the logs to see where we're at
20:38:58 <ennael> we are just starting on features topic
20:39:04 <anaselli> malo: just read the topic :p
20:39:27 <Luigi12_work> ouch
20:40:56 <malo> ok features progress ...
20:40:57 <anaselli> https://wiki.mageia.org/en/FeatureMageia5_Review ?
20:41:06 <malo> Was there any progress made?
20:41:47 <anaselli> from my side adminpanel has been released
20:42:30 <malo> ankh: yes, thanks for that!
20:42:48 <malo> anaselli: thanks
20:43:13 <malo> ennael: progress on btrfs
20:43:15 <malo> ?
20:43:27 <ennael> yep pterjan can speak about it
20:43:47 <malo> (the power of delegation :-))
20:43:48 <pterjan> not much, I did an install with / over btrfs and rebooted
20:44:04 <pterjan> it worked, nothing more done
20:44:15 <pterjan> I can switch it and let the bug reports flow :-P
20:44:34 <pterjan> main problem is that we have only simple support
20:44:59 <pterjan> like we don't offer toinstall ona snapshot, etc
20:45:20 <pterjan> and we haveno UI for any interesting feature
20:45:33 <pterjan> so we don't give much benefit for switching
20:46:12 <malo> is it reasonable to switch to it by default then?
20:46:41 <pterjan> not sure
20:47:00 <anaselli> not sure... or sure not :D
20:47:17 <DavidWHodgins> I'm inclined to say wait until at least Mageia 6.
20:47:24 <pterjan> well my home is on btrfs which is nice
20:47:25 <Luigi12_work> agreed
20:47:35 <Luigi12_work> we should go through a whole devel cycle with it, and have some UI and features for it
20:47:39 <pterjan> but I doubt many people would see any advantage without more integration
20:47:43 <Luigi12_work> otherwise what's the reason for the switch?
20:47:49 <pterjan> agree
20:48:16 <Luigi12_work> we should be able to steal stuff from opensuse
20:49:26 <malo> ok. Let's postpone that to mga6
20:49:31 <malo> ennael: sorry
20:50:36 <MrsB> i think would do well if combined with a move to grub2
20:50:37 <malo> Other features are about kdedm (neoclust)
20:50:59 <malo> and phonon
20:51:11 <malo> anyone from the kde team around?
20:51:12 <tmb> yeah, I guess we maybe should focus on getting installs on btrfs work oob for mga5, but not default to it until mga6
20:51:33 <Luigi12_work> switch to phonon-vlc by default is completed as I understand
20:51:41 <malo> Luigi12_work: yes.
20:51:54 <Luigi12_work> phonon packages were updated this weekend, except not the ones that require gstreamer 1.0, that'll wait for mga 6
20:52:11 <Luigi12_work> sddm is packaged, still a work in progress as far as perfecting it
20:52:30 <Luigi12_work> not sure if we'll be able to drop KDM, but we've got more testing to do
20:52:32 <malo> Luigi12_work: not yet by default for kde installs
20:52:51 <Luigi12_work> what isn't yet default?
20:52:53 <DavidWHodgins> MrsB: Why move to grub2?
20:53:17 <malo> is kdm still default for KDE installs?
20:53:25 <Luigi12_work> grub2 seems like needless complication to me.  I think coling has stated the same
20:53:34 <Luigi12_work> malo: yes, kdm is still the default DM
20:53:56 <DavidWHodgins> Luigi12_work: Agreed. I see no need for it on on uefi  systems.
20:53:59 <Luigi12_work> sddm should be the default for an LxQt install
20:54:13 <Luigi12_work> also for plasma 5
20:54:17 <Oro_Valley> if you use btrfs for / you need grub2?
20:54:36 <MrsB> yes, or separate /boot
20:54:54 <Luigi12_work> don't see much point of a btrfs /boot though
20:55:18 <Luigi12_work> but yes the installer should know to use grub2 if you configure it yourself without a separate /boot
20:55:20 * coling nods on grub2, but that doens't mean we can't use it in a simplistic way. Stripped down it's functional at least. I'm mainly proposing we simplify things greatly by default and don't give much in the way of options, but this requires both approval and finding time to actually do the work which is proving just as hard!
20:55:21 <pterjan> Luigi12_work: not having separate /boot
20:55:29 <pterjan> yes itnow knows
20:55:33 <Luigi12_work> ahh good
20:55:36 <pterjan> wellit will in next instalelr release :P
20:55:43 <pterjan> it knows in git :)
20:55:57 <Oro_Valley> ond grub2 on the rescue as well?
20:56:00 * ennael will offer some new fingers to pterjan :p
20:58:45 <tmb> well, if we decide to do the "UEFI" fat /boot layout by default on all installs bootloader handling will be simpler... and hide advanced setups behind some "expert YMMW mode"
20:59:45 <Luigi12_work> what about the idea that a subdir of /boot could be FAT instead?
20:59:55 <Luigi12_work> the idea of /boot itself being FAT just blows my mind (in a bad way)
21:00:09 * pterjan doesn't see the difference
21:01:02 <malo> can we postpone btrfs to ... a later meeting?
21:01:23 <malo> news on samba4?
21:01:36 <Luigi12_work> we pinged blingme earlier, but no response :o(
21:01:49 <DavidWHodgins> malo: Version freeze is today, so if it's going to go into the installer, it should be done today.
21:01:53 <MrsB> diogenese may know  too
21:02:13 <DavidWHodgins> I'm not in favour of making it the default yet.
21:02:25 <Luigi12_work> samba4 can still be done later, it hasn't been built yet.  SVN last updated several months ago
21:02:37 <tmb> yeah, and before mga4 he said he had srpm almost ready, but he didn't want to give that out back then either...
21:02:37 <Luigi12_work> blingme's been saying he'd update what he's got into SVN, but hasn't yet
21:02:50 <Luigi12_work> tmb: indeed :o(
21:02:56 <Luigi12_work> it's like vaporware
21:03:26 <malo> diogenese interacted with him about xymon
21:03:38 <MrsB> oh that's right, sorry
21:03:44 <DavidWHodgins> As it's a new package, not a version upgrade, it has until 2014/10/28 to get in.
21:03:50 <diogenese> Very little. Only on the ml and haven't heard anything since.
21:03:56 <tmb> I wuold have liked to use it as he usually have done a good job on samba, but I dont think we can wait forever...
21:04:12 <Luigi12_work> yeah, I'd like to set up a backup domain controller at work with it
21:05:33 <Luigi12_work> might have to use CentOS :o(
21:06:03 <malo> can someone ping him more strongly?
21:06:22 <MrsB> time for matches?
21:06:25 <malo> or a volunteer to work on it?
21:06:29 <Luigi12_work> water balloon sent by carrier pidgeon?
21:06:31 <diogenese> Use a ping hammer?
21:06:58 <leuhmanu> there was also an 'apprentice' news from him (for samba4)
21:07:00 <leuhmanu> ?
21:07:01 <Luigi12_work> we've had someone in IRC and maybe the ml (can't remember) express interest in helping package it, but it's a new packager
21:07:50 <Luigi12_work> I can't imagine it'd be *too* overly difficult to just adapt Fedora's to Mageia packaging, but the question is would that be "good enough"
21:08:05 <Luigi12_work> I guess some added libification would probably need to be done
21:09:08 <malo> what do we do about the feature?
21:09:21 <Luigi12_work> pray?
21:10:01 <tmb> switch it to a "provide samba4"
21:10:20 <anaselli> If you don't have any question on adminpanel &co... i would go to bed... i'm pretty tired
21:10:21 <tmb> and move "integration/upgrade" to mga6 feature
21:10:29 <malo> tmb: sounds good
21:10:30 <Luigi12_work> agreed on that
21:10:34 <malo> I'll edit the feature.
21:10:51 <MrsB> out of 5 new features, we're cancelling one and downgrading another
21:11:35 <tmb> yeah, it sucks but if no-one want / have time to work on the features...
21:12:32 <malo> Yep, I'm not sure the feature system is working well
21:12:39 <malo> coling: network tools?
21:14:02 <coling> I've done very little work on it sadly :(
21:14:07 <Oro_Valley> samba4 still needs a lot of work. they release version 4.1.12 yeasterday. It will not be ready to replace samba3 in mga5
21:14:10 <MrsB> need regular meetings again i think to raise their profile
21:14:35 <malo> Oro_Valley: we're proposing to provide it as an alternative
21:14:36 <coling> I think I'll just bail out on initscripts ifup-wlan tho' and revert back to what we had... I won't really have time to debug and understand it all properly.
21:15:50 <Oro_Valley> malo: We are making good progress. The apprentice is really good
21:16:28 <malo> Oro_Valley: version freeze is today
21:16:55 <Oro_Valley> as we said earlier, it doesn't apply since it's a new pacakge
21:17:59 <tmb> just need to be careful with obsoletes/provides so it does not mess up anything
21:18:30 <malo> Oro_Valley: the earlier in the distro the more testing it gets. Ideally Beta 1 should be the target.
21:21:10 <Oro_Valley> tmb: I agree
21:21:35 * tmb sorry... laptop keeps dying...
21:21:36 <malo> Ok. I thing we're done with feature review. It's not looking very good.
21:21:57 <malo> We should have a discussion about features for mga6 development.
21:22:47 <DavidWHodgins> malo: A discussion of mga6 features should be left until after mga5 is out, in my opinion.
21:23:03 <malo> DavidWHodgins: yes, that's what I mean :-)
21:23:07 <malo> not today :-)
21:23:16 <DavidWHodgins> Yep
21:23:25 <malo> ennael: there?
21:23:40 * Luigi12_work wonders if branching a next stable before the release and having cauldron separate would help
21:23:47 <ennael> yep
21:23:48 <Oro_Valley> I think the serious testing will start around RC
21:23:48 <ennael> reading
21:25:30 <anaselli> good night
21:25:34 <malo> done with features :-)
21:25:44 <ennael> ok :)
21:25:45 <leuhmanu> Oro_Valley: it should not
21:25:47 <malo> Other things on the agenda?
21:25:49 <ennael> then I guess meeting is done
21:26:25 <DavidWHodgins> Yeah. Time for dinner here (I don't cook, so always go out for dinner.)
21:26:34 <malo> can we get the version freeze tonight (Pacific time)? :-)
21:26:45 <ennael> malo: planned already :)
21:27:04 <Oro_Valley> sounds good, tmb needs some slepp
21:27:12 <Oro_Valley> sleep
21:27:19 <malo> ennael: Good!
21:27:27 <malo> Thanks everyone!
21:27:31 <malo> #endmeeting
21:27:41 <ennael> #endmeeintg
21:27:44 <ennael> oups
21:27:49 <ennael> #endmeeting