19:37:32 <malo> #startmeeting
19:37:32 <Inigo_Montoya`> Meeting started Tue Aug 26 19:37:32 2014 UTC.  The chair is malo. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:37:32 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:37:41 <malo> #chair ennael
19:37:41 <Inigo_Montoya`> Current chairs: ennael malo
19:38:06 <malo> Welcome to the first post-vacation packager meeting!
19:38:44 <MrsB> morning :)
19:38:57 <malo> On the menu today: beta 1, feature progress, mass rebuild, plus other questions if needed
19:39:02 <malo> MrsB: morning
19:39:15 <malo> #topic new packager
19:39:29 <malo> First let's congratulate diogenese!
19:39:34 <ennael> congrats
19:39:47 <diogenese> Thanks. :)
19:39:57 <st3ve_> malo, done, i'm using that in my rpm now
19:40:07 <MrsB> well done diogenese
19:40:07 <malo> diogenese has been with us for quite some time and now he will be able to help even more :-)
19:40:25 <sander85> oh, mass rebuild already
19:40:41 <malo> Also we have augier who is apprenticing with AL13N
19:40:49 <malo> Welcome augier !
19:40:51 <augier> Hi everyone !
19:40:55 <ennael> welcome
19:40:56 <augier> Thanks !
19:41:19 <MrsB> hi augier, I'm from the QA team, sure we'll meet more later
19:41:46 <augier> Nice to meet you !
19:42:02 <MrsB> you too, we're nowhere near as scary as it sounds
19:42:10 <malo> Last, we have several apprentices in waiting on the usual page, please contact some and help them become packagers if they are still interested.
19:42:52 <malo> Also ennael plans to revive some seminar, so stay tuned :-)
19:43:29 <malo> ennael: a word on that or is it too early?
19:44:02 <ennael> a bit early. I have to prepare it
19:44:08 <ennael> should b e ready in 2 or 3 weeks
19:44:19 <malo> ok. Let's switch to the menu.
19:44:24 <malo> #topic Beta 1
19:44:37 <malo> Beta 1 is in one month
19:44:45 <malo> https://wiki.mageia.org/en/Mageia_5_Development
19:44:50 <malo> 9/30
19:45:16 <malo> and before that we have version freeze on 09/09
19:45:34 <malo> plus string freeze on 09/09
19:46:08 <augier> Version freeze mean no more new packages ?
19:46:26 <anaselli> vell new version of a package
19:46:28 <malo> So basically it means we only have 2 weeks to update the packages to their mga5 versions.
19:46:30 <anaselli> well
19:47:00 <anaselli> malo: a lot of people is has been on holiday...
19:47:23 <malo> anaselli: they're back :-)
19:47:26 * anaselli should change keyboard :/
19:47:39 <anaselli> well also at work though :p
19:48:10 <malo> As a reminder, version freeze is essential to have a stable distro and accumulate enough testing.
19:48:27 <Luigi12_work> I will mail the list about packages youri-check is missing sometime soon
19:49:30 <malo> Luigi12_work: thanks!
19:50:04 <malo> ennael: some wise words about version freeze?
19:50:17 <ennael> well we need also to review features
19:50:27 <ennael> I will have a look on installer side
19:50:31 <doktor5000__> no exceptions and no freeze pushes allowed this time :p
19:50:57 <ennael> that's not possible
19:51:06 <ennael> pushes are quite reasonable usually
19:51:39 * Luigi12_work gives doktor5000__ something to help him sleep
19:52:06 <ennael> :)
19:52:14 * doktor5000__ fainted
19:52:16 <ennael> something strog to drink ? :)
19:52:22 <MrsB> if it comes in a bottle, count me in
19:52:26 <ennael> :)
19:52:33 <doktor5000__> drink? somebody mentioned drinks?
19:52:52 <ennael> also on desktops side I will try to make a review with all maintainers
19:53:06 <ennael> to avoid broken on and keep only usable one in isos
19:57:09 <ennael> anything else for beta1 ?
19:58:24 <malo> Sounds good, but a mail on -dev about the upcoming version freeze would be useful
19:58:31 <ennael> indeed
19:59:13 <malo> #action ennael will send a mail to -dev reminding people of the upcoming freeze
19:59:15 <malo> :-)
19:59:38 <ennael> ahah ok :)
20:00:51 <malo> my emails are notoriously unreliable
20:01:24 <malo> ennael: when would iso start getting spinned for Beta 1?
20:01:36 <malo> ennael: after the freeze?
20:02:38 <ennael> yep I will make some tests maybe before just on my side to check global status
20:03:28 <malo> ok next topic
20:03:43 <malo> #topic feature progress
20:04:16 <malo> Last month we reviewed the progress done on the feature side, and there wasn't much
20:05:50 <malo> ennael: should we do a round?
20:06:44 <malo> The main pending ones are Btfrs_as_default NetworkDrakToolsImprovements and Upgrade_to_Samba4_(mga5)
20:06:51 <malo> https://wiki.mageia.org/en/FeatureMageia5_Review
20:07:12 <ennael> btrfs is in my bag? I have to check woth tv and pterjan
20:08:30 <sander85> btrfs needs grub2?
20:09:41 <malo> coling: around?
20:10:10 <Luigi12_work> blingme said he was gonna commit samba4 soon...
20:10:30 <malo> Luigi12_work: thanks
20:10:44 <Luigi12_work> hope that's still true
20:10:58 <malo> I think phononVlc is done
20:11:40 <malo> I don't know about the situation with kdm: neoclust ?
20:12:03 <Luigi12_work> kdm still lives, but not sure the status for showing the correct users
20:12:09 <Luigi12_work> probably still needs to be patched
20:12:37 <malo> Reminder, features should be included in Beta 1!
20:14:39 <MrsB> it might be a good idea to have regular meetings in the build up to release
20:15:14 <anaselli> malo: i can talk about a pending feature only from my side :)
20:15:29 <malo> anaselli: go ahead.
20:15:31 <malo> MrsB: yes
20:16:00 <anaselli> porting of drak*tools is going on, but i stopped for a while :)
20:16:20 <malo> MrsB: at least more often than once a month :-)
20:16:22 <anaselli> matteo is too busy to help atm, so i'm alone
20:16:32 <MrsB> yeah
20:16:35 <anaselli> or almost
20:17:17 <anaselli> i think i will try to produce a package to have it in our repository by the end of this week if i can finish some desktop files
20:17:50 <Luigi12_work> awesome :D
20:17:50 <anaselli> but then i'd expect bugs if someone is so brave to use it :)
20:18:08 <joeghi> anaselli: hi
20:18:22 <anaselli> and I'm not sure i can fix and go on at the same time, incoming month i'm very busy at work...
20:18:25 <anaselli> joeghi: hi
20:18:49 <malo> anaselli: no one can test if it's not there :-)
20:18:59 <malo> anaselli: but your project is for the long run
20:19:15 <anaselli> malo: true, no one also opens bugs... so basically it works :D
20:20:08 <anaselli> malo: yes for long term, but merging new changes becomes hard if i wait too much i believe...
20:20:56 <Luigi12_work> yep.  and I'd guess you're more likely to get help if something (sort of) working is packaged and easy to try
20:22:00 <malo> ennael: should we do weekly meetings until freeze?
20:22:25 <malo> ennael: which basically means a meeting next week :-)
20:22:42 <ennael> why not... can be short meetings
20:22:45 <anaselli> Luigi12_work: let's hope that :)
20:24:01 <malo> anaselli: please send a mail to -dev reminding people to test
20:24:23 <anaselli> once i push an rpm i'll do promise :D
20:24:40 <MrsB> looking forward to seeing it anaselli :)
20:25:14 <malo> next topic?
20:25:30 <malo> #topic Mass rebuild
20:25:55 <malo> So after version freeze we will do a mass rebuild.
20:26:18 <ennael> and break beta1 :)
20:26:24 <anaselli> malo: at that time can we silence changelog mailing list?
20:26:54 <anaselli> i'm out for work and i cannot read mails too much...
20:27:15 <malo> So it is essential that all packagers should monitor http://check.mageia.org/cauldron/ not only for failed dependencies and missing packages and updates but also for build failures.
20:27:17 <[mbot> [ QA global report ]
20:27:37 <malo> Latest run is at http://pkgsubmit.mageia.org/autobuild/
20:27:44 <malo> thanks to pterjan
20:27:54 <ennael> we need help from everybody
20:27:59 <ennael> even if not maintainer of a package
20:28:08 <malo> so we have 815 packages which do not build
20:28:42 <anaselli> i need help with nlog... i seem i cannot build new upstream package :(
20:29:28 <Akien> anaselli: Mail dev about it, you'll probably get some feedback
20:29:30 <Luigi12_work> most of the not-building packages are Java crap
20:29:32 <malo> plus 30 ish which fail due to dependencies.
20:29:43 <Luigi12_work> I e-mailed dmorgan but got no response.  Has anyone been in touch with him?
20:29:53 * Akien had a go at packaging some Java apps. I give up :-)
20:29:54 <anaselli> Akien: yeah, i've just seen my list so i recalled it :)
20:30:11 <Luigi12_work> well we don't need any Java apps
20:30:29 <Luigi12_work> most of the Java packages are libraries.  Packaging them isn't *hard* necessarily as it's mostly syncing with Fedora.
20:30:32 <anaselli> Akien: nlog is for mono though :p
20:30:47 <Luigi12_work> It's just hardly anybody actually understands anything about those packages.  And there's too many of them.
20:32:02 <MrsB> they don't get much in the way of QA beyond testing they update OK. It's rare that we test them any deeper.
20:32:03 <malo> Reminder: removing packages that no one uses is an acceptable solution
20:32:36 <Luigi12_work> yes at some point we should really clean out a lot of them :o)
20:32:49 <Luigi12_work> I've been meaning to make a list but havne't gotten around to it yet
20:33:46 <malo> Is there a volunteer to start a clean-up effort?
20:34:44 <doktor5000__> does clean-up involve equate to dropping the whole lot?
20:34:53 <doktor5000__> s/involve//
20:35:38 <malo> doktor5000__: nothing so extreme immediately. But we won't ship packages which do not install or do not build
20:35:44 <Luigi12_work> well first step is propose ones to drop
20:36:05 <Luigi12_work> and yes ones that we can't get to build or fix the deps will be dropped before release
20:37:41 <malo> We can review progress next week, but we should aim to 100% build for mass rebuild
20:38:12 <malo> which means fixing 400 packages by next week :-).
20:38:25 <malo> Sounds good?
20:38:38 * Luigi12_work fixed a few today
20:40:35 <malo> #action packager should monitor http://check.mageia.org/cauldron/ for breakage and build failure and fix them
20:40:36 <[mbot> [ QA global report ]
20:40:43 <malo> ennael: more on the topic?
20:41:36 <ennael> not really
20:41:57 <malo> ok.
20:42:04 <malo> #topic Anything else?
20:42:07 <neoclust> doktor5000__: for kde4 see with luc but prefer fedora packaging
20:42:26 <neoclust> doktor5000__: tell me when a plasma 5 version exist we will add it :)
20:42:30 <doktor5000__> neoclust: meeting in progress ;)
20:42:41 <anaselli> ennael: is drinking her wine :)
20:42:52 <ennael> not yet :)
20:43:56 <neoclust> ennael: you are ill ? :)
20:44:07 <malo> Ok. Let's get back to work or sleep :-)
20:44:15 <Akien> Fixing some builds now :-)
20:44:24 <malo> #endmeeting