19:46:21 <malo> #startmeeting
19:46:21 <Inigo_Montoya> Meeting started Tue Jun  3 19:46:21 2014 UTC.  The chair is malo. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:46:21 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:46:29 <malo> #chair ennael
19:46:29 <Inigo_Montoya> Current chairs: ennael malo
19:46:49 <malo> morning mageians!
19:46:54 <Akien> o/
19:48:36 <malo> welcome to the 87th mageia-dev meeting!
19:49:12 <malo> on the menu tonight:
19:49:33 <malo> - feature list finalised/finalized for publicity
19:49:54 <malo> - mageia 5 planning change?
19:50:09 <malo> - updates (notably security)
19:50:21 <malo> #topic Who's new?
19:51:00 <ennael> (only old people around :p)
19:51:19 <malo> roelof joined recently as apprentice and seems very keen :-)
19:52:12 <malo> also André joined as apprentice, but is more quiet
19:52:43 <malo> roelof is mentored by rindolf and André by juancho
19:53:04 <malo> Welcome to both of them!
19:53:24 <malo> ok, next topic.
19:53:41 <malo> #topic mga5 finalised feature list
19:54:31 <malo> As we discussed features many times, we arrived to the following picture: https://wiki.mageia.org/en/FeatureMageia5_Review
19:55:26 <malo> we need to know what to do about the pending ones and which ones we can start advertising
19:55:33 <malo> ennael?
19:56:03 <ennael> malo: let's go !yep
19:56:05 <ennael> oups
19:56:26 <ennael> shall we list the remaining one ?
19:57:29 <malo> ennael, sure
19:57:49 <ennael> ok let's go then
19:57:52 <ennael> https://wiki.mageia.org/en/Feature:3DPrinters_Installation
19:58:56 <ennael> the question was about having hardware to test it
19:59:06 <malo> we discussed just adding drivers to enable people to test
19:59:33 <anaselli> who asked, can also offer himself for testing?
20:01:07 <Akien> I think it would be nice to at least package the drivers and corresponding software yes
20:01:59 <tmb> well, as long as they are usb connected, the installer can trigger driver install if needed, but as usual "someone" needs to package the drivers
20:02:19 <Oro_Valley> There may be folks on the ML who have one and can do some testing?
20:02:19 <filipesaraiva> Maybe it can added as a "experimental" feature. Like "Mageia 5 have the drivers, test it in your 3D Printers!".
20:02:20 <tmb> s/needed/detected/
20:02:55 <ennael> filipesaraiva: looks good written like this
20:03:01 <tmb> We might actually get one at work, so I might be able to test, but no promises so far
20:04:32 <ennael> ok so we just miss somebody to do the job :)
20:05:36 <ennael> malo: so we may include this one. Will need a main on -dev to look for a packager
20:05:46 <Oro_Valley> What's the dealine for such a pacakge?
20:06:19 <ennael> ideally the latest is alpha3 release
20:06:30 <malo> #action send mail on -dev to ask for volunteer and tester for 3d printers
20:06:33 <malo> next
20:06:49 <Oro_Valley> I can try to package one.
20:06:57 <ennael> https://wiki.mageia.org/en/Feature:Encryption
20:07:37 <ennael> this was about having encryption without lvm
20:07:42 <malo> Oro_Valley, great!
20:08:26 <malo> Oro_Valley, can you send that mail to -dev asking if anyone has access to such devices?
20:08:42 <Oro_Valley> OK
20:08:57 <ennael> thanks Oro_Valley
20:10:17 <malo> For encryption, there is a testing problem for QA
20:13:54 <Oro_Valley> encryption is certainly becoming more important with computers being a travelling companion
20:14:15 <malo> Oro_Valley, true
20:14:37 <malo> and many forums posts after release were about encryption.
20:14:44 <tmb> well, for QA it's like for everuthing else... one more thing to test... but proper procedures will help
20:15:09 <ennael> but with or without lvm is it really worth to make teh difference in graphical tools ?
20:16:07 <Oro_Valley> I think it comes down to "do we have the bandwith" do implement it.
20:16:56 <Oro_Valley> What are the Suse folks doing?
20:17:23 <coling> ennael, tmb I honestly thought we did that already.
20:17:56 <ennael> coling: we do but with lvm only
20:18:05 * coling was sure it was possible without...
20:18:06 <ennael> not on classical partition
20:18:15 <ennael> me too :)
20:18:27 <coling> But I've not looked for a while.
20:18:34 <tmb> the good thing about without lvm, means one layer less that can mess up
20:19:14 <coling> Yeah, but like I say I thought I'd setup several test VMs without LVM but with encryption when doing tests in dracut a while back...
20:20:31 <ennael> using diskdrake ?
20:21:05 <coling> Yeah.
20:21:09 <coling> I just tested it.
20:21:17 <coling> It definitely is possible.
20:21:31 <coling> You literally just tick the "Entrypt Partition" box during install.
20:21:32 <ennael> then I don't know what the point of this feature
20:21:43 <coling> Yeah, that's pretty much what I said on the discussion for it.
20:23:32 <coling> Not sure anyone has responded to my discussion item, but I just checked with a DVD+VM now was we were talking and unless I'm misunderstanding something, it's right there plain as day... not even in expert mode.
20:23:43 <coling> *not even hidden by expert mode.
20:23:54 <malo> then we remove the feature as already implemented!
20:24:18 <malo> next?
20:24:42 <ennael> https://wiki.mageia.org/en/Feature:HomerunKickerAsDefaultApplicationLauncherInKDE
20:26:22 * coling has no opinion
20:26:37 <ennael> neither do I
20:27:36 <malo> we talked about giving people the chance to vote on the default
20:27:45 <ennael> wait
20:27:55 <ennael> asking KDE guy to wake up on that topic :)
20:27:59 <neoclust> :)
20:28:01 <neoclust> who ? :)
20:28:12 * ennael can wake up dead people :)
20:28:16 <Luigi12_work> nice
20:28:27 <filipesaraiva> =D
20:28:33 <neoclust> ennael: i will call you viagra
20:28:37 * neoclust hides
20:28:42 <ennael> neoclust: any opinion on that feature?
20:28:45 <ennael> before I kill you
20:28:47 <filipesaraiva> lol
20:28:52 <Luigi12_work> lol, any last words
20:29:12 <neoclust> ennael: i need to test but i don't want any menu that takes all the screen like homerun was
20:29:14 * pterjan missed the beginning of the meeting, reading back and will read the encryption thing
20:29:17 <neoclust> so i need to retest
20:29:21 * Luigi12_work agrees with neoclust
20:29:32 <filipesaraiva> neoclust, but it is not fullscreen. =)
20:29:33 * anaselli has already said his opinion :)
20:29:44 <filipesaraiva> Well, I proposed it because the default application launcher in Mageia 4 was criticed in several reviews.
20:29:52 <tmb> just buy an uhd screen
20:29:56 <neoclust> filipesaraiva: and liked in may others :)
20:30:02 <filipesaraiva> Anyone can test it in Cauldron, the package name is plasma-applet-homerun-kicker.
20:30:04 <neoclust> filipesaraiva: and liked in many others :)
20:30:09 <neoclust> filipesaraiva: i will test
20:30:10 <Luigi12_work> neoclust is right
20:30:11 <pterjan> "During the installation process, nothing is mentioned about encryption possibilities. The Mageia Installer should propose a button to allow / or/and /home installation on encrypted partitions."
20:30:38 * pterjan believes this is about having an option more visible outside the manual partitioning
20:32:40 <Oro_Valley> I would leave it in the manual partitioning. I can already hear the cry when someone cannot read his/her home anymore
20:34:25 <neoclust> filipesaraiva: before you need to fix bugs :(
20:34:32 <pterjan> we need designers to find how to present it on the main partitioning screen :)
20:34:35 <neoclust> filipesaraiva: the menu is not good here
20:34:48 <neoclust> filipesaraiva: missing icons, taking a lot of place on the panel, etc
20:35:32 <neoclust> filipesaraiva: does not respect xdg :(
20:35:43 <neoclust> filipesaraiva: so for now this is a "no-go" for me
20:36:09 * pterjan remembers adding the support for encrypting any partition and the checkbox in 2009 or 2010, ennael should remember :P
20:36:20 <filipesaraiva> Thanks neoclust, I can to try fix it.
20:36:28 <filipesaraiva> Just one more information, I think Homerun Kicker will be available with Plasma Next. See "Major changes" in Plasma Next Beta 1 announcement - http://kde.org/announcements/announce-plasma-next-beta1.php. Maybe it will replace the current Kickoff Classic style.
20:36:46 <neoclust> filipesaraiva: i will work on packaging it soonish
20:37:15 <pterjan> http://wiki.mandriva.com/en/2010.1_RC#Diskdrake_.2F_Installer
20:38:08 <ennael> malo: so for KDE menu no go for now as just buggy
20:38:39 <ennael> next one is https://wiki.mageia.org/en/Feature:New_Mageia_KDE_TopMenu
20:38:43 <malo> ok
20:38:46 <neoclust> ennael: but i will review anything filipesaraiva do, to see the improvment, maybe a task for mga6
20:39:05 <neoclust> ennael: i will be in favor of letting this this way, as we use a svg to display for now
20:39:20 <neoclust> ennael: i personnaly don't know how to implement what is asked
20:39:47 <neoclust> ennael: i would love to see us do more QA on KDE itself instead :)
20:40:04 <ennael> ok nogo then
20:40:39 <ennael> https://wiki.mageia.org/en/Feature:Optimus
20:42:12 <Oro_Valley> Uhhhh, I would be glad if the curretn Nvidia driver would work.
20:42:36 <ennael> tmb: any opinion on that one ?
20:44:11 <Akien> I had a look at nvidia-prime, I don't think it's relevant
20:44:25 <Akien> It's just a bundle of scripts for Ubuntu, we can't include it in Mageia
20:44:58 <Akien> For now we have bumblebee + primus in Cauldron (and mga4 backports_testing), and it seems to work okay.
20:45:14 <Akien> At least I'm using bumblebee on a daily basis and a few other Mageia contributors do too.
20:45:49 <Akien> We're all looking forward to a better "native" support, but for now it's better than no access to the nvidia GPU.
20:46:35 <tmb> well, you can have access to the nvidia one, just configure it and it should work
20:46:53 <Akien> I don't think it would be that straight-forward.
20:47:10 * pterjan believes that not having access to a nvidia GPU is the best /o\
20:47:15 <ennael> :)
20:47:18 <Luigi12_work> I've seen mentioned in various places that bumblebee shouldn't be needed anymore
20:47:19 <Akien> At least the configuring step is more complicated than just using XFdrake.
20:47:28 * Luigi12_work agrees with pterjan, haha :D
20:48:14 <tmb> as for what to do... updstream dri3 and dma-buf should work in xorg 1.16 + intel 3.0 driver, but I dont know nVidia intentions around it yet
20:49:23 <ennael> so at least this feature about prime is not to be included
20:49:24 <tmb> as for any change... who will code it and in a way so we dont force it on everyone if they dont want it ?
20:50:13 <Akien> ennael: Nvidia Prime can't be included as such, but we might develop our own tool if there was an interest in it.
20:50:31 <Akien> Now, I'm not even sure that it would be a nice feature.
20:51:06 <Akien> From what I've read, Prime is kind of a bundle of dirty scripts to change from Intel chipset to Nvidia GPU and vice versa
20:51:19 <Akien> But you can't use it on the run, you have to reboot each time you want to switch
20:52:19 <Akien> So in the end, even though bumblebee is not that great either and scarcely maintainted, I find it personnally a good enough alternative until switching between intel and nvidia can be done on the run by xorg/others
20:52:41 <Akien> (I might be wrong though, it's just my experience)
20:53:02 <Akien> s/maintainted/maintained/
20:53:21 <ennael> "dirty" is a good reason to not include it then
20:54:05 <Akien> Well "dirty" is just my opinion, I just say that because it's a bunch of bash scripts that would work only on a Ubuntu-based system
20:54:22 <ennael> I've also seen such review
20:55:01 <Akien> For Mageia 5 I would propose that some experienced packagers have a look at improving the current state of my bumblebee package (it works just fine, but there is always room for improvement)
20:55:04 <ennael> optimus killed them all
20:55:21 <tmb> well, anything can be adapted, but it also needs "someone" todo the work :/
20:56:00 <Oro_Valley> tmb:well said
20:56:11 <ennael> ok so nogo for now
20:56:15 <ennael> speak now or never :)
20:56:25 <Oro_Valley> no go for me
20:56:48 <Akien> No go for Nvidia Prime, but not no go for Optimus support
20:57:12 <Akien> Since Optimus laptops run fine (currently) on Cauldron with bumblebee
20:57:28 * anaselli has Optimus in his notebook at office
20:58:39 <tmb> I have an optimus laptop here too, but I prefer to use open source intel drivers
20:59:10 <Akien> tmb: Just for the record, I packaged bumblebee in a way that makes it work with the nouveau drivers too
20:59:19 <anaselli> tmb: i have an external monitor and it's a mess without nvidia drivers in mga4
20:59:23 <Akien> (depending on whether one installs bumblebee-nouveau or bumblebee-nvidia)
20:59:54 <Akien> SuperTuxKart in high res runs just fine with the nouveau drivers :-)
20:59:54 <anaselli> desktop is managed as a big monitor instead of two
21:00:23 <tmb> yeah, but I wonder if nouveau is any faster than intel... (I havent tested)
21:00:38 <Akien> It is, definitely. Nouveau is quite good nowadays I find.
21:01:00 <anaselli> Akien: but if you have two monitors and optimus
21:01:36 <anaselli> one is set for intel and the second is nouveau
21:02:10 <anaselli> then i had to switch to nvidia to manage them as separate video
21:02:27 <Akien> Only if you configured it that way in xorg.conf/XFdrake I think, not with bumblebee (where you configure only the intel driver for normal usage)
21:02:37 <Akien> But we're drifting away from the topic :)
21:02:53 <anaselli> Akien: bumblebee is not in 4 (yet)
21:02:54 <ennael> ok so next one
21:03:04 <ennael> https://wiki.mageia.org/en/Feature:UseDEnativeAppletPrinter
21:03:07 <Akien> anaselli: You can find it in backports_testing for now
21:03:20 <anaselli> Akien: i know that :)
21:03:27 <anaselli> thanks
21:03:27 <ennael> neoclust: still around?
21:09:55 <anaselli> maybe neoclust is hidden :D
21:10:15 <tmb> I guess this falls into the same debate as all other "do we use DE specific or generic/mga tools" debate
21:10:40 <ennael> so let see that one and the next one during the meeting about drakx*
21:11:00 <ennael> last one is https://wiki.mageia.org/en/Feature:Add_a_step_in_order_to_choose_computer%27s_name_(installation)
21:11:01 <filipesaraiva> it is true tmb
21:12:21 <tmb> the computer naming already exists, but is hidden under network configuration... I think the proposed change would be good
21:12:30 <filipesaraiva> It would be interesting. Everyone loves to give a name to their computers. =)
21:13:26 <ennael> if everyone agree then let's go for it
21:13:28 <coling> That one seems reasonable. It's really just a matter of writing to /etc/machine-info and /etc/hostname (or ideally just using hostnamed's dbus interface which depending on installer reworks that might or might not be available.
21:13:57 <anaselli> coling: also /etc/sysconfig/network iirc
21:13:59 <coling> I notice that /etc/machine-info is not referenced tho'.
21:14:21 <anaselli> yep HOSTNAME
21:14:24 <coling> anaselli, yeah that one too possibly, but perhaps that one will get deprecated.
21:14:36 <Luigi12_work> you mean /etc/machine-id ?
21:14:42 <coling> (we should really try and rip out old stuff)
21:14:44 <coling> Luigi12_work, nope
21:14:48 <coling> see "man machine-info"
21:14:49 <anaselli> but now if you don't set it it does not work ;)
21:14:55 <coling> Luigi12_work, machine-id is a GUID
21:15:21 <coling> anaselli, yeah... will see when I update initscripts to upstream I guess....
21:15:23 <Luigi12_work> unlike the silly hostid command
21:16:14 <coling> Ugg I never even heard of that... is it needed?
21:16:41 <Luigi12_work> hostid is an old carryover from UNIX
21:16:49 <coling> Ahh well.
21:17:16 <coling> Anyway, the "pretty" hostname is needed for some higher level things (i.e. names that are not valid for lower level hostnames.
21:17:33 <coling> And this pretty hostname is set in /etc/machine-info I belived and hostname is the sanitised version of it.
21:17:39 <Luigi12_work> it's actually unique on Solaris/SPARC, and somewhat on Solaris/Intel.  On Linux hostid is just the IP address in hex (octets are in a different order) so it's useless.
21:17:48 <coling> So "Colin's Computer" might become colinscomputer
21:18:05 <Luigi12_work> yeah that's neat
21:18:41 <ankh> Luigi12_work, although note it's possible to make gethostid() return an arbitrary value :)
21:20:07 <Luigi12_work> which makes it even more useless :D
21:20:20 <coling> I've updated the feature page with a couple more notes.
21:20:25 <ennael> ok so these are implementation "details" :)
21:20:29 <ennael> at least for tonight
21:20:35 <ennael> so feature ok?
21:20:40 <coling> Yup, in principel tho' it's fine/sensible
21:20:43 <coling> *principle
21:21:21 <tmb> yep
21:21:36 <ennael> ok phew :)
21:21:53 <ennael> so that topic is done unles you have somehting to add
21:23:44 <malo> \o/
21:23:49 <tmb> next...
21:24:15 <malo> #topic mga5 planning change
21:24:28 <malo> ennael reports from council ...
21:24:53 <ennael> https://wiki.mageia.org/en/Mageia_5_Development
21:24:56 <ennael> as a reminder
21:25:09 <malo> alpha 1 is today!
21:25:10 <ennael> today was the day for alpha1...
21:25:13 <ennael> bingo
21:25:19 <ennael> where is it ?
21:25:32 <tmb> rip
21:25:37 <Luigi12_work> sleeping
21:25:39 <ennael> :)
21:25:40 * coling should probably upgrade to cauldron at some point....
21:25:48 <coling> (and all his packages etc. etc.)
21:25:59 <malo> coling, same here :-P
21:26:01 <ennael> ok so the point here is to redefine a realistic planning
21:26:27 <philippem> but you have to wait the Perl rebuild and some Python3.4 depencies too
21:27:00 <coling> Yeah I noticed that :)
21:27:15 <tmb> How about simply dropping alpha1 and only release 2 alphas ?
21:28:02 * coling would agree with that... I think until 4.1 is out that no-one is really going to have much motivation to test alpha1 anyway.
21:28:19 <philippem> yes
21:28:26 <ennael> so in 1 month
21:29:10 <Oro_Valley> OK
21:29:41 <anaselli> ennael: i think we should aslo fix backports in time for 4.1
21:29:44 * anaselli hides
21:30:16 <Luigi12_work> hopefully when we do an alpha, Cauldron will installable and the http://check.mageia.org/cauldron/dependencies.html page will be empty or close to empty
21:30:17 <[mbot> [ dependencies global report ]
21:30:33 <ennael> ok so all agree to keep same planning but start with alpha2 ?
21:30:36 <filipesaraiva> I agree with tmb
21:31:17 * tmb agrees with tmb
21:31:42 <ennael> malo: ?
21:31:49 <filipesaraiva> 6 mounths until final release, I think it is a good time to a stable release.
21:32:50 <tmb> and if it slip we get a fosdem release :)
21:33:01 <ennael> tmb: you bet !
21:33:33 * coling slaps both of you for event thinking of that again
21:34:13 * tmb got fosdem on his brain... no way to escape...
21:34:20 <ennael> :))
21:34:39 <ennael> ok for the planning then
21:34:47 <ennael> anything else on that topic ?
21:34:55 <tmb> nope
21:35:04 <grenoya> coling: didn't you appreciate drinking to the release? :)
21:35:04 * anaselli can see only sheeps atm
21:35:13 <ennael> (we should try to buy a fosdem free brain for tmb)
21:35:30 <tmb> anaselli, get a sheepdog
21:35:34 <ennael> let's go for it then
21:35:39 <ennael> Luigi12_work: around ?
21:35:46 <malo> ennael, ok for me
21:35:53 <anaselli> tmb: sooner or later... :D
21:36:00 * malo is working a bit at the same time
21:36:16 <Luigi12_work> yep
21:36:18 <malo> #topic updates
21:36:27 <ennael> Luigi12_work: your turn then :)
21:37:52 <Luigi12_work> so I've posted an updated summary at https://ml.mageia.org/l/arc/dev/2014-06/msg00026.html
21:37:53 <[mbot> [ dev - Developement discussion list - arc_protect ]
21:38:22 <Luigi12_work> basically there are several updates I need help with or feedback on, so please help where you can
21:38:51 <anaselli> sorry i can't go on, I'm falling asleep
21:38:54 <tmb> and help QA validate them
21:38:55 <anaselli> see you
21:39:02 <Luigi12_work> some packagers specifically implicated in the list are spturtle/cjw, pterjan, tv, joequant, anssi, coincoin/dams, bcornec
21:39:19 <Luigi12_work> if anyone ever has any questions about any of this, don't hesistate to ask :o)
21:39:58 <coling> anaselli, make sure to let your sheep go first...
21:40:05 <ennael> :)
21:40:08 <anaselli> :D
21:40:13 <ennael> maybe his name is shuan
21:40:15 <ennael> shaun
21:40:18 <coling> :)
21:40:19 <anaselli> which one?
21:40:42 <anaselli> and shaun is :D
21:40:45 <coling> Luigi12_work, I'll try and take a quick look over tomorrow when I'm awake
21:40:46 <anaselli> good night
21:40:54 <coling> See if there are any I can help with.
21:41:00 <ennael> Luigi12_work: thanks for the review, we will try to ping these guys
21:41:48 <coling> I can probably do the wordpress one.
21:44:05 <malo> great
21:44:09 <malo> anything else?
21:44:15 * tmb will try to look at some too
21:44:35 * ennael will ping bruno
21:44:36 <malo> thanks
21:44:43 <malo> #topic anything else?
21:45:21 <ennael> shheps !
21:45:24 <ennael> sheeps
21:45:55 <tmb> nothing for me
21:46:06 <ennael> ok for me
21:46:17 <Oro_Valley> OK for me
21:46:33 <filipesaraiva> I will try to fix the bugs with homerun kicker.
21:47:46 <ennael> ok let's end meeting then
21:47:53 <ennael> thanks guys for coming tonight
21:48:00 <ennael> good sheeps
21:48:05 <ennael> #endmeeting