19:07:29 <malo> #startmeeting
19:07:29 <Inigo_Montoya> Meeting started Tue Oct 15 19:07:29 2013 UTC.  The chair is malo. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:07:29 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:07:39 <malo> #chair ennael philippem
19:07:39 <Inigo_Montoya> Current chairs: ennael malo philippem
19:07:53 <malo> Welcome all to this freezing meeting!
19:08:02 <Luigi12> it is chilly
19:08:30 <malo> A few things on the agenda today ...
19:09:10 <malo> But before we start, QA has lots of pending updates, so please help them.
19:09:29 <MrsB> yes please do
19:09:37 <MrsB> actually there are big kernel updates atm
19:09:38 <malo> Talk to MrsB and DavidWHodgins on #mageia-qa
19:09:48 <MrsB> they would benefit from being tested on a wide range of hardware
19:10:02 <malo> #action please help QA with the big kernel updates
19:10:12 <MrsB> if you can do, please do test on mga2 and 3. Also glibc at the same time
19:10:45 <MrsB> http://mageia.madb.org/tools/updates
19:10:47 <[mbot> [ Mageia App Db - Current Update candidates ]
19:11:34 <malo> Yes, the different hardware are especially important
19:11:50 <malo> ah we talked about the kernel and the devil arrived :-)
19:11:56 <malo> tmb: welcome
19:12:12 * tmb tries to hide
19:12:14 <MrsB> It's a version jump too so there could possibly be breakage, we need as many to test as possible
19:12:19 <MrsB> morning tmb
19:12:31 <tmb> Morning.
19:12:47 <AL13N> tmb: btw: there's also some binutils breakage (ar) in mga4
19:13:04 <tmb> AL13N: BR ?
19:13:09 <coling> FWIW, my main concern with the kernel version jump in mga3 is the intel graphics issues on some more modern hardware/laptops
19:13:18 <malo> MrsB: thanks. I hope packagers will flock to QA.
19:13:27 <MrsB> thank you malo :)
19:13:34 <MrsB> (and all who test!)
19:13:50 <AL13N> tmb: "ar file.a file.o file.o" doesn't work anymore, it must now be "ar -r file.a file.o file.o" i think
19:14:02 <malo> AL13N: can it wait?
19:14:08 <tmb> coling: otoh there is not many cc'd on that br, do you have any more references
19:14:38 <malo> Ok. Let's move on. I don't want to make it a 3h meeting.
19:14:40 <MrsB> people with intel/nvidia seemed to suffer with alpha3
19:14:49 <coling> tmb not really, I'm probably clouded because it affects my laptop ;)
19:15:14 <malo> #topic Freeze!
19:15:51 <malo> As you all know, the freeze is today.
19:16:01 <malo> Let me remind what it means.
19:16:23 <malo> First, packagers are not allowed to submit packages with new versions.
19:16:57 <malo> Second, new rel (fixing bugs) are allowed (and even encouraged)
19:17:37 <malo> Third, new packages are allowed (but it'd be great if they don't bring additional breakage, please!)
19:17:52 <malo> Everyone ok?
19:18:11 <AL13N> maybe in the future we should also exclude new packages at version freeze
19:18:12 <malo> Especially our new packagers who might have never experienced a freeze
19:18:14 <grenoya> yes
19:18:18 <coling> malo, http://imgflip.com/i/47adm
19:18:30 <coling> Easy answer ;)
19:19:17 <ovitters> malo: a while back I got an ok to still being able to submit new versions (for GNOME 3.10.x uploads), will that happen?
19:19:34 * coling hopes so
19:19:37 <ovitters> I'll stop my bot, just "manual"
19:19:57 <malo> ovitters: thanks
19:20:28 <grenoya> malo: Scilab will be late, but il doesn't rebuild now, so I hope I will be allowed to push the update :)
19:20:47 <malo> Any exception for the freeze must be asked on -dev
19:21:02 <Oro_Valley> as last time
19:21:33 <malo> as last time. But this time, we want to be a bit more stringent, because we cannot delay the release.
19:22:11 <Oro_Valley> what are we going to do with suhosin, it's affecting a lot of packages
19:22:13 <malo> So the default answer will be coling 's cat: http://imgflip.com/i/47adm
19:22:16 <Luigi12> freeze pushes didn't delay the last release malo
19:22:33 <Oro_Valley> +1
19:22:40 <Luigi12> we don't need to be more "stringent" as long as people follow the reasons for pushes, just bug fixes, test as much as you can before asking, etc
19:23:20 <malo> Luigi12: sure. But we need to emphasise the bugfix only aspect.
19:23:40 <malo> We should all work on stability from now on.
19:23:50 <Oro_Valley> lunch is ready, see u in about 45 min
19:24:10 <coling> [as a side note, I have loose plans related to package VCS on how to make the whole "freeze push" thing more defined - i.e. a nice web UI rather than a mailing list queue)
19:24:35 <malo> coling: mga5? :-)
19:24:46 <coling> Yeah
19:24:57 <Luigi12> coling: it'd be nice if it could allow a build on the build system w/no upload, so you can at least double-check verify that it builds before asking for a push
19:25:05 <ovitters> malo: you really think me asking 400 times for freeze exceptions is fun for me?
19:25:05 <coling> I won't go into details now as it's vapourware until it happens.
19:25:19 <Luigi12> you can cheat now and use updates_testing for that, but then it needs cleaned later
19:25:38 <coling> ovitters, I think you should be fine, I think the "ask as before" was for other, individual pushes.
19:25:41 <ovitters> hmm, only 1 GNOME release left, maybe more like 150
19:25:53 <Luigi12> indeed, there should be an exception for bugfix releases of core GNOME/KDE packages
19:26:15 <coling> ovitters, so I wouldn't worry too much :)
19:26:26 <tmb> to a point yes, but even that will have to stop at some time
19:26:28 <malo> Of course there will be arrangements for things that have been agreed
19:26:34 * coling nods
19:27:38 <tmb> the point is this time around the RC _must_ be a real RC, not a gazillion changes after ... so betas need to be in better shape too...
19:27:59 <malo> tmb: yes
19:28:22 <malo> I think that any request  after beta 2 will be probably rejected
19:28:46 <ovitters> when is that?
19:28:53 <Luigi12> geez
19:29:00 <malo> Beta 2 is planned for 2013/11/28
19:29:37 <Luigi12> we don't need to be so crazy about it, I can't think of a freeze-pushed package that caused problems post-Mageia 3 release
19:30:12 <leuhmanu> we don't have a beta3 ?
19:30:18 <Luigi12> the point of this point of the development cycle is to fix bugs.  Upstream developers can contribute to this cause too.
19:30:32 <tmb> we dont need to be obsessed about new versions either, as there will always be a new version ....
19:30:38 <Luigi12> schedule is beta 2 2013/11/28 and RC 2013/12/17
19:30:42 <AL13N> the sooner we get ready, the sooner cauldron reopens and people can go wild again
19:30:50 <malo> There is no Beta 3
19:30:53 <Luigi12> tmb: there's a difference between feature releases and bugfix releases, it's good to fix bugs
19:31:00 <Luigi12> https://wiki.mageia.org/en/Mageia_4_Development is the schedule
19:31:19 <tmb> and upstream fixing bugs is one thing, but makeing sure they dont introduce any regressions is another...
19:33:02 <Luigi12> the dead horse is attracting flies, anything else on this topic malo?
19:33:14 <coling> Anyway, most of us have been here before: some people will be annoyed, some will like it, there will be blame and then we'll release and everyone will forget it and move on :)
19:33:30 <ovitters> I wish for less time between rc and final
19:33:51 <malo> Please all consider that we are all in there together, so any reasonable request will be granted and unreasonable ones will not :-)
19:33:52 <Luigi12> ovitters: 5 weeks sounds like a lot, but it'll go by fast, it usually does
19:34:02 <coling> ovitters, yeah me too, but if everything is ready before final, then maybe we'll release earlier #itcouldhappen
19:34:06 <Luigi12> it's a matter of how quickly we can get the release blockers fixed
19:34:22 <AL13N> ovitters: the problem is the holidays
19:34:23 <ovitters> what is a release blocker btw?
19:34:31 <malo> Everyone ok? Let's move on.
19:34:31 <ovitters> e.g. any Desktop Environment?
19:34:34 <coling> And yeah, the holidays get in the way.
19:34:35 <Luigi12> ovitters: something that can't be fixed after release
19:34:48 <doktor5000__> coling: remote mounts and systemd, seems systemd can't get the ordering correct, or i'm missing something in the picture
19:34:48 <ovitters> ah ok
19:34:55 <doktor5000__> coling: can you please comment on https://forums.mageia.org/en/viewtopic.php?f=8&t=6219
19:34:56 <[mbot> [ Mageia forum View topic - mageia3 fstab nfs not mounted at boot time ]
19:35:05 <coling> doktor5000__, one for after the meeting.
19:35:09 <malo> Ok next topic ...
19:35:17 * doktor5000__ is sorry and silent now
19:35:33 <malo> Oh, before moving on ...
19:35:47 <malo> tmb: do you have the finger on the freeze gun?
19:36:17 <Luigi12> looks like mitya and dmorgan are getting some last ones in now
19:36:19 <ovitters> GNOME 3.10.1 is still being released/tarballed btw
19:36:39 <malo> Ok. tmb will do that later.
19:36:51 <Luigi12> ovitters: they gonna finish today/tonight I hope?
19:36:53 <malo> #topic Mass rebuild
19:37:02 <malo> pterjan: you're right on time :-)
19:37:18 <tmb> yep, I guess in a couple of hours I'll commit the freeze change
19:37:20 <ovitters> Luigi12: deadline was yesterday :P  conference last weekend plus some are often late
19:37:22 <ennael> hi back
19:37:43 <pterjan> not much to say
19:38:08 <Luigi12> pterjan: could you the -O argument to %make (I guess it's in rpm-mageia-setup) before the mass rebuild?
19:38:10 * pterjan will commit new rpm-mageia-setup-build with the updated pythonegg stuff before
19:38:23 <pterjan> Luigi12: probably :)
19:38:39 <Luigi12> pterjan: it'll make rebuild errors easier to read so we can help fix them :o)
19:39:19 * Luigi12 hopes everyone will chip in to help fix build errors
19:39:32 * coling will try his best.
19:39:46 * ovitters loves task-obsolete
19:39:51 <Luigi12> :o)
19:40:17 * mitya preparing to push QGIS 2.0.1
19:40:38 <tmb> yeah, lets put anything but basesytem in task-obsolete and be done with it :)
19:40:46 <coling> :D
19:40:50 <mitya> hope the trigger hasn't been pulled yet
19:40:58 <Luigi12> wow, then what would we do?  Go outside?
19:41:16 <tmb> hmmm fresh air... whats that...
19:41:19 <coling> Have "conversations" with "people"? I feel slightly ill...
19:41:24 <coling> :p
19:41:25 * Luigi12 opens a window to find out
19:42:12 <AL13N> too cold
19:42:21 * MrsB wafts
19:42:44 <malo> ok guys :-)
19:42:50 <malo> and girls
19:42:54 <Luigi12> while we're on the topic of updating packages, I hope all the packagers kept up with the -dev ml and saw my messages about packages missed by youri-check.  I know some saw it; glad it helped.
19:43:02 <Luigi12> back to you malo
19:43:10 <malo> Luigi12: thanks.
19:43:51 <ovitters> Luigi12: would be cool to eventually merge this into Mageia infra
19:43:56 <malo> So for the mass rebuild, please already have a look at pterjan's autobuild results: http://pkgsubmit.mageia.org/autobuild/
19:44:34 <malo> Many of the failures there will come again during the mass rebuild, so you can all start fixing what can be fixed.
19:44:56 <Luigi12> ovitters: yep.  I just need to implement a --help and download functionality into my tool.
19:44:56 * pterjan will try to get rpm-mageia-setup in tonight to avoid having to request the first freeze push :P
19:45:02 <Luigi12> yep, the autobuild page is really helpful
19:45:24 <malo> So the question is: what do we do when a package does not build, and won't build?
19:45:30 <malo> option 1: drop it
19:45:43 <malo> option 2: keep it only if it still works
19:46:07 <coling> Default to 1, but will ultimately have to be dealt with on a case-by-case basis.
19:46:15 <coling> (IMO)
19:46:43 <malo> Everyone ok with that?
19:46:45 <Luigi12> yeah, if it's build problems are absolutely not fixable, we can't do any future security updates or bugfix updates for it, so we should drop it if at all possible
19:46:46 <ovitters> haha, gnome-panel doesn't build
19:46:55 <malo> for mga3, we kept a few.
19:47:01 <tmb> yep. option 1 is the way to go... (option 2 tends to get a mess for security / QA )
19:47:02 <malo> like celtx
19:47:35 <Luigi12> at some point we need to start cleaning out broken/unmaintained packages nobody really cares about
19:47:51 <malo> Ok we should go with option 1 then. Thanks
19:47:53 <pterjan> I think packages we don't want to drop that don't build should be release blockers
19:48:11 <tmb> yep
19:48:11 <malo> #action Mass Rebuild will start in a couple of days
19:48:28 <coling> yup
19:48:43 <malo> #action any package which does not build will be dropped
19:48:47 <Luigi12> ooh speaking of mass rebuild, before the last one boklm published a list of packages with uncommitted changes, so we could check them before the rebuild push
19:48:55 <Luigi12> can we do that again?
19:49:00 <malo> Luigi12: ah, good idea.
19:49:46 <coling> Nice idea yeah.
19:50:12 <pitahaya> hmm can I ask on a question for fixing bug ? To fix bugs for a implies to be maintainer for it ? Or not ?
19:50:31 <AL13N> no
19:50:32 <ovitters> /bin/sh: line 7: 63168 Segmentation fault      ../gdk-pixbuf/gdk-pixbuf-query-loaders $LOADERS > ./loaders.cache
19:50:34 <pitahaya> okay
19:50:35 <AL13N> anyone can fix bugs
19:50:35 <Luigi12> pitahaya: anyone can fix bugs.  If a package has a maintainer, you can check with them before submitted to the build system.
19:50:54 <pitahaya> ok thank you very much AL13N and Luigi12 :)
19:53:00 <ovitters> pitahaya: for anything GNOME, if you're sure, just submit
19:53:29 <pitahaya> ok ovitters :)
19:54:27 <pitahaya> my ambitions are more modest ;)
19:54:38 <malo> Great
19:54:43 <coling> ovitters, ping me after meeting if you want to debug the pixbuf issue.
19:55:03 <coling> s/to debug/help debugging/
19:55:11 <AL13N> coling: don't run away, we need you for the next topic
19:55:14 <AL13N> :-)
19:55:18 <ovitters> coling: http://pkgsubmit.mageia.org/autobuild/cauldron/x86_64/core/2013-10-13/gdk-pixbuf2.0-lsb-2.26.4-2.mga4.src.rpm/ lsb thing .. urgh urgh
19:55:18 <malo> #action boklm is going to list the unsubmitted things that are in svn
19:55:18 <[mbot> [ Index of /autobuild/cauldron/x86_64/core/2013-10-13/gdk-pixbuf2.0-lsb-2.26.4-2.mga4.src.rpm ]
19:55:23 * coling is not going anywhere
19:56:13 <malo> ennael, philippem: more on mass rebuild?
19:56:24 <ennael> not for me
19:56:29 <philippem> not for me
19:56:32 <malo> ok
19:56:41 <malo> #topic Feature review
19:57:01 <coling> Straight off, I'll likely drop systemd-in-initrd.
19:57:07 <coling> For now at least.
19:57:22 <coling> Tests show it'll need a bit more work and I've not really got the time/patience to fight this one right now
19:57:31 <malo> I don't know if people remember, but there was this idea that if a feature is not in Beta 1, then it's dropped.
19:57:35 <coling> For mga5 it'll be better supported upstream
19:57:42 <malo> coling: ok.
20:00:20 <malo> Ok. Someone needs to get hold of djennings
20:01:21 <malo> if we want to do that checkbox
20:01:24 <malo> feature
20:01:38 * malo reminds people to look at: https://wiki.mageia.org/en/FeatureMageia4_Review
20:02:03 <malo> coling: can you update the status of your features?
20:02:06 <AL13N> well, atm, about the checkbox feature, the first screen is too complicated, so if we cannot get to him, we will have to drop it
20:02:53 <coling> malo, most are fine... lemme think....
20:03:15 <coling> malo, so most are general tidyups that are ongoing.
20:03:33 <coling> But most of my time was sucked into the polkit changes - tho' I'm happy with the results generally (much better integrated)
20:03:59 <malo> coling: ok. thanks.
20:04:09 <coling> I'd still like to fix up /bin + /sbin + /lib* paths in packages before the mass rebuild, but not sure I'll have time.
20:04:22 <AL13N> what are we gonna do about the network device name change one?
20:04:26 <coling> (I might be able to make a mass change tho' so we'll see)
20:04:27 <tmb> the problematic one is still the interface naming mess
20:04:28 <malo> coling: mass rebuild is planned for tomorrow :-)
20:04:38 <malo> tmb, AL13N: yes
20:04:41 <coling> malo, then I'll miss that.
20:04:43 <coling> tmb, yeah
20:04:56 <coling> tmb, AFAIK, the main problem is just the installer getting the wrong name right?
20:05:13 <coling> tmb, or have I missed some other fallout?
20:05:15 <tmb> we need to figure out how to get kernel/installer on the same page
20:05:52 <tmb> coling: yeah that's about it...
20:05:54 <coling> Yeah, so i was going to take a look at a new stage1, but not had time. I believe neoclust and tmb are interested in this too.
20:06:33 <malo> it needs to be sorted out for beta 1 ...
20:06:34 <tmb> we should try to sort stage1 out for beta1
20:06:35 <coling> So if we pool resources a bit we could probably knock something out there fairly quickly.... I should have some time this weekend to look at it.
20:07:21 <coling> What's the b1 date again?
20:07:36 <malo> coling: end of the month
20:08:01 <coling> Hmm, OK. I won't be around much next week sadly (LinuxCon)
20:08:21 <coling> Which also means I only have Saturday for Stage1 now I think about it... (Sunday is earmarked)
20:08:24 <MrsB> bear in mind that first builds of isos start about a week before release
20:08:30 <malo> coling: basically it's two week-ends
20:08:49 <malo> coling: who can help you?
20:08:53 <coling> Sadly I'll be away the weekend after Linuxcon showing some geeks the highandls.
20:08:55 <tmb> well, lets try tro get it started anyway
20:09:09 <coling> malo, well tmb can certainly do it, but I'd feel guilty if he did it all :D
20:09:50 <coling> I've not poked around too much with the stage1 code, so I'm struggling to coment more, but I know it "should" all glue togeter OK with a dracut based initramfs...
20:10:17 * coling also still has to write some i18n git scripts too :s
20:11:38 <ennael> just a quick word about syslinux
20:11:55 <ennael> it's not in features but it has just been updated to 6.02
20:12:30 <ennael> this will break some things around like theme and some things in bcd and drakx-installer*
20:12:56 <ennael> still it was needed as we were stuck with an old version and some old and ugly patches from mdv
20:13:15 <pterjan> like: drakx-installer-images	libcom32.c32 not found
20:13:29 <ennael> yes some side effects to be fixed in coming days
20:13:38 <coling> pterjan, I think that's just a missing exception to the requires tho'...
20:13:49 <coling> (IIRC tv added a few - but not looked properly)
20:13:59 <ennael> erwan_taf is working on it and I will also in coming days
20:14:37 <coling> Hmm, maybe not actually.
20:14:46 * coling thought he'd seen such commits fly past
20:14:54 <coling> ennael, Nice work :)
20:15:17 <malo> ennael: nice
20:15:49 <AL13N> so, are we gonna go ahead with the device name change or not? will there be other issues? alphas are likely less tested than betas
20:17:20 <coling> IMO the mess with it, is still better (and fixable in other ways even if we don't get a new stage1) than the mess without it.
20:18:01 * Luigi12 agrees with coling
20:19:36 <coling> tmb, what's your take?
20:20:22 <tmb> atleast for now, yes. but I think we need something working for beta1
20:20:47 <AL13N> if it doesn't work with beta1, we may need to revert anyway, imho
20:21:28 <coling> Well lets see how we get on with stage1 then.
20:22:28 <tmb> yes, lest start with that and see where we end up, and do a new status check when beta1 is out
20:22:39 <malo> coling, tmb: ok. We'll have have fun next meeting :-)
20:22:44 <DavidWHodgins> Keep in mind that the installer has to work for upgrades too.
20:22:52 <tmb> yes
20:23:32 <tmb> as pointed out the plan is upgrades dont change, only new installs
20:23:33 <malo> So besides network interfaces and desktop chooser, everything fine or dropped?
20:24:05 <coling> DavidWHodgins, technically the install-used-for-ugrades could have easily had different device names anyway due to those flakey generators...
20:24:29 <coling> DavidWHodgins, e.g. eth0 could have been eth1 on the installed system being upgraded.
20:24:37 <ovitters> malo: I see a lot of 0% features
20:24:53 <Luigi12> ovitters: most people forget to update those
20:26:50 <ovitters> rpmlint, new mgarepo
20:26:57 <ovitters> both seem interesting
20:27:05 <coling> new mgarepo is an infra thing anyway
20:27:17 <coling> I think it'll happen but probably not till after mga4
20:27:34 <coling> (package is obviously needed too, but the bulk of the work is in infra.
20:28:04 <coling> Hopefully it can be deployed a month or so after mga4 release (likely leave things as is for the sec updates that come post-release)
20:28:17 <coling> Time will tell tho'.
20:28:25 <ovitters> when should features be final?
20:28:47 <coling> Well pretty much now ish ;)
20:30:13 <AL13N> malo: also, i should note that since we're at version freeze, diskdrakerefresh is not coming along... so we'll need to postpone for mga5
20:30:19 <coling> but some "features" are really not code drops and are just incremental.
20:30:54 <ovitters> so who will rechedule features and/or urge speedup?
20:31:06 <malo> AL13N: I assumed so :-)
20:31:31 <AL13N> ovitters: we already urged... if they aren't finished now, we should drop them (unless they are ongoing or infra)
20:31:35 <malo> ovitters: features not in by Beta 1 are dropped
20:32:12 <AL13N> however, the DE checkbox thing, if we cannot contact djennings, we will need to drop this one too
20:32:15 <neoclust> malo: no :) postponed for mga5 no ? :)
20:32:33 <malo> neoclust: right :-)
20:33:10 <ovitters> malo: good :)  I want mga4 to be out quickly
20:33:15 <malo> Anything else on features?
20:33:38 <malo> ovitters: we want mga4 done quickly and stable soon :-)
20:33:50 <malo> ennael, philippem?
20:33:52 <neoclust> s/stable/perfect/
20:33:53 <neoclust> :)
20:34:05 <AL13N> malo: the only other real question mark is the MTP one
20:34:32 <neoclust> coincoin: ^^
20:34:42 <ovitters> time based is IMO great, get stuff done by X date, else too bad.. then people will stick to deadlines next time
20:34:49 <ennael> I've already asked several times for mtp
20:34:53 <ovitters> combined with real blockers
20:34:56 <ennael> no answer really
20:35:16 <neoclust> ovitters: yes seems the saner approach
20:35:39 <malo> AL13N: can you email -dev about mtp and desktop chooser?
20:36:16 <Luigi12> yeah what happened to djennings?
20:37:38 <AL13N> ok
20:38:14 <AL13N> pending no response it'll be dropped/postphoned for mga5
20:38:31 <AL13N> 2 weeks to reply should be sufficient
20:40:18 <AL13N> malo: i might need to go soon, is this the end of the meeting?
20:41:15 <malo> AL13N: thanks.
20:41:31 <malo> #topic Anything else>
20:41:35 <malo> ?
20:41:45 <malo> coling: you had an item?
20:42:01 <Oro_Valley> as I asked before, what's the satus of suhosin?
20:42:20 <coling> malo, it seems like it's happening and maintainers are supporting it anyway.
20:42:30 <malo> coling: ok :-)
20:42:34 <coling> malo, basically we'll kill off polkit-gnome
20:42:44 <coling> Gnome itself no longer uses it, but xfce did
20:42:52 <malo> Oro_Valley: what is that?
20:42:57 <coling> it'll be replaced by mate-polkit
20:43:16 <coling> As this is the same code but developed a bit more.
20:43:25 <malo> coling: ok.
20:43:35 <coling> This will be used in windowmaker and xfce for certain.
20:43:43 <Oro_Valley> it's not usable but required by a lot of php and pear packages.
20:43:48 <coling> And maybe in lxde too if no one objects.
20:43:58 <malo> Oro_Valley: then it needs to be fixed
20:43:59 <neoclust> Oro_Valley: see with oden
20:44:09 <Oro_Valley> the problem is the missing logo in php and upstream is very... slow infixing
20:44:46 <ovitters> the Cinnamon thing on dev is now a Fedora release blocker bug :P
20:44:55 <coling> ovitters, :)
20:45:43 <malo> ovitters: yes, let's block the competition to get mga4 out :-)
20:46:09 <coling> ovitters, hopefully they'll find a nice solution... I still thing there lacks a nice proper way to have alternative providers of dbus services based on the desktop used.... i guess systemd-based user sessions might make this nicer.
20:46:15 <coling> *think
20:46:26 <malo> coling: mga5?
20:46:50 <coling> malo, certainly not for mga4 ;) Maybe for mga5 - timescales seems about right for mass adoption.
20:47:30 <ovitters> coling: that was MATE, this is different
20:48:07 <tmb> coling: what... we are not at freeze  yet... cant you "wing it" :)
20:48:08 <ovitters> coling: basically: Cinnamon puts ShowOnlyIn=GNOME; in their xdg/autostart files, they don't want to register "Cinnamon" + rely on that
20:48:10 <coling> Oh yeah ;)
20:48:51 <ovitters> coling: apparently GNOME starts Cinnamon because it has GNOME in there.. who would've thought! :P
20:49:28 <coling> ovitters, yeah I see the problem - pretty basic issue really.
20:50:14 <ovitters> coling: https://bugzilla.redhat.com/show_bug.cgi?id=1019405#c5 is a fun read
20:50:16 <coling> I actually wonder whether upstream Cinnamon will consider switching to a customised gnome-shell base instead... it's surely proved that it can be quite highly customised and tweaked now....
20:50:18 <[mbot> [ Bug 1019405 cinnamon-screensaver causes unwanted screen locking when running GNOME ]
20:50:42 <ovitters> in 2.0 they just forked more of GNOME
20:51:45 <malo> Ok. We should close the meeting :-)
20:52:10 <coling> Cool. Thanks malo :)
20:52:18 <Oro_Valley> bye
20:52:22 <malo> Thanks all!
20:52:27 <malo> #endmeeting