19:14:47 <ennael> #startmeeting
19:14:47 <Inigo_Montoya> Meeting started Tue Jun 18 19:14:47 2013 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:14:47 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:14:52 <ennael> #chair malo
19:14:52 <sander85> neoclust will implement in next telepathy..
19:14:52 <Inigo_Montoya> Current chairs: ennael malo
19:15:01 <ennael> hi all thanks for being there tonight
19:15:19 <ennael> #topic new comers
19:15:29 <ennael> to start with do we have new comers around?
19:15:49 <Crox> yes !
19:15:50 <djenning> yes me!
19:15:50 <Adrien_D> yes
19:15:57 <david_david> yep I
19:15:59 <tarakbumba> me too!
19:16:09 <rindolf> Welcome aboard.
19:16:15 <marja> 5, that is great :)
19:16:18 <Oro_Valley> welcom to all of u
19:16:20 <ennael> ok I let you introduce quickly: name, country, what you want to do...
19:16:24 <grenoya> welcome in hell
19:16:24 <ennael> Crox: ?
19:16:28 <ennael> your turn
19:16:35 <Crox> ok
19:16:52 <Crox> so real name : Francois Crosnier, aka Crox
19:17:00 <Crox> i'm from France
19:17:16 <neoclust> Crox: hello
19:17:26 <sebsebseb> hi
19:17:48 <ennael> Crox: any field you would like to work on ?
19:17:49 <sebsebseb> tarakbumba: your not as new now :d
19:17:50 <Crox> and i joined the community because i'm work on Mageia for my work and I want to be contribute to this nice project
19:17:57 <ennael> ok :)
19:18:02 <malo> btw Crox is still looking for a mentor, possibly who knows about security and the kernel
19:18:16 <neoclust> Crox: from where in france ?
19:18:31 <ennael> you are the one from alcasar ?
19:18:38 <tarakbumba> sebsebseb: :P
19:18:40 <ennael> Crox: ^^
19:18:41 <Crox> for the moment from Laval (West of France)
19:18:55 <Crox> yes I work on ALcasar
19:18:59 <ennael> :)
19:19:01 <ennael> http://www.alcasar.net/en
19:19:01 <[mbot> [ ALCASAR - un portail captif authentifiant et sécurisé. ]
19:19:10 <Crox> I'm the fourth officiel member of the ALCASAR project
19:19:20 <ennael> as a side note this is now all based on Mageia :)
19:19:29 <neoclust> :)
19:19:32 <ennael> welcome Crox
19:19:34 <neoclust> nice to hear :)
19:19:39 <ennael> djenning: your turn ?
19:19:42 <djenning> Derek Jennings from UK I want to help make Mageia the best possible user experience
19:19:55 <Crox> yes Mageia works on Mageia2 for the moment and soon on Mageia3
19:19:55 <ennael> nice target :)
19:20:11 <ennael> Adrien_D: your turn :)
19:20:13 <djenning> my  background is networking  ex Cisco
19:20:16 <ennael> oups sory
19:20:28 <ennael> so you can help on all networking packages
19:20:45 <sander85> djenning: so you want to integrate NM with mageia's tools, yes? :P
19:20:50 <djenning> sure
19:20:54 <ennael> great :)
19:21:01 <Adrien_D> i wait djenning ended.
19:21:02 <Crox> can i just precise something ?
19:21:07 <ennael> Crox: yep ?
19:21:49 <Crox> for the moment i already made some RPMS : havp, coova-chilli, ipt_netflow (kernel module) and nfdump
19:22:22 <ennael> ok so you have something to start with
19:22:28 <neoclust> ah nice
19:22:28 <Crox> but i dont already submit fir the moment
19:22:34 <ennael> yep sure
19:22:43 <ennael> Adrien_D: your turn now)
19:22:43 <neoclust> Crox: good enough, we will have something to review :)
19:22:52 <Kharec> :)
19:23:08 <Adrien_D> My name is ... Adrien , I live in Dijon (France)
19:23:21 <neoclust> jon
19:23:28 <Kharec> neoclust: :)
19:23:29 * ennael slaps neoclust
19:23:33 <Adrien_D> I'm an IT technician in a medium-sized enterprise and I'm CCENT Cisco Certified, and for information, I passed the TOEIC (Test of English for International Communication) 540/990 pts.
19:23:46 <ennael> don't be shy :)
19:23:49 <Crox> nice description ;)
19:24:00 <Adrien_D> I thanks Google Trad to translate harder words
19:24:12 <ennael> Adrien_D is a but uneasy with english he told us
19:24:18 <ennael> I'm sure people will help him
19:24:22 <Crox> like me with a better TOEIC score :D
19:24:23 <Adrien_D> I applied as a future Mageia packager, to strengthen the current team with my knowledge. (For 5 days)
19:24:46 <Adrien_D> I applied as a future Mageia packager, to strengthen the current team with my knowledge.
19:24:47 <Adrien_D> I use Mandriva and Mageia now since 2008.
19:24:56 <Adrien_D> I would like to contribute now.
19:24:58 <Kharec> :)
19:25:02 <ennael> thanks :)
19:25:08 <ennael> david_david: your turn
19:25:22 <david_david> hi, I am Geiger David
19:25:25 <Adrien_D> There's a little storm at home, hoping to stay until the end of the meeting. :P
19:25:37 <david_david> I live in France, Alsace, Mulhouse
19:25:46 <sebsebseb> Adrien_D: good luck sometimes they are like two to three hours :d
19:25:54 <sebsebseb> Adrien_D: the meeting
19:25:58 <ennael> sebsebseb: please
19:26:04 <david_david> I'm managing a small business
19:26:50 <Crox> which business ?
19:27:11 <david_david> ENR 68 SARL
19:27:28 <sander85> what's that?
19:27:30 <ennael> anything else to add ?
19:27:37 <david_david> in renewable energies
19:27:37 <ennael> sander85: the name of the company
19:27:45 <sander85> ok
19:28:08 <tarakbumba> should i introduce my self?
19:28:09 <sander85> so making the world a better place to leave in :P
19:28:13 <ennael> tarakbumba: yes please
19:28:25 <tarakbumba> Atilla ÖNTAŞ (not double "t") from Turkey. Totally an amateur. I work as prosecutor for my bread and water :)
19:28:33 <tarakbumba> I want to work on mainly DEs, especially MATE and if i can manage KDE, and some other packages like zemberek and al-anvar
19:28:33 <sander85> s/leave/live/
19:28:51 <tarakbumba> I'm Turkish translator, former Mandriva Turkey 3rd party maintainer, one of OpenMandriva&Mageia Turkey admins, one of ArchLinux Turkey admins, many projects translator...
19:29:16 <ennael> 3 braines and 6 hands for all that :)
19:29:22 <ennael> brains
19:29:29 <Crox> ^^
19:29:34 <tarakbumba> I do not know any programming languages but some bash scripting
19:29:40 <tarakbumba> ennael: thanks
19:29:46 <sander85> tarakbumba: amateur? :P doesn't sound so :P
19:29:53 <ennael> thanks all for introducing
19:29:58 <ryoshu> tarakbumba, wow so many admin privileges
19:30:05 <Crox> with pleasure ;)
19:30:05 <ennael> we will speak later a bit more about mentoring
19:30:07 * coling is enjoying hearing from the new comers :) Welcome all!!!
19:30:12 <neoclust> tarakbumba: for KDE, we are always open to any help. Nice CV resumé btw :)
19:30:14 <Crox> ok
19:30:20 <neoclust> tarakbumba: for KDE, we are always open to any help. Nice resumé btw :)
19:30:27 <ennael> coling, the one who intends to break Mageia in all releases :)
19:30:34 <david_david> thank for all
19:30:39 <neoclust> ennael: but fails and fix all :)
19:30:43 <tarakbumba> neoclust: thanks, after my insist on mate :)
19:30:44 <malo> Welcome all!
19:30:44 <coling> ennael, no need, I have that covered ;)
19:30:49 <ennael> :)
19:30:55 <Crox> thx all :)
19:30:58 <ennael> ok let switch topic
19:31:02 <tarakbumba> thx to all
19:31:07 <ryoshu> great apprentices:)
19:31:08 <ennael> one thing before
19:31:21 <ennael> during meeting we try not to speak all at the same time
19:31:30 <ennael> and keep focused on current topic
19:31:38 <Crox> yes sure !
19:31:46 <ennael> you can add any other topic at the end of the meeting or before sending a mail on -dev
19:32:02 <ennael> it helps us not have meeting for 3 or 4h :)
19:32:05 <ennael> thanks for that
19:32:27 <ennael> #topic SIGs reloaded and Mageia 4 features
19:32:46 <ennael> so
19:33:00 <ennael> we spoke about SIGs 2 weeks ago
19:33:01 <ennael> https://wiki.mageia.org/en/SIG
19:33:04 <ennael> as a reminder
19:33:14 <ennael> we want to try and test it
19:33:25 <ennael> this is not perfect this can be improved still we have to try it
19:33:47 <ennael> the main goal is to manage cross communication and not have lonely packagers
19:34:23 <ennael> so the proposal is to start working with it for people interested and mainly while we are working on mageia 4 features
19:34:51 <sander85> the current list of SIGs is not good
19:34:52 <ennael> (please stop me if something is not clear)
19:35:04 <sander85> we need to improve that
19:35:13 <ennael> sander85: just mail -dev for it
19:35:46 <ennael> it will be hard to have something perfect that will please eeverybody
19:35:51 <Crox> just a precise
19:35:55 <ennael> yep ?
19:35:55 <sander85> what's the point, i mail there i get told lets discuss during meeting, now i want to discuss and i'm told to mail -dev :/
19:36:09 <ennael> sander85: sorry I did not get it
19:36:21 <Crox> SIGs = group of packager about the same goal soft ?
19:36:35 <grenoya> Crox: or group of softs
19:36:36 <ennael> same interest
19:36:39 <sander85> Crox: this is what i would like to see
19:36:39 <Crox> ok
19:36:40 <ryoshu> SPECIAL INTEREST GROUPS
19:36:47 <sander85> currently it's way too broad
19:36:54 <ennael> so for example desktop is about desktop environment
19:37:05 <sander85> we can't assign php-* packages to devel sig, no one would care
19:37:10 <Crox> ok thk i see
19:37:35 <malo> sander85: your mail was about co-maintainership, not SIGs
19:37:38 <ennael> Crox: so you should be interested in both base system and security for example
19:37:52 <sander85> malo: and you told we shouldn't have both :)
19:38:15 <ennael> these are 2 differents sides imho
19:38:15 <Crox> <annael> ok i already a little idea about that ;)
19:38:30 <malo> sander85: no, I told you that we have SIGs now, but not co-maintainership yet, as it should be both discussed and implemented
19:38:54 <sander85> malo: ok
19:38:56 <ennael> sander85: co-maintenership needs some modification in build system, bugzilla,...
19:39:15 <sander85> ennael: it doesn't need much.. IMHO
19:39:17 <malo> sander85: don't misunderstand me, I think co-maintainance is great
19:39:26 <tarakbumba> SIGs will also help mentoring to us?
19:39:36 <ennael> sander85: if you have some proposal you can start on a wiki page
19:39:37 <malo> sander85: but SIGs have a different purpose
19:39:47 <ennael> ok I take an example
19:39:52 <ennael> see this guy neoclust
19:39:58 * neoclust hides
19:40:06 <ennael> he shouts a lot but he is not so bad in KDE packaging :)
19:40:06 <coling> I'm not really sure I grok the differences between SIGs and maintainter groups tbh... seems like too complex a structure we're creating...
19:40:28 * sander85 agrees with coling
19:40:40 <neoclust> sander85: not the moment to talk of this
19:40:46 <malo> As a reminder, https://wiki.mageia.org/en/SIG
19:40:47 <neoclust> sander85: we will do by mail first
19:40:48 <ennael> SIGs should be like a more or less formal way to manage communication between all packagers of DE
19:41:02 <ennael> as an example Mageia 4 features
19:41:12 <sander85> we really don't have that many packagers /o\
19:41:26 <neoclust> sander85: can we focus on the meeting ?
19:41:30 <ennael> DE will have their own features still we need to have a coherence between them
19:41:38 <ennael> and some kind of integration
19:41:43 <ryoshu> have we got plan when to release Mga4?
19:41:58 * coling thinks is valid to discuss just now as sander85 is doing but waiting to hear ennael's full example.
19:41:58 <ryoshu> and keep features in this context
19:42:11 * ennael stops
19:42:32 * ryoshu resumes ennael
19:42:42 <malo> ennael: may I?
19:42:59 <ennael> well ok it seems I'm not taking the right way
19:43:31 <malo> Alright guys, the idea for SIGs was to focus packagers as groups of users, and not just individual packagers. The main goal is to share resources, efforts and knowledge as much as possible, and also to promote cooperative work towards a common goal.
19:44:01 <sander85> to be true, dev list is all about that.. imho
19:44:08 * coling agrees.
19:44:25 <Crox> if i can give my opinion
19:44:28 <Crox> ?
19:44:29 <Adrien_D> thanks malo or clarification
19:44:30 <malo> We proposed SIGs as a light structure at first, because we don't know how we are going to make use of it
19:45:01 <malo> and also because heavier structures need sysadmin work and they are too few and too busy
19:45:06 <Adrien_D> s/or/for
19:45:14 <ennael> if it has to take all our time then let stop it
19:45:15 <Crox> just i think that the SIGs is a good idea
19:45:44 <neoclust> Crox: yes me too
19:46:03 <coling> I think the principle is fine, but I'm not sure of the technical infrastructure needed.
19:46:11 <Crox> good idea ti focus all competences on same field
19:46:21 <coling> I think it would be detrimental to have SIGs on separately mailing lists for example.
19:46:23 <tarakbumba> I thought SIGs are  somewhat also a mentoring program with many mentors not one
19:46:35 <ennael> coling: please read again all logs
19:46:37 <neoclust> coling: yes no != ML
19:46:52 <malo> So basically, SIGs are an option, not an obligation. If no one wants to make them live, then it's ok.
19:46:52 <ennael> it was ok for all that we keep all on -dev ML
19:47:00 <coling> OK, cool.
19:47:05 <coling> [sorry]
19:47:09 <ennael> :)
19:47:11 <Crox> ok, fine !
19:47:12 <malo> coling: that's why we said all discussions should stay on -dev.
19:47:13 <neoclust> coling: you are forgiven my son
19:47:14 <neoclust> :)
19:47:19 <coling> ;)
19:47:31 <sander85> malo: if all discussion is in dev anyway, then what changes?
19:47:38 <sander85> we discuss everything there anyway
19:47:42 <malo> tarakbumba: yes, hopefully :-)
19:48:17 * coling thinks he's probably projecting too much onto SIGs from previous thoughts on maintainer groups etc and thus thinking it's too broad. I'll keep out of it just now and try and help it develop in the medium term :)
19:48:21 <malo> sander85: it changes if people want to make these SIG live by co-mentoring and elaborating features together
19:48:34 <malo> for example.
19:49:00 <malo> Look at the Science SIG
19:49:03 <malo> https://wiki.mageia.org/en/Science_SIG
19:49:24 <ryoshu> coling: what are maintainer groups? I have missed this part
19:49:38 <malo> they want to support a lot of scientific software, so they made a list of the main ones, and tracked their inclusion in Mageia.
19:49:48 <malo> That's the typical use of a SIG.
19:49:59 <coling> ryoshu, they are nothing specific, just various loose discussions we'd had over the years.
19:50:06 <malo> ryoshu: no, they are not :-).
19:50:25 <sander85> yeah, i'm just getting really frustrated with unmaintained bugs :(
19:50:26 <coling> malo, cool, that's a nice example.
19:50:29 <ryoshu> like i18n group?
19:50:44 <sander85> i can't assign them to dev list
19:50:44 <tarakbumba> malo: it is a nice example...
19:51:17 <malo> SIGs are an opportunity to bring coherence accross ranges of packages
19:51:26 <sander85> our distros quality is going down and SIGs sadly won't help much here
19:51:32 <coling> ryoshu, I don't want to talk too much about it just now as this is about SIGs, but basically I don't wnat to be the sole maintainer for half of the basesystem pkgs, but I am more than happy to share the responsibility with other packagers in an "official" capacity.
19:51:56 <Crox> theoretically all Mageia RPM are similar no ?
19:51:59 <sander85> coling gets my point :)
19:52:14 <coling> sander85, I disagree that SIGs won't help. They likely will, but I think there are other things we need to do too.
19:52:15 <Crox> according with the policy ?
19:52:18 <coling> All part of the puzzle :)
19:52:29 <neoclust> coling++
19:52:55 <ennael> mentoring for new packagers is another part
19:53:02 <ennael> co-maintaining also
19:53:05 <sander85> Crox: they are similar yes, but specific rpms may have specific macros etc
19:53:09 <ennael> but we have to start at one point
19:53:30 <ryoshu> coling: ah, I remember some discussions of comaintainership of packages - in fact this is just lurking into svn logs and extract commit authors
19:53:39 <Crox> yes sure !
19:54:21 <coling> ennael, yeah and malo is doing a really good job on this particular part, so KUTGW malo - I think I'm getting a bit more of an idea of SIGs now and what role they would serve. Thanks for being patient with me :)
19:54:41 <ennael> well no pb it just means we were not clear enough
19:55:04 <coling> Perhaps... but perhaps I've also not read enough too (can't rule that out just now)
19:55:13 <ennael> about features, we will follow the same process as for mageia 3
19:55:21 <ennael> as a reminder here is the policy
19:55:27 <ennael> https://wiki.mageia.org/en/Features_policy
19:55:29 <coling> Cool. That seemed to work well.
19:55:39 <ryoshu> yes? Fedora is trying something new this time
19:55:41 <coling> Plus I wrote most of mine months ago.
19:55:41 <ennael> please read it carefully before propsing a new feature
19:55:43 <malo> coling: mostly thanks to you :-)
19:56:14 <coling> ryoshu, what is fedora doing this time?
19:56:21 * coling hasn't been following.
19:56:33 <ennael> if people wants to try out SIGs, then they can meet and see some kind of transversal one
19:56:46 <ennael> for DE it can be designe integration for example
19:57:21 <ennael> we will try to sort the final features through SIGs names
19:57:32 <ennael> to help people understand all the list
19:57:35 <tarakbumba> i think my https://wiki.mageia.org/en/Feature:Mate follows the policy...
19:57:51 <ennael> we need to fix a deadline for the proposals
19:58:00 <malo> tarakbumba: yes, your feature is fine and fits in the Desktop SIG :-)
19:58:06 <coling> ennael, two weeks time?
19:58:08 <ryoshu> For Fedora 20, in coordination with FESCo [1], the new Planning process was developed to replace the old, not satisfactory Feature process. In reality, it's pretty similar to the exercise we did for the Fedora 19 - with announcements, less burden for FESCo (and now also developers) for leaf, self contained changes and more time to coordinate system wide changes with impact to the rest of distribution and schedule. To emphasize the aim on the cross tea
19:58:18 <ennael> coling just proposed 2 weeks
19:58:23 <ennael> is it ok for all ?
19:58:48 <sander85> ok with me
19:58:57 <AL13N> ok
19:59:04 <grenoya> ok
19:59:05 <tarakbumba> ok
19:59:36 <ennael> #info deadline for Mageia 4 features proposal is 2d of july
19:59:47 <ennael> we will try to review all them for this date
20:00:04 <malo> Don't forget to put the Category: ProposedFeatureMageia4
20:00:08 <ennael> some may need to be discussed
20:00:10 <ryoshu> coling: https://fedoraproject.org/wiki/Changes/Policy
20:00:13 <ennael> we will do it after
20:00:24 <tarakbumba> i should say that i'll move to another city at 4th of july and can get internet for about 2 months, will it be a problem?
20:00:41 <ryoshu> Fedora Engineering and Steering Committee (FESCo) defined two Change categories:
20:00:43 <coling> ryoshu, thanks, will take a look but probably will only work for next year... we also likely have less "problem" topics than fedora anyway :)
20:00:44 <ryoshu> Self Contained Changes System Wide Changes
20:00:48 <ryoshu> (thanks for attention :) )
20:00:54 <malo> tarakbumba: no internet for two months?
20:01:18 <tarakbumba> well, some mess here... with internet providers.
20:01:30 <AL13N> 2 months no internetz.... i'll die
20:01:32 <tarakbumba> Also, i need to take a vacation.
20:01:48 <malo> tarakbumba: I think you have enough other people to work on mate here
20:01:55 <ryoshu> tarakbumba: there was a wiki page with people on vacations
20:01:57 <coling> tarakbumba, it's unlikely to be a major problem. We all have to take time off sometime :)
20:02:03 <ryoshu> or without internet access, busy
20:02:14 <tarakbumba> I can look to mails, etc. but can not commit and look into bugs
20:02:22 <ennael> https://wiki.mageia.org/en/Absent
20:02:47 <ennael> tarakbumba: you can add your name here
20:02:51 <malo> Everyone ok for features?
20:02:56 <tarakbumba> ennael: i'm adding right now.
20:02:57 <ennael> it will avoid some people to loose head :)
20:03:00 <neoclust> malo: ok for me
20:03:04 <marja> yOK
20:03:14 <marja> -y
20:03:28 <malo> ennael: do you mail -dev about it?
20:03:31 <ennael> we will also publish the planning for the release within these 2 weeks
20:03:36 <ennael> malo: yep
20:03:37 <Crox> <malo> propose new features for Mageia4 ?
20:04:23 <malo> ennael: next topic?
20:04:26 <ennael> yep
20:04:39 <ennael> Crox: yes that was it
20:04:52 <Crox> okok
20:04:55 <ennael> #topic Opening of Backports
20:05:04 <ennael> another burning topic
20:05:08 <AL13N> hmm
20:05:18 <ennael> so we should open backports this week
20:05:24 <ryoshu> wow!
20:05:31 <ryoshu> what kind of backports?
20:05:31 <Adrien_D> woow!
20:05:37 <tarakbumba> yep!
20:05:47 <neoclust> ryoshu: the backport media
20:05:56 <ennael> please have a look on policy
20:05:57 <ennael> https://wiki.mageia.org/en/Backports_policy
20:05:58 <sander85> can we decide something on separate branch for backports?
20:06:04 <ryoshu> are they going to be like EPEL? additional stuff not conflicting with releases?
20:06:12 <ennael> it was discussed months ago we will not discuss it again
20:06:27 <ennael> boklm is checking last items for it in build system and svn
20:06:37 <sander85> it was discussed in sysadmin list but no clear decision
20:06:43 <ennael> so you may be able to start by the end of the week
20:07:19 <coling> sander85, I think most people agreed that it should be a branch.
20:07:20 <AL13N> (sander85: before that it's been discussed in -dev ML for years)
20:07:32 <coling> sander85, certainly I'm happy with that.
20:07:36 <tarakbumba> if Mate is accepted, may we backport it? Some users asked at forums
20:07:48 <sander85> policy still says this: submit to {core,nonfree,tainted}/backports_testing from the cauldron branch
20:07:55 <sander85> and i'm not happy with that :)
20:07:55 <ennael> sander85: it will be updated
20:07:59 <sander85> ok
20:08:00 <AL13N> tarakbumba: please review the policy
20:08:31 <ennael> boklm is alos working on scripts so that QA can push it in repository when tests are ok
20:08:31 <malo> backports will add work to QA, so please help them as much as you can.
20:08:41 <ennael> also
20:09:03 <ennael> #info backports will start by the end of the week
20:09:13 <coling> go boklm \o/
20:09:17 <ennael> #action last checks needed on policy pages regarding branches
20:09:32 <ennael> what just said malo is really important
20:09:45 <tarakbumba> AL13N: packages not present in the distribution (provided it doesn't obsolete or provide stuff that would impact the distribution, like backporting a new jvm with a obsolete on the current one)
20:09:52 <ennael> we decided to have a complete process on backports including QA
20:09:52 <coling> He's doing a really nice job there - remind me to buy beer in brussels (as if that needs any reminder!!)
20:10:05 <ennael> which was not the case in Mandriva
20:10:11 <tarakbumba> malo is great!
20:10:16 <ennael> backports then suffered from quality problem
20:10:29 <ennael> and people now are a bit scared using it
20:10:47 <neoclust> oh yes this was an horror w/o QA
20:10:48 <ennael> if we want to achieve this process we will need packagers to be implied iun QA process also
20:10:57 * neoclust will
20:11:05 <malo> tarakbumba: coling was talking about boklm :-)
20:11:07 * AL13N will try to find others to do QA
20:11:17 <coling> malo is great too tho' ;)
20:11:28 <ryoshu> bravo malo and boklm :)
20:11:47 <tarakbumba> boklm: sorry
20:12:06 * ennael is the naughty girl with matches to keep people focused
20:12:07 <ennael> gnarc
20:12:08 <tarakbumba> malo: but you're doing great job for apprentices, don't you? :)
20:12:08 <coling> ennael, Do we have any policy text on whether to update vs. backport? e.g. a leaf package xbmc, should it just be updated to 12.2 (12.1 shipped) or should 12.2 be a backport. Knowing the project I'd vote for an update (as it technically reduces long term QA burdon - e.g. if a security release is made later it'll need updating in updates AND backports)
20:12:53 <ennael> the pb is if we start exceptions it will become a mess
20:12:56 <ennael> I bet you :)
20:13:14 <malo> Anyway... remember that backports are a heavy packager investment: quoting from the wiki page "Backports can be cherry-picked (ie, enable backports, install, disable backports). It means too that there must be strict requires between backported packages, in order to make sure they can be cherrypicked."
20:13:50 <ennael> coling: for now I would say we keep strict definition of updates and backports
20:13:56 <coling> ennael, yeah but I think we already benefit from a little loose structure that bogs down some other distros. I think maybe we should try to deliberately NOT over specify this and leave it to a judgement call by maintainer.
20:13:57 <ennael> but this is my opinion :)
20:14:07 <malo> quoting again: "be ready to fix bugs : once you pushed a backport, you have to maintain it until the distribution's end of life :)"
20:14:29 <coling> But maybe I'm just too laid back ;)
20:14:34 <ennael> coling: this should be discussed first maybe and agreed with secteam
20:15:21 <tarakbumba> sorry, i have to go for 5 minutes...
20:15:25 <sander85> i think backports shouldn't change anything about updates.. as updates currently work
20:15:49 <ennael> coling: btw we already heave some packages backported in updates
20:16:16 <ennael> because fixing it for bugs or security is just not possible
20:17:02 <coling> ennael, I know :) That's why I'm raising the question really. Like I say I don't think it needs too much discussion right now anyway - just something to keep in mind.
20:17:12 <sander85> i think we agreed that long time ago that wen update is too hard to do with patches and new version would work then it's ok to go with new version..
20:17:28 <ennael> coling: ok so it should not change a lot then
20:17:38 <ennael> anything else on backports?
20:17:42 <sander85> nop
20:17:45 <neoclust> not from me
20:17:51 <coling> nope
20:18:00 <ennael> ok
20:18:05 <ryoshu> yes
20:18:16 <ennael> #topic mentoring reloaded
20:18:23 <ennael> malo: your turn
20:18:28 <malo> ennael: thanks
20:18:34 <AL13N> (how important are the sigs wrt mentoring?)
20:18:48 <malo> AL13N: as important as you want it to be
20:19:30 <malo> So, these two weeks we had several new apprentices
20:19:47 <malo> djenning mentored by wally
20:19:51 <ryoshu> malo: completely new or returned?
20:20:06 <malo> diogenese mentored by me
20:20:16 <malo> adriend by Kharec
20:20:27 <malo> david_david by zezinho
20:21:03 <malo> jamescategory is mentored by rindolf as well
20:21:26 <malo> The restart of mentoring was also the pretext for some old apprentices to start again
20:21:42 <malo> notably marja and Akien
20:22:02 <tarakbumba> i came back
20:22:04 <Akien> \o/
20:22:10 <marja> :)
20:22:19 <tarakbumba> i'm mentored by zezinho also
20:22:22 <malo> but also philippeDidier and tarakbumba
20:22:32 <ryoshu> neofutur is new too
20:23:01 <malo> ryoshu: yes, but I can't get hold of him on IRC.
20:23:08 <Akien> (Have to go, but I'll continue reading the meeting in the logs)
20:23:11 <ennael> neofutur is an "old" mandriva contributor or user :)
20:23:28 <malo> Crox is looking for a mentor, so we need a volunteer
20:23:57 <malo> For the apprentice program, I remind you of the web page https://wiki.mageia.org/en/Becoming_a_Mageia_Packager
20:24:14 <Crox> yes please :)
20:24:21 <rindolf> malo: I can mentor Crox.
20:24:22 <sander85> if we would have some solution for bugsquad i could take him to try mentoring but first we need to fix the problem with bugsquad..
20:24:26 <AL13N> malo: are you gonna do those seminars again?
20:24:46 <sander85> ok, Crox found mentor :P
20:24:56 <ennael> rindolf: we are looking rather for kernel guys
20:24:58 <malo> please just wait a moment for questions
20:24:58 <Crox> yes great :)
20:25:07 <rindolf> ennael: ah.
20:25:36 <malo> rindolf: you can however mentor him to get him started if you two want
20:25:37 <sander85> ennael: and how many kernel guys do we have currently :)
20:25:57 <malo> sander85: well, we'd like to have one more with Crox
20:26:17 <sander85> me too, me too
20:26:29 <rindolf> malo: OK.
20:26:31 <ennael> sander85: you want so many things :)
20:26:37 <malo> So, I remind you that apprentices should start without a svn account
20:27:04 <tarakbumba> malo: my commit right will be taken? no?
20:27:08 <sander85> malo: isn't it too harsh?
20:27:25 <tarakbumba> please say no...
20:27:28 <malo> after they complete some tasks, an svn account can be given
20:27:33 <malo> tarakbumba: of course no
20:27:39 <tarakbumba> maloB
20:27:45 <tarakbumba> malo: :)
20:27:47 <sander85> when i started at mandriva i think i had those rights pretty fast as svn wasn't new for me
20:28:04 <malo> among the *mandatory* tasks are validating some updates for QA
20:28:14 <sander85> it's svn and you can always revert commit
20:28:45 <ryoshu> some mentors used to start mentoring with the first task "report a bug with a request for svn access"
20:28:55 <sander85> yeah
20:29:14 <malo> So please have your apprentices do a few updates check with QA: it's good practice, and since providing updates is one of the essential tasks of a packager it's important
20:29:34 <malo> The process is not meant to be too strict of course
20:29:43 <coling> sander85, yeah but svn history is fugly (I know it doesn't matter toooo much tho') I think in a future when we use git, this can be solved by using apprentice branches which can be dropped if they are terrible or merged cleanly if they are good etc. meaning an account can be given earlier with appropriate push rights. but I don't want to go too far off topic for now :)
20:30:10 <AL13N> ( coling: which you just actually did :-) )
20:30:16 * coling hides
20:30:56 <malo> but it's important that apprentices learn that packagers are 1) responsible (and therefore should not commit random things) 2) part of a community (notably with QA)
20:31:20 <marja> malo: can bugsquad be added?
20:31:24 <sander85> coling: i may be wrong but i think i did svn diff and sent to my mentor before commiting, but at least i had rights to do so :)
20:31:29 <marja> malo: triage?
20:31:37 <malo> marja: that's a good idea :-)
20:31:46 <marja> :)
20:32:06 <sander85> triage won't be easy for apprentices
20:32:16 <ryoshu> why not?
20:32:26 <malo> Anyway, mentors should also know that processes for apprentices to follow are described at https://wiki.mageia.org/en/Packagers_Howto_start
20:32:27 <marja> sander85: I didn't know anything at all when I started in BugSquad!
20:32:33 <ryoshu> ok, determining maintainer is harder
20:32:46 <sander85> with our current policies it's a headaceh :P
20:32:53 <malo> And mentors should also read https://wiki.mageia.org/en/Packagers_Mentoring_Howto
20:32:55 <marja> sander85: we have plenty of needinfo bugs where the info was, or was not, given
20:33:47 <malo> Remember, the goal is to make our apprentices very good packagers, but also to make them members of the community
20:33:54 <marja> ryoshu: maintainer can be found here http://pkgsubmit.mageia.org/data/maintdb.txt
20:34:49 <sander85> marja: it only helps if you know who's behind that username :/
20:34:56 <ryoshu> marja: yes. this should be given to apprentices
20:36:14 <sander85> anything else about mentoring?
20:36:18 <marja> sander85: they can ask on IRC
20:36:42 * david_david must go, a ++
20:36:53 <ryoshu> bye :)
20:36:59 <malo> Last thing: the old list of packagers/apprentices was too long and outdated. So I started a new table at the bottom of https://wiki.mageia.org/en/Becoming_a_Mageia_Packager
20:37:50 <malo> I'd like mentors to add their currently active apprentices there, with how far they've progressed with respect to the new apprenticeship steps.
20:37:59 <tarakbumba> malo: i think i'm forgotten for that list
20:38:30 <malo> #info mentors should add their current and active apprentices to the table at the bottom of https://wiki.mageia.org/en/Becoming_a_Mageia_Packager
20:38:47 <malo> tarakbumba: I'll add you
20:39:19 <tarakbumba> malo:thank you and looking for 2nd seminar.
20:40:16 <malo> Please remember that these apprenticeship criteria are there to guide the learning and to accelerate the graduation moment
20:41:07 <malo> #info malo will run another round of Seminar 1 in a couple of weeks
20:41:38 * ryoshu is waiting for questions part
20:41:39 <diogenese> Those are fun.
20:41:50 <malo> #info malo will organise the first round of Seminar 2 in a couple of weeks as well
20:42:07 <malo> Seminar 2 is targetted towards apprentices with svn access
20:43:15 <malo> When we have a video I'm happy with, we'll make a blog post to attract more apprentices, but maybe that will be in a month or so.
20:43:26 <malo> I'm done. Questions?
20:43:45 <tarakbumba> malo: if you may do Seminar2 soon it will be much appreciated. As i told i'll not be around after 2 weeks
20:44:40 <malo> tarakbumba: it'll be on youtube if you miss it, but maybe I'll do it next week if there are enough people
20:44:40 <tarakbumba> malo: and i really want to learn especially versioning, release and epoch stuff
20:44:47 <marja> malo: is there anything apprentices can do to facilitate something like the hplip update (I saw it has over 40 patches... there'll sure be a lot to learn there)
20:45:21 <tarakbumba> marja: i do not have a hp printer but will look into that...
20:45:22 <marja> s/it has/its current version has/
20:45:42 <malo> marja: I don't know what apprentices can do there, except working on it with their mentor and possibly other packagers
20:45:46 <ryoshu> malo: I was thinking how to make our seminars 'cheaper', do you know sites like ascii.io? they provide recording of TTY/virtual-term and stream it to a website like 'pastebin',then we would prepare a video and assist maintainers on IRC answering their questions or giving tasks
20:46:27 <malo> ryoshu: that's a good idea
20:46:29 <ryoshu> malo: we could also solve the Flash or internet connection problems
20:47:02 <malo> ryoshu: the second seminar was ok with the internet (from my office it's more stable)
20:47:03 <ryoshu> malo: ascii.io offers rewinding and seems good for slower connections
20:47:30 <tarakbumba> ryoshu: it is a good alternative than youtube
20:47:33 * marja likes what she saw on ascii.io
20:47:51 <malo> ryoshu: but it's not possible to have a soundtrack?
20:47:53 <ryoshu> malo: (but on the other hand it doesn't offer the voice streaming)
20:48:14 <marja> malo: yes, we'll miss your voice and face
20:48:16 <ryoshu> malo: ascii.io is opensource.. and Ruby :)
20:48:47 <malo> ok, let's discuss that out of the meeting
20:49:15 <ryoshu> thanks
20:50:21 <malo> Other questions?
20:50:38 <marja> not here
20:50:53 * tarakbumba wonders if current future proposals will be discussed tonight
20:51:05 <ennael> no
20:51:25 <malo> tarakbumba: next meeting.
20:51:38 <tarakbumba> malo:when?
20:51:49 <malo> tarakbumba: 2 weeks
20:52:37 * tarakbumba wishes to advocate his proposal but thinks that he may not be here 2 weeks later...
20:53:03 <malo> tarakbumba: don't worry others will argue for it
20:53:13 <malo> ennael: back to you
20:53:15 <ryoshu> tarakbumba: what proposal?
20:53:26 <ennael> ok any other topics for this meeting ?
20:53:43 <sander85> co-maintainership? :)
20:53:51 <tarakbumba> ryoshu: MATE Desktop
20:54:23 <sander85> ennael: but i can also quit following bugs ml and won't bother anymore :P
20:54:24 <ennael> sander85: we already answered you
20:54:42 <ennael> sander85: you can make some first proposal on -dev ML
20:54:58 <ennael> then people can check it can be added properly in todo list
20:55:16 <sander85> ok, i may ping it again, as i already did
20:55:27 <malo> ennael: sander85 actually already did :-)
20:55:43 <ennael> add also sysadmins in copy
20:55:48 <Oro_Valley> I agree with sander85, we need to get this moving
20:56:05 <ennael> Oro_Valley: we need a lot of things but we also need people to implement it
20:56:18 <philippem> when did he ?
20:56:41 <malo> sander85: as ennael said, can you check with sysadm what would be needed to implement co-maintainership, or teams?
20:56:49 <Oro_Valley> ennael: I agreeI need to release all of the php packages, I cannot keep up.
20:57:15 * ennael needs also to sleep
20:57:15 <sander85> Oro_Valley: i think you can do it
20:57:18 <ennael> good night guys
20:57:21 <Oro_Valley> I already asked on teh ml and was referred to todays meeting
20:57:33 <diogenese> Good night ennael
20:57:34 <sander85> Oro_Valley: if nobody grabs more packages then people maybe will notice :)
20:57:42 <malo> sander85: we can discuss it in next meeting
20:57:47 * barjac wonders if maintdb can store two maintainers for one package
20:58:00 <sander85> barjac: it probably can't
20:58:05 <sander85> and it won't help either
20:58:14 <sander85> as two maintainers doesn't sound like a team :)
20:58:15 <malo> barjac: it probably needs a different system
20:58:21 <sander85> people want to work in teams
20:58:25 <sander85> more motivation
20:59:05 <malo> sander85: basically everyone agrees, you know :-)
20:59:12 <malo> ennael: good night
20:59:20 <sander85> ennael: gn
20:59:34 <malo> #topic Anything else?
20:59:44 <malo> I forgot to change it :-)
21:00:07 <diogenese> Practice makes perfect ;)
21:00:43 <tarakbumba> ennael: good night
21:00:43 <malo> If there is no other (short) topic to be discussed, we can close the meeting
21:00:53 <rindolf> ennael: good night.
21:01:05 <ryoshu> goodnight
21:01:05 <sander85> malo: i'll ask sysadmind how hard it would be to make it possible to assign bugs to *-team
21:01:11 <tarakbumba> i need to go too... Thank you all for your patience to me. Good night!
21:01:19 <rindolf> tarakbumba: night.
21:01:27 <sander85> s/sysadmind/sysadmins/
21:02:33 <malo> sander85: not just that, but to manage who is in which team, and so on
21:02:38 <sander85> malo: i'm too sleepy :D assign packages to *-team
21:02:41 <bersuit> Bye guys, good night .
21:02:49 <marja> bersuit: night :)
21:03:12 <Crox> night
21:03:37 <malo> sander85: ok. We can chat about it out of the meeting.
21:03:39 <sander85> malo: joining part seemed quite easy for me.. team has ml, read only if needed and all you have to do is subscribe and you are in
21:04:05 <malo> sander85: next week!
21:04:15 <malo> sander85: I mean next meeting!
21:04:22 <sander85> malo: yeah
21:04:27 <malo> Let's finish for tonight
21:04:37 <malo> Thanks all for attending!
21:04:43 <malo> #endmeeting