19:09:55 <malo> #startmeeting
19:09:55 <Inigo_Montoya`> Meeting started Tue Apr  9 19:09:55 2013 UTC.  The chair is malo. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:09:55 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:10:05 <malo> Hello everyone,
19:10:10 <malo> mitya: Hi
19:10:26 <malo> we have a busy meeting tonight
19:10:34 <malo> let's get started
19:11:04 <malo> #topic status of broadcom / grub2 / boost
19:11:36 <malo> ok, these 3 are important things that are a bit unresolved for the upcoming mga3.
19:12:08 <malo> so we should start with tmb telling us about the broadcom situation
19:12:46 <malo> tmb: ?
19:14:12 <malo> tmb is busy, so let barjac tell us about the status of grub2
19:14:25 <tmb> well, to be honest  ... it got left a bit on "backburner" as I have been sick, and when I got a little better I had to start with live images ....
19:14:47 <malo> I am too quick :-P
19:15:11 <tmb> I will try to review all the stuff this week for known problems and start mapping the drivers back
19:15:30 <malo> tmb: ok. Please enroll help for that.
19:15:50 <malo> tmb: I hope you are better
19:16:22 <malo> #action tmb will start looking at the broadcom situation again this week
19:16:28 <MrsB> \o/
19:16:46 <tmb> malo: not really ... but that's for another debate...
19:16:48 <MrsB> We can maybe try and find a few broadcom people if you want to do a trial tmb
19:17:05 <malo> tmb: please tell us how we can help
19:17:33 <tmb> I'll post a message on dev about testing / confirming what works tonight
19:18:29 <malo> #action tmb will post an email on dev to explain the broadcom situation and get help
19:18:35 <malo> tmb: ok?
19:18:38 <tmb> yep
19:18:46 <malo> tmb: thanks
19:19:01 <malo> barjac: your turn on grub2
19:19:04 <barjac> From the package there are no outstanding bugs, but there are some LIVE installer issues that tv/tmb are hopefully working on ;)
19:19:24 <MrsB> you had that typed ready didn't you
19:20:03 <barjac> Some testing should really be done with efi but I have no h/w to do that
19:20:10 <MrsB> bug 9334 is for the live issues
19:20:11 <barjac> MrsB: ;)
19:20:44 <malo> barjac: could you also send an email to -dev and -qa explaining which tests would be more helpful?
19:20:59 <MrsB> I'm not sure there is much efi in QA either
19:21:13 <tmb> for grub2 and live images, they now carry the rpms in "local repos" on the live images, but we need to teach drakx installer to "fool" grub2 to not detect the live running system
19:21:40 <MrsB> tv's last update mentioned that
19:22:02 <tmb> MrsB: wich one ?
19:22:08 <malo> o configure urpmi media even if local media are configured, and only if
19:22:08 <malo> online media are not setup (for live)
19:22:26 <malo> I think this fixes another bug
19:22:30 <MrsB> drakxtools & drakx-installer-stage2.
19:22:34 <barjac> tmb: Simply re-running grub2-install after install fixes the problem in tests that I have done
19:23:07 <tmb> nah, that vas a fix by blino to add online medias upon reboot
19:23:30 <MrsB> ahh yeah, I remembered it wrong
19:23:46 <neoclust> doktor5000_: i started to package http://qt-project.org/wiki/QtDesktopComponents but i think i never uploaded it
19:24:08 <tmb> barjac: well, chrooting before installing grub2 also seems to work
19:24:39 <malo> #action barjac will synchronise with qa and tv/tmb about grub2, maybe sending a mail with tests that would be useful
19:25:17 <malo> barjac: anything else on that front?
19:25:38 <barjac> No - don't think so
19:25:48 <malo> ok, let's move on.
19:26:09 <malo> We need to reach a decision on the update to boost-1.53
19:27:07 <malo> barjac has been pushing for it, with many tests, in order to fix gnuradio
19:27:38 <malo> the sec team is also pushing for it, since we currently use boost-1.52, that no other distro uses
19:27:46 <MrsB> the tests seemed successful
19:27:50 <malo> so it's not going to be supported
19:28:07 <malo> Next Fedora is going to use 1.53
19:28:53 <malo> the downside is that it's close to release
19:29:28 <MrsB> in all fairness it will probably be tested better now than if it's updated after release
19:29:35 <malo> So, first: are there some strong objection about the update?
19:29:48 <malo> second: do we stage it to testing first?
19:30:14 <malo> it's a bit of a risk, but not updating is potentially costly in the long run
19:30:16 <barjac> Packages affected are here and now all build with 1.53 http://mtf.no-ip.co.uk/pub/linux/barjac/boost/boost.txt
19:30:47 <spturtle> directly to cauldron so we get one and a half tester instead of zero (approximates :)
19:31:27 <malo> ennael was suggesting to go to testing. david walser directly to cauldron
19:31:45 <malo> (for the people who are not here)
19:31:56 * tmb is reading changelog for boost-1.53
19:32:06 <barjac> spturtle: In testing - who would test?
19:32:44 <barjac> s/spturtle/malo/
19:33:03 <malo> spturtle: that's a fair point.
19:33:15 <spturtle> (our famous maintainer 'nobody' would test it of course)
19:33:25 <malo> how hard would it be to revert in cauldron if we found an outstanding bug?
19:34:05 <malo> spturtle: nobody has too much packages, no time to tesst
19:34:20 <malo> neoclust: an opinion?
19:34:41 <spturtle> for a revert boost would need an epoch increase, depending packages rebuilt, dunno about gnuradio
19:35:37 <malo> tmb: an opinion?
19:36:05 <barjac> spturtle: : gnuradio would probably be nuked until boost update
19:37:46 <barjac> boost-1.52 was AFAICT not a very good release and other distros have either stuck with earlier versions or gone to 1.53
19:38:13 <tmb> reading the changelog and looking at the affected packages I'd say we should go for it
19:38:25 <malo> tmb: thanks
19:38:42 <malo> overall, I think ennael and AL13N were against.
19:39:31 <barjac> To quote Luigi: looks like the next openmdv release (if it happens :o) and the next Fedora will probably both have 1.53
19:39:31 <MrsB> I would vote to go for it, purely because it will be better tested at this stage thean if it is updated after release
19:39:57 * mitya can't wait till decision is made, builds Boost 1.53 locally to begin testing
19:40:14 <malo> Let's say that we agree that we push it to cauldron and test well.
19:40:18 <tmb> and straight to /release to get a broad test as soon as possible
19:40:30 <malo> mitya: you can use barjac packages
19:40:44 <malo> barjac: everything is in svn?
19:41:04 <barjac> malo: boost is yes
19:41:20 <malo> barjac: the patched other packages as well?
19:41:22 <Kharec> hi all
19:41:27 <barjac> malo: yes
19:41:29 <malo> Kharec: hey
19:41:47 <barjac> malo: except libyui that mitya has in hand
19:42:06 <mitya> malo: yep, I'm in now in the process of mgarepo co boost
19:42:21 <MrsB> Kharec: o/
19:42:31 <malo> barjac: can you send an mail to -dev requesting the freeze push? including the list of packages to be rebuilt and in which order (for tmb)?
19:43:11 <malo> #action we are going to upgrade to boost-1.53
19:43:46 <neoclust> malo: barjac : fedora uses boost 1.53 and seems their kde is OK
19:44:01 <barjac> malo: Freeze push request is there - rebuild order only affects gnuradio and kde
19:44:58 <malo> barjac: right, but an exhaustive list of packages would be nice in an email, to get more attention
19:45:14 <barjac> malo: OK
19:45:37 <malo> tmb: no problem pushing that?
19:46:25 <malo> #action barjac is going to email -dev the list of affected packages to help testing
19:46:29 <tmb> nope
19:46:46 <malo> Nothing more on boost?
19:46:52 <malo> Let's move on
19:47:15 * mitya suddenly discovered that he has got a full Boost 1.50 set of libraries, and they can't be uninstalled because libcmis0.2_2-0.2.3-3.mga3.i586 requires them
19:47:36 <neoclust> malo: nothing more for me
19:47:45 <malo> mitya: see with barjac :-)
19:47:56 <malo> #topic (1) Testing organisation
19:48:21 <barjac> mitya: yes libcmis is in the list ;)
19:48:27 <malo> This is now release freeze.
19:48:54 <malo> Which means that packagers should stop being busy updating to the latest version
19:49:06 <malo> which means that time is now to fix bugs
19:49:59 <malo> I've heard that from now on, there will be pre-isos almost every week
19:50:16 * malo is winking at MrsB and tmb
19:50:27 <malo> so, we need to help
19:50:31 * MrsB hopes not
19:51:20 <MrsB> Can I give a link to a big list of bugs?
19:51:29 <malo> MrsB: yes!
19:51:32 <MrsB> http://tinyurl.com/bszn9hf
19:51:34 <[mbot> [ Bug List ]
19:51:56 <Kharec> I'm trying to look at mediawiki package right now, as Luigi12 told me.
19:52:16 <malo> Kharec: great, mediawiki is quite critical on the list
19:52:33 <Kharec> malo: I'm on it :)
19:53:24 <Kharec> Luigi12 and I hope we can have mediawiki 1.20 in mga3
19:53:30 <malo> So it would be great if each of us looks at these bugs and try to fix many
19:54:25 <malo> #info http://tinyurl.com/bszn9hf is a list of bugs to consider
19:54:27 <[mbot> [ Bug List ]
19:54:56 <malo> #action every packager should look at bugzilla and fix as many bugs as they can
19:55:18 <malo> That's the first bit
19:55:22 <MrsB> \o/
19:55:43 <doktor5000_> malo: maybe send a mail to all packagers with a link to MrsB's list ?
19:55:43 <malo> Also I think that we should have a collective look at bits of the distro.
19:56:09 <malo> #action doktor5000 is going to mail -dev with MrsB list of bugs.
19:56:22 * doktor5000_ hides and curses
19:56:27 <malo> hehe
19:56:34 <Kharec> malo: great idea for packagers looking at the bugs and fix as many as they can.
19:56:37 <Kharec> :)
19:57:12 <malo> I also think that we should start having packagers look at packages from their SIG
19:57:24 <malo> (I know, the SIG don't exist yet)
19:58:12 <malo> so it would be great if some people would be in charge of testing Games, some on testing DE, some for Science softs, some for Servers.
19:58:54 <malo> With overlaps of people of courser
19:59:30 <MrsB> testing/fixing
19:59:31 <malo> We could have days of testing as well. In order for many packagers to test the same things in liaison with QA
19:59:37 <malo> MrsB: true :-)
20:00:00 <malo> MrsB: the first step in fixing many bugs is to reproduce them
20:00:12 <malo> Any other idea?
20:00:33 <malo> How can we fix more bugs during the next weeks?
20:00:45 <doktor5000_> malo: mail's out!
20:01:43 <Kharec> malo: maybe packagers can warn about which package they're trying to fix on qa mail discuss
20:01:50 <Kharec> like "Hey, I'm on ...."
20:02:05 <Kharec> No stupid idea... /me zip his mouth
20:02:43 <malo> :-)
20:02:54 <Kharec> :)
20:03:16 <doktor5000_> malo: add WORKSASDESIGNED and FEATURENOTABUG status fields to bugzilla and use those extensively instead of WONTFIX?
20:03:17 <tmb> Kharec: no that is a good thing... add a comment on the bug you are working on to not duplicate work
20:03:29 * doktor5000_ runs again
20:03:51 <Kharec> tmb: yep
20:04:14 <malo> doktor5000_: can you follow up on that list?
20:04:39 <malo> doktor5000_: making sure it decreases by pinging people and adding comments
20:05:40 <doktor5000_> malo: that list of bugs? nope sorry, short on time, i can't help track that list :/ but i'll try to take a look at some of those
20:05:41 <malo> #action all of the packagers energy should now be on making Mageia as stable as possible.
20:06:44 <Kharec> great \o/
20:06:47 <malo> we will talk about testing and bug hunting again next week anyway. It would be great if by next week there are less than 100 bugs in MrsB's list.
20:07:04 <malo> Let's move on
20:07:17 <MrsB> thanks :)
20:07:22 <malo> #topic
20:07:28 <malo> #undo
20:07:28 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Topic object at 0x844008c>
20:07:37 <malo> #topic (2) Release Notes
20:08:10 <malo> As the release approaches, we need to finalise the release notes.
20:08:40 <malo> #info The release notes are at https://wiki.mageia.org/en/Mageia_3_Release_Notes
20:09:15 <malo> Every packager should add the major changes that affected the packages he/she touched.
20:10:26 <malo> Remember that this page is visited by every blogger/reviewer of the distro (not counting users of course). So it needs to be pretty neat and complete.
20:10:47 <malo> #action Every packager should add the major changes that affected the packages he/she touched to the release notes.
20:11:21 <malo> Ok?
20:11:26 <malo> No objection?
20:11:27 <MrsB> It's also displayed in the installer
20:11:27 <mitya> malo: how do I know if my changes are significant enough to be included?
20:11:43 <malo> mitya: add them anyway :-)
20:12:19 <malo> mitya: like new major version, new packages, new relevant feature
20:12:23 <mitya> what's if (significant) changes have been made to packages not even mentioned in Release Notes yet? ex., Dovecot, Zabbix, TeXLive, NVIDIA CUDA Toolkit
20:12:28 <malo> mitya: don't put bug fixes
20:12:30 <MrsB> https://wiki.mageia.org/en/Mageia_2_Release_Notes a link to mageia 2 release notes, if it helps
20:13:30 <malo> mitya: think about the reader: would he be interested in the new version or not?
20:13:58 <malo> I guess a new lib version is not so important, but a new major for a widely used application is useful
20:14:18 <malo> mitya: it's better to put more information than less.
20:14:49 <malo> MrsB: thanks
20:15:01 <mitya> am I free to introduce sections like "Scientific / computational software", "Publishing" etc.?
20:15:30 <MrsB> Whatever you think will be of interest to somebody looking at Mageia
20:15:38 <MrsB> it's our chance to sell it
20:15:39 <malo> mitya: yes
20:16:38 <mitya> MrsB: sell it? how can I get my share? :-D
20:16:53 <MrsB> you can have a full half of nothing :)
20:17:34 <MrsB> If there is something you think people will be ineterested to know about Mageia 3 that should go in
20:17:49 <mitya> yup, got it
20:20:28 <malo> Ok Let's move on
20:20:47 <malo> #topic (3) Review of release critical bugs
20:20:53 <malo> Big thing :-)(
20:23:22 <malo> https://bugs.mageia.org/buglist.cgi?quicksearch=P1
20:24:06 <MrsB> ouch
20:26:00 <malo> MrsB: yep, 55 of them
20:26:37 <malo> So, these are very important
20:27:09 <malo> So if you have one of these assigned to you, this is your priority
20:27:49 <malo> If you don't have any assigned to you, please pick one anyway, try to reproduce, find a solution
20:28:23 <tmb> well there is 8 trackers, and some broadcom ones
20:28:40 <malo> Many of these are very technical, but several are supposed to be fixed and are only waiting for a tester with the last beta
20:29:25 <malo> tmb: yep, you are related to many of these
20:30:42 <tmb> I just closed one as fixed :)
20:31:01 <malo> tmb: nice
20:31:04 <MrsB> \o/
20:31:26 <malo> #info there are still 54 Release-Critical bugs
20:31:52 <malo> #action These bugs should get the highest priority, and everyone should help.
20:33:05 <malo> coling is not here, nor tv, nor blino, so I don't think there is much benefit at looking at each bug individually
20:33:39 <malo> Solbu: ping?
20:34:15 <Solbu> Pong!
20:34:17 <malo> spturtle, guillomovitch: ping
20:34:48 <malo> Solbu: on top of that list of RC bugs, you were in charge of the non-installable packages. What is the situation?
20:34:57 <malo> http://check.mageia.org/cauldron/dependencies.html
20:34:58 <[mbot> [ dependencies global report ]
20:35:43 <Solbu> Ok..
20:35:58 <Solbu> It seems like most of them might be dropped before release.
20:36:16 <Solbu> Sorry, not really prepared. Just got home. :-)0
20:36:55 <malo> Solbu: ok. But you did a good job: the list is quite reduced now, and some are just waiting to be removed/updated, right?
20:37:06 <Solbu> Openstack is being worked on, but he didn't have timne untiull the freezxe.
20:37:14 <Solbu> Might be ready in a week.
20:37:33 <Solbu> Other than that, I don't know if anyone is working on the rest.
20:37:41 <Solbu> Yes.
20:38:31 <malo> ok
20:38:49 <tmb> I think the avr stuff will be fixed, openstack has a push request, I will take on the x11 ones
20:39:03 <malo> Solbu: can you follow up on that?
20:39:31 <Solbu> malo: I don't see why not. :-)=
20:39:44 <malo> Anyway, our focus is on the release critical ones
20:40:14 <malo> let's make it under 50 for next week, under 40 when we omit the few tracker ones.
20:40:27 <malo> It is a reasonable goal
20:40:30 <malo> Agreed?
20:41:11 <tmb> well we can agree :) but we still cant force anyone to fix or test ... :)
20:41:42 <malo> tmb: we cannot :-), but we can motivate ourselves, and help you!
20:43:37 <malo> #action the goal is to have under 50 release critical bugs for next week (under 40 when we do not count trackers)
20:46:11 <malo> anything else on that count?
20:46:32 <tmb> nope
20:46:53 <mitya> is Olav still with us? I've found a solution for one of the bugs assigned to him
20:47:07 <mitya> https://bugs.mageia.org/show_bug.cgi?id=7819
20:47:09 <[mbot> [ Bug 7819 Mga3 - A2 : Can't open calendar on Gnome 3 ]
20:47:23 <mitya> yep I know that's not critical, but it was on the first list
20:47:46 <malo> mitya: please email him
20:47:58 <mitya> ok
20:48:14 <mitya> or maybe it would be even faster to fix it myself :)
20:48:22 <malo> mitya: then go ahead :-)
20:48:24 <tmb> well, afaik he's taken a timeout, so go ahead and fix it
20:48:39 <neoclust> mitya: yes i would say 'go go go'
20:48:44 <ryoshu> proyvind: ping
20:48:51 <malo> #topic Anything else?
20:49:01 <ryoshu> ouch
20:49:11 <malo> ryoshu: hello :-)
20:49:44 <tmb> nothing else from me...
20:49:55 <malo> If there is anything else to discuss, let's close this meeting and work hard on fixing bugs.
20:50:41 <MrsB> bedtime :)
20:50:46 <malo> I actually mean the opposite
20:50:50 <malo> forgot the negation
20:51:11 <malo> All right, thanks everyone!!
20:51:15 <malo> #stopmeeting
20:51:22 <malo> #closemeeting
20:51:26 <MrsB> end
20:51:29 <malo> #endmeeting