20:03:55 <malo> #startmeeting
20:03:55 <Inigo_Montoya`> Meeting started Tue Mar 26 20:03:55 2013 UTC.  The chair is malo. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:55 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:04:17 <malo> nice
20:04:33 <malo> Alright everyone, welcome to the packagers meeting
20:04:48 <malo> We have a nice program today, full of nice and cute bugs
20:05:24 <malo> ennael is not handling the meeting as she's busy with Beta 4 preparation
20:05:29 <malo> so bare with me
20:05:57 <malo> First topic: uninstallable packages
20:06:07 <spturtle> (bear)
20:06:21 <Luigi12_work> there's a # topic thing I believe
20:06:23 <malo> #topic Uninstallable packages
20:06:30 <malo> Luigi12_work: :-)
20:06:52 <malo> pterjan: your turn!
20:07:26 <malo> #info A list of uninstallable packages can be found at http://check.mageia.org/cauldron/dependencies.html
20:07:29 <[mbot> [ dependencies global report ]
20:07:41 <malo> #info it is computed daily
20:07:48 <malo> (as far as I think)
20:07:55 <malo> pterjan: not here?
20:08:35 <malo> If pterjan not here, can we discuss these packages, whether they can be fixed or should be dropped
20:08:46 <Luigi12_work> computed hourly I believe
20:08:46 <malo> those are the only choices
20:09:00 <Luigi12_work> the openstack ones should be dropped for several reasons
20:09:03 <malo> #undo
20:09:03 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Info object at 0x848ffcc>
20:09:07 <Luigi12_work> the x11-video-driver ones don't build either
20:09:17 <malo> #info it is computed very frequently
20:09:24 <Luigi12_work> if there's a newer version of those, they need to be updated.  I think they're using old APIs.
20:10:02 <malo> can someone take responsibility for these ones?
20:10:10 <Luigi12_work> prosody is an interesting one, as it needs /usr/bin/lua which is provided by a different lua version than the package is built against
20:10:16 <malo> tv is official maintainer
20:11:00 <malo> let's look in order
20:11:26 <malo> if there is a maintainer, he should deal with it
20:11:53 <pterjan> sorry
20:11:55 <Luigi12_work> I haven't seen shikamaru recently
20:12:18 <Solbu> shikamaru is active on the -dev list..
20:12:24 <malo> remains hamster-applet, kmediafactory, mumble, oar, redmine, task-nagios, ultrastardx.
20:12:53 <Solbu> I tried looking at ultrastardx, and it's seems to be unm aintained upstream.
20:13:47 <malo> #action Solbu is in charge of ultrastardx (remove it or update it)
20:13:51 <malo> :-)
20:13:56 <Solbu> Hehe..
20:14:07 <Solbu> If it's up t me, I say drop it.
20:14:19 <malo> Solbu: fine by me
20:14:41 <Solbu> So, just add it to task-obsolete?
20:15:04 <malo> move the svn to obsoletes
20:15:32 <Solbu> Hmm. THat can be interesting. Never done that before. but sometime must be the first time.- :-)=
20:15:33 <malo> https://wiki.mageia.org/en/Packaging_guidelines#Obsoleting_a_package
20:15:40 <malo> what is the situation for redmine?
20:15:53 <Luigi12_work> shikamaru commented on redmine and chiliproject here https://bugs.mageia.org/show_bug.cgi?id=6487#c38
20:15:55 <[mbot> [ Bug 6487 ruby-rails and associated gem packages contain security issues ]
20:16:08 <Luigi12_work> so I guess I have seen him recently /o\
20:16:48 <malo> these ruby packages really need an active maintainer ...
20:17:00 <Luigi12_work> seriously
20:17:00 <Solbu> shikamaru is working on them.
20:17:10 <malo> Solbu: ok.
20:17:23 <malo> task-nagios seems easy to fix
20:17:32 <Solbu> I frequently see him asking for push requrests on them.
20:18:38 <malo> Solbu: it would speed up the meeting if I put you in charge of this list of missing dependencies
20:19:11 <malo> Solbu: would you accept the task of looking at that list, pinging maintainers, and dropping packages as last resort?
20:19:22 <Solbu> malo: I've been doing a few of them, but I have intentionally not touched those with a listed maintainer.
20:20:05 <malo> Solbu: for maintained ones, the idea is to ping maintainers to accelerate the fixing
20:20:32 <malo> #action Solbu is actually in charge of reducing that list
20:20:36 <malo> Solbu: thanks
20:20:40 <malo> :-P
20:20:44 <Solbu> :-)=
20:20:55 <Luigi12_work> use the defibrillator if necessary
20:21:02 <malo> Alright, any more thought on that topic?
20:21:17 <malo> Luigi12_work: please help Solbu :-)
20:21:26 <Luigi12_work> yep
20:21:51 <wally_> hamster-applet can be dropped
20:21:51 <malo> #topic Non-building packages
20:22:08 <malo> wally_: please help Solbu as well then :-)
20:22:20 <malo> wally_: he's in charge now
20:22:22 <wally_> I can move it to obsoletes, that's all :)
20:22:48 <malo> wally_: don't forget to move the svn dir.
20:22:56 <malo> pterjan: ping?
20:22:56 <spturtle> pdumpfs is fixed (my backup is still running)
20:23:14 <wally_> malo: that's what I ment
20:24:20 <malo> spturtle: ok.
20:25:02 <malo> pterjan is sleeping, but was kind enough to post on the list the packages that couldn't be rebuilt since mga1 and mga2.
20:25:20 <DavidWHodgins> On that list, tigervnc is the only one I use.
20:25:46 <malo> lets look at the mga1 ones for now
20:26:08 <Luigi12_work> the important ones to fix are the ones that are dependencies of something else
20:26:47 <malo> Luigi12_work: yes
20:27:16 <pterjan> yes mga1 is the most important
20:27:37 <pterjan> I can post a list on the wiki with also things depending on them
20:28:01 <AL13N> ah, just thought all these mga1 ones could be dropped
20:28:29 <pterjan> not sure about prelink
20:28:44 <pterjan> (and I don't know several other)
20:28:54 <Luigi12_work> atlas and prelink are dependencies of things
20:29:05 <Luigi12_work> prelink can probably be dropped as a dependency
20:29:14 <Luigi12_work> atlas contains a library used by some things
20:29:35 <mitya> hi guys
20:29:49 <mitya> I know I'm in charge of ATLAS - can we discuss this issue now?
20:29:59 <DavidWHodgins> Which list?  I don't see prelink on the list of 67 packages.
20:30:03 <Luigi12_work> tv tried to update atlas at one point but didn't finish the job
20:30:14 <Luigi12_work> http://article.gmane.org/gmane.linux.mageia.devel/23729
20:30:15 <[mbot> [ Gmane -- Packages not rebuilt since Mageia 1 ]
20:30:24 <pterjan> DavidWHodgins: the list of 26 packages not rebuilt since mga1
20:30:37 <pterjan> DavidWHodgins: the 67 were not rebuilt only since mga2 :)
20:31:09 <DavidWHodgins> Thanks.  A couple of messages further down in the mailing list.
20:31:43 <spturtle> tigervnc can probably be taken from fedora
20:32:02 <Luigi12_work> atlas can probably be synced with fedora or rosa/openmandriva if they fixed theirs
20:34:08 <spturtle> :maint tigervnc
20:34:09 <Sophie> spturtle: For Mageia (tigervnc): nobody
20:34:42 <Luigi12_work> packages not built since mga2 is http://article.gmane.org/gmane.linux.mageia.devel/23730
20:34:43 <[mbot> [ Gmane -- Packages not rebuilt since Mageia 2 ]
20:35:40 <Luigi12_work> hsqldb is a dependency of things, so it should be fixed.  IIRC it's some Java thing so hopefully dmorgan can have a look.
20:36:21 <Luigi12_work> xemacs doesn't make sense.  builds fine on mga2, on cauldron the build just stops at a certain point on the build system.  No errors, it just times out or hangs or something.
20:36:54 <malo> spturtle: can you look at tigervnc?
20:38:39 <malo> I need a volunteer for the mga1 packages and one for the mga2 packages. Anyone?
20:38:46 <spturtle> malo: dunno, I gave up on Xvnc a long time ago
20:39:07 <malo> same role as Solbu in a way
20:39:42 <mitya> malo: I'll try my best to fix ATLAS in time
20:40:03 <malo> pterjan: can you be in charge of reducing the list of mga1 packages? Using defibrillators on maintainers if needed?
20:40:26 <pterjan> malo: I can try, guillomovitch already commented on many :)
20:41:03 <guillomovitch> the perl ones only
20:41:07 <pterjan> Luigi12_work: xemacs in cauldron has a process which keeps running that I need to kill
20:41:11 <sebsebseb> hi
20:41:12 <malo> #action pterjan and guillomovitch are in charge of fixing or removing the packages not rebuilt since mga1
20:41:15 <guillomovitch> I'd like jq opinion also
20:41:16 <pterjan> guillomovitch: that's a lot :)
20:41:35 <guillomovitch> i'll try to do the same with perl package from mga2 too
20:42:32 * coling is sorry he's late :s
20:44:05 <malo> guillomovitch: thanks
20:44:46 <malo> mitya: please work on Altas and coordinate with guillomovitch and pterjan
20:45:01 <malo> atlas
20:45:15 <malo> for the mga2 packages, are there some critical ones?
20:45:36 <Luigi12_work> hsqldb
20:46:10 <malo> xemacs, tigervnc, I guess
20:46:22 <malo> spturtle: could you help on this list?
20:46:54 <Luigi12_work> x11-driver-input might be important, and I think transifex is used by the translator team
20:47:20 <malo> Luigi12_work: I think they are not using it and moving to a different system
20:47:33 <leuhmanu> transifex is no more used by i18n
20:47:39 <Luigi12_work> ahh good
20:47:46 <Luigi12_work> hsqldb is required by libreoffice, so that's important
20:48:08 <Luigi12_work> unless it can be dropped as a dep, dmorgan will have to look
20:48:47 <malo> volunteer?
20:50:52 <malo> come one guys! I need someone who can go through this list of 67 packages and ping maintainers and eventually fix or drop them.
20:52:08 * malo can hear flies ...
20:52:46 <malo> if it's too much I can split the list in 2
20:53:53 <malo> and the list is not that long: guillomovitch is doing the perl ones, dmorgan the java/ooo ones
20:54:13 <malo> celtx can be dropped I guess
20:54:33 <spturtle> celtx is missing translation stuff, only available in binaries AFAICT
20:54:51 <spturtle> I mean this is a problem for new versions
20:55:05 <malo> neoclust: qmf?
20:55:07 <Luigi12_work> someone needs to ping dmorgan if we haven't yet
20:56:02 <malo> #action spturtle and Luigi are in charge of fixing or removing the packages not rebuilt since mga2
20:56:04 <malo> hehe
20:56:48 <malo> spturtle and Luigi12_work are allowed the defibrillator.
20:57:02 <malo> spturtle, Luigi12_work: ok with that?
20:57:18 <Luigi12_work> I got tasked with something at work that'll keep me very busy the next month
20:57:40 <Luigi12_work> it's enough trying to stay on top of the security issues
20:58:06 <malo> Luigi12_work: true, you are quite busy ...
20:58:06 <Luigi12_work> speaking of which, please everyone check your bugzilla assigned/CC'd list
20:58:59 <malo> ok, then wally_ and mitya, can you help spturtle with that second list?
20:59:13 <Luigi12_work> # undo perhaps
20:59:28 <malo> Luigi12_work: once I get the volunteers ;-)
20:59:32 <malo> #undo
20:59:32 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Action object at 0x838cfec>
21:00:29 <malo> silence means consent here
21:00:43 <spturtle> sure I can probably take a look, also depends on pterjan having time to remove packages
21:00:56 <spturtle> (or others from sysadmin team)
21:01:09 <malo> #action spturtle and mitya and wally_ are in charge of fixing or removing the packages not rebuilt since mga2
21:01:16 <malo> spturtle: they are.
21:01:44 <malo> and pterjan will be busy with removing the mga1 packages, so he'll be available
21:02:16 <malo> Last on the failed rebuild packages, there are the ones that did not succeed in the mass rebuild.
21:03:26 <malo> pterjan: ping?
21:04:20 <mitya> ah, oops... I'm in charge
21:05:01 <malo> mitya: yep, please split the list in three
21:05:41 <pterjan> pong
21:06:31 <malo> pterjan: can you tell us about the packages which failed the mass rebuild?
21:07:11 <pterjan> malo: they are at least all the ones from mga1 and mga2 lists :)
21:07:34 <Luigi12_work> if you have a local repo, just ls -lt the packages directory and see which ones are older than early january
21:08:34 <pterjan> http://pkgsubmit.mageia.org/autobuild/results.php?run=2013-01-11
21:08:35 <[mbot> [ 95.2% Success ]
21:08:46 <pterjan> the ones not marked as fixed
21:09:25 <pterjan> 513 - 316 fixed - 118 removed
21:09:32 <mitya> guys, I'll be awfully busy the next two weeks - I'll be able to do something significant only after April 13
21:09:32 <mitya> not even mentioning that I've got to fix ATLAS and some stuff before hard freeze
21:09:47 <mitya> besides, is the freeze still scheduled on April 7?
21:11:59 <malo> mitya: your task is not to fix the list yourself, but to ping enough the maintainers so that they fix their packages.
21:12:12 <malo> pterjan: thanks.
21:12:30 <mitya> malo: ah, I see
21:12:35 <mitya> OK then
21:14:14 <malo> pterjan: can you post the list of packages to be fixed on the ml? So that packagers can be more aware?
21:18:20 <malo> Ok, let's say that fixing the mga1 and mga2 packages is the priority. Let's volunteer someone for the mass rebuild failure next week.
21:18:31 <pterjan> malo: I think I will prepare some lists on the wiki and then email
21:18:38 <malo> pterjan: thanks.
21:18:44 <malo> barjac: ping?
21:19:48 <malo> #action pterjan will mail -dev with a list of packages which failed the mass rebuild
21:20:05 <barjac> malo: pong
21:20:24 <malo> before we move on, barjac is going to explain us the boost problem.
21:20:40 <malo> so that we agree on a solution
21:21:01 <malo> barjac?
21:21:09 <barjac> gnuradio devs have blacklisted boost-1.52 which we have
21:21:31 <barjac> it builds but is broken - tests fail etc.
21:22:06 <barjac> We could update boost to 1.53 but that does break 3 other package builds
21:22:44 <barjac> http://mtf.no-ip.co.uk/pub/linux/barjac/boost/boost.txt
21:23:30 <barjac> There may be other options, but maybe gnuradio should be dropped?
21:23:40 <malo> boost is a widely used library, so I feel unwell updating it so late in the release cycle.
21:23:59 <AL13N> i don't really like it being updated
21:24:09 <AL13N> can we build a boot53 ?
21:24:12 <AL13N> conflicting?
21:24:21 <AL13N> for gnuradio only atm?
21:24:35 <Luigi12_work> I don't want two of them
21:24:50 <Luigi12_work> I've already done two security updates for boost and had to rediff and backport patches by hand both times
21:24:52 <AL13N> i would prefer it not to be updated
21:24:59 <AL13N> ah ic
21:25:07 <Luigi12_work> are any other distros using 1.52?
21:25:14 <Luigi12_work> it sounds like 1.52 was just a problematic version
21:25:18 <malo> Luigi12_work: are you saying everyone else uses 1.53?
21:25:27 <AL13N> updating boost can have issues with mariadb too. maybe not now... but...
21:25:34 <Luigi12_work> well 1.53 is pretty new, but I don't know of any that shipped with 1.52
21:25:40 <Luigi12_work> need to check opensuse 12.3
21:25:44 <AL13N> what about going back to earlier versions?
21:25:51 <AL13N> is that an option?
21:25:55 <Luigi12_work> 1.51 works with gnuradio IIRC
21:26:05 <barjac> AL13N: Yes that would be fine for gnuradio
21:26:30 <AL13N> does 1.51 have security issues?
21:27:07 <AL13N> what has to be rebuilt due to boost?
21:27:11 <AL13N> alot of packages?
21:27:12 <barjac> Did we ever have 1.51? I think we skipped it
21:27:27 <AL13N> we might have, i remember 1.50 at one time
21:27:28 <barjac> AL13N: See my list above
21:27:30 <Luigi12_work> :v -s boost -r 2
21:27:31 <Sophie> Luigi12_work: 1.48.0-9.2.mga2 // core-updates-src (Mga, 2, x86_64), core-updates-src (Mga, 2, i586)
21:27:31 <Sophie> Luigi12_work: 1.48.0-9.1.mga2 // core-updates-src (Mga, 2, x86_64), core-updates-src (Mga, 2, i586)
21:27:31 <Sophie> Luigi12_work: 1.48.0-9.mga2 // core-release-src (Mga, 2, x86_64), core-release-src (Mga, 2, i586)
21:27:54 <AL13N> 1.50 would be fine for me, it worked for mariadb
21:28:28 <AL13N> barjac: would it be possible to have such a list for boost 1.51?
21:29:01 <barjac> AL13N: If I had two days to spare :\
21:30:07 <AL13N> barjac: ah, i thought this thing came automagically with a script or something
21:30:25 <malo> barjac: well boost is important so we cannot choose without proper information ...
21:31:03 <AL13N> thinking about this... it would be nice if iurt would actually be able to rebuild the dependencies automagically
21:31:11 <AL13N> ah well
21:31:24 <malo> #action barjac is going to provide alternatives for boost to minimize disruption either downgrade to 1.51 or upgrade to 1.53.
21:32:40 <barjac> malo: Unless pterjan can do something automated?
21:33:11 <AL13N> pterjan: does your autobuild have this conditional feature?
21:33:37 <malo> barjac: please coordinate with him and anyone fit, so that changing boost eases security team and reduces the bug numbers
21:33:55 <malo> lets move on, the meeting is long
21:34:12 <barjac> malo: OK but I'm pushed for time
21:34:17 <malo> #topic Review of release critical bugs
21:34:34 <DavidWHodgins> List of bugs affecting iso images https://ml.mageia.org/l/arc/qa-discuss/2013-03/msg00205.html
21:34:35 <[mbot> [ qa-discuss - Discussions about QA tasks and requests - arc_protect ]
21:35:05 <DavidWHodgins> Anne is looking into
21:35:07 <DavidWHodgins> Bug 7303 - Mga3 DVD Hardware Detection Tool fails with text about MENU or
21:35:08 <DavidWHodgins> just reboots
21:35:25 <DavidWHodgins> Bug 9529 rpmdrake is fixed
21:35:51 <malo> DavidWHodgins: thanks. You also posted about the dbus and dconf issues. Can you remind us here?
21:36:14 <DavidWHodgins> Someone needs to look at Bug 8379 - drakx-finish-install should enable nonfree repo if nonfree packages used
21:36:44 <DavidWHodgins> The dbus and dconf issues only affect upgrading using urpmi, or, when it's ready, mgaapplet
21:37:03 <DavidWHodgins> As those can be fixed with updates, much less critical, in my opinion.
21:37:54 <malo> DavidWHodgins: in my opinion, if these bugs can be fixed easily and now, it's much better
21:37:56 <DavidWHodgins> For anyone who missed my posts to the dev mailing list, post-install scriptlets that use dconf or dbus-send commands will cause urpmi to hang, during an upgrade.
21:38:21 <malo> DavidWHodgins: how many packages are affected?
21:38:34 <DavidWHodgins> Agreed, but as they don't affect the iso images, they are less critical.
21:38:35 <malo> coling: you posted a list, right?
21:38:49 <DavidWHodgins> Two so far, for sure, gdm and rtkit.
21:39:10 <malo> DavidWHodgins: upgrade bugs are less critical than dvd ones, but more than package bugs.
21:39:27 <DavidWHodgins> I haven't tested the others that use dconf commands yet.
21:39:41 * coling reads backlog...
21:40:00 <coling> Ahh yes.
21:40:10 <coling> Only rtkit seems to call dbus-send directly.
21:40:23 <malo> coling: can you fix rtkit easily?
21:40:25 <DavidWHodgins> Bug 8368 is for the installer. Needs to enable nonfree repos if nonfree selected during install.
21:40:29 <coling> I'm not really sure how to "solve" these problems tho'. I suspect they both ultimately relate to dbus.
21:40:51 <DavidWHodgins> Yes. During upgrade, dbus stops working, once glibc, etc are installed.
21:41:06 <coling> I may be able to just drop the %post in that case, but I suspect more problems will result if we don't address the underlying problem which appears to be hangs in dbus generally.
21:41:07 <DavidWHodgins> Can't use "su -", once the upgrade starts
21:41:16 <malo> there are other dbus related bugs these days: Bug 9326 - dbus: dbus-daemon-launch-helper installed with wrong group
21:41:31 <malo> can it be related?
21:41:35 <coling> Yeah I thought that latter one was fixed.
21:41:41 <coling> But no, it's not related in this case.
21:41:47 <coling> As that's an initial install bug.
21:42:03 <DavidWHodgins> Bug 9341 - itext cannot be installed due to requires on java-1.5.0-gcj
21:42:04 <AL13N> dbus send calls just can't hang
21:42:12 <AL13N> if you fix that, it'll be fixed
21:42:16 <Luigi12_work> itext is also really outdated
21:42:25 <DavidWHodgins> But they do, hang if you're in the middle of an upgrade.
21:42:43 <malo> AL13N: can you help on these dbus issues?
21:43:01 <AL13N> not really, who maintains dbus?
21:43:16 <coling> :maint dbus
21:43:17 <Sophie> coling: For Mageia (dbus): nobody
21:43:22 <coling> Should have guessed.
21:43:27 <coling> I'm happy to look into it tho'.
21:43:37 <AL13N> for installer, we could workaround by starting a dbus during install?
21:43:45 <AL13N> not sure if that's the right way though
21:44:01 <DavidWHodgins> The installer is ok.  This only happens when using urpmi or mgaapplet to upgrade.
21:44:03 <coling> Is it even a problem in the installer?
21:44:10 <malo> coling: thanks. Can you assign these two bugs to you? lmenut is already helping
21:44:11 <coling> Yeah. Good, thought so :)
21:44:18 <coling> Yup.
21:44:24 <malo> coling: thanks!
21:44:43 <malo> #action coling will help with the dbus problems
21:44:54 <DavidWHodgins> Bug 9315 - kde device notifier not working  for some usb sticks
21:45:24 <malo> Luigi12_work: how hard is it to update itext?
21:45:29 <DavidWHodgins> That's a strange one.  Works fine in Mageia 2.  Probably a udev rule missing a device id.
21:45:43 <DavidWHodgins> Not a critical one though.
21:46:00 <DavidWHodgins> Bug 8049 - Can't switch to/from console login.
21:46:03 <malo> DavidWHodgins: lets look at the critical ones first
21:46:32 <DavidWHodgins> This one probably only affects people like me, with an old monitor that doesn't support the max resolution my video card can put out.
21:46:49 <coling> malo, I think I assigned the ones you meant to me... please let me know if I missed one :)
21:46:55 <DavidWHodgins> So, not critical.  Let me look through for the critical ones.
21:46:58 <malo> coling: thanks
21:47:02 <malo> 9428, 9372, 9362, 9334, 9326, 9261, 9242, 9169, 9102, 9016, 9011, 8999, 8928, 8892, 8890, 8888, 8665, 8540, 8469, 8354, 8039, 8018, 8016, 7557, 7331
21:47:36 <DavidWHodgins> Bug 8505, XFdrake still doesn't have the start x server automatically enabled, by default.
21:48:00 <malo> AL13N: you are looking at mga#9372 ?
21:48:15 <malo> xen kernel config
21:48:35 <DavidWHodgins> Bug 5661 - Can not unlock encrypted volumes on lvm
21:48:38 <Luigi12_work> malo: I have no idea, itext is more java crap.  It's required by 5 things
21:49:22 <AL13N> malo: well, generally i'd like tmb's ideas on this, but he wasn't really responsive to this
21:49:23 <DavidWHodgins> Comparing diskdrake from Mageia 1, where this works to Mageia 2, where it doesn't, it looks like changes made to get lvm on top of crypt working broke having crypt on top of lvm.
21:50:39 <malo> DavidWHodgins: yes, this one is a big one
21:50:55 <DavidWHodgins> Bug 9213 - dracut won't mount encrypted root filesystem after install from live iso
21:51:10 <malo> barjac is in charge of 9334
21:51:27 <malo> 9326 is fixed
21:51:29 <DavidWHodgins> That one only affects live isos, not the standard installers.  Not sure what's causing the difference.
21:52:18 <malo> can someone look at 9261?
21:52:40 <malo> AL13N is in charge of 9242
21:53:22 <barjac> DavidWHodgins: Did you see my last comment in 9334?
21:53:26 <DavidWHodgins> I'm working with colin to figure out what's going wrong with dracut when using lvm for / and /usr.  It isn't working for an upgrade.
21:53:47 * coling nods
21:53:59 <coling> I need to crack out my own VMs again soon.
21:54:07 <coling> Will try and reproduce the same issues.
21:54:24 <malo> 9102 is to tv
21:54:33 <DavidWHodgins> barjac: Yes. Strange though. I'm pretty sure I installed from at least one of the live iso images, using grub2, and had no problems.
21:54:38 <malo> DavidWHodgins and coling: thanks.
21:56:15 <DavidWHodgins> Bugzilla is really slow right now. Trying to load the mga3 tracker bug.
21:56:30 <malo> Luigi12_work: is https://bugs.mageia.org/show_bug.cgi?id=8665 fixed?
21:56:32 <[mbot> [ Bug 8665 rpm 4.11 considers too many things file conflicts with directories, causing upgrade issues ]
21:57:12 <AL13N> 9242 is nearly fixed by tv
21:57:27 <AL13N> just needs rebuilt and final testing
21:57:54 <malo> AL13N: thnaks.
21:58:06 <barjac> DavidWHodgins: I'll keep testing - could it have been gnome?
21:58:24 <Luigi12_work> malo: 8665 will probably never be fixed
21:58:27 <malo> https://bugs.mageia.org/show_bug.cgi?id=8354 is also for coling
21:58:29 <[mbot> [ Bug 8354 Apper installed on KDE live isos but cannot talk to packagekitd ]
21:58:35 <DavidWHodgins> barjac: Not sure.  I'll retest in vb after the meeting.
21:58:50 <Luigi12_work> malo: all we're doing right now is working around the issues of 8665
21:59:12 <Luigi12_work> malo: for the %pre script issues, I guess we'll find out if anyone's upgrade to mga3 breaks
21:59:35 <malo> Luigi12_work: as long as it's possible to know which packages are potentially affected beforehand ...
21:59:44 <DavidWHodgins> Luigi12_work: I'ts the post scriptets that were causing urpmi to hang, when upgrading using urpmi.
21:59:49 <neoclust> malo: sorry i was away
21:59:49 <coling> Hmm is 8354 maybe just a dupe of the dbus-launch-helper live install issue?
22:00:14 <Luigi12_work> DavidWHodgins: %pre is what I meant though, different issue
22:00:21 <malo> neoclust: please read the logs ;-)
22:00:38 <Luigi12_work> malo: yes tv made a list of potentially affected packages for the %pre script issues
22:00:54 <malo> coling: maybe :-)
22:00:54 <Luigi12_work> the directory conflict issues are hopefully all fixed now
22:01:17 <coling> malo, luc suggests this in comment 16 now I look
22:01:57 <DavidWHodgins> I didn't run into any directory conflict problems in my upgrade test.  Did a boot.nonfree.iso install of mga2,  selecting all package groups, then upgraded using urpmi.
22:02:33 <malo> coling: ok.
22:02:40 * coling hopes.
22:02:57 <neoclust> malo: i will try :)
22:03:03 <malo> DavidWHodgins: great. Several directory conflicts happened for some locales as far as I know.
22:03:33 <Luigi12_work> yeah it was mainly the man-pages-%lang packages, there were a few others that I and others fixed earlier
22:03:47 <DavidWHodgins> There are bound to be some.  They're going to be hard to find, as it isn't possible to install all packages, and then upgrade.
22:04:07 <Luigi12_work> well Luc ran a script checking all the packages for conflictgs
22:04:20 <Luigi12_work> so we had a full list
22:04:27 <malo> I'll downgrade https://bugs.mageia.org/show_bug.cgi?id=8018 to not being release critical (more an enhancement)
22:04:29 <[mbot> [ Bug 8018 keep only english language for the grub in the i586 LiveCDs-en ]
22:04:31 <AL13N> had?
22:04:36 <Luigi12_work> as for the %pre script issue, not possible to get a definitive list
22:04:49 <Luigi12_work> just a list of possible ones, they have to be checked by hand
22:06:11 <DavidWHodgins> Is anyone available who knows perl well enough to look at diskdrake, for the encrypted on lvm problem?
22:07:01 <malo> guillomovitch: can I assign the https://bugs.mageia.org/show_bug.cgi?id=6954 one to you?
22:07:04 <[mbot> [ Bug 6954 [Tracker] all bugs relating to the new ( or not ) apache 2.4 ]
22:10:47 <malo> coling: can you shed a light on the logging situation: https://bugs.mageia.org/show_bug.cgi?id=8039
22:10:50 <[mbot> [ Bug 8039 [Tracker] bugs related the change of logs system ( journalctl vs rsyslog) ]
22:12:04 <malo> For all packagers that are present here, but do not feel competent enough to help on the release critical bugs, please help qa for beta4!
22:12:07 <coling> Actually yeah, I've got a couple things to update still on that front, tho' not related to the bugs it seems :)
22:13:17 <malo> coling: thanks.
22:13:33 <AL13N> i hope bug 10k will happen after mga3 release
22:13:38 <coling> I thought Angelo was working on draklog replacements, but I guess they won't be ready for mga3.... I'll do a hacky fixup for draklog I guess :s
22:14:19 <ennael> hi there
22:14:35 <malo> ennael: welcome back!
22:14:54 <coling> malo, re 8028, I'm crap.... I should be able to fix this one easily enough.
22:15:30 <coling> And the other two open ones are likely the same problem all in all (or rather fixed in the same way).
22:15:41 <coling> Shouldn't be too hard to fix up I guess.
22:16:04 <malo> coling: thanks! I assigned the tracker to you.
22:16:08 <malo> ennael: how are the CD/DVD bugs?
22:16:10 <coling> So I see :)
22:16:25 <malo> coling: hehe
22:16:54 <ennael> malo: some are fixed. isos building at the moment
22:17:00 <coling> I know next to nothing about XEN stuff by the way AL13N...  not sure how much help I'll be on that bug.
22:18:00 <ennael> working on 7311. I should submit a list to start with
22:19:08 <malo> Anyone here knows XEN and can help AL13N and tmb fix the XEN bugs>
22:19:10 <malo> ?
22:19:18 <AL13N> coling: it's assigned to me, just, keeping you guys in the loop on that stuff
22:19:24 <coling> :)
22:19:29 <AL13N> coling: but, regarding udev, i thought you were the perons
22:19:33 <AL13N> *person
22:19:43 <AL13N> coling: it thought that maybe you would know
22:19:44 <coling> AL13N yp
22:19:49 <AL13N> something
22:20:12 <AL13N> granted, most of this is really just hvm-pv (which isn't used that often)
22:20:14 <coling> AL13N, yup, but I'm still not super clued up - I only leaned how module autolaoding worked the other day :D
22:20:25 <AL13N> coling: how does it work?
22:20:35 <AL13N> i've been wondering myself that
22:20:53 <coling> AL13N, well the installer had it specifically disabled until very recently.
22:21:01 <AL13N> ic
22:21:29 <coling> AL13N https://bugs.mageia.org/show_bug.cgi?id=9428
22:21:32 <coling> Some deatils in there.
22:21:33 <[mbot> [ Bug 9428 xfs kernel module not loaded in Mageia 3 installer ]
22:21:50 * AL13N goes to read
22:22:06 <malo> neoclust: can you go through the 430 kde bugs and clean them up a bit (fix/close as appropriate)?
22:22:49 <malo> I need volunteers on the 321 gnome bugs as well
22:22:58 <neoclust> 430 kdebugs ?
22:23:05 <neoclust> that much ? :)
22:25:08 <DavidWHodgins> My biggest concern is diskdrake.  Encrypted on lvm, an [Bug 5811] diskdrake DELETE fstab entries for working /dev/mapper/partitions !!
22:25:11 <malo> neoclust: many are old and not for mga3, but it might be the opportunity to close some
22:25:37 <neoclust> malo: you have a bugzilla search for me to see them quickly ?
22:25:58 <malo> neoclust: https://bugs.mageia.org/buglist.cgi?quicksearch=kde&list_id=2513
22:26:14 <malo> neoclust: I just typed kde in the search bar
22:26:47 <AL13N> DavidWHodgins: update bugreport and ping tv, maybe he has an idea
22:26:59 <neoclust> malo: ok so there is less than 430 kde bugs :)
22:27:07 <DavidWHodgins> AL13N: Will do.
22:27:27 <malo> ennael: can you help with tv and DavidWHodgins on the diskdrake issues?
22:27:38 <neoclust> malo: like https://bugs.mageia.org/show_bug.cgi?id=5212 which is in the list :p
22:27:39 <ennael> wich one?
22:27:40 <[mbot> [ Bug 5212 The flash-plugin RPM is unable to download Flash Player. ]
22:27:50 <AL13N> DavidWHodgins: there was a person though who would busy with luks and stuff, donno if it's just a tester or someone trying to fix
22:28:03 <malo> neoclust: ok, I might have exagerated the 430 ;-)
22:28:20 <DavidWHodgins> A tester, from what I understand.
22:28:38 <DavidWHodgins> ennael: [Bug 5811] diskdrake DELETE fstab entries for working /dev/mapper/partitions !!
22:28:49 <neoclust> malo: i prefere this :)
22:29:21 <DavidWHodgins> ennael: And [Bug 5661] Can not unlock and set /home on my crypted home partition on logical volume (LVM) to use it
22:29:59 <ennael> ok let me finish the isos and I will mail tv and cc DavidWHodgins
22:29:59 <malo> neoclust: with mikala you can probably go through the list fast.
22:30:11 <DavidWHodgins> ennael: Thanks.
22:30:23 <neoclust> malo: don't forget luc :)
22:30:34 <neoclust> malo: he is not on irc but is part of the KDE Team :)
22:30:38 <malo> ovitters is not here, but it'd be great if some people could help with gnome testing.
22:30:50 <malo> neoclust: true.
22:30:57 <neoclust> malo: after i will install a gnome VBox if i have time
22:31:48 <malo> neoclust: maybe the kde team should actually be in a Desktop environment SIG which looks after all DEs.
22:32:12 <neoclust> malo: we have already a lot of work with kde
22:32:22 <neoclust> and we have plans for mga so we won't be able to help other DE
22:32:35 <neoclust> but maybe i didn't understood what you told :)
22:33:07 <malo> neoclust: I don't mean more work to you, but that all DE are in the same SIG so that their maintainers can help each other.
22:33:26 <AL13N> SIG == Special Interest Group
22:33:48 <malo> AL13N: yes, we talked about it last week.
22:33:55 <malo> Alright, time to summarize.
22:33:57 <neoclust> malo: ah ok :)
22:33:58 <AL13N> some things might be the same over all DE's
22:34:03 <neoclust> malo: i didn't understood this
22:34:04 <neoclust> :)
22:34:43 <AL13N> neoclust: something to improve collaboration and help with mentoring
22:35:33 <leuhmanu> (I have a kde buglist search iirc)
22:35:37 <neoclust> AL13N: yeah understood now
22:37:38 <malo> #info there are still 57 release critical bugs remaining.
22:38:11 <malo> #info ennael is building mga3 beta4 isos and working on fixing some of the CD/DVD bugs
22:38:58 <malo> #info coling works on the dbus, logging and udev bugs bugs
22:39:04 <malo> #undo
22:39:04 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Info object at 0x84960ec>
22:39:10 <malo> #info coling works on the dbus, logging and udev bugs
22:39:30 <malo> #info AL13N works on the XEN bugs
22:39:52 <malo> #info guillomovitch works on the apache bugs.
22:40:06 <guillomovitch> gni ?
22:40:10 <guillomovitch> which apache bugs ?
22:40:23 <AL13N> the tracker
22:40:48 <AL13N> "(23:07:02) malo: guillomovitch: can I assign the https://bugs.mageia.org/show_bug.cgi?id=6954 one to you?"
22:40:50 <[mbot> [ Bug 6954 [Tracker] all bugs relating to the new ( or not ) apache 2.4 ]
22:40:52 <coling> guillomovitch, incidentally are you looking at the httpd.service broken symlink issue or do you want me to fix?
22:40:53 <malo> guillomovitch: you were silent so I assigned the apache upgrade bugs.
22:41:01 <malo> guillomovitch: to you.
22:41:57 <guillomovitch> coling: i'm not
22:42:10 <coling> guillomovitch, OK, I'll fix.
22:42:15 * coling has it half written.
22:42:24 <guillomovitch> well, web applications whose config files need to be updated
22:42:37 <malo> #info everyone else should help both with testing the upcoming beta4
22:42:37 <guillomovitch> are not apache bugs...
22:42:41 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=7443
22:42:43 <[mbot> [ Bug 7443 Unable to show images from skins (Forbidden) unless apache 2.4 directives used in webapps.d ]
22:43:02 <guillomovitch> that's a wikipedia package issue
22:43:29 <guillomovitch> and the whole thread about "my apache configuration is broken after update" is likely to be closed as WONTFIX
22:43:52 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=6805
22:43:54 <[mbot> [ Bug 6805 Apache configuration file handling during upgrade ]
22:44:03 <leuhmanu> maybe something to add in the errata / release notes ?
22:44:07 <guillomovitch> I'm mean, I'm OK to fix what I consider bugs myself
22:44:08 <AL13N> haha, i read "Unable to show images from skins (Forbidden)" as "Unable to show images with skin (Forbidden)"
22:44:22 <AL13N> guillomovitch: you can close or reassign the others :-)
22:45:27 <guillomovitch> I'm waiting for pterjan input on #8977
22:45:38 <guillomovitch> and other people input for #6805
22:46:07 <guillomovitch> #7443 is not my problem
22:47:50 <coling> I'm going to submit basesystem, but should I bump version to 3? I guess it goes hand-in-hand with the mga version.
22:49:49 <neoclust> coling: sound logic and sane
22:50:39 <malo> #action everyone looks both at the release critical list and at the bugs assigned to yourself or to packages you are concerned about.
22:51:09 <malo> #info the list of opened bugs needs to be reduced in order to release mageia 3. Time is now pressing.
22:51:59 <DavidWHodgins> Release freeze is in 12 days.
22:52:40 <AL13N> eek
22:53:05 <barjac> coling: Is grub2 going to be default? At present meta-task's /etc/urpmi/prefer.vendor.list says we prefer grub as default
22:53:08 <malo> #info release freeze is in 12 days, so please ask for freeze push for bug fix releases quickly.
22:53:42 <malo> Any other point to raise for the meeting?
22:53:42 <Solbu> malo: Maybe send a mail to the dev list and remind people of the deadline?
22:54:06 <barjac> malo: ^^ grub2
22:54:39 <malo> #action malo will send a mail to -dev reminding people of the approaching release freeze
22:55:12 <malo> barjac: ok, you got 5 min: at 11pm UTC I close the meeting.
22:55:30 <malo> #topic grub2 as default bootloader
22:55:36 <coling> barjac, I have no idea. I dislike grub2 personally. I use gummiboot :)
22:55:48 <neoclust> Anssi: do you think you can take a look at https://bugs.mageia.org/show_bug.cgi?id=5212 ?
22:55:50 <[mbot> [ Bug 5212 The flash-plugin RPM is unable to download Flash Player. ]
22:55:51 <leuhmanu> I think it's a bad idea
22:56:08 <neoclust> malo: as default for mga3 ?
22:56:16 <malo> neoclust: yes
22:56:31 <neoclust> malo: i think this is too late to speak about this
22:56:47 <malo> there was a discussion about it a few months ago, and it was left opened as far as I remember
22:57:20 <malo> it was up to seeing if it was integrated well-enough with our tools
22:58:14 <neoclust> malo: our tools + gfxboot
22:58:21 <neoclust> malo: don't forget the graphical grub part :)
22:58:23 <neoclust> i think
22:58:27 <barjac> malo: It's 95% there at the moment I reckon.
22:58:34 <neoclust> malo: but this is late really
22:58:47 <Solbu> I agree. It's late.
22:58:54 <malo> well, I'm not the one to decide by myself ...
22:59:16 <neoclust> malo: i have been dealing with distro since 8years now and i think that this is now too late and we will have pbs later as we won't be able to test enough
22:59:30 <neoclust> malo: and i think we have enough critical bugs for now :p
22:59:33 <malo> barjac: if it's 95%, it means that in the best case it'll be 100% only by rc. That's not enough I think
22:59:49 <barjac> malo: Put it on the list for next week.
22:59:57 <DavidWHodgins> For the decision of grub2 or grub by default, let's wait until after beta 4 is out, before deciding.
23:00:01 <neoclust> barjac: next week ?
23:00:07 <neoclust> DavidWHodgins: NO
23:00:11 <neoclust> DavidWHodgins: after this is RC
23:00:19 <neoclust> DavidWHodgins: and we don't do such changes when RC is near
23:00:49 <leuhmanu> well graphic kernel option is still not integrate
23:00:51 <malo> neoclust: the question is not about having grub2 or not, all isos will have grub and grub2. So both should work.
23:01:26 <Luigi12_work> is the meeting over yet?
23:01:30 <barjac> neoclust: What change?
23:01:37 <malo> Luigi12_work: in 1 min.
23:01:40 <neoclust> barjac: having it by default
23:01:46 <ennael> sorry to interrupt but are there some packages I should wait for for next set of isos for beta 4 ?
23:01:47 <neoclust> malo: the question was about grub2 by default
23:02:05 <barjac> neoclust: The Live installers already default to it
23:02:30 <leuhmanu> then it's more a bug
23:02:35 <malo> neoclust: yes, I'm just saying that grub2 is already there.
23:02:47 <neoclust> barjac: this shouldn't :(
23:02:51 <neoclust> barjac: this is not normal
23:03:18 <AL13N> yeah, let's hold off on grub2 until mga4
23:03:23 <AL13N> (as default)
23:03:29 <Solbu> Agree.
23:03:49 <AL13N> we have enough other critical bugs
23:04:30 <malo> anyway it's too late to change the mix of grub/grub2 for beta4, so we can discuss it (quickly) next week.
23:04:32 <barjac> neoclust: The remit in the features list for mga3 was to have grub2 as default, but I'm easy either way - I have not used legacy for years.
23:05:11 <malo> barjac: can you post on -dev with a summary of the current situation (things which work and don't work)?
23:05:33 <malo> ennael asked a question that is more urgent
23:05:52 <neoclust> barjac: yes but a feature list can be delayed
23:06:02 <AL13N> ennael: imho the drakx-installer-images
23:06:02 <malo> #action barjac will post on -dev with a summary of the current situation (things which work and don't work) with grub2?
23:06:05 <ennael> well not trhat much but I guess it's more time for bed than looking for packages :)
23:06:07 <neoclust> barjac: in KDE we don't do all, if this is not ready early we postpone
23:06:09 <AL13N> ennael: not sure if tv submitted them yet
23:06:10 <ennael> AL13N: added
23:06:20 <ennael> I submitted it 1h ago
23:06:26 <AL13N> ah ok :-)
23:06:46 <leuhmanu> colin updates
23:06:54 <malo> I guess the last packages for beta4 can be outside of the packager's meeting, right?
23:07:12 <ennael> yep
23:07:34 <AL13N> yes please end this monster of meetings
23:07:40 <malo> Thanks everyone for this long meeting!
23:07:45 <malo> #stopmeeting
23:07:49 <malo> #endmeeting