20:05:42 <ennael> #startmeeting
20:05:42 <Inigo_Montoya> Meeting started Tue Mar 19 20:05:42 2013 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:05:42 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:05:45 <AL13N> btw: can anyone tell me how i can produce a core file??? i tried everything
20:05:50 <AL13N> oops meeting started
20:05:51 <ennael> let start
20:06:00 <ennael> hi guys around
20:06:06 <DavidWHodgins> HiYa
20:06:18 <ennael> so I'm happy to manage meetings now with philippeM and malo :)
20:06:23 <ennael> welcome in hell
20:06:57 <AL13N> "Welcome TO hell"
20:07:12 * AL13N shuts up
20:07:22 <malo> :-)
20:07:26 <ennael> hell anyway :)
20:07:42 <ennael> #topic Mageia SIGs (Special Interest Groups)
20:08:12 <ennael> so here is a proposal from malo. We already spoke about this some time ago but let see how we can handle this
20:08:15 <ennael> malo: your turn
20:08:28 <malo> hi everyone :-)
20:09:04 <MrsB> hi malo o/
20:09:10 <AL13N> yo
20:09:16 <ennael> so SIGs !
20:09:27 <malo> the diagnostic we make is that too many times packagers work alone and might feel isolated if an issue arise
20:09:49 <malo> it's less motivating to work alone on a set of packages
20:10:07 <malo> and the packager team is too big to coordinate very well
20:10:16 <malo> over 65 packagers
20:10:48 <malo> So the proposal is to have sub groups of packagers for classes of packages
20:11:17 <fathom_> when did messages gone?
20:11:19 <malo> Any packager can belong to several groups, following its interests
20:11:30 <malo> his interests
20:12:12 <AL13N> is this more related to maintainership or is this how are you going to bring the people together?
20:12:12 <malo> packagers in the same group should talk to each other and help out each other to manage packages (bug fixes, new versions, etc)
20:12:13 <fathom_> and where is the syslog now?!?!
20:12:26 <ennael> fathom_: please meeting in progress
20:12:36 <fathom_> sorry
20:13:10 <malo> for now, no change to maintainership
20:13:20 <ennael> AL13N: managing maintainers will ask to modify infrastructure. we can start in a less formal way as teams or groups
20:14:04 <AL13N> yes, that would be best, but what i'm worried about, is that i don't know how you can motivate people to actually work as groups and how to bring the people together
20:14:08 <malo> but there is the implicit idea that the group is able to co-maintain the corresponding packages
20:14:46 <malo> being part of a group is not necessarily that everyone works on every package
20:15:16 <AL13N> i understand your point, but i mean that, it's not because you say you're a group, that you are a group
20:15:20 <malo> but it's just the opportunity of a bit more coordination and support
20:15:36 <malo> AL13N: of course, it's up to all of us :-)
20:15:38 <AL13N> what kind of actions can make this happen?
20:15:49 <malo> The constraints I see for groups are:
20:16:32 <malo> groups of packages should be big enough to have many packagers in it
20:17:06 <malo> each group should have at least someone present for the group at the weekly meeting
20:17:37 <malo> The rest is up to the groups
20:17:46 <malo> and how people like this idea
20:18:00 <malo> for example, there can be coordinated testing
20:18:01 <AL13N> i personally like the idea, but i have no idea how to get started
20:18:14 <AL13N> how can this be organized
20:18:22 <malo> importing large software
20:18:25 <malo> etc.
20:18:34 <malo> to be organised is quite easy :-)
20:18:46 <malo> we just decide what are the initial groups
20:19:21 <malo> and then let people say what should be the main actions for each group, then find volunteers to do these actions :-)
20:19:38 <malo> For example, let's imagine we have a Games SIG
20:20:13 <malo> one actions that packagers in that group could take would be to test all actions games on Mageia beta 3
20:20:23 <malo> opening bug reports
20:20:31 <malo> and then (ideally) fixing them
20:21:13 <AL13N> so, is this then limited to packaging team?
20:21:26 <malo> SIGs are about coordination and support, so that packagers/maintainers are not facing all their difficulties alone
20:21:51 <AL13N> i think it might be better to be somewhat bigger than just packaging team
20:22:03 <AL13N> like QA people might be fond of games
20:22:49 <MrsB> qa people don't restrict themselves to one type of package, we test everything from games to browsers and libs etc
20:22:53 <malo> AL13N: well nothing prevent the Games SIG to advertise their testing week on the qa mailing list
20:22:53 <AL13N> or artwork people might go into an installer SIG; or webdev team people into a web-SIG?
20:23:22 <malo> AL13N: let's talk only about Packager SIG for now
20:23:27 <AL13N> maybe it's better to start in packagers only
20:24:00 <malo> I prefer SIG not to create new barriers for contribution, but rather new opportunities.
20:24:42 <malo> Last and not least, SIGs would also help with mentoring (more on that later), with some people knowing way more than others and helping them out
20:25:28 <malo> In reality, there are not just two levels (apprentice, packager): one who knows nothing and one who knows everything
20:25:38 <AL13N> i personally have the problems of trying to contribute into drakxtools and related, and having difficulty in grasping the structure of the code and having to search myself without much help
20:26:02 <AL13N> but i guess this is more -dev team, rather than packagers team
20:26:27 <malo> AL13N: true, ennael and I (and others) are thinking about a dev team, but it's not as urgent now
20:26:31 <AL13N> anyway... are other people dead? or uninterested?
20:26:42 <malo> So, packagers, WDYT?
20:27:22 <philippeM> that's why having at least a wiki page for each SIG with members listed can help
20:28:08 <malo> yes, some SIGs already exist: Education, Science, Accessibility, etc. (you can find them on the wiki).
20:28:17 <neoclust> KDE :)
20:28:28 <MrsB> kde team works well
20:29:18 <AL13N> how many of those teams are single active members
20:29:24 <AL13N> or maybe 2 people
20:29:57 <malo> Suggested SIGs: Accessibility, Science, Education, Development (maybe several subgroups), KDE, Gnome, DE (other), Games, Sound/Video, System, Servers, WWW/Networking
20:30:41 <DavidWHodgins> I'd also add a few based on skills needed. perl, python, etc.
20:31:06 <malo> I repeat: we don't want to fragment the packager group too much
20:31:30 <AL13N> if we have more SIGs rather than active packagers, it's not gonna help
20:32:03 <DavidWHodgins> Keep in mind that each packager could be a member of multiple groups.
20:32:16 <MrsB> there are already more packages than packagers so SIGs can only improve that
20:32:22 <malo> DavidWHodgins: I don't like if it's too specialised, the idea is to be inclusive and teach rather than exclusive and die (I dramatise a bit).
20:32:34 <DavidWHodgins> Gotcha.
20:32:35 <neoclust> malo: i tend to agree with you
20:33:08 <AL13N> ok, i'm in
20:33:11 <malo> DavidWHodgins: I would even encourage people to always participate in several groups (at least one they are confident about, and one to learn)
20:33:43 <malo> AL13N: we can avoid that if we have around 10 groups
20:33:51 <malo> or maybe 15 at the most
20:33:59 <philippeM> python and perl group make sense. Already for python packages we update, fix packages we are not the official maintainer
20:34:53 <malo> Finally, each group will *not* get his own mailin list.
20:35:01 <AL13N> call it: Dev/p* SIG
20:36:02 <malo> For Development tools, I would have just one big group at first, and see if it makes sense, and only split if the group is too active
20:36:02 <ennael> (back sorry phone call)
20:36:58 <malo> So, ideally, if everyone agrees, we should
20:37:08 <malo> 1 - find a list of SIGs
20:37:13 <AL13N> malo: maybe it should be advised to have 5 members, having 10 or more would be candidate for split, and having less than 3 might be candidate for merger
20:38:26 <malo> 2 - find volunteers to start each group (simple wiki page and rough scope of packages)
20:38:51 <malo> 3 - each packager joins the SIGs they want
20:39:12 <malo> 4 - each SIG discusses its priorities
20:39:21 <malo> 5 - we meet again next week :-)
20:39:46 <malo> AL13N: why not, but I'd rather not fix numbers just yet
20:40:09 <malo> But definitely 3 is too little a number
20:40:20 <malo> Reactions?
20:40:53 <malo> (I've talked too much)
20:40:55 <ennael> malo killed them all
20:40:56 <ennael> :)
20:41:24 <AL13N> i think that alot of anciens might not want the overhead of SIGS and just keep working alone, and thereby not improving the mentoring concept of it
20:41:43 <malo> AL13N: we therefore need to kick their asses
20:41:45 <AL13N> *aspect
20:41:56 <malo> (sorry for the rudeness)
20:42:09 <AL13N> you can't really force people? can you?
20:42:17 <AL13N> every packager must join 2 SIG's?
20:42:20 <tmb> well, telling 3 is "too little" or 10 "too much" is not helping... the "lower limit" of a working SIG is actually how productive the members are...
20:42:30 <AL13N> it might help for mentoring, but...
20:42:39 <malo> Ok, I spoke a bit strongly
20:42:48 <AL13N> tmb: yeah
20:43:18 <malo> as tmb says the goal is for SIGs to work and improve our efficiency as a packager team
20:43:35 <malo> it's to make it easier for people to join as new packagers
20:43:47 <malo> and also more resilient if someone leaves
20:44:01 <MrsB> it's always better to work as a team than in isolation
20:44:11 <malo> so all my proposal is just ideas/proposals
20:45:16 <ennael> started here: https://wiki.mageia.org/en/Packagers_Team
20:45:26 <malo> If SIGs mean that we are less efficient, we shouldn't have them
20:46:22 <malo> SIGs should help us grow and be more reactive
20:46:23 <AL13N> ok
20:46:30 <tmb> I think the idea of SIGs is a great, but as always it comes down to "are people ready to step up and work on starting and sustaining them..."
20:47:00 <ennael> sure but if never test we'll never know
20:47:21 <tmb> yep.
20:48:14 <AL13N> ok, let's just start with this list and if more SIG's come, we can discuss those...
20:48:31 <ennael> the existing one for now on wiki
20:48:32 <ennael> Education
20:48:32 <ennael> Science
20:48:32 <ennael> Games
20:48:32 <ennael> Accessibility
20:48:35 <ennael> KDE
20:48:38 <MrsB> team leaders could help SIGs with initial organisation
20:49:19 <malo> We should at least have one for Gnome and other DEs
20:49:57 <AL13N> i don't think it matters much, people will create it if needed
20:49:59 <AL13N> right?
20:50:20 <AL13N> we just need to jumpstart the existing ones
20:50:37 <AL13N> it's just important that people know about this
20:51:01 <AL13N> i get the feeling the meeting is not that much people as when the new features get discussed after a release
20:51:14 <malo> Well we can suggest a Development one, Audio/Video, Graphics/Office/Publishing, Servers/Networking, System/Kernel/Hardware
20:51:30 <ennael> yep let's create page and announce it on -dev ML
20:51:40 <ennael> and see how people react
20:51:48 <malo> Ideally, we'd like a couple of volunteers to kick start each SIG
20:51:56 <malo> and bring life to it
20:52:11 <AL13N> better ask on ML, since there's noone here
20:52:37 <malo> there are plenty of people here, they are just silent :-P
20:52:49 <ennael> ok any other question on that topic ?
20:53:08 <tmb> nope
20:53:39 <ennael> ok newt topic then :)
20:53:48 <malo> we can talk about it some more next week after the initial reaction
20:54:00 <malo> ennael action send mail ?
20:55:02 <ennael> #action send an email explaining SIGs and asking for volunteers
20:55:45 <ennael> next topic now :)
20:55:54 <ennael> #topic restarting mentoring process
20:55:59 <ennael> malo again \o/
20:56:09 <malo> I'll be faster this time :-)
20:56:28 <malo> mentoring is quite at a halt
20:56:35 <malo> but it's vital
20:57:51 <malo> so we should analyse what's wrong and fix it :-)
20:59:03 <malo> so my proposal is to have group mentoring
20:59:41 <tmb> that is why we also have a m
20:59:52 <tmb> that is why we also have a #mageia-mentoring
21:00:03 <malo> so that 1- new apprentices get instant replies on the mailing list and can start immediately
21:00:44 <malo> 2 - apprentices can always learn when they are available and not just when their mentor is
21:01:16 <malo> tmb: yes, although it's quite dead these days
21:01:49 <malo> mentoring has the same problem as single maintainership
21:02:06 <malo> it's too prone to failure :(
21:03:39 <malo> so the proposal is to have some people (me for example, plus a few others)  who is in charge to welcoming new packagers, and telling them how to start
21:03:56 <malo> it has to be fast, otherwise apprentices move on
21:04:20 <tmb> yep
21:04:49 <malo> once the apprentice is hooked :-), we can find suitable mentors, but we are less rushed. SIGs can be mentors for examples.
21:05:55 <AL13N> SIG would definately help there, the person gets into contact with people having similar interests
21:06:57 <AL13N> the problem before, was imho, that sometimes people asked for help, i pointed them towards wiki and mentoring channel and send an email to -ML and such, but it doesn't get followed up
21:08:38 <malo> I was also thinking that we can call for apprentices, especially in areas where we are missing people
21:09:02 <malo> SIGs might want to do that for example
21:09:33 <malo> some apprentices might not know how to package, but they sometimes have very good technical skills
21:11:01 <AL13N> and there's the junior jobs issue
21:11:02 <malo> So the proposal I'm making is not finalised, and might be helped by SIGs, but I'm just asking you if that's a direction to pursue, and if you are ok with me being in charge of it.
21:11:15 <ennael> no :)
21:11:15 <AL13N> i don't think any such job has ever been solved by a junior
21:11:17 <ennael> oups
21:11:31 <malo> ennael: ;-)
21:11:56 <ennael> #action malo will mail -dev about proposals to improve mentoring process and manage it as a group
21:12:12 <AL13N> ok, now i'll go away until next topic has passed
21:12:46 <malo> are there apprentices listening to this meeting?
21:13:48 <ennael> I guess they have been sacrifier by Luigi12_work and DavidWHodgins (private joke :) )
21:14:02 <ennael> ok so let's ping them on ML then
21:15:32 <malo> ok, if there are no more thoughts on that, let's move on to RC bugs ...
21:18:00 <MrsB> i think the direction you're taking is very good malo
21:18:11 <sander85> quite a lot of those are network related :/
21:18:51 <malo> MrsB: we're taking ideas from QA :-)
21:18:53 <ennael> MrsB: direction is always easier when more people working on it
21:19:19 <ennael> things are much worrying on bugs side
21:19:27 <ennael> #topic release critical bugs
21:19:45 <sander85> tmb: do you plan to release some test isos before beta 4?
21:20:05 <Oro_Valley> I would be glad to help test them
21:20:26 <ennael> wait we are on bugs for now
21:20:37 <sander85> ennael: yes
21:20:49 <ennael> beta 4 is planned for 28th of march
21:20:54 <ennael> so very near now
21:21:01 <sander85> i'm asking because of many RC bugs about broadcom stuff
21:21:03 <Oro_Valley> when I'll be out of town
21:21:44 <ennael> tmb: what do we plan about broadcom ?
21:21:48 <sander85> beta 4 should fix most broadcom bugs or we have to release beta 5 as well :P
21:22:02 <Oro_Valley> I have two boxes with broadcomm and one with display stuff (the later on the live CD only)
21:25:50 <DavidWHodgins> Regarding [Bug 5661] Can not unlock and set /home on my crypted home partition on logical volume (LVM) to use it, I've figured out part of where the problem is, but don't know enough about perl, to figure out how to fix it.
21:26:50 <ennael> DavidWHodgins: have you updated the bug report?
21:26:57 <DavidWHodgins> Yes
21:26:59 <ennael> maybe malo can give a hand on this :)
21:28:23 <malo> ennael: :-)
21:29:41 <malo> ennael: I've never used either lvm or encrypted partitions or perl, I'm not sure I'm the shortest path to fix that one ... :-P
21:30:46 <ennael> ok let see if we can find somebody on it
21:31:10 <MrsB> there's plenty of others :)
21:31:19 <DavidWHodgins> Someone who knows perl well, and preferably diskdrake too.
21:31:54 <MrsB> other bugs i meant
21:32:03 <leuhmanu> about lvm too
21:32:19 <leuhmanu> (but some are old)
21:32:41 <DavidWHodgins> lvm and crypt, I can explain steps needed for testing.  It's the perl part I'm stuck with.
21:34:26 <sander85> AFAIK we have one new member who is submitting patches for perl related bugs.. can't remember his name tho' :/
21:34:36 <ennael> what we can do maybe with malo and philippeM is to take 1/3 of bugs each and check directly with people implied
21:35:16 <MrsB> teamwork \o/
21:35:18 <malo> ennael: with matches?
21:35:42 <ennael> why not :)
21:35:46 <DavidWHodgins> Use a zippo! :-)
21:36:14 <ennael> ok let's do that. malo, agree ?
21:36:36 <philippeM> ok
21:36:42 <malo> ennael: you take all of tv bugs?
21:37:03 <ennael> I can take them and see with him
21:37:37 <malo> I take the bugsquad ones and philippeM you take the other ones ?
21:37:51 <philippeM> let's try
21:37:53 <malo> I have too many
21:38:25 <malo> but let's try like that
21:38:38 <MrsB> what are bugsquad ones?
21:38:44 <ennael> ok
21:39:03 <malo> MrsB: the ones without anyone assigned yet
21:39:11 <philippeM> malo: send me the list by email (those you don't take)
21:39:41 <ennael> #action ennael, malo and philippeM will follow release critical bugs
21:39:50 <malo> philippeM: it's on the mailing list
21:39:59 <malo> philippeM: https://docs.google.com/spreadsheet/ccc?key=0Ao3phYOTRNeQdEEtSjBSSWkxTmdIcmJZcGtfYjN1NVE#gid=0
21:40:01 <[mbot> [ Welcome to Google Docs ]
21:40:14 <MrsB> you might find there are several people in CC for those malo
21:40:32 <malo> MrsB: yes, people to ping :-)
21:41:14 <sander85> philippeM: https://bugs.mageia.org/buglist.cgi?cmdtype=runnamed&namedcmd=Release%20critical&list_id=1942
21:41:41 <malo> sander85: thanks, google docs are not always appreciated
21:43:00 <philippeM> ;) this list I'm aware of, I mean send me the list of bugs malo  and ennael will not take care of
21:43:03 <sander85> malo: i'm ok with google docs too (as long as they don't spring-clean it...) but bugzilla is always up-to-date :)
21:43:28 <ennael> philippeM: adding name on last column
21:43:39 <sander85> philippeM: exclude bugs that are not assigned to thierry or bugsquad :P
21:44:39 <malo> I really have too many and ennael too few ...
21:44:49 <ennael> :)
21:45:18 <malo> ennael: can you take the oldest non-assigned as well? under bug 7000?
21:45:20 <sander85> malo: there are quite a few trackers, you can probably ignore them
21:45:25 <ennael> malo: ok
21:45:46 <philippeM> and me even less, so malo take part of the bugsquad only
21:46:38 <ennael> ok let stop the meeting now we can speak after about this :)
21:46:45 <MrsB> divide by bug number
21:46:45 <malo> ok
21:47:06 <ennael> thanks all for attending and let's hunt/burn bugs :)
21:47:09 <ennael> #endmeeting