20:11:32 <ennael> #startmeeting
20:11:32 <Inigo_Montoya> Meeting started Tue Nov 27 20:11:32 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:11:32 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:11:35 <ennael> hi all
20:11:44 <rindolf> Hi.
20:11:47 <grenoya> hi
20:11:48 <shikamaru> hi
20:11:49 <MrsB> morning
20:12:02 <mitya> hi
20:12:08 <barjac> evening :)
20:12:17 <ennael> so first topic
20:12:28 <ennael> #topic DuckDuckGo integration
20:12:45 <ennael> so it seems work was started on that topic
20:13:11 <barjac> Yep weather for ducks
20:13:15 <ennael> sure :)
20:13:24 <ennael> Firefox was updated in Cauldron
20:13:32 <ennael> what about other browsers?
20:14:21 <Luigi12_work> updated in mga2 SVN for firefox also, will be included in the next update (17.0.1)
20:14:33 <ennael> ok nice
20:14:35 <Luigi12_work> not sure about Konqueror or anything else yet
20:14:50 <ennael> I remember a bug about konqueror
20:16:24 <ennael> we need to list browser and mail -dev will be easier
20:16:33 <ennael> chromium also needs to be updated
20:16:47 <MrsB> and opera
20:16:51 <Solbu> I take it that the integration changes the Default, and not interfer with already personalised browser setups?
20:17:19 <ennael> it does not change the default...
20:17:28 <ennael> and it does not modify personal configuration
20:17:46 <Solbu> Then I don't understand what it is...
20:17:46 <ennael> #action ennael will send an email to review browsers to be updated
20:17:48 <shikamaru> it just adds it to the list of usable search engines right ?
20:18:04 <ennael> and add a way to define which requests come from Mageia
20:18:11 <Luigi12_work> chromium could really use a maintainer
20:18:18 <ennael> ?
20:18:40 <Luigi12_work> technically it's dmorgan, but he doesn't update it very often, and I don't blame him, it's a lot of work
20:19:20 <ennael> can you mail about this point on -dev ?
20:20:01 <Luigi12_work> I guess if there's a thread about duckduckgo, I'll add a note about it
20:20:09 <leuhmanu> a some pkgs are in this state (no only with dmorgan)
20:20:09 <ennael> ok thanks
20:20:21 <shikamaru> ennael: do you mean customizing user agent so that duckduckgo knows that it comes from a mageia box ?
20:20:29 <Luigi12_work> leuhmanu: yes there's lots
20:20:40 <ennael> nope have a look on last meeting
20:20:52 <shikamaru> k
20:20:53 <ennael> it's just a request when using DDG search
20:23:10 <ennael> can we go to next topic ?
20:23:49 <shikamaru> k
20:24:22 <ennael> #topic Beta 1 deadline and Mageia 3 features
20:24:47 <ennael> so this is a review of the big features we are waiting for integration
20:25:16 <ennael> so first is about installer
20:25:25 <ennael> QA be prepared for testing :)
20:25:37 <MrsB> /o\
20:25:50 <ennael> I had a quick discussion with tv just before meeting to get some quick answers
20:26:18 <ennael> he will add grub2 support for beta1 so in coming days (work has started for some time now)
20:26:20 <malo> ennael: I guess not just QA, every packager should help testing the isos as well
20:26:26 <ennael> sure :)
20:26:29 <MrsB> \o/
20:26:40 <ennael> but I like poking MrsB :)
20:26:52 <MrsB> I'm getting bruises :P
20:27:08 <ennael> second feature is proposal of non-free drivers during install
20:27:24 <ennael> to follow what was decided some weeks ago about isos content
20:28:19 <shikamaru> malo: are VMs acceptable or do you also need real world installs ?
20:28:34 <Luigi12_work> shikamaru: any tests are helpful
20:28:51 <MrsB> both help shikamaru but real world are important, especially with nonfree drivers being included
20:29:01 <ennael> so tests here are just essential for final release
20:29:06 <MrsB> qa only has a limited set of hardware
20:29:11 <malo> shikamaru: everything is helpful!
20:29:24 <leuhmanu> 21:27 < ennael> second feature is proposal of non-free drivers during install
20:29:29 <leuhmanu> more details ?
20:29:36 <leuhmanu> via network ?
20:29:59 <MrsB> the installer dvd's will carry optional nonfree
20:30:03 <ennael> not much for now, could be yes but we were quite in a hurry, I will get more information tonight
20:30:11 <ennael> and mail about this tomorrow I hope
20:30:18 <leuhmanu> ok thanks
20:30:31 <leuhmanu> great anyway
20:30:43 <ennael> #action mail -dev about process of non-free drivers proposal during install
20:31:02 <ennael> I guess that's it for installer (which is a big piece already)
20:31:16 <ennael> upgrade now
20:31:19 <ennael> coling: ping ?
20:31:42 <coling> ennael, pong
20:31:45 <ennael> ah ;à
20:31:46 <ennael> :)
20:32:03 <ennael> hi there anything to add about upgrade for beta1 release ?
20:32:46 <coling> ennael, nothing specific. I still need to liaise with tmb re: pushing the rpm update to mga2 for non-installer upgrades, but otherwise nothing new from my side.
20:33:10 <malo> ennael: last grub update breaks the boot, so I guess upgrade might be a problem currently ;-) https://bugs.mageia.org/show_bug.cgi?id=8223
20:33:13 <[mbot> [ Bug 8223 grub update for mageia3 alpha breaks boot loader. ]
20:33:20 <ennael> ok so rpm is ready, just need to be pushed ?
20:33:24 <ennael> malo: wait 2 sec please
20:34:12 <ennael> coling: ?
20:34:20 <coling> ennael, pretty much yeah
20:34:38 <coling> It's been pretty well tested on the cluster :)
20:35:10 <ennael> ok :)
20:35:15 <ennael> I will ping tmb then
20:35:39 <ennael> thanks
20:35:46 <ennael> malo: I've just updated that bug
20:35:57 <ennael> it has been fixed with last package
20:36:36 <malo> ennael: ok, it's just a nasty bug
20:36:49 <ennael> yep cauldron life :)
20:36:55 <malo> ennael: I mixed up upgrade and update
20:37:07 <malo> ennael: from your sentence
20:37:13 <leuhmanu> stage2 is for installed os too ?
20:37:32 <leuhmanu> cf (Build with -fno-reorder-functions to make stage2 work again)
20:37:33 <ennael> leuhmanu: nope it's for grub
20:38:10 <leuhmanu> how can we know it's fixed ? :)
20:38:26 <ennael> it can boot :)
20:38:46 <leuhmanu> well ok will wait
20:38:49 <ennael> which is quite a good test
20:38:51 <ennael> :)
20:39:06 <ennael> next point is groups management
20:39:23 <ennael> we still have lots of packages to be updated
20:40:03 <malo> ennael: I emailed -dev, and olav provided a nice breakout with maintainers
20:40:29 <ennael> yep
20:40:57 <malo> so please everyone, look at that list and update the %group tag of your packages, so that they are nicely displayed in rpmdrake :-)
20:41:18 <malo> thanks for the ones who already started btw
20:41:59 <barjac> malo: At least one can't be done as it won't re-build against new boost 1.5
20:42:14 <malo> ennael: there will still be some left for Beta 1 though, notably packages which do not build
20:42:18 <malo> barjac: yep
20:42:36 <malo> there are quite a few in that case
20:42:40 <ennael> ok
20:42:57 <ennael> would be nice if you can make regular updates on -dev on that specific topic
20:43:14 <malo> I will, as soon as I can boot my cauldron again :-P
20:43:29 <ennael> ok :)
20:44:46 <ennael> about packages mass rebuild tmb is not around, I will ping him by mail
20:46:16 <pterjan> good news is that we don't have that many old packages
20:46:32 <ennael> nice to hear
20:46:37 <pterjan> and most of the old ones I rebuilt were building fine
20:46:44 <pterjan> (except grub :P)
20:46:52 <ennael> :))
20:47:10 * ennael will not say that pterjan did try to break cauldron with grub
20:47:15 <ennael> I did not say it :)
20:47:17 <leuhmanu> (time to switch to grub2)
20:47:22 <trem> ennael: \o/
20:47:46 <ennael> next topic on beta 1 is about blocker bugs
20:47:57 <ennael> leuhmanu: anything on this ?
20:48:30 <leuhmanu> #link https://bugs.mageia.org/buglist.cgi?quicksearch=P1 blocker bugs
20:48:48 <leuhmanu> should be updated
20:49:07 <leuhmanu> so currently 31-32
20:49:14 <leuhmanu> + some in tracker
20:49:18 <ennael> ok
20:49:34 <leuhmanu> some not real blocker, but needs a response
20:49:40 <leuhmanu> some really easy to fix
20:49:44 <ennael> I will give a hand to follow this and mail every 2 weeks about
20:49:59 <leuhmanu> and some really old
20:50:08 <ennael> if we do not make any progress on this we will have to do it on last days as usual which is a pain
20:51:01 <MrsB> we'll do our best to add some more :D
20:51:08 * ennael slaps MrsB
20:51:37 <ennael> #action a review of blocker bugs will be mailed every 2 weeks about
20:51:42 <ennael> #undo
20:51:42 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x833136c>
20:51:50 <ennael> #action a review of blocker bugs will be mailed every 2 weeks about until final release
20:52:39 <ennael> anything else to add on that topic ?
20:52:44 <ennael> other pending features ?
20:53:48 <leuhmanu> MrsB: feel free to set them, I can forget it
20:53:59 <MrsB> ok, thanks
20:54:51 <ennael> ok next topic then
20:54:54 <leuhmanu> ,wiki feature mageia3
20:54:55 <[mbot> https://wiki.mageia.org/en/FeatureMageia3_Review
20:56:13 <MrsB> There are many other bugs found in the alphas so far which can be tackled also http://tinyurl.com/bszn9hf
20:56:19 <malo> leuhmanu: reminds me that I never put https://wiki.mageia.org/en/Feature:RPMGroupRevamp in the list ... :P
20:57:02 <shikamaru> could we add a new subcategory to the sound category for computer music ?
20:57:07 <leuhmanu> MrsB: or the big list since the pre-alpha1 test which all new bugs :)
20:57:54 <shikamaru> it could include softwares like sound synthesis softwares, or soft that can allow you tu use musical instruments
20:58:50 <malo> shikamaru: nope :-), but make a note somewhere, maybe on the wiki https://wiki.mageia.org/en/Feature:RPMGroupRevamp
20:59:00 <leuhmanu> :g yoshimi
20:59:00 <Sophie> leuhmanu: Sound // core-release (Mga, cauldron, i586)
20:59:08 <shikamaru> leuhmanu: yeah that’s one of them
20:59:22 <malo> shikamaru: we might have time to adjust some categories after beta 1 and before beta 2
20:59:36 <shikamaru> k :)
20:59:44 <shikamaru> thanks
20:59:55 <leuhmanu> some are both in midi and "mao" then
21:00:20 <mitya> as for sound, at least the following major categories could be proposed: DAW, sequencers, samplers, editors, converters, score editors
21:01:20 <malo> please write your proposal at the bottom of https://wiki.mageia.org/en/Feature:RPMGroupRevamp
21:01:39 <shikamaru> yeah we can talk about that in detail later :)
21:01:53 <leuhmanu> next !
21:01:57 <ennael> ok
21:02:42 <ennael> so you may have read the thread about cinamon ?
21:03:06 <malo> ennael: use Inigo_Montoya, no?
21:03:13 <Luigi12_work> more entertaining than the football game last night
21:03:23 <ennael> raaaa
21:03:31 <ennael> #topic  Improve / remember /write policy about packages management
21:03:36 * ennael slaps ennael
21:04:45 <malo> is Joseph around?
21:04:49 <ennael> https://www.mageia.org/pipermail/mageia-dev/2012-November/020312.html
21:04:50 <[mbot> [ [Mageia-dev] Cinnamon ]
21:04:53 <ennael> I don't think so
21:05:05 <Luigi12_work> I don't recall seeing him on IRC
21:05:14 <ennael> having read this, the question is not to solve this or speak about that particular case
21:05:35 <ennael> rather to avoid other conflicts like this one
21:06:01 <malo> ennael: it's about writing somewhere the things we have currently agreed on, right?
21:06:01 <ennael> do you think rules are not clear enough? that we should improve it? missing items in policy ?
21:06:28 <Luigi12_work> where's the policy?
21:06:50 <malo> Luigi12_work: it's all over the place in the wiki ...
21:07:03 <Luigi12_work> nice
21:07:25 <ennael> so it means we need to clarify this and maybe write such statement in the wiki
21:07:31 <Luigi12_work> I think it's just something you have to learn as you acclimate yourself into the community, and something mentors should probably express at some point
21:07:47 <malo> https://wiki.mageia.org/en/Policies
21:08:03 <ennael> it means also that mentors should follow also cauldron to have such information
21:08:12 <Luigi12_work> the important thing being IMO (and this was mentioned in the thread), that to bring in a significant new package/package set that will affect a lot of people, you need to demonstrate some staying power so we know you'll stand behind it and help with support
21:08:33 <Luigi12_work> bringing in niche packages that won't affect many people isn't so controversial
21:09:18 <Luigi12_work> well the "cinnamon" thing was a specific decision, but I think we can generalize it
21:09:27 <ennael> meaning ?
21:09:42 <malo> But Joseph is right in that we have been quite busy and not welcoming new apprentices much
21:10:04 <Luigi12_work> the reason it's controversial is it's a desktop environment, and it's something that has a big impact
21:10:12 <shikamaru> let me tell you this has nothing to do with significancy of a package :)
21:10:27 <shikamaru> old story is old, it’s always been said there are too many DE over there
21:10:42 <ennael> it's not only about number of DE
21:10:47 <Luigi12_work> there's no such thing as too many if we have the resources to support something
21:10:51 <ennael> it's also about interactions with current one
21:11:02 <ennael> the thing is we cannot afford it for now
21:11:05 <Luigi12_work> but if you're gonna add something to what we support, you need to contribute at least as much to helpiing support
21:11:07 <ennael> we are lacking resources
21:11:24 <Luigi12_work> in terms of interactions, it doesn't sounds like cinnamon is actually very impactful, unlike MATE
21:11:55 <ennael> malo: also joseph was welcome by me and another one
21:12:08 <shikamaru> well, in Joseph’s mail I read “non-intrusive” but idk that DE at all so I give you the benefit of the doubt :)
21:12:18 <ennael> now mentors also have to carefull with apprentices
21:12:36 <ennael> that's also why I asked mentors not too have too many apprentices
21:12:40 <Luigi12_work> but another point is we could do a better job bringing new packagers/contributors into the fold.  They often get frustrated waiting to get started, and we've lost a lot of potential contributors because of this.
21:13:19 <ennael> Luigi12_work: on that particular point I was planning to mail to ask for apprentices on -dev
21:13:33 <Luigi12_work> ok
21:14:00 <Luigi12_work> at one point we had a "mentoring coordinator" to keep track of this and make sure people didn't get lost in the ether, but this didn't last long
21:14:15 <ennael> well updates were done on wiki
21:14:26 <Luigi12_work> ahh
21:14:45 <Luigi12_work> yes I used the wiki when I was brought in
21:15:00 <leuhmanu> where is reponsable of mentorship ?
21:15:22 <leuhmanu> someone told me in a bug he get no answer of mentor
21:15:38 <leuhmanu> I ask him to send a mail on dev
21:16:00 <ennael> can you please forward me such one ?
21:16:11 <leuhmanu> ok for the next time
21:16:20 <ennael> thanks
21:16:32 <leuhmanu> (can't found anymore the bug /o\)
21:16:35 <ennael> :)
21:20:31 <malo> ennael: back to the topic?
21:20:40 <ennael> yep
21:20:42 <ennael> so
21:20:51 <ennael> it means mentoring should be improved
21:21:08 <ennael> at least information for new comers
21:21:56 <leuhmanu> (I removed me as candidate to due lack of time)
21:22:03 <ennael> yep
21:25:03 <ennael> so maybe be more precise of what apckages should be included in Mageia ?
21:25:53 <MrsB> would it be better to be about how they can be included rather than what can't?
21:25:56 <malo> https://wiki.mageia.org/en/Software_inclusion_policy
21:26:39 <ennael> it's rather about licence for now
21:26:45 <ennael> but we could complete it, wdyt ?
21:26:49 <Luigi12_work> +1
21:26:58 <malo> We should complete it
21:27:19 <ennael> ok then
21:27:33 <ennael> #action complete https://wiki.mageia.org/en/Software_inclusion_policy
21:27:44 <malo> that page should be rewritten anyway
21:28:27 <ennael> yep ok let's try to work on it in coming days then
21:30:08 <malo> so the policy should be the common sense one: "please ask around before importing packages that have a potential impact on existing ones" ?
21:30:16 <ennael> sure
21:30:29 <ennael> policy is often about common sense :)
21:31:22 <malo> ennael: maybe we can add the current consensus on that page (w.r.t. to Mate and Cinamon and upstart and ...)
21:31:32 <shikamaru> the question is also, do we decide to be quite conservative, and raise the overall quality of packages, meaning having less of them
21:31:36 <ennael> sure that could be a good place
21:31:38 <malo> and trinity
21:32:14 <shikamaru> or do we think diversity is good, and if something does not work, helping people that need those packages to maintain them themselves
21:32:33 <leuhmanu> https://bugs.mageia.org/buglist.cgi?product=Mageia&component=New%20RPM%20package%20request&resolution=---
21:32:44 <leuhmanu> if you see something to remove...
21:32:52 <malo> shikamaru: I'm not sure limiting the number of packages raises the packagers to packages ratio
21:33:12 <malo> shikamaru: since many new packagers come with new packages they want to add.
21:33:17 <shikamaru> yeah, but one concern I read a few lines above was
21:33:29 <shikamaru> will he maintain it in the long run
21:33:35 <shikamaru> will upstream maintain it in the long run
21:33:38 <shikamaru> and so on
21:34:16 <malo> mass rebuild is a good thing to clean-up packages that do not work anymore
21:34:31 <malo> shikamaru: as long as we clean-up regularly ...
21:34:48 <Luigi12_work> like MrsB said, better to say what is needed for something to be included, rather than saying what should not be
21:34:49 <shikamaru> ok, so drop policy should be improved as well :)
21:35:09 <Luigi12_work> shikamaru: this is a good point, the drop policy *really* needs to be clarified
21:35:20 <shikamaru> but getting something to compile does not mean it works as expected either
21:35:30 <Luigi12_work> "it builds, ship it!"
21:35:57 <shikamaru> being more open also mean potentially more bugs
21:37:18 <shikamaru> so yeah we can’t import anything if it means we can’t triage all bugs
21:37:50 <ennael> ok I guess we will not finalize this tonight
21:38:04 <shikamaru> I feel that’s a huge issue with DE like Cinnamon, maintainance is only one aspect :/
21:38:22 <ennael> can you guys add ideas on proper wiki pages about this (add/drop packages)
21:38:28 <ennael> we will mail -dev about this also
21:44:12 <malo> action ennael?
21:44:38 <ennael> oups
21:45:14 <ennael> #action rewrite, complete wiki pages about drop and add packages policies
21:47:11 <malo> next topic, before everyone falls asleep? :-P
21:47:21 <shikamaru> :)
21:48:32 <ennael> Was the last topic for me
21:48:38 <ennael> any other ?
21:48:42 <ennael> speak now or never !
21:48:56 <malo> (and if pterjan could say how to fix the grub thing, that'd be great, because rescue does not work)
21:49:05 <malo> ennael: tv's deltarpm?
21:49:28 <ennael> malo: we can follow this on ML thread for now
21:49:41 <ennael> maybe have more feedbacks for next meeting
21:50:31 <malo> ennael: ok
21:51:08 <ennael> ok ending meeting now before everybody sleep
21:51:13 <ennael> #endmeeting