20:01:37 <guillomovitch> #startmeeting
20:01:37 <Inigo_Montoya`> Meeting started Tue Nov 20 20:01:37 2012 UTC.  The chair is guillomovitch. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:37 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:01:39 <AL13N> there"s #topic and #info stuff
20:01:45 <guillomovitch> #chair guillomovitch
20:01:45 <Inigo_Montoya`> Current chairs: guillomovitch
20:01:46 <AL13N> oh helpful
20:01:57 <sebsebseb> guillomovitch: you can cheat and look at logs of previous  meetings for command stuff to :d  http://meetbot.mageia.org
20:01:58 <[mbot> [ Index of / ]
20:02:05 <sebsebseb> anyway you started the meeting
20:02:20 <guillomovitch> good point
20:02:35 <guillomovitch> #topic Mageia 1 EOL
20:02:42 * AL13N stares at guillomovitch
20:02:46 <guillomovitch> I hope someone knows what it is about
20:02:52 <guillomovitch> because I don't have a clue myself
20:02:55 <sebsebseb> oh
20:02:56 <AL13N> i think about security EOL
20:03:03 <sebsebseb> ok so December 1st Mageia 1 will go End Of Life
20:03:06 <sebsebseb> no more updates at all
20:03:08 <AL13N> maybe Luigi12 can help
20:03:18 <guillomovitch> I mean, is there anything to discuss/plan here ?
20:03:26 <guillomovitch> or is this purely informative ?
20:03:29 <AL13N> perhaps something was said in council meetings?
20:03:43 <sebsebseb> probably just so packagers know it's end of life, and how to deal with that or something
20:03:54 <guillomovitch> #info December 1st Mageia 1 will go End Of Life
20:03:55 <AL13N> ennael sometimes does informative short topics, so it's a possibility
20:03:57 <sebsebseb> and yeah that's been mentioend in prevous council meetings
20:04:13 <Luigi12_work> so if you want to fix anything else in mga1, do it quickly!
20:04:21 <AL13N> ah, so that's the point
20:04:28 <sebsebseb> in fact I think was mentioned in the latest one counci lmeeting from Monday briefuly to
20:04:32 <Luigi12_work> also if you're still using mga1, time to upgrade :o(
20:04:47 <sebsebseb> I think the repos will get frozen for Mageia 1 to, not sure quite when it goes EOL
20:05:32 <guillomovitch> said otherwise: if you want to spare time with mageia 1 updates, just wait a few days
20:05:49 <Luigi12_work> :P
20:05:52 <guillomovitch> anything else to say ?
20:06:14 <AL13N> not for me
20:06:24 <AL13N> i'll be glad that mysql is gone
20:06:34 <guillomovitch> #topic Duckduckgo integration
20:06:47 <sebsebseb> there will be a EOL warning on the updates list according to: http://meetbot.mageia.org/mageia-meeting/2012/mageia-meeting.2012-10-29-20.36.html
20:06:48 <[mbot> [ #mageia-meeting Meeting ]
20:06:53 <sebsebseb> and I know there willl be another blog post to
20:07:07 <guillomovitch> ah yes
20:07:07 <AL13N> guillomovitch: i saw your post about the integration, and i sort of agree with you
20:07:20 <AL13N> but, it wasn't clear to me if this was just ADDED or default?
20:07:21 <guillomovitch> #topic Mageia 1 EOL
20:07:34 <guillomovitch> who will take cares of the blog post ?
20:07:38 <sebsebseb> Atelier
20:07:49 <guillomovitch> for the notes
20:07:56 <Schultz> can someone email the atelier list with requirements please
20:08:20 <sebsebseb> Schultz: I think that's for us to sort out as a team really,  with Anne and rda etc
20:08:36 <guillomovitch> sebsebseb: you're volonteer here ?
20:08:43 <sebsebseb> guillomovitch: I am on that team
20:08:56 <guillomovitch> #action sebsebseb will take cares of blog post about EOL
20:09:01 <Schultz> yep, but it is a technical issue, qa need to give input as we dont know the technicalities of the upgrade path for this
20:09:04 <sebsebseb> guillomovitch: uh no not quite
20:09:18 <sebsebseb> MrsB about?
20:09:26 <Luigi12_work> QA shouldn't need anything special
20:09:40 <sebsebseb> guillomovitch: change the action  to Atelier and that's ok :d
20:09:49 <Luigi12_work> once they push the last update for mga1, they'll just know that they won't have anything to test for it anymore
20:09:51 <guillomovitch> is 'atelier' someone in particular ?
20:09:56 <sebsebseb> that's the name of the team
20:10:04 <guillomovitch> ok, sorry for my ignorance
20:10:05 <sebsebseb> the merge of the former Marketing and communications, artwork, and webteam
20:10:12 <sebsebseb> into one team
20:10:14 <guillomovitch> #action the atelier team will take cares of blog post about EOL
20:10:33 <guillomovitch> can we switch to next topic now ?
20:10:36 <sebsebseb> packagers will ignore Mageia 1 after 1st December heh heh
20:10:55 <Schultz> is there anything technical that atelier need to include?
20:11:07 <Luigi12_work> links to instructions on how to upgrade to Mageia 2
20:11:12 <Luigi12_work> should be something on the wiki somewhere
20:11:16 <sebsebseb> Schultz: probably just need a blog post like the one from earlier this month,  that was a reminder of it going EOL
20:11:57 <guillomovitch> #topic Duckduckgo integration
20:12:24 <guillomovitch> ennael sent a mail about it on -dev today
20:12:25 <sebsebseb> guillomovitch: you know about this one? I do
20:12:39 <AL13N> (21:07:16) AL13N: guillomovitch: i saw your post about the integration, and i sort of agree with you
20:12:39 <AL13N> (21:07:30) AL13N: but, it wasn't clear to me if this was just ADDED or default?
20:12:53 <pterjan> I am quite against giving more work to qa for it, but don't really care if it is integrated in a existing update
20:12:54 <sebsebseb> Duck Duck Go will be an option in browsers in Mageia
20:12:56 <sebsebseb> not default
20:13:23 <sebsebseb> so the browsers need some updating, as part of the revenue share as well
20:13:41 <Luigi12_work> are we forced to issue updates for mga2 for this, or can this change take effect as of mga3?
20:13:44 <AL13N> ok, let's agree not to have a specific browser update only for this
20:13:53 <guillomovitch> how are we supposed to get big bucks, if that's not the default :) ?
20:14:05 <sebsebseb> and  the Duck Duck Go intregation might go into Mageia 2 as well, not sure about that one though
20:14:10 <Luigi12_work> didn't the default get switched to ask.com when we were still Mandriva?
20:14:29 <pterjan> Luigi12_work: but i don't want mageia to select the default for financial reasons
20:14:45 <AL13N> iinm we mentioned a while ago that we would keep as close to upstream as possible if it was unneeded
20:14:47 <sebsebseb> it was explained  in  yesterdays council meeting how things would work:
20:14:48 <Luigi12_work> I have no strong feelings about that
20:14:48 <malo> sorry I'm late
20:14:49 <pterjan> if people pefer duck duck go it should be the default
20:14:54 <sebsebseb> http://meetbot.mageia.org/mageia-meeting/2012/mageia-meeting.2012-11-19-20.10.html
20:14:55 <[mbot> [ #mageia-meeting Meeting ]
20:14:56 <pterjan> not for financial reasons
20:15:10 <Luigi12_work> sebsebseb: can you give a quick summary?
20:15:13 <sebsebseb> http://meetbot.mageia.org/mageia-meeting/2012/mageia-meeting.2012-11-19-20.10.log.html#l-218
20:15:14 <[mbot> [ #mageia-meeting log ]
20:15:36 <sebsebseb> the browser header or whatever, when peopel have selected Duck Duck Go them selves
20:15:39 <Schultz> financial or not, the search engine is rather easy to change these days so the impact either way will be small
20:15:42 <sebsebseb> needs a update, to say the search was done from Mageia
20:15:58 <sebsebseb> and then Mageia will get some revenue share money as a result basically
20:16:16 <pterjan> Schultz: easy but people don't care
20:16:17 <sebsebseb> copied from the log:
20:16:21 <sebsebseb> 21:30:22 <ennael> "Please add https://duckduckgo.com/?q={{search}}&t=mageia to all the
20:16:22 <[mbot> [ {{search}} at DuckDuckGo ]
20:16:22 <sebsebseb> 21:30:22 <ennael> browsers distributed with Mageia.  This will help us count the number of
20:16:23 <pterjan> (most of people)
20:16:24 <sebsebseb> 21:30:23 <ennael> requests coming from Mageia for revenue share."
20:17:04 <Luigi12_work> ok, well I don't think the firefox or konqueror maintainers are here, this concerns them I guess
20:17:30 <guillomovitch> so, we can't decide much on this issue
20:17:46 <guillomovitch> excepted that there seems quite a clear consensus about not delivering an update
20:17:47 <sebsebseb> no, bu some packages have to be updated for this
20:17:50 <sebsebseb> browsers I mean
20:17:50 <guillomovitch> just for this reason
20:18:06 <sebsebseb> also MrsB suggested that maybe the update could be done like a security update
20:18:08 <Luigi12_work> sebsebseb: yes, but like I said the maintainers to do that work aren't here at the moment
20:18:11 <sebsebseb> instead of providing a specific update
20:18:16 <guillomovitch> :maint firefox
20:18:17 <Sophie> guillomovitch: For Mageia (firefox): dmorgan
20:18:23 <Luigi12_work> you mean in a security update, not as a separate one sebsebseb
20:18:34 <sebsebseb> Luigi12_work: yeah I guess
20:18:47 <Luigi12_work> firefox seems to be mostly dmorgan and tv working on it, and konqueror is neoclust and mikala
20:19:09 <sebsebseb> yep the browser maintainers need to do whatever with this one it seems
20:19:11 <rindolf> There's also midori.
20:19:20 <Luigi12_work> what's midori?
20:19:20 <guillomovitch> so, we're expecting maintainers to do it in cauldron
20:19:25 <sebsebseb> also someone was wondering about Opera in the council meeting
20:19:30 <rindolf> Will this be an issue with Firefox's trademarks policy?
20:19:37 <sebsebseb> Midori is a webkit browser
20:19:39 <pterjan> do we have a cpan module to search duckduckgo ? :P
20:19:48 <Luigi12_work> is midori the default for one of the desktop environments?
20:19:54 <sebsebseb> no don't think so
20:19:59 <sebsebseb> except for LXDE maybe?
20:20:02 <guillomovitch> http://search.cpan.org/~getty/App-DuckDuckGo-0.006/
20:20:03 <[mbot> [ Torsten Raudssus / App-DuckDuckGo-0.006 - search.cpan.org ]
20:20:12 <sebsebseb> or I think the idea was to have maybe for LXDE by default, dont' know
20:20:15 <Luigi12_work> I imagine we only need to be concerned about the default browsers, not every single third party one
20:20:24 <Schultz> no, if we go down small things, then we have arora, rekonq.....
20:20:33 <guillomovitch> lynx ?
20:20:37 <guillomovitch> telnet ?
20:20:37 <Luigi12_work> yeah that seems overkill for very little benefit
20:20:38 <sebsebseb> Luigi12_work: yeah I guess
20:20:39 <Luigi12_work> :o)
20:20:43 <sebsebseb> the default ones
20:20:54 <sebsebseb> and Opera can't be changed much anyway I guess, and might be using a  DDG thing itself
20:21:06 <sebsebseb> more about that in the council meeting log
20:21:12 <Luigi12_work> might be against license agreement to change opera anyway
20:21:28 <guillomovitch> well, if the  council already discussed it, what are we supposed to do now ?
20:21:38 <sebsebseb> packagers have to provide updates to the browsers
20:21:40 <sebsebseb> that will have it
20:21:45 <Luigi12_work> I guess if it's announced on the mailing list, packagers will see it and do the work eventually
20:21:49 <guillomovitch> they are not present
20:21:58 <sebsebseb> guillomovitch: yep I know
20:22:06 <sebsebseb> they may end up reading the log of this meeting though :D
20:22:13 <guillomovitch> ok
20:22:18 <Luigi12_work> not sure there's much else to say about it now, now that we've gotten the word out
20:22:26 * sebsebseb won't be present for much longer either it seems, since going out soon
20:22:31 <guillomovitch> "dear package maintainers, if you are reading this, please update your packages in cauldron"
20:22:43 <guillomovitch> the plan is:
20:22:46 <Luigi12_work> :o)
20:22:59 <guillomovitch> - we expect maintainers take care of it in cauldron rioght now
20:23:08 <sebsebseb> yeah
20:23:13 <sebsebseb> I guess
20:23:24 <guillomovitch> - we wait for next security-motivated update for mageia2 to also backpot this change
20:23:33 <guillomovitch> is that OK for everyone ?
20:23:40 <Luigi12_work> actually please wait until *after* 10.0.11 update for mga2
20:23:45 <pterjan> ok for me
20:23:46 <sebsebseb> yep the brwoser thing is for Mageia 3, but I think probably 2 as well
20:23:48 <Luigi12_work> don't want this to hold up this update since it is needed now
20:24:08 <Luigi12_work> I will hopefully work on it tomorrow
20:24:12 <guillomovitch> #action firefox and konqueror maintainers are supposed to do the change in cauldron ASAP
20:24:26 <sebsebseb> ok going away from computer
20:24:27 <sebsebseb> now
20:24:47 <guillomovitch> #action secteam will wait for next security update to also backport those changes to mageia 2
20:25:09 <sebsebseb> yep seems good to me that :)
20:25:21 <guillomovitch> ok, next topic
20:25:39 <guillomovitch> #topic beta 1 release
20:25:55 <guillomovitch> I need someone else to introduce it
20:26:10 <Luigi12_work> think that was on the topics as there are things to be done before beta1
20:26:30 <Luigi12_work> like mass rebuild (tmb), finish integrating update capability and grub2 in installer (colin + tv), plus some other things maybe
20:26:49 <Luigi12_work> possibly some of the other features are supposed to be at a certain state
20:27:03 <Schultz> aim was to have artwork as well, but I don't really see that happening
20:27:10 <Luigi12_work> ahh yes and artwork
20:27:14 <guillomovitch> coling: ping ?
20:27:17 <coling> guillomovitch, pong
20:27:30 <sebsebseb> Grub 2 by default :)  new artwork for Beta 2 and right I am going afk now
20:27:35 <guillomovitch> can you enlighten us about the status of "finish integrating update  capability and grub2 in installer (colin + tv
20:27:38 <guillomovitch> "
20:27:55 <coling> guillomovitch, not really. I'm afraid I don't know much/anything about grub2
20:28:03 <coling> :)
20:28:06 <guillomovitch> hint: it is a bootloader :)
20:28:17 <Luigi12_work> coling: in general, what did you hope to finish before beta1?
20:29:11 <coling> But the update bit is mostly complete. I want to test some more about issues relating to mounting /usr when it's on a separate LVM which I had issues with during previous testing, but this is actually not related to usrmove specificially as it would cock up any other upgrade anyway AFAICT
20:29:46 <coling> I'm certainly not going to have time to look at moving installer to systemd so will likely abandon that one until mga4
20:29:48 <sebsebseb> Grub 2 is planned for Beta 1 by default
20:30:05 <guillomovitch> is anyone one actually working on it ?
20:30:12 <guillomovitch> or is it just "planned" ?
20:30:29 <ennael> sorry back on line
20:30:30 <ennael> phew
20:30:32 * guillomovitch likes magic planification
20:30:38 <barjac> AFAIK tv is doing something on integration
20:30:47 <ennael> grub2
20:30:55 <barjac> yes
20:31:08 <ennael> we have the package ready and tested for some time now in cauldron
20:31:21 <ennael> tv is working on installer but still some pb with it
20:31:34 <Luigi12_work> heard ROSA developers say last week that it's pretty much done on their end now
20:32:18 <ennael> have to check but some days before tv had a look and there was not much ready
20:32:27 <Luigi12_work> was he checking git?
20:32:31 <guillomovitch> cool, we won't have any issue with /usrmove
20:32:35 <Luigi12_work> apparently they don't use the "master" branch in git
20:32:42 <guillomovitch> because we won't even be able to pass the bootloader stage...
20:32:45 <Luigi12_work> everything is in the 2012.1 branch
20:33:03 <ennael> guillomovitch: if it's not ready it will not be integrated
20:33:21 <guillomovitch> so, what's the deadline ?
20:33:24 <ennael> Luigi12_work: I will give this information
20:33:37 <ennael> should be end of next month the latest
20:34:21 <guillomovitch> ok, that's work in progress
20:34:37 <pterjan> that gives me enough time to start a lilo2 project
20:34:43 <guillomovitch> #info grub2 integration deadline is planned to end of december
20:35:03 <guillomovitch> #info pterjan is busy with a new shiny lilo2 project
20:35:15 <guillomovitch> next stuff to plan before beta 1 ?
20:35:58 <guillomovitch> coling: I understand than /usrmove migration issue is pretty much solved, right ?
20:36:24 <Luigi12_work> we still haven't pushed an update for mga2 rpm so that urpmi updates can work IINM
20:36:29 <coling> guillomovitch, pretty much I think yeah.
20:36:41 <coling> guillomovitch, still some path related tidyups I guess.
20:36:48 <coling> But nothing major
20:37:02 <guillomovitch> when is this urpmi update planned ?
20:37:17 <guillomovitch> before finale release, or before first beta ?
20:37:28 <Luigi12_work> hopefully before beta so QA can test upgrades
20:37:46 <guillomovitch> mageia2 -> mageia3 upgrades, right ?
20:37:52 <guillomovitch> sorry
20:37:53 <Luigi12_work> yep
20:38:00 <guillomovitch> mageia2 -> mageia3 beta 1 upgrade
20:38:02 <Luigi12_work> via urpmi or mgaonline
20:38:20 <guillomovitch> not an urpmi update, btw
20:38:25 <Luigi12_work> apparently it won't work without updating rpm in mga2 first, which is in updates_testing
20:38:36 <coling> Whenever it's ready really. I have some uncommitted changes to push to it to not depend.
20:38:55 <DavidWHodgins> Also mageia-prepare-upgrade has to be installed.  It currently is not required by anything, so must be selected manually.
20:39:14 <guillomovitch> well, there is a decision needed here
20:39:17 <Luigi12_work> looks like fedora has punted on the issue and removed upgrade support from their installer altogether, they'll handle it with a separate tool now
20:39:30 <coling> Luigi12_work, that should be pushed as an update.
20:39:31 <guillomovitch> if we want mageia2 -> mageia3 beta 1 upgrade path, we need it
20:39:38 <Luigi12_work> coling: yes, but when?
20:39:58 <guillomovitch> is this achievable with current schedule ?
20:40:04 <coling> Luigi12_work, soon... Myself and tmb discussed it a while back but then forgot :s
20:40:34 * guillomovitch heard fedora removed a lot of stuff from their installer recently :)
20:40:50 <coling> I'll ping tmb about it and open an update bug. /me has been crappy at pushing this officially.
20:41:05 <guillomovitch> ennael: when is beta 1 expected precisely ?
20:41:24 <coling> And yes I'm not sure how to pull in the mageia-prepare-update package automatically.
20:41:33 <ennael> 2012 Dec. 12th
20:41:37 <coling> Other than via "insttructions"
20:41:46 <coling> or "instructions" even :)
20:41:48 <guillomovitch> coling: having the rpm update requires it ?
20:41:56 <guillomovitch> as it seems to be mandatory anyway ?
20:42:08 <coling> guillomovitch, hmm, bit hack, but yeah that might work :)
20:42:22 <pterjan> ennael: 12/12/12
20:42:22 <oden> will mga2 -> mga3 upgrade yiu mean?
20:42:23 <guillomovitch> I mean, if we push rpm just to make upgrade possible...
20:42:27 <coling> guillomovitch, I'd rather it required the new rpm tho'.
20:42:30 <oden> will mga2 -> mga3 upgrade you mean?
20:42:45 <guillomovitch> right
20:42:51 <ennael> pterjan: an evil release
20:42:59 <Luigi12_work> 12/12/12 seems ambitious for beta1 if a full rebuild is planned before.  There will be a lot of packages to fix which will take some time.
20:42:59 <guillomovitch> right now, that's even "mga2 -> mga3 beta 1"
20:43:07 <coling> oden, yeah it'll upgrade, but you'll need to install a special "prepare" pkg and reboot first.
20:43:16 <coling> brb phone
20:43:41 <oden> coling: ah, looked at tjhat package today but understood zip, nada.
20:43:44 <guillomovitch> the coward
20:43:47 <guillomovitch> he fleed
20:44:09 <guillomovitch> we need a deadline here
20:44:38 <guillomovitch> if we can't satisfy this update issue, we just won't have an upgrade-ready beta
20:45:08 <ennael> then we should postpone beta
20:45:15 <AL13N> or we'd have to scratch grub2 feature or /usrmove feature
20:45:17 <guillomovitch> that's another option
20:45:39 <Luigi12_work> UsrMove isn't scratchable
20:45:45 <ennael> AL13N: not the same people working on these features
20:45:46 <Luigi12_work> not without a lot of work in packages reverting it
20:45:57 <guillomovitch> so, this is a blocking issue for beta
20:45:58 <oden> require the boot entry in the installed grub config to continue the install/upgrade?
20:47:00 <guillomovitch> #info a clean upgrade path from mageia2 is a prerequisite for beta 1 release
20:47:12 <coling> (shouldn't be a big issue)
20:47:17 * coling is still on phoen
20:48:02 <guillomovitch> #info it should be achieved by pushing rpm and another package to mageia2 updates
20:48:11 <coling> Only issue is making it super user friendly - .e. g some way to get the pkg installed easily and let the user know they need to reboot into the new entry once before upgrading.
20:48:11 <guillomovitch> #action coling is taking care of it
20:48:31 <guillomovitch> coling: use 'reboot' in %post ?
20:48:38 <guillomovitch> pretty evil, indeed
20:48:43 <coling> guillomovitch, rebootin even :)
20:48:56 <guillomovitch> ok, next issue: mass rebuild
20:48:58 <malo> the upgrade should fail with a message saying to reboot, no?
20:49:31 <guillomovitch> some README.urpmi file should be enough ere
20:49:49 <guillomovitch> for post-installation instructions displaying
20:50:10 <malo> guillomovitch: it's easy to miss though
20:50:14 <coling> I can also make the package provide a "should-restart" IIRC
20:50:36 <coling> e.g. trigger a "You should reboot your system for ..." message
20:50:48 <coling> But yes a README.urpmi is also very desirable.
20:51:16 <guillomovitch> as tmb isn't there
20:51:32 <guillomovitch> does anyone knows about the mass rebuild status ?
20:51:43 <guillomovitch> or rather feasability ?
20:51:46 <ennael> nope I hoped to see tmb this evening
20:52:07 <ennael> looks like it's all doable but we need tmb feedback
20:52:07 <guillomovitch> #info tmb input needed about mass rebuild
20:52:28 <guillomovitch> can I edit previous #info statements ?
20:52:38 <AL13N> i think only one
20:52:46 <ennael> #undo for the last one
20:52:47 <malo> please use the opportunity of the mass rebuild to change the RPM groups beforehand (otherwise many will fail)
20:52:54 <guillomovitch> #undo
20:52:54 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Info object at 0x844002c>
20:53:10 <guillomovitch> #action ennael will look after tmb feedback about mass rebuild
20:53:12 <Luigi12_work> malo: you should send a mail to the list about what packages still need fixed then asap
20:53:29 <malo> Luigi12_work: there are still hundreds ...
20:53:34 <guillomovitch> ouch...
20:53:57 <malo> but I will send a reminder email
20:53:58 <Luigi12_work> well they won't get fixed unless someone fixes them, which won't happens unless someone knows they need fixed
20:54:00 <Luigi12_work> ok
20:54:49 <guillomovitch> tv was once able to perform
20:55:04 <guillomovitch> large spec file changes at onee
20:55:21 <pterjan> he had a svn checkout of all .spec
20:55:25 <guillomovitch> from a global svn checkout
20:55:35 <pterjan> actually easier now that tarballs are outside
20:55:39 <guillomovitch> isn't this the perfect use case ?
20:55:53 <malo> the problem with RPM groups is that it's not just a simple renaming ...
20:56:11 <guillomovitch> ah, we need intelligence too ?
20:56:14 <guillomovitch> we're dommed
20:56:16 <guillomovitch> doomed
20:56:20 <malo> it's Video -> Video/Player or Video/Editor and so on ...
20:56:29 <malo> yep :-)
20:56:47 <malo> We should put the packager apprentices on it ...
20:56:57 <malo> the ones with svn access
20:57:00 <malo> no?
20:57:13 <guillomovitch> what about the guy broking the group list fixing it :) ?
20:57:31 <coling> :p
20:57:39 <barjac> 30mins argument per package X 100 pkgs = 50 hours :\
20:57:45 <Luigi12_work> it would be nice, since it will hold up those packages being able to rebuild
20:57:48 <guillomovitch> but yes, that would be some good exercise for apprentices
20:57:50 <malo> I'll fix as many packages as I can ;-), but it's the middle of the term, so I have a bit less time
20:57:51 <Luigi12_work> it doesn't take 30 minutes to change an rpm group
20:58:09 <coling> If a map can be built it would make it easier to do a mass change.
20:58:19 <Luigi12_work> lol, sick some apprentices on your homework assignments...
20:58:19 <coling> Some creative scripting might be in order?
20:58:23 <guillomovitch> Luigi12_work: especially with a random new one...
20:58:25 <Luigi12_work> err your grading
20:58:37 <malo> Luigi12_work: that's what we do in academia :-)
20:58:39 <coling> Luigi12_work, it takes 30 mins to "argue about it" :)
20:58:52 <barjac> Luigi12_work: that's the discussion time yes ;)
20:58:59 <Luigi12_work> heh, I don't argue, I change the group to whatever malo tells me
20:59:05 <guillomovitch> perl -pi -e 's/Group: .*/Group: Tool/ *.spec
20:59:24 <malo> guillomovitch: you wish ...
20:59:32 <guillomovitch> perl -pi -e 's/Group: .*/Group: `malo`/ *.spec ?
20:59:36 <coling> Everything is a Tool. Genius :)
20:59:55 <guillomovitch> ok, do we need someone to coordinate/handle it ?
21:00:05 <malo> I coordinate the RPM group already
21:00:18 <malo> but tmb should coordinate the rebuild
21:00:57 * Luigi12_work needs to talk to tmb about a couple things before the rebuild too
21:01:32 <guillomovitch> #action malo is taking care of fixing package group, using apprentices as slav^H^Hintern^H^Hworkforce
21:02:09 <guillomovitch> is the mass rebuild a mandatory prerequisite for beta 1 too ?
21:02:23 <guillomovitch> or can it be delayed for beta2 if needed ?
21:02:42 <Luigi12_work> don't think so, but tmb wanted to get it done.  It might take a lot of time to fix broken packages though, so we shouldn't delay it too much if we're gonna do it.
21:02:51 <Luigi12_work> otherwise we can wait until after mga3
21:03:05 <leuhmanu> it was planned for the alpha3 but was missed
21:03:15 <leuhmanu> or nobody take it
21:03:26 <guillomovitch> and is likely to be missed for beta1 too, given current schedule
21:03:34 <Luigi12_work> true
21:04:13 <leuhmanu> iirc tmb will have a look, but I don't know if he had time
21:04:19 <malo> it'd be good if it can be started before beta1
21:04:38 <guillomovitch> #info mass rebuild should preferentially be done before beta1, but given the number of packages to fix before, can eventually be postponed to beta2
21:04:51 <guillomovitch> does it sounds OK for everyone ?
21:05:24 <Luigi12_work> also, just wanted to note that ROSA recently did mass rebuild and fixed almost all of their packages
21:05:39 <Luigi12_work> so looking at their stuff might help fix our broken ones when the time comes, possibly
21:06:10 <guillomovitch> rosa means mandriva here, right ?
21:06:34 <Luigi12_work> essentially, the distros are basically merging
21:06:41 <Luigi12_work> abf.rosalinux.ru/import is the URL for their GIT
21:06:58 <Luigi12_work> 2012.1 branch is where all the updated work is
21:07:15 <Luigi12_work> but yes it's just forked from Cooker about 6 months ago or so I think
21:07:39 <guillomovitch> ok, anything else to plan for beta 1 release ?
21:07:47 <guillomovitch> #info beta 1 is planned for 12/12/12
21:08:11 <guillomovitch> or 0xC/0xC/0xC if you prefer
21:08:34 * guillomovitch hungry and willing to close the meeting
21:08:51 <Luigi12_work> yay
21:09:09 <guillomovitch> ennael: anything else ?
21:09:20 <barjac> I think mass rebuild will be chaos and will take longer than predicted.
21:09:57 <ennael> nope
21:10:06 <leuhmanu> people which have time can check blocker_bugs
21:10:17 <leuhmanu> ,buglist P1
21:10:18 <[mbot> https://bugs.mageia.org/buglist.cgi?quicksearch=P1
21:10:39 <guillomovitch> #info people which have time can check blocker_bugs (https://bugs.mageia.org/buglist.cgi?quicksearch=P1)
21:10:58 <guillomovitch> NetworkManager spawns a wpa_supplicant instead even if interface is unmanaged, conflicting with drakx-net tools
21:11:01 <guillomovitch> ouch
21:11:28 <guillomovitch> this is true for ages, and will probably last until we get rid of one of them
21:11:41 <AL13N> NM can go
21:11:46 <AL13N> :-)
21:11:46 <leuhmanu> yes some should not be here, some are missing
21:12:01 <barjac> leuhmanu: But if maintainers don't react what then? Will people get upset if someone else jumps in to fix it?
21:12:16 <AL13N> well, time to make a list with mga4 and move all those away from that list into mga4
21:12:17 <leuhmanu> I don't know.
21:12:30 <leuhmanu> AL13N: we have said for mga2
21:12:35 <leuhmanu> +that
21:12:45 <leuhmanu> for some lvm bugs
21:12:54 <guillomovitch> #closemeeting
21:13:00 <guillomovitch> not the right one...
21:13:03 <guillomovitch> #help
21:13:04 <leuhmanu> endmeeting
21:13:09 <guillomovitch> #endmeeting