20:09:53 <ennael> #startmeeting
20:09:53 <Inigo_Montoya`> Meeting started Tue Nov  6 20:09:53 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:09:53 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:10:01 <ennael> #chair guillomovitch
20:10:01 <Inigo_Montoya`> Current chairs: ennael guillomovitch
20:10:32 <guillomovitch> #help
20:10:45 <ennael> people around ?
20:11:05 <DavidWHodgins> Lurking. :-)
20:11:20 <MrsB> morning
20:13:48 <rindolf> ennael: I am.
20:14:24 <ennael> ok let start then
20:14:45 <ennael> #topic faac in Mageia
20:14:51 <ennael> guillomovitch: your turn
20:15:18 <guillomovitch> well, I think everyone is aware of the cauldron discussion
20:15:49 <guillomovitch> basically, they are four options:
20:15:56 <guillomovitch> - doing nothing new
20:16:10 <guillomovitch> - distribute faac in the non-free repository
20:16:21 <guillomovitch> - distribute faac in the tainted repository
20:16:26 <guillomovitch> - create a new repository
20:16:50 <guillomovitch> most people seems to agree we'd better change the current situation
20:17:29 <guillomovitch> we have 50% people agreeing for either scenarios 2 or 3
20:17:41 <guillomovitch> provided we relax the rules a little bit in our documentation page
20:18:15 <guillomovitch> and we have people convinced than we absolutly need yet another package repository for this (currently) single package
20:19:39 <guillomovitch> then Christian also made a remark
20:19:45 <guillomovitch> than even if we distributed faac
20:20:03 <guillomovitch> they would be some legal concerns distributing software linked against it...
20:20:54 <guillomovitch> because there seems to be prohibited to distribute GPL code linked against non-free code
20:21:22 <guillomovitch> I'm not convinced, but I'm not a laywer
20:21:26 <guillomovitch> lawyer
20:21:51 <guillomovitch> so basically, the current questions are:
20:21:59 <guillomovitch> - is this legal problem true ?
20:22:51 <guillomovitch> - and if true, is there any interest to solve a painful question for a limited interest ?
20:23:10 <guillomovitch> does it seems a good summary :) ?
20:23:20 <Solbu> yes. :-)=
20:23:43 <guillomovitch> btw, there seems to be work-in-progress for aac coded support in ffmpeg
20:23:44 <DavidWHodgins> If nonfree programs  are not allowed to be *linked* against gpl libraries, then programs such as opera would be illegal too.
20:24:02 <guillomovitch> DavidWHodgins: i'm sure they can't
20:24:12 <guillomovitch> they can only link against LGPL ones, AFAIK
20:24:19 <guillomovitch> but here, we're in the reverse situation
20:24:36 <Solbu> david_david: They aren't. that's why the LGPL license was invented.
20:24:43 <guillomovitch> 'linking' is an asymetric association
20:24:46 <Solbu> Baah, should be DavidWHodgins..
20:25:04 <guillomovitch> between an executable and a library
20:26:00 <guillomovitch> we all know than non-free code can not benefit from gpl code
20:26:15 <guillomovitch> but here we're in the opposite situation
20:27:02 <guillomovitch> can gpl code benefit from non-free one ?
20:27:56 <rindolf> guillomovitch: can we ask for advice from the Software Freedom Law Center (SFLC)?
20:28:15 <guillomovitch> sure, if someone volonteers to do it
20:28:27 <Solbu> rindolf: Good idea.
20:28:41 <tmb> http://www.gnu.org/licenses/gpl-faq.html#GPLIncompatibleLibs
20:29:36 <guillomovitch> tmb: basically, it says: you can allow it, if you're the software author
20:29:50 <rindolf> guillomovitch: I guess I can try phrasing a query with help from the mailing list.
20:30:08 <tmb> "If you want your program to link against a library not covered by the system library exception, you need to provide permission to do that"
20:30:16 <guillomovitch> faac is definitively not a system library
20:30:35 <guillomovitch> I guess the cinerella authors, who provided explicit faac support
20:30:51 <guillomovitch> did it implicitely
20:31:15 <guillomovitch> and we may eventually ask them for a more formal formulation
20:32:03 <guillomovitch> so, the plan is: have rindolf ask the SFLC
20:32:19 <tmb> " You have to get the approval of the copyright holders of those programs."
20:32:20 <guillomovitch> and eventually, ask the cinerella authors second if needed
20:32:48 <guillomovitch> I hope they qualify as copyright holders...
20:33:18 <guillomovitch> does this plan sound sensible enough ?
20:33:29 <Solbu> If not, they can hopelully tell us who to contact.
20:33:47 <guillomovitch> well, I won't run after authors endlessly personnaly
20:33:58 <guillomovitch> I already built cinerella at home :)
20:34:03 <Solbu> :-)=
20:34:07 <Solbu> This sounds like a good plan.
20:34:28 <tmb> I think that's the way to start, yes
20:34:55 <guillomovitch> let's see the distribution issue later, once we are sure it's worth the pain
20:35:30 <ennael> so can we sum up all this ?
20:35:38 <MrsB> even blender can save as aac, there are a number of programs affected. If it's necessary to contact each one and ask explicit permission it would be a pain.
20:35:46 <guillomovitch> #action rindolf ask the SFLC about distributing a GPL software (cinerella) linked against non-GPL code (libfaac)
20:35:53 <Solbu> Does SFLC charge for providing advice? If so, who should pay? (I'm not familiar with asking law firms for advice)
20:36:06 <guillomovitch> we can't pay
20:36:20 <guillomovitch> isn't aac an audio codec only ?
20:36:34 <Solbu> yes.
20:36:34 <MrsB> afaik yes
20:36:36 <rindolf> Solbu: http://www.softwarefreedom.org/about/contact/
20:36:53 <Solbu> Think it stands for Advanced Audio Coded
20:36:56 <guillomovitch> let's try to have a generic answer first on this issue
20:37:16 <guillomovitch> we'll have a cost estimation for each specific case second
20:37:30 <rindolf> FAAC is an encoder and is non-free. FAAD is the decoder and it is free.
20:37:49 <guillomovitch> #action guillomovitch see with cinerella authors for an exception if needed once we have SFLC answer
20:38:41 <guillomovitch> #agreed let's discuss faac distribution issue later, if it's worth the effort
20:39:11 <ennael> what deadline for all this ?
20:39:24 <guillomovitch> christmas :) ?
20:39:33 <ennael> :)
20:39:44 <tmb> I guess that depends on when we get responses :)
20:39:56 <ennael> well we need to fix a limit for mageia 3
20:40:02 <Solbu> What about , say, a week or two after rindowl get his answers?
20:40:02 <ennael> to avoid last minute integration
20:40:32 <guillomovitch> I guess we're off-limit for mageia 3
20:41:04 <Solbu> guillomovitch: I had the same thought.
20:41:12 <guillomovitch> excepted maybe for the ffmpeg alternative
20:41:26 <guillomovitch> but as Christian said, cinerella was notably instable this way
20:41:40 <ennael> just to give some answer to people and avoid somebody does it
20:41:46 <guillomovitch> the 'full-free software alternative that sucks'
20:42:16 <guillomovitch> I'd say: don't expect a quick solution right now
20:42:25 <Solbu> Doesn't most Free software suck in the beginning? :-)=
20:42:58 <guillomovitch> end of month then
20:43:13 <guillomovitch> we're at beta3 right now, afaik
20:43:25 <tmb> alpha3
20:43:37 <Solbu> Yes. Sounds like a good deadline.
20:43:58 <MrsB> final isn't until march next year
20:44:10 <guillomovitch> there won't be much side effect for software not present in the distribution right now anyway
20:45:05 <guillomovitch> #agreed let's consider 1 december as deadline for mageia3 integration
20:45:33 <Solbu> If we're done with faac for todays meeting, I need to go.
20:45:56 <guillomovitch> I think so
20:46:09 <guillomovitch> next point ?
20:46:11 <rindolf> Solbu: bye.
20:46:13 <ennael> is it all ok about that topic ?
20:46:26 <ennael> guillomovitch: can you sum up all this in a mail for -dev ML ?
20:46:30 <guillomovitch> sure
20:46:37 <ennael> thanks
20:46:50 <ennael> #action guillomovitch will mail -dev to explain these steps
20:47:46 <Solbu> see you later tonight. Enjoy the rest of the meeting. :-)=
20:47:52 <ennael> ok next topic then
20:47:53 * guillomovitch hungry
20:48:06 <ennael> :)
20:48:10 <ennael> #topic Mageia 1 EOL
20:48:10 <tmb> (sounds familiar)
20:48:43 <ennael> so we have a blog post to inform about EOL for Mageia 1
20:48:54 <ennael> thanks to tmb
20:49:06 <ennael> we plan to have also one in 2 weeks to remind it
20:50:07 <ennael> http://www.mageia.org/fr/support/ is now up to date
20:50:28 <ennael> Mageia 1 will be supported until December 1st, 2012.
20:52:16 <ennael> any comment on this ?
20:53:03 <DavidWHodgins> Some people would prefer to have Mageia 1 supported at least until 3 is out.
20:53:04 <MrsB> \o/
20:53:12 * MrsB isn't one
20:53:19 <ennael> DavidWHodgins: decision has been taken there will be no change
20:53:26 <DavidWHodgins> Ok
20:53:37 <ennael> it's also a question of work load for QA
20:54:11 <DavidWHodgins> Which is why I personally am glad to see it ending. :-)
20:54:57 <ennael> Qa is already adding comment on Bugzilla to warn people about EOL
20:55:24 <MrsB> bugsquad
20:56:20 <ennael> oups sorry
20:56:26 <rindolf> I'm fine with terminating support for Mag 1.
20:57:20 <Luigi12_work> :o(
20:57:38 <ennael> ok
20:57:50 <ennael> #topic Mageia 3 alpha 3 release
20:58:40 * coling is late sorry... feel free to ping me after if there was anything I was needed for.
20:58:41 <AL13N> (i would prefer mageia 2 or mageia 3 to be LTS'd)
20:58:52 <AL13N> (not mga1)
20:59:12 <ennael> so alpha3 isos tests are in progress
20:59:45 <tmb> AL13N: so join QA to help out
21:00:00 <ennael> MrsB: want to give a sum up about current tests ?
21:00:20 <MrsB> can do if you like
21:00:29 <ennael> thanks :)
21:00:49 <MrsB> We're now on the first build of the ISOs.
21:01:08 <MrsB> We've found a small number of big bugs
21:01:20 <MrsB> Libroeffice missing due to build problems
21:01:34 <MrsB> some people have had problems with X starting at boot
21:01:47 <MrsB> some gnome problems
21:01:58 <MrsB> overall it's looking pretty good
21:02:15 <MrsB> I believe there are new ISOs due tonight/tomorrow
21:02:51 <MrsB> If you'd like to get involved with the testing please contact myself, ennael or tmb
21:02:59 <MrsB> :)
21:03:17 <ennael> thanks MrsB :)
21:03:23 <MrsB> np
21:03:24 <ennael> tmb: anything else to add there ?
21:04:51 <ennael> (except pizza :p)
21:05:03 <tmb> nope, not really. most of the bugs regarding livecds should be somewhat easy solvable by working around a painful urpmi bug
21:06:16 <ennael> ok
21:06:35 <ennael> as a reminder also please guys do not provide major updates while alpha3 is not out
21:06:55 <ennael> or you will be burnt by tmb, QA guys and me :)
21:06:57 <guillomovitch> girls are not affected ?
21:07:04 <AL13N> :-)
21:07:14 <grenoya> \o/
21:07:20 * guillomovitch will delegate package submission
21:07:21 <ennael> guillomovitch: we try to be kind with them, they are too few :)
21:07:25 <AL13N> i guess the girls won't do it because they know better
21:07:44 <tmb> (or dont know how)
21:07:47 * tmb hides
21:07:56 * ennael slaps tmb
21:08:10 <ennael> #topic Main features review
21:08:22 <ennael> ok let see features there
21:08:30 <ennael> coling: around ?
21:08:43 <coling> ennael, yup
21:08:57 <ennael> want to sum up yours ?
21:09:14 <coling> Well I've forgotten most of them :)
21:09:28 <ennael> tsss
21:09:30 <coling> But in terms of usrmove, the installer should now run the conversion.
21:09:49 <coling> I still need to work on the "uprmi version" for upgrades that are run that way.
21:10:04 <coling> There did seem to be a bug in the installer however
21:10:27 <guillomovitch> so the feature is: the upgrade won't fuck up your system ?
21:10:30 <coling> For me I couldn't get it to mount my partitions on upgrade, so my separate /usr was never mounted and thus the conversion (and any install) failed.
21:10:47 <coling> guillomovitch, in theory.... ;p
21:11:15 <guillomovitch> interesting
21:11:46 <guillomovitch> anyway, my time allowance has run over, I've to leave
21:11:55 <guillomovitch> have a fine meeting
21:12:11 <coling> guillomovitch, but like I say this only applies to a net install via the installer at present. I'll try and get the mga2 version of the upgrade procedure ready this week/weekend.
21:12:30 <coling> Although as this does not technically depend on the isos etc. this shouldn't interfere.
21:12:53 <coling> In terms of "installer users systemd" feature, I've simply not had time to do this.
21:13:24 <coling> I still would like to do this eventually, but unless I get a spurt of development and have it ready for the betas I doubt it'll happen!
21:14:54 <ennael> ok people any other feedback on features ?
21:15:06 <coling> The boot sans ramdisk is also not really supported by the tools yet, and I've not even tested the tmb kernel that Thomas kindly sorted out to include some essential modules. I will likely do that during the final testing phases. It would be nice to get it working although it will need manual intervention to configure.
21:15:48 <tmb> well, you can boot without ramdisk even if tools creates one for you :)
21:16:22 <tmb> (not with core kernel, only with -tmb kernel for now)
21:18:29 <Luigi12_work> interesting.  IIRC the mdv version of the installer is still sysvinit
21:18:37 <coling> Indeed - still need to take it for a spin myself tho' :)
21:19:04 <coling> Luigi12_work, ours is not systemd yet either (tho' I think it was a custom init, not sysvinit)
21:19:27 <coling> Luigi12_work, as I mentioned above, I've simply not had time to look into this properly.
21:19:35 <Luigi12_work> yeah I imagine that will be a lot of work
21:19:48 <coling> Luigi12_work, probably not a crazy amount to be honest.
21:20:04 <coling> Just a bit fiddly and a lot of regenerations and reboots.
21:21:37 <rindolf> coling: can these be done with VMs?
21:21:55 <coling> rindolf, yeah, that's how I usually do it.
21:22:13 <rindolf> coling: OK.
21:22:34 <coling> rindolf, normally when messing with stage2 I just have a vm in a state that just about to download/execute stage2, but this particular work will also involved a new stage1
21:23:26 <coling> (i then just restore the vm to the snapshot and it's ready to go with the stage2 bit again - saves a lot of time - sorry kinda messed up the order of my description there...)
21:27:07 <rindolf> coling: OK.
21:29:57 <ennael> ok anything else for coling ? :)
21:30:41 <coling> ennael, not from me.
21:30:53 <ennael> ok
21:30:56 <MrsB> 3 cheers :)
21:31:09 <ennael> as a side note tv is working on implementing grub2 in installer
21:31:29 <ennael> still not ready so it will not be done for alpha3
21:31:38 <ennael> he will try to finalize it as soon as possible
21:31:56 <Luigi12_work> I think rosa has done work on that, so that might help
21:31:59 <ennael> also working on managing non-free repository in classical installer
21:32:13 <ennael> Luigi12_work: we had a look indeed but very few has been done
21:32:26 <Luigi12_work> ahh bummer :o(
21:32:31 <ennael> yep
21:32:35 <MrsB> there could be big changes then for beta 1
21:32:58 <ennael> could be as tv was overloaded these last weeks
21:33:23 <ennael> on my side I've started working on auto_install documentation
21:34:19 <AL13N> now that is a nice feature
21:34:27 <AL13N> definately something i can use
21:34:53 <ennael> anybody wants to add something ?
21:35:03 <ennael> we will ask trhough ML for all other features
21:35:17 <AL13N> well, i've started that refresh button thingie, but i don't have much time for it
21:35:27 <AL13N> not sure if i'm gonna make it in time
21:35:31 <ennael> hurry up :)
21:35:39 <AL13N> myeah :-/
21:35:52 <AL13N> need to do all the xen security patches first
21:36:00 <ennael> tmb: wants to add something ?
21:36:02 <MrsB> what refresh button thingie is that ?
21:36:02 <Luigi12_work> all 50 of them :O
21:36:20 <AL13N> i think the problem is that for alot of us that we are working on packages and whatnot and we don't have much time for features
21:36:29 <Luigi12_work> yeah :o(
21:36:48 <anaselli> well apanel is on svn
21:36:54 <tmb> well, the "forgotten" mga3 rebuild will be kicked off after alpha3...
21:36:54 <AL13N> MrsB: https://wiki.mageia.org/en/Feature:DiskDrakeRedesign
21:36:57 <Luigi12_work> cool anaselli
21:37:04 <anaselli> but does not so mutch at the moment
21:37:04 <MrsB> thanks
21:37:14 <Luigi12_work> tmb: wow, it's really gonna happen
21:37:23 <tmb> coling: you wanted some rpmlint rules in plave before that iirc ?
21:37:24 <AL13N> and i also want to help with #2137
21:37:25 * Luigi12_work prepares for lots of work fixing packages
21:37:25 * anaselli is arrived late :)
21:37:50 <Luigi12_work> tmb: we should also update ppl and cloog-ppl before the mass rebuild
21:37:53 <coling> tmb, Oh yeah... where does one add rpm lint rules?
21:38:01 <coling> tmb, the rules I would like:
21:38:11 <coling> 1. no files in /var/run or /run
21:38:34 * coling forgets 2.  It'll come to me :)
21:38:50 <Luigi12_work> 3. profit!
21:38:51 <tmb> coling: rpmlint-mageia-rules
21:39:07 <coling> tmb, cool, I'll try and learn what to do in a way that won't break the BS :D
21:39:32 <coling> I guess it would need pushed to infra anyway, so I'm sure it could be reviewed appropriately first :)
21:39:32 <AL13N> Luigi12_work: :-)
21:39:47 <coling> Or does it "just work" if pushed to cauldron?
21:40:00 <AL13N> iinm infra has different repos
21:40:10 <tmb> coling: nope, it needs to be pushed to infra, and explicitly installed
21:40:13 <MrsB> anaell congratulations on getting that done
21:40:21 <MrsB> anaselli: even^
21:40:42 <tmb> coling: what about the libexec macro ?
21:40:59 <leuhmanu> btw, whould be good to start reviewing release blockers bugs (for people which are on these bugs) if you have some time (don't know if it's the right topic if not sorry)
21:41:02 <anaselli> MrsB: well i worked more to libyui, and added some buttons :) the most is done bu tuxta
21:41:23 <MrsB> i congratulated tuxta earlier :)
21:41:35 <coling> tmb, ahh yes. Did we ever decide on what libexec should be?
21:41:36 <anaselli> but we need modules now to start having an usable tool
21:41:47 * coling remembers the discussion but not the outcome.
21:41:59 <coling> Did we think /usr/lib on both arches?
21:42:33 <anaselli> MrsB: then you've forgot pasmatt :)
21:42:35 <tmb> /usr/libexec was considered arch cleanest :)
21:42:52 <tmb> (since it already exists)
21:42:56 <MrsB> that won't do :\ congratulations pasmatt too :)
21:43:17 <anaselli> :)
21:43:24 <coling> tmb, OK, that works for me.
21:43:41 <coling> tmb, I suspect that could cause a few build failures :)
21:44:44 <tmb> yep, can be, but that's good to get done before full rebuild so all packages get "checked"
21:45:12 <pasmatt> MrsB anaselli you're very kind, tnx :)
21:46:24 <ennael> antyhing else?
21:46:41 <tmb> nope
21:47:12 <ennael> ok
21:47:17 <ennael> #topic Review of pending security updates
21:47:24 <ennael> Luigi12_work: your turn  \o/
21:47:37 <Luigi12_work> https://www.mageia.org/pipermail/mageia-dev/2012-November/019745.html is the most recent list
21:47:39 <[mbot> [ [Mageia-dev] Security updates - help needed (status update) ]
21:47:41 <ennael> as a reminder Luigi12_work sent a mail
21:47:42 <ennael> https://www.mageia.org/pipermail/mageia-dev/2012-November/019745.html
21:47:47 <Luigi12_work> otrs is fixed, the rest there are still relevant
21:47:48 <ennael> raaa too late
21:48:24 <Luigi12_work> basically we have not much time to fix any relevant to mga1, or they'll be vulnerable forever.  Also some are still relevant in cauldron, so we really should fix before mga3.
21:48:45 <Luigi12_work> I've done as many myself as I could, so really need help/input to finish the others.
21:49:38 <Luigi12_work> if anyone has any questions, don't hesistate to ask
21:50:01 <ennael> ok
21:51:56 <ennael> I will mail -dev about mentoring (avaialble mentors and apprentices)
21:53:53 <ennael> anything else to add ?
21:54:09 <sander85> to this topic or in general?
21:54:18 <ennael> both
21:54:44 <sander85> i have question about mga1 status on mirrors after eol
21:54:56 <ennael> wait
21:55:11 <ennael> #topic mga1 status on mirrors after EOL
21:55:19 <ennael> tmb: any answer about this ?
21:55:26 <sander85> are we going to have some archive?
21:55:52 <tmb> the idea is to keep it online, but frozen (even testing/backlorts medias)
21:56:17 <Luigi12_work> shouldn't testing be cleared once the last updates are pushed?
21:56:46 <tmb> Luigi12_work: yes, that will happend
21:57:27 <sander85> i think we should consider moving it to some other folder as well, not all mirrors can take it all, archive or something like that woulde be much easier to exclude imho
21:57:29 <tmb> there is no real need to move it to any "archive" status imho
21:58:04 <Luigi12_work> Mandriva had an /old or something for really old versions since they added up over time, but it's way too early for that
21:59:15 <tmb> yeah, we dont have so big distro tree anyway, so I think we can keep it as-is for now, unless mirror admins start to complain
21:59:36 <sander85> ok, sounds good to me
22:00:27 <ennael> anything else ?
22:00:56 <tmb> and if we do move it, we must do it with long notice before so mirror admins are ready (those that subscribe to the mirrors-announce ml that is)
22:00:58 * Luigi12_work hugs mga1 for dear life
22:01:40 <ennael> tmb: yep will avoid some hungry guys :)
22:02:21 <tmb> s/hu/a/ ..
22:02:21 * AL13N is hungry
22:02:31 <ennael> erf...
22:02:38 * ennael is hungry too :)
22:02:43 <ennael> so let's close this meetinr
22:02:44 <tmb> nothing else from me
22:02:45 <ennael> g
22:02:55 <ennael> thanks all for attending
22:03:14 <ennael> #endmeeting