19:18:04 <ennael> #startmeeting
19:18:04 <Inigo_Montoya> Meeting started Tue Sep 25 19:18:04 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:18:04 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:18:17 <ennael> is malo around ?
19:19:25 <rindolf> ennael: hi all.
19:19:40 <rindolf> Oh, I thought the meeting was not going to start until 23:00 here.
19:19:54 <rindolf> Due to day change, but I got the offset mixed up.
19:20:20 <AL13N> "day" change?
19:20:32 <ennael> so
19:20:55 <ennael> we have alpha2, features, mentoring
19:21:14 <ennael> #topic Mageia 3 alpha 2
19:22:10 <rindolf> AL13N: sorry, I mean timezone DST (Day Savings Time) stuff
19:22:18 <ennael> so it's planned for 2012-10-04
19:22:24 <ennael> next week
19:22:38 <ennael> isos build should start before end of this week
19:22:58 <rindolf> Does the /usrmove work fine on a net upgrade already?
19:23:10 <ennael> no news on that one
19:23:12 <ovitters> fortunately I don't expect any major GNOME updates after today/max tmr
19:23:25 <ennael> ovitters: ok good to know indeed
19:23:30 <Luigi12_work> so I guess the mass rebuild has been put off until after mga3
19:23:59 <ennael> Luigi12_work: we had massive updates these last days so was hard to do it
19:24:09 <ovitters> new alpha will have almost all of 3.6.0 btw (Epiphany / webkit is still a problem)
19:24:09 <coling> rindolf, I've been super busy so not integrated usrmove into installer yet sadly...
19:24:15 <rindolf> coling: OK.
19:24:24 <rindolf> coling: I'm talking about urpmi upgrade.
19:24:57 <rindolf> coling: well, I hope you become less busy sooner (also for your own sake).
19:25:03 <coling> rindolf, ahh, that's a different story. it'll need a new package to be backported to mga2 to act as a kind of helper, installer it and reboot into a new menu option.
19:25:18 <coling> rindolf, beginning to settle down a bit (colleague had a baby!)
19:25:21 <ennael> coling: can we expect it for alpha 3 ?
19:25:22 <Luigi12_work> hopefully that guy on #mageia will stop flaming coling too, that would help
19:25:28 <rindolf> coling: mazal tov.
19:25:28 <coling> ennael, I'll make sure of that yes.
19:25:34 <ennael> ok
19:25:55 <rindolf> coling: I mean - send him my regards.
19:25:59 <AL13N> Luigi12_work:  :)
19:26:04 <rindolf> Or her.
19:26:09 <ovitters> Luigi12_work: nick? I don't like unfriendliness
19:26:10 <ennael> please
19:26:16 <Luigi12_work> ovitters: it was mchou
19:26:33 <coling> rindolf, :)
19:26:34 <ennael> neoclust: anything on KDE side for alpha 2 ?
19:26:36 <coling> (him)
19:26:49 * coling shudders at the name mchou
19:26:59 <Luigi12_work> sorry to bring it up
19:27:00 <neoclust> ennael: no
19:27:06 <ennael> ok
19:27:25 <ennael> would be nice to stop big updates the very last days before release
19:27:30 <coling> Luigi12_work, I'm only kidding, don't worry.
19:27:39 <ennael> from monday here
19:28:13 <mchou> perhaps I haven't made clear my reasons for being upset
19:28:24 <Luigi12_work> mchou: save it for after the meeting please
19:28:30 <mchou> no
19:28:39 <mchou> I'm going to make it very clear
19:28:54 <leuhmanu> please don't start
19:29:28 <mchou> the timeline is fuzzy in my head
19:29:37 <ennael> please guys
19:29:40 <ennael> meeting in progress
19:30:17 <mchou> ennael: luigi12 thinks I'm "flaming"
19:30:30 <ennael> mchou: I don't care for now we are handling a meeting
19:30:35 <ennael> so
19:30:37 <anaselli> neoclust: have you update digikam?
19:30:46 <mchou> ennael: he's perhaps unclear why I'm so upset
19:30:47 <neoclust> anaselli: no, i missed time :(
19:30:51 <ennael> we should have live isos also for this alpha 2
19:31:15 <anaselli> ok let's talk about it after neoclust to see if it has to be included
19:31:18 <ovitters> the whole iso redesign is alpha 3?
19:31:24 <ennael> ovitters: yep
19:31:32 <ennael> ovitters: proposals will end tomorrow
19:31:36 <neoclust> anaselli: it can wait after, in 2 weeks beta2 is out
19:31:40 <neoclust> for digikam 3
19:31:45 <Luigi12_work> also the filesystem issue for liveCDs was solved
19:31:53 <AL13N> \o/
19:32:01 <ennael> Luigi12_work: file system was changed
19:32:13 <Luigi12_work> yep, unionfs->overlayfs IIRC
19:32:20 <mchou> the timeline is fuzzy in my head.
19:32:25 <neoclust> mchou: if this haven't have to be discussed on the meeting, let speak if this after
19:32:33 <neoclust> mchou: timeline ?
19:32:33 <ennael> ok
19:32:42 <ennael> anything else we should expect for alpha 2 ?
19:32:53 <mchou> but several months ago coling proposed dropping support for startx
19:33:02 <ennael> mchou: please stop now
19:33:12 <mchou> at the time the reasons weren't clear to me
19:33:13 <ennael> anything else we should expect for alpha 2 ?
19:33:20 <AL13N> since mariadb is late with the coming 10.X release... not sure if i will be able to include it for mga3
19:33:39 <ennael> will check with tmb about kernel
19:33:45 <mchou> It has since become abundantly clear to me why this is the case
19:34:03 <ennael> so QA team should get first isos friday I think
19:34:08 <ennael> for very first tests
19:34:08 <AL13N> if mariadb10.X is out after freeze, i won't proceed with it
19:34:13 <mchou> yesterday coling stated supporting startx "is a pain in th e ass"
19:34:17 <mchou> yesterday coling stated supporting startx "is a pain in the ass"
19:34:29 <ennael> somebody to kick mchou please ?
19:34:44 <AL13N> ennael: afaik you're on the access list for this channel
19:34:46 <mchou> that's just euphemismis for it''s too difficult to shoehorn int systemd*
19:34:55 <ennael> thanks
19:35:12 <ennael> anything else to add on coming alpha ?
19:35:19 <Luigi12_work> sorry about that, wouldn't have mentioned it if I knew they were in the channel
19:35:39 <AL13N> not for me
19:35:42 * coling already has him in his ignore list so is blissfully ignorant to what was said.
19:35:49 <ennael> ok
19:35:55 <Luigi12_work> some people have complained of a fonts issue recently
19:36:05 <ennael> any bug report on this ?
19:36:07 <ovitters> ah.. yeah, fonts seem to have changed
19:36:11 <ovitters> thought it was a GNOME thing
19:36:23 <AL13N> alot of people don't like these defaults it seems
19:36:26 <Luigi12_work> apprently it only affects gtk apps, not sure if a bug was filed
19:36:45 <ennael> Luigi12_work: can I ask you to mail -dev about this?
19:36:52 <Luigi12_work> ennael: I believe someone already has
19:36:55 <ennael> ah
19:36:59 <Luigi12_work> I don't run Cauldron, so I only know what I've heard
19:37:21 <barjac> It affects Thunderbird in kde
19:37:25 <Luigi12_work> that's the only issue besides usrmove upgrading that I've heard of that should be affecting the alphas
19:37:33 <ennael> indeed "New fonts?"
19:37:35 <anaselli> 23/9 Subject: new fonts?
19:37:40 <anaselli> :)
19:38:11 <ennael> https://www.mageia.org/pipermail/mageia-dev/2012-September/018863.html
19:38:56 <ennael> looks like people do not agree
19:39:08 <ovitters> I'm fine with it
19:39:25 <ovitters> aliasing seems different though, different than before
19:39:31 <AL13N> ovitters: are people that are fine with the change, fine with both ways? or prefer the new?
19:39:46 <ovitters> AL13N: fine with both
19:40:00 <anaselli> neoclust: [Kde-cvs-announce] [REMINDER] 4.9.2 Tagging this Thursday
19:40:06 <AL13N> if all is fine with both and some only fine with old, perhaps old would be better
19:40:19 <Luigi12_work> was it determined what caused the change?
19:40:46 <ovitters> fonts-ttf-liberation sets itself as default for sans, etc
19:41:15 <ovitters> apparently a sync with RH/Fedora
19:41:16 <neoclust> anaselli: see with mikala for this ;)
19:41:18 <AL13N> apparently removing some config symlinks seemed to "fix" it
19:41:42 <barjac> here thunderbird appears to be using "times"
19:41:49 * coling has not updated for a while, but I wonder if this font change will fix a long standing font issue I have on some webpages... (relating to sans serif font handling)
19:41:56 <Luigi12_work> :maint fonts-ttf-liberation
19:41:58 <Sophie> Luigi12_work: For Mageia (fonts-ttf-liberation): dmorgan
19:42:04 <ovitters> tv changed it btw
19:42:19 <AL13N> ovitters: you mean revert to old?
19:42:44 <ovitters> AL13N: no, added the conf file from RH/Fedora which resulted in the switch
19:43:09 <Luigi12_work> strange tv hasn't commented on the thread
19:43:29 <coling> strange or suspicious :p
19:43:35 <ennael> :)
19:43:42 <ennael> so can we sum up thi?
19:43:57 <rindolf> Well, my fonts improved a little after I did some KDE-fu that someone on #mageia suggested.
19:44:00 <Luigi12_work> well supposedly nobody uses Rawhide anymore so maybe Fedora users havne't seen the change to complain about it yet :o)
19:44:02 <rindolf> I still preferred the old fonts.
19:45:11 <Luigi12_work> anyway it'd be good if this could be resolved one way or another before the next alpha, as a lot of people have talked about it on IRC too
19:45:31 <Luigi12_work> either revert or someone put their foot down and say we're sticking with it
19:45:47 <ennael> Luigi12_work: can you please ping on -dev on the proper thread about that topic ?
19:46:00 <Luigi12_work> ok
19:46:05 <ennael> thanks
19:46:36 <ennael> anything else ?
19:47:26 <ennael> ok
19:47:34 <ennael> #topic Mageia 3 features
19:47:43 <ennael> it's a shame malo is not around
19:48:43 <ennael> ok we need to review Mageia 3 features
19:48:46 <ennael> as a reminder
19:49:18 <ennael> https://wiki.mageia.org/en/FeatureMageia3_Review
19:49:47 <anaselli> ennael: mcc2 is in wip
19:49:53 <ennael> ?
19:49:59 <anaselli> but i work in progress
19:50:05 <anaselli> ui abstraction
19:50:06 <ennael> oh ok
19:50:17 <leuhmanu> port to qt ?
19:50:17 <ennael> any preview available ?
19:50:24 <leuhmanu> or webkit 3 ?
19:50:31 <anaselli> but i (well we reaaly) dont think it will be ready for mga2
19:50:33 <anaselli> mga3
19:50:46 <ennael> ok
19:51:01 <anaselli> anyway tuxa will present it and we will package it for internal testing etc
19:51:02 <pasmatt> leuhmanu: libyui
19:51:23 <anaselli> yes libyui based
19:51:24 <ennael> anaselli: ok
19:51:48 <ennael> about this list of features could you guys all have a look
19:51:54 <ennael> especially if you are part of it
19:52:00 <ennael> to update the wiki page
19:52:24 <ennael> if you cannot do it yourself please use -dev ML to ask for contribution
19:54:25 <barjac> grub2 - the package is OK and I use 100% of time, but developers are needed to integrate it.
19:54:54 <ennael> barjac: so please mail -dev about this
19:54:58 <Luigi12_work> someone mailed me a spec file for chrony, but I haven't had time to look at it yet
19:55:16 <leuhmanu> iirc rosa or mdv started the integration for grub2
19:55:25 <ennael> barjac, Luigi12_work : can you please add a note about all this on wiki page ?
19:55:47 <Luigi12_work> yes I heard ROSA has done most of the work already and mdv plans to sync it from them soonish
19:56:02 <Luigi12_work> ennael: a note about what on which wiki page?
19:56:38 <Luigi12_work> mdv also plans to switch to chrony but has not yet commenced this work
19:56:52 <ennael> Luigi12_work: to give a status
19:57:02 <Luigi12_work> ennael: ahh yes
19:57:06 <ennael> so that we can follow :)
19:57:52 <ennael> I will mail -dev to ask other guys to do the same
19:58:13 <Luigi12_work> ennael: I sent the mail to -dev about the fonts
19:58:19 <ennael> yep just saw it
19:58:44 <ennael> coling: something to add on features ?
19:59:17 <coling> ennael, nothing specific. As mentioned earlier, I've been pretty busy of late so not had much time to do much on the features I planned.
19:59:34 <coling> ennael, but will hopefully enter "productive mode" soon ish (especially as winter is coming!)
19:59:54 <ennael> :)
19:59:56 <ennael> ok
20:01:07 <ennael> anything else to add ?
20:01:31 <coling> Not from me.
20:01:41 <ennael> ok
20:01:44 <anaselli> from me neither
20:03:08 <ennael> ok
20:03:18 <ennael> #topic reorganize mentoring
20:03:41 <ennael> as Mageia is growing it's really important now to be able to increase packagers team
20:04:11 <ennael> so I'm cleaning at the moment the mentoring wiki page
20:04:52 <ennael> https://wiki.mageia.org/en/Becoming_a_Mageia_Mentor
20:05:17 <ennael> I'm mailing all apprentice to check they are still interested in
20:06:21 <ennael> so if you have any information please ping me
20:06:34 <ennael> if you look for a mentor or if you want to mentor, same thing
20:07:16 <anaselli> ennael: i know you contacted mine :)
20:07:27 <ennael> :)
20:07:42 <ennael> it's quite a mess at the moment so we need at least to be clear on current one
20:08:53 <ennael> any other topic pending ?
20:09:48 <Luigi12_work> packagers please help with security updates :o)
20:10:13 <anaselli> Luigi12_work: haven't mandriva helped yet there?
20:10:20 <ennael> #topic Pending updates
20:10:24 <Luigi12_work> anaselli: not really
20:10:35 <ennael> ok I will ping them on my side
20:10:40 <anaselli> hmm i read it that somewhere :)
20:10:51 <Luigi12_work> I think they'll help more in mga3 since they'll actually have a product based on it
20:10:57 <ennael> Luigi12_work: can you please mail a list of pending one or the url for it?
20:11:03 <leuhmanu> btw there is at least two svn account request https://bugs.mageia.org/buglist.cgi?quicksearch=comp%3Aaccoun
20:11:05 <Luigi12_work> ennael: yes I'll send a new mail
20:11:13 <ennael> Luigi12_work: nope it will be based on Mageia 2
20:11:17 <ennael> so it should have started
20:11:28 <Luigi12_work> oh, strange
20:11:30 <ennael> I will speak with Oden about this
20:11:34 <anaselli> so i'd expect help at least in mga2 :)
20:11:39 <Luigi12_work> he's been doing work in Cauldron
20:11:46 <ennael> yep
20:11:49 <ennael> let me see
20:12:10 <ennael> Luigi12_work: how many updates pending ?
20:12:47 <Luigi12_work> ennael: I have around 30 packages on the list that need help currently
20:13:20 <anaselli> neoclust:  it's not a security update but i need help in fixing digikam bug in mga2...
20:13:45 <anaselli> unfortunately i have very little time in this moment :/
20:13:56 <ennael> Luigi12_work: any url that lists all these ?
20:14:16 <Luigi12_work> ennael: the last mail I sent about it has most of them, I can send a new mail with the current list
20:14:19 <leuhmanu> https://bugs.mageia.org/buglist.cgi?quicksearch=comp:secu+-kw:vali+-@qa-b (quick one)
20:14:25 <Luigi12_work> last mail was early september
20:14:33 <Luigi12_work> leuhmanu: no that's not it
20:14:57 <neoclust> anaselli: which bug ?
20:15:03 <leuhmanu> +@bugsquad ?
20:15:21 <Luigi12_work> leuhmanu: oh sorry I misinterpreted, that actually has most of them
20:15:38 <anaselli> neoclust: https://bugs.mageia.org/show_bug.cgi?id=7015
20:16:01 <ennael> #action ask contribution on pending updates https://bugs.mageia.org/buglist.cgi?quicksearch=comp:secu+-kw:vali+-@qa-b
20:16:12 <anaselli> neoclust: but mikala wanted to update digikam to 2.9 las August
20:16:15 <anaselli> last
20:16:23 <ennael> ok anything else ?
20:16:28 <anaselli> when i was on holidays
20:16:46 <anaselli> ennael: no from me.
20:17:47 <ennael> ok then looks like we can close this meeting
20:17:52 <ennael> thanks for attending
20:17:54 * Luigi12_work confirms leuhmanu
20:17:57 <Luigi12_work> 's list has them all
20:18:03 <anaselli> thanks ennael
20:18:05 <ennael> #endmeeting