19:11:50 <ennael> #startmeeting
19:11:50 <Inigo_Montoya> Meeting started Wed Jul 18 19:11:50 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:11:50 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:11:51 <erzulie> [ MeetBot - Debian Wiki ]
19:11:53 <ennael> hi all
19:11:58 <sebsebseb> hi
19:12:06 <rindolf> Hi.
19:12:36 <ennael> ok first topic
19:12:39 <ennael> #topic
19:12:44 <ennael> argh
19:12:55 * ennael needs to change brain and fingers :)
19:13:07 <ennael> #topic Mageia 3 features
19:13:43 <ennael> so
19:14:02 <ennael> Here is the list https://wiki.mageia.org/en/FeatureMageia3_Review#Refused_features
19:14:02 <erzulie> [ FeatureMageia3 Review - Mageia wiki ]
19:14:20 <ennael> we sorted the first lists in 4 categories
19:14:44 <ennael> first one is a list of complete features, meaning no information is missing and ready to be started or already started
19:14:49 <malo> hi all, sorry I'm late.
19:15:05 <ennael> second one is a list of features complete but missing resources
19:15:24 <ennael> meaning it may be started depending on people who will work on it
19:15:53 <ennael> third one is a list of features that needs to be completed
19:16:00 <sebsebseb> malo: hi
19:16:01 <ennael> and finally last one about refused features
19:16:24 <ennael> for many reasons: duplicated, already refused in previous discussion...
19:16:42 <doktor5000__> may i throw in a question?
19:16:46 <ennael> sure
19:17:31 <doktor5000__> what about network tools consolidation, meaning net_applet VS networkmanager? as this gave quite some issues to end-users ... ?
19:17:56 <ennael> is it listed in features ?
19:18:10 <doktor5000__> i mean, net_applet is not really under active development, and networkmanager has an active upstream and is widely used
19:18:26 <ennael> I already had many troubles with NM
19:18:33 <ennael> but it's not really a topic here
19:18:44 <ennael> you should first mail -dev or open a feature
19:18:51 <doktor5000__> nope, not listed in features, just a question
19:19:08 <doktor5000__> ok, i'll try to, question answered
19:19:12 <ennael> :)
19:19:23 <ennael> hard to discuss this here
19:19:26 <doktor5000__> :/
19:19:37 <doktor5000__> comprehensible ...
19:19:51 <ennael> I mean it's better to have many people as it's a big question
19:20:31 <ennael> it's not "yes" or "no" ok ?
19:21:25 * ennael hopes she did not kill doktor5000__
19:21:34 <coincoin> hard not to answer "yes" or "no" to ennael question :p
19:21:41 <ennael> :)
19:21:46 <doktor5000__> yep, comprehensible as i said, just go on
19:21:50 <ennael> ok :)
19:22:02 <doktor5000__> and no, i'm hard to kill - as most zombies ;)
19:22:11 <ennael> phew :)
19:22:25 <MrsB> he's 5000 years old
19:22:46 <ennael> ok any question, comment on features ?
19:22:47 <doktor5000__> but you know, zombies still fear fire and stakes and things like that :P
19:23:25 <MrsB> this is the final finalised final list now ennael?
19:23:46 <ennael> well features can still move from one list to another
19:23:52 <MrsB> ok ty
19:23:55 <ennael> depending on resources mainly
19:24:18 * coling is here too just so you know :)
19:24:23 <ennael> :)
19:24:29 <ennael> coling: want some more work ? :)
19:24:37 <ennael> we have a nice list ready :)
19:24:41 <coling> ennael, no thanks not right now :)
19:24:50 * coling is busy doing the usrmove stuff.
19:24:51 <ennael> MrsB: is this answer ok ?
19:25:04 <MrsB> yes, thanks. Perfect.
19:25:08 <ennael> ok
19:25:26 <ennael> btw we will publish a blog post to explain the process and this final page
19:27:34 <rindolf> ennael: great.
19:27:37 <ennael> #action list of final features is now ready on https://wiki.mageia.org/en/FeatureMageia3_Review
19:27:38 <erzulie> [ FeatureMageia3 Review - Mageia wiki ]
19:27:49 <ennael> #action blog post is planned to explain it
19:27:57 <ennael> anything to add on this ?
19:28:23 <ennael> of course all developments should be implemented during alpha stages
19:28:48 <ennael> can we switch to next topic ?
19:30:14 <MrsB> everybody's reading :D
19:30:24 <ennael> speak ! I'm feeling alone :)
19:30:26 <malo> MrsB: yes :-)
19:30:26 <ennael> ok
19:30:33 <ennael> #topic Avoid orphan commits in svn
19:30:46 <ennael> maybe title is a bit mysterious :)
19:31:06 <ennael> so it seems we have quite a lot of commits pending in svn
19:31:12 <ennael> and not being submitted
19:31:44 <ennael> It may be hard to manage when we switch to new stable release (it means commits were done during freeze)
19:32:13 <ennael> or sometimes make life quite hard when another packager is updating a package and has to manage errors due to old commits
19:32:50 <ennael> don't know if I'm clear enough
19:32:51 <coling> I think the freeze issue is quite hard to control anyway.
19:33:09 <spturtle> hasn't this come up before for stable release forking? That's just a technical issue, fork the right svn release
19:33:23 <ennael> well in this case yes
19:33:25 <coling> Didn't tmb have a script to do create the updates tree from the latest markrelease?
19:33:30 <coling> (or soemthing similar)
19:33:39 <ennael> this has to be checked
19:34:01 <coling> But yeah dealing with not yet submitted stuff when you're doing big rebuilds for new libmajors etc. is a pain :(
19:34:21 <ennael> coling: and some are pending for weeks
19:34:34 <ennael> and not because of freeze
19:34:45 <coling> Indeed.
19:35:05 <malo> sometimes it's pending because of a build problem that the packagers can't fix immediately
19:35:16 * coling can't think of a nice way to check for that tho' (other than a script that checks everything maybe once a day)
19:35:53 <ennael> maybe once a day is too much but at least once a month or every 2 or 3 weeks
19:36:22 <ennael> malo: then this will be the answer given by the packager and maybe it will be a good way to get some help
19:37:43 <malo> ennael: ok. Sounds reasonable.
19:38:20 <coling> Yup
19:38:44 * MrsB senses more updates coming
19:39:09 <ennael> #action run a script to check old svn commits every 2 or 4 weeks to check all unsubmitted commits
19:39:17 <ennael> MrsB: this rather happens in cauldron
19:39:42 <MrsB> we can handle it :) (not really)
19:39:50 <ennael> anything else on that topic
19:39:51 <ennael> ?
19:39:55 <malo> if we were using git, it'd be easier to manage the work in progress situation
19:41:17 <malo> I mean when packages are not submitted because of unfinished work on them
19:41:23 <ennael> sur
19:41:24 <ennael> e
19:41:39 <ennael> it has been asked but it needs some work on build system also
19:41:46 <tmb> well, one can also create a svn branch if needed
19:41:47 <ennael> so a question for sysadmins rather
19:42:29 <malo> tmb: how does svn branching affects the forking of cauldron?
19:43:19 <malo> ennael: ok.
19:43:44 <wally_> btw, branching for mga2 was done from wrong revision :\
19:43:54 <tmb> as we fork /current, anything above that wont follow to release tree
19:45:07 <wally_> there's no dir for latest release in updates/2/foo/releases/x.y.z/
19:45:26 <malo> tmb: ok.
19:46:29 <coling> One other solution for freeze periods was to implement a pre-commit check which bans most users rights to commit. Users who need to push a change must request a "commit token" from a freeze buster user. That token can then be used in the commit message to allow the pre-commit check to pass.
19:46:48 <coling> This approach prevents people committing stuff that won't ultimately be pushed but it might slow down the process.
19:47:04 <coling> It should, however, be quite simple to implement.
19:47:30 <ennael> well like freezes for submission
19:47:44 <ennael> but it's for a short period
19:48:03 <coling> Yeah. With this approach you could pretty much NOT freeze submission.
19:48:17 <ennael> ok
19:48:18 <coling> As if it's in svn it *should* be built.
19:48:27 <coling> It just changes where the block exists.
19:48:44 <ennael> #action apply freezes on svn commits like we do for packages submissions
19:49:55 <ennael> anything els on this .
19:50:02 <ennael> anything else on this?
19:51:24 <coling> not for me.
19:51:37 <malo> nope
19:51:46 <ennael> I forgot one topic on my side about arm
19:51:57 <ennael> #topic short review about arm support
19:52:24 <ennael> so as you may know rtp is working on rebuilding cauldron for arm
19:52:44 <ennael> he is at the moment working on a script for automatic rebuilds
19:52:52 <ennael> and test it on x86_64 for now
19:53:27 <ennael> so he took the opportunity to fix some packaging bugs and may also ask packagers to fix some
19:53:34 <coling> Cool.
19:53:41 <tmb> didn't blino say iurt had that capability already ?
19:53:46 <ennael> then arm will be rebuilt
19:53:56 <ennael> I must say I did not check that point
19:54:07 <coling> Regarding mass rebuilds.... I know there is one planned for post glibc (which is now landing I believe)
19:54:23 <coling> tmb, can I just request that we hold off on a full mass-rebuild for a week or two?
19:54:33 <coling> I should be done with the usrmove stuff by this weekend if all goes well.
19:54:41 <ennael> yep and this script can also be  used for regular rebuilds
19:55:22 <MrsB> Are we planning on releasing a fully supported arm build? If so how will we QA it?
19:55:24 <ennael> I guess the thing missing is sending failed builds to packagers
19:55:28 <tmb> coling: I see no problem with that
19:55:45 <coling> tmb, cool, thanks :)
19:55:51 <ennael> MrsB: for now it's still "experimental"
19:56:01 <MrsB> ok phew :)
19:56:03 * coling would be tempted to add a few extra lint rules too...
19:56:08 <ennael> yep
19:56:28 <tmb> one important thing about arm support...
19:56:47 <malo> coling: that would be a good thing
19:57:05 <ennael> tmb: yep ?
19:57:24 <tmb> packagers should not blindly drop arm related patches just because they dont apply when they update something.
19:57:39 <tmb> instead rediff, or ask for help
19:57:43 <ennael> yes
19:57:48 <blino> tmb: ennael : yes, iurt already has support for rebuild packages for an arch, and I think we told rtp
19:57:49 <ennael> and it already happened some times
19:58:05 <ennael> blino: but as I said I did not check with him
19:58:11 <ennael> and he is not around tonight
19:58:56 <coincoin> yes but the main issue is that on ARM, we need to shedule things as it make more and more time than on x86. So, rtp is doing something like "building each monday" for example
19:59:16 <ennael> #action check packagers do not delete arm patches because they don't apply
19:59:43 <blino> coincoin: that's just about adding a iurt command in a crontab :)
20:00:19 <doktor5000__> ennael: can we get rtp to give some status update how far the arm port is
20:00:24 <doktor5000__> whoops
20:00:27 <coincoin> blino: perhaps, but IIRC rtp have a lot of "new requires" for the ARM BS, better to ask him I think.
20:00:28 <coincoin> rtp: !
20:00:44 <doktor5000__> ennael: can we get rtp to give some status update how far the arm port is usable yet, please?
20:01:01 <ennael> doktor5000__: If I'm not wrong he is starting bootstrap
20:01:15 <ennael> but we will ask him more information about that point
20:01:23 <malo> the more rtp communicates about the arm port, the more packagers will remember that it exists
20:01:35 <tmb> blino: one thing... I guess we need a scheduler for iurt lazy builds since we have 2 arm nodes
20:02:30 <doktor5000__> ennael: or how far it is from, say installing a basesystem-minimal yet? as i think he already did some images already, and his mirror seems quite big yet for cauldron
20:02:53 <blino> tmb: probably in a second step, unless someone has time to add "lazy support" in emi/ulri (which should be quite simple)
20:03:31 <ennael> doktor5000__: you can also ask him directly :)
20:03:55 <MrsB> what does 'starting bootstrap' mean please?
20:03:57 <ennael> If I remember well he did not bite anybody... for now
20:04:08 <ennael> MrsB: 2 sec I give you a link
20:04:14 <MrsB> thanks
20:04:14 <coincoin> MrsB: it means that he just starts the bootstrap
20:04:16 * coincoin runs :p
20:04:23 <MrsB> thanks coincoin :P
20:04:31 <tmb> blino: or maybe set up icecream on both arm nodes and let them share the workload
20:04:35 <ennael> MrsB: http://blog.mageia.org/en/2011/02/02/bootstrap-what-bootstrap-i-want-mageia-iso/
20:04:36 <erzulie> [ Bootstrap? What bootstrap? I want Mageia ISO! | Mageia Blog (English) ]
20:04:49 <ennael> boostrap is explained here
20:04:53 <MrsB> thanks. It's bound to be asked.
20:05:36 <MrsB> so basesystem is really the bootstrap
20:05:57 <ennael> yep part of
20:06:11 <ennael> anything else to add ?
20:06:25 <blino> tmb: could work as well
20:07:13 <coincoin> not for me
20:07:21 <tmb> ennael: nope
20:07:34 <doktor5000__> ennael: well he did not respond yet, CC'ed him on my previous post to -dev ml :(
20:07:45 <doktor5000__> ennael: that's why i'm asking more directly ...
20:07:55 <ennael> doktor5000__: ok we will propose him a beer :)
20:07:55 <blino> ennael: maybe rtp could post a status on -dev?
20:07:56 <coincoin> doktor5000__: try to ping him tomorrow on IRC
20:08:07 <ennael> we will do it tomorrow
20:08:10 <ennael> rtp: don't run
20:08:14 <coincoin> :)
20:08:31 * doktor5000__ will not be available tomorrow, probably :/
20:08:38 <ennael> well on ML rather
20:08:50 <ennael> ok last topic was proposed by malo
20:09:08 <coincoin> tomorrow, no coffee before he answered your mail!
20:09:11 <coincoin> fear!
20:09:17 <stblack> but how we could QA when it'll be ready?
20:09:31 <ennael> #topic Involvement of packagers in supporting/fixing bugs on stable releases
20:09:38 <ennael> malo: your turn :)
20:09:48 <malo> ennael: thanks :-)
20:10:00 <coincoin> stblack: you will have info at this time (not ready before september so... be patient :))
20:10:17 <stblack> coincoin: thanks
20:10:30 <malo> this is about something that was talked about recently on several occasions: packagers tend to focus on cauldron
20:11:18 <malo> and not spend much time on investigating/fixing bugs for stable releases.
20:12:23 <malo> Considering our very limited manpower, how can we improve on that situation?
20:12:28 <ennael> which as I say is not very new unfortunatelly
20:12:32 <ennael> said
20:12:59 <malo> ennael: yes. One of the main reasons why I thought this maybe deserved to be discussed :-)
20:13:08 <ennael> yep sure
20:13:30 <AL13N> coling: ping, i've submitted that mariadb, it'll likely finish soon-ish. lemme know if there's any regression or and if it actually fixes your issue.
20:13:48 <ennael> AL13N: meeting in progress
20:13:54 <ennael> nearly finished
20:13:55 <malo> as far as I understand, packagers run mainly cauldron
20:13:57 <AL13N> oh no, sorry, i forgot that there's a meeting /o\
20:14:15 <malo> QA and users run stable releases
20:14:31 <malo> there is a gap there
20:15:01 <malo> (actually there is another gap: QA is not running cauldron, but it's another topic)
20:15:38 <MrsB> It would be beneficial maybe if we did, we can't really though
20:16:15 <malo> so the question is, whether or not we can recruit new packagers and new QA, how can we improve the maintainance of stable releases
20:16:20 <malo> ?
20:16:21 <tmb> well, the fact that packagers run cauldron is also a "pre QA" as more bugs get solved for final relase too
20:16:23 <DavidWHodgins> I do keep a cauldron image, and check it out a few times every week.
20:18:32 <malo> tmb: I entirely agree.
20:19:18 <malo> I was thinking that having a few bug squashing week-ends might be a good way to motivate people into looking at stable releases issues.
20:19:30 <tmb> yep
20:19:45 <MrsB> there is a list of bugfixes awaiting validation too which might squash a few
20:20:09 <MrsB> we're concentrating on security bugs which doesn't leave much time for the bugfixes
20:20:21 <coling> My general problem is that I only actually run mga-stable on servers and media centres. Any colleagues who run it are no longer in my office so I tend not to see too many issues first hand on stable releases.
20:20:54 <malo> this can be organised in liaison with QA and the bugssquad. And having packagers running stable releases for a week-end can also help QA during that week-end.
20:21:24 <MrsB> run with it malo, see how it goes :)
20:21:33 <malo> I'd just hate to see bugs closed as OLD as in the Mdv times
20:21:43 <ennael> it needs time and people to organize it or it's just wasting time
20:21:51 <malo> ennael: true
20:22:01 <ennael> meaning people available and answering and following
20:22:06 <ennael> just to underline this :)
20:22:35 <MrsB> need to generate some interest first then
20:23:01 <ennael> malo: can you mail -dev about this with a formal proposal?
20:23:16 <malo> ennael: I can.
20:23:43 <MrsB> you're welcome to come to qa meeting tmrw too malo
20:24:01 <malo> MrsB: I'll pass by
20:24:21 <MrsB> i'll mention it anyway
20:24:24 <malo> ennael: you're not giving me a little #action? ;-)
20:24:37 <ennael> #action malo will mail -dev about organizing days for bugs hunting in stable releases
20:24:51 * ennael is reading in heads :)
20:25:05 <MrsB> is it bug hunting or bug fixing?
20:25:06 <malo> :)
20:25:15 <ennael> #undo
20:25:15 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x8386b8c>
20:25:26 <ennael> #action malo will mail -dev about organizing days for bugs fixing in stable releases
20:25:33 <malo> MrsB: bug fixing.
20:25:44 <malo> ennael: thanks
20:25:46 <MrsB> :)
20:26:03 <tmb> hunting is easy... fixing is harder :)
20:26:07 <ennael> :)
20:26:19 <ennael> anything else ? other topic ?
20:26:26 <tmb> not for me
20:26:35 <MrsB> none here, thankyou
20:26:38 <malo> ennael: andre is not around, but we need new apprentices
20:26:49 <ennael> yep
20:26:53 <grenoya> ennael: about how to have some ?
20:27:28 <ennael> yes
20:27:47 <malo> when misc was here he would push people to adopt packages. We have currently almost 2000 unmaintained packages ...
20:27:48 <ennael> but before looking for apprentices we need to have mentors ready to help
20:27:53 <malo> ennael: we have
20:28:03 <ennael> who ? when ? where ? :)
20:28:09 <malo> rindolf even sent a mail to -dev to propose his services
20:28:17 * MrsB saw that
20:28:19 * rindolf is guilty as charged.
20:28:33 <rindolf> I'm willing to mentor people.
20:28:39 <ennael> wait
20:28:46 <malo> #mageia-mentoring has been almost dead for weeks
20:28:48 <ennael> #topic look for new apprentices
20:28:57 <grenoya> i have a padawan since one month (but lake of disponibility -> nothing done yet)
20:29:14 <ennael> would be nice to identify mentors first
20:29:32 <ennael> we lost apprentices some months ago because mentors were lacking
20:29:57 <malo> I suspect many currently registered apprentices are missing, with already registered mentors not effectively mentoring.
20:30:28 <ennael> so we need to clean these lists
20:30:37 <ennael> somebody volunteer for this ?
20:30:44 <malo> andre was supposed to do it
20:30:51 <doktor5000__> i'd like to mentor, but me free time currently tells me something differnt would be better and more honest -> suspend my packaging activities nearly altogether until i can spare more time for that again :/
20:31:13 <ennael> it's better not to propose being a mentor if you have no time
20:31:24 <doktor5000__> totally busy with dayjob and doing supoort and helping with forum organisation
20:31:51 <doktor5000__> ennael: maybe you have misunderstood, i did not propose actually :/ just told some even worse news
20:32:05 <ennael> yep I saw that
20:32:14 <rindolf> I can mentor people.
20:32:20 <ennael> but it was a more general sentence not for you only :)
20:32:44 <ennael> ok I can start cleaning mentoring process (mentors/apprentices)
20:33:11 <malo> ennael: maybe some pinging is needed :-)
20:33:16 * ennael will take her best matches and will ask people in list
20:33:49 <ennael> #action ennael will ping registered mentors and apprentices to have an uptodate status
20:33:57 <ennael> malo: is that ok ?
20:34:10 <malo> ennael: yes
20:34:18 <MrsB> big long matches!
20:34:31 <ennael> :)
20:34:39 <ennael> ok anything else ?
20:34:42 <ennael> questions ?
20:34:43 <malo> QA was able to recruit a few people in a few weeks by a bit MrsB noise
20:35:05 <ennael> everybody is frightened by MrsB that's why :)
20:35:05 <malo> maybe some ennael noise would be helpful to get new apprentices :P
20:35:15 <grenoya> ennael: maybe i can explain how i find my padawan ?
20:35:15 <MrsB> a few yes. We had alot of interest but not many stayed
20:35:28 * MrsB isn't allthat scary :(
20:35:40 <malo> MrsB: same with apprentices unfortunately
20:35:50 <ennael> sure and soon averybody will see you are a real human being :)
20:36:02 <MrsB> now that will be scary :D
20:36:10 <ennael> grenoya: we can see that after meeting ?
20:36:18 <stblack> MrsB: I'll try to do more QA work ;-)
20:36:25 <grenoya> ennael: it was to explain to others :)
20:36:26 <MrsB> maybe pick a packager to do the same?
20:36:34 <ennael> grenoya: oh go now then
20:36:38 <MrsB> thanks stblack \o/
20:36:43 <coincoin> grenoya: you sleep with him! :D
20:36:48 <ennael> coincoin: !
20:36:55 <grenoya> coincoin: no !
20:37:00 <ennael> grenoya: your turn then we will stop the meeting
20:37:11 <ennael> before we cannot control it anymore
20:37:16 <coincoin> :)
20:37:43 <grenoya> i was at "Solution Linux" at the booth, just explaining how a distribution is made, just that
20:38:08 <grenoya> but this year (in france) we were not many the all the booths
20:38:28 <grenoya> packagers, must put their nose outside and meet poeple irl :)
20:38:37 <coincoin> :)
20:38:42 * AL13N doesn't like the scary outside
20:38:44 <Luigi12_work> what's outside?
20:38:51 * Luigi12_work hears the rumbling of thunder outside right now
20:38:58 <MrsB> you're not allowed outside Luigi12_work :P
20:39:08 <Luigi12_work> MrsB: OK :o)
20:39:13 <ennael> ok
20:39:20 <Luigi12_work> except to go for a run
20:39:21 <ennael> can we close the meeting now ?
20:39:26 <Luigi12_work> just not in the thunder
20:39:28 <Luigi12_work> yep
20:39:33 <AL13N> k
20:39:35 <ennael> thanks all for attending
20:39:41 <malo> ennael: thanks
20:39:42 <ennael> #endmeeting