19:06:57 <ennael> #startmeeting
19:06:57 <Inigo_Montoya> Meeting started Wed Jun 13 19:06:57 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:57 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:06:58 <erzulie> [ MeetBot - Debian Wiki ]
19:07:29 <ennael> hi all
19:07:35 <MrsB> hi
19:07:39 <AL13N> yo
19:07:58 <ennael> #topic  Features proposal (Mageia 3 specs)
19:08:18 <ennael> New feature proposals are accepted until 2012-06-18. After 2012-06-18 a mail is sent to the mageia-dev mailing list with a preliminary list of accepted and rejected features.
19:09:14 <ennael> for french people it's nice date :)
19:09:15 <ennael> http://en.wikipedia.org/wiki/Appeal_of_June_18
19:09:16 <erzulie> [ Appeal of 18 June - Wikipedia, the free encyclopedia ]
19:09:37 <ennael> anyway for those who still not have fill the wiki you have some days left for this
19:10:20 <ennael> we already have a nice list of features
19:10:36 <AL13N> i'm guessing if there's not enough people who join these features, there's no chance of it being accepted?
19:10:36 <ennael> still we need some more people to work on it
19:10:48 <ennael> I will send a mail after this meeting
19:10:58 <ennael> and a list of features without anybody inside
19:11:03 <sebsebseb> Ok so I got untill then to propose, Mate, and Cinnamon, and even Unity,  yes I think it's important that Mageia provides at least Mate and Cinnamon, if it's going to have any chance at gaining many Desktop Linux users.  Hope someone will maintain them though.
19:11:21 <ennael> this was already discussed
19:11:29 <AL13N> is there some features who are not considered features?
19:11:37 <AL13N> or is what was proposed sufficient?
19:12:21 <ennael> for now we will just underline missing resources
19:12:46 <AL13N> https://wiki.mageia.org/en/Category:ProposedFeatureMageia3
19:12:48 <erzulie> [ Category:ProposedFeatureMageia3 - Mageia wiki ]
19:13:18 <AL13N> ok, that about sums it up?
19:13:54 <anaselli> ennael: we could add a field, something like candidate to join the team
19:13:56 <ennael> #action ennael will send an email to call for people on features
19:14:22 <anaselli> so maybe someone who does not want to get the ownership
19:14:22 <sebsebseb> an email to get people to propose features?
19:14:32 <anaselli> but wants to work on it... may sign it
19:15:12 <ennael> well resources is the right field I guess
19:15:20 <AL13N> ennael: perhaps in the email, you could list the needed resources? like installer maintainer (feature A, B & C)
19:15:34 * anaselli should missed that then :/
19:16:02 <ennael> as an example
19:16:02 <anaselli> or better i misunderstood it
19:16:03 <ennael> https://wiki.mageia.org/en/Feature:Accessibility#Resources
19:16:04 <erzulie> [ Feature:Accessibility - Mageia wiki ]
19:16:31 <ennael> but I will add this in mail asking people interested to register in this field
19:16:43 <AL13N> ok
19:16:52 <anaselli> yep i thought it was who were needed...
19:16:57 <ennael> :)
19:17:23 <ennael> boklm worked on a kind of policy to explain how features will be chosen
19:17:51 <ennael> it's not very complicated and based on quite logical reasons :)
19:17:59 <ennael> will be published tomorrow
19:18:03 <AL13N> nice
19:18:35 <AL13N> if they are not chosen, they can still be worked on partially and presented for mageia 4 ?
19:18:41 <dmorgan> ennael: logical reasons ? like lottery ? :)
19:18:47 <ennael> even for Mageia 3
19:18:47 <dmorgan> AL13N: of course
19:19:14 <ennael> but if it's really against policies or global goals of Mageia we will not allow it
19:19:26 <AL13N> ok, that's reasonable
19:19:35 <ennael> for example no need to post a feature against rpm5
19:19:37 <ennael> :)
19:19:38 <sebsebseb> What are  the global goals of Mageia?
19:19:41 <AL13N> :-)
19:19:42 <dmorgan> ennael: :)
19:19:52 <AL13N> sebsebseb: maybe she means the values
19:19:56 * Luigi12_work waits for someont to propose distepoch
19:19:59 <ennael> yep
19:20:04 <anaselli> breaking all sebsebseb :D
19:20:27 <ennael> proposing all graphical environments on earth
19:20:33 <ennael> it's just not maintainable
19:20:48 <sebsebseb> ennael: true
19:20:50 <ennael> so anything else to add on feature?
19:21:02 <AL13N> it would be nice to get the sevearl installer features though
19:21:04 <sebsebseb> ,but Cinnamon and Mate are getting quite pouplar in the DEsktop Linux world
19:21:04 <[mbot> Please...
19:21:09 <sebsebseb> so they are good for Mageia to have I think
19:21:13 <AL13N> lol
19:21:16 <AL13N> mbot again
19:21:33 <ennael> sebsebseb: we can hardly maintain current environment...
19:21:37 <ennael> anyway
19:21:42 <ennael> anything else ?
19:21:45 <AL13N> not for me
19:21:56 <sebsebseb> yes I know there are issues maintaning Gnome and KDE, but hope they will get at least thinked about properly, if I do propose :d
19:22:03 <MrsB> do you need any input from QA on those?
19:22:11 <ennael> ah
19:22:13 <ennael> MrsB !
19:22:19 * MrsB present
19:22:21 <AL13N> heh
19:22:24 <ennael> MrsB has joined QA team as leader
19:22:33 <ennael> please welcome her in packagers hell
19:22:35 <MrsB> o/
19:22:38 <AL13N> o/
19:22:41 <sebsebseb> yep I already knew MrsB is leader of QA
19:22:50 <ennael> sebsebseb: please...
19:22:53 <AL13N> MrsB: it's always barbecue here
19:23:01 <MrsB> thankyou for the welcome
19:23:04 <ennael> MrsB: something to add on features ?
19:23:10 <MrsB> I have something to ask while I'm here ;)
19:23:21 <ennael> about features ?
19:23:27 <MrsB> no, bugzilla
19:23:34 <ennael> ok so later :)
19:23:36 <MrsB> updates
19:23:38 <MrsB> yep
19:23:44 <ennael> next topic then
19:23:46 <AL13N> wait
19:23:58 <AL13N> does QA get a say about features?
19:24:02 <AL13N> what is maintainable?
19:24:06 <AL13N> is that important information?
19:24:22 <ennael> not really not automatically
19:24:28 <AL13N> ok
19:24:33 <ennael> devs are the one to be implied and make something usable
19:24:46 <ennael> #topic Managing coming development planning
19:24:46 <MrsB> It shouldnt really affect us in that way, not like opening backports or something. Just more packages
19:24:53 * anaselli laugh
19:24:59 <ennael> so
19:25:07 <AL13N> MrsB: k
19:25:08 <ennael> have you all seen planning for Mageia 3 ?
19:25:11 <AL13N> yes
19:25:29 * anaselli hides
19:25:32 <ennael> tsss
19:25:41 <ennael> you should all know it by heart :)
19:25:41 <Solbu> I havent.
19:25:45 <ennael> anyway
19:26:00 <ennael> as a reminder first development release is planned for 04/09
19:26:18 <AL13N> this? http://blog.mageia.org/en/2012/06/11/cauldron-is-boiling-again-never-2-without-3/
19:26:18 <ennael> we will work together with QA team to follow this planning
19:26:20 <erzulie> [ Cauldron is boiling again: never 2 without 3 | Mageia Blog (English) ]
19:26:39 <Solbu> ennael: You're using mm/dd dating?
19:26:43 <ennael> QA team is working on process to have proper tests for isos release
19:26:50 <ennael> 09/04
19:26:56 <anaselli> wow a mageia spring :p
19:27:11 <AL13N> ennael: better put the year with it, so we know which is month
19:27:36 <ennael> please
19:27:41 <ennael> can we go on ?
19:27:47 * AL13N hides
19:28:06 <ennael> MrsB: want to add something for QA team ?
19:28:35 <MrsB> not yet. We're hoping to have a more formal setup for next iso's
19:28:48 <MrsB> we should begin testing earlier
19:28:55 <ennael> while we are on it
19:29:11 <ennael> we will start discussions next week about isos
19:29:20 <ennael> how many, what inside, how...
19:29:27 <MrsB> fewer please
19:29:39 <ennael> MrsB: that's part of this discussion :)
19:30:34 <anaselli> ennael: not that important, but can you add an ical on pallning page?
19:30:42 <ennael> ?
19:30:46 <ennael> ah
19:30:52 <ennael> we will add it on calendat
19:30:54 <ennael> calendar
19:31:11 <anaselli> yes thanks i think it's useful :)
19:31:29 <ennael> yep good reminder :)
19:31:41 <ennael> #action add release planning in Mageia calendar
19:32:59 <ennael> anything else to add ?
19:33:22 <AL13N> not for me
19:33:27 <anaselli> calendar link :D
19:34:20 <ennael> added as an action
19:34:26 <ennael> #topic collaboration policy
19:34:36 <ennael> ok as discussed last week
19:34:50 <ennael> we needed such policy for Mageia
19:35:12 <ennael> to make things clean and avoid useless flame war
19:35:31 <ennael> coling did write it (thanks for that)
19:35:33 <ennael> https://wiki.mageia.org/en/Collaboration_policy
19:35:33 <erzulie> [ Collaboration policy - Mageia wiki ]
19:35:42 * AL13N reads
19:35:51 <ennael> Please have a look on it
19:35:59 <ennael> you can comments on -dev ML
19:36:57 <AL13N> perhaps we can show this to other distro's for comments?
19:37:10 <AL13N> to ask if it's sufficient in their opinion?
19:37:14 <anaselli> already approved :)
19:38:24 <ennael> I guess a blog post would be nice to announce it
19:39:28 <anaselli> after mailing list discussion?
19:39:28 <AL13N> perhaps it should be approved first?
19:39:35 <ennael> anaselli: yep
19:39:44 <ennael> of course... when it's all ok
19:39:49 <AL13N> ok
19:40:12 * AL13N phears... it's being quite silent
19:40:20 <ennael> #action when collaboration policy is approved, work on a blog post to announce it
19:41:23 <ennael> any comment ?
19:41:42 <rindolf> ennael: no, sounds good.
19:41:51 <anaselli> fine for me
19:41:57 <sebsebseb> reading that wiki page, seems good to me so far :)
19:42:12 <AL13N> k, thanks coling
19:42:15 <ennael> #action post url on -dev to get approval
19:42:29 <ennael> ok that's all for the list of topics
19:42:33 <ennael> MrsB: wanted to add one ?
19:42:44 <MrsB> Yes please
19:43:01 <ennael> #topic QA demand for Bugzilla
19:43:05 <ennael> shoot :)
19:43:05 <MrsB> bugzilla policy for updates covering both releases
19:43:08 <MrsB> thanks
19:43:24 <MrsB> So, we currently are trying to use one bug report for updates
19:43:38 <MrsB> some bug reports carry updates for both mga2 and mga1
19:43:56 <MrsB> at present with current bugzilla ther eis no obvious way for us to tell they are for both
19:44:13 <MrsB> I'd like to request that when that sort of bug report is made
19:44:33 <MrsB> we follow bugsquad policy and use a keyword in the whiteboard
19:44:47 <MrsB> so, set release to Mageia 2
19:44:57 <MrsB> and in the whiteboard add MGA1TOO
19:45:15 <MrsB> It's obvious for us in QA then that it covers both releases
19:45:27 <MrsB> Please :)
19:45:32 <spturtle> for such cases usually a separate issue is created for each release AFAIK
19:45:43 <MrsB> We've been trialing using one
19:45:51 <MrsB> so far it has seemed to work quite well
19:45:55 <AL13N> that's nice
19:46:05 <AL13N> it can group the same issue then
19:46:33 <MrsB> One issue we found was where multiple versions of a package were on that report for two releases
19:46:52 <MrsB> ie. postgresql 8.4 9.0 and 9.1 for mga1 and mga2
19:47:05 <MrsB> could have done with 2 or even 3 reports
19:47:14 <AL13N> MrsB: the other day somone asked if there was a bug for cauldron and also valid for mga2, how is that handled?
19:47:41 <AL13N> MrsB: is it set to cauldron and MGA2TOO on it?
19:47:50 <MrsB> Bugsquad have been setting the release to the highest one and using the whiteboard keywords
19:47:54 <MrsB> yep
19:47:59 <AL13N> that's what i suggested
19:48:01 <AL13N> ok then
19:48:02 <AL13N> good to know
19:48:16 <MrsB> I'd just like to apply that to qa bugs too please
19:48:28 <spturtle> so how does it end up if fixed for cauldron but rejected for mga2...
19:48:41 <MrsB> so when you create a bug please add the keyword to whiteboard if it concerns both releases and set it to mga2
19:49:04 <AL13N> spturtle: we set it to cauldron
19:49:23 <AL13N> MrsB: perhaps there should be an #info or something so it's on the summary
19:49:25 <ennael> #action when you create a bug please add the keyword MGA2TOO to whiteboard if it concerns both releases and set it to mga2
19:49:26 <MrsB> This is for bugs you create to send updates to QA
19:49:37 <Solbu> Maybe the bugzilla should have a smal note on this so the avarage user hwo is not in the ml or in the chat, know hotw to report correctly.
19:49:47 <MrsB> ennael: and set it to MGA2 release
19:49:56 <MrsB> oh sorry you said that
19:50:06 <ennael> just copied what you said :)
19:50:11 <MrsB> thanks :)
19:50:25 <ennael> ok antyhing else to add ?
19:50:38 <MrsB> not on that, thanks
19:50:49 <ennael> any other topic ?
19:50:59 <MrsB> bug 2317 /o\
19:51:13 <ennael> MrsB: I forgot to post on -dev
19:51:19 <ennael> I will mail just after meeting
19:51:26 <MrsB> AL13N has begun to look at it I think
19:52:07 <ennael> ok
19:52:08 <AL13N> i could use some help on that though
19:52:17 <rindolf> AL13N: how can I help?
19:52:23 <ennael> can we close meeting for tonight ?
19:52:26 <rindolf> AL13N: what do you ned help with?
19:52:28 <ennael> (shot one for once)
19:52:29 <AL13N> ok, that's fine
19:52:30 <rindolf> ennael: fine by me.
19:52:30 <MrsB> rindolf \o/
19:52:34 <sebsebseb> yep
19:52:37 <ennael> #endmeeting