19:10:15 <ennael> #startmeeting
19:10:15 <Inigo_Montoya> Meeting started Wed Jun  6 19:10:15 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:10:15 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:10:16 <erzulie> [ MeetBot - Debian Wiki ]
19:10:18 <ennael> hi all
19:10:26 <sebsebseb> hi
19:11:10 <ennael> #topic
19:11:16 <ennael> erf
19:11:25 <ennael> this meeting is going to be long :)
19:11:34 <sebsebseb> ok
19:11:37 <ennael> #topic post-mortem review
19:11:49 <ennael> so thanks guys who added some notes there
19:12:04 <ennael> as a reminder: https://wiki.mageia.org/en/Mageia2_Postmortem#Packagers
19:12:05 <erzulie> [ Mageia2 Postmortem - Mageia wiki ]
19:12:36 <ennael> so basically topics are planning
19:12:55 <ennael> jq asked to be able to push some packages a bit later
19:13:11 <ennael> we will have to check this depending on upstream projects planning
19:13:57 <ennael> one other topic is about getting more packagers, we will see that later with mentoring
19:14:23 <ennael> one topic is about late commits of new features and bug fixes
19:15:01 <ennael> what we saw is most release critical bugs were fixed 3 weeks before release
19:15:19 <ennael> while some of them were in bugzilla since much longer
19:15:43 <ennael> so again fixing bugs vs updating to new versions
19:15:59 <anaselli> ennael: imo that was because we start an indeep study of that also during the meeting...
19:16:13 <ennael> ?
19:16:24 * coling is late sorry.
19:16:30 <ennael> hi coling
19:16:30 <rindolf> coling: hi.
19:16:34 <anaselli> i mean last three weeks we spent time to read and read again them
19:16:50 <sebsebseb> yeah hi coling
19:16:52 <anaselli> and looking into them helped also to start fixing
19:16:54 <ennael> well it's just a shame people wait for a mail to work on fixing bug
19:17:07 <ennael> so we will have to start this much sooner
19:17:11 <sebsebseb> coling: not missed that much
19:17:19 <ennael> and QA will be implied for this
19:18:06 <AL13N> but QA is small
19:18:28 <anaselli> ennael: true, it's just what i think has happened, not what is the best to reach more bug fixing  ;)
19:18:34 <ennael> this is not an answer AL13N
19:18:47 <ennael> and not your business if you don't join QA team :)
19:18:53 <ennael> it's a QA job
19:18:59 <ennael> and QA team is growing
19:19:05 <sebsebseb> someone wanted to join marketing today, I got him to join other teams as well such as QA :)
19:19:05 <AL13N> that's good
19:19:15 <MrsB> AL13N: most welcome to join :)
19:19:20 * AL13N hides
19:19:24 <MrsB> lol
19:19:42 * AL13N needs to keep his big mouth shut
19:19:44 <ennael> ok anything else to add on post mortem ?
19:19:56 <AL13N> no
19:20:09 <ennael> #info planning will be enforce especially during freezes to focus on bug fixes
19:20:29 <ennael> #undo
19:20:29 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x847596c>
19:20:33 <ennael> #info planning will be enforced especially during freezes to focus on bug fixes
19:20:47 <AL13N> maybe we can also restrict new packages during freezes
19:21:03 <ennael> AL13N: the thing is if we say "we can't do things because we are not enough nothing will happen"
19:21:13 <ennael> and see even QA team is growing now :)
19:21:18 <AL13N> ok
19:21:21 <ennael> MrsB is using guns to get new people
19:21:23 <ennael> hum
19:21:30 <MrsB> yep, anything goes
19:21:31 <sebsebseb> I got the latest new person into QA :)
19:21:33 <anaselli> bah it's an old story no new packages no new bugs
19:21:39 <ennael> tsss
19:21:41 <ennael> ok
19:21:43 <Kharec> hi all
19:21:44 <anaselli> but often neither old one fixed
19:21:55 <AL13N> ok, so, next topic then?
19:21:59 <Kharec> Sorry, I'm late.
19:22:03 <ennael> #topic collaboration policy
19:22:07 <MrsB> hi Kharec
19:22:15 <ennael> so here is a tricky topic
19:22:27 <ennael> coling: want to introduce it ?
19:22:33 <coling> ennael, sure.
19:22:39 <coling> OK, so for some backgrouns:
19:22:43 <coling> background*
19:23:15 <coling> Since the fork from Mandriva, we have obviously carried on developing the various tools: drakx* draknetcenter etc.
19:23:44 <coling> I think it's relatively uncontroversial to state that we've done a lot of work here.
19:24:11 <coling> Obviously Mandriva folk have done a lot of work too, but I think the majority of changes have come from us (although I will stress I've not done a full analysis yet)
19:24:33 <coling> It become clear some time ago that Mandriva folk have imported a lot of our changes into their SVN.
19:24:42 <AL13N> didn't mandriva stop usin drakx* and uses ROSA apps instead?
19:24:43 <coling> This is, in and of itself not a problem
19:25:10 <coling> However, when importing them, proper credit was not really given in the changelog as to who wrote the patch.
19:25:29 <coling> It did say "Author: tv" or "Author: colin"
19:25:39 <coling> But it made no mention of the Mageia project.
19:25:46 <Kharec> sad :/
19:25:53 <coling> In later commits the git-svn id was included so the mageia.org domain was included.
19:26:19 <coling> While it is sad, I think it's more due to the limitations of the tools rather than any specific attempt to hide the source.
19:26:48 <coling> And to be completely fair, we have also committed some changes from the Mandriva side which similarly do not credit the source properly, so we are not guilt free.
19:26:50 <ennael> (or also some people do not know anything about collaboration in open source projects)
19:27:23 <coling> So the software aside, we have also noticed several package commits of late on the Mandriva side.
19:27:34 <Kharec> So we have to write a collaboration policy for us and for others?
19:27:37 <coling> These are simply commit messages: "update to x.y.z"
19:27:47 <coling> But they actually just import our spec wholesale.
19:27:55 <coling> Again, without any credit.
19:28:24 <coling> This is almost more upsetting than the software changes as it's clearly a more manual (or scripted) process which could easily give credit.
19:28:38 <coling> So, in order to address this we will do two things:
19:28:52 <coling> 1) We (I) will attempt to convert the software stuff to use git.
19:29:15 <Kharec> maybe a #action ?
19:29:17 <coling> This should make collaboration much easier (both ways) and also provides a very obvious mechanism to maintain proper credit.
19:29:26 <coling> (in a minute)
19:29:31 <Kharec> sorry.
19:30:13 <coling> This will likely take some time, and will have a few manual tweaks in there, but it should be achievable in the nearish future.
19:30:56 <coling> and 2) We will write a Collaboration Policy that will outline the correct behaviour when using other peoples code.
19:31:10 <anaselli> coling: All you've said is true, but i think you cannot force other group to do that, you can just give a policy for us...
19:31:25 <coling> This will cover taking e.g. patches from Fedora packages git, or importing a spec based on a mandriva or fedora rpm etc.
19:31:47 <coling> anaselli, correct. However, if we have such a policy, it can be used to set an example.
19:32:05 <coling> anaselli, I think we have to lead by example rather than just complain.
19:32:09 <ennael> and also you can ask others to do the same as we ourselves did it inside Mageia
19:32:22 <ennael> coling: check :)
19:32:34 <AL13N> cf the thread on cooker
19:32:43 <anaselli> well i believe the example is easier than ask to others
19:33:03 <coling> So I think I've covered the basic points there ennael. anything to add?
19:33:31 <ennael> nope
19:33:32 <anaselli> i will be more careful when i get a patch or a spec somewhere...
19:33:48 <ennael> so policy can be written in coming week I guess
19:33:55 <coling> Yup.
19:34:16 <anaselli> coling: just a silly question
19:34:19 <AL13N> coling: so, plan is that after policy is written to point it out on the cooker thread?
19:34:30 <coling> AL13N, yeah I think that would be best.
19:34:36 <anaselli> if i take a patch from fedora, how can i be sure is it from fedora?
19:35:20 <coling> anaselli, that's a fair point. Most of the time these days they tend to use git formatted patches, and the package history is easy to explore so you can look at the commit logs of the patch too.
19:35:57 <coling> anaselli, All in all we can only credit where we got the patch from. If it was ultimately sourced somewhere else I think this is still OK.
19:36:04 <anaselli> coling: but no one ensures the commiter is the real author...
19:36:24 <anaselli> ok same point then :)
19:36:31 <coling> anaselli, It's more to credit where we got the patch from rather than who wrote it originally. Ideally the patch itself would contain the who.
19:36:34 <ennael> #url https://wiki.mageia.org/en/Collaboration_policy
19:36:35 <erzulie> [ Collaboration policy - Mageia wiki ]
19:37:34 <Solbu> The change to git will be another nice switch, as git is better it many ways, according to those who claim to know the difference. (Like Mr. Torvalds :-)= )
19:37:34 <Umeaboy> coling: ping
19:37:42 <coling> Umeaboy, meeting in progress, please wait.
19:37:46 <Umeaboy> Uhu.
19:38:00 <ennael> ok anything to add on that topic ?
19:38:07 <ennael> comments questions ?
19:38:23 <coling> ennael, the only thing would be regarding the git conversion itself, we may need to liaise with i18n
19:38:28 <anaselli> let's say we can discuss on mailing list the wiki page :)
19:38:30 <AL13N> no, i think it's only proper and ethical
19:38:42 <ennael> ovitters: yep
19:38:43 <coling> As we may need infrastructure to support it, but this is more an implementation detail.
19:39:17 <anaselli> coling: well i18n can stay on svn in the very first time...
19:39:22 <ennael> so who will write the policy.
19:39:23 <ennael> ?
19:39:29 <ovitters> ennael: ?
19:39:31 <coling> ennael, I can take a first stab.
19:39:39 <ennael> ok
19:39:53 <ennael> then mail -dev to check everything is there
19:40:02 <coling> ACK
19:40:11 <ennael> thanks coling :)
19:40:30 <ennael> now you can give up armor and helmet :)
19:40:37 <anaselli> coling: if you need, call me i will review it or help (less :) )
19:41:23 <ennael> ok next topic?
19:41:33 <anaselli> ennael: features or backports? :)
19:41:37 <coling> anaselli, thanks :)
19:41:59 <ennael> #topic reminder: Mageia 3 features
19:42:14 <anaselli> coling: but you have to shout ;)
19:42:25 <ennael> so this is just a reminder about features
19:42:41 <ennael> here is the first list
19:42:42 <ennael> https://wiki.mageia.org/en/Category:ProposedFeatureMageia3
19:42:43 <erzulie> [ Category:ProposedFeatureMageia3 - Mageia wiki ]
19:43:03 <ennael> so please we need to focus on this
19:43:15 <ennael> about 1 week remaining for this
19:43:36 <andre999> I have an idea about isos
19:43:49 <ennael> about isos
19:44:00 <ennael> we will have a discussion about it
19:44:10 <ennael> with packagers, QA, i18n, marcom and so
19:44:20 <ennael> as the current situation is hard to manage
19:44:34 <ennael> so rethink about a precise list of isos, which content...
19:44:49 <ennael> maybe after features are done
19:44:55 <ennael> ok ?
19:45:01 <andre999> i thought of making sort of composite isos -- ok
19:45:23 <ennael> at the moment as I said to marja we have 1 guy = 1 proposal for isos
19:45:31 <ennael> I guess QA will get made quickly :)
19:45:57 <MrsB> qa proposal is 'fewer' iso's :D
19:46:02 <ennael> :)
19:46:09 <ennael> ok any questions on features?
19:46:15 <DavidWHodgins> One live dvd, instead of so many live cds.
19:46:20 <ennael> please
19:46:30 <Solbu> I had an idea earlier today.
19:46:37 <ennael> not now please
19:46:46 <andre999> would it be a good idea to combine all iso ideas on one feature page ?
19:46:53 <ennael> nope
19:46:59 <Solbu> I noticed that there was a dual CD-iso. Wouldn't it make more sens that the dual arch  was a DVD?
19:47:01 <ennael> feature is really what we want to do
19:47:20 <ennael> we need first to discuss and then write down feature
19:47:42 <ennael> the thing is packagers are not the only one to thing about that topic
19:48:16 <ennael> ok other questions?
19:48:16 <sebsebseb> ennael: what's the page for adding a feature request? :d
19:48:33 <ennael> ...
19:48:34 <sebsebseb> the link you just gave just been having a look
19:48:41 <anaselli> well i think we need developers also here
19:48:45 <Umeaboy> sebsebseb: https://wiki.mageia.org/en/Category:ProposedFeatureMageia3
19:48:46 <erzulie> [ Category:ProposedFeatureMageia3 - Mageia wiki ]
19:48:47 <AL13N> the feature policy page
19:49:00 <ennael> ok
19:49:04 <sebsebseb> Umeaboy: yeah, but it's in categories going to other pages etc
19:49:07 <AL13N> https://wiki.mageia.org/en/Features_policy
19:49:08 <erzulie> [ Features policy - Mageia wiki ]
19:49:09 <ennael> #topic backports
19:49:31 <ennael> so we need to move on that subject
19:49:41 <ennael> it was discussed in last QA meeting
19:49:45 <Umeaboy> I've been wishing for backports for a longer time.
19:49:48 <ennael> MrsB: wants to speak ?
19:49:53 <MrsB> Yes if you like
19:50:02 <ennael> give QA position
19:50:37 <Umeaboy> Especially when it comes to keeping updated with hardware-drivers & such.
19:50:37 * tmb read poison
19:51:05 <ennael> :))
19:51:05 <MrsB> We agreed that it would be OK to open backports. QA would view them as having the lowest possible priority. We have had packages backported into mga1 as updates as they were in mandriva so we have been doing it to some extent already.
19:51:23 <MrsB> We'd ideally like the person requesting the backport to agree to help test it
19:51:30 <Stormi> or find testers
19:51:32 <Umeaboy> Yes.
19:51:43 <ennael> as a reminder
19:51:44 <ennael> https://wiki.mageia.org/en/Backports_policy
19:51:45 <erzulie> [ Backports policy - Mageia wiki ]
19:51:58 <Umeaboy> Uuuhm. Perhaps have a minimum of 5 testers to import it as a Backport?
19:51:59 <andre999> like our original proposals for backports
19:52:09 <Stormi> like I said during QA meeting, if backports are slow to validate, it will mechanically incitate users to help testing, if they really want the backports
19:52:09 <ennael> #info QA is ok to work on backports tests with lower priority / updates
19:52:32 <ennael> boklm: around?
19:52:50 <MrsB> could you add info that we'd like the person requesting the backport to help with testing too pls
19:52:50 <boklm> yes
19:53:04 <Solbu> One reason for having backports is to provide pakcages that doesn't exist in current releases.
19:53:10 <AL13N> is it better for the packager to QA test his own backport, or better to test other people's backports/updates?
19:53:18 <ennael> #info QA would like the person requesting the backport to help with testing too
19:53:26 <MrsB> tnx
19:53:32 <Umeaboy> AL13N: I'd say the second choice.
19:53:45 <MrsB> We're envisioning backport requests will come from users
19:53:51 <ennael> boklm: so as we said this afternoon backports can be managed within 1 week ?
19:53:57 <Stormi> AL13N: one might suppose the packager has tested locally at least
19:54:00 <boklm> I think yes
19:54:20 <ennael> #action sysadmin team will activate backport in coming week
19:54:26 <Stormi> hooray
19:54:31 <Umeaboy> Yaaaay!
19:54:39 <andre999> preliminary testing by the packager locally + testing by others to find what the packager might have missed
19:54:39 <Solbu> Question: Will enabeling backports mean that mga1 and 2 can start having packports or is this for mga3 an onwards?
19:54:52 <anaselli> no problem for earlier tests as bp packager
19:54:53 <ennael> all supported versions
19:55:00 <Solbu> :-)=
19:55:07 <andre999> :)
19:55:19 <ennael> we will communicate more when it's all ready
19:55:28 <Umeaboy> Right.
19:55:31 <ennael> policy, testers needed, quality...
19:55:58 <leuhmanu> maybe we can add a new component in the bugzilla ?
19:55:58 <ennael> questions ?
19:56:11 <Umeaboy> No, not really.
19:56:16 <leuhmanu> because it's a little behind with only a keyword
19:56:19 <Umeaboy> leuhmanu: Yes.
19:56:23 <Umeaboy> I'd like that.
19:56:50 <AL13N> leuhmanu: component?
19:57:11 <AL13N> for backport request?
19:58:34 <tmb> one thing...
19:58:35 <ennael> tmb: yep ?
19:58:35 <boklm> leuhmanu: a backports component ?
19:58:35 <Solbu> About testers. Maybe there should be a page on the wiki that talks a little about what it means to be a tester. Like what does he do, how does he test.
19:58:35 <leuhmanu> boklm: yes like for rpm request
19:58:35 <ennael> Solbu: it's all on QA pages
19:58:35 * Umeaboy agrees.
19:58:35 <Solbu> Right. :-)=
19:58:35 <tmb> we should state in policy how long a package can stay in updates_testing before getting wiped again
19:58:35 <rqcursq> any help for QA needed ?
19:58:35 <rqcursq> :)
19:58:35 <tmb> and backports_testing
19:58:35 <ennael> meaning removing it if no tests coming.
19:58:35 <MrsB> always rqcursq
19:58:35 <ennael> ?
19:58:36 <Umeaboy> Will translations ever be put in backports?
19:58:50 <MrsB> rqcursq: https://wiki.mageia.org/en/QA_Team_portal
19:58:51 <erzulie> [ QA Team portal - Mageia wiki ]
19:58:52 <andre999> Umeaboy: why not if a separate package ?
19:58:53 <tmb> yep, and so no-one start using the _testing medias as "lets upload it there and forget about it..."
19:59:10 <leuhmanu> tmb: indeed...
19:59:11 <andre999> tmb: good point
19:59:28 <ennael> volunteer to add this on wiki ?
19:59:34 <leuhmanu> we have ff and thunderdird without bug yet..
19:59:48 <andre999> ok :)
19:59:55 <leuhmanu> AL13N: yes
20:00:01 <AL13N> sorry, had lag
20:00:19 <Umeaboy> Perhaps an automated function that pulls some package from Backport to Core if it isn't touched in like 5 days.
20:00:51 <leuhmanu> Umeaboy: please read again what is core and backport
20:01:02 <Umeaboy> OK.
20:01:09 <DavidWHodgins> Umeaboy: That seems a bit short.  Some packages take a while to figure out how to test.
20:01:27 <Umeaboy> My view of a Backport is something that's considered stable enough to be in Core-medias.
20:01:59 <Umeaboy> I may be wrong thou.
20:02:07 <Solbu> Umeaboy: You cannot add anything to core once a new release is out. THat is where backports comes in.
20:02:33 <DavidWHodgins> My view is that backports are new versions, or packages not in core.  Must be stable enough not to break a newbies system.
20:02:48 <MrsB> or a qa system
20:02:59 <DavidWHodgins> :-)
20:03:02 <Solbu> :-)=
20:03:04 <leuhmanu> Umeaboy: backport vs backport_testing
20:03:25 <Umeaboy> OK.
20:03:33 <linuxguy101> how can pclinux create a new fire fox rpm and mageia cant
20:03:36 <linuxguy101> they are on 13 now
20:03:42 <AL13N> ok, so... is this topic closed?
20:03:43 <AL13N> next?
20:03:49 <Umeaboy> linuxguy101: Because noone requested such atm?!
20:03:53 * coling has to go... (offtopic: tmb when you get a mo' can you reply to the coreutils message on the ML? I need to update it in mga2 to get cyrus-imap to work OOTB)
20:03:54 <Stormi> linuxguy101: we're in a meeting right now
20:04:00 <linuxguy101> oh sorry
20:04:01 <leuhmanu> linuxguy101: read our release notes please
20:04:08 <ennael> #topic non-free firmware management
20:05:27 <ennael> mmm looks like we are missing people
20:05:55 <ennael> we need to solve this topic with one solution or another
20:06:18 <andre999> we need an "essentially free" dvd with non-free firmware where no reliable free firmware is available
20:06:38 <andre999> at least for major hw - in my view
20:07:30 <AL13N> ennael: worst case, we can vote between the existing solutions
20:07:38 <ennael> ok we will take existing ML thread and propose solutions then choose
20:07:44 <AL13N> ok
20:07:54 <ennael> but still main guys discussing it are not there
20:07:56 <Solbu> andre999: "where no reliable free firmware is available" ?
20:08:11 <Solbu> you mean unreliable?
20:08:14 <ennael> #topic mentoring review
20:08:15 <andre999> if we must make totally free dvds, couldn't we develop the dvds with non-free firmware,then just remove the non-free for the totally free version ?
20:08:17 <Umeaboy> And we need more testers for Audio & Video-drivers & firmware as well.
20:08:19 <AL13N> ennael: i guess we'll have to defer it to next time? or decide in thread? or something?
20:08:19 <ennael> andre999: your turn
20:09:10 <doktor5000_> ennael: also here :)
20:09:26 <ennael> andre999: ping ?
20:09:27 <andre999> ok, i've started working on inviting new packagers again
20:09:54 <Umeaboy> What about a HCL/wiki-page for firmware management?
20:09:58 <andre999> since pre-release potential mentors were occupied
20:10:00 <ennael> Umeaboy: please
20:10:10 <Umeaboy> Perhaps the Errata will do.
20:10:35 <ennael> andre999: can you give the wiki link here for mentoring?
20:10:36 <andre999> we now need more apprentices
20:10:58 <andre999> ok a moment
20:11:22 <AL13N> is there any apprentice waiting atm? or are all apprentices taken?
20:11:31 <rindolf> andre999: do all apprentices have mentors? Or are there candidates that aren't apprentices yet?
20:11:45 <doktor5000_> https://wiki.mageia.org/en/Becoming_a_Mageia_Packager#Packager_apprentice_candidates
20:11:45 <erzulie> [ Becoming a Mageia Packager - Mageia wiki ]
20:11:45 <andre999> essentially yes
20:11:53 <rqcursq> any approval for becoming mageia packager
20:12:04 <rqcursq> ?
20:12:16 <andre999> https://wiki.mageia.org/en/Becoming_a_Mageia_Packager
20:12:17 <erzulie> [ Becoming a Mageia Packager - Mageia wiki ]
20:12:22 <rqcursq> I saw my name in https://wiki.mageia.org/en/Archive:Initially_registered_Packagers
20:12:23 <erzulie> [ Archive:Initially registered Packagers - Mageia wiki ]
20:12:34 <andre999> https://wiki.mageia.org/en/Becoming_a_Mageia_Mentor
20:12:35 <erzulie> [ Becoming a Mageia Mentor - Mageia wiki ]
20:13:11 <ennael> #info apprentices have now nearly all a mentor, we are looking for new apprentices
20:13:50 <andre999> there is no potential apprentice that responds to emails
20:14:36 <ennael> ok we can call for it
20:14:36 <rqcursq> i can start from 8th june to packaging?
20:14:36 <ennael> blog, ML...
20:14:36 <andre999> and I'm sure that we have at least a few willing mentors available
20:15:13 <AL13N> andre999: what about existing padawans? are they progressing towards full packagers?
20:15:22 <ennael> #action call for apprentices to be done in coming days
20:15:48 <MrsB> rqcursq: I think you have to put your name on a list on the wiki somewhere
20:16:03 <andre999> AL13N: I'm not sure, slowly they seem to be graduating
20:16:07 <MrsB> andre999: a volunteer ^^
20:16:12 <andre999> like solbe
20:16:24 <AL13N> andre999: perhaps the mentors could reactivate their padawans of sorts?
20:16:48 <rqcursq> I have my name in here https://wiki.mageia.org/en/Archive:Initially_registered_Packagers but i don't have an account for pushing to repo
20:16:48 <erzulie> [ Archive:Initially registered Packagers - Mageia wiki ]
20:17:04 <andre999> actually some new packagers have yet to (officially) maintain a package
20:17:11 <AL13N> rqcursq: you can read and follow https://wiki.mageia.org/en/Becoming_a_Mageia_Packager
20:17:12 <erzulie> [ Becoming a Mageia Packager - Mageia wiki ]
20:18:05 <ennael> ok next topic?
20:18:33 <AL13N> ok
20:18:40 <andre999> rqcursq: under what id ?
20:18:46 <rqcursq> regularlambda
20:18:52 <MrsB> bug 2317?
20:19:09 <ennael> #topic bug #2317
20:19:14 <ennael> as a reminder
20:19:15 <ennael> https://bugs.mageia.org/show_bug.cgi?id=2317
20:19:17 <erzulie> [ Bug 2317 - --update option should behave like --search-media <list of the update media> ]
20:19:18 <andre999> aha - I sent you an email a while back ...
20:19:39 <MrsB> please please please please please can we fix it :)
20:19:49 <Stormi> same as MrsB :)
20:20:23 <AL13N> https://wiki.mageia.org/en/Feature:UpdatesCanUseDependenciesFromOtherRepos
20:20:24 <erzulie> [ Feature:UpdatesCanUseDependenciesFromOtherRepos - Mageia wiki ]
20:20:49 <Stormi> the real problem is not urpmi --update but rather MageiaUpdate
20:21:20 <AL13N> Stormi: that may be true, but fixing this for cli is nice too
20:21:22 <Stormi> (AFAIK it does not issue a urpmi --update but directly uses perl bindings)
20:21:30 <AL13N> oh
20:21:44 <MrsB> It affects the installer also in the upgrade process
20:22:01 <AL13N> perhaps the details could be added to that feature page
20:22:14 <AL13N> of both MageiaUpdate and Installer
20:22:18 <MrsB> We're not requesting it fixed in mga3
20:22:24 <AL13N> of course not
20:22:39 <AL13N> but if it's not an a wiki page, it 'll never be done
20:22:47 <ennael> again people working on this are not around
20:22:49 <tmb> MrsB: well, technically you are :)
20:23:05 <AL13N> does Installer also use the perl bindings? or does it use urpmi directly?
20:23:10 <tmb> but you dont want to wait for mga3 to get released :)
20:23:12 <AL13N> Stormi: tmb: ^^ ?
20:23:12 <ennael> :)
20:23:36 <Stormi> AL13N: I don't know
20:23:38 <MrsB> exactly tmb
20:23:42 <proyvind> installer doesn't use perl bindings
20:23:50 <MrsB> ideally we'd like it fixed yesterday
20:24:07 <proyvind> and IIRC the updater (if it's based on mandriva update), is very much using urpmi code
20:24:20 <DavidWHodgins> Bug 5687 is closely related, as the installer really needs to do the same as a urpmi --auto-select.
20:24:22 <proyvind> with the ugliest code quality of all the tools using it
20:24:37 <ennael> ok we will mail -dev ML and ask for comments on this
20:24:47 <boklm> it seems that tv doesn't want to change this, as he think it will make MageiaUpdate too slow, so maybe someone should provide a patch to change it, and make some speed comparisons with and without patch
20:24:57 <tmb> mgaonline is the package that needs to be fixed andd backported to mga2 and mga1
20:25:04 <MrsB> It has been 'ignored' for so long because QA have been able to work around the bug
20:25:52 <MrsB> It's seen as low priority for that reason I think
20:26:00 <AL13N> but, chances are that if it's fixed in perl-URPM, that both urpmi and MageiaUpdate will be fixed
20:26:03 <DavidWHodgins> There are likely many cases we miss though, as upgrades make it much more complicated.
20:26:17 <tmb> yep, and the "speed factor" goes missing as time goes by as we end up linking half of /release into /updates
20:26:47 <Stormi> also, speed would not be impacted  for update detection, only for installation
20:27:06 <Stormi> (at least the applet should not use much more cpu)
20:27:41 <anaselli> Stormi: using a local mirror should help, but during installation is the cpu that does the difference
20:27:51 <tmb> not to mention the "extra time" it takes for mgaonline to analyze deps can be ignored as it runs in the backgrounf
20:28:02 <tmb> background*
20:28:13 <proyvind> hmm
20:28:23 <proyvind> urpmi is spending veryvery little time on analyzing dependencies actually..
20:28:40 <proyvind> most of the time spent when using urpmi is on loading the metadata  actually
20:29:00 <anaselli> tmb: it is if you don't need to install any packages in the mean while :)
20:29:07 <AL13N> so, if the linking is removed, there's less metadata?
20:29:36 <boklm> so now we need someone to provide a patch for this
20:29:39 <proyvind> and since the synthesis metadata that urpmi uses is so light, it's the main reason why it's so much faster than the others, ie. suse's zypper is shitloads faster at dependency resolution, but that only makes up for a minor part of the time..
20:29:40 <tmb> AL13N: well, update media metadata will be smaller, yes
20:29:59 * Stormi thinks proyvind wants to propose a patch
20:30:09 <Stormi> :)
20:30:09 <Solbu> :-)=
20:30:23 <proyvind> synthesis for update medias are so small already so that any reductions in size wouldn't give any noticable differences anyways..
20:30:37 <tmb> and since /release tree is frozen, the metadata only needs to be downloaded once
20:30:48 <proyvind> tmb: totally
20:31:11 <AL13N> i can try to take a look, but i'm not familiar enough with perl-URPM, i'd rather at least someone experienced helps or reviews at the very least
20:31:21 <proyvind> Stormi: no patches, not today, I have way less time to spend on these things than I'd like to already..  :/
20:31:27 <MrsB> \o/
20:31:35 <proyvind> but feel free to CC me on the bugzilla entry
20:31:45 <proyvind> and I might come back look at it and share some thoughts
20:31:45 <AL13N> in short, i can't do it on my own and i'd rather not be responsible for it
20:32:06 <tmb> and we need to remove the "add update medias only" option from media manager
20:32:19 <boklm> yes
20:32:23 <Solbu> Why?
20:32:25 <AL13N> yes
20:32:33 <leuhmanu> because it's confuse
20:32:39 <anaselli> so what all or nothing?
20:32:51 <boklm> Solbu: because having only update media will not be supported in that case
20:33:18 <Solbu> boklm: That i understood. but why?
20:33:43 <AL13N> Solbu: because of this bug, if it's fixed, it's no longer workarounded
20:33:44 <boklm> because some update packages can require packages in release
20:33:46 <DavidWHodgins> Because dependencies may have to come from release
20:33:53 <proyvind> I don't think most knows much about any difference about it, even less people cares about it..
20:34:12 <AL13N> well, if anyone experienced step forward to help me with it
20:34:34 <AL13N> or someone does it on their own, because i might be dragging him/her down
20:34:39 <proyvind> AL13N: /msg me an url with a reference or something and I'll take a look later
20:34:45 <proyvind> I'm about to leave the office now
20:35:10 <proyvind> or soon at least.. :o)
20:35:26 <AL13N> ,bug 2317
20:35:28 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=2317 critical, High, ---, thierry.vignaud, NEW, --update option should behave like  --search-media <list of the update media>, rpmdrake-5.26.10-1.mga1.src.rpm
20:35:30 <erzulie> [ Bug 2317 - --update option should behave like --search-media <list of the update media> ]
20:35:37 * MrsB shudders
20:35:45 <AL13N> MrsB: sorry
20:35:46 <boklm> so we can send an email on -dev mailing list, to remind people about this bug, and ask if anyone wants to provide a patch
20:35:51 <AL13N> ok
20:36:02 <proyvind> AL13N: /msg, I'm tired and have no intention of reading it now and I rarely read backloags.. ;)
20:36:10 <ennael> boklm: ok
20:36:18 <anaselli> proyvind: at office... soon is an odd word at this time in our local time :p
20:36:34 <ennael> #action ennael will sen a mail about this bug to ask for participation (patch...)
20:36:36 <MrsB> can it be phrased with some urgency, this is really a pain for qa
20:36:49 <ennael> doing it now
20:36:59 <ennael> ok anything else for tonight ?
20:37:02 <MrsB> I mean the words not the email :D
20:37:04 <proyvind> anaselli: aren't we in pretty much almost same or at least close timezone?
20:37:06 <AL13N> MrsB: just don't validate updates until this is fixed :-)
20:37:19 <ennael> proyvind: please we are in meeting
20:37:20 <anaselli> proyvind: we should
20:37:25 <tmb> one somewhat related thing...
20:37:50 <ennael> MrsB: do not hesitate to post on -dev to enforce this topic
20:37:56 <ennael> for QA team
20:38:03 <MrsB> I'll do that, thanks
20:38:07 <ennael> ok
20:38:11 <ennael> other topic pending?
20:38:20 <tmb> yep, for mga1 we keep every version of every package in updates tree for easy regression testing
20:38:30 <anaselli> so AL13N you must be in a hurry writing that patch :D
20:38:35 <ennael> oh I've got one
20:38:52 <ennael> #topic maintainance management
20:39:00 <ennael> it's part of post-mortem in fact
20:39:20 <boklm> tmb: and all versions are shown in rpmdrake ?
20:39:22 <ennael> we need clear position on what to do when packages are just let without maintaince
20:39:27 <ennael> maintainance
20:39:45 <ennael> it's the case for example for ruby since Mageia 1
20:39:45 <anaselli> you mean assigned to anybody?
20:40:03 <AL13N> i say we drop in cauldron unmaintained packages
20:40:04 <leuhmanu> or assigned but not reall active maintainer
20:40:10 <anaselli> or just that no one cares about?
20:40:13 <AL13N> maybe we can do a call for maintainers first thoguh
20:40:27 <leuhmanu> like with cjw, supp
20:40:36 <ennael> how long should we wait for without any answer?
20:40:45 * anaselli doesn't know them :/
20:41:22 <doktor5000_> depending on the packages i'd say at least one or two months or so ...
20:41:23 <anaselli> ennael: and what to do if not really maintained? we can't remove all the unmaintained packages
20:41:29 <anaselli> some are important
20:41:42 <boklm> anaselli: that's not the same topic
20:41:50 <Solbu> About the unmaintained packages list, are current and obsoleted and to-be-droped packages on the same list?
20:41:54 <andre999> tmb: rather make ADD updates available only if release active.  we should do the same for updates-testing, backports* also
20:42:08 <doktor5000_> anaselli: if they were so important, someone should/would care
20:42:18 * anaselli maybe has not explained his point well :/
20:42:37 <leuhmanu> all ruby-*** is a good example
20:42:39 <anaselli> that can happen though
20:42:41 * AL13N agrees with doktor5000_
20:42:48 <anaselli> ruby is good example
20:42:59 <ennael> doktor5000_: well you can care but there is still a maintainer in database
20:43:05 <ennael> and this maintainer is missing in action
20:43:10 <rindolf> I'm willing to volunteer to maintain the ruby packages.
20:43:18 <ennael> so we need soemthing official to say
20:43:21 <AL13N> oh wow
20:43:22 <boklm> first we should detect inactive packagers
20:43:30 <ennael> X has not answered for x days
20:43:35 <AL13N> we need to take into account vacations
20:43:40 <AL13N> some people are 2months on vacation
20:43:48 <MrsB> well done rindolf :)
20:43:50 <boklm> AL13N: they should warn in that case
20:43:51 <anaselli> so we need to look for other maintainer
20:44:05 <ennael> if people warn about vacations there is no pb
20:44:06 <leuhmanu> and some since 10 months
20:44:12 <ennael> wait please
20:44:25 <ennael> everybody speaking at same time is hard to follow
20:44:28 <AL13N> so, what timeframe are we speaking of: 2 weeks?
20:44:34 <ennael> wait
20:44:40 <AL13N> k sorry
20:44:46 <ennael> before that peple leaving for some time should mail about it
20:44:47 <ennael> ok?
20:44:53 <AL13N> ok
20:44:55 <Solbu> boklm: Why should they? in some occupations about 2 months vacations is the norm.
20:44:56 <tmb> yep
20:44:59 <ennael> so that people can help in between
20:45:08 <AL13N> agreed
20:45:24 <ennael> then if no such thing happened
20:45:28 <boklm> they should add their name on https://wiki.mageia.org/en/Absent and send an email
20:45:30 <erzulie> [ Absent - Mageia wiki ]
20:45:31 <ennael> how long should we consider ?
20:45:41 <leuhmanu> Solbu: the bugsquad need to know that in release time..
20:45:55 <AL13N> 2 weeks is good i think
20:45:58 <Umeaboy> What about if a user package a new version of something & has tested it to be OK, how can it become an official release in the future?
20:46:07 <boklm> 2 weeks is short
20:46:08 <ennael> please
20:46:08 <Umeaboy> Can we upload it to cauldron for testing?
20:46:12 <ennael> Umeaboy: please !
20:46:15 <leuhmanu> Umeaboy: of topic
20:46:26 <Umeaboy> OK.
20:46:41 <ennael> so how long should we consider a package is without maintainer?
20:46:43 * boklm would say 1 month
20:46:43 <Umeaboy> I thought the topic was packaging.
20:46:56 <Solbu> Umeaboy: Read the topic. ;-)=
20:47:03 <ennael> 1 month is ok?
20:47:18 <anaselli> without packaging or without answering any mails?
20:47:19 <AL13N> so, this 1 month to reply on bug report???
20:47:20 <ennael> 1 month without any answer
20:47:21 <AL13N> it's long
20:47:26 <Umeaboy> What kind of maintanance management?
20:47:29 <doktor5000_> ennael: as already said, maybe more like 1-2 months
20:47:38 <ennael> let start with 1 month
20:47:38 <anaselli> one month could be ok
20:47:39 <AL13N> especially during alpha and such
20:47:43 <ennael> we can change it later
20:47:57 <AL13N> ok fine
20:48:00 <ennael> it does not prevent people to provide updates in between if needed
20:48:01 <doktor5000_> 1 month starting by a mail directed at maintainer, some don't read bugzilla mails
20:48:27 <ennael> then if no answer for 1 month a mail is sent
20:48:36 <anaselli> neither if they are the assignees?
20:48:36 <ennael> and package proposed on -dev
20:48:38 <AL13N> doktor5000_: bugzilla mails are assigned to maintainer, so he get's an email
20:48:43 <ennael> is that ok.
20:48:44 <ennael> ?
20:48:48 <AL13N> ok
20:48:49 <boklm> ok
20:48:52 <anaselli> fine
20:49:08 <ennael> now how can we detect this automatically
20:49:09 <ennael> ?
20:49:17 <leuhmanu> AL13N: read vs get
20:49:18 <AL13N> bugsquad?
20:49:20 <ennael> Bugzilla ? pending updates ?
20:49:41 <AL13N> is there some saved search that can do this?
20:49:47 <leuhmanu> what should we do after 1 month ?
20:49:54 <ennael> aaaaaaah
20:50:04 <ennael> 22:48 < ennael> then if no answer for 1 month a mail is sent
20:50:07 <ennael> 22:48 < ennael> and package proposed on -dev
20:50:18 <doktor5000_> ennael: pending updates would be ok, but imho we'd need more people who create security bugs like Luigi12 and sysadmins do for that ...
20:50:19 <leuhmanu> ah
20:50:21 <AL13N> leuhmanu: can we detect this in bugzilla?
20:50:39 <ennael> bugzilla statistics fans, can we have such thing?
20:50:40 <boklm> we can probably have automatically a list of people who didn't commit for more than one month, and use this list to search for inactive maintainers
20:51:05 <ennael> boklm: well packages may not need commits for 1 month
20:51:12 <leuhmanu> what to do with packager that commit without reading bugs ?
20:51:12 <ennael> does not mean they are unmaintained
20:51:22 <AL13N> leuhmanu: is a bad packager
20:51:23 <ennael> leuhmanu: they should not be packagers
20:51:24 <boklm> ennael: yes, but this list is manually checked
20:51:31 <ennael> so several lists
20:51:36 <anaselli> ennael: i missed a point after a month, the maintainer is removed as maintainer with a mail and the package is proposed to mailing list?
20:51:36 <ennael> commits, bugs
20:51:47 <boklm> this list is only used to find potential inactive maintainers
20:51:51 <ennael> anaselli: as proposed twice already :)
20:52:04 <ennael> so using bugzilla and commits
20:52:12 <AL13N> perhaps a bugzilla list and a commit list can be used to crossmatch
20:52:13 <anaselli> but i thought to wait his answer first :)
20:52:16 * leuhmanu kill all packagers
20:52:48 <ennael> ok
20:52:49 <Solbu> Removing someone as maintainer as the first thing, seems rather harsh?
20:52:50 <AL13N> leuhmanu: can you find us a way to search inactive assigned people in bugzilla?
20:52:54 <ennael> so to summarize
20:53:08 <leuhmanu> AL13N: of course, marja do already that in some point
20:53:16 <ennael> #info a packager has to mail -dev and add vacations in wiki if leaving for a long time
20:53:46 <ennael> #info if nothing is done within 1 month, a mail is sent to him and packages proposed for maintainance on -dev
20:54:08 <ennael> #info commits activity and bugzilla will be used to detect inactive packagers
20:54:15 <ennael> is that it?
20:54:20 <leuhmanu> ok
20:54:20 <AL13N> maybe confirm with absent wiki page
20:54:21 <boklm> I don't know if we can do it with bugzilla
20:54:33 <anaselli> yes consider case by case anyway...
20:54:38 <ennael> no answer on bugs
20:54:46 <anaselli> maybe a bug can't be fixed
20:54:46 <rqcursq> :file pomed
20:54:51 <ennael> triage team, a task for you :)
20:54:53 <boklm> ok
20:55:00 <ennael> anaselli: then wont'fix
20:55:21 <ennael> we need to add this on policy
20:55:27 <ennael> just looking for the proper one
20:55:27 <Solbu> So is the proposal to assume that if rindolf for some reason doesn't do anything for a month, that we assume he is inactive and propose his packages on the list, and remove him as packager?
20:55:42 <rqcursq> :findfile pomed
20:55:43 <Sophie> rqcursq: Sorry, no file pomed found in (Mageia, cauldron, i586)
20:55:45 <ennael> Solbu: he will be mailed to ask about it
20:55:47 <anaselli> ok let's see i'm not sure it's the right solution, but i can see only my bugs :)
20:56:05 <rqcursq> :q pomed
20:56:09 <Sophie> rqcursq: Nothing matches `pomed' in (Mageia, cauldron, i586)
20:56:14 <rqcursq> :(
20:56:19 <ennael> rqcursq: please meeting in progress
20:56:23 <rindolf> rqcursq: there's a meeting in progress.
20:56:25 <AL13N> rqcursq: you can ask Sophie in private
20:56:27 <anaselli> certainly i'm one who answers for the most :p
20:56:29 <Umeaboy> rqcursq: Take it in PM with Sophie.
20:56:34 <rqcursq> sorry
20:56:41 <Solbu> ennael: Then the packager should be given a time to respone before mailing the -dev asking for someone to take his packages. Like a week.
20:57:10 <anaselli> Solbu: ah ah. so you got my point :D
20:57:21 <Solbu> The mail should also say this in plain text.
20:57:44 <ennael> shall we create a policy for packagers
20:57:46 <AL13N> 1 day should suffice
20:57:53 <ennael> I cannot see anything about thhis
20:58:01 <Solbu> AL13N: that is to short.
20:58:01 <sander85> send mail and wait how long before removing maintainership?
20:58:04 <AL13N> ok
20:58:22 <leuhmanu> anyway, personly I will only propose people case par case
20:58:30 <ennael> #action packager policy will be added
20:58:30 <Solbu> AL13N: what if the mail is sendt out on friday evening, and the pakcager is not reading mail untill he's back from the weekend?
20:58:43 <ennael> Solbu: no we wait for 1h
20:58:48 <anaselli> or three weeks. a mail, one week later a post to -dev
20:58:48 <boklm> Solbu: a 1 month weekend ?
20:58:49 <Solbu> Hehe
20:58:50 <ennael> if no answer he will be burnt
20:59:00 <Solbu> boklm: That is not my issue.
20:59:24 * doktor5000_ is afraid he willl lose his maintainership then - and his life also
20:59:37 <anaselli> ennael: witch :D
20:59:51 <Solbu> Hehe,.
20:59:58 <ennael> doktor5000_: well you can give these reasons then we do not remove maintainance
21:00:04 <AL13N> anaselli: hmm, kind of rude...
21:00:07 <boklm> doktor5000_: if you plan to be away for more than one month, you can add yourself to Absent wiki page
21:00:11 <ennael> but at lease we know you are alive :)
21:00:19 <Solbu> Either tehre is a miscommunication, or someone is not understanding what is beeing proposed.
21:00:25 <ennael> which is not the case of all current packagers
21:01:00 <ennael> anaselli: I'm proud of it :)
21:01:30 <ennael> ok we work on a draft and post it on -dev
21:01:33 <tmb> so something like 1 month inactive -> mail maintainer -> wait a week -> if no answer -> send mail to -dev asking for other maintainer, or atleast someone to fix bug / update package(s) in question
21:01:33 <anaselli> ennael: i know you since ages :D
21:01:34 <leuhmanu> :nb_rpm supp
21:01:35 <Sophie> leuhmanu: supp (Mageia) maintains 30 rpms
21:01:42 <leuhmanu> :nb_rpm cjw
21:01:42 <Sophie> leuhmanu: cjw (Mageia) maintains 11 rpms
21:01:53 <ennael> anything else ? question ?
21:01:53 <AL13N> so, 3weeks + mail +1week + removal? or 4weeks + mail + 1week + removal ???
21:02:05 <doktor5000_> :nb_rpm shikamaru
21:02:06 <Solbu> tmb: Yes.
21:02:07 <Sophie> doktor5000_: shikamaru (Mageia) maintains 278 rpms
21:02:19 <doktor5000_> rindolf: ^^^^
21:02:20 <sander85> i would prefer 5 weeks in total
21:02:29 <rindolf> doktor5000_: OK.
21:02:36 <ennael> next time we will write in red
21:02:58 <ennael> we said 1 month, a mail and then depending on the answer removing maintainance
21:02:58 <anaselli> with blood i know
21:03:00 <AL13N> hmm, due to lag, i may have missed part of conv
21:03:08 <anaselli> pacakger's of course ennael
21:03:13 * ennael likes blood after 23h
21:03:13 <AL13N> happend several times during this meeting
21:03:27 <boklm> 23h UTC ?
21:03:34 <AL13N> :-)
21:03:37 <ennael> 21hUTC
21:03:38 <ennael> :p
21:03:52 <ennael> ok I guess it's late and already 2h meeting
21:03:55 <AL13N> k
21:03:57 <agron_> Did you guys talk about mentoring yet? I just finished work.
21:04:06 <ennael> so thanks for attending
21:04:09 <AL13N> agron_: about to end meeting
21:04:17 <Solbu> I have one aditional point, regarding the meetings them selves.
21:04:29 <AL13N> agron_: you can read the archives after meeting ends
21:04:31 <ennael> and still you have -dev ML to discuss about all this if things are unclear, or irc
21:04:44 <ennael> see you next week
21:04:50 <ennael> #endmeeting