19:13:05 <ennael> #startmeeting
19:13:05 <Inigo_Montoya`> Meeting started Wed May 30 19:13:05 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:13:05 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:13:06 <erzulie> [ MeetBot - Debian Wiki ]
19:13:10 <ennael> hi all
19:13:40 <sebsebseb> hi :)
19:14:02 <ennael> #topic Mageia 2 release and post-mortem
19:14:25 <ennael> so quick topic
19:14:35 <ennael> again thanks and congrats all for this second release
19:15:07 <coincoin> hello
19:15:19 <ennael> if you are interested in reviews published on Mageia 2
19:15:22 <ennael> #url https://wiki.mageia.org/en/Mageia_2_Press
19:15:23 <erzulie> [ Mageia 2 Press - Mageia wiki ]
19:15:38 <ennael> if you see one not in list please feel free to add it
19:16:49 <ennael> so now that Mageia 2 is out please do not forget post-mortem
19:17:24 <ennael> hi tmb
19:17:29 <ennael> #url https://wiki.mageia.org/en/Mageia2_Postmortem
19:17:31 <erzulie> [ Mageia2 Postmortem - Mageia wiki ]
19:17:46 <ennael> #action fill packagers post-mortem within 2 weeks
19:17:51 <anaselli> ennael: italian ones talk about mandriva and mageia collaboration for server...
19:18:00 <anaselli> i think they're wrong posts
19:18:06 <ennael> if nothing is added it means nothing has to be changed :)
19:18:24 <anaselli> :)
19:18:36 <tmb> hi
19:18:51 <ennael> anything to add on post-mortem?
19:19:16 <ennael> (argh it kills them all)
19:20:41 * AL13N was reading reviews
19:21:10 <AL13N> the only thing i can think of is that there wasn't enough testing people and some features ended being fixed at the very last moment
19:21:11 <ennael> ok let swtch to second topic then
19:21:16 <AL13N> it's a bit too close for comfort
19:21:29 <ennael> AL13N: then add this in wiki not here
19:21:32 <AL13N> k
19:22:12 <ennael> so I hope your are all ready to go back on work
19:22:12 <ennael> :)
19:22:17 <ennael> #topic Mageia 3 planning
19:23:05 <ennael> we had a look on Mageia 2 planning and basically we think dates for devel releases were quite ok
19:23:11 <ennael> so here is the planning
19:23:20 <ennael> Alpha 1    04/09/2012
19:23:20 <ennael> Alpha 2    04/10/2012
19:23:20 <ennael> Alpha 3    06/11/2012
19:23:20 <ennael> Beta 1    12/12/2012
19:23:20 <ennael> Beta 2    11/01/2013
19:23:22 <ennael> Beta 3    12/02/2013
19:23:25 <ennael> RC        05/03/2013
19:23:27 <ennael> finale    20/03/2013
19:23:45 <sebsebseb> oh right you decided on a planning since MOnday
19:23:54 <ennael> #ino final release is planned for 20/03/2013
19:24:08 <pterjan> good
19:24:13 <tmb> have we checked gnome/kde release schedules ?
19:24:16 <sebsebseb> one little thing,  let's take Gnome for example,  with that planning Gnome 3.6, but the next month 3.8 comes out, then we have old
19:24:16 <ennael> #ino final release is planned for 20/03/2013
19:24:19 <ennael> argh
19:24:19 <pterjan> with the usual delay it will be on April 1st
19:24:25 <ennael> #info final release is planned for 20/03/2013
19:24:28 <ennael> pterjan: tsss :)
19:24:41 <ennael> for now it's spring release :)
19:24:55 <sebsebseb> I think the release planning should try and fit in when major verisons of Gnome and KDE are expected to be released, personally, even if that means a final isn't out of Mageia 3 untill April
19:24:58 <ennael> flowers in a geek world :)
19:25:40 <ennael> KDE is 3rd of may
19:25:55 <ennael> we may have rc version in mageia then update when it's out
19:25:55 <sebsebseb> Gnome 3.6 in September probably, and Gnome 3.8 in April probably
19:26:49 <ennael> freeze dates are not fixed for now
19:26:55 <ennael> we need to speak about this
19:27:00 <sebsebseb> rc version of what KDE?
19:27:06 <anaselli> ennael: it's almost near anyway, we will consider what to do when it's going to happen...
19:27:26 <ennael> yep
19:27:33 <ennael> dates are not frozen
19:27:41 <tmb> yeah, lets go with this initial planning for now and adjust if we feel the need
19:27:42 <ennael> but still let's target this planning for now
19:27:51 <ennael> :)
19:28:01 <ennael> so about freeze dates
19:28:08 <ennael> at least for packagers
19:28:09 <AL13N> which leaves us 3 months of development....
19:28:11 <sebsebseb> ok  Gnome 3.6 in Mageia 3 probably then, but much later than a lot of other distros
19:28:35 <ennael> AL13N: are you joking ?
19:28:40 <ennael> more than 5 months
19:28:40 <anaselli> so it should be much tested :p
19:28:58 <ennael> so freeze dates !
19:29:03 <ennael> version and release
19:29:22 <ennael> any proposal?
19:29:31 <ennael> shall we keep same kind of planning as mageia 2 ?
19:29:39 <ennael> #chair tmb boklm
19:29:39 <Inigo_Montoya`> Current chairs: boklm ennael tmb
19:29:52 <Kharec> hi there
19:29:52 <AL13N> yes
19:30:54 <anaselli> ennael: i think we can, so can you give some date?
19:30:57 <ennael> so something like 27/12 for version freeze ?
19:31:00 <anaselli> :)
19:31:21 <ennael> which may be not that good as everybody will be eating chocolates
19:31:33 <AL13N> between beta1 and 2?
19:31:40 <sebsebseb> It seems with the current planning around the time Mageia 3 comes out with Gnome 3.6, upstream come out with Gnome 3.8.
19:31:48 <ennael> so either we do it before christmas
19:32:03 <ennael> or in the beginning of january
19:32:05 <AL13N> ennael: better before
19:32:10 <pterjan> I think better after
19:32:12 <tmb> I'd say after new year
19:32:15 <ennael> :))
19:32:16 <anaselli> ennael: maybe we can consider to reache the new year's eve... with some holidays people could work more...
19:32:18 <ennael> fight !
19:32:19 <AL13N> nothing much will happen during anyway
19:32:22 <pterjan> people will have time during vacation :)
19:32:36 <AL13N> pterjan: if you put it like that :-)
19:32:43 <tmb> I know I for one have more time during holidays :)
19:32:50 <AL13N> ic
19:32:53 <AL13N> well, ok, after then
19:32:56 <ennael> so who would choose before?
19:33:09 <ennael> after ?
19:33:13 <pterjan> \o_
19:33:13 <AL13N> i'll change my opinion to after
19:33:16 <coincoin> I remind you that end of the world is december the 21th! So... before or after Xmas...
19:33:16 * coling is here... sorry I'm late....
19:33:39 <AL13N> definately after, so that if the world ends, we don't ahve to do all this work
19:33:45 <erwan_ta-> coincoin: would be fun
19:33:57 <leuhmanu> coincoin: Maya are wrong !
19:34:02 <ennael> so guys :)
19:34:08 <erwan_ta-> Instead of EOF we could have EOW
19:34:58 <ennael> 02/01/2013?
19:35:13 <ennael> will be nice to freeze in champagne
19:35:20 <Kharec> :)
19:35:29 <AL13N> sysadmin mightnot have ttime to do freeze on that day
19:35:38 <ennael> boklm: wdyt ?
19:35:47 <boklm> yes
19:35:48 <coincoin> erwan_ta-: :)
19:35:53 <boklm> we can do 02/01/2013
19:35:56 <ennael> ok
19:35:57 <tmb> I think 02/01/2013 is good
19:36:09 <ennael> #info version freeze will be on 02/01/2013
19:36:09 <pterjan> please, no freeze of champagne
19:36:11 <tmb> it gives us time for iso building and qa
19:36:13 <erwan_ta-> 2013 = 2 01 3 = 2/01/13
19:36:14 <ennael> :)
19:36:17 <boklm> :)
19:36:24 * ennael slaps erwan_ta-
19:36:36 <Kharec> :)
19:36:42 <ennael> recursivity in freeze may announce a total mess
19:36:43 <ennael> :)
19:36:49 <ennael> ok now release freeze
19:37:05 <sebsebseb> ok do version freeze on 2nd Jan
19:37:12 <pterjan> hmmm
19:37:17 <sebsebseb> people keep on wanting to push stuff after version freeze anyway, another reason having one a bit later could be good :D
19:37:24 <ennael> 21/02/2013
19:37:34 <ennael> sebsebseb: no way
19:37:40 <pterjan> when is fosdem ?
19:37:49 <ennael> beginning of february
19:37:53 <pterjan> ok
19:38:06 <sebsebseb> ennael: I meant if it was  in December,  then people would still want something in, that tiny bit more time to get something in before version freeze if it's later :D
19:38:14 <boklm> it would be nice to have freeze before fosdem, so people can buy beers to have freeze exceptions
19:38:21 <ennael> :))
19:38:24 <coling> :)
19:38:28 * coling likes that plan
19:38:29 <ennael> boklm: you will be able to with version freeze
19:38:32 <AL13N> hahaha
19:38:32 <coincoin> :)
19:38:51 <ennael> os what about 21/02/2013 ?
19:38:55 <ennael> so
19:38:57 <pterjan> ok
19:38:59 <sebsebseb> for what?
19:39:05 <sebsebseb> version freeze?
19:39:08 <AL13N> the dates are fine, it's mostly dependant on the possible changement of the release days anyway
19:39:14 <ennael> release freeze
19:39:18 <boklm> ok
19:39:21 <tmb> I think it's ok
19:39:33 <ennael> #info release freeze is 21/02/2013
19:39:41 <sebsebseb> ah right yeah, version freeze first, then release freeze after,  21st of the February for release freeze I guess that's ok
19:39:54 <tmb> and I suggest we will be more strict regarding exceptions this time
19:39:55 <anaselli> coling: only because you have the power now... and beers from your country are good :p
19:40:15 <ennael> tmb: yep but for what I've seen it was not that bad
19:40:23 <ennael> at least much better than some releases in mdv
19:40:45 <anaselli> tmb: just open backports, and i believe less exceptions ;)
19:40:58 <ennael> in fact it depends on coling :)
19:41:00 <ennael> oups :)
19:41:04 <tmb> oh, and string freeze should be atleast 1 week before release freeze, to give translators time to sync up
19:41:20 <lemonzest> tmb: tmb means??? i only know it from the awesome kernels :)
19:41:25 <ennael> yep so 14/02.2013
19:41:35 <ennael> st valentin day what a date !
19:41:41 <AL13N> oh noes
19:41:53 <lemonzest> ennael: Magia version <3
19:41:57 <AL13N> lol
19:41:58 <sebsebseb> by the way I  think Gnome release in March, and so in that case should be able to get Gnome 3.8 into Mageia 3 I guess, with this current planning,  wel might have to change the final slightly depending on when it is
19:42:00 <ennael> #info string freeze is planned for 14/02/2013
19:42:21 * ennael slaps sebsebseb with gnome planning
19:42:27 <sebsebseb> ennael: heh heh
19:42:31 <ennael> ok anything else on planning ?
19:42:34 <anaselli> and heart freeze as well than :D
19:42:37 <ennael> will add it on wiki
19:42:48 <ennael> anaselli: packagers do not have any heart
19:42:53 <ennael> I d'ont
19:42:55 <ennael> don't
19:43:06 <anaselli> no ithought to valentines :p
19:43:10 <lemonzest> btw what happaned to the gnome-shell extensions from rc2, there gone in final :S
19:43:16 <AL13N> nothing else to add
19:43:18 <lemonzest> or maybe it was rc1
19:43:19 <lemonzest> not sure
19:43:25 <ennael> anything else ?
19:43:27 <sebsebseb> lemonzest: ask in #mageia it's a packagers meeting
19:43:38 <lemonzest> sebsebseb: packers gunna pack
19:43:42 <sebsebseb> ennael: for this topic nope
19:43:52 <blino> why can't have meetings in #mageia-meeting then? :)
19:44:06 <sebsebseb> blino: council is
19:44:06 <blino> to keep the dev chan open for dev questions
19:44:08 * ennael kicks blino
19:44:14 <pterjan> blino: because I'm not there !
19:44:15 <AL13N> such violence
19:44:28 <AL13N> huh?
19:44:37 <AL13N> no #topic?
19:45:08 <ennael> mmmm
19:45:10 <sebsebseb> I see a new topic
19:45:11 <pterjan> AL13N: ennael is the new name of Inigo_Montoya`
19:45:19 <AL13N> pterjan: lol
19:45:21 * ennael broke the topic :)
19:45:25 <AL13N> :-(
19:45:39 <ennael> #topic Mageia 3 specifications
19:45:44 <AL13N> hmm
19:45:47 <anaselli> too meny kicks ennael :P
19:45:48 <ennael> to make packagers focus on topic
19:45:50 <anaselli> many
19:46:12 <ennael> ok we spoke together with boklm and guillomovitch  about specifications process
19:46:31 <ennael> so here are some comment on previous one
19:46:44 <ennael> - lots of proposals, very few achieved
19:46:54 <ennael> - lots of incomplete proposals
19:47:16 <ennael> - specifications that are not really specifications like "update to xxx version"
19:47:38 <ennael> - some kind of catalog of items without being logic
19:47:43 <pterjan> well it can be for major stuff
19:47:51 <ennael> yes
19:47:58 <ennael> but we had also minor packages
19:48:11 <ennael> or things like "add more games"
19:48:18 <pterjan> I see
19:48:19 <ennael> interesting but not really specification
19:48:25 <AL13N> ok
19:48:26 <coincoin> xmoto is already there so it's good enough!
19:48:30 * pterjan does not remember reading them /o\
19:48:47 <ennael> and so it was also hard to communicate on all this
19:48:51 <AL13N> so, does this mean less proposals, but more founded?
19:49:00 <ennael> either "not they won't be able to do it"
19:49:07 <ennael> or "waouuu they are so clever"
19:49:26 <ennael> so we had a look on other distributions and especially Fedora
19:49:30 <coling> So what's the suggestions? Make a "call for specs" with a deadline, then an official review process to separate the wheat from the chaff?
19:49:41 <ennael> boklm found policy about it
19:49:52 <ennael> and we thought it was good to have something like that
19:50:00 * coling quite likes the feature template pages in fedora wiki
19:50:05 <ennael> yep that one :)
19:50:10 <ennael> so
19:50:12 <AL13N> link?
19:50:16 <ennael> wait
19:50:23 <ennael> I finish and you shout after :)
19:50:28 <ennael> so about the process
19:50:38 <coling> AL13N e.g. https://fedoraproject.org/wiki/Features/tmp-on-tmpfs
19:50:39 <erzulie> [ Features/tmp-on-tmpfs - FedoraProject ]
19:50:40 <ennael> we have nearly 3 weeks to work on it
19:50:45 <ennael> and make proposals
19:50:58 <ennael> then we take some days to choose the proper one to be included
19:51:06 <ennael> then we can publish it
19:51:13 <ennael> and of course follow it :)
19:51:24 <coling> ennael, how do we keep track of individual pages? Should we have an index page with links to them all?
19:51:26 <AL13N> so, we do a feature template page, then do features, then decide?
19:51:37 <ennael> coming :)
19:51:41 <coling> k :)
19:51:45 <ennael> now here is a proposal for policy
19:51:47 <ennael> #How_to_define_and_propose_a_feature
19:51:49 <ennael> oups
19:51:57 <ennael> https://wiki.mageia.org/en/Features_policy
19:51:59 <erzulie> [ Features policy - Mageia wiki ]
19:52:14 <ennael> this is a beginning as we wanted to propose something tonight
19:52:29 <ennael> and a template for feature
19:52:30 <ennael> https://wiki.mageia.org/en/Feature_Template
19:52:31 <erzulie> [ Feature Template - Mageia wiki ]
19:52:36 <coling> Oh nice :)
19:52:39 <ennael> now you can fight :)
19:52:42 <ennael> wdyt ?
19:53:16 <tmb> seems ok
19:53:21 * AL13N looks
19:53:56 <coling> I would add "contingency plan" to the policy + feature template. e.g. what happens if we decide to drop the feature.
19:54:10 <pterjan> do we have to work on specified features or can we just have fun hacking around? /o\
19:54:19 <lemonzest> coling: and the Plan B for the contingency plan?
19:54:32 <coling> indeed
19:54:37 <coling> pterjan, I think that's OK too.
19:54:38 <coling> :)
19:54:50 <lemonzest> because since like, has plan A ever worked <3
19:54:54 <lemonzest> (name dat show)
19:55:07 <AL13N> coling: is right, contingency plan would be nice, even if it'll likely not be needed
19:55:15 <ennael> pterjan: I guess you can add your name in team even if you do not spend all your time on it
19:55:54 <ennael> do you think we can follow this?
19:56:03 <coling> pterjan, but if the hacking around turned out to be a big thing that was disruptive/controvercial then I'd suggest any big change is either posptoned to the next release (and has a feature plan) or an official "late feature planning decision" is made+announced such that everyone knows it's happening.
19:56:11 <anaselli> it seems ok to me
19:56:23 <ennael> coling: can you add it in template?
19:56:23 <AL13N> it looks satisfactory, just add plan B and plan C sections
19:56:27 <coling> ennael, sure.
19:56:30 <ennael> ok
19:57:13 <ennael> it means more work, maybe less proposals but much better to follow and achieve
19:57:32 <anaselli> maybe just adding that some discarded featured could be postponed for some reasons...
19:57:40 <ennael> sure
19:58:08 <ennael> so one thing important we need kind of "leader" for features and resources if needed
19:58:26 <ennael> so it's important to start discussion and call for it before we review all features
19:58:32 <ennael> feel free to mail -dev about it
19:59:11 <ennael> boklm: anything to add.
19:59:12 <ennael> ?
19:59:13 <coling> usually the contingency is pretty simple, but it's nice to think about these things.
19:59:15 * ennael speaks too much
19:59:22 <ovitters> what about difficult to undo features, like a possible /usr-merge or systemd only feature?
19:59:37 <boklm> ennael: hmm, I see nothing to add at the moment
19:59:44 <AL13N> well,it should just be mentioned in that contingency section
19:59:49 <coling> ovitters, well that contingency is harder to write :D
20:00:27 <AL13N> if there's on contingency, then we'll have to see the possible impact and see if we really need it right now (and not later)
20:00:38 <anaselli> too much noise here, my headache increases :)
20:01:04 <AL13N> the trick to less noise is not saying anything :-)
20:01:05 <ennael> #action coling will add contingency on feature template
20:01:11 <coling> already done :)
20:01:16 <ennael> great
20:01:33 <ennael> #action ennael will mail -dev about all this
20:01:59 <ennael> now deadline
20:02:14 <ennael> 15/06 for proposals, does it sound reasonable ?
20:02:37 <AL13N> isn't that too long?
20:02:40 <coling> Two weeks. Seems fine to me. Won't take me long to write up mine.
20:02:41 <ennael> the more time spend on it, the less we have on dev
20:03:24 <AL13N> 13/06 is a wednesday
20:03:28 <ennael> AL13N: better take enough time on this it's important to have well written features
20:04:43 <blino> do we really have time & resources to develop features or should we focus on integrating features from other projects?
20:05:02 <ennael> well we had some proposals for devel on irc some days ago
20:05:10 <ennael> guys wanted to contribute on devel
20:05:11 <coling> blino, that's fine too, but we should just write that up on a feature page.
20:05:22 <ennael> but still I have one in mind: mcc
20:05:40 <anaselli> ennael: port it to QT? :D
20:05:42 <ennael> we really should take time on it and fix/develop if needed/refresh
20:05:53 <blino> anaselli: yes, it would be nice, and maybe not so difficult
20:05:56 <ovitters> perl-Gtk3 :D
20:06:18 <ennael> reviews spoke about mcc as a strong point for mageia but also weak as it's getting old
20:06:22 <anaselli> blino: it's in my dreams... but i can't program in perl :/
20:06:24 * pterjan wants some buildsystem features but that's not tied to a release
20:06:26 <blino> anaselli: it would mostly be about writing an interactive.pm backend with PyQt (or whatever binding we chose)
20:06:34 <blino> ovitters: good idea as well
20:06:45 <blino> pterjan: such as?
20:06:46 <ennael> but I'm already speaking of feature :)
20:06:56 <shikamaru> anaselli: it’s not more difficult than any other language believe me :)
20:07:01 <ennael> pterjan: we can add it
20:07:15 <leuhmanu> maybe we have some feature request on the bugzilla
20:07:15 <pterjan> blino: handling upload of packages present in several medias
20:07:24 <ennael> also you may propose features for mageia 4 with part delivery for mageia 3
20:07:25 <pterjan> (correctly)
20:07:35 <ovitters> fwiw, I hate perl, I can contribute in Python.. but different language = loads of bugs, loads of time.. not worth it
20:07:40 <anaselli> blino: with pyQT i could try to, python is more readable to me
20:08:00 <pterjan> => making sure nonfree/tainted packages get rebuilt when updating in core
20:08:07 <AL13N> we don't need to port, it, we should use a Gtk/Qt independant layer
20:08:11 <pterjan> (and fail the upload if they fail)
20:08:51 <ennael> also for memory https://wiki.mageia.org/en/Mageia_Ideas_Page
20:08:52 <erzulie> [ Mageia Ideas Page - Mageia wiki ]
20:08:59 <ennael> if you need some :)
20:09:15 <AL13N> what about the review planning
20:09:35 <AL13N> if proposals are ready 15/06; when is decided which to use, and which not?
20:09:41 <AL13N> (and by whom)?
20:09:43 <blino> anaselli: err, sorry, I meant PerlQt4 :)
20:09:47 <ennael> in the following days
20:09:57 <Kharec> AL13N: 15/06 is my birthday :)
20:10:03 <ennael> we will make proposals as done for mageia2
20:10:13 <ennael> following policy in wiki
20:10:29 <anaselli> blino: ah, i tryed to install it, but my example did not work...
20:10:32 <AL13N> ok then. next topic?
20:10:43 <ennael> any other comment on specifications topic ?
20:11:00 <anaselli> blino: anyway i can't swear, but i could try
20:11:08 <anaselli> perl or not...
20:11:16 <pterjan> you could try to swear at blino ?
20:11:31 <anaselli> i believe that could help in decreas kde livecd size blino
20:11:49 <anaselli> pterjan: on his head... easy :p
20:12:04 <ennael> ok
20:12:14 <ennael> now we have finished all planned topics
20:12:42 <ennael> about backports as said we will discuss it next week
20:12:56 <ennael> same thing about mentoring as we need complete review to be done before
20:12:56 <anaselli> yes
20:13:33 <ennael> ok so  we still have a topic
20:13:41 <ennael> #topic mageia wiki
20:13:41 <ennael> PageDiscussionEditHistoryMoveWatch
20:13:46 <ennael> Search      argh
20:13:49 <ennael> #undo
20:13:49 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Topic object at 0x84d51ac>
20:14:17 <ennael> #topic radeon firmware in non-free
20:14:20 <ennael> phew
20:14:28 <ennael> so it was started on -dev ML
20:14:36 <ennael> tv___ is around
20:14:38 <blino> anaselli: well, it's not only about drakconf then, but also about more complicated tools like rpmdrake, which would be a lot less easier to port
20:14:45 <ennael> tv___: are you available?
20:15:12 <ennael> tmb: can you sum up this discussion?
20:15:19 <anaselli> blino: i started exactly from  there... now i see why i changed my mind :)
20:15:23 <ennael> at least both positions?
20:16:32 <ennael> tmb ? tv___ ?
20:16:39 <ennael> or anybody else ?
20:16:41 <anaselli> they should have reach an agreement :D
20:16:53 <ennael> if nobody is around we postpone this to next meeting
20:17:08 <anaselli> i think we should focus on the jhon doe user perspective
20:17:39 <pterjan> but no one knows him
20:17:39 <anaselli> yes it's better to postpone, it's a big decision i believe with the pros and cons
20:18:04 <anaselli> who nobody or jhon doe pterjan
20:18:05 <anaselli> ^
20:18:28 <ennael> ok nobody 1 ?
20:18:36 <ennael> ok nobody 2 ?
20:18:48 <ennael> nobody 3 !
20:18:51 <anaselli> \o
20:18:56 <ennael> so I guess we can close meeting
20:18:57 * anaselli jokes
20:19:09 <ennael> unless there is questions
20:19:16 <anaselli> tmb exits :)
20:19:16 <ennael> arf radeon killed tmb
20:19:36 <coling> Video killed the radio star.
20:19:41 <ennael> :)
20:19:43 <anaselli> LOL
20:19:46 <ennael> old song for old people :)
20:19:49 <coling> :D
20:19:54 <blino> ennael: about radeon, offering the choice in DVD install to enable nonfree media looks sensible
20:20:07 <ennael> ah still some people awake
20:20:13 <blino> though, it would require a network connection
20:20:22 <anaselli> yes that should be
20:20:28 * coling is just reading some reviews and yeah, offering the choice in the installer IMO makes sense.
20:20:28 <blino> maybe we could add some non-free on the DVD media, but disable it by default?
20:20:30 <anaselli> blino: or adding an optional media
20:20:40 <blino> we would not have a pure non-free DVD, but it would be more convenient
20:20:51 <boklm> blino: it looks like a good idea
20:20:58 <coling> blino, yeah I think this could be OK.
20:21:24 <coling> I don't think many FOSS-only zealots would worry too much about it "tainting their DVD" :)
20:21:30 <pterjan> but would it restrict diffusion of dvd ?
20:21:43 <coling> I don't think so - provided it wasn't tainted stuff.
20:21:47 <boklm> pterjan: we only inclure nonfree software which are redistributable
20:22:02 <pterjan> even for commercial use?
20:22:07 <pterjan> (like in a magazine)
20:22:21 <blino> good point
20:22:32 <blino> but do radeon firmware have such non-commercial clause?
20:22:40 <anaselli> that's why an additional media could be better
20:22:56 <blino> anaselli: it would require an available network to work :/
20:23:03 <AL13N> but regular users can't really handle additional media
20:23:04 <anaselli> maybe a usb
20:23:11 <blino> not convenient at all
20:23:14 <lemonzest> it would have been nice if i would have instered a 2nd usb stick holding the radeon firmwares
20:23:15 <ennael> yep
20:23:17 <anaselli> i recall a feature in old rh installer
20:23:20 <AL13N> anaselli: you tell to users to write a cd and also a usb key
20:23:22 <lemonzest> beats messing with vesa
20:23:24 <anaselli> add a floppy driver...
20:23:38 <pterjan> or a sdcard !
20:23:39 <anaselli> two cd is the same
20:23:40 <shikamaru> debian does that as well
20:23:49 <blino> anaselli: we have this, yes
20:23:50 <anaselli> you could burn it where you prefer
20:23:57 <blino> but who will take care of doing that?
20:23:57 <pterjan> shikamaru: but debian does not try to be convenient for users :P
20:24:02 <AL13N> dvd has space, i suggest we put it on there, possibly we can make easily an image withit it, so that FOSS people have a nonworking setup if they want to
20:24:12 <boklm> do we have software in nonfree repository that don't allow redistribution for commercial use ?
20:24:15 <anaselli> blino: that's the real point
20:24:19 <blino> most first-time users will expect it to work by default, and won't take time to copy firmware on a separate media...
20:24:23 <pterjan> boklm: no idea
20:24:25 <anaselli> we should offer a clear way to the user
20:24:36 <AL13N> what about a multisession DVD? first part DVD FOSS only, second part is nonfree section
20:24:36 <anaselli> the one who does not read before just click
20:24:50 <boklm> https://wiki.mageia.org/en/Mirrors_policy#nonfree "contains apps/drivers/firmware that are free to redistribute but we dont have redistributable source for"
20:24:51 <erzulie> [ Mirrors policy - Mageia wiki ]
20:24:55 <ennael> AL13N: make it simple pleeeeeeeeease
20:24:55 <blino> boklm: I don't think so, for the commercial-only ones like Flash, packages are just download wrappers
20:25:14 <blino> so it should be ok
20:25:23 <AL13N> ennael: how difficult is it to have nonfree, but make at final one more iso that just removes the nonfree directory
20:25:27 <boklm> maybe we should review packages in nonfree repository for this
20:25:39 <blino> yes
20:25:50 <ennael> AL13N: either we include it or not
20:25:56 <blino> and split a noncommercial repo if needed :)
20:26:05 <boklm> yes
20:26:10 <ennael> we have too many isos
20:26:20 <ennael> no way to add more
20:26:20 <AL13N> ennael: if you don't want to make one more extra iso, then i suggest to have nonfree
20:26:35 <anaselli> mee too
20:26:42 <blino> I agree with ennael, we should not clutter the choice with too many ISO images
20:26:46 <ovitters> 1st priority is legally ok, 2nd that users understand that non-open source = buggy, 3rd that patents and so on are bad, but you cannot get point across if their GPU doesn't work
20:27:00 <AL13N> ennael: i'm think thinking generating an iso which is the same, except removing of nonfree, might not be hard, nor require any QA
20:27:19 <ennael> AL13N: it will require QA
20:27:24 <AL13N> argh
20:27:29 <ennael> we do not release any iso without QA tests
20:27:36 <Stormi> indeed
20:27:37 <AL13N> just have it then and ask the users to have nonfree/tainted
20:27:44 <AL13N> if he has such a need for firmware or drivers
20:27:57 <AL13N> in that extra screen, you can explain that nonfree and patents are bad
20:28:03 <AL13N> thus exposure too
20:28:05 <boklm> why do you want to release 2 different ISOs ?
20:28:06 <anaselli> well let's say that having a network connection is must then...
20:28:16 <anaselli> but if it is a network card problem?
20:28:16 <ennael> no way to add tainted on free dvd imho
20:28:18 <AL13N> boklm: i don't want that
20:28:22 * anaselli is in loop
20:28:39 <AL13N> ennael: of course not, but i'm speaking more general, network install is also an install
20:29:07 <anaselli> AL13N: but you choose what to install...
20:29:15 <anaselli> i mean first
20:29:22 <AL13N> i've sent an email with a proposal for changing extra media screen
20:29:31 <ennael> ok we will not close that discussion tonight and we miss tv___ and tmb who started discussion
20:29:35 <AL13N> this would solve this, as it also asks for nonfree to select or not
20:29:43 <ennael> can you guys add your proposals on -dev thread ?
20:30:00 * AL13N has sent an email on -dev a while ago in that thread
20:30:25 <ennael> and we should close that topic next week the latest
20:30:28 <AL13N> k
20:30:38 <AL13N> so, next topic then?
20:30:51 <ennael> any other topic?
20:31:14 <anaselli> a kmail2 kde replacement?
20:31:20 * anaselli hides
20:31:26 <AL13N> not that i know of
20:32:16 <ennael> ok thanks for attending then
20:32:18 <AL13N> what's that java dependency thing?
20:32:25 <AL13N> that claire asked for?
20:32:28 <ovitters> no Oxygen in GNOME for Mageia 3 :D
20:32:32 <ennael> next week
20:32:36 <AL13N> k
20:32:36 <ennael> #endmeeting