19:19:20 <ennael> #startmeeting
19:19:20 <Inigo_Montoya`> Meeting started Wed May  9 19:19:20 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:19:20 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:19:21 <erzulie> [ MeetBot - Debian Wiki ]
19:19:44 <ennael> hi all
19:20:12 <coling> hello
19:20:14 <coling> :)
19:20:14 <remmy> Heya :)
19:20:23 <guillomovitch> I'm here too, but only temporarily
19:20:35 <ennael> ok
19:20:39 <ennael> #topic RC isos
19:20:46 <pterjan> guillomovitch: like all of us sadly
19:20:49 <sebsebseb> hi
19:20:49 <ennael> so finally they are available
19:20:55 <coling> \o/
19:20:58 <ennael> :)
19:21:08 <ennael> thanks coling for helping tmb to break it :)
19:21:10 <coling> Massive kudos to you and tmb (and blino and everyone else)
19:21:19 <ennael> thanks tmb for not sleeping since some days
19:21:35 <ennael> thanks QA for all the hard work during these days
19:22:01 <ennael> we have all live cds, DVDs, and dual
19:22:13 <ennael> so please if you can have a look on it that would be great
19:22:27 <ennael> we still need some tests on upgrade
19:22:36 <ennael> also we still have some space on DVDs
19:22:50 <ennael> if nobody makes any proposal I will add divs :)
19:22:52 <ennael> divx
19:23:15 * coling gets dinner out of the oven... brb
19:23:16 <remmy> Question: Is there any difference between version freeze pre RC and after RC?
19:23:20 <ennael> #action tests needed on live CDs
19:23:26 <ennael> remmy: ?
19:23:30 <pterjan> ennael: we can play the divx during install
19:23:37 <ennael> pterjan: yep :)
19:23:49 <ennael> #action tests needed for upgrade
19:23:55 <remmy> Do the same rules still apply? That is: Only bug fixes and no new versions?
19:24:02 <ennael> of course!
19:24:08 * ennael will kill remmy :)
19:24:09 <remmy> Or are they tighter for RC?
19:24:15 <ennael> tighter
19:24:23 <remmy> Okies
19:24:31 <ennael> meaning we will push only fixes for critical bugs
19:24:49 <pterjan> especially the ones that can not be fixed in updates
19:24:53 <ennael> yep
19:25:05 <ennael> so release_blocker ones (review planned in next topic)
19:25:22 <pterjan> is it safe to upgrade now?
19:25:39 <ennael> main issues are fixed but still some pending
19:25:52 <ennael> the last one discovered is about MySQL => mariadb
19:26:02 <coling> What issue is that?
19:26:10 <ennael> let see that in next topic :)
19:26:24 <pterjan> my only mageia machine has no monitor so it boot/network/sshd breaks I can't contribute anymore but I should probably try :)
19:26:30 <ennael> just to finish on this topic, final release is planned for 22d of may
19:26:57 <ennael> so one week postponed to give enought time afte RC
19:26:59 <ennael> after
19:27:02 <coling> Cool
19:27:17 <ennael> #info as a reminder final release is planned for 22d of may
19:27:21 <coling> Not bad in the overall scheme of things :)
19:27:38 <ennael> hope it will be less painfull than RC :)
19:27:58 <coling> So does tmb :p
19:28:01 <ennael> :)
19:28:14 <ennael> ok anything else to add on RC ?
19:28:30 <leuhmanu> yes,
19:28:41 <leuhmanu> can we add a package in core/updates ?
19:28:49 <ennael> ?
19:28:57 <leuhmanu> for testing the updates step in the dvd installer
19:29:12 <zezinho> there is already gimp 2.8
19:29:25 <leuhmanu> updates not updates_testing
19:29:41 <leuhmanu> (since it use urpmi --update)
19:29:47 <zezinho> right, sorry
19:29:52 <pterjan> we can have a newer null there but null is not in the dvd :P
19:30:25 <tmb> I think we could bump mageia-release with 0.1 and push it in updates :)
19:32:04 <ennael> erf
19:32:50 <ennael> can't remember if we used to do such test in mdv
19:33:06 <ennael> pterjan or blino: do you remember ?
19:33:11 <tmb> well, we need a package that is on every iso to verify updates works
19:33:25 <pterjan> I don't remmeber but it sound like a good idea
19:33:26 <ennael> kernel :)
19:33:35 <ennael> basesystem
19:33:53 <pterjan> I think we had some updates ready usually
19:34:03 <pterjan> the non critical bugs
19:34:27 <zezinho> so we could submit the freeze push for non-critical?
19:34:56 <pterjan> yes things that are not critical should go to updates_testing and then updates
19:35:10 <pterjan> like normal updates
19:35:21 <zezinho> but we need at least one fastly in updates
19:35:45 <pterjan> yes probably better to do mageia-release/basesystem/whatever
19:36:02 <pterjan> and clean the updates media before uploading the first real one
19:36:07 <leuhmanu> it this way, some package can be resolved but not in the media...
19:37:03 <AL13N> pterjan: leuhmanu: task-lamp
19:37:19 <ennael> nope
19:37:31 <ennael> anybody volunteer to provide this update?
19:37:32 <pterjan> ideally we want something present on dual cd
19:37:40 <pterjan> to test from there too
19:38:35 <ennael> pterjan: can you push it?
19:38:46 <pterjan> I can do
19:38:50 <ennael> thanks
19:39:17 <ennael> #action pterjan will submit a package in update media to test it at the end of classical installer
19:39:31 <ennael> anything else ?
19:39:34 <ennael> (on RC)
19:40:28 <coling> not from me
19:40:38 <tmb> or me
19:40:46 <ennael> ok
19:40:53 <ennael> #topic release blocker bugs review
19:41:21 <ennael> https://bugs.mageia.org/query.cgi?bug_status=NEW&bug_status=UNCONFIRMED&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=VERIFIED&priority=release_blocker&product=Mageia&query_format=advanced&version=Cauldron&known_name=release_blocker
19:41:23 <erzulie> [ Search for bugs ]
19:41:38 <ennael> we have 16 bugs in list
19:41:50 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5798
19:41:52 <erzulie> [ Bug 5798 - rpmdrake is missing on the dual cd. ]
19:41:54 <zezinho> much less than Debian ;-)
19:42:13 <ennael> I will have a look tomorrow to try to make it fit inside but it will be diffcult
19:42:32 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5796
19:42:34 <erzulie> [ Bug 5796 - task-printing missing required task-* cause upgrade to fail - mga1 to RC DVD 64 ]
19:42:39 <ennael> that one is blocker for upgrade
19:43:50 <ennael> boklm had a  look on that one
19:44:04 <ennael> it seems hdlists are ok in 32 but not 64 bits
19:44:08 <ennael> (about libwsutil.so.1)
19:45:36 <coling> But that's apparently fixed now?
19:45:45 <coling> So just the task-printing* remain?
19:46:08 <ennael> MrsB: around ?
19:46:19 <rindolf> https://bugs.mageia.org/show_bug.cgi?id=5734 - what should we do about that?
19:46:21 <erzulie> [ Bug 5734 - ATI fglrx breaks resume from hibernation ]
19:46:35 <ennael> rindolf: please wait
19:47:02 <coling> So what's the actual problem, do we know why task-printing was not selected for upgrade?
19:48:24 <AL13N> i thought MrsB was going to go sleep
19:48:27 <ennael> ok
19:48:33 <ennael> I will ping her back on that one
19:48:48 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5791
19:48:50 <erzulie> [ Bug 5791 - mysql.sock not created; Can't start mysql: error in /etc/init.d/mysqld? ]
19:48:56 <ennael> reported today
19:49:06 <ennael> yesterday
19:49:10 <ennael> AL13N: any status ?
19:49:16 <trem> doktor5000: I've asked on #e.fr, and it seems that connman isn't very smart
19:49:27 <AL13N> original report was an install with /var unformatted
19:49:30 <ennael> trem: meeting in progress
19:49:39 <AL13N> i think it might be a problem with mga1 > mga2 upgrade
19:49:52 <AL13N> but we can't test atm due to mariadb not on DVD
19:50:06 <AL13N> MrsB was planning on testing the upgrade part from mariadb
19:50:09 <ennael> ok I can build temporary iso to check this
19:50:15 <AL13N> so we would know if it broke
19:50:25 <ennael> will do it after meeting
19:50:37 <AL13N> ennael: better first check if package installed on her system would break upgrade
19:50:37 <ennael> please do not spread these isos as it will be a mess
19:50:39 <zezinho> I did mga1 > mga2 upgrade on mysql server
19:50:42 <AL13N> the data is still there, so it could be testable
19:50:56 <AL13N> zezinho: b3 or rc2?
19:50:57 <zezinho> all worked nicely
19:51:01 <ennael> ok
19:51:03 <AL13N> ah ok
19:51:06 <ennael> so more tests needed
19:51:06 <AL13N> so it might be ok
19:51:10 <zezinho> network update 1 week ago
19:51:14 <zezinho> so almost RC
19:51:22 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5767
19:51:23 <AL13N> ennael: can you build an iso anyway?
19:51:24 <erzulie> [ Bug 5767 - File conflicts - Failed upgrade from mga1 to Pre RC DVD 64 (guile) ]
19:51:28 <ennael> AL13N: yes
19:51:32 <AL13N> ennael: k thx
19:51:43 <ennael> we need a volunteer to have a look on guile
19:51:57 <rindolf> ennael: I can try doing that on the weekend.
19:52:04 <rindolf> ennael: which is on Fri+Sat.
19:52:05 * tmb thinks ennael is now addicted to iso building :)
19:52:25 <ennael> tmb: don't laugh :)
19:52:39 <ennael> rindolf: would be nice to have it on friday
19:52:43 <ennael> is it possible ?
19:52:54 <pterjan> I can try before but not sure
19:52:57 <remmy> I don't see how we can fit onto a CD for mga 3... but that's a challenge for next year :P
19:53:01 <rindolf> ennael: yes, I guess.
19:53:10 <ennael> great
19:53:14 <rindolf> ennael: you're talking about this bug, right - https://bugs.mageia.org/show_bug.cgi?id=5767 ?
19:53:16 <erzulie> [ Bug 5767 - File conflicts - Failed upgrade from mga1 to Pre RC DVD 64 (guile) ]
19:53:33 <ennael> #action  #5798 needs more infomation from MrsB
19:53:56 <ennael> #undo
19:53:56 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Action object at 0x84ddaac>
19:54:08 <ennael> #action  #5798 tests tomorrow by ennael
19:54:14 <ennael> #action  #5796 needs more infomation from MrsB
19:54:36 <ennael> #action  #5791 needs more tests + 1 DVD iso including mariadb
19:54:48 <zezinho> An upgrade from DVD should always enable network medias?
19:55:02 <coling> AL13N, FWIW, the upgrade from mga1 -> mga2 will still have the problem that mariadb (and httpd) get disabled due to systemd migration related to the fact that the package name changed for both.
19:55:05 <ennael> #action #5767 rindolf will have a look and prpose a fix for friday
19:55:23 <leuhmanu> zezinho: nop
19:55:28 <zezinho> coling : is this in the release notes?
19:55:47 <AL13N> coling: is it fixable or even required to be fixed?
19:56:36 <coling> zezinho, AL13N, not sure. probably not. I did intend to do something about it but it requires new rpm-helper to add a special mode to disable package disabling on package uninstall... It was a bit complicated tho', so I didn't get around to it.
19:56:43 <coling> I suspect we should just document it.
19:56:56 <coling> (i don't really want to play too much more with rpm-helper at this stage)
19:56:57 <AL13N> good for me, it's not critical i think
19:57:05 <zezinho> Yes, I experienced it in my server upgrade
19:57:06 <ennael> anyway modifying rpm-helper is not a good idea now
19:57:21 <ennael> AL13N: can you update release notes ?
19:57:27 <ennael> we need it for installer
19:57:32 <AL13N> ok
19:57:39 <zezinho> I can update release notes
19:57:43 <AL13N> what about httpd?
19:57:50 <ennael> #action AL13N will update release notes about upgrade/mariadb
19:57:52 <AL13N> i didn't see it renamed?
19:57:56 <zezinho> For both httpd and mariadb
19:57:56 <coling> AL13N same deal as mariadb.
19:58:06 <coling> AL13N, the actual service file moved into the mpm subpackages.
19:58:11 <AL13N> ah
19:58:27 <coling> So it's slightly different, but similar in principle.
19:58:45 <AL13N> release notes is on the wiki right?
19:58:47 <coling> Although actually hmm.
19:58:49 <zezinho> After the update, both services are not enabled
19:58:52 <AL13N> should it be release notes or errata?
19:58:58 <coling> Maybe it's a slightly different issue there.
19:59:10 <ennael> https://wiki.mageia.org/en/Mageia_2_Release_Notes
19:59:11 <erzulie> [ Mageia 2 Release Notes - Mageia wiki ]
19:59:22 <coling> I'll double check the httpd one (I have seen it get disabled due to ordering, but I'll need to look again.
19:59:28 <ennael> thanks
19:59:47 <ennael> #action coling will have a look on httpd and check upgrade process
20:00:01 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5746
20:00:03 <erzulie> [ Bug 5746 - An error occured: One big transaction - Upgrading mga1 to Pre RC. Upgrade failed. ]
20:00:41 <ennael> that one is a weird one that is happening quite randomly since years now
20:01:16 <ennael> so either somebody has an idea now or we lower the priority
20:01:22 <AL13N> wait, shouldn't it be on errata? i see no obvious place to put this warning (maybe with upgrading from mga1)
20:03:34 <AL13N> btw: is this good: https://wiki.mageia.org/mw-en/index.php?title=Mageia_2_Release_Notes&action=historysubmit&diff=6271&oldid=6261 ?
20:03:35 <erzulie> [ Mageia 2 Release Notes - Mageia wiki ]
20:04:17 <ennael> ok nobody for 5746, decreasing for now
20:04:32 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5734
20:04:34 <erzulie> [ Bug 5734 - ATI fglrx breaks resume from hibernation ]
20:04:58 <boklm> maybe there should be a section in release notes to list important changes affecting users
20:05:37 <anaselli> ennael: Bug 5746 it's very similar to the one i had upgrading mdv 2010.2 to mga1 on my netbook
20:06:07 <anaselli> at least the fact to have full partition
20:06:38 * AL13N agrees with boklm
20:06:40 <anaselli> that was because the packages were first all cached and then installed
20:06:56 <coling> For the ATI issue I have no hardware but I'd say that it's not a critical problem and can be addressed after release with updates as needed.
20:06:58 <ennael> ok so this is something we can't change now anyway
20:07:06 <ennael> coling: ok
20:07:30 <ennael> #action #5734 can fixed later through update
20:07:46 <tmb> the ati bug seems to be the system tries to resume with radeon even if fglrx is configured..
20:07:57 * Led43_mag2 tested and could not recreate Bug but had plenty of free space on all partitions
20:08:26 <Led43_mag2> Bug 5746
20:08:29 <anaselli> no if it's the same... i believe we can't, but we should think about it soon, if we want to upgrade usb keys or something like that
20:09:11 <coling> tmb, could be an initrd issue?
20:09:18 <AL13N> boklm: i did this: https://wiki.mageia.org/en/Mageia_2_Release_Notes#Notable_changes_after_upgrade
20:09:19 <erzulie> [ Mageia 2 Release Notes - Mageia wiki ]
20:09:27 <anaselli> Led43_mag2: i think you could try installing on 4/8 Gb disk to get it
20:09:51 <anaselli> i updated it via urpmi by hands...
20:09:59 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5674
20:10:01 <erzulie> [ Bug 5674 - reboot or shutdown hangs with either rc live cd or dvd. ]
20:10:26 <coling> Was that the "press any key" issue?
20:11:05 <tmb> nope, that is fixed
20:11:19 <ennael> "I entered reboot in a terminal, which hung after displaying the message
20:11:20 <ennael> shutting down for reboot."
20:11:29 <anaselli> there's no "any" key in the keyboard coling, i believe :p
20:12:00 * Led43_mag2 was waiting for some one to say that
20:12:13 * anaselli hides
20:12:46 <ennael> :)
20:13:16 <coling> Hmm, it's not clear what the problem is there.
20:13:19 <ennael> our friend simplew is not here
20:14:04 <leuhmanu> maybe the duplicate was not really a duplicate
20:14:06 <AL13N> is that one of those systemd is still pending on something?
20:14:07 <leuhmanu> then sorry
20:14:21 <coling> It's not clear whether that bug is about an installed system or a live system... seems to have comments about both.
20:14:46 <leuhmanu> (simplew was comming with the duplicate)
20:15:40 <ennael> ok it seems we need more information...
20:15:59 <coling> I'll try and track that one down.
20:16:03 <ennael> ok
20:16:23 <ennael> #action #5674 coling will track this one
20:16:35 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5672
20:16:37 <erzulie> [ Bug 5672 - rc pre-release cd very slow to boot. ]
20:16:40 <anaselli> coling: i believe the text is to high
20:16:54 <anaselli> i've seen that problem only on the notebook
20:17:23 <anaselli> not on my PC with high screen resolution
20:17:25 <ennael> coling: wdyt?
20:17:28 <anaselli> just guess
20:17:42 <anaselli> well on the notebook
20:17:44 <anaselli> s
20:17:53 <ennael> anaselli: please
20:18:10 <anaselli> ah sorry, wrong bug :/
20:18:27 <coling> ennael, no idea on the slow boot one. I fixed the only issue I was aware of and could not reproduce it.
20:18:41 <coling> ennael, seems Dave was the only one who could reproduce as I don't think tmb could either...
20:19:07 <AL13N> well, from comments it looks like tmb will try to find similar hardware
20:19:21 <coling> Yup.
20:19:36 <ennael> ok let see that in coming days
20:19:41 <AL13N> perhaps tmb can check it out, or else it'll have to wait until someone can reproduce
20:19:53 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5567
20:19:54 <erzulie> [ Bug 5567 - tg3 fails to initialize in installer ]
20:20:44 <AL13N> #action #5674 needs reproducing
20:21:10 <ennael> tmb: any comment on #5567 ?
20:21:10 <coling> No changes since last discussion on the tg3 it seems unless tmb has more info/ideas
20:21:17 <ennael> ok
20:21:34 <Stormi> I have the hardware (the bug was reported by a colleage of mine)
20:21:43 <Stormi> so feedback can be quick
20:21:58 <coling> Stormi, for tg3?
20:22:00 <Stormi> yes
20:22:51 <AL13N> it looks like upstream kernel problem to me
20:22:58 <tmb> Stormi: can you "modprobe -r tg3 && modprobe broadcom && modprobe tg3" on that system, does it work then?
20:23:12 <ennael> ah he is still alive :)
20:23:18 <AL13N> :)
20:23:20 <Stormi> tmb: I have it at work so must try tomorrow
20:23:38 <ennael> can you fill bugzilla with this test?
20:23:45 <tmb> yep
20:23:48 <ennael> thanks
20:23:49 <Stormi> what I know is that hardware works with mageia
20:24:15 <Stormi> only during install it can't use it
20:24:19 <ennael> #action #5567 tmb provides some tests - Stormi will give results
20:24:33 <Stormi> do you need me to issue this from the boot.iso ?
20:24:43 <Stormi> (well, boot-nonfree)
20:25:45 <Stormi> I must go, will give the results tomorrow
20:25:50 <ennael> ok
20:25:55 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5462
20:25:57 <erzulie> [ Bug 5462 - Beta 3 LiveCDs (Probably all) fail to boot with nvidia GPU ]
20:26:26 <ennael> can we close this one?
20:26:51 <tmb> 5462 should be fixed, atleast on single-gpu systems... it would be nice to see if it works on a nvidia/intel laptop
20:27:19 <ennael> do we have people around with this hardware?
20:27:20 <leuhmanu> and the blocker ?
20:27:22 <tmb> single-gpu as in nvidia only
20:27:55 <tmb> MrsB has confirmed it works for her (and her hw uses nvidia-current)
20:28:07 <ennael> so can we close it?
20:28:28 <tmb> I think we can, it can always be re-opened if someone else hit it
20:28:46 <ennael> ok
20:28:53 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5426
20:28:56 <erzulie> [ Bug 5426 - Beta3 doesn't boot on ati graphics hardware ]
20:29:18 <anaselli> tmb could amd/intel be helpful instead?
20:29:22 <leuhmanu> can somebody remove the line in the download page ? so we can have new bug if npt
20:29:25 <leuhmanu> not
20:30:16 <tmb> anaselli: amd/intel test is needed for 5426
20:31:03 <anaselli> tmb ok i can ask my collegue for that, but the iso livecd i have now does not start X at the moment
20:31:32 <anaselli> have you got one new?
20:31:42 <tmb> anaselli: RCs ?
20:31:46 <anaselli> yes
20:32:00 <AL13N> anaselli: did you have a pre-RC?
20:32:08 <anaselli> AL13N: yes
20:32:24 <AL13N> anaselli: RC is out, so i suspect it is newer
20:32:27 <AL13N> unsure though
20:32:27 <tmb> final RC that is ?
20:32:59 <anaselli> tmb: no the pre rc
20:33:12 <anaselli> MrsB: told me where to download it
20:33:32 <anaselli> so if rc is out i will test that tomorrow morning, then tmb
20:33:34 <AL13N> anaselli: better get the real one then
20:33:35 <tmb> ah, maybe you got one of broken build that booted in runlevel 3
20:33:40 <rindolf> Sorry. Got disconnected.
20:33:59 <AL13N> #action #5426 anaselli will test
20:33:59 <tmb> anaselli: thanks
20:33:59 <anaselli> tmb: i will give you the feed back tomorrow then
20:34:08 <ennael> ok
20:34:35 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5192
20:34:37 <erzulie> [ Bug 5192 - keyboard layout not set correctly for LUKS passphrase ]
20:34:48 <coling> couldn't reproduce no matter how many times I tried.
20:35:00 <coling> I think  the reporter said he's retry after the official RC.
20:35:02 <coling> So next :)
20:35:07 <ennael> yep
20:35:17 <ennael> https://bugs.mageia.org/show_bug.cgi?id=4772
20:35:19 <erzulie> [ Bug 4772 - boot hangs at 'Starting cpufreq (via systemctl)' ]
20:35:32 <coling> Again waiting for feedback with RC I think.
20:35:44 <ennael> can you update bug then for RC ?
20:35:58 <coling> Somebody said their netbook had issues and were going to try... Luigi12 maybe? I forget
20:36:10 <ennael> #action #5192 #4772 waiting for updates after RC tests
20:36:13 <rindolf> Hmmm... my Mageia 1 VM keeps crashing when I run urpmi --auto --auto-select.
20:36:24 <coling> rindolf, please wait.
20:36:29 <coling> rindolf, we're mid-meeting
20:36:35 <rindolf> coling: OK, OK.
20:36:52 <rindolf> coling: I'm trying to fix my assigned bug.
20:36:57 <ennael> coling: can you ask for tests using RC on that bug ?
20:37:04 <coling> ennael, I'll update the bug. Is the RC announcement out there?
20:37:18 * coling hasn't seen it.
20:37:23 <ennael> yep on blog
20:37:27 * ennael forgot ML my bad
20:37:32 <ennael> will do it juste after
20:37:43 <ennael> https://bugs.mageia.org/show_bug.cgi?id=1812
20:37:54 <ennael> tmb: any idea on that one ?
20:38:10 <AL13N> (i don't see erzulie)
20:38:23 <ennael> she is sleeping
20:38:25 <ennael> with tmb
20:38:26 <leuhmanu> ,bug 1812
20:38:26 <ennael> :)
20:38:28 <[mbot> Bug https://bugs.mageia.org/show_bug.cgi?id=1812 major, release_blocker, Mageia 2, mageia, NEW, Closing an "Advanced settings" window during live-install quits the installer without warning, draklive-install
20:38:53 <AL13N> heh
20:39:08 <AL13N> ok, so is this fixable, noone seems to do it
20:39:17 <AL13N> if not, i guess this goes on to errata
20:39:24 <Luigi12> oh no, meeting :o(    coling: no I don't have a netbook
20:39:31 <ennael> let's add it to errata
20:39:40 <ennael> AL13N: can you add it to errata please ?
20:39:46 <AL13N> yeah
20:40:02 <ennael> thanks
20:40:12 <ennael> #action AL13N add #1812 to errata
20:40:52 <ennael> now 2 last trackers
20:40:54 <ennael> https://bugs.mageia.org/show_bug.cgi?id=2120
20:40:59 <coling> My favourite
20:41:01 <coling> :)
20:41:20 <coling> OK, so the hwclock one is pretty much waiting IMO on the e2fsprogs issue I've been pinging about.
20:41:21 <ennael> :)
20:41:36 <coling> I really don't see why people are confused by this one.
20:41:38 <ennael> yep we need to decide on that one...
20:41:51 <coling> Basically e2fsck is braindead.
20:41:56 <Luigi12> ennael: icewm wasn't ready to be pushed yet, now it's config is broken
20:42:06 <coling> It uses the *current* time to decide on whether or not to break boot and perform a check
20:42:18 <coling> This is just dumb and no other fsck that I know of does this.
20:42:27 <coling> My change is simply to turn this option off.
20:42:33 <ennael> Luigi12: please meeting in progress
20:42:51 <ennael> I would say ok on my side
20:42:54 <coling> Fedora have done this already and I've spoken to Kay (upstream udev, systemd) and he recommends this approach.
20:42:55 <sander85> +1 on turning it off
20:43:00 <Luigi12> :P
20:43:54 <coling> OK, so decided?
20:44:13 <ennael> yes adding opinions on ML I think we validate it
20:44:17 <coling> The only other bug on the tracker (cpufreq one is also marked as release blocker so we've discussed already)
20:44:31 <coling> is the prefdm.service fails to start.
20:44:40 <ennael> yep
20:44:41 <coling> That's a bad title really, but it's the LSB scripts issue.
20:44:53 <sander85> how many scripts left?
20:44:54 <ennael> pterjan did the remaining one yesterday evening
20:44:59 <coling> There are still about 10-15 packages with this issue.
20:45:06 <coling> Oh really?
20:45:14 <ennael> yep I submiytted it yesterday
20:45:27 <coling> Hmm, I don't think that covers all of them.
20:45:31 <coling> See https://docs.google.com/spreadsheet/ccc?key=0AjumKqYMRG9WdHdkRWM3dUhEYms5T1BkR05KRnp6V1E#gid=0
20:45:51 <AL13N> (action colin will check the last LSB header packages)
20:45:53 <AL13N> :-)
20:45:54 <coling> These are the packages that I have listed that have initscripts with no LSB headers.
20:45:57 <pterjan> ennael: that was not the same, I fixed the 10-15 packages with broken lsb headers
20:46:06 <pterjan> not the ones without any
20:46:11 <ennael> argh ok my bad
20:46:16 <coling> I can probably fix the remaining packages on Friday
20:46:17 * ennael is tired :)
20:46:21 <ennael> would be great
20:46:29 <coling> (I have a long train journey to fill!)
20:46:43 <coling> Might not be able to commit/submit until Monday evening tho'
20:46:49 <AL13N> (be careful what you wish for)
20:46:57 <coling> :D
20:47:07 <erzulie> [ Bug 1812 - Closing an "Advanced settings" window during live-install quits the installer without warning ]
20:47:07 <erzulie> [ Bug 1812 - Closing an "Advanced settings" window during live-install quits the installer without warning ]
20:47:07 <erzulie> [ Bug 2120 - [Tracker] Implement systemd in Mageia 2 - specifications ]
20:47:07 <erzulie> [ Welcome to Google Docs ]
20:47:20 <ennael> #action #5262 coling will fix remaining packages
20:47:21 <coling> Ahh Freenode issues it seems :)
20:47:34 <ennael> yep :)
20:47:50 <AL13N> heh
20:47:59 <AL13N> so now the upgrade issue tracker?
20:48:02 <coling> I guess so.
20:48:10 <AL13N> pfff, still al ot
20:48:34 <ennael> https://bugs.mageia.org/show_bug.cgi?id=3342
20:48:37 <erzulie> [ Bug 3342 - [Tracker] Upgrade Mga 1 > Mga 2 ]
20:48:49 <ennael> many of them have been already discussed
20:49:01 <ennael> https://bugs.mageia.org/show_bug.cgi?id=4136
20:49:03 <erzulie> [ Bug 4136 - mgaapplet still displays 'invalid password' dialog even when I haven't entered any password ]
20:49:08 <coling> Yeah we've already discussed a few of them it seems
20:49:09 <anaselli> sorry i'm tired and need to go to bed... good night
20:49:17 <coling> Night anaselli :)
20:49:28 <ennael> leuhmanu: can you ping on that bug ?
20:49:34 <ennael> a long time nothing happened
20:50:03 <leuhmanu> yes
20:50:06 <ennael> thanks
20:50:08 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5103
20:50:10 <erzulie> [ Bug 5103 - libchamplain-gtk0.12_0 needs to replace libchamplain-gtk0.8_1 ]
20:51:05 <ennael> leuhmanu: web site updated on nvidia issue
20:51:27 <leuhmanu> hum it's mdv 2010.2 > mga1 upgrade sorry
20:51:34 <leuhmanu> ennael: yep seen thaks
20:51:36 <leuhmanu> +n
20:52:02 <ennael> leuhmanu: ?
20:52:41 <leuhmanu> I upgraded from Mandriva 2010.2 to Mageia 1.
20:52:58 * leuhmanu don't know what's happen in his brain...
20:53:07 <leuhmanu> so next :)
20:53:32 <sander85> https://bugs.mageia.org/show_bug.cgi?id=5357 is this really release_blocker?
20:53:34 <erzulie> [ Bug 5357 - Default-kde4-config requires plasma-applet-icontasks ]
20:53:52 <ennael> these one are not release blocker but dealing with upgrade
20:54:03 <ennael> I will ping mikala
20:54:32 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5686
20:54:34 <erzulie> [ Bug 5686 - python-at-spi needed on iso images to allow update of pyatspi ]
20:54:48 <ennael> I'm on it but it seems reporter did not use final RC iso
20:55:00 <ennael> I guess it's all on bug review
20:55:34 <coling> Yup seems so.
20:55:44 <ennael> anything else to add on meeting ?
20:56:08 <coling> Well, only thing from me is to ask if I can push memcache and maybe openvpn to change slightly how things are done.
20:56:19 <tmb> submission lockdown...
20:56:32 <coling> I asked about memcache a few days ago.
20:56:36 <coling> But no reply.
20:56:50 <coling> The issue is not IMO super important but it's a nice change after discussing with upstream.
20:56:56 <AL13N> coling: what will you change with openvpn?
20:57:17 <coling> AL13N, same as with memcache. It's to add a target that deals with all instances of the templated unit.
20:57:23 <AL13N> oic
20:57:29 <coling> Thus allowing an easy command to restart all openvpn configs at once.
20:57:34 <coling> (or memcache instances)
20:57:34 <AL13N> so if you have more tunnels it''ll be easier
20:57:38 <coling> Yeah.
20:58:03 <coling> This was an ideal after discussing upstream when dealing with a RH client who had to deal with several hundred ftp templated units.
20:58:11 <coling> Restarting them was, as you can imagine a pain.
20:58:17 <AL13N> right
20:58:30 <AL13N> coling: allthough he could likely script it :-)
20:58:40 <coling> AL13N indeed.
20:58:58 <coling> The only reason I'd be keen to push the change now is that doing it later is that it becomes harder to deal with *after* migrating to systemd from sysvinit for upgraders.
20:59:15 <coling> But if it's considered too much of a risk, I'll concede.
20:59:25 <AL13N> i'm not averse to the change, but it's a new feature, isn't it
20:59:35 <AL13N> or rather, a feature that was lost, reimplemented
20:59:44 <coling> Indeed.
20:59:57 <coling> memcache and openvpn initscripts kinda did this internally before.
21:00:17 <coling> (I guess the new feature is that you can control each independently now under systemd)
21:00:26 <AL13N> yes, but that's already there
21:00:31 <coling> Yeah.
21:00:39 <AL13N> it's a gray area
21:00:39 <coling> new vs. sysvinit I meant
21:01:08 <AL13N> coling: will it have an effect on MCC drakxservices?
21:01:19 <coling> AL13N no.
21:01:28 <AL13N> like: openvpn-all + openvpn1 + openvpn 2 + .... etc...
21:01:29 <coling> It'll only list the individual units.
21:01:33 <AL13N> :-(
21:01:46 <AL13N> but yeah
21:01:51 <coling> One for later when we drop sysvinit support... too much of a pain to support just now.
21:02:00 <AL13N> of course
21:02:10 <AL13N> well, who decides for this?
21:02:14 <AL13N> not me for sure
21:02:19 * pterjan updating the server, one big transaction of 1898 packages :/
21:02:20 <AL13N> tmb: ennael: ?
21:02:27 <coling> Well not me :)
21:02:43 <coling> But I have committed memcached so if it's not going to get pushed I should revert it.
21:03:14 * ennael would like tmb opinion but seems to break current freeze
21:03:15 <boklm> AL13N: https://wiki.mageia.org/en/Mageia_2_Release_Notes#mariadb
21:03:16 <erzulie> [ Mageia 2 Release Notes - Mageia wiki ]
21:03:19 <sander85> we should push it in, it should be easy to revert if it causes some trouble
21:03:42 <coling> sander85, no reverting now tho'. If it goes in, it stays in IMO.
21:04:07 <coling> It's not a major thing tho'. I'll work out a way to do it as an update.
21:04:18 <coling> So forget about it.
21:04:28 <coling> #action coling to revert memcached in svn.
21:04:34 <Umeaboy> Is minios meant to be included in Mageia?
21:04:34 <ennael> ok
21:04:40 <ennael> Umeaboy: meeting in progress
21:04:46 <AL13N> boklm: it was specific to upgrade so i added in a bit more text
21:04:46 <Umeaboy> OK.
21:04:47 <Umeaboy> Sorry.
21:04:56 <ennael> ok anything else to add for tonight ?
21:05:16 <tmb> ennael: the submission stop
21:05:39 <coling> I guess not. I do want to push a new systemd, to include the specific fixes also taken from fedora. But we'll see what tmb thinks of that.
21:05:39 <ennael> tmb: ?
21:06:05 <coling> I'm not too worried if we don't and I suspect i'll do some updates post release anyway.
21:06:20 <tmb> ennael: as in when we stop submitting packages through freeze even if they are security updates
21:06:59 <ennael> we stopped security updates last friday
21:07:04 <ennael> so it should be stopped now
21:07:05 <AL13N> i think now is good, some security fixes are present for 4 months before fixing, so 2 weeks should be fine
21:07:45 <leuhmanu> we have not said the 12 in the council ?
21:07:58 <ennael> #topic final planning
21:08:00 <pterjan> well we can upload them to updates/ anyway
21:08:48 <ennael> outch I'm a bit disturbed :)
21:08:57 <ennael> security tracker has been closed
21:09:05 <tmb> leuhmanu: yep, thats why I wanted it to get noted /confirmed on packagers meeting too
21:09:18 <ennael> but sublmission closed on friday
21:09:21 <ennael> sorry
21:09:30 <leuhmanu> saturday
21:09:45 <ennael> #info security updates submission will stop on 12nd of may
21:10:22 <ennael> tmb: what about starting building final isos on monday or tuesday ?
21:11:27 * ennael sees tmb running very far
21:12:25 <tmb> well, I'd probably let first set build during night between sunday and monday the, so lets sync frozen repo on sunday
21:12:33 <Luigi12> can we at least get the ffmpeg/mplayer update in?  It's already been tested.  I won't ask for any more until release.
21:13:41 <ennael> tmb: ok
21:13:50 <coling> tmb, what about the intel + nvidia updates/testing packages?
21:13:59 <coling> tmb, should these go into core/release now?
21:14:11 <ennael> #info repository will be frozen sunday evening for first builds of final isos
21:14:23 <tmb> intel will be pushed. I'd like more tests on the nvidia one
21:14:56 <leuhmanu> there is also calligra hplib and gimp at least
21:15:03 <leuhmanu> and some gtk fix
21:16:20 <ennael> ok
21:16:25 <ennael> anything else?
21:17:17 <coling> Not from me. (tho' please do remember to push e2fsprogs :D)
21:17:42 <Luigi12> just please get to the last freeze push requests I pinged on the list, and also desktop-common-data once coincoin fixes it
21:17:51 <coling> Oh there was a prdoom build issue IIRC (it was an LSB script thing)
21:17:51 <ennael> in progress
21:18:00 <coling> prbroom?
21:18:01 <ennael> ok tahnks guys for attending
21:18:05 * coling forgets the name
21:18:14 <coling> That should be fixed by maintainer ideally
21:18:17 <coling> :maint prbroom
21:18:18 <Sophie> coling: The rpm named `prbroom' has not been found in (Mageia, cauldron, i586)
21:18:24 <coling> :maint prboom
21:18:24 <Sophie> coling: For Mageia (prboom): zezinho
21:18:51 <Luigi12> yeah there's a denial of service issue in a few games that still needs to be addressed, but it'll happen after release now
21:18:52 <coling> Anyway, that shouldn't delay the end of the meeting :)
21:18:57 <ennael> closing the meeting then
21:18:58 <Luigi12> yep
21:19:02 <ennael> #endmeeting