19:05:12 <guillomovitch> #startmeeting
19:05:12 <Inigo_Montoya`> Meeting started Wed May  2 19:05:12 2012 UTC.  The chair is guillomovitch. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:05:12 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:05:13 <erzulie> [ MeetBot - Debian Wiki ]
19:05:52 <guillomovitch> is there anything else to discuss as blocker bugs ?
19:07:45 <guillomovitch> hum hum...
19:08:00 * ennael gives some matches to guillomovitch
19:08:16 <ennael> coling, tmb, Anssi around ?
19:08:21 <sebsebseb> hi
19:08:49 <coincoin> hello
19:09:55 <ennael> guillomovitch: forgot to mail -dev so people may be missing
19:11:39 <guillomovitch> indeed
19:11:55 <trem> doktor5000_: I've done the commit on e and e_modules, if you want to check it
19:12:21 <ennael> guillomovitch: well... we can work on mail about release_blocker
19:12:30 <guillomovitch> ok
19:12:43 <tmb> yo
19:12:48 <ennael> ah tmb :)
19:12:50 <guillomovitch> #topic release_blocker bugs
19:13:36 <guillomovitch> on bugzilla, how do I stroke one dependant bug
19:13:49 <guillomovitch> without removing it
19:13:52 <guillomovitch> once resolved ?
19:14:09 <guillomovitch> stroke may not be the correct verb
19:14:27 <tmb> mark it as fixed, but dont remove from blocker list
19:14:58 <guillomovitch> OK
19:15:13 <guillomovitch> this doesn't apply to bug fixed in cauldron only, unfortunatly :/
19:15:22 <guillomovitch> anyway, let's review tracker bugs
19:15:39 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5046
19:15:41 <erzulie> [ Bug 5046 - [Tracker] Security updates for Mageia 2 ]
19:15:46 <guillomovitch> two issues still to fix
19:16:30 <guillomovitch> both of them with someone assinged
19:17:08 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5034
19:17:10 <erzulie> [ Bug 5034 - [TRACKER] Oxygen integration issues ]
19:18:05 <guillomovitch> 3 bugs, only two of them assigned to someone
19:18:47 <dwalluck> http://www.nvnews.net/vbulletin/showthread.php?t=177732
19:18:48 <erzulie> [ Random crashes, NVRM Xid messages - nV News Forums ]
19:19:01 <guillomovitch> none of them considered blocker
19:19:09 <guillomovitch> so ?
19:19:25 <ennael> I guess we can decrease priority
19:19:48 <guillomovitch> 3 bugs normal/normal => tracker set to normal/normal
19:20:33 <leuhmanu> well the missing bug is a real one
19:20:43 <leuhmanu> an a bit anoying (?)
19:20:44 <guillomovitch> missing ?
19:20:52 <leuhmanu> missing icon sorry
19:21:13 <guillomovitch> are you volonteering for fixing it ?
19:21:18 <leuhmanu> no
19:21:47 <ennael> this can be fixed in update
19:21:48 <guillomovitch> so, next tracker
19:21:53 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=4300
19:21:55 <erzulie> [ Bug 4300 - [Tracker] General artwork in Mageia 2 - specifications ]
19:21:58 <leuhmanu> yep
19:22:02 <guillomovitch> 5 issues
19:22:46 <guillomovitch> 3 classified as enhancement
19:23:00 <guillomovitch> 2 normal/normal bugs
19:23:21 <guillomovitch> I suggest to remove enhancement from the tracker, and set their target to mageia3
19:23:29 <guillomovitch> and to lower tracker priority
19:23:34 <ennael> yep
19:23:51 <guillomovitch> one bug is considered 'high' tough
19:23:52 <ennael> I just closed the one about installer images
19:24:11 <guillomovitch> fine
19:25:44 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=3342
19:25:46 <erzulie> [ Bug 3342 - [Tracker] Upgrade Mga 1 > Mga 2 ]
19:25:48 <guillomovitch> upgrade tracker...
19:26:00 <guillomovitch> 10 bugs
19:27:12 <ennael> 5721 is in progress
19:27:16 <ennael> from RC tests
19:27:29 <guillomovitch> 5677 should be easy to fix
19:27:42 <guillomovitch> and it is already assigned to me :)
19:28:14 <guillomovitch> 5721 should rather get assigned to someone
19:28:39 <guillomovitch> ovitters: ping ?
19:28:58 <ennael> I close the first one 4541
19:29:06 <ennael> looks like it's solved
19:29:42 <guillomovitch> cool
19:30:14 <guillomovitch> 5358 is considred critical
19:30:53 <guillomovitch> ok, two release_blockers in the list
19:31:20 <guillomovitch> 5556 and 5721
19:31:42 <guillomovitch> I think something has been tried tudring the week-end for 5556
19:31:47 <guillomovitch> tmb: ping ?
19:32:01 <tmb> yep. 5556 is fixed.
19:32:12 <ennael> raaaaa close it !
19:32:13 <ennael> :)
19:32:44 <tmb> the autoreq stuff failed, so I did it manually for all ~115 packages :)
19:32:50 <guillomovitch> so, 8 remaining issues, one being release_blockers-but-in-progress
19:33:32 <ennael> yep
19:33:34 <guillomovitch> ennael: we need someone else as the bug squad for 5721
19:33:41 <guillomovitch> as assignee for
19:34:06 <guillomovitch> you seem quite well placed for it, according to the first comment
19:34:15 <ennael> xfce seems to be fixed
19:34:20 <ennael> still need e17 fix
19:34:28 <ennael> so either trem or doktor5000_ ?
19:34:35 <tmb> I think the e stuff is waiting in svn for verification before submission
19:34:47 <leuhmanu> guillomovitch: they are in the cc list
19:35:00 <ennael> can we close it now ?
19:35:03 <doktor5000_> ennael: trem already commited, i'll need to review, and write freeze push request
19:35:10 <leuhmanu> (but indeed the triaged keyword is missing)
19:35:13 <ennael> ok can it be done now?
19:35:19 <doktor5000_> ennael: i'll try
19:35:23 <ennael> so that we can include it for RC isos
19:35:24 <guillomovitch> leuhmanu: I want someone to be responsible for the bug
19:35:33 <ennael> guillomovitch: I will follow it
19:35:36 <guillomovitch> not just "part of people aware of it"
19:35:44 <guillomovitch> ennael: ok, you're the assignee now
19:35:45 <ennael> need this one to be solved for isos
19:37:01 <guillomovitch> final word on this tracker: 8 bugs, one of them being release blocker
19:37:49 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=2120
19:37:52 <erzulie> [ Bug 2120 - [Tracker] Implement systemd in Mageia 2 - specifications ]
19:38:21 <doktor5000_> ennael: tmb: freeze push request sent
19:38:31 <ennael> thanks
19:38:32 <guillomovitch> 4 bugs, including one release blocker
19:38:47 <doktor5000_> ennael: thanks to trem, too ;)
19:38:59 <ennael> :)
19:39:16 <guillomovitch> #info upgrade tracker #3342 has 8 bugs, including 1 release blocker
19:39:53 <guillomovitch> #info artwork tracker #4300 has 1 bug
19:40:31 <Luigi12_work> guillomovitch: just FYI, cifs-utils isn't quite fixed yet in Cauldron since it won't build on the build system
19:40:36 <guillomovitch> #info oxygen tracker #5034 has 3 bugs
19:40:47 <guillomovitch> Luigi12_work: argh...
19:41:17 <guillomovitch> #info security tracker #5046 has 3 bugs
19:41:34 <guillomovitch> so, any thoughs on systemd tracker now ?
19:42:08 <Luigi12_work> there's one more security bug not added to the tracker; I hope to fix it tomorrow
19:42:10 <guillomovitch> 4 issues, one of them release blocker
19:42:36 <guillomovitch> without coling, it's a bit difficult to decide what to do there
19:42:39 <ennael> having a look
19:42:41 <ennael> yep
19:42:48 <ennael> we may mail about that specific one
19:43:31 <anaselli> which is exactly?
19:43:35 <Luigi12_work> did I miss anything in the beginning of the meeting that I was needed for?
19:43:52 <guillomovitch> anaselli: https://bugs.mageia.org/show_bug.cgi?id=2120
19:43:55 <erzulie> [ Bug 2120 - [Tracker] Implement systemd in Mageia 2 - specifications ]
19:44:13 <guillomovitch> #info systemd tracker #2120 has 4 bugs, including 1 release blocker
19:44:40 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=4299
19:44:42 <erzulie> [ Bug 4299 - [Tracker] syslinux, gfxboot in Mageia 2 ]
19:44:57 <anaselli> https://bugs.mageia.org/show_bug.cgi?id=4772
19:44:59 <erzulie> [ Bug 4772 - boot hangs at 'Starting cpufreq (via systemctl)' ]
19:45:23 <guillomovitch> ennael: you were to discuss with erwan_taf for those issues
19:45:29 <guillomovitch> 3 bugs
19:45:31 <ennael> yep
19:45:33 <guillomovitch> none of them blocker
19:45:38 <ennael> should not appear here
19:46:05 <ennael> already decreased do "high"
19:46:08 <guillomovitch> 2038 and 5263 seems quite close
19:46:27 <ennael> postponed for mageia 3 as it needs changes in installer also
19:46:58 <guillomovitch> the 3 of them ?
19:47:08 <ennael> yep it's all about gfxboot theme
19:47:26 <guillomovitch> so, let's remove them from the tracker, and set their target milestone to mageia 3
19:48:07 <ennael> [RPM] cauldron core/release e-0.16.999.68658-0.r69188.3.mga2
19:48:11 <ennael> what a version
19:49:29 <guillomovitch> #info gfxboot tracker #4299 has been closed \o/
19:49:39 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=1994
19:49:42 <erzulie> [ Bug 1994 - [TRACKER] Mageia 2 Technical Specifications ]
19:50:05 <guillomovitch> 3 bugs (two of them being trackers)
19:50:09 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=1215
19:50:12 <erzulie> [ Bug 1215 - Partitioning issues with 4k drives ("advanced format") ]
19:50:26 <guillomovitch> this one seems to be closed
19:50:34 <guillomovitch> but no one answer...
19:51:16 <guillomovitch> let's wait for pterjan answer
19:51:45 <guillomovitch> #info Technical Specifications tracker #1994 has 3 bugs, two of them being other trackers
19:52:02 <guillomovitch> #action ask pterjan about #1215
19:53:00 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5015
19:53:03 <erzulie> [ Bug 5015 - TRACKER: WLAN - WIFI not or badly working in cauldron ]
19:53:26 <sebsebseb> guillomovitch: Pterjan is away
19:53:43 <anaselli> add an action :D
19:55:06 <ennael> blino, tmb around ?
19:55:07 <erwan_taf> on my side, removing networkmanager solved my wifi issues
19:55:22 * ennael smells troll
19:55:36 <tmb> yep
19:56:18 <ennael> we have a tracker about wifi issues
19:56:54 <Bertl> a lot of the wifi configuration wasn't working up to recent cauldron
19:57:16 <Bertl> main problem seems/seemed to be that there are 3 different tools to configure
19:58:07 <guillomovitch> I'd say than removing drakx-net would also solve the very same issues
19:58:32 <guillomovitch> Bertl: which is the 3rd one ?
19:58:59 <guillomovitch> we still have 9 issues for this tracker
19:59:00 <leuhmanu> related to wifi, any ideas https://bugs.mageia.org/show_bug.cgi?id=5682 ?
19:59:02 <erzulie> [ Bug 5682 - System boot locks up when b43 firmware is not installed on systems with BCM4318 wireless LAN controller. ]
19:59:10 <guillomovitch> I just removed one enhancement
19:59:23 <blino> erwan_taf: there's a known bug in NM, starting a wpa_supplicant instance even if interface is not managed by NM...
19:59:48 <blino> erwan_taf: https://bugs.mageia.org/show_bug.cgi?id=3344#c13
19:59:50 <erzulie> [ Bug 3344 - NetworkManager spawns a wpa_supplicant instead even if interface is unmanaged, conflicting with drakx-net tools ]
19:59:51 <guillomovitch> \o/ blino
19:59:56 <ennael> ah :)
19:59:58 <Bertl> guillomovitch: there is one you get from e.g. the gnome network applet, another one from the control center and finally the drak one
20:00:00 <ennael> blino: don't move !
20:00:22 <guillomovitch> Bertl: the one form the control center is draknet
20:00:30 <guillomovitch> packaged in drak-net package
20:00:41 <guillomovitch> and the 'gnome network  applet
20:00:50 <guillomovitch> is just an interface over networkmanager
20:00:55 <guillomovitch> you have two tools, actually
20:01:08 <erwan_taf> blino: thx
20:01:14 <leuhmanu> (wicd does'nt work iirc)
20:01:24 <guillomovitch> we ship wicd ?
20:01:28 <leuhmanu> yes
20:01:31 <guillomovitch> including the recent exploit :) ?
20:01:34 <ennael> outch
20:01:47 <anaselli> has nm been tested under kde? I mean in mga1 the widget was very buggy
20:02:05 <Luigi12_work> I patched the exploit for wicd in Cauldron recently, but it's in QA for Mageia 1 because nobody knows how to test it
20:02:15 <Luigi12_work> What is wicd used for?  Nothing seems to require it.
20:02:36 <guillomovitch> nothing requires a configuration tool
20:02:40 <guillomovitch> except the final user :)
20:02:45 <anaselli> if nm is our future, i will test it better... i din't care of that at the moment...
20:02:50 <guillomovitch> ok, we have 10 bugs for this tracker
20:03:05 <guillomovitch> roughly 4 for blino and 4 for tmb
20:03:29 <guillomovitch> 1 for titi, and 1 for bug squad
20:04:01 <guillomovitch> none of them release blocker, tough
20:04:06 <guillomovitch> so, what can we do ?
20:04:25 <Bertl> I also presume that the HSPA modem support is still not working, but I can test that tonight
20:04:27 <guillomovitch> apart loweing the tracker to 'high'
20:04:32 <guillomovitch> modem ?
20:04:58 <Bertl> well, gsm, 3g modems
20:04:58 <guillomovitch> guys, are you living in the same century as everyone else :) ?
20:05:14 <guillomovitch> ah, that kind of modem, ok
20:05:17 <Bertl> they are still modems :)
20:05:46 <guillomovitch> they don't play music when connecting !
20:05:53 <ennael> guillomovitch: shall we switch to high this tracker ?
20:06:12 <blino> Bertl: it used to be working
20:06:24 <guillomovitch> ennael: yes, of course
20:06:49 <ennael> ok
20:07:08 <guillomovitch> #info wifi tracker #5015 has 10 bugs, but no blocker
20:07:24 <Bertl> blino: well, it didn't work since mageia 1 (the configuration via GUI that is) they can be made to work by preventing auto configuration and writing your own scripts/configs :)
20:07:53 <ennael> about security tracker I would close it now
20:08:04 <ennael> we are 3 weeks from final release
20:08:13 <ennael> at one point we have to stop
20:08:21 <blino> guillomovitch: just closed #4046
20:08:22 <guillomovitch> we don't have any other trackers AFAIK
20:08:40 <blino> Bertl: do you have more details about the issue?
20:08:50 <guillomovitch> #info wifi tracker #5015 has 9 bugs only now
20:09:24 <Bertl> blino: 5232 for example, asssigned to you
20:09:29 <guillomovitch> who has the magic URL for release blocker bugs ?
20:09:41 <leuhmanu> ,bugslist P1
20:09:47 <leuhmanu> ,buglist P1
20:09:47 <[mbot> https://bugs.mageia.org/buglist.cgi?quicksearch=P1
20:09:49 <erzulie> [ Bug List ]
20:10:18 <guillomovitch> ouch...
20:10:19 <anaselli> Bertl: have you tried using nm also=
20:10:23 <anaselli> sorry ?
20:10:31 <Bertl> blino: but as I said, I can easily test
20:10:39 <anaselli> i mean s/=/?
20:10:49 <guillomovitch> 23https://bugs.mageia.org/show_bug.cgi?id=3921
20:10:51 <erzulie> [ Bug 3921 - %post fails to add xguest to /etc/ssh/denyusers if this file does not exist yet ]
20:11:03 <guillomovitch> how  can bugs for stable release be considered release blockers :) ?
20:11:22 <leuhmanu> because this is for all bugs
20:11:30 <Bertl> anaselli: a lot of things were tested to get it working, if you have specific suggestions, please let me know
20:11:31 <leuhmanu> all 5700 we have
20:11:43 <leuhmanu> ,buglist P1+ver:caul
20:11:43 <[mbot> https://bugs.mageia.org/buglist.cgi?quicksearch=P1+ver:caul
20:11:45 <erzulie> [ Bug List ]
20:11:46 <leuhmanu> better ?
20:12:01 <Luigi12_work> ennael: can you wait until Friday on the security tracker?
20:12:07 <ennael> yep sure
20:12:15 <ennael> but we close it on friday then
20:12:22 <Luigi12_work> ok
20:12:33 <leuhmanu> this does'nt list the sysadmin blocker bugs..
20:12:58 <anaselli> Bertl: i have 3 3G keys, none of them worked with drakconnet, but did with networkmanager, that i enable only for that at the moment in mga1
20:13:13 <ennael> tmb: any clue on that one https://bugs.mageia.org/show_bug.cgi?id=5674 ?
20:13:15 <erzulie> [ Bug 5674 - reboot or shutdown hangs with either rc live cd or dvd. ]
20:13:43 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=2317
20:13:45 <erzulie> [ Bug 2317 - --update option should behave like --search-media <list of the update media> ]
20:15:09 <coling> ennael, guillomovitch Hi
20:15:12 <coling> Sorry, I'm late.
20:15:20 <tmb> ennael: I think I have the shutdown for livecds fixed (testing currently)
20:15:32 <ennael> ok
20:15:38 <ennael> so to be tested on next isos
20:15:58 <ennael> which packages concerned ?
20:16:12 <guillomovitch> hi coling
20:16:34 <guillomovitch> we're reviewing the non-tracker release blockers
20:16:47 <coling> tmb, did you get the unit stuff working after our discussion last night?
20:17:00 <coling> (for the shutdown of live cds)
20:17:15 <guillomovitch> https://bugs.mageia.org/buglist.cgi?bug_status=REOPENED&bug_status=NEW&bug_status=ASSIGNED&bug_status=UNCONFIRMED&field0-0-0=priority&query_format=advanced&type0-0-0=anyexact&value0-0-0=release_blocker&order=short_desc%2Cpriority%2Cbug_id%20DESC&query_based_on=
20:17:17 <erzulie> [ Bug List ]
20:17:25 <ennael> tmb: oh vnstat package ?
20:17:37 <tmb> ennael: well, shutdown on livecds are due to a specially crafted /sbin/halt.local we install during livecd creation
20:17:40 <guillomovitch> gentlemen (and gentle ladies too)
20:17:47 <guillomovitch> can we review the list in order ?
20:17:50 <guillomovitch> first
20:18:08 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5426
20:18:10 <erzulie> [ Bug 5426 - Beta3 doesn't boot on ati graphics hardware ]
20:18:32 <guillomovitch> this one is really painful
20:18:40 <ennael> yep
20:19:06 <guillomovitch> can we do anything about it right now ?
20:19:12 <Bertl> well, the ati firmware issue is quite annoying in general
20:19:30 <guillomovitch> s/the ati firmware issue/ati/
20:19:45 <anaselli> but unfortunately a lot of people have (me too)
20:19:46 <guillomovitch> anyway, Anssi is not there
20:20:15 <guillomovitch> so ?
20:20:37 <ennael> is Anssi the only one working on this ?
20:20:48 <ennael> tmb, blino, any idea on this ?
20:21:02 <tmb> well, we have dropped radeon kernel module from livecd initrd, so the display_helper kicks in properly now
20:21:21 <guillomovitch> meaning, it should be fixed ?
20:21:23 <ennael> does that mean it solves this issue ?.
20:21:25 <ennael> :)
20:21:45 <leuhmanu> what said the qa ?
20:22:22 <ennael> tmb: it means it should sollve the issue but still we need some tests ?
20:22:29 <tmb> it should hopefully do so as display_helper switches to vesa/nokmsboot without problems
20:22:48 <ennael> maybe we should mail -dev to ask for tests
20:22:52 <Anssi> hi!
20:23:04 <tmb> but yes, we need tests ... and specifially also dual intel/amd gpu
20:23:04 <ennael> as testers of isos are quite short in term of needed hardware
20:23:06 <anaselli> \o/ Anssi
20:23:18 <ennael> tmb: can you write an email about this ?
20:23:26 <ennael> adding test case to help people ?
20:23:33 <anaselli> i can do some test with livecd on my ATI card
20:23:43 <Anssi> another thing (that would probably fix the dual graphics issues on Live) would be to make fglrx used properly
20:23:45 <Bertl> I can test on a number of problematic cards as soon as I get the isos
20:23:45 <anaselli> but do i need the new one?
20:23:55 <coling> I can possibly boot on my colleagues laptop which is dial intel/amd
20:24:01 <anaselli> i meen iso livecd :)
20:24:12 <leuhmanu> Bertl: http://bn.parinux.org/p/mageia2rc
20:24:16 <guillomovitch> well, if there is someone to handle the issue, let's switch to the next one
20:24:17 <leuhmanu> on the top
20:24:18 <coling> (tmb FYI it's the one I disabled the ATI on earlier... think I mentioned it to you!)
20:24:20 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=4696
20:24:21 <Anssi> since fglrx AFAIK contains hacks that make intel/amd systems work properly without us needing to add any switcheroo magic at this point
20:24:28 <ennael> Anssi: can you work on it before final release ?
20:24:32 <ennael> guillomovitch: wait 2 secs
20:24:34 <erzulie> [ Etherpad Lite ]
20:24:34 <anaselli> i could do the same with a nvidia/intel one
20:24:34 <erzulie> [ Bug 4696 - Install freeze after licence acceptation (system without floppy disk in the drive) (error I/O fd0) ]
20:25:14 <tmb> coling: ok
20:25:17 <ennael> about tests we need history and written results or it will be a mess
20:25:36 <ennael> so if you have proper hardware add information about tests on bugzilla
20:25:44 <tmb> coling: if you still have your copy of livecd image, you can test it
20:25:44 <anaselli> ennael: ok for the mail to dev, we will add our reports there
20:26:05 <Anssi> ennael: I don't have the hw (i.e. anything working with fglrx), so it is a bit difficult to test properly
20:26:08 <coling> tmb, Yup, still got it on USB stick. Can maybe try tomorrow.
20:26:13 <coling> (if he lets me!)
20:26:23 <guillomovitch> anaselli: you're taking care of it ?
20:26:26 <Anssi> tmb: I think you had fglrx, does it work with live isos properly now?
20:26:46 <anaselli> i can, i hope my mail is going to be read this time :)
20:26:49 <guillomovitch> #action anaselli asking in -dev for #5426
20:26:52 <ennael> ok
20:26:54 <guillomovitch> ok, next issue
20:26:57 <ennael> yep
20:27:02 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=4696
20:27:04 <anaselli> guillomovitch: can you point me bug number again thanks?
20:27:04 <erzulie> [ Bug 4696 - Install freeze after licence acceptation (system without floppy disk in the drive) (error I/O fd0) ]
20:27:05 <anaselli> ops
20:27:07 <anaselli> ok
20:27:20 <guillomovitch> according to tmb, it should be fixed also
20:27:21 <ennael> anaselli: 5426
20:27:52 <guillomovitch> we're needing original reporter output
20:27:59 <Bertl> I can test that :)
20:28:10 <ennael> thanks
20:28:18 <ennael> please close this bug if fixed
20:28:18 <guillomovitch> #action Bertl will test #4696
20:28:26 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=1812
20:28:28 <erzulie> [ Bug 1812 - Closing an "Advanced settings" window during live-install quits the installer without warning ]
20:28:58 <guillomovitch> there is no fix
20:29:12 <guillomovitch> and not any issue identification either
20:29:20 <guillomovitch> blino: ping ?
20:29:57 <blino> guillomovitch: didn't investigate this one yet, I did not manage to properly run a live system in a VM
20:30:37 <leuhmanu> ( anaselli: you can also add 5462 and blocker in your mail)
20:31:17 <anaselli> leuhmanu: 5462?
20:31:28 <guillomovitch> so, what shall we do ?
20:31:57 <Bertl> blino: what's the problem there?
20:32:03 <leuhmanu> ( anaselli bug 5462 and the blocker to this one, related to nvidia card)
20:32:07 <guillomovitch> reproducing the issue, I'd say
20:32:42 <leuhmanu> (it was missing in the release_clocker list)
20:32:43 <guillomovitch> is there anything we can do right now ?
20:33:11 <anaselli> ok leuhmanu, it seemed odd to me 5462 and 5426 :D
20:33:51 <guillomovitch> ok, let's hope we'll be more productive for other bugs
20:33:55 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5603
20:33:57 <erzulie> [ Bug 5603 - Mga 1->2 upgrade fails due to pm-utils problem ]
20:33:59 <guillomovitch> coling: this one for you
20:34:11 <coling> Right
20:34:41 <coling> I asked on the list and it seems OK to just do the obsolete. But I questioned that l-m-t was updated more recently than pm-utils.
20:35:09 <Luigi12_work> coling: I don't think anyone objected to dropping l-m-t
20:35:14 <coling> I wanted to know if this was just a "there is a newer version" update (i.e. without really using it) or if there was a real reason.
20:35:43 <coling> But as there has been no reply I guess we just nuke it and forget.
20:35:48 <guillomovitch> ok
20:35:49 <coling> I'll do that tonight.
20:35:55 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=4999
20:35:57 <erzulie> [ Bug 4999 - Mga2 Beta2 fails to boot fully into KDE ]
20:36:15 <a-865> what causes "urpmi error 9" after OK after selecting partitions to format? http://fm.no-ip.com/Tmp/Linux/Mdv/reportbug-m2b3.txt
20:36:18 * guillomovitch would say tan failure to boot kde is rather a solution than a problem
20:36:39 <Luigi12_work> coling: did you try asking dams directly?  He's the one that updated l-m-t last.
20:36:40 <ennael> mikala: ping ?
20:37:03 <coling> Luigi12_work, I think I CC'd him specifically in the mail.. (certainly I meant to)
20:37:05 <guillomovitch> this  seems to be a dsiplay issue
20:37:07 * Luigi12_work kicks guillomovitch
20:37:17 <guillomovitch> not really critical
20:37:33 <Luigi12_work> coling: maybe try IRC
20:37:59 <guillomovitch> coling: isn't it yet another prefdm/systemd issue ?
20:38:17 <coling> I don't think so in this case.
20:38:22 <guillomovitch> we have a workaround, tough
20:38:30 <coling> I thought that bug was about kwin being weird?
20:38:34 <guillomovitch> does anyone object to lowering it to 'high' priority
20:38:59 <barjac> guillomovitch: Fine by me - reporter
20:39:09 <ennael> great
20:39:31 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5593
20:39:33 <erzulie> [ Bug 5593 - Missing /boot/initrd.img after removal of old kernel version with drakconf ]
20:39:34 <guillomovitch> thanks
20:39:46 <coling> guillomovitch, I think the only way it could be systemd related is if it's a user permission problem (e.g. on /dev/dri/* devices), but I don't think that's an issue generally.
20:39:56 <barjac> guillomovitch: Maybe needs something in errata?
20:40:05 <Luigi12_work> isn't 5721 fixed now?
20:40:34 <coling> I think 5593 is likely fallout from earlier bugs
20:40:42 <guillomovitch> barjac: feel free to do so, but generally that's better when the problem is identified precisely
20:41:08 <guillomovitch> I've had such an issue too
20:41:08 <coling> I do still think there are some strange theme update script issues lurking around (one package creates .old files in /boot which can suck up needed space.
20:41:11 <guillomovitch> I fixed it manually
20:41:32 <guillomovitch> even if I never run drakconf
20:41:51 <guillomovitch> I think it is a transient cauldron -> cauldron update issue
20:41:55 <coling> Yeah it's not related to drakconf
20:42:07 <coling> I think it occurs when some bootspash scripts were run.
20:42:16 <coling> They replaced initrd.img symlink iwth a real file.
20:42:29 <coling> And then later other scripts, that expect it to be a symlink break.
20:42:51 <guillomovitch> according to one comment, it also occured during mga1 -> cauldron upgrade
20:42:55 <tmb> but if it pops up during a kernel update, it can hit us on security updates :/
20:43:15 <guillomovitch> we don't have any assignee here...
20:43:32 <coling> So I think now that the initrd.img symlink is no longer removed (that bit of the bug has been fixed) the other half will also no longer occur.
20:43:37 <guillomovitch> please someone volonteer for it
20:43:56 <coling> Also on the "theme update initrd" theme... I've noticed that during update we regenerate all initrds for new themes.
20:44:02 <coling> I'm really not sure that's a good idea.
20:44:15 <guillomovitch> who speaks english here :) ?
20:44:20 <guillomovitch> ...
20:44:33 <coling> i.e. if you install dracut, you'll be regenerating all previous initrds.
20:44:59 <coling> Assign it to me.
20:45:15 <coling> But only if someone comments on the "regenerate all initrds" thing :)
20:45:50 <guillomovitch> does '/me too' suit your desire :) ?
20:46:09 <coling> So you'll fix the scripts... Great :D
20:46:37 <guillomovitch> ok, next one
20:46:38 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5036
20:46:40 <erzulie> [ Bug 5036 - Recent ISOs cause boot failure on HP6830s notebook ]
20:46:47 <ennael> this one is fixed
20:46:54 <ennael> forgot to update it
20:47:06 <ennael> closing it now
20:47:14 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5404
20:47:16 <erzulie> [ Bug 5404 - Urpmi is not asking which enchant-dictionary mark to install ]
20:47:21 <a-865> "Can't call method 'traverse_tag' on an undefined value."
20:47:49 <ennael> Anssi: ?
20:49:29 <Anssi> probably an urpmi bug, but I fear I don't have the time to look at it in detail in time
20:49:30 <anaselli> leuhmanu: mail sent feel free to add comments, if i missed anything :)
20:50:02 <guillomovitch> Anssi: can we lower it to 'normal' ?
20:50:10 <guillomovitch> I really don't see anything critical here
20:50:39 <guillomovitch> I mean, that's just a missing dependency that can be installed manually later, right ?
20:51:17 <Anssi> guillomovitch: it is not a missing dependency, but an unwanted "locales-fi" and "voikko-fi" being installed when installing dictionary using software on a minimal system
20:51:40 <guillomovitch> ok, but is it really critical ?
20:51:42 <Anssi> guillomovitch: but well, I guess we could lower it to high or normal, as it doesn't really affect most installations, and we can ship an update to urpmi to fix it later
20:51:54 <guillomovitch> ok, switch to 'normal' then
20:52:01 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=3375
20:52:04 <erzulie> [ Bug 3375 - after hibernation system starts booting from scratch ]
20:52:06 <Anssi> (of course, we can't fix people who've already gotten locales-fi, but still)
20:52:26 <ennael> outch Anssi wants to fix people :)
20:52:30 <ennael> sorry
20:53:10 <coling> I've not tested hibernation specifically, but I did fix issues with dracut finding swaps on LVMs
20:53:25 <guillomovitch> so, we just need testing and feedback ?
20:53:45 <Bertl> I guess I can test the lvm/raid setups
20:53:48 <coling> I'll test on a VM
20:54:04 <guillomovitch> also, the reporter is speaking of ati-related issues
20:54:08 <leuhmanu> we have a least 4 bugs related to suspend
20:54:12 <coling> I've got about 5 vms with various different and weird LVM+filesystems setups.
20:54:20 <Bertl> okay
20:54:33 <guillomovitch> tmb is the assignee for this one
20:54:41 <guillomovitch> but he didn't provide any comment
20:54:43 <leuhmanu> one for gnome one for kde, and with both pm-suspend works but not the gui
20:55:00 <guillomovitch> maybe you should replace him as assignee here ?
20:55:09 <coling> Sure.
20:55:12 <guillomovitch> anyway, next bug
20:55:13 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=4772
20:55:16 <erzulie> [ Bug 4772 - boot hangs at 'Starting cpufreq (via systemctl)' ]
20:55:33 <Bertl> unrelated, but before I forget: I'm seeing a huge number of 'Schema' warnings on recent cauldron updates (gnome)
20:55:36 <guillomovitch> this one should probably get attached to systemd tracker,
20:55:50 <coling> I think it already is.
20:55:58 <guillomovitch> yes
20:56:19 <guillomovitch> so we already discussed it sligthly
20:56:45 <guillomovitch> that's the only one release blocker bug
20:56:53 <guillomovitch> among the 4 systemd issues
20:56:59 <coling> I'm pretty certain that issue is fixed, (I broke it again, but then I refixed it)... but reports suggest otherwise... I'm just not 100% convinced. Dave Hodges seems to have the same issue on the RC Live CD previews that I cannot reproduce either.
20:57:35 <guillomovitch> so, work in progress, right ?
20:57:43 <coling> That one yes.
20:57:49 <coling> The others are also pretty simple.
20:57:50 <Luigi12_work_> was there any discussion before I got here about what to do about chromium-browser?
20:58:04 <coling> The microcode one is not really systemd related anyway.
20:58:22 <guillomovitch> coling: so move it out of the tracker
20:58:25 <guillomovitch> Luigi12_work_: no
20:58:25 <coling> And the hwclock one is just waiting for comment about my request to push new e2fsprogs.
20:58:48 <guillomovitch> next bug
20:58:50 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=4948
20:58:52 <erzulie> [ Bug 4948 - check all missing packages ]
20:59:16 <guillomovitch> we need some update on this one from pterjan
20:59:29 <guillomovitch> #action ask pterjan about #4948
20:59:30 <tmb> that one should be fixed.
20:59:58 <tmb> pterjan run the check script ~2 days ago, and we fixed the missing one.
21:00:05 <tmb> *onse.
21:00:10 <tmb> *ones.
21:00:13 <coling> tmb, have you had a sec to look at the e2fsprogs thing (I can describe the problem if you like - save you reading up on the background)
21:00:15 <guillomovitch> so, it is safe to close it now ?
21:00:37 <tmb> guillomovitch: yep
21:00:56 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5192
21:00:58 <erzulie> [ Bug 5192 - keyboard layout not set correctly for LUKS passphrase ]
21:01:20 <guillomovitch> #action no need to ask pterjan about #4948
21:01:56 <coling> I've tried several times in qemu and VB to reproduce that error and I cannot.
21:02:11 <coling> I followed the exact steps the poster suggested and it was all fine.
21:02:18 <Bertl> might be already fixed or depends on some strange package selection, will try to recreate tonight or tomorrow
21:02:51 <guillomovitch> ok, next one
21:02:53 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5044
21:02:55 <erzulie> [ Bug 5044 - lilo failed commande introuvable .. sh ligne 0 erreur d'ecriture / broken pipe ]
21:02:57 <coling> If others could try and reproduce that would be good yeah. Thanks Bertl
21:03:49 <guillomovitch> there is a 'we should not' suggestion by pterjan
21:03:58 <guillomovitch> but nothing else
21:04:08 <guillomovitch> any comment on this one ?
21:04:23 <guillomovitch> I'm unfair, it's a recent comment from him
21:04:53 <guillomovitch> next one
21:04:57 <dwalluck> is there a kernel person around, tmb? ;) I am wondering about the nvidia issue.. sigh, I wish I know what changed, surely the kernel, I don't think the driver changed recently
21:04:59 <guillomovitch> everybody seems tired
21:05:09 <guillomovitch> dwalluck: we're one a meeting right now
21:05:19 <guillomovitch> please wait for it to be finished first
21:05:22 <Bertl> guillomovitch: regarding 5044, I think the issue is still there
21:05:26 <dwalluck> guillomovitch: my bad. please continue
21:05:36 <guillomovitch> Bertl: sure
21:05:43 <guillomovitch> I didn't said anything else
21:05:51 <guillomovitch> but apparently, pterjan is commited to it
21:05:57 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=2975
21:05:59 <erzulie> [ Bug 2975 - missing non-free firmware for some network cards ]
21:06:03 <guillomovitch> kernel issue for tmb
21:06:38 <guillomovitch> apparently, rather an installer issue
21:06:57 <guillomovitch> tmb: should we change the assignee to titi ?
21:07:59 <tmb> regarding 5044, it's fixed in svn
21:08:43 <tmb> and in drakx-kbd-mouse-x11-0.102-1.mga2
21:08:44 <guillomovitch> oh, we just need test and feedback then ?
21:08:52 <tmb> yep
21:08:59 <guillomovitch> cool
21:09:20 <guillomovitch> still 4 bugs to discuss...
21:09:22 <Bertl> great!
21:09:31 <guillomovitch> 2975 first ?
21:10:14 <tmb> 2975 should be fixed
21:10:50 <coling> Great. So 5672?
21:10:53 <guillomovitch> do we have some ways to mark bugs
21:11:01 <guillomovitch> as 'fix commited, need feedback' ?
21:11:15 <guillomovitch> NEEDINFO keyword ?
21:11:48 <tmb> for 5672, seems only Dave so far can reproduce
21:11:50 <guillomovitch> or 'waitin for next RC to be validated'
21:11:51 <coling> I guess that's the closest fit.
21:11:53 <coling> Re 5672: I tried to reproduce on VMs and on my spare machine here.. couldn't reproduce it.
21:12:35 <coling> I'll try on my laptop tonight when I next reboot.
21:12:58 <coling> So 5674? tmb did you say you had that one fixed?
21:13:04 <tmb> so I guess it's something we'll see more about when we release RC
21:13:15 <coling> tmb, yeah.
21:13:27 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5672
21:13:29 <erzulie> [ Bug 5672 - rc pre-release cd very slow to boot. ]
21:13:56 <coling> guillomovitch, already discussed :)
21:14:06 <ennael> yep
21:14:14 <guillomovitch> ouch, I'm too slow
21:14:21 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5674
21:14:22 <ennael> :)
21:14:23 <erzulie> [ Bug 5674 - reboot or shutdown hangs with either rc live cd or dvd. ]
21:14:32 <ennael> already discussed :)
21:14:40 <coling> ennael, no answer yet tho' :)
21:14:44 <coling> tmb, ?
21:14:54 <guillomovitch> 5672 and 5764 don't have any assigned
21:14:55 <coling> Or was your comment about that one?
21:14:57 <guillomovitch> assignee
21:15:11 <guillomovitch> only the default one
21:15:19 <tmb> coling: well, for 5674 and livecds, it's our special halt.local on livecds seems to work for halt. but reboot hangs (as it does not call halt.local afaik
21:15:19 * anaselli goes to bed...
21:15:30 <guillomovitch> good night
21:15:40 <ennael> what about this comment https://bugs.mageia.org/show_bug.cgi?id=5674#c11
21:15:42 <erzulie> [ Bug 5674 - reboot or shutdown hangs with either rc live cd or dvd. ]
21:15:43 <anaselli> good night
21:15:45 <coling> tmb, Ahh OK.
21:16:18 <coling> tmb, so maybe we should not rely on halt-local.service and instead write our own mageia-live-finished.service?
21:16:38 <coling> After all we can put in all the same things as halt-local.service but also make it trigger on reboot.
21:16:55 <coling> (that' said, i'm not sure why halt-local.service isn't called on reboot.
21:17:05 <coling> As AFAIUI, it should be.
21:17:36 <tmb> ok, I need to check if it does work here now after tweaked halt.local
21:17:43 <coling> Incidentally, on installed systems, we actually go back into the initrd to deal with late cleanup and unmounting tasks. Maybe we should consider the same for the live CDs?
21:18:06 <coling> (i.e. we switch root again back to the initrd)
21:18:31 <coling> But maybe that's too big a change right now (and I'm not really super happy with how it's handled right now anyway)
21:19:03 <guillomovitch> ok, last one
21:19:10 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5567
21:19:12 <erzulie> [ Bug 5567 - tg3 fails to initialize in installer (mdio bus probed / No PHY devices / Problem fetching invariants of chips, aborting) ]
21:19:31 * coling doesn't even understand the title of that one.
21:19:46 <guillomovitch> ETOOLONGTITLE
21:19:59 <coling> :)
21:19:59 <Bertl> tg3 is a network driver/card
21:20:01 <Luigi12_work_> doing them out of order is confusing
21:20:36 <guillomovitch> bugs ?
21:20:40 <Luigi12_work_> yep
21:20:51 <guillomovitch> I'm using bugzilla search result
21:21:05 <Luigi12_work_> jumping around in random order
21:21:29 <ennael> Luigi12_work_: wants to do it ?
21:21:36 <Luigi12_work_> ennael: I did it last week
21:21:39 <ennael> how many bugs remaining ?
21:21:46 <guillomovitch> that's the last one
21:21:50 <ennael> phew
21:22:01 <tmb> that one is problematic.. it's been discussed on lkml too .. for someone it helps to modprobe -r tg3 && modprobe  broadcom && modprobe tg3
21:22:06 <Luigi12_work_> the newest one is 5721, but that should be fixed as of today
21:23:48 <guillomovitch> tmb: is there anything to do for it ?
21:24:25 <tmb> well, I'm still monitoring some discussions, but no good solution yet
21:24:44 <guillomovitch> ok, we're close to the end
21:24:55 <coling> The end is nigh!
21:25:11 <guillomovitch> #info still 18 release blocker bugs
21:25:26 <Luigi12_work_> I think 5721 is fixed
21:25:33 <guillomovitch> #info approximatively 1/3 having a fix commited, and waiting feedback
21:25:47 <Luigi12_work_> oh :o)
21:26:13 <ennael> on isos side, we have postponed a bit RC release
21:26:26 <ennael> to include last fixes especially for upgrade
21:26:40 <guillomovitch> how much delay ?
21:26:43 <coling> ennael, tmb when will be the final resync?
21:26:46 <ennael> last set of isos will be built tonight for tests tomorrow
21:26:52 <guillomovitch> ouch
21:26:54 <ennael> coling: I did one just now
21:27:02 <guillomovitch> I need to fix the webserver package right now then
21:27:02 <coling> ennael, OK
21:27:03 <ennael> but we can do another one
21:27:09 <ennael> guillomovitch: yes please
21:27:13 <guillomovitch> argh
21:27:23 <guillomovitch> ok, can we close the meeting now ?
21:27:24 <ennael> we did not do any annoucement about precise date
21:27:25 <coling> OK, I'll do the pm-utils thing and a couple small other fixes in systemd.
21:27:37 <ennael> so final release should be also postponed
21:27:42 <ennael> to give enough time
21:27:51 <Luigi12_work_> we can pull in line with Fedora
21:28:07 <ennael> coling: are you doing it now ?
21:28:16 <coling> ennael, yup.
21:28:21 <Luigi12_work_> hope they don't overshadow us
21:28:23 <coling> Gimme 5 mins
21:28:25 <guillomovitch> ok, end of the meeting
21:28:28 <guillomovitch> #endmeeting