19:21:46 <ennael> #startmeeting
19:21:46 <Inigo_Montoya`> Meeting started Wed Apr 25 19:21:46 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:21:46 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:21:47 <erzulie> [ MeetBot - Debian Wiki ]
19:22:46 <sebsebseb> hi
19:22:49 <ennael> so again let focus on release  blocker bugs
19:23:10 <ennael> https://bugs.mageia.org/buglist.cgi?cmdtype=runnamed&namedcmd=release_blocker
19:23:12 <erzulie> [ Log in to Bugzilla ]
19:23:51 * coling doesn't get that link working...
19:24:14 <Luigi12_work> how about https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=release_blocker&sharer_id=69
19:24:16 <erzulie> [ Log in to Bugzilla ]
19:24:48 <ennael> argh sorry
19:25:00 <ennael> so need a volunteer for this one https://bugs.mageia.org/show_bug.cgi?id=5609
19:25:01 <erzulie> [ Bug 5609 - mgaonline cache invalidation fix should be pushed as an update ]
19:25:07 * coling has done it manually: https://bugs.mageia.org/buglist.cgi?priority=release_blocker&query_format=advanced&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED
19:26:57 <Luigi12_work> why didn't tv just build it for 1 in updates_testing and assign to qa?
19:27:33 <ennael> well that's not the question here
19:28:17 <ennael> ok I'll do it
19:28:19 <ennael> next one
19:28:41 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5603
19:28:43 <erzulie> [ Bug 5603 - Mga 1->2 upgrade fails due to pm-utils problem ]
19:28:53 <ennael> leuhmanu: around ?
19:29:30 <coling> Did tv faint on comment 3?
19:29:58 <ennael> looks like he missed hi keyboard :)
19:30:01 <ennael> his
19:30:07 <ennael> or felt asleep on it
19:30:48 <Luigi12_work> that's a weird one.  I had that problem on my sister's laptop on mdv2010.2->mga1, but then I think I just removed laptop-mode-utils and fixed it.
19:31:22 <coling> Hmm, /me doesn't have laptop-mode-tools installed... just pm-utils.
19:31:46 <Luigi12_work> this user should probably just uninstall laptop-mode-tools before the upgrade
19:31:57 <ennael> coincoin: any opinion on that one ?
19:32:26 <ennael> well we need ti take a decision. either there is a solution or we have to add this in errata
19:32:45 <coling> What does l-m-t actually do anyway?
19:33:04 <Luigi12_work> yes it'd be nice to just obsolete it if it doesn't do anything useful anymore
19:33:47 <coling> Hmm I can't even instll it here without removing upower...
19:34:14 <coling> (which also takes task-gnome-minimal and task-gnome away too)
19:34:16 <zezinho> yes , seems l-m-t should be dropped
19:35:32 <coling> OK, so I'll mail the list about this, and if all in agreement, I'll obsolete it.
19:36:02 <ennael> #action coincoin will mail -dev about laptop-mode-utils and if all in agreement it will be obsoleted
19:36:08 <coincoin> yes I agree
19:36:10 <coincoin> oops
19:36:11 <ennael> raaa
19:36:12 <coincoin> I agree too :)
19:36:14 <ennael> #undo
19:36:14 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Action object at 0x839264c>
19:36:23 <ennael> #action coling will mail -dev about laptop-mode-utils and if all in agreement it will be obsoleted
19:36:50 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5593
19:36:52 <erzulie> [ Bug 5593 - Missing /boot/initrd.img after removal of old kernel version with drakconf ]
19:39:40 <coling> I think I've seen similar problems, in the past but they've not hit me for ages... seems to be very sporadic and not reproducible (I'm not actually sure I've ever seen it on my laptop)
19:40:21 <Luigi12_work> I've never seen this problem, but I always uninstall old kernels with urpme, not drakconf.  This person says always reproducible?
19:40:47 <anaselli> coling: but do you use drakconf to remove old kernel?
19:41:07 <anaselli> i usually don't, just urpme
19:41:10 <coling> anaselli, no, but it shouldn't really make a difference (in theory)
19:41:27 * coling will try - he has an old kernel
19:41:38 <zezinho> I am running a fresh Live Beta 3 installed and updated, I just removed 3.3.2 with mcc, and no bug
19:41:39 <anaselli> well since it's sporadic as you say... it means sometimes we do something different ;)
19:42:02 <zezinho> So I am sure it is not  always reproducible
19:42:26 <Luigi12_work> if (rand() *17 < 2) system("rm -f /boot/initrd.img");   ?  :o)
19:43:04 <anaselli> lol
19:43:47 <zezinho> Maybe set this bug  as unconfirmed if no one else reproduces it?
19:45:04 <Luigi12_work> maybe we should ask for /etc/sysconfig/installkernel contents, as that could cause this probably
19:45:09 <coling> There was a bug in bootsplash where initrd.img symlink would be replaced with a file.
19:45:10 <Luigi12_work> if there's something weird in there
19:45:15 <coling> Maybe it was some hangover from that?
19:47:47 * coling has commented on the bug but I'd suggest it's not a release blocker... I don't think it's new (I'm sure when I saw it, it was on my mga1 box)
19:48:32 <anaselli> coling: as far as i'm concerned is not, we're talking about a kernel update and an old kernel removing...
19:48:50 <anaselli> so nothing that should prebvent an upgrade
19:48:55 <anaselli> or installation
19:49:04 <anaselli> i mean a new installation
19:49:06 <Luigi12_work> well, probably the first thing a lot of people do after upgrade is remove the mga1 kernel
19:49:17 <Luigi12_work> so if this problem was reproducible, it'd be a big issue, but I've never seen it
19:51:06 <ennael> ok so let remove it from release_blocker for now
19:51:27 * anaselli has commented as well
19:51:37 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5556
19:51:39 <erzulie> [ Bug 5556 - Need to add rpm-helper Requres(post/preun) automatically to packages containing systemd units. ]
19:51:45 <ennael> coling: some comment ?
19:51:56 <anaselli> if he can boot by choosing the right kernel, there's a workarounf
19:52:04 <anaselli> s/f/d
19:52:37 <coling> ennael, just reading the mails on the list.
19:52:49 <coling> ennael, this is really for uprmi and installer-based upgrades.
19:53:19 <coling> we need to ensure that rpm-helper is upgraded early in the transaction (i.e. before any packages that use it in %post/%preun are upgraded)
19:53:47 <coling> While we could add it to the priority updates list in urpmi, this wouldn't help in the installer
19:54:33 <coling> As doesn't deal with priority updates as the urpmi that is used is from the installer itself, not the one on the system.
19:55:46 <coling> So I don't really know how the automatic requires are added for e.g. perl modules etc., but I'm hoping that something similar can be done here?
19:55:56 <coling> pterjan could likely comment if he were here.
19:56:50 <coling> I don't really know more than that :(
19:58:06 <Luigi12_work> I have an idea, sort of
19:58:17 <Luigi12_work> just found a Requires ordering cycle that may cause a problem
19:58:28 <Luigi12_work> rpm requires rpm-helper which requires systemd-units which requires rpm
19:58:40 <Luigi12_work> so there's no guarantee of the install ordering I believe
19:58:48 <ennael> sorry I have to leave the meeting
19:58:52 <ennael> leaving chair
19:58:59 <ennael> #chair coling guillomovitch
19:58:59 <Inigo_Montoya`> Current chairs: coling ennael guillomovitch
19:59:10 <coling> ennael, no problem. All the best
19:59:24 <coling> Luigi12_work, that's not really a big problem
19:59:25 <anaselli> bye ennael
19:59:27 <boklm> systemd-units require rpm ?
19:59:49 <Luigi12_work> well maybe not, s/rpm/dbus/
20:00:00 <coling> Luigi12_work, for a fresh install, rpm-helper will be installed early on.
20:00:06 <Luigi12_work> coling: I think some of the helper script stuff won't work if systemd-units isn't installed
20:00:08 <anaselli> coling: how about providing rpm-helper update in mga1 to prevent the problem?
20:00:23 * anaselli shot in the dark :)
20:00:26 <coling> anaselli, it would help some but not everyone will do it.
20:01:00 <coling> Luigi12_work, true.
20:01:02 <anaselli> i can't see why? i mean official update....
20:01:29 <coling> anaselli, some people will upgrade from e.g. a fresh mga1 install (sans updates)
20:02:06 <anaselli> well in that case we can add an errata
20:02:23 <anaselli> who is going to update needs to have it
20:02:44 <anaselli> better a release note :)
20:02:46 <coling> Well yeah. And I suppose the worst case scenario here is that people who didn't do that will have to reenable/redisable some services.
20:03:01 <coling> So if we cannot find a solution, this is a reasonable fallback.
20:03:11 <coling> I'll still look into it if I can but otherwise this will do.
20:03:26 <boklm> why can't we make rpm require rpm-helper ?
20:03:30 <anaselli> i think who is going to upgrade, he does with an updated system for the most...
20:03:49 <coling> boklm, rpm is not necessarily updated early when using the installer to upgrade.
20:04:01 <boklm> ah
20:04:04 <coling> Yeah :s
20:04:38 <boklm> is there something updated first, when using the installer to upgrade, or is it random ?
20:05:04 <coling> boklm, I think TV said it did not do any priority updates first (like urpmi does)
20:06:16 <coling> But actually as Luigi said, we likely don't require systemd-units everywhere it's needed either... (we rely on it always being installed due to it being needed at a quite low level...
20:07:14 <coling> I'll keep looking into it tho'.
20:08:34 <boklm> ok
20:08:37 <coling> #action coling will discuss rpm-helper/systemd-units installation on upgrade issues with pterjan and tv
20:09:34 <Luigi12_work> next bug is https://bugs.mageia.org/show_bug.cgi?id=5426
20:09:36 <erzulie> [ Bug 5426 - Beta3 doesn't boot on ati graphics hardware ]
20:09:46 <coling> Yeah I htink that's the next biggue.
20:09:50 <coling> *biggie
20:10:04 <coling> Anssi thinks he won't be able to work on it much sadly.
20:10:26 <coling> I don't really know much about it, as I don't have that hardware (a colleague does but I can't really use that machine much)
20:11:01 <Luigi12_work> was it just machines that have onboard intel + ati card?
20:11:23 <leuhmanu> missed the meeting :/
20:13:00 <anaselli> coling: https://bugs.mageia.org/show_bug.cgi?id=5426#c40
20:13:01 <erzulie> [ Bug 5426 - Beta3 doesn't boot on ati graphics hardware ]
20:13:10 <anaselli> says he has also with ati alone
20:13:32 <anaselli> a friend of mine has intel+nvidia :/
20:13:57 <Luigi12_work> all of my machines are ATI, but all my mga2 testing has been VMs
20:13:59 <anaselli> for ati alone i can have a test in this pc
20:14:28 <anaselli> we can try the live to start or an USB disk :)
20:15:06 * coling has limited scope to test this bug and I'm not sure anyone else (maybe blino?) is here to discuss it so I think we'll just have to leave this for now.
20:15:17 <Luigi12_work> next bug is https://bugs.mageia.org/show_bug.cgi?id=5404
20:15:19 <erzulie> [ Bug 5404 - Urpmi is not asking which enchant-dictionary mark to install ]
20:16:54 <anaselli> blocker?
20:16:57 <leuhmanu> not a release blocker for me
20:17:43 <coling> I agree - it's annoying but not a blocker.
20:17:47 <Luigi12_work> want to move on?
20:18:25 <coling> Yup
20:18:33 <Luigi12_work> next is my favorite https://bugs.mageia.org/show_bug.cgi?id=5046
20:18:35 <erzulie> [ Bug 5046 - [Tracker] Security updates for Mageia 2 ]
20:18:47 <Luigi12_work> juancho is looking into a possible security issue in openarena, otherwise we're good
20:19:03 <Luigi12_work> so we can move on, next bug is https://bugs.mageia.org/show_bug.cgi?id=5044
20:19:05 <erzulie> [ Bug 5044 - lilo failed commande introuvable .. sh ligne 0 erreur d'ecriture / broken pipe ]
20:21:10 * coling doesn't speak French :D
20:21:24 * coling also doesn't use lilo
20:21:55 <pterjan> that's a simple bug, affecting people with raid 1 and clicking to configure X in the summary
20:22:03 <pterjan> before bootloader is configured
20:22:29 <pterjan> I suggested how to fix it in a comment but did not have time to work on it yet
20:23:06 <pterjan> (/boot on raid1)
20:23:22 <coling> pterjan, OK, so it's in hand?
20:23:52 <pterjan> if I get some time soon yes :)
20:24:20 <coling> Cool.
20:24:29 <Luigi12_work> next bug is https://bugs.mageia.org/show_bug.cgi?id=5036
20:24:31 <erzulie> [ Bug 5036 - Recent ISOs cause boot failure on HP6830s notebook ]
20:26:06 <anaselli> ATI related?
20:26:52 <leuhmanu> no
20:27:24 <coling> Seems like it's an issue with the partition setup that affects live boots.
20:27:28 <Luigi12_work> syslinux related?
20:27:48 * coling doesn't know exactly what the problem is, but I think it's related to dracut in some way?
20:28:30 <leuhmanu> tmb had a fix for the live + boot.iso so it's same we can fix bcd too no ?
20:29:38 <pterjan> i think it was supposed to be fixed before beta3
20:29:43 <pterjan> I did not check the isos
20:29:57 <coling> Yeah, probably need tmb to comment on that one.
20:30:38 <Luigi12_work> no tmb in the house.  Should we move on?
20:30:52 <anaselli> coling: add him in cc?
20:31:09 <anaselli> oops he is already
20:31:25 <Luigi12_work> yeah twice (he reads sysadmin-bugs too)
20:31:51 <anaselli> maybe we should ask for a comment :)
20:32:01 <Luigi12_work> good idea
20:33:46 <anaselli> coling: action for that?
20:34:48 <coling> #action Get tmb's input on #5036
20:34:59 <coling> Next bug?
20:35:09 <Luigi12_work> https://bugs.mageia.org/show_bug.cgi?id=5034
20:35:10 <erzulie> [ Bug 5034 - [TRACKER] Oxygen integration issues ]
20:35:33 <anaselli> https://bugs.mageia.org/show_bug.cgi?id=5272
20:35:35 <erzulie> [ Bug 5272 - drakconf.real crashed (object 9f3dcc0 is not really a GObject at /usr/sbin/drakconf.real) ]
20:36:04 <AL13N> (how many release blockers are there? it's already late in the meeting)
20:36:21 <Luigi12_work> 25 total
20:36:24 <coling> AL13N There are not too many more....
20:36:27 <AL13N> k
20:36:36 <coling> We probably don't need to discuss all in depth.
20:36:40 <AL13N> is there other topics besides this?
20:36:47 <Luigi12_work> we're only on the 10th one
20:36:52 <Luigi12_work> AL13N: no other topics
20:36:55 <AL13N> ok then
20:36:59 <AL13N> i guess we can proceed
20:37:27 <AL13N> just go a bit quick and have people who will take care of each bug one way or another
20:37:35 * coling also can't stay for too much longer... hence maybe quick discussions.
20:37:45 <Luigi12_work> sure, any comments on Oxygen?
20:37:46 <AL13N> max 2min/bug
20:38:35 <coling> I'd say the drakconf bug is not necessary a blocker.
20:38:51 <leuhmanu> only the 'missing icon' for me
20:39:23 <coling> OK so will you chase that up?
20:40:14 <anaselli> i think no blocker here i read quickly all of them
20:40:34 <anaselli> they are all open as normal :)
20:41:01 <leuhmanu> yes
20:42:12 <anaselli> so can we go on, or do we have otherr comments here?
20:42:35 <coling> Let's go on.
20:42:37 <Luigi12_work> next is wifi https://bugs.mageia.org/show_bug.cgi?id=5015
20:42:38 <erzulie> [ Bug 5015 - TRACKER: WLAN - WIFI not or badly working in cauldron ]
20:43:04 * anaselli hides... how many bugs here
20:43:10 * coling has working wifi. That's all I know. There are a few issues in there, but I've not read them all :s
20:43:59 <leuhmanu> not sure read all bugs in the trackers will help tonight
20:44:10 <anaselli> could we consider all of them have been opened as critical or blocker, or we should read them all now?
20:45:09 <Luigi12_work> thankfully next ones are not trackers
20:45:25 <coling> Yeah, I'm not sure it helps to discuss every bug here.
20:45:42 <coling> In terms of broad topics, I can say I've almost closed all the bugs on the systemd tracker :D
20:45:58 <anaselli> \o/
20:46:03 <coling> I added all the necessary support to drakxservices to work (mostly) with systemd.
20:46:13 <Luigi12_work> nice
20:46:18 <coling> The installer works in a kinda fake way so won't show all services, but it'll do for now.
20:46:25 <Luigi12_work> only other trackers besides systemd one are upgrade tracker and dracut tracker
20:46:26 <anaselli> coling: i will test it them :)
20:46:27 <coling> I've made plans for mga3 on how to handle it properly.
20:47:03 <anaselli> about wifi anyh of them prevent installation or upgrade?
20:47:06 <Luigi12_work> coling: I've had an idea for that for a while too, guess we can talk about it after mga2
20:47:25 <Luigi12_work> anaselli: doubtful
20:47:28 <coling> The dracut tracker is also quite small and I think one is invalid and the other is also OK (testing it now)
20:48:17 <anaselli> coling: i propose to send a remind to mailing list with the bloker bug link
20:48:34 <anaselli> and go on with a quicker look :)
20:48:58 <coling> anaselli, good plan
20:49:50 <coling> #action anaselli will send blocker reminder.
20:50:02 <anaselli> coling: :p
20:51:36 <Luigi12_work> want the next bug?
20:51:39 <coling> So considering that does anyone have any other blockers that need discussing here?
20:51:54 <AL13N> are there any big ones left?
20:51:55 <coling> I think https://bugs.mageia.org/show_bug.cgi?id=3921
20:51:57 <erzulie> [ Bug 3921 - %post fails to add xguest to /etc/ssh/denyusers if this file does not exist yet ]
20:52:00 <coling> is likely not new
20:52:31 <Luigi12_work> that's not on ennael's list
20:52:52 <coling> (and thus not a blocker - even if it does suck - we need a better system to manage this and I'd say adding it as a mga3 design task)
20:53:06 <coling> Hmm, it's marked as a blocker.
20:53:27 <coling> Oh ti's for mga1
20:53:27 <Luigi12_work> interesting
20:53:32 <Luigi12_work> heh
20:53:33 <coling> Told you it wasn't new :D
20:53:43 <Luigi12_work> next on ennael's list is https://bugs.mageia.org/show_bug.cgi?id=4999
20:53:45 <erzulie> [ Bug 4999 - Mga2 Beta2 fails to boot fully into KDE ]
20:54:05 <leuhmanu> it was also valid for mga2 iirc
20:54:55 <Luigi12_work> this one looks like nouveau + kdm + kwin + desktop effects enabled == bad
20:55:16 * anaselli has sent the reminder email
20:55:24 <coling> Has anyone spoken to upstream about this?
20:55:52 <coling> I forget the name of the main guy... Maarten I think...
20:56:10 <Luigi12_work> upstream for?
20:56:30 <coling> kwin
20:56:32 <coling> Martin Gräßlin
20:57:19 <coling> Worth giving him a shout here as he may have had the reports on other bugs. Perhaps someone can mail him?
20:57:29 <anaselli> noone asked for gnome install?
20:57:46 <anaselli> to understand if it is akde or hardware?
20:57:52 <anaselli> one
20:58:01 <coling> Good point.
20:58:03 <anaselli> he spoke about nouveau
20:58:20 * coling has to go in 2 mins :(
20:58:27 * guillomovitch is back
20:58:39 <coling> :)
20:58:41 <guillomovitch> I can relay you
20:58:49 <guillomovitch> but I didn't followed the discussion
20:59:12 <coling> guillomovitch, just discussing blocker bugs.
20:59:22 <Luigi12_work> coling: next bug is yours I think if you want to say a word before you go https://bugs.mageia.org/show_bug.cgi?id=4772
20:59:24 <erzulie> [ Bug 4772 - boot hangs at 'Starting cpufreq (via systemctl)' ]
20:59:27 * anaselli has addded his comment
20:59:31 <Luigi12_work> didn't you fix that one?
21:00:15 <coling> Luigi12_work, well, I thought I had but apparently it was inconclusive.... some work has been done to give a native unit to cpufreq, but the real problem may be deeper.
21:00:39 <coling> Luigi12_work, I suspect we;ll have to wait for the next round of installs during RC to get data.
21:01:06 <coling> But if you can reproduce, please try a net-install of current cauldron.
21:01:19 <Luigi12_work> coling: ok.  At least we know this one is cared for, as I've seen it being discussed.
21:01:29 <Luigi12_work> I have been doing net-installs for my upgrade tests
21:01:29 <coling> Yeah it's still on my radar.
21:01:54 <guillomovitch> the xguest one is really not a blocker
21:02:00 <guillomovitch> and is likely resolved
21:02:10 <Luigi12_work> yes guillomovitch it's not on ennael's list anyway
21:02:18 * coling had a bad list....
21:03:15 * coling has to leave. Sorry :( See you all later :)
21:03:18 <AL13N> whoa... i got quite a scare, someone mentioning my real name
21:03:25 <Luigi12_work> lol, yep
21:03:25 <coling> guillomovitch, you are now the chair :D
21:03:28 <AL13N> luckily it wasn't me
21:03:43 <Luigi12_work> we can move onto the next bug if people want to continue
21:03:44 <guillomovitch> wow, big responsability
21:04:01 <AL13N> how many still left?
21:04:02 <guillomovitch> yes, can you give the url
21:04:16 <Luigi12_work> 9 left
21:04:20 <guillomovitch> ouch
21:04:24 <Luigi12_work> yeah :o(
21:05:11 <anaselli> how many trackers?
21:05:18 <Luigi12_work> none, we talked about those
21:05:21 <Luigi12_work> we skipped ahead
21:05:41 <Luigi12_work> well I guess we didn't do the upgrade tracker
21:06:09 <anaselli> ok so which is the next? :)
21:06:13 <Luigi12_work> https://bugs.mageia.org/show_bug.cgi?id=4696
21:06:15 <erzulie> [ Bug 4696 - Install freeze after licence acceptation (system without floppy disk in the drive) (error I/O fd0) ]
21:06:55 <leuhmanu> should be ok with the fix of tmb, next one ! :)
21:07:09 <leuhmanu> (/me I don't know what is your list)
21:07:10 <AL13N> i was just gonna ask if it wasn't fixed
21:07:24 * guillomovitch note for next bug: start reading from last comment
21:07:36 <AL13N> good idea
21:07:37 <Luigi12_work> sounds like it might be fixed
21:07:41 <Luigi12_work> next is https://bugs.mageia.org/show_bug.cgi?id=4562
21:07:42 <erzulie> [ Bug 4562 - dracut uses udevadm info to detect LVM+RAID+BTRFS ]
21:08:00 <anaselli> here we should have coling :/
21:08:07 <Luigi12_work> indeed
21:08:12 <AL13N> coling 'll take care of it
21:08:17 <AL13N> next
21:08:21 <Luigi12_work> https://bugs.mageia.org/show_bug.cgi?id=4357
21:08:23 <erzulie> [ Bug 4357 - [debloat] consider moving Suggests: seahorse to task-gnome ]
21:08:35 <AL13N> oi, this was a major discussion
21:08:38 <guillomovitch> that has been resolved
21:08:42 <Luigi12_work> I rememver that on -dev list, isn't it done?
21:08:46 <guillomovitch> at least temporary
21:08:54 <guillomovitch> the suggest move was refused
21:08:58 <guillomovitch> I'll close it
21:09:01 <guillomovitch> myself
21:09:04 <guillomovitch> next one please
21:09:07 <Luigi12_work> ok, https://bugs.mageia.org/show_bug.cgi?id=4301
21:09:09 <erzulie> [ Bug 4301 - Migration of module-init-tools to kmod lib in Mageia 2 - specifications ]
21:09:23 <anaselli> great guillomovitch we should have started with you :D
21:09:32 <AL13N> yes, he's much faster
21:09:39 <guillomovitch> arf :)
21:09:49 <guillomovitch> worksforme / next one
21:09:51 <Luigi12_work> didn't we already migrate to kmod?
21:09:54 <Luigi12_work> ok https://bugs.mageia.org/show_bug.cgi?id=4300
21:09:56 <erzulie> [ Bug 4300 - General artwork in Mageia 2 - specifications ]
21:09:59 <Luigi12_work> we are not artwork team...
21:10:10 <anaselli> tracker...
21:10:13 <Luigi12_work> oops
21:10:16 <Luigi12_work> next?
21:10:18 <AL13N> tmb 'll look after it
21:10:26 <leuhmanu> and not really blocker inside
21:10:41 <guillomovitch> they are 7 linked bugs
21:11:28 <anaselli> and a blocks one
21:11:30 <AL13N> i think artwork team 'll take care of this on their own, no? who's the artwork team leader? perhaps we can let him know
21:11:35 <anaselli> that is a tracker
21:11:48 <guillomovitch> but it mix enhancements proposals
21:11:52 <AL13N> i mean, so that the artwork leader can follow it up
21:11:56 <guillomovitch> and other issues
21:11:57 <Luigi12_work> yes, sorry I missed that tracker, it wasn't labeled
21:12:11 <guillomovitch> Luigi12_work: can you relabel it then ?
21:12:17 <Luigi12_work> sure...
21:12:19 <guillomovitch> in order to not miss it next time
21:12:45 <Luigi12_work> done
21:12:45 <AL13N> so, next?
21:12:48 <Luigi12_work> https://bugs.mageia.org/show_bug.cgi?id=4299
21:12:49 <erzulie> [ Bug 4299 - syslinux, gfxboot in Mageia 2 ]
21:12:51 <leuhmanu> (that's why Magbot read the keyword :D)
21:13:07 <anaselli> guillomovitch: but the point is if none of them are really blocker should the tracker be?
21:13:08 <AL13N> again
21:13:23 <guillomovitch> anaselli: no, indeed
21:13:28 <Luigi12_work> isn't ennael working behind the scenes on 4299?
21:13:40 <AL13N> it's a tracker again
21:13:50 <Luigi12_work> ouch :o(
21:14:05 <AL13N> but i assume it's blocker so that when all the others are done they can be evaluated and moved to mga3 or something
21:14:15 <AL13N> just go next again
21:14:16 <Luigi12_work> I think the thing with trackers is the idea is you don't have to mark the bugs inside as blockers, but they are considered as until we decide to cut bait on them
21:14:21 <Luigi12_work> ok, next is https://bugs.mageia.org/show_bug.cgi?id=3919
21:14:23 <erzulie> [ Bug 3919 - indexhtml's %post script reads /etc/product.id, but does not require this file b/c of bogus requires ]
21:14:50 <AL13N> :maint indexhtml
21:14:51 <leuhmanu> yes it was the idea, for the next time we will make that more readable, I hope)
21:14:53 <Sophie> AL13N: For Mageia (indexhtml): nobody
21:14:55 <guillomovitch> wait wait
21:15:08 <guillomovitch> what's the final decision about 4299?
21:15:55 <guillomovitch> still 4 bugs
21:16:03 <guillomovitch> one of them at least quite painful
21:16:20 <guillomovitch> 5263
21:16:32 <Luigi12_work> oh, are they all even related to syslinux?
21:16:45 <leuhmanu> or gfxboot
21:17:36 <guillomovitch> we need someone to enquire there
21:17:39 <AL13N> (imho 5263 is just a packaging bug, it should be assigned to rda, so he can fix the wrong requires)
21:18:03 <Luigi12_work> 3919 is assigned to rda too
21:18:03 <pterjan> anyone can fix it
21:18:04 <guillomovitch> kernel issue, packaging bug ?
21:18:14 <guillomovitch> you're discussing 3919 here
21:18:17 <anaselli> 5263 seems to have a workaround https://bugs.mageia.org/show_bug.cgi?id=5263#c6
21:18:18 <guillomovitch> not 5263
21:18:19 <erzulie> [ Bug 5263 - Pressing f2-f6 to change kernel options also moves selection from boot to install ]
21:18:35 <guillomovitch> a workaround, but with already 2 duplicates
21:18:43 <guillomovitch> seems quite heavy impact
21:18:52 <leuhmanu> well move the cursor works :)
21:19:09 <pterjan> for 5263 we need a syslinux expert
21:19:21 <AL13N> guillomovitch: why is it assigned to erwan? didn't he stop?
21:19:30 <guillomovitch> no idea
21:19:36 <pterjan> no idea
21:19:39 <AL13N> https://bugs.mageia.org/show_bug.cgi?id=2038
21:19:41 <erzulie> [ Bug 2038 - Can't select option to install (key f2-6) ]
21:19:44 <guillomovitch> we can ask him, at least, a status
21:19:46 <AL13N> no comment from him either
21:19:51 <guillomovitch> for those 4 linked bugs
21:20:12 <Luigi12_work> yes I thought ennael was asking erwan for help with those ones
21:20:13 <guillomovitch> #action: ask erwan status and propsals for 4299
21:20:22 <guillomovitch> is that the correct syntax ?
21:20:23 <AL13N> https://bugs.mageia.org/show_bug.cgi?id=44
21:20:25 <erzulie> [ Bug 44 - slow OS under VirtualBox due to HZ=1000 (was mkinitrd fails in VB) ]
21:20:26 * guillomovitch is a new chair
21:20:35 <guillomovitch> #help
21:20:36 <AL13N> guillomovitch: i think no
21:20:41 <AL13N> guillomovitch: no :
21:20:53 <AL13N> i thin #action <person> stuff
21:21:09 <coincoin> yep
21:21:21 <guillomovitch> #action ennael ask erwan status and proposals for 4299
21:21:27 <AL13N> :-)
21:21:36 <AL13N> roflmao
21:21:52 <Luigi12_work> pretty sure she had already said she would do that though, so that should be ok
21:22:05 <guillomovitch> #youdirtypieceofjunkgivemehelp
21:22:12 <anaselli> silly question, should virtualbox installation really blocker?
21:22:16 <Luigi12_work> Inigo_Montoya`: help guillomovitch
21:22:16 <Inigo_Montoya`> Luigi12_work: Error: There is no command "guillomovitch".
21:22:29 <AL13N> :-)
21:22:38 <guillomovitch> anaselli: not for me
21:22:44 <guillomovitch> is only virtualbox is affected
21:22:47 <Bertl> Inigo_Montoya`: help #action
21:22:47 <Inigo_Montoya`> Bertl: Error: There is no command "#action".
21:22:51 <AL13N> next one
21:22:52 <AL13N> (imho 5263 is just a packaging bug, it should be assigned to rda, so he can fix the wrong requires)
21:22:59 <AL13N> next url
21:23:00 <guillomovitch> yes, please
21:23:01 <Luigi12_work> https://bugs.mageia.org/show_bug.cgi?id=3919 was the next one
21:23:02 <erzulie> [ Bug 3919 - indexhtml's %post script reads /etc/product.id, but does not require this file b/c of bogus requires ]
21:23:13 <AL13N> yeah, i meant that on
21:23:15 <guillomovitch> this one is the packaging bug
21:23:18 <AL13N> assign to rda
21:23:24 <AL13N> let him fix it
21:23:29 <AL13N> it's his code
21:23:35 <Luigi12_work> maybe someone should ping him?
21:23:38 <AL13N> he should really be maintainer
21:23:47 <pterjan> why?
21:23:50 <guillomovitch> AL13N: you're taking care of affecting the bug to him ?
21:24:02 <AL13N> assigning it and pinging?
21:24:03 <AL13N> sure
21:24:06 <guillomovitch> pterjan seems to be volonteer also :)
21:24:20 <pterjan> do we ask artwork team to package their stuff ?
21:24:34 <guillomovitch> if only yhey could finish it...
21:24:46 <guillomovitch> I'd be glad to do the packaging stuff
21:24:59 <coincoin> rda is off for 2 weeks
21:25:01 <coincoin> so...
21:25:20 <AL13N> really
21:25:22 <AL13N> ah
21:25:29 <AL13N> coincoin: who will fix it then?
21:25:35 <guillomovitch> I can do it
21:25:37 <guillomovitch> next one
21:25:39 <AL13N> k
21:25:40 <Luigi12_work> https://bugs.mageia.org/show_bug.cgi?id=3375
21:25:41 <erzulie> [ Bug 3375 - after hibernation system starts booting from scratch ]
21:25:43 <coincoin> AL13N: :)
21:26:15 <guillomovitch> According to latest comment, it works now
21:26:17 <AL13N> pterjan: (well rda is a packager too, artwork isn't, plus as maintainer you get to solve your bugs)
21:26:51 <Luigi12_work> ok, next one is the upgrade tracker, skipping that one for a second, last regular bug is https://bugs.mageia.org/show_bug.cgi?id=1812
21:26:53 <erzulie> [ Bug 1812 - Closing an "Advanced settings" window during live-install quits the installer without warning ]
21:27:00 <guillomovitch> someone just has to either close
21:27:06 <guillomovitch> or ask the reporter if we canclose it
21:27:07 <coincoin> AL13N: I'm not sure rda is a packager ;)
21:27:18 <guillomovitch> I don't know how the bug squad handles it usually
21:27:26 <guillomovitch> for the hibernantion bug
21:27:30 <AL13N> coincoin: :-)
21:27:36 <Luigi12_work> leuhmanu: still around?
21:27:37 <pterjan> guillomovitch: not from the original reporter
21:27:39 <Bertl> I can test the hibernation with lvm setup with and without encryption
21:27:49 <pterjan> we should ping him
21:27:52 <guillomovitch> pterjan: his original issue seems to be fixed
21:27:56 <AL13N> Bertl: can you test and close if fixed?
21:28:09 <guillomovitch> he just has another slight issue with network activation
21:28:23 <AL13N> he can open another bug, no?
21:28:31 <Bertl> well, I can at least test, but not close as it is for a different system than I have
21:28:46 <guillomovitch> I'd rather have somone ask him if that's ok to close this bug
21:28:46 <pterjan> guillomovitch: this is not the original reporter (Kamil)
21:28:52 <guillomovitch> ah, ok
21:29:16 <AL13N> i think bugsquad closes it with note that if it's not fixed it needs to be reopened
21:29:18 <guillomovitch> so Kamil's input is needed too
21:29:23 <guillomovitch> before closing it
21:29:32 <guillomovitch> can someone handles this one until definitive closure ?
21:29:33 <AL13N> (mostly they give them 2 weeks to do so)
21:29:33 <guillomovitch> please
21:29:51 <pterjan> I added a comment
21:29:53 <Bertl> btw, we seem to have a bunch of (potential) kernel issues
21:29:56 <guillomovitch> thanks
21:30:08 <guillomovitch> next one: 1812
21:30:19 <Luigi12_work> Bertl: I always assume tmb will take care of kernel issues :o)
21:30:32 <Luigi12_work> yes, any comments on 1812?
21:31:08 <guillomovitch> blino seems to be on it
21:31:15 <Luigi12_work> ok
21:31:26 <Luigi12_work> all we have left is the upgrade tracker https://bugs.mageia.org/show_bug.cgi?id=3342
21:31:27 <erzulie> [ Bug 3342 - [Tracker] Upgrade Mga 1 > Mga 2 ]
21:32:22 <guillomovitch> wasn't 5556 already discussed ?
21:32:28 <Bertl> one thing which comes to my mind in this regard is the ssh(d) upgrade
21:32:36 <Luigi12_work> guillomovitch: yes 5556 was discussed earlier
21:33:02 <guillomovitch> coling: stop pretending you're away, while posting to -dev :P
21:33:09 <Luigi12_work> lol
21:33:17 <Bertl> with the new denyusers setting, certain folks might end up with a broken system
21:33:44 <guillomovitch> which denyusers setting ?
21:34:02 * coling is 90% away.
21:34:15 <Bertl> well, before the sshd update, you could enable root login e.g. with password or key
21:34:44 <Bertl> now you need to remove 'root' from denyusers (which is added by default unconditionally)
21:35:06 <guillomovitch> which bug id ?
21:35:30 <Bertl> not sure we already have one
21:35:40 <AL13N> Bertl: so, perhaps it should not get added unconditinally?
21:35:53 <AL13N> Bertl: if not, please file it
21:36:07 <Bertl> I'll do some testing and file a bug report
21:36:11 <guillomovitch> back to the upgrade tracker
21:36:13 <guillomovitch> Bertl: thanks
21:36:22 <guillomovitch> a quick examination
21:36:24 <guillomovitch> 1 systemd issue
21:36:28 <guillomovitch> 2 KDE issues
21:36:34 <guillomovitch> 2 libification issuse
21:36:58 <AL13N> Bertl: better file it quick and add it to the upgrade tracker :-)
21:37:05 <Bertl> and probably about 50 gnome issues :)
21:37:24 <Luigi12_work> mikala is working on the 2 KDE issues to the extent that he can
21:37:27 <guillomovitch> they are only seven
21:37:28 <Bertl> but systemd is really down to 1?
21:37:38 <guillomovitch> in this specific upgrade tracker, yes
21:37:49 <AL13N> hmm...
21:38:00 <AL13N> i'll do another test with upgrade myself i think
21:38:08 <AL13N> add some more release_blockers
21:38:13 * anaselli can't go on... morpheus is calling him
21:38:14 <Luigi12_work> I did another upgrade test yesterday and hope to do one tomorrow
21:38:29 <Bertl> interesting ... especially as installation from scratch doesn't work on 9 of 10 machines and usually it is either firmware or system related (or both)
21:38:33 <Luigi12_work> and hopefully one this weekend too
21:38:40 <Bertl> *systemd
21:38:55 <AL13N> well, alot of systemd was fixed in the last weeks
21:38:59 <guillomovitch> the only blocker one is the systemd one
21:39:03 <AL13N> i'll give it the benefit of the doubt
21:39:07 <guillomovitch> which has already been discussed
21:39:13 <AL13N> ok then
21:39:19 <AL13N> perhaps we can close the meeting too
21:39:22 <guillomovitch> so, I'd lower the severity of this tracker to normal
21:39:29 <Bertl> for upgrade, we presume it is the latest mageia 1, yes?
21:39:42 <AL13N> Bertl: only mga1 > mga2 is supported
21:39:53 <Luigi12_work> I think he means with all updates applied
21:39:58 <Bertl> yes
21:40:03 <AL13N> i don't think we can guarantee that
21:40:03 <guillomovitch> that's not mandatory
21:40:11 <leuhmanu> ( Luigi12_work again here )
21:40:11 <Bertl> so, mag1 cd install, no updates should work as well, right?
21:40:22 <AL13N> hmm
21:40:30 <AL13N> Bertl: that's a pretty interesting pov
21:40:40 <AL13N> one that could be tested
21:40:53 <guillomovitch> no
21:40:58 <guillomovitch> the point is just:
21:41:09 <Luigi12_work> leuhmanu: there were some questions about the proper procedure for closing bug 3375 and how that should be handled
21:41:19 <guillomovitch> any upgrade from mag1 to mga2 should work smoothly
21:41:30 <guillomovitch> everything else is left to maintainer decision
21:41:38 <AL13N> ok
21:42:08 <leuhmanu> Luigi12_work: I don't know there is many bug related to supend, hibernation etc
21:42:08 <guillomovitch> no
21:42:11 <Luigi12_work> wasn't mdv's policy "we assume you have all updates applied" ?
21:42:16 <Bertl> yeah, but my guess is somebody upgrading from mag1 -> mag2 either has kept the mag1 up to date or not updated at all
21:42:18 <guillomovitch> I don't think so
21:42:25 <guillomovitch> anyway
21:42:31 <guillomovitch> is that a real issue right now ?
21:42:38 <Luigi12_work> not for the meeting
21:42:58 <guillomovitch> #action coling give status on 5556, and lower tracker 3342 severity once this one fixed
21:42:59 <Bertl> it's important for testing, IMHO
21:43:24 <Bertl> i.e. no need to test mag1 (no updates) upgrade if it isn't officially supported
21:43:24 <guillomovitch> I don't htink there is an established policy in this regard
21:43:35 <guillomovitch> that's not truc
21:43:40 <guillomovitch> true
21:43:45 <leuhmanu> Bertl: you need at least the last urpmi...
21:43:48 <guillomovitch> anyway, we finished the list of current blockers ?
21:43:53 <Luigi12_work> guillomovitch: yes
21:44:07 <guillomovitch> we do have people in charge of at least giving status
21:44:11 <guillomovitch> for each of them ?
21:44:51 <guillomovitch> I hope so...
21:44:59 <guillomovitch> can we close the meeting ?
21:45:16 <Luigi12_work> ok by me
21:45:26 <guillomovitch> any other survivor :) ?
21:45:30 * pterjan died
21:45:32 <AL13N> k
21:45:38 <Bertl> fine by me
21:45:42 <guillomovitch> congratulations for those present since the beginning
21:45:44 <AL13N> guillomovitch: do you even know how to close?
21:45:44 <guillomovitch> #close
21:45:49 <AL13N> loooooooooool
21:45:51 <guillomovitch> something similar ?
21:45:53 <Luigi12_work> #closemeeting ?
21:45:53 <AL13N> #endmeeting
21:45:55 <anaselli> good night all
21:45:59 <Luigi12_work> uh oh
21:46:00 <guillomovitch> #endmeeting