19:14:59 <ennael> #startmeeting
19:14:59 <Inigo_Montoya> Meeting started Wed Apr 18 19:14:59 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:14:59 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:15:01 <erzulie> [ MeetBot - Debian Wiki ]
19:15:05 <ennael> #chair boklm guillomovitch
19:15:05 <Inigo_Montoya> Current chairs: boklm ennael guillomovitch
19:15:57 <ennael> ok
19:16:04 <ennael> so we did it!
19:16:10 <coling> We did?
19:16:14 <ennael> beta 3 is out
19:16:17 <coling> \o/
19:16:23 <remmy> Yay :)
19:16:30 <ennael> still have to post on ML but blog is up
19:17:07 <ennael> special thanks to tmb, oliver, coling and blino
19:17:15 <rindolf> Is there a LiveCD?
19:17:15 <remmy> Thanks team
19:17:19 <ennael> that was quite hard time with live cds
19:17:27 <ennael> we have DVDs, dual and lives
19:17:38 <coling> That's awesome well done everyone :)
19:17:44 <rindolf> Thanks everybody.
19:18:00 <ennael> still some work to be done on lives about content but basically it's ok
19:18:30 <ennael> we will have to speak for real after mageia 2 is out about the media we want to have
19:18:32 * sebsebseb looks forward to trying out Live CD's :) later on some time
19:18:48 <ennael> to avoid multiplying isos
19:18:54 <coling> Yeah I was about to mention that but it's a post-mga2 topic really :)
19:19:00 <ennael> yep :)
19:19:25 <ennael> #info need to fix a list of media to be kept after mageia 2 is out
19:20:08 <ennael> #topic review of release blocker bugs
19:20:19 <ennael> coling: review about systemd ?
19:20:49 <coling> ennael, well I think there may still be the "cpufreq" bug, but I can't reproduce it myself. I really need more data on that one.
19:21:07 <coling> https://bugs.mageia.org/show_bug.cgi?id=4772
19:21:09 <erzulie> [ Bug 4772 - boot hangs at 'Starting cpufreq (via systemctl)' ]
19:21:29 <coling> I suspect it only happens on real laptops. Certainly none of my VM installs triggered any problems.
19:22:04 <coling> If someone can reproduce this, then if they could make their first boot with "systemd.log_level=debug systemd.log_target=kmsg" on the command line.
19:22:24 <ennael> leuhmanu: could we ping the guys who did report that pb
19:22:25 <ennael> ?
19:22:27 <ennael> on -dev
19:22:37 <ennael> and make them focus on this
19:22:57 <ennael> coling: could you also give information you need to work on this ?
19:23:06 <leuhmanu> ping the reporter on -dev ?
19:23:19 <coling> Yup, I'll comment on the bug.
19:23:43 <coling> Other than that, there are only two things on my radar: LSB scripts and drakxservices support.
19:23:54 <ennael> or in bug but maybe asking on ML will give us more guys to help on this
19:24:02 <ennael> ok
19:24:02 <coling> ennael, cool.
19:24:15 <ennael> guillomovitch: can you help on LSB scripts
19:24:23 <guillomovitch> I can
19:24:30 <coling> LSB scripts are easy enough to do, and I'll work on updating the wiki page guillomovitch mentioned tonight.
19:24:35 <ennael> maybe ask more people for this
19:24:48 <coling> Then hopefully we can just get every packager to do two packages :)
19:24:59 <coling> Then ask for another two after that if we're not done.
19:25:03 <coling> :)
19:25:06 <remmy> I have that problem on my notebook, I can test on saturday
19:25:08 <ennael> #action #4772 coling will ask for more info, mail on -dev to ask help on people having same issue
19:25:16 <ennael> remmy: great
19:25:40 <ennael> #action finalize LSB scripts migration with help of guillomovitch
19:25:54 <ennael> #action coling will work on drakxservices migration
19:26:15 <coling> And as for the drakxservices thing, despite my crappy perl skills I should be able to hack on that before rc
19:26:21 <ennael> :)
19:26:27 <coling> brb
19:26:31 <guillomovitch> ennael: well, that's not rather LSB scripts migration
19:26:36 <guillomovitch> that's systemd migration
19:26:54 <guillomovitch> ensuring non-systemd migrated package have LSB initscrcipts ass fallback
19:26:56 <ennael> yep sorry that was a crappy shorcut
19:26:56 <pterjan> well not really, it also improves for people using pinit :P
19:27:02 <ennael> :)
19:27:21 <ennael> coling: I guess pterjan  may help on perl for drakxservices :)
19:27:35 <rindolf> ennael: I can try helping too.
19:27:46 <ennael> well just see with coling about this
19:27:51 <rindolf> When I'm not at work.
19:27:52 <rindolf> OK.
19:28:12 <tmb> and we have our perl_checker tv, that probably will comment on commits :)
19:28:19 <ennael> :)
19:28:22 <ennael> hi tmb :)
19:28:36 <coling> tmb, Yup I've no doubt :)
19:28:39 <ennael> we still have to close some discussions to close release blocker bugs
19:28:48 <coling> (awesome work btw tmb :))
19:29:04 <ennael> guillomovitch: any progress on the mail you sent on -dev ?
19:29:14 <guillomovitch> not much, actually
19:29:25 <ennael> shall we cut this and take decision here ?
19:29:25 <tmb> wich one ?
19:29:28 <guillomovitch> everyone basically stated on his position
19:29:33 <guillomovitch> tmb: debloatin
19:29:43 <guillomovitch> basically, everyone considers
19:29:53 <guillomovitch> installing as 'running the installer' only scenario
19:30:08 <guillomovitch> so, everyone focuses on rpmsrate issue
19:30:40 <guillomovitch> the infamous KDE/totem relationship
19:30:53 <guillomovitch> just dropping it should leverage part of the problem
19:31:14 <ennael> dropping ,
19:31:15 <ennael> ?
19:31:16 * pterjan silently stated his position: does not care about kde /o\
19:31:27 <ennael> kind of position :)
19:31:47 <guillomovitch> pterjan: mine is 'does not care about the installer' :)
19:31:57 <guillomovitch> ennael: well, ensuring people installing a kde dekstop
19:32:17 <guillomovitch> won't have also gnome installed just because someone thought they'll need totem also
19:32:27 <guillomovitch> which is my current understanding of the problem
19:32:37 <ennael> as I said totem install was quite historic one
19:32:56 <ennael> to have codecs management apps working on all desktop
19:32:59 <ennael> this comes from mdv
19:33:03 <ennael> codeina
19:33:06 <guillomovitch> so, is this still useful ?
19:33:13 <ennael> because at that moment we had a contract
19:33:24 <guillomovitch> I couldn't understand this precise question
19:33:34 <Luigi12_work> totem has already been removed from rpmsrate for kde last I checked
19:33:46 <ennael> so no more reason imho
19:33:48 <guillomovitch> so, the problem should be 80% fixed
19:33:54 <ennael> yep I think so
19:34:02 <guillomovitch> cool
19:34:05 <ennael> now what is left ?
19:34:14 <guillomovitch> the other bug that could be closed quite fast
19:34:31 <guillomovitch> is the infamous 'we can't ship gnome 3 because sometimes we need proprietary drivers"
19:34:35 <ennael> oh yes
19:34:46 <ennael> https://bugs.mageia.org/show_bug.cgi?id=3774
19:34:48 <erzulie> [ Bug 3774 - GNOME3 on free DVD? (requires non-free drivers) ]
19:34:52 <guillomovitch> just tell you don't care about free software, and this one is closed too
19:35:01 <ennael> #action totem is no more installed in default KDE
19:35:06 <ennael> :)
19:35:13 <guillomovitch> or rather, this is a corner case
19:35:28 <tmb> well, speaking generally with my "livecd hat" on, every doc and handbook stuff need to be broken out of main packages if not already done, and only suggests to pull them in
19:35:29 <guillomovitch> which doesn't make gnome3 useless anywhere
19:35:54 <mitya> is this an ATI only problem? GNOME 3 runs with Nouveau almost perfectly
19:35:58 <mitya> *AMD
19:36:06 <ennael> pterjan: you are GNOME user ? :)
19:36:08 <Luigi12_work> plus there's always fallback mode, so who cares?
19:36:10 <guillomovitch> and with intel too
19:36:13 <guillomovitch> and and and...
19:36:27 <pterjan> ennael: not on Mageia
19:36:42 <tmb> as for the 3774, it should be closed as wontfix as amd/ati has no problem either on running Gnome3
19:36:43 <guillomovitch> the point is: as long as it is not useless everywhere
19:36:46 <guillomovitch> we can ship it
19:36:56 <remmy> There was no more room on the Gnome CD for the bigfoot logo.
19:37:18 * pterjan happy with fallback mode
19:37:45 <ennael> it's really usable
19:38:04 <guillomovitch> usable is a subjective point
19:38:32 <guillomovitch> let's make the charge to prove it is not usable to the other party
19:38:47 <pterjan> well for my use of gnome, fallback mode is perfect and light :)
19:39:05 <ennael> guillomovitch: want to post to ask for it?
19:39:09 <tmb> most free drivers work with GNOME, and for those that it does not, they can install nonfree drivers after, or use LiveCDs
19:39:38 <guillomovitch> ennael: no, I don't
19:39:49 <guillomovitch> I already commented the bug on bugzilla
19:40:00 <guillomovitch> I just have additional 'it works for me too'
19:40:13 * pterjan volunteers to close it with a comment
19:40:15 <blino> Gnome3 is unusable for me on a Core 2 Duo with integrated Intel graphics :/
19:40:19 <sebsebseb> in my expereince with Gnome Shell, I have always needed the propritary Nivida driver to run it properly in distros I have used it in
19:40:43 <coling> blino, that's my setup, (945GMA) Works fine here.
19:40:54 <guillomovitch> works for me here too
19:41:01 * coling has been running GS on that h/w for ages.
19:41:09 <blino> coling: IIRC, that's a Q57
19:41:18 * coling can't recall.
19:42:24 <ennael> pterjan: can you close it ?
19:42:32 <pterjan> ok
19:43:35 <sebsebseb> this is from a user point of view, but I think the free software only DVD's/CD's shoudn't have the propritary NIvida driver, because it's not freesoftware, and the other Live CD's should be able to detect computers that have it and then automatically enable it I think.
19:44:12 <tmb> sebsebseb: that's already the case
19:45:12 <guillomovitch> we still have quite a bunch of security issues, tough
19:45:14 <ennael> pterjan: can you have a look here https://bugs.mageia.org/show_bug.cgi?id=5044 ?
19:45:16 <erzulie> [ Bug 5044 - lilo failed commande introuvable .. sh ligne 0 erreur d'ecriture / broken pipe ]
19:45:18 <guillomovitch> especially the tomcat ones
19:45:41 <guillomovitch> we have tons of java package in the distribution
19:45:57 <guillomovitch> without proper maintainance
19:46:34 <pterjan> ennael: hmm yes forgot about it, I'm assigning it to myself
19:46:34 <mitya> besides, are we going to update Oracle Java to 1.6.0.31?
19:46:47 <Luigi12_work> mitya: we can't, the license doens't allow it
19:46:49 <pterjan> mitya: as far as I know we can't
19:46:50 <guillomovitch> mitya: AFAIK, we can't, for licensing issues
19:47:05 <guillomovitch> so we are going to provide a pseudo-update
19:47:08 <Luigi12_work> guillomovitch: I updated our openjdk 1.6.0 to fix the security issues, but 1.7.0 needs to be done, as well as tomcat as you said
19:47:21 <Luigi12_work> it should be as simple as updating tomcat5/6/7 to newest versions
19:47:26 <guillomovitch> removing it
19:47:27 <mitya> the license does allow redistribution of JRE (but not JDK)
19:47:32 <Luigi12_work> dmorgan said he'd work on it, hopefully he will
19:47:59 <Luigi12_work> the other packages on the security tracker I can do if nobody else does
19:48:09 <guillomovitch> we should cleanup those nasty java mandatory dependencies
19:48:19 <guillomovitch> and remove stuff we don't need
19:48:38 <Luigi12_work> I wish libreoffice didn't need tomcat too
19:48:44 <guillomovitch> it doesn't
19:48:52 <guillomovitch> some mysterious part of libreoffice
19:48:56 <guillomovitch> requries hsqdlb
19:49:02 <guillomovitch> wich requires servlet api
19:49:10 <guillomovitch> that's all
19:49:21 <Luigi12_work> yeah
19:49:49 <pterjan> mitya: really? aren't they both under Operating System Distribution License for Java ?
19:51:20 <guillomovitch> gajim, gnash and raptor have security issues too
19:51:25 <guillomovitch> :maint gajim
19:51:25 <Sophie> guillomovitch: For Mageia (gajim): misc
19:51:28 <guillomovitch> :maint gnash
19:51:28 <Sophie> guillomovitch: For Mageia (gnash): nobody
19:51:33 <guillomovitch> :maint raptor
19:51:33 <Sophie> guillomovitch: For Mageia (raptor): mikala
19:51:49 <mitya> "The Java(TM) Platform, Standard Edition Runtime Environment (JRE(TM)),  excluding the JavaFX(TM) runtime, is intended for software developers  and vendors to redistribute with their applications." (from the official README)
19:52:12 <Luigi12_work> to be fair, I only reported those three this week
19:52:15 <mitya> " Use and redistribution of the Java SE Runtime Environment is subject to  the Oracle Binary Code License Agreement for the Java SE Platform  Products."
19:52:42 <guillomovitch> and they should be easy to fix
19:52:49 <guillomovitch> the real issue is with java stuff
19:52:56 <guillomovitch> especially tomcat5
19:53:03 <Luigi12_work> yes
19:53:11 <guillomovitch> and how to handle the sun java issue
19:53:26 <guillomovitch> even if the license allows it
19:53:32 <guillomovitch> replacing a jdk by a jre
19:53:42 <sebsebseb> guillomovitch: I think handle that Java issue like Ubuntu does
19:53:42 <guillomovitch> is not really worth
19:53:47 <pterjan> mitya: as far as I remember this is the old licence, before they added the linux distro one, which needed approval to dsitribute it
19:53:57 <mitya> guillomovitch: probably, JRE can go to "non-free", while JDK lands in "tainted"
19:54:05 <pterjan> no
19:54:15 <guillomovitch> we can live without sun jdk
19:54:50 <sebsebseb> mitya: no for some reason apparnatly  Java can't be put into distro repos anymore or something, because of the lisence
19:54:52 <Luigi12_work> tainted isn't for bad licenses
19:55:26 <sebsebseb> mitya: users must instead  download directly from Oracale that want it, or something like that
19:55:26 <guillomovitch> :maint libreoffice
19:55:26 <Sophie> guillomovitch: For Mageia (libreoffice): dmorgan
19:55:33 <guillomovitch> ah, the java guy...
19:55:42 <pterjan> http://www.oracle.com/technetwork/java/javase/terms/license/index.html
19:55:43 <erzulie> [ BCL For Java SE ]
19:56:03 <guillomovitch> I'm going to leave soon
19:56:04 <Luigi12_work> I think he's been really busy the last two months
19:56:12 <guillomovitch> yes
19:56:18 <pterjan> (i) you distribute the Software complete and unmodified and only bundled as part of, and for the sole purpose of running, your Programs
19:56:31 <guillomovitch> but that's my point: we can't afford housing hundred of java stuff
19:56:37 <guillomovitch> with only one guy to manage them
19:56:45 <guillomovitch> we should make some cuts
19:56:55 <Luigi12_work> yeah I don't think it's all needed
19:57:09 <Luigi12_work> of course we have lots of PHP stuff with no maintainer currently :o(
19:57:18 <guillomovitch> all my bugs about excessive runtime dependencies have been ignored sofar...
19:57:26 <pterjan> mitya: we are only allowed to bundle jre with our java software (+other restrictions like the countries were we export it) and only to run our software
19:57:39 <guillomovitch> OK, I volonteer for having this java-security-issues specific discussion on -dev
19:57:40 <sebsebseb> provide the OpenJDK or whatever it's called, and make it clear to users that if they want Sun/Oracale Java, they must get it themselves from the Oracale website,  I guess that's what should be done really
19:57:49 <Luigi12_work> guillomovitch: sure
19:58:10 <guillomovitch> meaning the 4 first bugs from the security tracker
19:58:18 <ennael> well we could first ask dmorgan about all this and see if there is a possibility for a java team
19:58:29 <ennael> before cleaning all this
19:58:36 <Luigi12_work> dmorgan wanted to build a java team and was mentoring packagers hoping to do this
19:58:37 * coling uses a lot of the PHP stuff for $dayjob but I can't really afford the time to take over maintenance :(
19:58:43 <Luigi12_work> then he got really busy (I guess with work)
19:58:49 <Luigi12_work> so it didn't really happen
19:58:58 <ennael> ok I will ask him
19:58:58 <guillomovitch> of course, I don't intend to exclude him from the discussion
19:59:10 <guillomovitch> just give some facts
19:59:43 <ennael> #action start discussion about java packages: keep all of them or drop some of them, java team, ...
19:59:44 <guillomovitch> what are the other blocker bugs ?
20:00:07 <ennael> we found 2 nasty bugs during isos tests
20:00:44 <ennael> #55426
20:00:46 <ennael> oups
20:00:50 <ennael> #5426
20:02:05 <bmahe> hola
20:02:06 <bmahe> hold on
20:02:30 <bmahe> ennael, what do you mean by "start discussion about java packages: keep all of them or drop some of them, java team, ..." ?
20:02:48 <ennael> basically we miss regular updates on all these
20:02:56 <ennael> only one guy working on it (dmorgan)
20:03:10 <ennael> so either we find people to help or we will have to drop some of these packages
20:03:20 <ennael> want to volonteer ? :)
20:03:30 <bmahe> I want to, and even tried to
20:03:40 <bmahe> but my lack of time prevented me to
20:04:00 <bmahe> but I need the java stuff to support Mageia in hadoop land
20:04:15 <Luigi12_work> bmahe: you were one of dmorgan's mentees yes?
20:04:22 <bmahe> no
20:04:23 <ennael> well we would like too but it needs volunteers
20:04:35 <ennael> anyway we will start discussion on it
20:04:41 <ennael> we may not find a solution tonight :)
20:04:50 <bmahe> indeed
20:05:13 <ennael> we still have https://bugs.mageia.org/show_bug.cgi?id=5330
20:05:15 <erzulie> [ Bug 5330 - When entering encryption key for an encryped LVM in the installer, it does not show the VGs within it. ]
20:05:19 <mitya> I'm using Tomcat actively in my business, so I probably could do something
20:05:20 <ennael> coling is on it
20:05:37 * coling isn't really doing anythin on it
20:05:47 <coling> I was quietly hoping pterjan would fix it :D
20:05:58 <pterjan> me too
20:06:01 <ennael> oh :)
20:06:02 <Luigi12_work> mitya: that would be nice.  Basically tomcat5/6/7 need updated to fix security issues, and apparently QA found some more issues with tomcat5's package
20:06:08 <coling> (as I don't really know the diskdrak code)
20:06:14 <guillomovitch> let's pretend than some US law prevent disk encryption
20:06:17 <ennael> waiting for each oither :)
20:06:28 <pterjan> no no waiting for myself :)
20:06:33 <guillomovitch> and than we can't support this feature
20:06:46 <coling> pterjan, so can I assing to you?
20:06:49 <coling> erm
20:06:49 <pterjan> yes
20:06:55 <coling> that sounded bad :D
20:06:59 <coling> assign is better
20:07:03 <ennael> :)
20:07:04 <Luigi12_work> coling will assing you a song
20:07:05 <pterjan> I have created a vm to reproduce it
20:07:23 <coling> The songs I sing with my ass don't smell too good.
20:07:25 <ennael> #action pterjan will work on #5330
20:07:30 <ennael> outch
20:08:21 <ennael> #5404
20:08:25 <guillomovitch> #fortune
20:08:29 <ennael> :)
20:08:35 <guillomovitch> too bas it's not implemented yet
20:09:10 <mitya> Luigi12_work: do we need to keep all the three versions of Tomcat in parallel?
20:09:19 <guillomovitch> 3 ?
20:09:23 <ennael> mitya: please
20:09:24 <pterjan> mitya: that's part of the discussion of dropping some packages
20:09:35 <pterjan> that will be started soon
20:09:37 <mitya> ok, sorry
20:09:39 <ennael> can we focus on this later not end meeting after midnight
20:09:42 <ennael> :)
20:10:01 <mitya> (it's midnight in Moscow already :)
20:10:20 <sebsebseb> mitya: 01:10  ?
20:10:39 <guillomovitch> so, just two blocker bugs left ?
20:10:59 * leuhmanu will maybe add one or two more
20:11:05 <mitya> sebsebseb: 00:11
20:11:20 <ennael> then https://bugs.mageia.org/show_bug.cgi?id=4364
20:11:22 <erzulie> [ Bug 4364 - If I change my bios setting from IDE to AHCI, I can't boot as dracut can't find my device (sdX) ]
20:11:40 <ennael> https://bugs.mageia.org/show_bug.cgi?id=4696
20:11:42 <erzulie> [ Bug 4696 - Install freeze after licence acceptation (system without floppy disk in the drive) (error I/O fd0) ]
20:12:09 <tmb> for 4364 we can make dracut always include it.
20:12:19 <coling> Yeah, that was my suggestion.
20:12:27 <coling> I was waiting for coincoin to test.
20:12:33 <coling> or rather confirm.
20:12:41 <coling> I tested in Virtualbox
20:12:49 <coling> So it seemed to work for me.
20:12:49 <tmb> for 4696 I will do like redhat and disable floppy autoloading
20:13:01 <tmb> (unless someone objects)
20:13:18 <guillomovitch> well, this is quite similar to 'if I change my harddrive, I can't boot anymore'
20:13:20 * coling would just disable floppy completely... :p
20:13:44 <tmb> coling: well, there is still some floppy users :)
20:13:59 <ennael> so basically we have solutions for both ?
20:14:01 <pterjan> guillomovitch: except that this one require no physical change
20:14:05 <coling> guillomovitch, yeah, but as it's just a bios option it's a bit more surprising for it to break. It shouldn't be hard to support.
20:14:24 <coling> And also the installer technically now generates such an initrd.
20:14:36 <coling> Because the modules are loaded at the time the initrd is generated.
20:14:40 <jcapik1> Good evening.
20:14:44 <obgr_seneca> ennael: anything broken till now?
20:14:52 <guillomovitch> userproof-initrd.img
20:14:56 <ennael> :)
20:15:13 <ennael> coling, tmb : can we then validate solutions for these bugs
20:15:29 <coling> ennael, like I say I was waiting for coincoin to confirm on his hardware.
20:15:38 <ennael> ok I will slaps him
20:15:42 <coling> He did say he'd test it when we chatted on IRC :)
20:15:42 <tmb> imho yes
20:16:15 <coling> But I'd be tempted to just make the change anyway and then if there is some fundamental problem I can't htink of, revert it later. It's highly likely it'll be fine IMO.
20:16:31 <coling> Incidentally tmb, I did find some fallout from kmod Ithink.
20:16:39 <ennael> ok anything else on yep let's do that
20:16:42 <guillomovitch> I always have the same excuse for every single commit I make
20:16:54 <tmb> coling: what?
20:16:54 <ennael> and I will threaten coincoin so that tests are done
20:17:16 <coling> tmb but I'm not 100% certain it was caused by it. Basically some modprobe rules using --first-time didn't behave exactly the same.
20:17:33 <obgr_seneca> ennael: you should go searching for some antimatter, no traces left :D
20:17:46 <coling> tmb I've fixed the problems for now, but there could be others lurking in there. I don't think it's a major problem tho'.
20:17:49 * coling looks for the bug number
20:17:50 <ennael> obgr_seneca: I guess so
20:17:58 <Luigi12_work> ennael: can you threaten coincoin so he finishes security updates for wordpress and ocsinventory on Mageia 1?  :o)
20:18:10 <guillomovitch> ocsinventory...
20:18:22 <ennael> guillomovitch: don't feed the troll
20:18:23 <coling> tmb: FYI https://bugs.mageia.org/show_bug.cgi?id=5329 (the interesting bits are problem around comment 30)
20:18:26 <erzulie> [ Bug 5329 - Soundcard doesn't work after latest update ]
20:18:39 <guillomovitch> this is just an SQL injection traning target
20:18:52 <coling> :)
20:19:00 <ennael> ok anything else to add on release blocker bugs ?
20:19:16 <jcapik1> Has anybody seen dmorgan recently?
20:19:31 <Luigi12_work> ooh sound broke on my VM at home when I updated this weekend, wonder if it's related
20:19:32 <guillomovitch> he posted on -dev recently
20:19:34 <pterjan> ennael: what is the prize for closing one ?
20:19:43 <coling> jcapik1,  spoken to him a few times on IRC yeah.
20:19:50 <ennael> pterjan: a night with U...y
20:19:55 <pterjan> :(
20:19:56 <jcapik1> coling: thx ...
20:20:02 * pterjan reassigns then
20:20:05 <ennael> of maybe coling :)
20:20:18 <ennael> he seems to have nice music to share
20:20:31 <Luigi12_work> cool :o)
20:20:39 <ennael> ok
20:20:42 <coling> Luigi12_work, this only applied to non-pulseaudio setups. Alsa modules not being loaded.
20:20:51 <ennael> canwe switch topic ?
20:20:54 <tmb> coling: ok, I'll check with upstream on that
20:21:15 <pterjan> ennael: you can do it
20:21:29 <ennael> #topic  release freeze
20:21:35 <coling> tmb, cool. It only happens when multiple sound cards are needed.
20:21:42 <coling> s/needed/used/
20:21:57 <Luigi12_work> coling: I have pulseaudio disabld on my VM, but even enabling it didn't fix it
20:22:00 <ennael> release freeze is planned for 2012 Apr. 23rd
20:22:11 <pterjan> Monday
20:22:23 <Luigi12_work> wow
20:22:23 <ennael> which is very short now
20:22:41 <ennael> it does not mean we will not be able to push updates
20:22:52 <tmb> but we will be picky
20:22:57 <ennael> but you will have to ask on -dev giving good reasnons for it
20:23:09 <guillomovitch> the same as usual ?
20:23:13 <guillomovitch> or real reasons ?
20:23:14 <pterjan> better to fix all lsb initscripts now if you don't want to have 50 requests :P
20:23:22 <sebsebseb> guillomovitch: heh heh
20:23:23 <coling> so "snd" was a dep of both, and because the first driver i.e. snd-hda-intel loaded snd as a dep then all was well, but when the second card, snd-usb-audio was inserted it tried to load snd as a dep (even tho' it's already loaded) and then it failed due to the --first-time and that seemed to prevent snd-usb-audio loadeing.... at least that's my analysis. I could be wrong.
20:23:31 <Luigi12_work> guess I better try to do some security fixes this weekend
20:23:31 <coling> tmb ^^
20:23:47 <ennael> guillomovitch: beer is not a good reason
20:24:10 <pterjan> armagnac?
20:24:14 <coling> :)
20:24:16 <ennael> we can speak
20:24:19 <ennael> hum
20:24:44 <ennael> anything else on that topic ?
20:24:46 <ennael> (short one)
20:24:54 <tmb> yep
20:25:08 <ennael> #info release freeze is planned for 2012 Apr. 23rd
20:25:19 <ennael> tmb: want to add something ?
20:25:28 * coling has a small request regarding a new version..... I can understand if it's vetoed, but I have to try... mythtv. It's a very leaf package but I'd like to include the new version (>500 days since last release!)
20:25:51 <tmb> dont commit anything extra to svn after release freeze unless absolutely necessary... as it should match final mirrors
20:26:04 <coling> I'd like Anssi's approval specifically tho'. And I won't mind if people think this is a bad idea.
20:26:14 <ennael> #info dont commit anything extra to svn after release freeze unless absolutely necessary... as it should match final mirrors
20:26:25 <ennael> coling: can you mail -dev?
20:26:31 <coling> ennael, yup I will.
20:26:34 <ennael> thanks
20:26:35 <tmb> so please disable "automatic update scripts" when we hit release freeze
20:26:42 <boklm> tmb: we can diff current and pristine directories to check that nothing was committed unsubitted
20:27:18 <ennael> boklm: how could we use that ?
20:27:20 <tmb> boklm: true, but good to think twice anyway before committing
20:27:21 <Luigi12_work> tmb: shouldn't the /updates/2 SVN be generated from the SRPMS so it does match exactly?
20:28:01 <tmb> Luigi12: no, you loose commit history
20:28:13 <Luigi12_work> tmb /updates/1 SVN doesn't have commit history already
20:28:28 <boklm> /updates/1 has commit history
20:28:49 <Luigi12_work> no, they all start with "copied to updates" or something like that, no history before that
20:28:50 <pterjan> It should be generated from the release dir, not current
20:29:04 <Luigi12_work> pterjan: oh is the release dir made by schedbot?
20:29:05 <boklm> Luigi12_work: they have history before that
20:29:17 <Luigi12_work> boklm: not according to viewvc...
20:29:29 <boklm> I can make a script to copy each package using revision from pristine directory
20:29:38 <Luigi12_work> ok
20:30:03 <leuhmanu> http://svnweb.mageia.org/packages/updates/1/firefox/current/SPECS/firefox.spec?view=log here it works
20:30:06 <erzulie> [ [packages] Log of /updates/1/firefox/current/SPECS/firefox.spec ]
20:30:10 <pterjan> Original Path: cauldron/rpm/current/SPECS/rpm.spec
20:30:18 <pterjan> Luigi12_work: click on the link
20:30:27 <pterjan> to get to the path before copy
20:30:40 <pterjan> ah no
20:30:46 <pterjan> actually it diaplays it all :)
20:30:54 <pterjan> http://svnweb.mageia.org/packages/updates/1/rpm/current/SPECS/rpm.spec?view=log
20:30:55 <erzulie> [ [packages] Log of /updates/1/rpm/current/SPECS/rpm.spec ]
20:30:59 <guillomovitch> what's left on the agenda ?
20:31:33 <tmb> beta3 tests
20:32:02 <ennael> #topic beta 3 tests
20:32:06 * ennael was sleeping
20:32:10 <ennael> so
20:32:22 <ennael> we do need tests on this especially on live CDs
20:32:43 <ennael> on DVD side, please check installer and content
20:32:52 <ennael> we do have some space left, 500Mo
20:33:06 <sebsebseb> For the Live CD's, how should they be tested?
20:33:09 <ennael> but it's not christmas so please post on -dev for any demand
20:33:24 <ennael> tmb: about live cds, any specific request for tests ?
20:33:39 <pterjan> we need toilet on dvd !
20:33:53 <tmb> pterjan: thats the hole in the middle
20:33:55 <ennael> #info DVDs tests focus on installer and content (500Mo unused)
20:33:55 <pterjan> :size toilet
20:33:58 <pterjan> tmb: :)
20:34:03 <ennael> outch second fortune
20:34:10 <guillomovitch> pterjan: that could be the price for closing blocker bugs
20:34:11 <ennael> we need to implement #fortune
20:34:17 <ennael> guillomovitch: :)
20:35:35 <tmb> as for livecds, test on as much hw as you can, look for missing packages (but note that adding one package might mean dropping another)
20:35:52 <sebsebseb> I'll test on three computers here :D.
20:35:56 <guillomovitch> even cowsay ?
20:36:04 <ennael> (see lives are much less fun than dvd :) )
20:36:41 <ennael> #info live CDs test: focus on hardware tests, missing packages (note that adding one package might mean dropping another)
20:36:52 <ennael> anything else ?
20:36:59 <guillomovitch> hungry...
20:37:12 <leuhmanu> 22:33 < ennael> but it's not christmas so please post on -dev for any demand
20:37:21 <sebsebseb> guillomovitch: yeah I could do with food as well :D.
20:37:21 <leuhmanu> nothin in the bugzilla ?
20:37:23 <leuhmanu> +g
20:37:46 <ennael> I will open a bug adding all packages on which we agree
20:37:52 <tmb> leuhmanu: (it's spelled G+)
20:37:55 <ennael> otherwise bug report will be 10 pages long
20:38:11 <ennael> tmb: secondary effects of live CDs ? :)
20:38:28 <tmb> :)
20:38:35 <ennael> leuhmanu: will post on -dev for it
20:38:45 <leuhmanu> okokoké
20:38:49 <ennael> can we close that meeting ?
20:38:53 <guillomovitch> yes
20:38:57 <ennael> coincoin: you are a dead duck
20:39:02 <ennael> #endmeeting