19:13:00 <ennael> #startmeeting
19:13:00 <Inigo_Montoya> Meeting started Wed Mar 28 19:13:00 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:13:00 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:13:01 <erzulie> [ MeetBot - Debian Wiki ]
19:13:57 <ennael> ok as stated in mail our coming meetings will be focused on Mageia 2
19:14:22 <ennael> so mainly always the same topics, you should be fed up with it quite quickly :)
19:14:34 <ennael> #topic release_blocker bugs management
19:15:09 <ennael> ok we spoke about this during last council meeting
19:15:21 <ennael> given the current list of release_blocker bugs
19:15:45 <ennael> we may have to delay the release if it does not decrease fast enough
19:16:13 <ennael> see following url
19:16:14 <ennael> https://bugs.mageia.org/buglist.cgi?cmdtype=runnamed&namedcmd=release_blocker
19:16:15 <erzulie> [ Log in to Bugzilla ]
19:16:21 <ennael> erf
19:16:51 <doktor5000> ennael: https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=release_blocker&sharer_id=69
19:16:52 <erzulie> [ Log in to Bugzilla ]
19:16:59 <ennael> https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=release_blocker&sharer_id=69
19:17:00 <erzulie> [ Log in to Bugzilla ]
19:17:02 <ennael> oups
19:17:05 <ennael> ok that one
19:17:16 <remmy> We have gone down a few since the beginning of this week, and others are showing progress, but yeah, still a lot of them left.
19:17:25 <ennael> we need to work on that list
19:17:35 <ennael> some of them are really not release_blocker
19:17:47 <ennael> and may be dicreased
19:19:10 <remmy> ::nods::
19:19:12 <ennael> "release_blocker" can be quite subjective no we need to agree on what should be release_blocker
19:20:07 <guillomovitch> apparently 20% of them are gnome bugs
19:20:12 <guillomovitch> and 40 % are installer bugs
19:20:30 <ennael> others are systemd :)
19:20:31 <ennael> oups
19:20:54 <remmy> guillomovitch: I guess we have to assists these guys where we can
19:21:12 <remmy> It is a bit much for single persons to work on
19:23:21 <ennael> well we may ask people to have a look
19:23:40 <ennael> check if reporters have made proper bug reports, ask again information
19:23:55 <remmy> Yup. But we can only ask the same thing so many times.
19:24:05 <ennael> and dicrease tag if no answer for a long time
19:24:22 <ennael> remmy: meaning ?
19:24:23 <remmy> I'll go through it with a fine haired comb on the weekend (but don't let that stop anyone from doing that before then :P   )
19:24:34 <Stormi> remmy: what about the "one day one blocker" mail to the mailing list idea from council meeting?
19:24:57 <remmy> ennael: We have asked quite a few times for help with this... I fear this is all the help we're going to get.
19:24:59 <Stormi> it can be a "different" way to ask "please help fixing blockers"
19:25:00 <ennael> can you please remind us what it was about ?
19:25:05 <remmy> But perhaps that's my pessimist nature.
19:25:37 <Stormi> it would be a daily e-mail sent to mageia-dev ML picking one bug report, explaining it, asking for someone to take it
19:25:53 <AL13N> Stormi: if you have an idea that might work, we should try it... we never know it might work
19:25:54 <Stormi> It might help focusing
19:26:10 <Stormi> the main problem is I will not be available to do it :)
19:26:55 <AL13N> perhaps someone from qa is wellsuited for this task
19:26:58 <ennael> well we can find people to do it
19:27:01 <ennael> not only qa team
19:27:11 <AL13N> well, it's best to be one person
19:27:18 <AL13N> or there are suddenly 5 emails a day
19:27:21 <AL13N> or none
19:27:37 <AL13N> or at least one person who can delegate to someone else
19:27:50 <ennael> I don't understand you at all :)
19:27:58 <remmy> Also, just an idea... do people know how they can test bug fixes on for example the installer ? I for example wouldn't know what to do without waiting for someone to build an iso for me.
19:28:29 <AL13N> remmy: there's a bug where tv explains to me how to do it, it's a bunch of work though
19:28:40 <ennael> I can build isos before RC
19:28:51 <Luigi12_work> network installation is an easy way to test the installer
19:29:12 <AL13N> well, yes, but the sqfs files should be rebuilt too
19:29:14 <remmy> AL13N: Maybe we should wikify that in some way... I'd feel bad to ask someone else to spend hours on building me something which might be broken anyways
19:29:25 <AL13N> remmy: i'll try and refind it and put it in the wiki
19:29:51 <ennael> I will ask also tv to give some tips and detail all this a bit more
19:31:04 <remmy> Thanks :)
19:31:29 <ennael> so what should be a release_blocker bug ?
19:31:42 <guillomovitch> a bug affecting me
19:31:46 <remmy> haha
19:31:47 <AL13N> :)
19:31:56 * Luigi12_work agrees with guillomovitch
19:32:01 <AL13N> well, we should agree in some form
19:32:03 <remmy> and > 10% of random users
19:32:10 <Luigi12_work> also something that could lock someone out of a server if they upgraded
19:32:13 <ennael> not precise enough
19:32:16 <Stormi> upgrade bugs are likely to be blockers
19:32:17 <Luigi12_work> or cause an upgrade to fail
19:32:22 <AL13N> but a voting will take too much time, and i don't think we can have any exact measures
19:32:27 <ennael> please
19:32:30 <ennael> one at a time
19:32:45 <remmy> Perhaps hardware support things should be set to major instead of blocking
19:33:04 <Luigi12_work> unless it's in the installer, since that can't be fixed later
19:33:13 <AL13N> i don't see any way to have a precise judgement, i think maybe this is for a team leader to decide
19:33:14 <Stormi> remmy: it depends on the range of affected hardware, to me
19:33:15 <ennael> yep that's a good part
19:33:24 <remmy> As well as esthetics, but I don't want them forgotten about either.
19:33:30 <ennael> installer and boot
19:33:32 <guillomovitch> what having some generel categories, perhaps as additional tracker bugs ?
19:33:48 <remmy> Some bugs, from scanning the list, should probably go to a tracker.
19:33:54 <Stormi> what a blocker is also depends on where we want to put the bar for quality
19:34:04 <Luigi12_work> someone said on the -dev list there are some things that need to be working on Live ISOs, as they can't be fixed later either.  Maybe that point could be expanded upon.
19:34:15 <Stormi> it would also set a maximum number of major bugs
19:34:22 <ennael> well hidding bugs in tracker may not help that much
19:34:29 <guillomovitch> that's not hiding
19:34:29 <ennael> :)
19:34:32 <guillomovitch> rather sorting
19:34:33 <AL13N> so, "things that can't be fixed later, have reproducable data loss or hardware destruction, and which will show bad marketing value" ?
19:34:34 <doktor5000> Luigi12_work: usually no iso can be fixed later on
19:35:01 <ennael> sorting ok but it seems trackers have at the moment release_blocker and non blocker bugs
19:35:21 <remmy> Luigi12_work: In theory we could release an updated ISO, but we are short on manpower and QA for that.
19:35:46 <doktor5000> remmy: so that's a no in reality
19:35:53 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=4880
19:35:55 <erzulie> [ Bug 4880 - Cannot get web pages with Java to work ]
19:35:57 <remmy> doktor5000: aye
19:36:01 <guillomovitch> clearly, this is not blocker, for instance
19:36:16 <remmy> guillomovitch: I think that one should be major, perhaps even critical, but not release blocking
19:36:19 <guillomovitch> and it is an isolated problem
19:36:32 <guillomovitch> not a general class of problems, as for systemd ones
19:36:52 <guillomovitch> ok, this is not a scientific rule
19:36:56 <AL13N> ok, i propose someone goes through them all, and lists the ones to be degraded in an email to -dev ML, and unless someone disagrees, to be decreased after 2 days
19:37:15 <Stormi> what about deciding a number of high priority bugs (but not blockers) above which we would not release ?
19:37:29 <remmy> AL13N: Sounds good to me... and I think we need ownership... all bugs but the tracker ones should not be assigned to bugsquad
19:37:33 <doktor5000> AL13N: agreed
19:37:41 <AL13N> so, who will do it?
19:37:44 <AL13N> any volunteers?
19:38:06 <remmy> AL13N: I can spend some time on saturday on it, but would prefer not to do it alone
19:38:19 <remmy> Stormi: +1
19:38:42 <ennael> I can have a look tomorrow afternoon
19:38:49 <Stormi> blockers are important since they are blockers, but other major bugs are important too, especially if numerous
19:38:56 <ennael> at leaset make a proposal
19:39:04 <AL13N> ok so ennael and remmy do it, and one takes upper numbers, other person lower numbers
19:39:18 <AL13N> agreed?
19:39:34 <remmy> AL13N: And anyone else who has a moment and cares :)
19:39:49 <AL13N> well, yes, but important is that all of them are done and none are missed
19:40:02 <AL13N> ennael: can you do #action ,
19:40:03 <AL13N> ?
19:40:34 <guillomovitch> https://bugs.mageia.org/show_bug.cgi?id=5034
19:40:36 <erzulie> [ Bug 5034 - [TRACKER] Oxygen integration issues ]
19:40:38 <ennael> #action review of release_blocker and make proposals for keeping them all or not (ennael and stormi)
19:40:42 <guillomovitch> this one seems to be complete now
19:40:51 <ennael> yep some of them are done
19:41:02 <Stormi> stormi ?
19:41:07 <AL13N> lol
19:41:09 <Luigi12_work> guillomovitch: have you tried running oxygen theme in 16bpp?
19:41:11 <ennael> oups
19:41:12 <ennael> #undo
19:41:12 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x83d9e4c>
19:41:21 <ennael> #action review of release_blocker and make proposals for keeping them all or not (ennael and remmy )
19:41:23 <guillomovitch> Luigi12_work: I have no clue what oxygen theme is...
19:41:35 <Luigi12_work> guillomovitch: default gtk and gt widget theme
19:41:35 <ennael> guillomovitch: default one replacing ia_ora
19:41:47 <guillomovitch> I'm just trying to figure what's the full blocker dependency tree look like
19:41:56 <guillomovitch> a some problems are actually counted 3 times
19:42:08 <remmy> I'm still surprised that a theme can cause programs to crash... I remember when a theme was just some colours and a handful of icons.
19:42:29 <Luigi12_work> themes can have c/c++ code, always room for crashes
19:42:32 <ennael> it's also about drawing windows
19:42:36 <AL13N> about Stormi's idea... is that a good idea or not?
19:42:42 <guillomovitch> 4301, 4801 and 4802, for instance
19:43:02 <guillomovitch> if number is the single criteria, one kernel hacker may have an high-score there
19:43:35 <ennael> 4802 seems not release_blocker
19:43:42 <ennael> it can be fixed through updates
19:43:48 <guillomovitch> also
19:43:58 <guillomovitch> seems to be a good decision criteria
19:44:09 <guillomovitch> reducing the list to installer bugs mostly
19:44:27 <ennael> well there are some nasty bugs with systemd for example
19:44:27 <AL13N> ok, good
19:44:31 <ennael> that can prevent boot
19:44:45 <ennael> or make graphical environment unusable
19:44:48 <remmy> Ok, so let's reassess the next few days. And ensure that bugs get ownership, and that we also ask the owners what their timelines are and what help they need in order to close these bugs?
19:44:55 <ennael> yep
19:45:05 <ennael> so criteria for releas_blocker
19:45:08 <ennael> installer
19:45:12 <ennael> boot time
19:45:37 <guillomovitch> upgrade ?
19:45:41 <Luigi12_work> upgrade issues
19:45:42 <AL13N> hardware destruction
19:45:56 <remmy> house on fire
19:46:00 <guillomovitch> fridge emptying anf GF loss
19:46:01 <Luigi12_work> data destruction too, although I don't think we have any of those
19:46:03 <remmy> lol
19:46:10 <AL13N> and data destruction too
19:46:13 <ennael> upgrade
19:46:14 <Luigi12_work> "things that can't be fixed later"
19:46:15 <Stormi> system crash if not related to a specific piece of hardware?
19:46:26 <AL13N> (and don't laugh, at one time there was a firmware that destroyed the CDdrive)
19:46:31 <Stormi> and frequent
19:46:35 <Stormi> (not just one reporter)
19:46:41 <remmy> and: random crash < reproducable
19:46:47 <Luigi12_work> what about security issues?
19:46:56 <guillomovitch> they can be fixed later
19:47:00 <Luigi12_work> ok
19:47:00 <guillomovitch> it's just more work
19:47:06 <guillomovitch> as everything else done later
19:47:34 <ennael> security issues tracker is just a reminder
19:47:36 <guillomovitch> default are clearly not release blockers in this regards
19:47:36 <remmy> Other than 3921, most security ones are being picked up quite quickly I think
19:47:54 <ennael> yep
19:47:59 <doktor5000> maybe keep an eye out for the recent rpm db corruption issues as the problem was only workarounded, IIRC?
19:48:13 <ennael> I will ping also tv on this
19:48:37 <guillomovitch> bug 3921 is funny
19:48:48 <AL13N> ok, so, we need not go through this list right now
19:48:55 <AL13N> let's continue meeting
19:49:16 <ennael> #info criteria for release_blocker bugs: installer, boot time, upgrade, system crash, issues that can hardly be fixed through updates
19:49:36 <AL13N> Stormi had idea: "what about deciding a number of high priority bugs (but not blockers) above which we would not release ?"
19:49:41 <AL13N> is that somethign we want or not?
19:49:55 <Luigi12_work> if it can be fixed later, it can go in the errata?
19:50:02 <ennael> Luigi12_work: yep
19:50:38 <remmy> But would be good to flag any unsolved issues in the release notes / errata so people don't stumble into them when they want to install
19:50:57 <remmy> on their mothers sole computer who lives 300 km away from them
19:52:02 <ennael> ok anything else to add on that topic ?
19:52:13 <guillomovitch> which is a bad idea, even if your mother is living next door anyway :)
19:53:20 <AL13N> ennael: Stormi's idea?
19:53:26 <AL13N> Stormi had idea: "what about deciding a number of high priority bugs (but not blockers) above which we would not release ?"
19:53:42 <ennael> AL13N: well if we can have information about this before thus we why not
19:53:52 <ennael> this
19:54:06 <ennael> but it's a bit late so we would have to hurry
19:54:28 <Stormi> I looked at bugzilla : the high priority is rarely used
19:54:37 <Stormi> so it would require to define what is "high"
19:54:46 <guillomovitch> not blocking :)
19:54:46 <AL13N> we have to hurry for fixing all the bugs too, so maybe not at this time
19:54:50 <Stormi> and then look at all bugs :)
19:55:03 <ennael> okok
19:55:07 <AL13N> ok, then let's not atm, and proceed to next topic
19:55:09 <guillomovitch> format definition "evertyhing that was previously consisted blocked, but later degraded as we don't have enough time"
19:55:21 <AL13N> :)
19:55:45 * Luigi12_work marks all his bugs blocking so they can be high priority :o)
19:55:58 <ennael> ok I guess next topic is already done (security updates)
19:56:04 <remmy> Luigi12_work: That's fine, if you also resolve them in the next week :)
19:56:12 <ennael> as it seems they are nearly all done
19:56:30 <Luigi12_work> well the java one has been sitting for quite some time
19:56:43 <Luigi12_work> I think dmorgan has been busy with work
19:56:54 <Luigi12_work> the others I'm not too worried about
19:57:22 <Luigi12_work> I would like some feedback on the expat one actually
19:57:28 <ennael> ok
19:57:32 <guillomovitch> I'll take care of it
19:57:35 <ennael> did you mail -dev about it ?
19:57:36 <guillomovitch> meaning: building
19:57:43 <Luigi12_work> ennael: no not yet
19:58:02 <Luigi12_work> expat is totally unmaintained, so eventually we need to resync it with Mandriva (fixes for library policy)
19:58:04 <guillomovitch> I just reassgined it to myself
19:58:12 <Luigi12_work> in the short term, we can probably just patch it
19:58:18 <Luigi12_work> guillomovitch: thanks
19:58:37 <Luigi12_work> also I hope someone can help with the libzip test error, I'll look closer at it at some point, but no guarantee I'll figure it out
20:01:02 <remmy> guillomovitch: Thanks for submitting it :)
20:01:11 <guillomovitch> you're welcome
20:01:33 <ennael> can we switch to next topic ?
20:01:37 <remmy> yup
20:01:38 <Luigi12_work> yep
20:01:42 <AL13N> k
20:02:03 <ennael> #topic broken dependancies
20:02:17 <ennael> so this is a reminder and also a way to kick ass ! :)
20:03:11 <Luigi12_work> ennael: you're referring to the check.mageia.org reports I assume
20:03:14 <ennael> http://check.mageia.org/cauldron/dependencies.html
20:03:14 <erzulie> [ dependencies global report ]
20:03:35 <guillomovitch> I think the kmod ones
20:03:46 <guillomovitch> are juste side-effect of kernel upgrade
20:03:56 <AL13N> 5 have no maintainer
20:03:57 <guillomovitch> old packages not removed the mirror
20:04:14 <ennael> ok so it means all this can be solved in 2 or 3 days :)
20:04:14 <Luigi12_work> I think I remember MDV dropping gnome-python-gtkmozembed recently
20:04:19 <guillomovitch> I can manage the perl ones
20:04:22 <guillomovitch> at leas try
20:04:48 <remmy> What is the impact if these things are not solved?
20:04:54 <guillomovitch> they are not installable
20:04:57 <guillomovitch> without --nodeps
20:04:59 <remmy> (Just for my noob understanding)
20:05:03 <guillomovitch> usually
20:05:10 <remmy> So, one can't install iceape for example?
20:05:12 <guillomovitch> ocsinventory ...
20:05:25 <Luigi12_work> I think some come from packaging changes where a package is renamed or dropped and not obsoleted somewhere
20:05:32 <guillomovitch> yes
20:05:46 <remmy> Gotcha, thanks.
20:06:11 <guillomovitch> unfortunatly, release number doesn't appear
20:06:28 <guillomovitch> so many times, it's a remnant after an update
20:06:46 <guillomovitch> http://check.mageia.org/cauldron/missing.html
20:06:47 <erzulie> [ missing global report ]
20:07:06 <guillomovitch> this one more specifically tracks binary without matching source packages
20:07:14 <doktor5000> remmy: iceape is another issue for itself, feel free to comment on -dev thread about this (applies to every packager)
20:07:29 * doktor5000 fixed iceape issue just now (locally)
20:07:30 <guillomovitch> ennael: only admins, AFAIK, can cleanup the mirrors
20:07:32 <Luigi12_work> I was told a script is supposed to delete old libraries (changed major) after 2 weeks, but I see some here older than that
20:07:38 <remmy> doktor5000: Aye, I saw that...
20:07:41 <ennael> guillomovitch: ok so this is for sysadmin
20:07:43 <ennael> boklm: around ?
20:07:45 <guillomovitch> making the other report more accurate
20:07:50 <Luigi12_work> I know it was more than two weeks ago I upgraded netpbm for instane
20:07:52 <doktor5000> remmy: comment then, please!
20:08:04 <remmy> doktor5000: I should put your mails on my to do list :)
20:08:33 <guillomovitch> I'd have to see with pterjan how we could avoid reporting issues twice in this regard
20:08:42 <AL13N> shouldn't they just be rebuilt with proper obsoletes?
20:08:52 <AL13N> or am i mistaking with something else?
20:09:07 <guillomovitch> obsolete should not be used
20:09:15 <guillomovitch> as a way to cleanup mirrors
20:09:16 <ennael> #action ask sysadmin about repository cleaning
20:09:23 <Luigi12_work> not for libraries, some of the other things on there could be fixed with obsoletes
20:09:33 <AL13N> guillomovitch: so the cause of these wasn't forgotten obsoletes then?
20:09:34 <guillomovitch> that's not obsolete tag purpose
20:09:38 <guillomovitch> no
20:09:45 <AL13N> ok nvm
20:10:23 <guillomovitch> you should not abuse package metadata just to handle this kind of transient issues
20:10:48 <guillomovitch> ennael: I'd said, once sysadmin did their jobs at cleaning
20:10:59 <AL13N> ok
20:11:18 <AL13N> is it a problem that 5 of them do not have maintainer?
20:11:22 <guillomovitch> I'm volonteer to remind packagers about those issues
20:11:29 <guillomovitch> it is
20:11:40 <AL13N> well, not if they are the transient kind :-)
20:12:00 <guillomovitch> I'll take care of the task-nagios one
20:12:20 <ennael> boklm: can sysadmin have a look on cleaning ?
20:12:37 <boklm> yes
20:13:12 <boklm> remove binary packages without source package ?
20:13:26 <ennael> yep
20:13:28 <guillomovitch> and the opposite also :)
20:13:33 <ennael> also :)
20:13:40 <boklm> ok
20:14:02 <boklm> pterjan started a script for this, we need to finish it
20:14:20 <ennael> ok
20:14:59 * boklm will look tomorrow
20:16:55 <ennael> next topic ?
20:17:09 <remmy> aye
20:17:27 <ennael> #topic QA tests on upgrade
20:17:27 <Luigi12_work> wait
20:17:33 <ennael> #undo
20:17:33 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Topic object at 0x8442b2c>
20:17:39 <ennael> shoot
20:17:43 <Luigi12_work> sorry one last thing for sysadmins
20:17:59 <Luigi12_work> a report that says what packages are older in Cauldron than Mageia 1 (including updates)
20:18:36 <Luigi12_work> that is all, and it actually ties in with the next topic
20:18:43 <Luigi12_work> I already caught one this week by testing upgrades
20:18:48 <AL13N> oh
20:19:09 <Luigi12_work> but if the sysadmins could generate a report, that would be better
20:19:23 <Luigi12_work> we can only catch the packages we actually have installed in upgrade tests
20:19:31 <ennael> boklm: can you have a look on this ?
20:19:38 * boklm will look
20:19:46 <ennael> thanks
20:20:35 <ennael> #action sysadmin will work on getting a list of packages older in cauldron than in Mageia 1 updates
20:21:42 <ennael> next topic ?
20:21:44 <Stormi> yes
20:22:17 <ennael> #topic QA tests on upgrade
20:22:21 <ennael> QA ?
20:22:31 <Stormi> QA started tests one week ago
20:22:42 <Stormi> current results are rather good
20:22:43 <Luigi12_work> I've been testing upgrades since Friday
20:22:50 <Luigi12_work> yes, not many issues
20:23:05 <Stormi> however it would be good to be backed by testers from outside QA
20:24:15 <Stormi> so those who have a mageia 1 computer and want to upgrade at some point, maybe now is the good moment
20:24:18 <AL13N> i'll try and do an upgrade test
20:24:34 <ennael> Stormi: could you please send a mail on -dev
20:24:35 <AL13N> i'll clone a vm and upgrade
20:24:38 <ennael> reviewing these tests ?
20:24:43 <AL13N> what is the best way to upgrade?
20:24:53 <Stormi> ennael: actually I send a mail to QA team asking for a volunteer to do it :)
20:24:56 <ennael> AL13N: there is no best way :)
20:24:57 <Stormi> sent*
20:24:58 <remmy> And some instructions on how to upgrade and how to move your install to a vm or something
20:25:00 <ennael> arf :)
20:25:05 <AL13N> ennael: errr
20:25:09 <Luigi12_work> network or hard drive installer if you have a local mirror is the easiest
20:25:17 <Stormi> as my time is limited and i will be away from computer for 10 days soon
20:25:17 <remmy> I still need my 1 box for updates to 1 :)
20:25:21 <ennael> upgrade has to be test through isos, cli and mgaonline
20:25:34 <AL13N> ic
20:25:45 <Stormi> I'll send a mail again to QA and make sure there's a mail that comes to -dev whatever the way
20:25:56 <Stormi> with relevant information
20:25:57 <AL13N> as a reference a while back i upgraded my dads mdv to mga one, and mgaonline failed to do it
20:25:59 <Luigi12_work> yeah I should probably do a urpmi test
20:25:59 <ennael> ok thanks for that
20:26:02 <AL13N> i used urpmi sources
20:26:15 <ennael> AL13N: api needed to be fixed
20:26:26 <ennael> it has been done today by rda
20:26:32 <AL13N> ah
20:28:33 <ennael> https://bugs.mageia.org/show_bug.cgi?id=5135
20:28:35 <erzulie> [ Bug 5135 - https://releases.mageia.org/api/a/testing-i586 should be updated for testing mgaaplet prior to mga2 release ]
20:29:20 <ennael> anything else to add ?
20:30:14 <AL13N> i have something small, but not really this topic
20:30:40 <remmy> I have something small on a non agenda topic too
20:31:05 <AL13N> hmm
20:31:41 <ennael> ok let's go now
20:31:54 <AL13N> remmy: you go first
20:32:02 <remmy> haha, I was about to type the same
20:32:02 <remmy> ok
20:32:05 <AL13N> lol
20:32:18 <remmy> Just about being a maintainer for a given package
20:32:43 <remmy> I am just a padawan still, but more than once in the past month or so, a package for which I (stormi) has been listed as maintainer
20:32:49 <remmy> has been submitted by others
20:33:01 <remmy> One time this had to be reversed
20:33:20 <remmy> the other time it were small changes which I don't know where they came from
20:33:26 <remmy> there was no bug report or anything
20:33:33 <remmy> What is the best way of dealing with this?
20:33:58 <Luigi12_work> I'm not sure we have enough maintainers to have a hard rule about this
20:34:05 <remmy> I don't want to come across as being easily offended, but I do wonder what the value is of being listed as maintainer when people upload changes without checking or consulting
20:34:20 <doktor5000> remmy: ping the commiter/submitter via mail and ask for reasons?
20:34:22 <Luigi12_work> if there's a particular package someone touches and you don't like it, just ask the person (directly if possible) to go through you for that package in the future
20:34:40 <AL13N> well, i'm not certain, but i think there are some people who don't check and consult or anything and just for example do a new version
20:35:02 * doktor5000 thinks about funda :)
20:35:11 <Luigi12_work> well I've done that too
20:35:34 <Luigi12_work> mainly tried to do it with ones that don't appear to be actively maintained
20:35:40 <AL13N> O_o
20:35:45 <AL13N> Luigi12_work: tssk
20:36:05 <AL13N> Luigi12_work: i try to send patch via email or make bug report and assign
20:36:10 <remmy> I don't want Mageia to become bureaucratic... but I only found out by checking the rsync message from my mirror as well as stormi seeing a message on -dev by chance.
20:36:21 <doktor5000> i don't mind anyone updating my stuff if i don't get to it in time (as for wireshark freeze push by guillomovitch) if it doesn't do more harm than it does good
20:36:29 <Luigi12_work> it's good to watch the changelog list like a hawk :o)
20:36:40 <remmy> I don't mind a rebuild because of library x being fixed or something
20:36:56 <remmy> but changes to the package itself, I'd like to be notified of in advance
20:37:03 <AL13N> yes, me too
20:37:04 <remmy> (and then I'll prolly say: go ahead)
20:37:11 <AL13N> but afaik the best way is to follow the changelog
20:37:13 <Luigi12_work> yeah I try not to make major changes without asking
20:37:17 <AL13N> and filter it with your packages
20:37:26 <Stormi> I plan, via madb, to offer packagers the way to subscribe to submits of their packages (if a sysadmin doesn't do that kind of stuff before based on svn :))
20:37:36 <Luigi12_work> Stormi: neat
20:37:47 <AL13N> Luigi12_work: well, even if it's a little change, explain it in commit mesage or in comment in spec file why or what you do
20:37:53 <remmy> Stormi: That's enough incentive for me to look into working on madb too :)
20:37:54 <AL13N> Stormi: neat
20:38:05 <Luigi12_work> AL13N: yes I like to think I do good commit messages
20:38:10 <AL13N> k
20:38:13 <Stormi> (it's already possible to subscribe to packages, one by one, in one of the demo instances, but I must create users one by one)
20:38:13 <AL13N> ennael: ping
20:38:16 <ennael> yep
20:38:17 <Luigi12_work> don't be afraid to call me out on IRC if I don't :o)
20:38:22 <remmy> Ok, thanks for the input guys... I'll learn to live with it for now :P
20:38:30 <AL13N> ennael: about my small topic
20:38:44 <ennael> I suggest we go back on maintainance pb after release
20:38:52 <AL13N> ennael: iinm you are the only candidate for packaging team leader?
20:38:54 <Luigi12_work> maintainance pb?
20:39:07 <Luigi12_work> oh nvm
20:39:31 <AL13N> ennael: i would like some of the expert packagers to be on the team leaders, but people i've asked, didn't have the time
20:39:35 <ennael> AL13N: We will have a look on this later but still it seems guillomovitch agreed on applying
20:39:55 <AL13N> ennael: if it helps at all, i would be an extra volunteer for team leader
20:39:56 <ennael> *fear*
20:40:05 <AL13N> ennael: but i donno if i ahve the skillset for it
20:40:12 <AL13N> ennael: so you're welcome to deny me
20:40:35 <Luigi12_work> what is the packaging team leader for?
20:40:43 <AL13N> ennael: i'm just thinking that more people will mean less work/person
20:40:50 <guillomovitch> to say other people volonteered
20:40:56 <guillomovitch> when they only asked questions :)
20:40:59 <Luigi12_work> lol
20:41:11 <ennael> :)
20:41:24 <ennael> can we have a look on that topic in next meeting ?
20:41:25 <AL13N> ennael: lemme know how you feel about it
20:41:28 <AL13N> but sure
20:41:36 <ennael> will write a quick mail in between about this
20:41:44 * ennael is just falling asleep :)
20:41:50 <AL13N> it's ok, it's not 100% pressing matter
20:42:01 <ennael> ok
20:42:03 * AL13N is tired too
20:42:08 <ennael> #endmeeting