20:14:26 <ennael> #startmeeting
20:14:26 <Inigo_Montoya> Meeting started Wed Mar 21 20:14:26 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:14:26 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:14:28 <erzulie> [ MeetBot - Debian Wiki ]
20:14:55 <ennael> hi all
20:15:06 <coincoin> hello all
20:15:20 <ennael> #topic freeze push reminder and release freeze
20:15:27 <Remmy> Heya team :)
20:15:31 <ennael> this first topic will be fast
20:15:37 <ennael> just a reminder
20:16:00 <ennael> if you have package to be sumitted with new version mail -dev explaining why we should submit it
20:16:22 <ennael> AL13N: will do yours
20:16:39 <AL13N> k
20:16:46 <ennael> please add clear reason on mail so that we do not loose too much time trying to find reasons
20:16:58 <AL13N> is mine clear enough?
20:17:06 <ennael> yep
20:17:10 <AL13N> k thx
20:17:31 <ennael> release freeze is planned for 07/04
20:17:48 <ennael> so basically a bit more than 2 weeks
20:18:05 <bkor> GNOME 3.4.1 is due Apr 18 btw
20:18:23 <ennael> well same rule will be applied for release freeze
20:18:36 <coincoin> shotwell 0.12 (final) will arrive in a few days... 2 weeks late (only 70 bugs remaninng)
20:18:38 <ennael> no more packages submitted except the one asked on -dev
20:19:02 <ennael> anything to add on freezes ?
20:19:38 <coincoin> can I push new version if their is no "bug fixes" but important improvement?
20:20:04 <ennael> we should not
20:20:16 <coincoin> like for calibre (Ipad3 support and Kindle Fire: ok on my laptop) or phoronix-test-suite
20:20:44 <ennael> avery softwares have big improvements in more recent version :)
20:21:04 <ennael> at one point we have to stop updating
20:21:09 <coincoin> yes but iPad3 and Kindle support for a ebook reader... :)
20:21:12 <coincoin> k
20:21:21 <ennael> you can use backport then
20:21:28 <grenoya> /win 18
20:21:30 <AL13N> i think we should just make a decision to open up backports after release, which will likely end this current discussion
20:21:33 <grenoya> oops /o\
20:21:40 <coincoin> ennael: ok
20:21:50 <ennael> ok next topic to illustrate this
20:21:55 <AL13N> ok
20:21:56 <ennael> #topic bug tracking (release_blocker bugs)
20:22:04 <ennael> my favorite subject at the moment
20:22:53 * AL13N watches tumbleweed go by
20:23:31 <ennael> https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=release_blocker&sharer_id=69
20:23:33 <erzulie> [ Log in to Bugzilla ]
20:23:48 <ennael> this should be our fixed idea for coming days
20:24:16 <ennael> triage team around ?
20:24:21 <marja> I'm here
20:24:24 <Remmy> I'm here
20:24:26 <ennael> ah :)
20:24:52 <Remmy> As always, we can use your help in handling bug reports... but other than the usual mantra
20:24:53 <ennael> so we need to follow this list and update bugs, ping reporter or packagers
20:25:08 <ennael> coling_ around ?
20:25:15 <Remmy> we'd also like to ask people to assist with the release blocking bugs
20:25:22 <Remmy> and other bugs listed as major
20:25:25 <ennael> you can :)
20:25:38 <ennael> I will mail -dev about this specific subject
20:25:39 <Remmy> even when they are not *your* package or your area of expertise
20:25:50 <ennael> yes that was the meaning of this topic
20:25:59 <Remmy> help is most welcome if we want to have Mageia 2 a stable release
20:26:05 <Remmy> :)
20:26:19 <AL13N> can we have a list of such bugs related to packages without (active) maintainer?
20:26:31 <AL13N> i mean, specifically listed in the email itself (not a link to it)?
20:26:56 <marja> AL13N: I'll make a list
20:27:08 <Remmy> There are quite a few bugs related to the install process for example, but tv can't do them all by himself
20:27:13 <AL13N> i think it might help raise awareness
20:28:01 <Remmy> And if I may say something else on the subject?
20:28:09 <ennael> yep ?
20:28:33 <Remmy> We probably should set a target on how many blocking and major bugs we can have before releasing a rc
20:29:03 <ennael> well answer is rather simple
20:29:04 <Remmy> We are busy pushing beta after alpha out, but some important bugs get little love and attention
20:29:05 <AL13N> a daily countdown?
20:29:21 <ennael> 0 release_blocker bugs
20:29:27 <marja> AL13N: there is no need to make a list, I sorted it, all the ones assigned to bugsquad have no maintainer
20:29:31 <marja> AL13N: https://bugs.mageia.org/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=bugsquad%40mageia.org&emailtype1=substring&priority=release_blocker&query_format=advanced&order=assigned_to%2Cbug_id%20DESC&query_based_on=
20:29:33 <erzulie> [ Bug List ]
20:29:43 <ennael> so there is 2 solutions
20:29:47 <ennael> either it's fixed
20:29:57 <AL13N> marja: thx
20:29:58 <ennael> or some of them can downgraded
20:30:01 <ennael> be
20:30:12 <Remmy> And perhaps a few need upgrading too :(
20:30:17 <ennael> maybe
20:30:34 <ennael> so please do not hesitate to ask on irc or on -dev if you have any doubt on this
20:30:56 <ennael> if we need more time than expected then we will delay this release
20:31:04 <ennael> but still we have some time left
20:31:15 <Remmy> We can do a "bug of the day" thing, but I fear it will be the usual suspects who'll have to work on it.
20:31:31 <ennael> well let's try
20:32:07 <Remmy> Ok
20:32:25 <ennael> we can plan this now ?
20:32:26 <Remmy> I'll fully commit leuhmanu to this :P
20:32:34 * Remmy looks at Marja
20:32:35 <AL13N> :)
20:32:35 <marja> grinz
20:32:49 <Remmy> I think bugsquad can beat some drums the next weeks
20:33:36 <ennael> what about starting friday until monday ?
20:33:48 <ennael> to have we inside
20:33:54 <marja> yep.... and if ennael is willing to provide us with some matches :)
20:34:06 <marja> ennael: OK
20:34:22 <Remmy> ennael: Will have to check with leuhmanu, but I think we can do this :-)
20:34:22 <ennael> can we work on blog announcement after meeting?
20:35:36 <Remmy> Uhm, I hope to do bed then... but I'm available from 6 am onwards
20:35:47 <ennael> ok no pb
20:36:10 <ennael> anything else on that topic ?
20:36:34 <Remmy> Not from me.
20:36:44 <AL13N> one more slightly related thing
20:36:44 <coincoin> yep
20:36:53 <ennael> shoot
20:37:21 <coincoin> on my side I've got a lot of issues since systemd... I think it could be a good pooint to ask for more and more debug/test on this. what do you think?
20:37:23 <AL13N> the distrib/cauldron/x86_64/ on mirrors has a index.html page or something, in mageia website thema colors, it should get updated also
20:37:36 <coincoin> don't you have issues with network, boot time, services?...
20:37:37 <ennael> coincoin: this is part of the topic
20:37:53 <ennael> AL13N: ?
20:38:02 <coincoin> ennael: yes but no many improvments on my bugs about systemd for weeks
20:38:13 <ennael> coincoin: this is part of the topic :)
20:38:26 <AL13N> ennael: is this release blocker bug, or is this something that is done only at final release time?
20:38:37 <ennael> AL13N: I don't understand your point :)
20:38:55 <coincoin> ennael: yes, I was just pointing this out :)
20:39:36 <ennael> ok next topic
20:39:40 <AL13N> i don't know if this is a bug to be taken care of, or that this is normal, because it's only updated at release time
20:39:48 <coincoin> AL13N: kamoulox
20:40:02 <ennael> AL13N: all artwork is done before release
20:40:12 <ennael> #topic security updates before final release
20:40:17 <AL13N> coincoin: wut?
20:40:28 <ennael> I will open a tracker about security updates
20:40:46 <ennael> we usually did it in mdv so that major security updates can be solved before release
20:40:56 <ennael> I will mail about this
20:41:22 <ennael> is that clear ?
20:41:26 <AL13N> yes
20:41:32 <ennael> looks like people are dead tonight
20:41:56 <mitya> we are listening with great attention! :) good evening
20:42:03 <ennael> :)
20:42:08 <Remmy> Can't we assign all the work to the dead people?
20:42:09 <ennael> ok last topic then
20:42:12 <ennael> #topic QA tests for upgrade
20:42:28 <ennael> this is just a reminder for tests
20:42:45 <ennael> so that upgrade can be done without bugs
20:42:50 <ennael> QA team ?
20:43:12 <coincoin> yep
20:43:12 <rindolf> ennael: I'm not part of the QA team but I'm waiting for the Live CD/DVD.
20:43:31 <coincoin> so, QA Team will start tomorrow upgrade tests from 1 to 2
20:43:39 <ennael> rindolf: one topic at a time please
20:43:48 <ennael> ok
20:43:52 <coincoin> I will send a process (in fact quite the same I used for the upgrade from 2010.2 to 1)
20:44:05 <coincoin> we will see with bugsquad to have a tracker for upgrade issues
20:44:13 <ennael> as a reminder mageia support officially mga1 => mga2 only
20:44:21 <ennael> coincoin: I guess it's already there
20:44:39 <ennael> https://bugs.mageia.org/show_bug.cgi?id=3342
20:44:41 <erzulie> [ Bug 3342 - [Tracker] Upgrade Mga 1 > Mga 2 ]
20:44:54 <coincoin> thx
20:45:11 * ennael forgot action/info
20:45:22 <coincoin> the idea will to setup 3 teams: installer, desktop and apps/services
20:45:22 <ennael> #info as a reminder mageia support officially mga1 => mga2 only
20:45:41 <coincoin> stormi: something to add on this topic?
20:45:46 <ennael> #action upgrade tests will start tomorrow
20:46:25 <Remmy> Is there anyone that needs help with their tasks? I realise ennael is alone as release manager for example, or the live cd thing is solely with tmb now, etc.
20:46:33 <coincoin> we also plan to have test days like last years during with RC
20:46:48 <coincoin> Remmy: join QA! :)
20:46:50 <ennael> coincoin: carefull RC time is short
20:47:00 <ennael> coincoin: so it should start just after RC release
20:47:09 <coincoin> ennael: yes but we noticed last year that ppl only test in RC... :/
20:47:16 <coincoin> ok so let's try before
20:47:28 <Remmy> coincoin: As soon as I finish all open work on the teams I'm on already ;)
20:47:52 <ennael> anything else to add ?
20:48:06 <coincoin> not for me
20:48:20 <ennael> short meeting so that we can go back to work :)
20:48:28 <coincoin> he he
20:48:37 <ennael> about live cds we are still waiting some news about it
20:48:46 <ennael> tmb is still on it
20:49:04 <ennael> we will mail as soon as it's available for tests
20:49:10 * AL13N thinks alot of people test only livecds
20:49:19 <Remmy> If we can help in any way, I hope he'll let us know
20:49:24 <ennael> sure
20:49:35 <AL13N> will the dual arch be also there?
20:49:53 * ennael has to deal with husband for this :)
20:50:03 <AL13N> ic
20:50:20 <ennael> erwan is the one working on syslinux update and overloaded
20:50:23 <ennael> will try to manage this
20:50:45 <ennael> finally just a word about elections
20:50:50 * AL13N gives ennael a whip
20:50:59 <ennael> nobody applied for now
20:51:09 <Remmy> you're not nobody
20:51:13 <AL13N> i read Anne Nicolas applied
20:51:13 <ennael> I mailed directly sime people to ask them for applying
20:51:24 <ennael> well I will not go alone
20:51:27 <AL13N> i asked Anssi, but he didn't have the time, he said
20:51:45 <ennael> so I will try to get answers as soon as possible
20:51:54 <ennael> I guess we can go on like this for now
20:52:00 <ennael> priority is on release
20:52:01 <AL13N> sorry
20:52:02 <Remmy> If no one steps forward, what would that mean?
20:52:14 <dlucio> ehlo
20:52:17 <ennael> Remmy: sombody at least will
20:52:24 <ennael> or I will have to use matches
20:52:46 <Remmy> I would, but I don't have the necessary experience and skills yet.
20:52:46 <ennael> :)
20:52:53 <dlucio> i'm fixing ss5, but it stucks when starting services. it seems it calls /bin/systemd-tty-ask-password-agent --watch.  have any clue?
20:52:55 <Remmy> I can lend you my matches though.
20:53:00 <ennael> anything else to add on this meeting ?
20:53:07 <ennael> dlucio: meeting in progress
20:53:12 <dlucio> sorry
20:53:20 <ennael> no pb
20:53:31 <AL13N> i would guess it's about to end
20:53:51 <ennael> ok then triage, test, bug fix \o/
20:53:56 <ennael> #endmeeting