20:13:26 <ennael> #startmeeting
20:13:26 <Inigo_Montoya`> Meeting started Wed Feb 15 20:13:26 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:13:26 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:13:29 <erzulie> [ MeetBot - Debian Wiki ]
20:15:04 <ennael> #topic Mageia 2 beta 1 release
20:16:01 <ennael> ok so first topic is about beta 1 release
20:16:28 <sebsebseb> Beta 1 :)
20:18:13 <misc> yes ?
20:19:59 <jcapik> hello
20:20:43 * misc think ennael had a emergency
20:20:50 <misc> ( or a network problem )
20:20:58 <sebsebseb> yep something has happended
20:21:02 <sebsebseb> jcapik: hello
20:21:11 <ennael> sorry dual in progress at same time
20:22:52 <jcapik> Has anybody experienced problems with booting the latest 3.2.6 kernel? it seems the xz compression of modules is not handled correctly
20:23:17 <misc> jcapik: there is a meeting in progress  ( even if it doesn't look like now )
20:23:45 <AL13N> jcapik: there's stuff on the mailing list about it
20:23:48 <ennael> misc: can you start please...
20:24:06 <AL13N> needs chair command, i think
20:24:09 <jcapik> misc: sorry :]
20:24:56 <misc> ennael: provided I know what to say
20:26:07 <jcapik> AL13N: thx
20:26:10 <AL13N> or we can just wait a bit, no harm in a bit of waiting
20:27:06 <rindolf> AL13N: well, I need to go to sleep sooner or later as it's 22:26 here *and* I have work tomorrow.
20:27:18 <ennael> ko
20:27:20 <ennael> opk
20:27:22 <ennael> raaaa
20:27:26 <ennael> so about beta1
20:27:37 <ennael> as usual we have to update release page
20:27:38 <ennael> https://wiki.mageia.org/en/Mageia_2_beta1
20:27:39 <erzulie> [ Mageia 2 beta1 - Mageia wiki ]
20:28:00 <ennael> tmb started it but we need as much information as possible
20:28:50 <ennael> again this is important as all communication is based on this page
20:29:25 <ennael> would be nice to have some input about burning topics like systemd for example
20:29:34 <ennael> and also fill errata if needed
20:29:42 <leuhmanu> thierry started also https://wiki.mageia.org/en/Mageia_2_Release_Notes
20:29:43 <erzulie> [ Mageia 2 Release Notes - Mageia wiki ]
20:29:49 <misc> and know bugs, yes
20:30:27 <ennael> leuhmanu: let focus on beta 1
20:30:38 <ennael> final release is not for next week
20:30:45 <andre999> I noticed that tmb posted on the dev list that systemd is the default for mga2 - but I understood that sysvinit remains the default
20:31:37 <misc> andre999: this should be discussed on the ml
20:31:44 <misc> ( and not in a unrelated topic )
20:31:48 <AL13N> andre999: (that was a misconception of some people, systemd will be default sysvinit supported)
20:31:50 <andre999> misc: ok :)
20:32:14 <grenoya> ennael: is it alpha3 -> beta1 specific or mga1 -> mga2b1 ?
20:32:24 <ennael> ?
20:32:44 <AL13N> the https://wiki.mageia.org/en/Mageia_2_beta1 ?
20:32:45 <erzulie> [ Mageia 2 beta1 - Mageia wiki ]
20:33:11 <AL13N> nothing changed for mariadb between alpha3 and beta1
20:33:19 <AL13N> do i need to put it there still?
20:33:23 <grenoya> the first page, we need to explain that is new in mga2 (and yet impletented) or what is new in beta1 compared to alpha
20:33:36 <ennael> as this is a big change I guess we can keep it
20:33:55 <AL13N> k
20:34:24 <grenoya> so compared to mga1
20:34:48 <ennael> isos build has started
20:34:52 <ennael> dvds for now
20:35:02 <ennael> we may have dual cd
20:35:07 <ennael> and tmb is working on live cds
20:35:59 <ennael> we still need volunteers for QA, people available until 21/à2
20:36:02 <ennael> 21/02
20:37:28 <ennael> what we will need after beta1 is really to focus on debug main topics as stated in a previous mail
20:38:27 <ennael> together with http://check.mageia.org/
20:38:27 <erzulie> [ QA global report ]
20:39:59 <ennael> anything to add on this ?
20:40:29 <misc> not for me
20:41:16 <doktor5000> is someone working on kde during mikala's absence?
20:41:56 <ennael> luc menut and dmorgan for some pieces
20:44:21 <ennael> anything else ?
20:45:38 <ennael> oh of course as a reminder please avoid major update until 21/02
20:45:59 <ennael> we may have to sync again local repository
20:47:56 <doktor5000> maybe lay some boobytraps for funda on important packages? ;)
20:48:05 <ennael> joker
20:48:13 <ennael> anything else?
20:48:48 <ennael> #topic Version freeze reminder
20:48:56 <ennael> ok this topic is a short reminder
20:49:14 <ennael> do you all see what is exactly a version freeze ?
20:49:37 <Stormi> yes
20:49:45 <sebsebseb> yes
20:50:02 <Motoko> Yes
20:50:07 <grenoya> yes
20:50:27 <AL13N> yes
20:50:36 <andre999> yes
20:50:40 <ennael> ok so it's planned for 07/03
20:50:41 <rindolf> Yes.
20:50:48 <sebsebseb> a version freeze, freezing everything,  no new later versions of packages, unless with very good reason. (and I am not even doing packaging and have an idea what one is)
20:51:14 <ennael> you will not be able to submit new version anymore
20:51:16 <rindolf> Can I add new packages?
20:51:33 <ennael> only some people will be able to submit in case of very good reason
20:51:41 <ennael> new packages are ok
20:51:52 <ennael> but this time should be dedicated to fix bugs
20:52:16 <ennael> meaning you will have to ask for it on -dev ML
20:52:25 <sebsebseb> yep exactly a version freeze should be mainly about fixing bugs
20:52:35 <misc> how do we decide who can submit ?
20:53:09 <ennael> imho should be advanced packagers
20:53:16 <ennael> experienced one
20:54:08 <jcapik> ennael: 07/03 is quite early
20:54:15 <Nanar> define "experienced" please...
20:54:31 <Nanar> jcapik: it's always too early
20:54:31 <ennael> meaning worked on distro for a long time
20:54:42 <ennael> this is only my point of view :)
20:55:09 <ennael> people who are aware of consequences of submitting a new version
20:55:09 <Nanar> someone who already broke all install around the world ? /o\
20:55:14 <ennael> :)
20:55:39 <AL13N> you could have a peer-invited group starting with packager team leaders
20:55:43 <AL13N> put it into ldap
20:55:47 <AL13N> and do it like that
20:55:59 <misc> Nanar: someone that know we can find him and break knees
20:56:15 <AL13N> so Nanar is one of them :-)
20:56:47 <misc> AL13N: well, while that's a good idea, I am still not sure that people are team leader or team representant
20:57:05 <AL13N> misc: take both of them just in case
20:57:43 <AL13N> if they have been elected once, they are likely experienced packagers
20:57:44 <ennael> we have to have several people
20:57:50 <AL13N> and peer-invited
20:57:57 <AL13N> so those people can invite other people into the ldap group
20:58:11 <AL13N> or you know "chinese volunteered"
20:58:18 <ennael> and this is important also after release freeze as they need to be available to do it
20:58:44 <AL13N> if necessary, you can invite more
20:58:46 <Nanar> we can ask for volunteer
20:58:59 <AL13N> we should appoint, not ask for volunteer :-P
20:59:10 <Nanar> but we'll have to reject some young packagers
20:59:12 <misc> well, let's start by putting ennael and she do the peer stuff
20:59:17 <AL13N> good
20:59:26 <doktor5000> misc: AFAIK there is no packaging team leaders, and you and ennael are representatives
20:59:31 <AL13N> if anyone rejects, they can be taken off the list
20:59:44 <Nanar> I am volunteer then
21:00:04 <ennael> misc: hey
21:00:06 <misc> doktor5000: yeah, but people keep talking of leader, so I am unclear about my own statut
21:00:08 <AL13N> for the prerelease QA testing?
21:00:30 <ennael> ok so we need to think about this
21:00:44 <ennael> anything else on version freeze ?
21:00:45 <doktor5000> misc: well, i can fix it in the wiki, then you both are leader and representative (not that this would change anything in practice IMHO)
21:01:57 <misc> doktor5000: while I do not care about the title really ( or we would have used something greater, dictator have good idea usually ), I am more concerned about the way people become what they are and what they elect
21:02:38 <AL13N> yes, but is this important atm? i mean, likely after board election, there's another team election round?
21:02:45 <ennael> can we go to next topic ?
21:02:46 <AL13N> can we just do next topic pls?
21:02:49 <misc> anyway, I guess we can start by the people in the group to create iso, since we trust them enough to do the iso
21:02:59 <misc> ennael: we can
21:03:06 <doktor5000> misc: maybe should be continued in a council meeting ...
21:03:09 <doktor5000> ennael: yes please
21:03:12 <misc> I will send a email on -dev to see what people think
21:03:14 <ennael> this has to be decided in coming week
21:03:17 <ennael> ok
21:03:27 <ennael> #topic Updates advisories
21:03:43 <ennael> this topic comes from people working on updates
21:03:54 <misc> doktor5000: on the ml, no need to discuss with everybody while that's purely for packagers to organise among themself ( I mean this will likely bore everybody else )
21:04:06 <ennael> it seems some packagers just do not want or forget to write advisories
21:04:30 <ennael> this is just a reminder as it's part of packager duties to write it
21:05:20 <doktor5000> or some do drive-by updates and forget to notify maintainer that there's a security update needing validation (and rotting on the mirrors with noone knowing about it)
21:05:57 <doktor5000> more on-topic, here's an example advisory: https://wiki.mageia.org/en/Example_update_advisory_announcement
21:05:58 <erzulie> [ Example update advisory announcement - Mageia wiki ]
21:06:04 <misc> i guess automated mail sending to the maintainer when something is sent to updates-testing would help
21:08:24 <ennael> can you think about this?
21:08:37 <misc> thinking, yes
21:08:44 <ennael> :)
21:08:54 <misc> doing, yes, but in a geological or galactical timeframe
21:08:54 <doktor5000> ennael: maybe needs an #action for everyone
21:08:54 <anaselli> there's another issue i found, when you reassing bug to qa, you will be removed from bug, so you're not in cc, I've realized it when i first wrote advisory and then re assing the bug
21:09:08 <Bertl> wouldn't it be better to somehow integrate that into the submission?
21:09:34 <leuhmanu> anaselli: check your pref email in the bugzilla
21:09:43 <doktor5000> anaselli: triage team/qa will normally re-CC you if you forget ;)
21:09:52 <leuhmanu> as default it add you un cc when you add a comment
21:09:52 <AL13N> ah yes, i've seen that happen too
21:10:21 <AL13N> if you're assigned, but it's wrong or need more info or whatever, you're not on CC anymore
21:10:24 <doktor5000> leuhmanu: happens with default pref's
21:10:25 <AL13N> kind of irritating
21:10:26 <misc> Bertl: the exact details on how we do it is not important for now, if someone submit a patch, i guess we will accept it
21:10:30 <anaselli> abd that is, leuhmanu but if you reassign it after adding a comment you are out of it
21:10:45 <leuhmanu> https://bugs.mageia.org/userprefs.cgi?tab=settings
21:10:46 <erzulie> [ Log in to Bugzilla ]
21:10:49 <anaselli> i mean you were the assignee
21:10:58 <leuhmanu> indeed
21:11:40 <leuhmanu> seemsit was changed
21:12:04 <Bertl> misc: no, what I meant was (and please clarify if I got that one wrong), the update advisory should be done when a package/change gets 'submitted' to updates-testing
21:12:40 <Bertl> misc: so wouldn't it make sense to create the advisory in the process instead of 'not forgetting to do it'
21:12:56 <anaselli> leuhmanu: what should i change in my settings?
21:13:01 <misc> Bertl: that would just block sooner
21:13:27 <misc> and we cannot force people to write advisory when they submit
21:13:33 <doktor5000> is any work on https://bugs.mageia.org/show_bug.cgi?id=2223 planned, BTW?
21:13:35 <erzulie> [ Bug 2223 - no update advisories in rpmdrake ]
21:13:36 <leuhmanu> Bertl: there should be advisory in rpmdrake, but seems nobody know how it's work
21:13:48 <leuhmanu> (to late :) )
21:13:54 <doktor5000> leuhmanu: see ^^^ above bug
21:13:54 <anaselli> Automatically add me to the CC list of bugs I change?
21:14:08 <leuhmanu> anaselli: yes Automatically add me to the CC list of bugs I change
21:14:12 <misc> ( i mean, we cannot for technical reason for now, we can add it with enough code )
21:14:27 <doktor5000> anaselli: https://bugs.mageia.org/userprefs.cgi?tab=email and click on enable all mail ;)
21:14:28 <erzulie> [ Log in to Bugzilla ]
21:14:35 <anaselli> why th e default is only if i have no rike of them
21:14:47 <anaselli> all it's ok there
21:15:09 <leuhmanu> anaselli: take always
21:15:09 <AL13N> ok, so the only thing we can do is having QA team reject the updates until the advisory is there
21:15:15 <AL13N> and bug the packager in question
21:15:27 <anaselli> leuhmanu: should be for maintainers
21:15:35 <doktor5000> AL13N: that's what they always do
21:15:39 <anaselli> and who does not want can remove it imo
21:16:25 <AL13N> doktor5000: i don't think there's anything else we can do
21:16:32 <doktor5000> ennael: maybe an #action for dmorgan/bkor to check default bugzilla preferences?
21:16:44 <andre999> anaselli: I have everything except the cc field changes checked, which works for me
21:16:48 <AL13N> if it comes to that, perhaps we can block svn for that package or something, if people don't listen
21:16:52 <leuhmanu> (the bugsquad/qa/other, can also add packagers in the cc)
21:17:13 <AL13N> or reject packaging status for the person who doesn't do it
21:17:29 <AL13N> bump them back to padawan
21:18:09 <AL13N> so, anything useful on this topic?
21:18:42 <andre999> AL13N: agree QA should reject without advisory
21:19:14 <doktor5000> andre999: that's what they already do, and they do a really good job IMHO
21:19:51 <AL13N> ok, so that's it for this topic then? next topic?
21:19:59 <andre999> doktor5000: I thought so.  I agree they do a great job
21:20:20 <ennael> ok
21:20:41 <ennael> #topic Use of new servers
21:20:45 <ennael> misc: your turn
21:21:01 <misc> ok so that will be rather quick
21:21:28 <misc> as i said ( or as I tought have said ) on the sysadm list, we have setup news servers, and this will impact packagers in 2 ways :
21:21:32 <misc> - arm node
21:21:43 <misc> - new server for packagers/qa access
21:21:57 <Bertl> s/news/new/ I presume
21:22:06 <misc> Bertl: yes
21:22:18 <misc> so for the arm nodes, they are plugged
21:22:31 <misc> not puppet managed yet ( not even properly networked )
21:23:05 <misc> so the BS for arm is not ready, and there is still some work to do
21:23:35 <misc> no ETA for that, but we will wan of progress on that front, and server will be used to rebuild packages from cauldron
21:23:57 <misc> #info arm nodes are plugged and need to be integrated into the BS
21:24:09 <misc> so for the 2nd server, we have more important news
21:24:22 <Bertl> sorry for the (maybe stupid) question: what architecture are planned for mageia?
21:24:51 <AL13N> afaik ARM v5 and later on v7
21:24:58 <misc> x86 and x86_64 for now, arm ( see rtp for details ), and whatever people can work on, provided they manage to get us hardware and do the work
21:25:01 <anaselli> mageia2?
21:25:34 <Bertl> has anybody considered putting the buildsystem (for various archs) into a qemu guest?
21:25:34 <misc> anaselli: no
21:25:46 <anaselli> ah ok
21:26:05 <misc> Bertl: yes,  and see with rtp for detail of why we will likely not do it
21:26:15 <Bertl> okay, tx
21:26:33 <misc> ( at least, not for the package used for the distribution , I was thinking of it for the 2nd part of the topic, but since people keep interrupting me, I cannot speak of it )
21:27:23 <misc> ok so
21:27:37 <misc> the 2nd part
21:28:04 <misc> we racked a new server, called sukuc ( or sucuk, never know )
21:28:39 <misc> we first tought of doing like klama when it was used at mandrake, ie a server where anybody can build
21:28:42 <misc> and use iurt
21:29:26 <misc> except that du to technical issue, we cannot let people use iurt as they would become root on the server
21:29:58 <misc> so the proposla that was made would be :
21:30:08 <misc> people connect to the server, and can request a vm
21:30:29 <misc> once the request is made, a fresh vm is installed, where the user is root, connected with his ssh keys
21:30:52 <misc> we erase old vm after a time, and people can use them to either build, or test packages ( for QA )
21:31:16 <misc> we didn't do any work on it yet, but would that satisfy the need of people so far ?
21:31:39 <Bertl> you know that there is also Linux-VServer?
21:31:44 <Nanar> won't this overload the server if everyone request a vm ?
21:31:58 <Bertl> i.e. you could give root without compromising the host
21:32:25 <AL13N> well, i guess when requesting it, one checks the resources and rejects with too much resources, try again later
21:32:30 <misc> Nanar: yes, but we can just decide to put limitation
21:32:37 <doktor5000> any disk space quotas planned? and is there any info page about that new server?
21:32:49 <misc> Bertl: yes, we know, but I would prefer to use something that is in the vanilla kernel
21:33:16 <Bertl> LXC then, but it isn't secure (yet)
21:34:12 <misc> lxc is also more complex to integrate, while we already have a working stack for virtualisation
21:34:36 <AL13N> i don't think kvm has alot of extra overhead?
21:34:41 <Bertl> but you are losing a lot of performance and resources to full system virtualization
21:34:55 <misc> anyway, i think that's implementation detail, and for people running a script that create stuff for them to do ssh , that's not different
21:35:36 <misc> and people who wish to work on this can contact sysadmin to see how to push that to puppet
21:35:59 <misc> but what is important here is if such service would be useful or not
21:36:14 <misc> ie, do people want more, less, something different ?
21:36:39 <misc> ( like a server to do scratch build, or would a shared server with all packager be ok, or something else ) ?
21:36:49 <doktor5000> misc: sounds good to have it at all
21:37:00 <AL13N> personally, mostly i build using chroots myself, but it can be helpful sometimes if there is something weird about the build locally and not on BS
21:38:00 <Bertl> well, the question is, who wouldn't be able to quickly setup a full virtualization install (qemu/kvm) in a few minutes at home?
21:38:20 * Nanar have its own server
21:38:22 <AL13N> Bertl: people lacking the resources and finances
21:38:24 <Bertl> (nowadays that's not really complicated for x86/32/64
21:38:37 <AL13N> i've seen people on a netbook
21:38:50 <Bertl> I've wenn qemu on a netbook :)
21:38:54 <Bertl> *seen
21:38:55 <misc> or people who have a low badnwidht connexion
21:39:04 <misc> ( or who are moving between flat )
21:39:08 <Nanar> something interesting is to be able to get quickly a computer for any version/arch of mageia (eg previous release)
21:39:30 <AL13N> well, in any case, sometimes there's something different at home vs BS and you can't find it, so for that purpose, it sounds great
21:39:36 <Nanar> to test compatibility, of making update
21:39:37 <anaselli> misc: my big problem is whe uploading big source tarball from home... I think a server in which i can do that with more band is good
21:39:38 <Bertl> IMHO build environments for different (than x86) archs would be really interesting, even if they are in qemu for example
21:39:40 <misc> or people who are using mobile broadban
21:39:49 <doktor5000> or people who want to test bigger builds (like libreoffice, 50-60GB+) and can't locally
21:40:01 <Bertl> good point
21:40:16 <Bertl> e.g. tex build takes what? 500GB?
21:40:29 <misc> Bertl: for now, we do not have a BS for arm, so that's too soon to discuss, but yet, that what i attempted, be able to run qemu-arm with libvirt ( and there was some bug that I wanted to address in virtinst )
21:41:24 <Bertl> fair enough, let's postpone that one
21:41:53 <jcapik> misc: I have a pandaboard rev A3 here
21:42:09 <jcapik> misc: I can share it if needed
21:42:17 <misc> jcapik: we do have a pandaboard too, but there is a *herm* problem with the kernel :)
21:42:22 <misc> but see with rtp
21:43:16 <misc> anyway, I guess we will see this on the ml if people have more ideas, and I will take a look at what was said ( and also, we can change later the setup if that's not suitable )
21:43:59 <philippeM> this vm solution seems good yes, a server to do scratch build may help too if it is possible to set up
21:44:21 <misc> next topic ?
21:44:45 <misc> philippeM: everything is possible, provided a infinite amount of time and contribution :)
21:44:59 <doktor5000> misc: yep
21:45:52 * misc check the list
21:46:19 <AL13N> ok
21:46:34 <misc> #topic GSOC 2012
21:46:43 <misc> ennael ....
21:47:09 <misc> #info new server to be used for providing system to packagers and QA for build and test
21:47:19 * misc cannot change the topic
21:47:54 <AL13N> misc: you're not the chair
21:47:55 <grenoya> misc: so all your 'info' have to be done again too
21:48:24 <misc> grenoya: afaik, everybody can do #info ( or at least should be )
21:49:17 <ennael> back
21:49:18 <misc> ok so I cannot even close the meeting
21:49:25 <Nanar> we're waiting ennael ?
21:49:37 * Nanar hides
21:49:40 <pterjan> I saw her!
21:49:42 <ennael> tsss
21:50:00 <ennael> #topic GSOC 2012
21:50:15 <misc> thanks :)
21:50:15 <ennael> #chair misc
21:50:15 <Inigo_Montoya`> Current chairs: ennael misc
21:50:48 <misc> so ? ir posed on -discuss, and during the council meeting, i proposed to participate to Google Summer of Code 2012
21:50:56 <misc> but first, does everybody see what it is ?
21:52:26 <grenoya> misc: not really
21:52:35 <Nanar> http://code.google.com/soc/
21:52:35 <erzulie> [ Google Summer of Code - Google Code ]
21:53:22 <misc> ok so the idea is to have people who are basically google trainee, paid to work on a project for 2 monts, mentored by someone from the community
21:53:46 <misc> to participate as a trainee, there is some condition ( being a student, etc )
21:54:04 <misc> to participate as a organisation that will take student, there is some work to do :
21:54:21 <misc> - fill some papers for the candidacy
21:54:48 <misc> - propose some project, have someone to take care of the projects ( ie, serve as mentor for the student )
21:55:11 <misc> I posted http://permalink.gmane.org/gmane.linux.mageia.user/6120 to explain what is left to do
21:55:11 <erzulie> [ GSOC 2012 ]
21:55:24 <Nanar> who paid ?
21:55:34 <misc> Nanar: google
21:56:03 <misc> so what we need is some project idea to fill https://wiki.mageia.org/en/SummerOfCode2012
21:56:03 <grenoya> Nanar: you want a student for Sophie ? :)
21:56:03 <erzulie> [ SummerOfCode2012 - Mageia wiki ]
21:56:25 <Nanar> I already have slave for that
21:56:29 <misc> if you add a project, it need to have 1 mentor, and one backup, or will be erased
21:56:30 <Nanar> salves
21:56:47 <misc> so you can add something, but we will do a cleaning before sending them
21:57:05 <pterjan> I had mane some propositions for Mandriva many years ago
21:57:18 <misc> also, we need someone to fill the TODO on the page
21:57:23 <pterjan> to have youri-check use a db with historic values
21:57:27 <pterjan> and a dynamic interface
21:57:57 <Nanar> the BS can be a good candidate
21:58:03 <pterjan> I should try to find how I wrote it at that time :)
21:58:15 <misc> there is lots of idea, what we need is 2 volunteer to mentor
21:58:30 <Nanar> this part is probably the hardest things
21:58:41 <misc> please also keep in mind that the goal is to have people to enter the community, so that should not be too hard or too complex
21:58:49 * pterjan can mentor some things
21:58:54 <Nanar> where the students will be hosted during these two months ?
21:59:03 <misc> Nanar: where they want
21:59:04 <pterjan> Nanar: in their homes ?
21:59:10 <misc> that's done online
21:59:41 <Nanar> ok
21:59:48 <pterjan> they get some money to work on the project so that they don't need a summer job and can contribute instead
22:00:18 <Nanar> so anyone having time can mentor
22:00:18 <pterjan> one problem is that some of them disappear after getting the first part
22:00:34 <pterjan> (before doing anything)
22:00:43 <AL13N> can i take a leave of absense from work and become a "student"?
22:00:44 <pterjan> there is a check in the middle that they progressed
22:00:45 <misc> hence the question "how to deal with disappearing student"
22:00:51 <Nanar> they are paid before coding ?
22:00:57 <misc> Nanar: nope
22:00:59 <pterjan> Al13N: if you register at university, yes
22:01:04 <AL13N> hmm
22:01:07 <misc> AL13N: if you manage to be a student ( ie, with a card )
22:01:15 <AL13N> do i get more money than my $dayjob?
22:01:17 <pterjan> misc: I think they do get part of it when they start
22:01:26 <pterjan> AL13N: I doubt it.
22:01:32 <AL13N> :(
22:01:34 <misc> anyway
22:01:52 <misc> #action proposes ideas ( and add mentor, or we will not bbe able to take them in account )
22:01:57 <Nanar> if google give them an android we'll have their location ! :)
22:02:07 <misc> #action fill the application if someone has idea
22:02:21 <pterjan> http://google-melange.appspot.com/document/show/gsoc_program/google/gsoc2010/faqs#administrivia
22:02:22 <erzulie> [ Google Summer of Code 2010 Frequently Asked Questions ]
22:02:31 <AL13N> well, even if they run away, at least they might do some partial job
22:02:33 <pterjan> 500 USD when starting
22:02:47 <pterjan> 2250 USD after mid-term evaluation
22:02:59 <pterjan> 2250 USD after final evaluation
22:03:16 <AL13N> 5k$ for 2 months
22:03:19 <pterjan> the org gets 500 USD per student after the final evaluation if they finished
22:03:24 <AL13N> is this a scholarship? ie: no taxes?
22:03:37 <misc> AL13N: again the goal is not only the work but more the integration of fresh blood
22:03:37 <pterjan> AL13N: I think so
22:03:57 <misc> so could we keep the current plan of stealing money from google for the end of the meeting
22:04:03 <AL13N> okok
22:04:09 <misc> ( and for a time there is no google people reading the chan :p )
22:04:14 <AL13N> lol
22:04:57 <AL13N> that's a lot of money, i wouldn't understand why people leave fo rit
22:05:11 <pterjan> it depends where you live
22:05:30 <pterjan> 5k in india is more than if you live in new york
22:05:40 <AL13N> well, considering students, and disregarding prostitutes...
22:05:46 <sebsebseb> This is one long packaging meeting :D.
22:06:10 <AL13N> even i don't have this much after tax deduction
22:06:13 <misc> AL13N: hum..
22:06:17 <AL13N> anyway
22:07:03 <AL13N> fresh blood, ok
22:07:15 <AL13N> so, is there a way to find fresh suitable blood?
22:07:43 <misc> that's the goal of the whole program, ie, google take care of announcing it
22:07:54 <AL13N> oic, interesting
22:08:07 <pterjan> but we can try on our lists to motivate users
22:08:23 <pterjan> it's better if they already know mageia and are interested in it
22:08:37 <AL13N> perhaps people know of some developers/sysadmin students that would want to help
22:08:42 <pterjan> it's more likely that they continue contributing
22:08:47 <Nanar> do we have students as packagers or coders ?
22:09:23 <AL13N> the name suggests only coding
22:09:24 * pterjan doesn't know
22:09:48 <pterjan> yes it will be coding, but some current packagers can be interested
22:09:54 <AL13N> is the proposal rejected if it's not hard enough?
22:10:29 <misc> well, if that's something that would take 1 week, I think we should maybe not propose it :)
22:10:33 <pterjan> if we don't have interesting enough proposals we will be rejected
22:10:46 <misc> we cannot send people do paper copy if they have nothing to do
22:10:58 <AL13N> what about the backports issue, which is long-standing?
22:11:30 <pterjan> gnome had many successful gsoc, like Cheese
22:11:41 <pterjan> 2 months is enough to write a large piece of code
22:11:48 <AL13N> hmm, interesting, /me goes reading up on it
22:12:13 <misc> anyway, if you want to discuss, please discuss on -discuss
22:12:24 <misc> as we are rather late
22:12:28 <AL13N> k
22:12:34 <misc> so thanks for coming
22:12:34 <AL13N> next topic then?
22:12:40 <doktor5000> misc: i've proposed an additional meeting topic already asked at other meeting (how to handle unresponsive maintainers)
22:12:41 <misc> that was the last one
22:12:50 <misc> doktor5000: oups, indeed, forgot
22:12:50 <Nanar> AL13N: yes, next topic is sleeping
22:12:59 <AL13N> Nanar: not yet
22:13:02 <misc> #topic how to handle unresponsive maintainer
22:13:07 <misc> doktor5000: go for it
22:14:13 <doktor5000> i.e. what do we do if we want/try to contact a maintainer, either via IRC (some are not on IRC) and then via mail, and they do not respond after a timeframe of say 2-4 weeks
22:14:48 <Bertl> build a voodoo doll?
22:14:59 <doktor5000> like happend to me with f.ex. eandry, as i tried to point some usb_modeswitch issues to him, and possible solutions, as he's the maintainer, and he didn't respond
22:15:31 <misc> well, we can either see if we can contact harder
22:15:42 <pterjan> or make it unmaintained
22:15:48 <misc> ( ie, try to see if he gave a phone, if someone know him IRL )
22:15:54 <doktor5000> or for spturtle (but thankfull he responded in between, after ~7 months absence and is looking at iceape security issues now
22:15:57 <misc> and/or make it unmaintained
22:16:04 <misc> fedora has a procedure for that
22:16:54 <doktor5000> didn't really want to call names, but we have to handle that somehow
22:16:55 <AL13N> it would be interesting if there was a way to have contact info for packages, and to list which ones he wants to have publicly accessible or not (could even be a GSoC)
22:17:12 <AL13N> *packagers
22:17:15 <misc> https://fedoraproject.org/wiki/PackageMaintainers/Policy/NonResponsiveMaintainers
22:17:18 <erzulie> [ Policy for nonresponsive package maintainers - FedoraProject ]
22:18:12 <doktor5000> misc: i'll import that into our wiki, and then set it up for discussion via mail on -dev, ok?
22:18:22 <misc> didn't found one for debian or opensuse or others, but this could be interesting to see how they do
22:18:36 <Bertl> debian doesn't care
22:18:43 <Nanar> sound good for me
22:18:54 <AL13N> hmm, debian would have been a good comparison point for us
22:19:01 <misc> doktor5000: I would rather discuss first and then import in the wiki :)
22:19:17 <misc> but yes, maybe importing would help to have a common discussion point
22:19:19 <AL13N> doktor5000: or just mention on the wiki it's a "proposal"
22:19:31 <misc> I guess we can also mail distribut@freedesktop
22:20:23 <doktor5000> misc: AL13N: surely it's a proposal, if it's in our wiki doesn't mean it's set in stone and finalized, and actively enforced :)
22:21:17 <misc> doktor5000: well, i already made some proposal and people started to enforce it :/
22:21:46 <doktor5000> misc: like?
22:22:09 <AL13N> misc: must have been a good proposal :)
22:22:24 <misc> doktor5000: python @ mandriva
22:22:33 <misc> ( ok, it was a draft for 4 years, but still )
22:23:04 <AL13N> ok, so that's the end of meeting? can we go sleep now?
22:23:17 <misc> ( and started, mean after some time, like one or two year )
22:23:42 <misc> so if we place proposal, we should make it expire at a moment and say "this is now a real policy"
22:24:08 <doktor5000> so, is someone maybe in contact with eandry, or knows him in RL, and can ask what's going on?
22:24:41 <misc> well, i know he live in south of france
22:24:53 <Nanar> should we ask to people their real address ?
22:25:17 <misc> I would rather avoid it
22:25:27 <misc> or do it as a optin basis ( like now )
22:25:40 <AL13N> perhaps we could and use it as a very last resource only by sysadmin to contact person?
22:25:43 <Bertl> I don't think there is a point in 'hunting down' a maintainer
22:25:47 <Nanar> I am not propsing to have it public
22:25:55 <anaselli> so we should ask ennael when we go holidays? and to our boss... lol
22:26:07 <misc> well, there is no info for eandry
22:26:15 * anaselli jokes
22:26:19 <AL13N> well, we can notify people when we go on vacation, no?
22:26:20 <Bertl> either s/he cares or not, in the latter case, a new maintainer needs to be found or the package faded out
22:26:31 <misc> doktor5000: I guess you can upload and take ownership of the software
22:26:49 * doktor5000 did not propose a witchunt, BTW
22:27:22 <misc> he say that because he is a witch !
22:27:44 <Nanar> well
22:27:47 <misc> #action doktor5000 import the fedora policy to have a starting point and start the discussion
22:27:53 <doktor5000> misc: it's not my area of expertise, so i'd prefer someome more familiar with it to look at it, i can point out some problems and possible solutions
22:28:10 <misc> doktor5000: I doubt it is eandry speciality
22:28:21 <pterjan> %info doktor5000 is a witch
22:28:35 <misc> doktor5000: so go for it
22:28:42 <misc> doktor5000: cannot be worst than cups, you know :)
22:28:56 <anaselli> misc: it's not always easy to find a reporter who writes more than a comment, without been invoked though
22:29:10 <doktor5000> anyone familiar and/or wanting to fix usb_modeswitch who is not yet overloaded with other packages?
22:29:57 <anaselli> doktor5000: no and to be honest i've seen it working only in fedora... with my keys
22:30:15 <doktor5000> misc: i'd like someone available who's more familiar with kernel/drakx11/udev to look/help with it (leaves not so much people, sadly)
22:30:25 <pterjan> it used to work fine when I used it on mandriva few years ago, but havent' needed for more than a year
22:31:00 <misc> doktor5000: well, can we see after the meeting ( ie, in 30 secondes )
22:31:04 <anaselli> pterjan: unfortunately not with my keys...
22:31:13 <doktor5000> misc: sure
22:31:35 <anaselli> sorry too tired, will read the meeting report later tomorrow good night
22:31:46 <AL13N> anaselli: can't wait 30sec?
22:31:53 <anaselli> 29
22:31:57 <AL13N> :)
22:31:58 <anaselli> 28
22:31:58 <Nanar> AL13N: it's too late
22:32:01 <anaselli> :D
22:32:03 <Nanar> just too late
22:32:08 <misc> ok
22:32:11 <misc> thanks for coming
22:32:16 <misc> see you after the meeting
22:32:20 <misc> #endmeeting