20:13:42 <ennael> #startmeeting
20:13:42 <Inigo_Montoya> Meeting started Wed Nov 30 20:13:42 2011 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:13:42 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:13:44 <erzulie> [ MeetBot - Debian Wiki ]
20:13:55 <leuhmanu> hi
20:14:31 <sebsebseb> hi
20:14:55 <Umeaboy> I think I have an autoconf-issue.
20:15:08 <Umeaboy> Related to pulseaudio
20:15:12 <ennael> Umeaboy: meeting in progress please
20:15:14 <sebsebseb> Umeaboy: they have started a meeting here
20:15:15 <Umeaboy> OK.
20:15:18 <Umeaboy> Sorry.
20:15:46 <ennael> #topic Improve release process
20:16:16 <ennael> ok alpha1 is now out
20:16:53 <ennael> we spoke about it during council meeting as we really need to improve current process
20:17:21 <ryoshu> what went wrong?
20:17:51 <ennael> here are the main points to be improved: QA, release notes, packagers answers
20:18:24 <ennael> just have a look on release notes for alpha1 it's really light despite several mails asking for information to complete these release notes
20:19:22 <ennael> on that point misc proposed to packagers to take 1 or 2 package and explain what is new for alpha2
20:19:30 <ennael> and add it to release notes
20:20:33 <ennael> also would be nice to have weekly news from cauldron
20:20:40 <ennael> as we had in mdv
20:20:47 <ennael> it helps a lot to write release notes also
20:20:49 <ennael> wdyt ?
20:21:28 <doktor5000> ennael: currently i think up-to-date errata would be more useful, release notes maybe only later after beta1 or so
20:21:38 <ryoshu> also with 1-2 packages explained from every packager?
20:21:48 <ennael> doktor5000: not really
20:21:50 <Stormi> well, release notes help to test
20:21:57 <ennael> release notes help for tests
20:22:10 <ennael> but also to communicate
20:22:28 <ennael> most information web sites use relase notes to speak about dev releases
20:22:43 <ennael> if you do not provide any they don't speak about you
20:23:07 <ennael> also final release notes use all these dev release notes
20:23:10 <mitya> probably packages should be somehow ranked by importance - I don't think that it would be interesting for an end-user to read about some minor bugfixes in libfoobaz-1.2.3.rpm :)
20:23:49 <ennael> well at the moment we have nearly *no* informations
20:23:52 <ennael> -s
20:24:35 <ryoshu> ennael: I think it could be better to have a team (or a task for one team) - to read change-logs, collect information about the newest versions (KDE, Gnome, kernel, etc) and allow the packagers to do their work
20:25:13 <ennael> if packagers are not able to speak about their own package I don't see the point really...
20:26:00 <ryoshu> not everybody has time to package & write summaries :)
20:26:03 <obgr_seneca> And since we don't have extra people to do it, it would be best for those people knowing the packages best to do it
20:26:18 <obgr_seneca> And those people knowing best are the packagers!
20:26:26 <ennael> :)
20:26:56 <ennael> but we need also that weekly report for cauldron
20:27:09 <ennael> on wiki page for example, can be done by non packager
20:27:34 <AL13N> can't something like this be automated?
20:28:00 <ennael> you mean filtering a 50 mails thread and sum up it ? :)
20:28:17 <AL13N> hmm
20:28:23 <AL13N> i was thinking about svn logs
20:28:28 <AL13N> but maybe that's not really the point
20:28:51 <AL13N> and someone would have to decide the importance
20:29:03 <ennael> well it's not really about rewritting logs but gives the main points of some updates
20:29:15 <ennael> and what is important also for tests
20:29:18 <AL13N> to be honest, for me, it's not really that important, and i think this is better done by a single person
20:29:24 <doktor5000> AL13N: i think it's about abstraction at a greater scale, like gnome 3 changes & news, systemd migration and ...
20:29:31 <AL13N> right
20:29:34 <ennael> sure
20:29:45 <ennael> but still alpha 1 has no information about it
20:29:57 <ennael> except some very rare one I had to add on that wiki page
20:30:03 <AL13N> actually, perhaps this should be done by a non-packager, because that person looks from different perspective
20:30:07 <AL13N> more user perspective
20:30:23 <ryoshu> there is 1 single svn command to read a certain range of svn commits
20:30:34 <ennael> you cannot ask a non packager who is not specialist to write it
20:30:38 <doktor5000> AL13N: most non-packagers lack the needed information IMHO
20:30:45 <AL13N> that is true
20:30:55 <AL13N> but who will decide importance?
20:31:05 <ennael> for example speak about systemd modifications on boot process and explain what are the points to be tested
20:31:06 <AL13N> it's a tricky thing if you have multiple persons providing that
20:31:12 <Stormi> importance is not the most important problem :)
20:31:21 <AL13N> oic
20:31:22 <mitya> I guess SVN logs often contain much technical, low-level details; "release notes" is a public document, intended to be read by laymen :)
20:31:37 <ennael> better to have too many information than no information
20:31:40 <AL13N> ennael: so you mean, it's like if i'm doing mariadb and obsoleteing mysql, to tell people who to test mariadb and upgrade?
20:32:12 <ennael> AL13N: explain what is mariadb why we include it in mageia and some points about install and conf
20:32:16 <ennael> for example
20:32:34 <ennael> does not have to be that long but at least explain it
20:32:41 <sebsebseb> What's the weekly report from Cauldron?
20:32:41 <AL13N> hmm, i see your point
20:32:52 <ennael> sebsebseb: we had it in mdv
20:33:04 <ennael> I can't remember who was doing it
20:33:11 <ennael> I guess frederik himpe
20:33:27 <ennael> giving the main discussions and what was decided
20:33:47 <misc> the weekly report was done by gc, then me, then ofaurax, and then fhimpe
20:34:00 <ennael> ah :)
20:34:02 <ennael> hi misc :)
20:34:14 <misc> hi
20:34:20 <ennael> so would be nice to have volunteers to write it on wiki for example
20:35:13 <ryoshu> isn't 1 week too short time? I usually do just some minor changes like cleaning in this period of time
20:35:29 <ennael> can be longer
20:35:31 <ryoshu> or preparing a few packages
20:35:58 <misc> ryoshu: well, 1 week is usually already enough of changes
20:36:38 <ryoshu> maybe don't force everyone to write a summary in every week, but at least once a month
20:37:00 <ennael> we don't force anybody
20:37:08 <ennael> but 1 month is too long
20:37:13 <ennael> ask ofaurax...
20:37:30 <sebsebseb> Not really sure if this is what's being talked about, but maybe there should be some sort of team that looks after the wiki for example, and works together with the other teams, to make sure the wiki is how it should be?
20:37:50 <ryoshu> well I mean, release this report weekly, but people should put there something at least once / 4 weeks :)
20:38:54 <misc> ryoshu: I think we didn't really explain what was the weekly note before, or how it was done
20:39:15 <AL13N> tell us?
20:39:29 <misc> just let me find a link
20:39:32 <AL13N> k
20:40:00 <AL13N> btw: can ofaraux help us with this?
20:40:19 <ennael> http://artipc10.vub.ac.be/wordpress/2010/02/28/noteworthy-mandriva-cooker-changes-15-february-28-february-2010/
20:40:20 <erzulie> [ Noteworthy Mandriva Cooker changes 15 February - 28 February 2010 - Frederik's Blog ]
20:40:48 <mitya> also http://wiki.mandriva.com/en/Development/Weekly_News
20:40:48 <erzulie> [ Development/Weekly News - Mandriva Community Wiki ]
20:41:09 <misc> ( or the cooker weekly news in 2004 )
20:41:50 <AL13N> seeing that link, i think we should find someone who's not on this meeting, or at least, i think people not in this meeting but on -dev ML could likely do this
20:42:29 <misc> out of the 4 incarnations of the news letter, 3 were done by rather technical people
20:42:46 <AL13N> misc: not all packagers are here
20:43:07 <AL13N> there are also some people who are not that active with packaging, but may want to do this
20:43:10 * AL13N thinks of eugeni
20:43:40 <AL13N> or only 1/4 of packagers are actually at this meeting
20:43:48 <AL13N> i propose we ask on -dev ML for volunteer
20:43:54 <misc> ok
20:44:05 <misc> #action AL13N ask on-dev and find a volunteer
20:44:16 <AL13N> k
20:44:18 <ryoshu> a lof of packager maintain just a few packages
20:44:37 <AL13N> (there's also advanced users who look out for such things)
20:44:37 <ryoshu> less than 10-15
20:44:56 <ryoshu> but ok, ask in -ml :)
20:46:17 <ennael> ok
20:47:10 <ennael> alpha 2 is planned for 14th of december
20:47:35 <sebsebseb> :)
20:47:41 <ennael> so maybe it will be hard to have these news ready for it
20:48:04 <ennael> so please guys, work on release notes when asked on -dev ML
20:48:27 <AL13N> mail sent
20:48:58 <AL13N> is there a place for these release notes? a wiki link or something?
20:49:55 <ennael> I will open wiki page for alpha2 just after this meeting
20:50:01 <AL13N> k
20:50:25 <misc> #action ennael open the wiki page for alpha2
20:52:24 <ennael> ok so for planning now
20:52:44 <ennael> we will freeze local repository on 9th of december
20:53:13 <ennael> so again if you have to submit new versions or fixes to be taken into account for isos, please do it before
20:53:51 <mitya> freeze until the actual release (14 Dec)?
20:54:13 <ennael> freeze is only done locally
20:54:16 <ennael> on build machine
20:54:34 <AL13N> ah, ic
20:54:45 <AL13N> you mean for stuff that goes into alpha2
20:54:50 <ryoshu> what was the problem with QA?
20:54:54 <ryoshu> for Alpha1
20:54:58 <ennael> yes
20:55:18 <ennael> about QA, it's a more global pb, organizing tests and reports
20:55:21 <misc> #info snapshot for alpha2 will be done on 9/12
20:55:57 <ennael> as time is short for alpha2, we will work with some advanced users or packager for tests
20:56:10 <ennael> and work on how to train new testers on QA
20:57:45 <doktor5000> ennael: related question, how are the results of the previous internal tests for alpha 1 (piratepad) relayed to the relevant packagers to fix these issues?
20:58:25 <ennael> well if we cannot fix quickly this issue for isos it should be reported in bugzilla
20:58:48 <ennael> otherwise we poke packagers
21:01:46 <ennael> something to add on that topic ?
21:02:00 <misc> not for me
21:02:54 <ennael> is triage team there tonight ?
21:03:11 <ryoshu> leuhmanu: marja ping
21:03:30 <marja> ryoshu: aren't you in a meeting?
21:03:43 <marja> o, it is for the meeting
21:03:54 <leuhmanu> yes ?
21:04:02 <ennael> ok :)
21:04:12 <ennael> #topic triage team review
21:04:17 <ryoshu> ennael asks for the triage team :)
21:04:23 <marja> OK
21:04:27 <ennael> leuhmanu: can you give us a status about triage team ?
21:04:37 <ennael> and also pending security updates
21:04:56 <leuhmanu> there is no news about security updates
21:05:13 <leuhmanu> no new bugs, no resolved since 1 or 2 weeks
21:05:25 <leuhmanu> (maybe one new)
21:05:27 <ennael> some pending for a long time ?
21:05:47 <doktor5000> leuhmanu: actually just resolved one as duplicate some minutes ago :)
21:05:49 <leuhmanu> yes I have ping last week iirc
21:06:24 <ennael> can you give us a link for archives ?
21:06:30 <doktor5000> ennael: we'd need someone to look at https://bugs.mageia.org/show_bug.cgi?id=3101 IMHO
21:06:32 <erzulie> [ Bug 3101 - Java Version 6 Update 29 ]
21:06:48 <leuhmanu> yep sorry
21:06:54 <leuhmanu> https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=Open%20security%20issues&sharer_id=151 open security bugs
21:06:56 <erzulie> [ Log in to Bugzilla ]
21:07:45 <leuhmanu> there is also some bugs against isos
21:08:17 <leuhmanu> https://bugs.mageia.org/buglist.cgi?product=Mageia&component=Release%20%28media%20or%20process%29&resolution=---
21:08:19 <erzulie> [ Bug List ]
21:08:47 <ennael> thanks we will have a look on that last one
21:09:03 <ennael> will ping also about sec updates
21:09:07 <leuhmanu> and a lot of bugs that can be resolved easyly:
21:09:09 <leuhmanu> https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=Junior_job_no_new_packages&sharer_id=446
21:09:10 <erzulie> [ Log in to Bugzilla ]
21:09:34 <leuhmanu> https://bugs.mageia.org/buglist.cgi?keywords=PATCH&resolution=---
21:09:35 <erzulie> [ Bug List ]
21:11:38 <leuhmanu> ah yes, I guess a keyword for the errata can be useful no ?
21:12:41 <ennael> yep
21:12:47 <ennael> can you add it?
21:13:03 <leuhmanu> ahmad had added errata on the whiteboard
21:13:15 <leuhmanu> (for some month)
21:13:51 <leuhmanu> an maybe we added 2 or 3 new, so too little
21:14:27 <leuhmanu> personnly, I have no specific right on the bugzilla
21:15:07 <ennael> ok will ask for it
21:15:18 <leuhmanu> can ask dmorgan too
21:15:27 <ennael> yep sure your turn then :)
21:15:58 <leuhmanu> marja: something other ? :p
21:16:46 <marja> not now
21:16:49 <ennael> what about proposing junior jobs to mentored people ?
21:17:14 <leuhmanu> links are in the wiki iirc
21:17:28 <leuhmanu> but maybe not in the right page
21:18:52 <AL13N> perhaps each mentor can ask their padawans to look at this page and take one or two such bugs on
21:19:04 <ennael> yep
21:19:16 <ennael> I will mail about this
21:19:42 <ennael> #action ennael will mail mentors about junior jobs so that apprentices can help on this list
21:19:54 <ennael> anything else to add ?
21:20:21 <barjac> Anyone got actual link to that list?
21:20:34 <leuhmanu> (even if the bug is assigned it does not mean that the person working)
21:21:41 <doktor5000> barjac: list of junior jobs: https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=Junior_job_no_new_packages&sharer_id=446
21:21:43 <erzulie> [ Log in to Bugzilla ]
21:22:11 <leuhmanu> (and nothing to add for me)
21:22:40 <ennael> ok can we end meeting ?
21:23:21 <ennael> mmm last word, as a reminder next general assembly for Mageia should tale place during FOSDEM on 4th of february
21:23:44 <AL13N> ok
21:24:51 <ennael> ok thanks for attending
21:25:05 <ennael> #endmeeting