19:16:59 <ennael> #startmeeting
19:16:59 <Inigo_Montoya> Meeting started Wed Oct 19 19:16:59 2011 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:16:59 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:17:00 <erzulie> [ MeetBot - Debian Wiki ]
19:17:29 <ennael> #chair misc, boklm
19:17:29 <Inigo_Montoya> Current chairs: boklm ennael misc
19:18:09 <ennael> #topic Bugzilla management
19:18:50 <ennael> ok first topic was proposed during council meeting
19:19:11 <ennael> and we thought it was better to discuss it during packagers meeting
19:20:00 <ennael> it's about ASSIGNED status
19:20:10 <ennael> did you all have a look on that discussion ?
19:21:11 * misc didn't
19:21:34 <rindolf> I didn't either.
19:21:47 <obgr_seneca> https://bugs.mageia.org/show_bug.cgi?id=3047
19:21:49 <erzulie> [ Bug 3047 - ASSIGNED status means ]
19:22:55 <ennael> as said stormi in mail it's more about general workflow for triage team
19:25:43 <tmb> well, imho the only one to set ASSIGNED is the maintainer (or any other taking the responsibility to fix the bug) when accepting to fix the bug, the triage sets the assigned-to
19:26:05 * misc has also said the same when asked by stormi or leuhmanu on irc
19:26:38 <obgr_seneca> tmb: that's right, but it doesn't look good to the reporter, when the bug is kept on new for a very long time
19:27:37 <misc> obgr_seneca: on the other hand, if we say assigned and no fix is coming, people will just feel the same
19:27:41 <tmb> well, it does not look better if it's ASSIGNED but no-one still cares
19:27:54 <obgr_seneca> that's right
19:28:28 <misc> anyway, that's just a convention so I guess we can discuss endlessly for that
19:28:47 <misc> while exploring the infinity is a nice adventure, I do not think that's the best way to do it
19:28:51 <tmb> I mean I can "promise" that another user will fix it by setting ASSIGNED, but that does not mean he will ever do so...
19:32:17 <anaselli> hi, in my opinion it's not the status that is really important to the reporter but the fact that the bug is followed by developers/packagers, e.g. comments, questions and any other things that interact with the reporter
19:33:01 <anaselli> well it is important... just if it is closed :D
19:34:28 <ennael> ok... so really no change needed for now ?
19:34:47 <misc> in fact, the whole problem is wrongly phrased, it is not "what should mean assigned", but "how do we want to filter the bug, according to their state"
19:35:42 <misc> ie, "packagers want to see bug that they need to fix", "bug triagers want to see bug they need to triage", and "users want to know if something is missing", so "we should do that and that"
19:36:16 <Stormi> misc: you're saying basically what I told in my mail :)
19:36:32 <Stormi> (hi all)
19:36:34 <misc> Stormi: possible, as I said, i didn't read my mail or the bug until today
19:36:47 * anaselli neither :/
19:37:01 <ennael> so basically improve process rather than change bugzilla
19:37:21 <Stormi> and change bugzilla only if needed after choosing how to improve the process
19:37:39 <ennael> ok nice stormi
19:37:46 <ennael> you ask questions and give answers :)
19:38:25 <misc> I agree that maybe assigned would create false expectation from users, so since bugzilla has renamed the state, we could also investigate this ( but maybe this also have been told already )
19:38:28 <Stormi> I asked questions ? :)
19:39:44 <ennael> misc: so it's a question of how assigned is understood by reporter ?
19:40:00 <tmb> IIRC in mdv the keyword "Triaged" was used
19:41:51 <LpSolit> I don't think you should worry about what the reporter understands, but how to help the triage team
19:42:03 <LpSolit> at least, that's how I understood the problem by reading the bug :)
19:42:05 <misc> ennael: well, this could be, at least
19:42:18 <ennael> LpSolit: well if we do not care about reporter we will not have reporters anymore
19:42:31 <misc> that mean no more bug, sound good
19:42:40 <ennael> :)
19:42:42 <obgr_seneca> :D
19:42:55 <LpSolit> ennael: no, I mean the reporter reports the bug and wants to see it fixed, and doesn't care about all the details
19:42:58 <misc> but IMHo, there is 2 separate issue, 1) workflow and how it map in practice to the status, etc
19:43:38 <misc> and 2) communication with reporters, which may be carried by only 1 word of difference, when we change status without more comment
19:43:39 <JohnR> To most EN speakers, ASSIGNED means that the item has been passed on to someone/thing else. TRIAGED in this case would indicate that the job has been seen by the bugsquad. Yes, it's about what those two words mean to the reporter
19:43:57 <LpSolit> if you improve the time it takes for the triage team to triage bugs and for the maintainers to fix bugs, the reporter will be happy
19:44:38 <ennael> it's hard to guarantee time for all bugs
19:44:43 <ennael> even if we improve things
19:45:09 <misc> we can garantee that 90% of the bug will be solved in less than 20 years, not that hard to do :)
19:45:13 <tmb> An other thing could be to add "IN PROGRESS"  as status for maintainer/fixer to set... but that means patching bugzilla
19:46:01 <LpSolit> this doesn't mean patching Bugzilla, there is a UI to do this :)
19:46:12 <misc> a ui to patch bz ?
19:46:31 <LpSolit> you can add as many new bug statuses as you want since Bugzilla 3.2
19:46:39 <LpSolit> from the Admin pages
19:46:44 <LpSolit> misc: :-p
19:47:35 <anaselli> misc: i seem to remember you can do that by logging in as administrator in bz
19:47:58 <misc> anaselli: yeah, it was a joke
19:48:05 <anaselli> oops
19:48:32 * anaselli should read better :D
19:48:33 <LpSolit> https://bugs.mageia.org/editvalues.cgi?field=bug_status for those who don't know where to find it
19:48:34 <erzulie> [ Log in to Bugzilla ]
19:49:37 <ennael> ok so any proposal ?
19:50:24 <obgr_seneca> Iirc in Mandriva the triage team put some comment on the bug
19:51:00 <obgr_seneca> This would make the reporter happy, because he see's the bug has been seen and we wouldn't have to add or change anything on bz
19:51:34 <LpSolit> a comment is more friendly, and makes sense if the bug fix is blocked by some more important or related work
19:51:54 <LpSolit> "thanks for your bug report. Note that bug XXX must be fixed first before we can fix this one"
19:52:07 <LpSolit> and then the reporter better understands why his bug stalls
19:52:24 <tmb> my suggestion is to add the "IN PROGRESS", iirc both fedora and launchpad uses it..
19:53:23 <tmb> and nothing prevents triage to add a comment at the same time they set status (we could require a comment to be added)
19:53:41 <AL13N> i personally don't really care, to me it was just not evident that ASSIGNED was only to be used by the person taking the bug on, even if it's assigned
19:53:53 <ennael> tmb: sounds good
19:54:05 <boklm> what would the difference between "IN PROGRESS" and "ASSIGNED" ?
19:54:23 <AL13N> semantics?
19:54:36 <obgr_seneca> i would propose the order "NEW -> ASSIGNED -> IN PROGRESS -> CLOSED"
19:55:10 <AL13N> in that case it would be nice if ASSIGNED status would go automagically if the bug becomes assigned to an email
19:55:12 <Stormi> or that in https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow (nice schema inside)
19:55:15 <erzulie> [ BugZappers/BugStatusWorkFlow - FedoraProject ]
19:55:44 <tmb> boklm: triage sets ASSIGNED, when maintainer starts fixing he sets IN PROGRESS
19:55:58 <boklm> ok
19:56:30 * Stormi still thinks an irc meeting is not the best place to come up with a comprehensive proposal
19:56:51 <boklm> so ASSIGNED is the same as TRIAGED on fedora, and IN PROGRESS the same as ON_DEV on fedora ?
19:57:08 <JohnR> boklm: yes
19:57:15 <ennael> Stormi: it can start discussion...
19:58:28 <Stormi> ennael: yes, but in fact we will end with more or less the same workflow as other distributions, so we should really first look at what they do, see how that fits with our needs, and get a proposal out of this
19:58:44 <Stormi> discussing it here is not bad, of course, but not really efficient
19:58:59 <ennael> well so do not ask in council meeting :)
19:59:04 <Stormi> I didn't ask
19:59:13 <ennael> anyway we have some proposals and we can go on on mageia-dev
20:00:00 * AL13N votes for "NEW -> ASSIGNED -> IN PROGRESS -> CLOSED"
20:00:13 <ennael> ok so
20:00:51 <ennael> #action mail mageia-dev and write first proposal to improve both process and comprehension of this process
20:02:10 <ennael> can we switch to other topics ?
20:02:22 <AL13N> yes
20:02:23 <misc> yep
20:02:59 <ennael> ok
20:03:24 <ennael> #topic quick review about coming hardware for bs
20:03:36 <ennael> boklm: quick summary ?
20:03:42 <boklm> ok
20:04:07 <boklm> so we are going to buy new servers for mageia
20:04:17 <boklm> http://mageia.org/pipermail/mageia-sysadm/2011-October/004012.html
20:04:18 <erzulie> [ [Mageia-sysadm] Final proposal for new servers ]
20:04:51 <boklm> we will have one server given by Nanar, that we will use for backups
20:05:10 <boklm> we will buy an ARM board to build packages for ARM
20:05:53 <boklm> and a new server that will be used to host virtual machines to test packages builds for packagers
20:06:34 <boklm> coincoin will buy the new hardware this week
20:07:25 <boklm> and we will bring to the datacenter in marseille in a few weeks, when we received it
20:08:58 <ennael> any question ?
20:09:16 <AL13N> wasn't there also a possible donation by tv, iirc?
20:09:25 <boklm> yes, but it will be for later
20:09:41 <AL13N> k
20:09:54 <boklm> I don't know if we will be able to have it before we go to marseille
20:10:26 <boklm> we will also have replace disks on the 2nd build node, so we will have again two nodes on the build system
20:10:28 <AL13N> will maat be involved since he lives there?
20:10:56 <boklm> we will see when we plan the trip to go there
20:12:29 <ennael> ok thanks boklm
20:13:15 <ennael> #topic organize coming alpha1 release
20:14:13 <ennael> so
20:14:20 <ennael> 2011-11-16: Mageia 2 Alpha 1 for memory
20:14:45 <ennael> would be nice to organize process for dev releases
20:15:23 <ennael> what we want to include in coming one, tests for isos, organize bug reports after isos are available
20:15:26 <ennael> ...
20:16:13 <misc> and do the iso, in fact
20:16:17 <ennael> yep
20:16:39 <AL13N> 16 nov already
20:16:41 <AL13N> hmm
20:16:46 <AL13N> i need to get cracking
20:17:10 <tmb> -ing
20:17:14 <ennael> :)
20:17:16 <AL13N> :)
20:17:56 <AL13N> i definately need to fix rescue
20:19:36 <tmb> a small status update for now is that stage2 installer is broken either due to all updates rpm, but we (mostly tv) is checking to get it fixed.
20:19:48 <ennael> ok
20:20:01 <tmb> *updated rpms
20:20:45 <tmb> but when we have that pinned down we'll push the new xorg server current in testing to /release
20:21:24 <tmb> (and maybe watch stage2 break again ...)
20:21:49 <ennael> so maybe we need to fix a planning before, during and after release
20:21:54 <misc> maybe we could decide to not push anything that could break stage 2 before doing the alpha 1 ?
20:22:49 <tmb> glibc update seems to work ok for all testers so far
20:24:02 <tmb> as for xorg update I think we'll check that stage2 works with it before pushing it to mirrors
20:24:27 <ennael> ok so we need to status on what to be included for alpha1
20:24:53 <ennael> making isos and test it before upload takes about 5 or 6 days
20:25:14 <tmb> so we have ~20 days left
20:25:35 <ennael> yep
20:25:58 <tmb> I think we'll know more about stage2 by this weekend
20:26:21 <ennael> maybe also have a look on triage side to check we do not have blocking bugs
20:26:55 <leuhmanu> what about release bug ?
20:27:26 <ennael> ?
20:27:51 <tmb> yep. and one question we will get is: will there be non-free firmwares on the isos "protected" by an installer option/question
20:28:05 <tmb> and will there be x86_64 live isos
20:28:31 <leuhmanu> yes like that and including rpm is the iso
20:29:09 <tmb> but keep in mind this is alpha 1, so not everything must be fixed on it...
20:29:34 <AL13N> (btw: is there someone who can help me understand the stage1/stage2/rescue system? or point to some docs? i've looked at it, but it seems to be sometimes one source file used for both... it's confusing me...)
20:29:47 <leuhmanu> the search in https://bugs.mageia.org/buglist.cgi?product=Mageia&component=Release%20%28media%2C%20process%29&resolution=--- did'nt work ( bug with the , in the title )
20:29:49 <erzulie> [ Bug List ]
20:29:54 <ennael> AL13N: please ask on mageia-dev
20:30:14 <tmb> AL13N: stage 1 boots, then you choose installer (stage2) or rescue
20:30:31 <AL13N> tmb: obviously :-)
20:30:38 <leuhmanu> tmb: yes sure (for the alpha)
20:31:53 <ennael> ok so mail is needed to fix a planning
20:32:10 <ennael> we will need also to be organize tests with QA team for isos
20:34:51 <tmb> I have "secured" some more "older" hw to test on too in order to try and improve the testbase :)
20:35:08 <ennael> nice :)
20:35:36 <ennael> ok we will formalize this in wiki and send mail reminders about planning
20:36:09 <ennael> any question, proposal ?
20:37:18 <tmb> Is blino available for the livecds?
20:37:36 <ennael> we will check but we will need help for sure
20:38:11 <AL13N> is there need for pre-release testers?
20:38:25 <ennael> QA team will manage this
20:38:34 <tmb> yep. I'll try to dig up the documentation here too and see if I can replicate the build locally
20:39:29 <ennael> ok any question on this ?
20:40:49 <tmb> not from m
20:40:52 <tmb> me
20:41:50 <ennael> ok
20:42:08 <ennael> #topic reviews for triage, QA, secteam
20:42:20 <ennael> guys ? anything to mention on this ?
20:42:42 <leuhmanu> yes, Thanks you packagers, after the adoption of packages, the triage is more efficient.
20:43:11 <leuhmanu> It remains more a few important packages and this will be perfect: D
20:43:28 <leuhmanu> (like drakx-net, mkinit, initscript, and other that I have forget)
20:43:32 <ennael> have you sent this list on ML ?
20:43:53 <leuhmanu> hum no I can do that indeed
20:44:22 <tmb> yeah, I have several that I havent grabbed yet, but will try to do so this week
20:45:56 <ennael> leuhmanu: anything else to add on triage ?
20:46:10 <leuhmanu> no thanks :)
20:46:13 <ennael> ok :)
20:46:18 <ennael> Stormi: anything on QA ?
20:46:41 <Stormi> I don't think so, tmb is pushing the pending updates at the moment
20:47:09 <tmb> yep.
20:47:22 <ennael> status for sec updates ?
20:47:23 <Stormi> of course, we could use more testers :)
20:47:35 <ennael> of course :)
20:47:48 <Stormi> updates that reach QA usually don't stall, usually (there are a few exceptions)
20:48:19 <Stormi> however at our level we don't know if there are security problems that don't reach QA
20:48:32 <Stormi> I guess there are
20:49:00 <Stormi> https://bugs.mageia.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=security&sharer_id=69 suggests there are :)
20:49:01 <erzulie> [ Log in to Bugzilla ]
20:49:06 <leuhmanu> I have see some security bugs reported by boklm, Dave and one or two others
20:50:11 <ennael> yep some have been added recently
20:50:32 <tmb> yesterday we had a user on #mageia asking for a "security team" to present to his bosses in order to switch from mdv to mga
20:50:52 <ennael> ?
20:50:58 <ennael> you mean something formalized ?
20:51:23 * tmb checks logs
20:51:47 <misc> was he grey, small, big black eyes and did he ask to be taken to our leader :) ?
20:52:12 <ennael> outch
20:52:23 <ennael> misc needs some more crack or pizzas
20:52:26 <eugeni> talking in backwards fashion was he, and green and small looking as well?
20:52:30 <AL13N> :)
20:52:51 <tmb> [09:19.33] <mramish> It is just a the matter of "showing important people". I know that mga devs are doing a great job, but ive to show them something like an infrastructure. Dont get me wrong :)
20:53:07 <AL13N> maybe eugeni can be security team leader
20:53:52 <ennael> tmb: so basically, team, process...
20:54:17 <tmb> yep
20:55:16 <ennael> ok
20:56:33 <ennael> #action work on secteam process and team to make it more evident
20:57:27 <ennael> anything else to add
20:57:49 <tmb> nope
20:57:57 <ennael> (before sleeping  or dying)
20:58:34 <AL13N> anything on mentor team?
20:58:54 <ennael> andre is not there tonight
20:59:03 <ennael> we will ask him to mail report on -dev
20:59:28 <AL13N> k
20:59:31 <AL13N> end meeting?
20:59:57 <ennael> questions ? comments ?
21:00:25 <misc> not for me
21:00:32 <obgr_seneca> not for me either
21:00:32 <boklm> not for me
21:00:47 <ennael> ok we can now feed misc :)
21:00:52 <ennael> #endmeeting