19:07:10 <ennael> #startmeeting
19:07:10 <Inigo_Montoya> Meeting started Wed Jul  6 19:07:10 2011 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:07:10 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:07:11 <erzulie> [ MeetBot - Debian Wiki ]
19:07:23 <Nanar> hi
19:07:58 <ennael> #chair misc stewb
19:07:58 <Inigo_Montoya> Current chairs: ennael misc stewb
19:08:37 <ennael> first no meeting next week
19:08:45 <ennael> some of us will be in RMLL
19:08:51 <ennael> http://2011.rmll.info/?lang=en
19:08:51 <erzulie> [ Home - 12th LSM from 9 to 14 July 2011 ]
19:09:29 <ennael> Mageia will have a booth and 2 conferences about build system and community
19:09:38 <ennael> misc  is on a blog post about it
19:10:13 <ennael> #topic release cycle, backports policies
19:10:24 <ennael> ok first burning topic :)
19:11:07 <ennael> did everybody have a look on misc mail ?
19:11:12 <xardas008> sure
19:11:15 <AL13N> yes
19:11:44 <ennael> ok so 9 months release cycle
19:12:10 <ennael> Mageia 2 should be announced for 4th of april 2012
19:12:33 <AL13N> is there any idea about freeze times yet? or is that for after specifications planning?
19:12:40 <ennael> we started release from beginning of july as we took some time to discuss
19:12:48 <ennael> planning will be announced in coming days
19:13:23 <ennael> still we have 2 topics to finalize
19:13:48 <ennael> backports policy and life time for each release
19:14:07 <sebsebseb> Why 9 months release cycle, and no  I didn't read the email.
19:14:21 <ennael> the I let you read it first
19:14:38 <Nanar> sebsebseb: better to jump on your email client first then
19:14:45 <ennael> about life time, we would like to have at least one version LTS (long time support)
19:15:40 <AL13N> i have a remark about that
19:15:46 <ennael> yep ?
19:16:10 <AL13N> maybe it's better for a company supporting mageia to actually do the LTS? instead of mageia itself?
19:16:31 <AL13N> i mean, thinking about resources
19:16:51 <ennael> do you have acompany in mind ?
19:16:58 <ennael> can you create it? :)
19:16:59 <andre999> but that would entail security updates, etc
19:17:01 <AL13N> well, not really :-)
19:17:16 <AL13N> i would like an LTS version
19:17:24 <spturtle> ennael: the question would be more if there will be enough (paying) customers
19:17:33 <AL13N> but well, we'll have to grow soon imho to be able to finalize it
19:18:07 <ennael> well we have some time before it to let teamgrowing
19:18:12 <AL13N> anyway it's just a remark
19:18:16 <AL13N> something to keep in mind
19:18:18 <ennael> stewb: any idea on all this ?
19:18:21 <ennael> or tmb ?
19:19:09 <stewb> I'd like to see an LTS version, resources are always a problem
19:19:22 <AL13N> yes :-)
19:19:25 <spturtle> updates have just started I think, it's a little early to seriously think about long term support
19:19:51 <AL13N> but ok, enough OT... ennael; please continue and sorry for interrupting
19:19:52 <ennael> well if we do not plan anything we won't be able to ask for targetted resources
19:20:03 <AL13N> true
19:20:07 <ennael> having some plans for future does not hurt
19:20:08 <andre999> we have at least another release before it would kick in
19:20:34 <brianb> why not use odd versions to represent LTS which would give a 18month cycle?
19:20:45 <andre999> I think it is almost essential - to expand our user base
19:21:05 <ennael> stewb: what would you propose as basic life time support ?
19:21:35 <ennael> I mean non LTS versions
19:22:32 <tmb> I think we need a LTS if we want to expand user base to companies as well... and even used for our own infra too
19:22:43 <stewb> 18/24 perhaps, although that may be too long
19:22:48 <AL13N> tmb: good point, i did not think of that
19:22:58 <sebsebseb> Ok just read the email :) https://mageia.org/pipermail/mageia-dev/2011-July/006404.html
19:22:59 <erzulie> [ [Mageia-dev] Summary of the release cycle decision ]
19:22:59 <ennael> stewb: 18 for non LTS one ?
19:23:02 <andre999> exactly - lts essential for cies
19:23:24 <stewb> yes, based on the 9mon release cycle
19:23:28 <ennael> ok
19:23:43 <ennael> 18 for non LTS end 36 for LTS ?
19:23:49 <stewb> maybe only 12/18
19:24:06 <ennael> ?
19:24:11 <andre999> I like 18/36
19:24:19 * shika thinks we would need a much larger team for that…
19:24:35 <ennael> shika: again we need targets
19:24:43 <ennael> without it it's hard to plan anything
19:24:50 * stewb was still talking the non-lts
19:24:56 <AL13N> well, i think we definately need at least 2 releases that are supported at the same time, so perhaps this discussion is more for mga3?
19:24:56 <ennael> oh
19:25:06 <misc> AL13N: that's a good point
19:25:17 <andre999> with a 9-month release cycle, the short-term support should be at least 18 mo
19:25:25 <AL13N> i think everyone agrees with at least 2 releases, right?
19:25:31 <Jehane> like fedora do ?
19:25:31 <ennael> so 18 months for non LTS relase
19:25:34 <sebsebseb> yep at least two releases should be supported sure
19:25:40 <misc> I think we can safely start by saying "we support for now 2 releases", and in 6 months, we will have a better view
19:25:44 <ennael> stewb: 18 sounds reasonable?
19:25:48 <AL13N> i agree with misc
19:25:49 <andre999> ennael: right
19:25:59 <stewb> yes
19:26:10 <ennael> and we will have a first review before Mageia2 ?
19:26:11 <sebsebseb> 18 months is what Ubuntu do for non LTS, so sure that should work
19:26:34 <andre999> I agree with misc also -- but we should plan on having a lts
19:27:07 <misc> well, as i said, we should keep this for later , one discussion after the other
19:27:59 <ennael> could we say we think about a LTS version but will need some more visibility after first release ?
19:28:27 <AL13N> yes, but i think depending on growth we can revisit this issue earlier if wanted
19:28:30 <sebsebseb> I think a LTS version is a good idea, but I guess let Mageia 2 come out first,  and then think about having one more properly.
19:28:33 <misc> yes, and we also need to understand how to speel the requirement of selecting proper version
19:28:44 <ennael> ok
19:28:48 <AL13N> and also mirror size requirements
19:29:04 <ennael> #info release cycle is 9 months, each version will be supported 18 months
19:29:17 <ennael> #action first review of resources is planned before Mageia 2 is out
19:29:32 <ennael> #info Mageia 2 is planned for 4th of april 2012
19:29:45 <stewb> do we think we want to differentiate between base system and desktop support?
19:29:52 <ennael> #info we plan a LTS version but this will be discussed further when we have more visibility
19:30:00 <Nanar> the mirror size is defined to support all lts (and more than that)
19:30:01 <ennael> stewb: as in mdv ?
19:30:08 <stewb> yes
19:30:14 <AL13N> stewb: i don't follow?
19:30:17 <ennael> wdyt ? pros and cons ?
19:30:19 <brianb> with there be a server version of mageia?
19:30:38 <sebsebseb> What about later Gnome versions and KDE versions, after Mageia version releases, or is that backports?  Take Gnome for example they release a new version in March and September useually it seems.
19:30:40 <andre999> that sounds like main/contrib
19:30:50 <AL13N> i think all that is packaged should be maintained, thus can be supported? i don't see any difference?
19:31:01 <AL13N> (as long as we clean up)
19:31:14 <stewb> ok, just raising the question
19:31:27 <AL13N> stewb: i don't really understand the question
19:31:31 <ennael> what would be the reason ?
19:31:34 <misc> I am against, that's too complex to manage
19:31:36 <ennael> just a question
19:31:55 <misc> given the current complexity of the distribution, I am not sure we will really win something
19:32:02 <andre999> definitely more complex
19:32:10 <misc> and I think people who run desktop also want a long support, this was requested on forums
19:32:22 <AL13N> oic
19:32:27 <spturtle> support is a) security fixes, b) bug fixes - some bug fixes take a lot of effort (to test)
19:32:34 <Nanar> I agree with misc
19:32:49 <andre999> also, companies with servers will also want desktops
19:33:11 <AL13N> imho as long as we clean up and have sufficient resources, we should not differentiate in support level
19:33:21 <brianb> is there goingto be a server version of mageia?
19:33:45 <AL13N> brianb: imho, that's a different discussion point
19:33:58 <olorin_> Speaking of which, do we go for bugfixes and security updates this time? Minor bugfixes as backports is a bit daft.
19:34:14 <ennael> olorin_: 2 secs please
19:34:20 <andre999> true :)
19:34:26 <ennael> backports is following topic
19:35:14 <AL13N> ok, so we do not differentiate in support level?
19:35:36 <andre999> it makes sense to try to focus support on key parts of mageia, if a lack of resources
19:35:45 <andre999> but try to do all
19:36:04 <misc> well, the meeting is not to discuss the topic endlessly, as I said, we will makde proposal on the ml
19:36:08 <AL13N> andre999: it takes also resources to manage this extra complexity
19:36:21 <AL13N> ok then, next topic?
19:36:32 <ennael> second part of this topic is about backports
19:36:43 <ennael> we need to finalize policy by the end of this week
19:37:13 <AL13N> personally, i've looked at both sides and i do _not_ have the answer
19:37:27 <misc> ennael: I think we will close the discussion to the end of the week, and summarize it like we did for the release :)
19:38:01 <ennael> still it's a target we have to keep in mind to avoid endless discussions
19:38:22 <brianb> i think the following commen in distrowatch sums up the complexty issue:
19:38:27 <brianb> ." The author concludes the article with an interesting observation: "As many old Linux veterans will tell you, getting the first release out the door is not nearly as taxing as setting up a smooth development, testing, and release process that is sustainable over a multi-year period."
19:38:55 <misc> so for backport, do people think there was enough time to discuss everything, and so we can summarize and go forward ?
19:39:03 <brianb> this weeks distowatch on mageia 1
19:39:16 <andre999> I think so, essentially
19:39:21 <AL13N> misc: yes, imho; i think all points have been mentioned
19:39:37 <ennael> misc: can you summarize it on ML ? :)
19:39:59 <misc> ennael: yes, but not until at least the 15th july, due to LSM
19:40:07 <ennael> hum
19:40:13 <AL13N> LSM?
19:40:20 <andre999> ?
19:40:25 <sebsebseb> Ok so backports, getting later versions of software  after release right?
19:40:29 <misc> libre software meeting, the event next week where i will be present
19:40:39 <sebsebseb> after the version of the distro has come out
19:40:41 <andre999> ok:)
19:40:42 <misc> ( ie, for the whole week, I am busy as a organizer )
19:40:49 <misc> ( I have a blog post for that )
19:41:21 <ennael> any volunteer to sum up?
19:42:03 <ennael> tmb: would you be ok to do it ?
19:43:50 <andre999> I could try ?
19:44:16 <misc> andre999: you are already on the mentoring topic
19:44:29 <andre999> true
19:44:47 <misc> so we should not overload too much the same people
19:44:50 <xardas008> andre999 is a fully volunteer
19:46:26 <spturtle> the consensus appears to be that backports should not be used a lot, so all important bugfixes need to go out as stable updates
19:47:04 <spturtle> but that's all the summing up I can do (:
19:47:37 <misc> well, let's see if we can find a volunteer, else it will simply wit
19:47:47 <misc> ( I am sure I can trick stormi in doing it )
19:48:06 <xardas008> even he is not here today xD
19:48:15 <spturtle> ok, next topic
19:48:39 <xardas008> but would not be very nice i think
19:49:23 <ennael> ok next topic then
19:49:27 <ennael> #topic starting implementing specifications for Mageia2
19:49:55 <ennael> so not many reactions on mail about specifications
19:50:03 <ennael> we need to start now
19:50:32 <ennael> each spec should be reported in bugzilla so that we can follow it
19:50:38 <ennael> AL13N already did some
19:50:43 <AL13N> yes
19:51:02 * AL13N also made a TRACKER
19:51:04 <ennael> but we need now to start discussion for them, take decisions and planning
19:51:07 <AL13N> for those bug reports
19:51:22 <sebsebseb> Well I read on the wiki before that Mageia 2 would probably have Gnome 3.2, but here's the thing, if Mageia 2 is coming out in April,  that means  Gnome 3.2 will probably be the old version, because as far as I know the next major version Gnome 3.4 will probably come out in March 2012.
19:51:42 * olorin_ mumbles something about tools in Qt and focus on accessibility.
19:51:44 <AL13N> https://bugs.mageia.org/show_bug.cgi?id=1994
19:51:45 <erzulie> [ Bug 1994 - [TRACKER] Mageia 2 Technical Specifications ]
19:51:55 <sebsebseb> Gnome 3.2 in September,  and Gnome 3.4 in March probably.
19:51:56 <ennael> topic tonight is not about adding new specs
19:52:01 * misc mumble something about patches
19:52:05 <ennael> you have a wiki page for it
19:52:13 <ennael> but rather to organize work
19:52:37 <ennael> one thing we can do is start a new thread for big subjects inside these specs
19:52:43 <misc> yes
19:52:44 <ennael> and join bugzilla report
19:52:53 <ennael> is that ok ?
19:53:00 <olorin_> Works for me.
19:53:20 <andre999> sounds good
19:53:29 <ennael> ok
19:53:31 <AL13N> should we also include a sort of estimated finishing time? or worktime?
19:53:36 <ennael> will do it after meeting
19:53:48 <ennael> AL13N: it's not "should" but "must"
19:53:55 <AL13N> ok
19:54:00 <ennael> otherwise it's hardly mangeable
19:54:03 <ennael> manageable
19:54:14 <AL13N> i will update mine and do the other bugreports that have my name on it
19:54:32 <ennael> #action start new topic on-dev ML for each big part of specs and join bug report
19:54:43 <ennael> ok
19:54:46 <ennael> next topic then
19:54:54 <ennael> #topic review on mentoring
19:54:57 <ennael> andre999: your turn
19:55:01 <andre999> ok :)
19:55:31 <andre999> I've set up the packages_mentoring page to accommodate apprentices
19:55:44 <andre999> with the help of numerous suggestions
19:55:58 <andre999> it seems to ok now
19:56:42 <andre999> I am thinking of putting entries in various forums for those interested in packaging
19:56:58 <andre999> with links to the packages_mentoring page
19:57:30 <ennael> I just sent you a demand from blogdrake guys
19:57:33 <andre999> which has basic info + links to all the other info in the wiki
19:57:44 <xardas008> will you send the links to this topics to magnus and me too?
19:57:50 <AL13N> i don't want to sound rude, or disrespectful, but perhaps we should not focus on new packagers if we have no mentors available?
19:57:57 <andre999> good - I haven't look at my mail yet today
19:57:59 <AL13N> i mean, perhaps we should try to find more mentors?
19:58:13 <ennael> AL13N: well we need also to answer people asking to join
19:58:30 <ennael> even if we do not have resources of mentoring
19:58:38 <brianb> lol
19:58:39 <ennael> or they will just leave
19:58:39 <AL13N> yes that is true, but as i read it, it seemed like actively searching new packagers
19:58:44 <andre999> xardas008: all the links are from the packages_mentoring page
19:58:50 <ennael> and nothing says nobody is available
19:59:13 <andre999> more mentors also :)
19:59:30 <andre999> I have thought of a contact point
19:59:35 <xardas008> andre999: i mean of the forum topics, so we can have a look on it if there is something new
19:59:46 <misc> andre999: I think the emphaisis should be on being able to learn without waiting a mentor ?
20:00:06 <andre999> and after reflection, thought that a separate packagers_mentoring ml would be a good idea
20:00:38 <shika> sorry if I am uninformed but what’s wrong with the #mageia-mentoring channel ?
20:00:45 <andre999> misc: right, the page I set up gives suggestions and links to help self-start
20:00:53 <philippeM> please not another ml
20:01:12 <shika> philippeM: +1
20:01:37 <andre999> shika: irc is great in real time, but everything that happens there disappears
20:01:49 <spturtle> people can always send a patch/src.rpm to a maintainer
20:02:05 <andre999> a mailing list stays -- so people can follow it afterwards
20:02:11 <shika> andre999: I’d rather say nothing happens at all :/
20:02:20 <shika> but if it’s logged it does not disappear
20:02:27 <andre999> ok, just an idea :)
20:03:07 <andre999> there is a starter page for apprentices
20:03:37 <andre999> maybe an expert packager (or two) could look at it to see how it could be improved ?
20:03:56 <ennael> give us url
20:05:03 <ennael> andre999: ping ?
20:05:14 <xardas008> http://www.mageia.org/wiki/doku.php?id=packages_mentoring
20:05:15 <erzulie> [ packages_mentoring [Mageia temporary wiki] ]
20:05:19 <ennael> ok
20:05:24 <misc> http://www.mageia.org/wiki/doku.php?id=packager_start
20:05:24 <erzulie> [ packager_start [Mageia temporary wiki] ]
20:05:28 <ennael> philippeM: can you have a look on it?
20:05:35 <misc> ( as he said on #mageia-mentoring )
20:05:54 <AL13N> lol
20:06:01 <xardas008> *gg*
20:06:05 <philippeM> ennael: ok
20:06:08 <andre999> sorry I accidently switched out
20:06:10 <ennael> thanls
20:06:12 <ennael> k
20:06:25 <ennael> #action philippeM willhave a look on http://www.mageia.org/wiki/doku.php?id=packager_start to check content
20:06:25 <erzulie> [ packager_start [Mageia temporary wiki] ]
20:06:26 <andre999> but misc gave the page
20:06:33 <ennael> andre999: anything else to add?
20:06:47 <andre999> not for now
20:06:52 <ennael> ok thanks :)
20:06:56 <andre999> :)
20:07:06 <ennael> #topic review of secteam
20:07:10 <ennael> stewb: your turn ?
20:07:31 <stewb> ok, as people running mga1 should have noticed, updates are trickling out
20:07:59 <stewb> and as I undersatnd, work is being done on a database to track the updates, which will fuel the mail list, web page, etc
20:08:57 <stewb> I see 27 bugs tagged with the "Security" component in bz, some opened as update targets, some opened by users, most in the NEW state
20:09:51 <stewb> bottlenecks appear to be - triage (assign to maintainer, maintainer db would probably help here), qa, and people creating the bugs with the info in the first place
20:10:20 <stewb> I've attempted to open a few, as have a few others, but we're still behind a bit
20:10:45 <ennael> so basically what kind of resources do we need ?
20:11:26 <spturtle> stewb: please also track the security keyword
20:11:32 <stewb> would appear we may need more QA and more people auditing the security resources to see if we're vulnerable and initiate bugs
20:11:49 <stewb> spturtle: ok
20:12:03 <ennael> I guess we have people here tonight who could help on QA
20:12:07 <ennael> volunteers?
20:12:29 <andre999> I could help out at bit
20:12:40 <andre999> I started to do that in mdv
20:12:44 <ennael> thanks anybody else ?
20:13:11 <ennael> might 1 or 2 packages
20:13:15 <stewb> and triage to get things from NEW -> ASSIGNED
20:14:13 <philippeM> you mean testing packages listed in "Updates waiting for QA" ?
20:14:41 <ennael> yep
20:15:33 <ennael> philippeM: can you helpa bit on that ?
20:15:44 <philippeM> I can but only from time to time
20:15:54 <ennael> yep sure
20:16:36 <ennael> people who want to help please subscribe qa-bugs
20:16:45 <philippeM> let's say that once a week I will try to pick up one or two
20:17:09 <ennael> nice thanks for that
20:18:27 <spturtle> would it be good to ask on mageia-discuss? this is about a stable release so no need to run cauldron / be involved with packaging
20:18:56 <ennael> yep will send another mailabout this on -dev and discuss
20:19:20 <ennael> stewb: anything else?
20:20:19 <stewb> think that covers it, I'm willing to mentor anyone interested in the secteam/monitoring end of things, had one volunteer who promptly disappeared after the intro :)
20:20:29 <ennael> :)
20:20:45 <andre999> I'll put you in the list :)
20:20:46 <ennael> andre999: can you lookfor an apprentice for stewb ?
20:20:48 <ennael> ok
20:20:57 <andre999> ok will do :)
20:21:16 <ennael> I guess that's all for tonight
20:21:23 <ennael> can weclose themeeting ?
20:21:34 <misc> yes
20:21:37 <ennael> :me needs to buy new space key
20:21:38 <andre999> I had a further thougt
20:21:46 <andre999> about mentoring
20:22:02 <andre999> when I put the entries in the forums
20:22:29 <andre999> should I post to i18n re translating for other forums ?
20:22:41 <andre999> (I'll do the french)
20:22:51 <ennael> yep
20:23:02 <andre999> ok thanks :)
20:23:21 <ennael> one last thing
20:23:23 <ennael> http://mageia.org/wiki/doku.php?id=qa_updates#how_to_push_an_update
20:23:23 <erzulie> [ qa_updates [Mageia temporary wiki] ]
20:23:52 <ennael> mmmnope http://mageia.org/wiki/doku.php?id=qa_updates#how_to_validate_an_update
20:23:52 <erzulie> [ qa_updates [Mageia temporary wiki] ]
20:23:58 <ennael> Assign the bug to security@mageia.org if it's a security update (check that qa-bugs@ml.mageia.org is in 'CC')
20:24:16 <ennael> looks like we do not have any security@mageia.org account in bugzilla
20:24:56 <misc> that should be security@group.mageia.org
20:25:02 <misc> and yes, we need to add it to bugzilla
20:25:10 * misc ant to automate this since a long time
20:25:10 <ennael> ok
20:25:22 <misc> ennael: remind me once I have finish eating :)
20:25:29 <ennael> ok :)
20:25:38 <ennael> ok so let end meeting
20:25:44 <andre999> :)
20:25:50 <ennael> #endmeeting