19:02:34 <misc> #startmeeting
19:02:34 <Inigo_Montoya> Meeting started Wed Jun 22 19:02:34 2011 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:34 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:34 <erzulie> [ MeetBot - Debian Wiki ]
19:02:39 <grenoya> hi
19:02:42 <misc> #name Packagers
19:02:51 <misc> #chair ennael boklm
19:02:51 <Inigo_Montoya> Current chairs: boklm ennael misc
19:03:07 <misc> #topic quick reminder about current brainstorms: release cycle, specs
19:03:52 <misc> so, just to remind people that the release cycle discussion will be closed tonight, as said when we started it, as we think that people had time to epxress their point of view
19:04:27 <misc> we will review the discussion and the feedback that was given and, based on that, we will see how it goes
19:04:55 <misc> #info release cycle discussion end tonight
19:05:29 <misc> regarding the specs, that's the same, we will see what was proposed, and try to sort them, even if, obviously, we cannot prevent people from working on what they want :)
19:05:55 <spturtle> "we" = ?
19:05:57 <misc> yet, the idea would be to see what can be done in time, and try to organize the work, and give some direction for volunteer
19:06:24 <Kharec> hi
19:06:30 <misc> spturtle: unfortunately for me, I guess this would be ennael and I, but volunteers are welcome to help
19:07:51 <misc> so the same for specs, volunteers to sort are welcome
19:08:23 <spturtle> some spec proposals are unclear, I tried to get more info 2 cases but failed
19:08:53 <misc> spturtle: that's the easy stuff, unclear -> out :p
19:09:05 <andre999> :)
19:09:11 <spturtle> ok unclear -> wishlist
19:09:52 <misc> then, as said, we will also start the discussion for the others topics, such as backports policy, support policy, etc ( with etc being quite vague on purpose, as I do not have the list of all potential topic in my head )
19:10:52 <misc> so has anyone a question, or we can go onto next topic ?
19:12:11 <misc> ok so next topic
19:12:17 <misc> #topic incoming arm port
19:12:20 <misc> rtp: ?
19:13:47 <misc> ok, timeout on rtp, or he hide
19:14:07 <misc> so rtp finished to compile the arm port, iirc
19:14:48 <misc> and should be soon uploaded ( not sure where, didn't see anything on sysadmin ml yet ), a blog post would be ready for that
19:16:06 <misc> basically, the next part of the plan is to integrate that with our buildsystem, and the details are not decided yet, and we will discuss this on the ml
19:16:59 <misc> ( and we managed to get one PandaBoard, that is at the moment in a box in Paris, and we will move it to the datacenter once we will have a more precise idea on how we integrate it )
19:17:17 <misc> so besides that, I guess you can ask everything to rtp, or on -dev
19:17:49 <xardas008> what is a PandaBoard?
19:18:00 <misc> xardas008: a arm motherboard
19:18:12 <xardas008> ah ok
19:18:27 <misc> http://pandaboard.org/
19:18:28 <erzulie> [ Pandaboard ]
19:19:15 <misc> of course, despites being quite beefy, that's not enough, so we are looking at having more :)
19:19:39 <mdawkins> there is a downside to pandaboards
19:19:53 <misc> lack of sata ? lack of avaliability ?
19:19:59 <misc> lack of case ?
19:20:08 <mdawkins> all three
19:20:14 <misc> well, we know :)
19:20:37 <mdawkins> i've watched builds go faster on DPs just b/c you can install pkgs faster
19:21:10 <misc> well, we have a pandaboard because it was given to the project mainly :)
19:21:15 <misc> and we have some ideas to fix that, but I guess we can keep that for the post meeting discussion
19:21:26 <mdawkins> :-)
19:21:26 <misc> ( especially once rtp will be present )
19:21:46 <dmorgan> misc: he is shy :)
19:22:10 <dmorgan> can someone turn off the lights ? :)
19:22:11 <misc> has anybody a question about the topic, or we can go on next one ?
19:22:23 <AL13N> yes
19:22:31 <dmorgan> misc: next i think and we ca do a dedicated meeting for ARM
19:22:33 <AL13N> what kind of port is being done on arm
19:22:39 <AL13N> i mean
19:22:45 <AL13N> what can you run mageia on?
19:22:46 <AL13N> phones?
19:22:52 <AL13N> or rather bigger arm machines?
19:22:52 <misc> AL13N: netbook
19:22:58 <AL13N> what about smaller nas machines?
19:23:23 <AL13N> misc: only for netbook?
19:23:25 <shikamaru> phones would not be interesting without a proper interface
19:23:30 <misc> well, for technical details, see with rtp, arm is quite a complex ecosystem and I cannot answer right now
19:23:52 <misc> ( ie, there is different instruction set, etc etc )
19:23:57 <shikamaru> unless of course you want to run kde on a mobile phone :)
19:23:57 <AL13N> i'm still looking to buy a small nas and possibly use it with mageia, but not sure
19:24:17 <AL13N> i was thinking less on desktop and more on servers
19:24:21 <andre999> shikamaru: that should be fun :)
19:24:27 <shikamaru> andre999: useless
19:24:33 <shikamaru> thus a waste of time
19:24:34 <AL13N> but ok, that sort of answers my question
19:24:39 <shikamaru> :)
19:24:40 <Nanar> shikamaru: maybe getting android for mageia ? :)
19:24:48 <misc> well, for details, please keep that for rtp, only to punish him from not being here
19:24:48 <andre999> shikamaru: true :)
19:24:54 <Nanar> the interface I mean
19:25:04 <AL13N> (ie: if you have a nas with arm, and mageia, you could even use it as a XDMCP server, with kde
19:25:05 <shikamaru> or taking something open like hildon, or meego touch framework
19:25:24 <AL13N> anyway
19:25:29 <AL13N> next topic then?
19:25:30 <brianb__> is rtp the kernel and hardware expert/
19:25:37 <misc> brianb__: arm expert, yes
19:25:47 <misc> so next topic (  review on secteam current work )
19:25:48 <AL13N> brianb__: kernel expert is tmb
19:25:55 <AL13N> brianb__: and hardware expert is damsweb
19:25:57 <misc> #topic review on secteam current work
19:27:16 <misc> so as you have seen, the updates process has started, the first package have been pushed to updates-testing, and then it requires QA to be validated
19:27:37 <dmorgan> some have been validated today too
19:28:01 <misc> dmorgan: nothig pushed to https://ml.mageia.org/wwsympa-wrapper.fcgi/info/updates-announce ?
19:28:01 <erzulie> [ updates-announce - Packages update for stable release - info ]
19:28:23 * misc take a note for himself "remove the wwwsympa-wrapper.fcgi from url"
19:29:14 <AL13N> misc: is the announce for after update is available, or when it's on updates_testing?
19:29:25 <misc> so since QA of stable release is a important part of the distribution, it would be nice to give a hand, if you have a stable system
19:29:32 <misc> AL13N: after update
19:30:33 <misc> see the ml for the instruction posted by damsweb about that, and you can subscribe the ml to recieve bugs about update, test them and give feedback
19:32:19 <misc> so has anybody question, something to ask ?
19:32:23 <AL13N> yes
19:32:39 <misc> go
19:32:52 <AL13N> i don't want to be difficult, but it's about missing rpms for upgrade mdv2010.1
19:33:22 <AL13N> i have such a package that's more or less urgent
19:33:39 <misc> for tax , yes
19:33:44 <AL13N> spturtle: mentioned that he thought it was ok to go to updates
19:33:51 <AL13N> but afaik there was no decision yet
19:33:56 <misc> he also mentioned to read the archive
19:34:02 <misc> did you ?
19:34:05 <AL13N> yes
19:34:18 <AL13N> i could see people agreeing
19:34:30 <AL13N> but no decision (also not reflected on updates_policy on wiki)
19:34:43 <misc> if people agree then it should be ok
19:34:54 <AL13N> i'd like to go ahead and let Anssi submit to updates_testing
19:34:56 <AL13N> but
19:34:59 <Stormi_> let's mark it as such in the meeting then :)
19:35:04 <AL13N> how are the "missing packages" tested?
19:35:10 <AL13N> do we always test them with mdv upgrades?
19:35:12 <misc> AL13N: like the other ?
19:35:13 <andre999> I thought that the consensus was for mga1 it should go to updates
19:35:19 <AL13N> or just test the packages?
19:35:32 <misc> andre999: it was that if people ask for it
19:35:44 <misc> ie, we do not place for package that were for example not present on mandriva
19:35:45 <andre999> ok
19:35:53 <AL13N> also, i haven't been able to get ahold of Anssi for the last 2 days, so can anyone push beid-middleware to updates_testing?
19:36:02 <andre999> right
19:36:34 <Stormi_> I probably missed it, but where are the instructions to use mgarepo with stable release and various media ?
19:36:40 <spturtle> AL13N: of course upgrade from mdv2010.1 must be tested (but isolated, only for that package), you already discussed that
19:36:49 <AL13N> https://bugs.mageia.org/show_bug.cgi?id=773
19:36:51 <erzulie> [ Bug 773 - Belgian Identity card reader package beid ]
19:36:56 <AL13N> http://mageia.org/wiki/doku.php?id=updates_policy
19:36:57 <erzulie> [ updates_policy [Mageia temporary wiki] ]
19:36:59 <dmorgan> but we have to make sure ppl add the  soft in the svn updates/1/ if they add new packages in mga 1
19:37:00 <misc> AL13N: we will see after the meeting
19:37:04 <stewb> there are a few bits I copied from irc in the updates_policy doc
19:37:05 <AL13N> ok
19:37:22 <stewb> please expand as needed (or move to a better place and I'll link)
19:37:26 <Stormi_> AL13N: thanks, I probably read this page too fast :)
19:37:50 <misc> ok so any question ?
19:37:54 <AL13N> Stormi_: i hadn't seen you requesting it, i was just providing it
19:37:56 <AL13N> no more questions
19:38:00 <Stormi_> yes, are backports "open" yet ?
19:38:28 <AL13N> ah yes, i have a backport as well ready
19:38:40 <misc> Stormi_: afaik, no, but that's also because we didn't discuss backport policy yet
19:38:54 <Stormi_> ok, looking forward to discussing it then :)
19:39:02 <Stormi_> no more question
19:39:14 <misc> ( like "should be support cherry picking, and how do we do", for example )
19:41:09 <misc> ok so next topic
19:41:38 <misc> #topic review on mentoring process
19:41:58 <misc> so I gues I can let andre999 talk about that ?
19:42:07 <andre999> ok
19:42:19 <misc> ( or not, do not hesitate if you didn't expect it )
19:42:46 <Anssi> AL13N: replied
19:42:52 <andre999> I've been thinking about consoldating everything to track mentors/ apprenctices in one page
19:43:12 <andre999> (I didn't anticipate it)
19:43:55 <andre999> adding a 'so you want to be a packager' section just before the mentor list in packages-mentoring
19:44:31 <andre999> so potential packagers will be able to add their name there
19:44:42 <andre999> or see packagers to contact just below
19:45:17 <andre999> I'm still thinking about details to add to mentor list
19:45:26 <beranger> heu... con permiso, is this not the list of those who want to become packagers and are asking for a mentor? http://mageia.org/wiki/doku.php?id=packaging#list_of_registered_people
19:45:27 <erzulie> [ packaging [Mageia temporary wiki] ]
19:45:46 <andre999> like orientation of mentor ...
19:46:22 <andre999> beranger: add a section for those who want to be mentored
19:46:32 <misc> beranger: it is, but the list should be "refreshed" :/
19:46:40 <andre999> already the page has a list of mentors
19:47:28 <andre999> which one it is reformated - in a table - with more info - will be kept up to date my myself + those working with me
19:47:41 <andre999> now, it isn't updated regularly
19:47:53 <andre999> which is the utility of my position
19:48:33 <andre999> any input for layout, etc - would be appreciated
19:48:55 <andre999> especially from ennael + misc + mentors
19:49:14 <andre999> any feedback ?
19:49:14 <misc> I think the main issue is that people wait for mentor, and so maybe we should tell them what to do in that time
19:49:35 <Stormi_> indeed, start to have them train even without a mentor
19:49:43 <andre999> like documentation to read, etc
19:49:57 <andre999> a guide - good idea
19:50:01 <misc> andre999: or just work to do like bug triaging, that is important for packager
19:50:10 <Stormi_> new packages to prepare, existing packages to fix, bug triaging
19:50:12 <andre999> another good idea
19:50:28 <misc> ideally, maybe some exercise, except someone has to write them
19:50:38 <misc> ( and that take time :/ )
19:50:40 <ahmad78> why do people have professors in college?
19:50:54 <ahmad78> I mean the text box are filling the shelves in libraries, the internet ... etc
19:51:00 <andre999> somewhere I saw the idea of a bug report for tasks for potential packagers
19:51:19 <beranger> excuse me, but mentoring sounds precious. imho, after some doc/guidelines, the need whould be for someone to review the packages proposed/built by the aspirants/mentorees. or am too much of a simpleton?
19:51:20 <AL13N> perhaps an idea is also to contact packagers and ask them if they would like a padawan (eg: if they were busy with a related package)
19:51:29 <stewb> imho, there's too much emphasis on "more packagers"
19:51:32 <brianb__> are there any good books on packaging?
19:52:01 <AL13N> stewb: you want more secteam members instead :-)
19:52:03 <andre999> beranger: that is what the mentor helps with
19:52:03 <Kharec> brianb__: the rpmbook
19:52:09 <misc> beranger: review is the idea, but yes, maybe people are too much focused on the mentoring part
19:52:26 <Kharec> brianb__: http://www.rpm.org/max-rpm/
19:52:26 <brianb__> wher can that be obtained from?
19:52:27 <erzulie> [ Maximum RPM ]
19:52:27 <stewb> well, no, but I do want people concerned about the stable release and updates
19:52:30 <andre999> books ? good question
19:52:42 <stewb> and not just the shiniest cauldron
19:52:47 <misc> stewb: yes :/
19:52:51 <xardas008> fedora is rewriting the rpm book you linked above
19:52:55 <Stormi_> stewb: I am a packager but more concerned by the stable release than cauldron :)
19:53:05 <dmorgan> stewb: agreed too
19:53:13 <andre999> in my experience, review by the mentor was an essential part of the process
19:53:27 <xardas008> review is always good
19:53:50 <ahmad78> beranger: the better the specs and packages are, the faster/shorter the mentoring process becomes, it's not designed to hamper new packagers, in as much as help them with the first kickstart
19:54:00 <AL13N> stewb: if it makes you feel any better, i'll use only the stable personally and cauldron only in vm
19:54:13 <andre999> I'm going to review all comment here later, so suggest at will :)
19:54:29 <AL13N> stewb: imho, more packagers could almost mean more secteam members
19:55:17 <misc> s/secteam/qa people/
19:55:33 <andre999> right
19:56:11 <brianb__> do we have any feedback re the secteam?
19:56:54 <Nanar> could we stay on the current topic ?
19:57:13 <stewb> sorry, please continue
19:57:43 <misc> well, I think there isn't much besides mentoring ?
19:58:07 <Nanar> stewb: but it(s true mentoing must take into account stable / updates
19:58:08 <misc> andre999: will you take care of seeing of the various prposed idea are doable, etc ?
19:58:18 <andre999> will do
19:58:36 <andre999> what I want to reflect on
19:59:02 <andre999> the last thing I want to do is ad hoc changes, only to be soon changed again
19:59:34 <andre999> I've been doing notes on various options
19:59:34 <misc> could you prepare a proposal for next week ? ( or maybe just do if this is easier, but a proposal would help to see where can others help, and serve as a TODO list )
19:59:50 <andre999> ok - good idea
20:00:04 <andre999> I'd like to get feedback from a proposal
20:00:15 <andre999> good approach
20:01:31 <misc> #action andre999 write a proposal for next week about taks to improve mentor and newer packager income
20:01:41 <andre999> :)
20:02:14 <xardas008> andre999: if you need help tell me
20:02:21 <Stormi_> income = revenue, isn't it ?
20:02:27 <andre999> ok :)
20:02:27 <Stormi_> can we improve mine too ? :)
20:02:37 <andre999> :)
20:02:39 <misc> #undo
20:02:39 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0xb7552d4c>
20:02:48 <misc> welcome ?
20:02:50 <misc> no
20:02:57 <misc> influx ?
20:03:06 <misc> #action andre999 write a proposal for next week about taks to improve mentorship
20:03:11 <andre999> incoming packagers
20:03:16 <misc> andre999: too late :p
20:03:21 <Stormi_> taks :)
20:03:21 <misc> so anything to add ?
20:03:27 <andre999> ok :)
20:03:31 <Stormi_> ok for me
20:03:44 <Stormi_> glad that andre999 and xardas008 could attend the meeting btw
20:04:00 <andre999> usually I'm not available
20:04:19 <misc> andre999: well, that's why we should do less meeting and more ml discussion :/
20:04:21 <andre999> but I suspected that my position might be discussed
20:04:33 <brianb__> maybe throughput of new packagers or progress
20:04:55 <misc> andre999: usually, we try to warn before
20:04:57 <andre999> misc: definitely a plus
20:05:18 <andre999> ok - I was reflecting a lot on it anyway
20:05:21 <misc> but I was sick and busy, and ennael was busy ( and maybe sick ), so we tought that the other would sent the reminder
20:05:35 <andre999> and in our field, this happens a lot
20:06:04 <andre999> misc: no problem
20:06:15 <misc> anyway, nothing to add ?
20:06:31 <andre999> sounds good :)
20:07:22 <misc> ok so thanks for coming
20:07:26 <misc> #endmeeting