19:07:02 <misc> #startmeeting
19:07:02 <Inigo_Montoya> Meeting started Wed Jun 15 19:07:02 2011 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:07:02 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:07:02 <erzulie> [ MeetBot - Debian Wiki ]
19:07:06 <misc> #name packager
19:07:09 <misc> #chair ennael
19:07:09 <Inigo_Montoya> Current chairs: ennael misc
19:07:29 <ennael> #topic post-mortem review
19:07:34 <damsweb> hello all
19:07:44 <ennael> ok first topic is about post-mortem of this first release
19:08:22 <ennael> here is a temporary report
19:08:23 <ennael> http://pastebin.com/At8f2WeE
19:08:24 <erzulie> [ Improve freeze planning ----------------------- - i18n: add string freeze - f - Pastebin.com ]
19:08:44 <ennael> I will post it after meeting and keep it also in wiki
19:09:07 <ennael> one frequent comment is about freeze planning
19:09:25 <ennael> we will have to add dates for i18n and artwork teams
19:09:42 <ennael> was missing for strings in i18n
19:09:54 <ennael> also artwork integration was done in a hurry until last minute
19:09:59 <ennael> which is hardly manageable
19:10:19 <ennael> the other point is about following freeze dates
19:10:56 <ennael> despite rules that were explained lots of time we still had lots of packages with new version
19:12:06 <ennael> this may be linked to the 3rd point
19:12:16 <ennael> about bug fixing and tests
19:12:50 <ennael> looks like we *really* miss tests and and bug fixes
19:13:10 <ennael> so this is about triage and QA
19:13:37 <tmb> and tests on _real_ hw, not only virtual machines...
19:13:42 <ennael> and also people more interested in upgrading packages than fixing bugs
19:13:46 <ennael> yep
19:14:26 <ennael> so we really have to think about the way we can improve this
19:14:33 <damsweb> tmb: agree but only 4 ppl were testing on VM
19:14:34 <ennael> motivate people on triage and bug fixing
19:14:48 <ennael> damsweb: well only 4 people were testing isos
19:14:59 <spturtle> maintainers + database would be first step
19:15:04 <ennael> sure
19:15:06 <tmb> maybe list on wiki: testers, available hardware to test
19:15:24 <ennael> but still triage and tests are not seen as valuable tasks in distro
19:15:38 <ennael> see when we want to add triage step in mentoring
19:15:52 <xardas008> yes we should
19:16:15 <ennael> but even if we have thousands of packagers, without any tests and triage no need to go on
19:17:01 <xardas008> we should not import any package which is not tested by the packager himself
19:17:35 <misc> we already do
19:17:50 <misc> and that doesn't solve the problem of testing isos, and triage :/
19:17:56 <ennael> yep
19:18:23 <ennael> so I guess we will start some training support for QA on isos
19:18:33 <ennael> damsweb is on it to make it easier
19:18:43 <ennael> but still we will need volunteers
19:18:50 <ennael> same thing for triage
19:19:11 <brianb__> maybe there should be a irc channel set aside for this
19:19:24 <ennael> there is already a qa one
19:19:38 <ennael> but without anybody it's just unusefull
19:19:40 <tmb> and adding channel does not help if no-one join...
19:19:41 <Nanar> I'am afraid there is too many irc channel already
19:19:52 <damsweb> we need to have a list of "always available HW for test if needed". On the wiki will be enough, no need to have a glpi or other inventory thing but it's important to know who is available and what HW can he provide (the lack of a physical HW lab is too big)
19:19:55 <ahmad78> yep, the triage channel should be dropped, I think
19:20:11 <ennael> ahmad78: join QA and triage if needed
19:20:19 <ennael> and triage should happen mainly on -dev
19:20:21 <ahmad78> triage should be right here
19:20:25 <ennael> :)
19:21:51 <ennael> so imho Mageia future is not only specs but the way we will be able to solve that point
19:23:16 <AL13N> maybe we can find volunteers to test on forii?
19:23:24 <AL13N> fora?
19:23:31 <brianb__> a quick way of testing for harware compatability is with a live iso and surly that should be released before the non live DVD
19:24:03 <misc> there is a automated rebuild of live
19:24:10 <xardas008> yeah a live cd would be nice. some guys have a slow internet connection and do not want to download 4gb
19:24:13 <ennael> #action use pre released live cds to test hardware
19:24:18 <brianb__> from the DVD?
19:24:21 <ennael> misc: we have to make it available
19:24:23 <Nanar> I am not sure live will trigger all issue
19:24:31 <ennael> Nanar: it can help to start with
19:24:37 <xardas008> not all, but you can see most of it i think
19:24:40 <sebsebseb> brianb__: Live CD is  one way to test hardware,  but they also take time to build
19:24:46 <Nanar> especially on big hardware/ server hardware
19:24:48 <brianb__> but it will capature quite alot
19:25:00 <misc> sebsebseb: that's automated
19:25:06 <ennael> I really think isos are not the biggest issue
19:25:07 <sebsebseb> misc: ok
19:25:13 <ennael> triage worries me much more
19:25:47 <ennael> because it has to be done all the time not only during release time
19:25:58 <misc> yes, or thing get out of control :/
19:26:09 <ennael> also we had a proposal "more time allocated to bugfixing between pre-release and freeze"
19:26:23 <ennael> which will be unuseful as most of the time
19:26:32 <ennael> we wait for last minute to fix bugs
19:26:51 <AL13N> it could work, but requires more QA, imho
19:26:56 <xardas008> maybe regularly bug days would help a little bit?
19:26:59 <Nanar> longer freeze time ?
19:27:01 <ennael> because it's less interesting and/or we do not have triage enough
19:27:15 <xardas008> looking on bugzilla and evaluate and triage bugs on a special topic
19:27:41 <ennael> it's hard to organize
19:28:04 <AL13N> perhaps we need a good QA leader who can make that happen
19:28:06 <ennael> also people will get bored
19:28:15 <ennael> AL13N: QA != triage
19:28:15 <ofaurax> hello
19:28:17 <ofaurax> hi tmb
19:28:22 <ennael> ofaurax: meeting in progress
19:28:35 <ofaurax> oups, sorry
19:28:42 <ennael> we really have to think about it
19:28:45 <AL13N> ennael: i meant qa not during release time, so triage
19:29:03 <ennael> make triage something as "sexy" as packaging
19:29:15 <AL13N> but packaging is not sexy
19:29:33 <spturtle> people running cauldron helps a lot
19:29:33 <Nanar> packaging is, more than triage
19:29:37 <grenoya> is there training support for triage ?
19:29:44 <AL13N> otoh, packager have counters (accomplishments) # of packages for instance
19:29:50 <AL13N> perhaps triage needs a counter too
19:29:58 <AL13N> a # of triaged bugs counter
19:30:01 <spturtle> so cauldron needs to be usable
19:30:17 <ennael> spturtle: cauldron is rather usable
19:30:24 <ennael> that's not really the point
19:30:37 <ennael> but lots of bugs fixed in last minute could have been done much before
19:30:38 <misc> ( provided you are wlling to switch de from time to time :) )
19:31:06 <AL13N> triaging is also for stable
19:31:13 <ennael> sure
19:31:28 <brianb__> is there any SPC stats applied to bugs?
19:31:31 <AL13N> training helps, but not if there are no volunteers
19:31:33 <Nanar> who is in charge of triage at time ?
19:31:34 <damsweb> I think that the maint DB will help a lot for mga2 so perhaps we should focus on helping stormi to work on it
19:31:40 <misc> maybe we could forbid packager to upload a new packages unless they do triage X bugs :)
19:31:41 <AL13N> Nanar: afaik noone
19:31:51 <damsweb> misc: :)
19:31:52 <ennael> Nanar: ahmad78 is doing the big work
19:31:54 <ennael> http://mageia.org/wiki/doku.php?id=triage_guide
19:31:55 <erzulie> [ triage_guide [Mageia temporary wiki] ]
19:31:55 <Stormi> damsweb: I'm not working on the maintdb :)
19:32:02 <ennael> written by ahmad78
19:32:12 <grenoya> AL13N: I could be volunteer if i have training :)
19:32:19 <AL13N> afaik ahmad78 didn't want to be leader
19:32:19 <damsweb> Stormi: bah completion ;)
19:32:28 <damsweb> I meant shikamaru
19:32:32 <ennael> ahmad78: can you give some help for new comers ?
19:32:34 <Nanar> does he agree to train people on this ?
19:32:37 <ahmad78> ennael: imported from mdv wiki (so written by adamw, and imported/edited for mageai by me)
19:33:06 <Nanar> ahmad78: can you train people ?
19:33:14 <Nanar> to help you
19:33:20 <ahmad78> ennael: sure, they just read the docs, and I can help them at the begining as much as I can
19:33:27 <ahmad78> Nanar: yeah
19:33:36 <ennael> moreover I really think working on triage can also help a lot trainees for packaging
19:33:56 <ennael> they learn a lot about how works on distro
19:34:32 <brianb__> is there any policies and procdures in place
19:34:38 <adamw> ahmad78: you can check out fedora bugzappers stuff too and see if there's anything you can use
19:34:43 <Nanar> should we force futur packager to do triage ?
19:34:46 <ennael> so even if we are in the middle of packaging meeting I guess we should join triage in our topics in a regular way
19:34:48 <adamw> https://fedoraproject.org/wiki/BugZappers
19:34:50 <erzulie> [ BugZappers - FedoraProject ]
19:34:51 <adamw> i wrote quite a bit of that
19:34:59 <ennael> thanks adamw :)
19:35:15 <misc> Nanar: that's something that crossed my mind
19:35:15 <ennael> Nanar: that was proposed in previous meeting
19:35:26 <ahmad78> adamw: no, checking fedora triage stuff makes me sad about how measly the triage docs in our wiki is (my fault, kind of) :)
19:35:30 <Nanar> ennael: ah, ooops
19:35:42 <adamw> well, bugzappers is kinda dormant atm so don't feel too bad :(
19:35:43 <ennael> :)
19:35:55 <adamw> fedora wiki is CC-licensed btw so you can happily copy/paste big chunks of it
19:36:02 <ennael> ok great
19:36:02 <adamw> that's how i wrote mandriva's licensing policy =)
19:36:06 <ennael> :)
19:36:15 <AL13N> misc: Nanar: i have no objection about this, but this may up the bar for packagers...
19:36:15 * Hawkwind Peeks in and looks around
19:36:23 <ennael> so are you ok to add triage in packaging meeting?
19:36:27 <adamw> if mageia copied mandriva's licensing policy then what you now have is fedora's licensing policy THIRD-hand, haha
19:36:39 <ennael> :)
19:36:59 <ahmad78> ennael: sure
19:37:24 <ahmad78> FWIW, some people are already helping with triage, e.g. leuhmanu (and tv, but that doesn't need to be said)
19:37:36 <misc> #agreed speak of triage during packagers meeting on a regular fashion
19:37:44 <ennael> we also can think about how adding triage and bug fix in mentoring process
19:37:53 <brianb__> so bugzapper are they also maintainers as well?
19:37:54 <damsweb> sounds good way to improve things
19:37:58 <ennael> so that it does not double time for it but help on it
19:38:23 <ennael> brianb__: it can be as maintainers should triage their own bugs also
19:38:32 <ennael> but we need more regular guys looking at it
19:39:07 <adamw> the idea of triage is for non-maintainers to do it in order to lessen the burden on maintainers
19:39:11 <adamw> but it doesn't always work out that way
19:39:17 <ennael> yep
19:39:17 <ahmad78> yep
19:40:15 <ennael> ok we can speak again about it in mentoring topic
19:40:50 <brianb__> if there is a mantainer element then that would help people with understanding some packaging espically if they work with a packager
19:41:03 <zemo> good afternoon everyone :)
19:41:05 <ennael> a mantainer element ?
19:41:16 <ennael> brianb__: what do you mean ?
19:41:23 <brianb__> yes to the triage/bug zapper
19:41:37 <ennael> having official maintainers ?
19:42:28 <brianb__> well i gues you are short on the ground of official maintainer too
19:42:45 <ennael> the point is we have no maintainers db for now
19:42:49 <misc> technically and as any project, we are short on everything :)
19:42:53 <ennael> :)
19:42:57 <AL13N> :-)
19:42:58 <misc> there is just stuff where we are more short than other
19:43:07 <ennael> I have to post on -dev to get people on finalizing maintainers db
19:43:18 <AL13N> i think we're more short on maintainer db, than on maintainers
19:43:30 <ennael> meaning ruby devs
19:43:50 <Nanar> or rewritting it
19:44:00 <ennael> maybe if we have no volunteers
19:44:14 * Nanar look the sky
19:44:31 <ennael> "hey why not rewritting it in perl ?"
19:44:48 <ennael> Nanar: you win
19:44:52 <Nanar> ennael: did you see this star, on the top ,
19:44:52 <AL13N> :-)
19:44:54 <Nanar> ?
19:45:01 <xardas008> ennael: that would be more worse than writing it in ruby
19:45:14 <ennael> xardas008: why?
19:45:28 <xardas008> why not using python, python is easy
19:45:30 <AL13N> maybe we should rewrite in php
19:45:32 <ennael> really if we can rewritte it quickly then go on
19:45:35 <AL13N> :-)
19:45:37 <misc> well, volunteer can send patch
19:45:37 <xardas008> i heard only bad things about perl
19:45:58 <stewb> we need the functionality more than a particular language
19:46:00 <boklm> the one who rewrites it can choose his favorite language
19:46:01 <Nanar> xardas008: do agree to write somethings ?
19:46:10 <Stormi> AL13N: why not, that's not worse than other languages if done well :)
19:46:12 <xardas008> Nanar: sure, if java is ok?
19:46:15 <ennael> any volunteer to work on it?
19:46:30 <misc> ennael: there is a lot, we can organize some kind of race
19:46:31 <AL13N> Stormi: hey, i was serious
19:46:35 <ennael> misc: :)
19:46:41 <Nanar> ennael: I'll check my calendar first, don"t want to promise to quickly
19:46:42 <misc> and then get money with having a bookmaker team
19:46:50 <ennael> :)
19:46:59 <Stormi> what's the status of the current maintdb code ?
19:47:00 <AL13N> ennael: misc: well, we need to keep in mind the requirements
19:47:05 <Stormi> is there much missing ?
19:47:11 <ennael> #action check volunteers who would like to finalize maint db
19:47:13 <AL13N> imho: yes
19:47:18 <misc> Stormi: I think it was working
19:47:25 <ennael> pb is ruby is not that used in Mageia community
19:47:42 <ennael> it seems to be a mess when we need volunteers to work on it
19:47:49 <Stormi> seen kosmas
19:47:49 <xochiquetzal> kosmas was last seen in #mageia-dev 63 days 7 hours ago joining the channel.
19:47:50 <AL13N> any good coder can write in any language
19:47:58 <ennael> no news from kosmas
19:48:30 <Stormi> I'm almost sure I saw him on an irc channel today
19:48:30 <xardas008> is there any spec about that tool
19:48:32 <xardas008> ?
19:48:37 <boklm> yes, on the wiki
19:48:43 * boklm look for the page
19:48:47 <AL13N> i would rewrite something from my own framework, but i need to finalize other stuff first, so i'm passing
19:48:58 <ennael> http://mageia.org/wiki/doku.php?id=web:maintdb&s[]=maint&s[]=db
19:48:58 <erzulie> [ web:maintdb [Mageia temporary wiki] ]
19:49:14 <Nanar> if we could avoid java... IMHO
19:49:29 <AL13N> we should avoid hard to package apps
19:49:33 <AL13N> ie: java, ruby
19:49:49 <misc> well, the meeting is not about plan of rewriting a application
19:49:52 <pterjan> why is ruby hard to package ?
19:49:53 <misc> but about postmortem
19:49:55 <xardas008> why are java packages hard to package?
19:50:06 <AL13N> pterjan: the current maintainersdb is hard to package
19:50:14 <ennael> okok
19:50:14 <misc> AL13N: no, it is packaged
19:50:16 <AL13N> xardas008: ask dmorgan about that
19:50:23 <ennael> please :)
19:50:29 <ahmad78> not package, maintain, fix, integrate...
19:50:30 <misc> ennael: let me handle that
19:50:32 <AL13N> misc: ah, i seem to remember earlier requirements being harsh on sysadmin
19:50:39 <misc> so everybody who speak will have his account closed
19:50:46 <ennael> :)
19:50:53 <pterjan> is writing ok?
19:50:53 <misc> ennael: see, it worked :)
19:50:58 <ennael> :)
19:51:00 <AL13N> :-)
19:51:05 <ennael> just to summarize
19:51:08 <ahmad78> misc: so, will you close your account?
19:51:14 <ahmad78> :p
19:51:18 <AL13N> :-)
19:51:23 <ennael> one big point in post-mortem is about bugs fixing and triage
19:51:26 <ennael> + QA
19:51:38 <ennael> we join triage in packaging team
19:51:49 <ennael> damsweb will work on ready to use process
19:51:57 <ennael> ahmad78 will help new comers
19:52:04 <ennael> we have to finalize maint db
19:52:15 <AL13N> some kind of #info?
19:52:37 <ennael> about that last point our main focus is about being able to develop it and maintain it easily because we have resources
19:52:51 <brianb__> what is the current number of bugs?
19:53:04 <AL13N> 800+ open bugs iirc
19:53:07 <ennael> Nanar will tell us if he can help but if any of you is available and has proposals feel free to raise hand
19:53:20 <pterjan> I can try to have a look at current code
19:53:47 <ennael> #action pterjan will have a look on maint db code
19:53:55 <Nanar> I'll reply after pterjan look current code
19:54:08 <Nanar> if xcurrent can work, useless to redo it
19:54:09 <grenoya> maybe I can help if it is rewritten en python
19:54:12 <ennael> yep
19:54:30 <pterjan> Nanar: contact your lawyer too before answering
19:54:38 <ennael> you should indeed:)
19:55:02 <AL13N> pterjan likely has a team of lawyers at his disposal
19:55:16 <ennael> ok anything else to add ?
19:55:20 <ennael> on that topic
19:55:24 * spturtle would help code maintdb if java based
19:55:25 <AL13N> no
19:55:46 * Nanar suggest to everyone start, best code win
19:55:56 <ennael> ok
19:56:02 <spturtle> grenoya also good idea
19:56:08 <Nanar> I was kidding
19:56:14 <ennael> #topic small review about current discussion / cycle release
19:56:16 <xardas008> Nanar: why not?
19:56:39 <ennael> so not much time left to give your opinion
19:56:47 <Nanar> xardas008: it's a wxaste of time, I have lot of other things to finish already
19:56:47 <ennael> it's now or never (on ML of course)
19:56:48 <spturtle> not many people with time to waste
19:57:28 <ente> circular releases
19:57:43 <ennael> woot new concept
19:57:49 <misc> anyway, next topic ?
19:57:55 <erwan_taf> get perpendicular
19:57:59 <ennael> yep
19:58:01 <boklm> cloud release
19:58:08 <AL13N> :-)
19:58:16 <ennael> misc: can you close boklm and erwan_taf accounts ?
19:58:22 <ahmad78> (yes, people who have time don't hav the experience, and people who have the experience don't have time, that's that the same as 42)
19:58:26 <boklm> :)
19:58:29 <ennael> #topic start of stable updates
19:58:33 <ennael> ok
19:58:42 <ennael> stewb: around?
19:58:50 <stewb> yep
19:58:58 <ennael> can you sum up situation?
19:59:04 <brianb__> can you summerize on the release cycle i just gave up reading all the emails on the ML list what is the perfered release cycle?
19:59:14 <ennael> brianb__: we will do later
19:59:30 <stewb> sure, so as I mentioned on the -dev, most of the pieces are in place to start updates
19:59:42 <pterjan> The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
19:59:42 <pterjan> Apache Server at gitorious.org Port 443
19:59:51 * pterjan will look at maintdb later
20:00:02 <stewb> I selected 2 packages, with open bugs as trial runs, subversion and vde2
20:00:31 <stewb> now we need the maintainer(s) to create update packages, test, and pass to QA
20:01:03 <stewb> or any willing packager
20:01:31 <pterjan> I had prepared update for flash (already in nonfree/updates_testing)
20:01:35 <misc> I guess I can take the vde2
20:01:48 <stewb> there is a preliminary policy doc at http://mageia.org/wiki/doku.php?id=updates_policy
20:01:49 <erzulie> [ updates_policy [Mageia temporary wiki] ]
20:01:56 <misc> ( since I imported : http://sophie.zarb.org/rpms/36778558ade6dff1511dab8748b50264/changelog )
20:01:57 <erzulie> [ Sophie: vde2-2.2.3-1.mga2 i586 ]
20:02:08 <stewb> pterjan: so lets push that through too
20:02:23 <ennael> there is one also about mysql
20:03:06 <ennael> package is in testing
20:03:11 <stewb> I suspect we might stumble a little getting these first few out, but hopefully will converge on a working process
20:03:12 <erwan_taf> stewb: I do have a nice one on curl also that could affect the instability on the product
20:03:20 <erwan_taf> s/on/of/
20:03:38 <boklm> do we/should we have a mailing list to announce updates ?
20:03:50 <misc> boklm: yes
20:03:56 <pterjan> we should
20:03:58 <erwan_taf> instability -> the way of installing the product
20:04:15 <pterjan> installability ? :)
20:04:22 <AL13N> :-)
20:04:33 <erwan_taf> pterjan: sorry
20:04:56 <erwan_taf> you're perfectly right
20:05:06 <stewb> erwan_taf: great, bring 'em on :)
20:05:09 <ennael> stewb: so back to our topic :)
20:05:11 <misc> so a list called updates-announce , for package pushed in updates ?
20:05:16 <ennael> yep
20:05:38 <AL13N> stewb: can we finish the "fix me" in your wiki page somehow?
20:05:42 <stewb> I'd guess there are upwards of 30 or more CVEs I've seen go by that could affect us
20:05:43 <misc> ( ie, backport are announced using another lists )
20:05:51 <stewb> AL13N: of course
20:05:55 <adamw> coling: ping again?
20:05:58 <erwan_taf> stewb: https://bugs.mageia.org/show_bug.cgi?id=1813
20:06:00 <erzulie> [ Bug 1813 - Curl 7.21.5 fails with SSL proxy ]
20:06:16 <misc> #action misc create a list "updates-announce" for sending update
20:06:23 <stewb> AL13N: it's a wiki, and we're a community :)
20:06:35 <ennael> so for updates candidates how do we proceed to start with?
20:06:40 <AL13N> stewb: well, i think that particular issue needs to be decided
20:07:04 <stewb> build packages, builder test -> QA
20:07:16 <ennael> ok looks like we have already built one
20:07:19 <coling> adamw, pong!
20:07:29 <ennael> so tests and QA
20:07:40 <ennael> stewb: can you make a list of these candidates?
20:07:50 <ennael> so that we have people to work on it
20:08:22 <stewb> sure, where would you like them?
20:08:42 <boklm> on bugzilla ?
20:08:56 <ennael> well on -dev ML and we follow that thread until first updates are released
20:08:58 <stewb> they're in bugzilla
20:09:03 <ennael> of course base on bugzilla links
20:09:25 <tmb> misc: does that mean we should add a backports-announce too ?
20:09:26 <stewb> ok, I'll follow up with bug links
20:09:43 <pterjan> I usually browse security component on bugzilla
20:09:53 <stewb> AL13N: my thought is we refine the process/policy as a result of this trial run
20:10:06 <ennael> http://mageia.org/wiki/doku.php?id=qa_updates
20:10:07 <erzulie> [ qa_updates [Mageia temporary wiki] ]
20:10:11 <stewb> we *really* need to start getting updates out the door and not discuss forever
20:10:15 <ennael> here is QA process proposed by damsweb
20:10:27 <ennael> it's also based on what we used in mandriva
20:10:38 <AL13N> stewb: yes
20:10:39 <misc> tmb: depend, maybe using madb would be better ( ie have people subscribed to the package they prefer, rather than seeing everything )
20:10:58 <damsweb> I just have to fix mail address and other info about groups (secteam, etc...) but all is here for the first needs
20:10:59 <ennael> stewb: we can add a link to this page
20:11:02 <misc> tmb: but I think this should be discussed to see the workflow of backports using people :)
20:11:20 <ennael> misc: stop speaking or I close your account
20:11:21 <stewb> ennael: ok, misc: lol
20:12:49 <stewb> anything else on updates?
20:12:57 <ennael> any questions ?
20:13:19 <ennael> stewb: when this is finalized can you think about a blog post about all this?
20:13:23 <AL13N> stewb: well, i only have a package that is new and was "missing" on mga1
20:13:53 <stewb> AL13N: I'm ignoring that aspect for the moment
20:14:00 <stewb> ennael: yep, sure
20:14:12 <ennael> thanks
20:14:35 <Stormi> What about opening the gates for backports ? Do we wait for a backports policy ?
20:14:36 <ennael> #action stewb will post list of first updateds on -dev so that we can follow process and adjust it if necessary
20:14:40 <stewb> there is a mention of the "missing" packages in the policy, pending whatver the final decision is
20:15:01 <AL13N> stewb: that was the "fixme" i was referring to earlier
20:15:03 <ennael> #action stewb will propose a blog post when updates process is all ready
20:15:12 <AL13N> stewb: but ok, i'll hold off
20:15:40 <stewb> Stormi: I'm ignoring backports too, I really care about getting bugs fixed and security issues addressed or we're going to get a bad reputation
20:15:58 <ennael> yep we already have lots of questions about it
20:16:12 <misc> Stormi: well, I would wait for a backport policy yes
20:16:31 <stewb> I'd rather have a bad rep for being "old" than buggy and insecure, given the choice
20:16:32 <ennael> speaking about it any volunteer to work on it ?
20:16:33 <misc> Stormi: while they are important, I think updates are a little bit more urgent :)
20:16:55 <Stormi> misc: if we can't work them in parallel, then of course updates are more important :)
20:17:29 <ennael> ok next topic ?
20:17:34 * stewb waits for the rush of volunteers
20:17:39 <ennael> :)
20:17:41 <brianb__> work on what ennael?
20:17:53 <ennael> brianb__: backports policy
20:18:06 <ennael> but this can wait first updates are out
20:18:20 <Stormi> I can start a thread on the ML
20:18:41 <ennael> ok
20:19:28 <ennael> #topic mentoring process
20:19:30 <brianb__> a distro being buggy and unstable is not a good advert for potential new users
20:20:07 <ennael> so here is an updated page
20:20:08 <ennael> http://mageia.org/wiki/doku.php?id=packages_mentoring
20:20:09 <erzulie> [ packages_mentoring [Mageia temporary wiki] ]
20:20:28 <ennael> I've mailed all mentors so that they can update current status
20:20:32 <ennael> it's in progress
20:20:49 <ennael> Remmy mailed also about having somebody to manage this more carefully
20:20:55 <ennael> Remmy: around ?
20:21:06 <Stormi> am I Remmy ? :)
20:21:16 <ennael> mmm
20:21:21 <misc> Stormi: no, you are Stormi
20:21:24 <ennael> oups
20:21:27 <ennael> wrong nick :)
20:21:36 <ennael> sorry
20:21:48 <Stormi> so yes, we have 2 candidates
20:21:55 <ennael> looks like we found a victim^w^wvolunteer
20:21:58 <Nanar> ennael: toucpad ? /o\
20:22:08 <ennael> Nanar: no, brain...
20:22:08 <xardas008> oh ok if i am a victim xD
20:22:14 <ennael> :)
20:22:16 <Stormi> xardas008 and andre999. I could interview xardas008 but not andre999 yet
20:22:48 <Stormi> because of timezone constraints
20:23:33 <ennael> can you sum up proposal?
20:23:42 <brianb__> take it this is the job that was banded about on the ML?
20:23:47 <Stormi> ennael: the "job offer" ?
20:23:50 <ennael> yep
20:23:58 <ennael> brianb__: yep
20:24:12 <AL13N> "mentoring coordinator"
20:24:22 <Stormi> the core is ensuring every goodwilling volunteer is taken care of
20:24:26 <Stormi> speaking of packaging
20:24:58 <Stormi> so the first recurrent tasks are keeping track of who needs mentoring, who is being mentored, who can mentor
20:25:23 <brianb__> Some stats: from the list of registered people ref wiki page on mentoring 11 people have no packing experience at all, 60 people have varying degrees of packaging experience, and there are 43 mdv packagers
20:25:59 <Stormi> other tasks that would be good from the "coordinator" is promoting mentoring
20:26:10 <Stormi> probably working with the marcom team
20:27:22 <ennael> ok when do you think we will have this guy.
20:27:23 <ennael> ?
20:27:50 <Stormi> I think we can choose from the 2 remaining candidates before the end of this week
20:28:07 <ennael> ok nice
20:28:08 <Stormi> I don't know exactly how to choose, because the 2 have good points for them
20:28:23 <ennael> we can kill one and keep second
20:28:30 <misc> Stormi: mud fight, if no one win, throw some knife
20:28:35 <misc> that's how we select admin for plf
20:28:35 <ennael> :)
20:28:38 <Stormi> must I just choose one, or let the board decide, or (but I fear that option) use votes
20:28:40 <xardas008> ok then pls kill andre (i hang on my life though)
20:28:47 <ennael> ok
20:29:02 <ennael> so given this we will wait then to go further on that topic
20:29:17 <ennael> if mentors around in that chan please update this wiki page
20:29:33 <ennael> also for trainees as it seems some of them just let i down without mention
20:29:48 <Stormi> Are people ok if I choose the candidate myself ?
20:30:13 <ennael> well if we do not agree we will kill you first
20:30:21 <Stormi> great :/
20:30:28 <ennael> and this does not prevent to have 2 people working on this
20:30:43 <Stormi> indeed, there a third one who is not candidate but eager to help
20:30:50 <misc> Stormi: I am ok if you choose, yes
20:31:02 <Stormi> and a fourth one who was candidate but already is too busy :)
20:31:13 <AL13N> perhaps mentors could vote
20:31:26 <ennael> let make it easy
20:32:06 <ennael> any question?
20:32:28 <damsweb> nop
20:32:57 <ennael> misc: ?
20:33:37 <misc> ennael: ?
20:33:40 <misc> ennael: ok for me
20:33:56 <ennael> they are all sleeping
20:34:01 <ennael> let end the meeting
20:34:03 <misc> yep
20:34:04 <xardas008> not yet
20:34:10 <xardas008> still awake
20:34:11 <damsweb> :)
20:34:14 <ennael> #endmeeting