19:06:51 <misc> #startmeeting
19:06:51 <Inigo_Montoya> Meeting started Wed May  4 19:06:51 2011 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:51 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:06:52 <erzulie> [ MeetBot - Debian Wiki ]
19:07:00 <misc> #name packager
19:07:03 <misc> #chair ennael
19:07:03 <Inigo_Montoya> Current chairs: ennael misc
19:07:56 <misc> so let's start with the upcoming release
19:08:02 <misc> #topic next release
19:08:31 <misc> as explained before, there will be a release freeze soon, and a rc1 that will be exactly that, a release candidate
19:08:51 <misc> release freeze mean that no package will be uploaded, unless this is a bugfix
19:09:22 <misc> but I will let ennael explain the process
19:09:30 <ennael> :)
19:09:53 <zemo> good afternoon :)
19:09:56 <ennael> ok so as mailed freeze is coming
19:10:17 <ennael> RC will be released for 18th of may
19:10:29 <ennael> we will start working on isos about 3 days before
19:10:35 <zemo> misc: runnning virt-manager, runs gest OS slowly?
19:10:45 <misc> zemo: meeting right now, can we see later ?
19:10:47 <ennael> zemo: please, meeting in progress
19:10:53 <zemo> no problema
19:11:13 <ennael> time between RC and final is only dedicated to finalize isos
19:11:17 <Nanar> when does the freeze start ?
19:11:22 <ennael> and maybe fixes if it needs
19:11:43 <saispo> Nanar: 10th no ?
19:11:46 <ennael> yep
19:11:50 <Nanar> k
19:11:53 <AL13N> ennael: how is translation done? is that also before release freeze?
19:11:54 <ennael> so 6 days left
19:12:07 <ennael> translation should happen in same time
19:12:22 <ennael> again if some are coming later we may add it and push packages
19:12:33 <zemo> is still possble to update portuguese transaltion before next release?
19:12:38 <ennael> but we have to keep in mind this freeze date
19:12:53 <misc> zemo: yes, see with i18n people
19:13:35 <ennael> http://mageia.org/wiki/doku.php?id=iso1:countdown
19:13:36 <erzulie> [ iso1:countdown [Mageia temporary wiki] ]
19:13:43 <ennael> you can have a first look here
19:13:50 <ennael> this is a draft of very last days work
19:13:58 <ennael> switching from cauldron to stable release
19:14:18 <ennael> we will need volunteers to work on release notes and errata
19:14:50 <ennael> http://mageia.org/wiki/doku.php?id=mageia1_notes
19:14:51 <erzulie> [ mageia1_notes [Mageia temporary wiki] ]
19:14:58 <ennael> release notes can be started now
19:15:09 <misc> #info volunteer needed for release note and errata
19:15:20 <ahmad78> I volunteer for that (though I would have liked to work on a mediawiki installation)
19:15:21 <zemo> misc: well i still the account activated, when logging in transifex reports inactive account
19:15:54 <misc> #info ahmad78 is volunteer for release notes
19:16:11 <stewb> zemo: please wait for the meeting to end
19:16:18 <ennael> we will need also volunteers to work with marketing team on Mageia 1 tour
19:16:53 <misc> ie, more precisely ?
19:17:03 <ennael> well less technical document
19:17:08 <saispo> ennael: for example ?
19:17:11 <ennael> more user side
19:17:18 <ennael> KDE in images for example
19:17:56 <ennael> this can be used then by reviewer
19:18:31 <ahmad78> screehshots... etc
19:18:35 <ahmad78> markenting stuff
19:18:35 <misc> #info help needed for marketing team to produce document ( screenshot, etc )
19:19:23 <saispo> the Mageia marketing is oriented on Kde ?
19:19:36 <ennael> no was an example
19:19:40 <saispo> ok
19:19:41 <Kharec> lo
19:20:06 <ennael> any question on that subject ?
19:20:16 <spturtle> so an introduction on the mageia OS, focusing on features
19:20:18 <saispo> at this time no, but can help ahmad78
19:20:21 <ennael> yep
19:20:30 <mikala> ennael: all thoses screenshot should the one from a default install
19:20:36 <ennael> yep
19:20:43 <mikala> or it can be with others packages available in mageia
19:20:46 <mikala> ok.
19:20:53 <ennael> even if we do not have big new feature we need to explain mageia
19:21:07 <misc> you can just change the color and tout this as "new feature"
19:21:12 <ennael> mikala: everything that can be valuable
19:21:17 <ennael> tsss
19:21:29 <saispo> ennael: and speaking a lot on the control center, i think it's a big difference between other distro
19:21:37 <ennael> sure
19:21:48 <saispo> misc: yep, with purple, ennael like that :)
19:21:55 <ennael> oh while we are speaking about this
19:22:03 <ennael> one proposal about draksnapshot
19:22:12 <ennael> it needs lots of work
19:22:16 <saispo> for taking scressnhot ? ;)
19:22:23 <ennael> we have quite a lot of bugs opened on it
19:22:28 <saispo> ok, excuse me, it's too late ..
19:22:37 <ennael> shall we remove it in default install ?
19:22:41 <mikala> yep
19:22:53 <saispo> ennael: maybe a reworking on it needed and may include brtfs ?
19:22:54 <ennael> then we can work on it after release
19:23:05 <misc> I think it would be better to not install it, yes
19:23:09 <saispo> but i think a this time, the work on it is hughe and may be delayed no ?
19:23:14 <ennael> ok
19:23:16 <ahmad78> yes, but not installed by default
19:23:20 <mikala> saispo: btrfs is not for end users so.
19:23:21 <ennael> saispo: after stable release
19:23:28 <ennael> ok
19:23:39 <ennael> also
19:23:46 <misc> afaik, the work to make it work was quite simple
19:23:54 <saispo> mikala: i have some idea about that, see apt plugin with brtfs, maybe urpmi can integrate it ?
19:24:07 <ennael> well it needs also some rework in ergonomy
19:24:07 <saispo> misc: you think ?
19:24:07 <misc> https://qa.mandriva.com/show_bug.cgi?id=58534
19:24:09 <erzulie> [ Bug 58534 - draksnapshot does not set intervals for rsnapshot (at least one backup level must be set error) ]
19:24:23 <saispo> misc: perl program ?
19:24:45 <misc> saispo: yes
19:24:56 <saispo> not for me..
19:25:02 <ennael> also we are going to import mandriva-seed
19:25:13 <ennael> it's GPL code and usefull for endusers
19:25:20 <ennael> to dump isos on usb key
19:25:24 <misc> #agreed draksnapshot requires some love and will not be on default installation
19:25:45 <ennael> it's working quite well but needs some fixes for vista and seven
19:25:51 <ennael> python used inside
19:25:59 <ennael> any volunteer to have a look on it ?
19:26:11 <ahmad78> on linux dd works, problem is mostly about windows users...
19:26:12 * misc has no vista nor seven
19:26:24 <misc> ennael: do we have a list of errors ?
19:26:49 <ennael> well it seems it's mainly a pb to access usb device
19:26:56 <mikala> ennael: by import you mean we're going to *package* it too
19:26:59 <saispo> ahmad78, misc : hard for this :x but if we need a python windows coder, i can convince a friend for helping us
19:27:00 <ennael> due to modifications in registry database
19:27:11 <mikala> & not only put it on the ftp?
19:27:16 <ennael> mikala: yep
19:27:23 <mikala> nice.
19:27:26 <saispo> ennael: and i think the 32bits and 64 bits registry under 7 is different
19:27:52 <ennael> saispo: so do you think this guy could help in coming days ?
19:28:19 <saispo> ennael: we can ask him
19:28:31 <spturtle> what does draksnapshot do on windows? I have VMs with win7 so I could take a look
19:28:43 <ennael> not draksnapshot
19:28:46 <misc> spturtle: mandriva-seed on win7 :)
19:28:47 <ennael> mandriva-seed
19:28:51 <mikala> spturtle: we're talking about mandriva-seed
19:28:51 <saispo> spturtle: mandriva-seed :)
19:29:02 <spturtle> k missed that
19:29:17 <AL13N> :-)
19:30:11 <ennael> saispo: thanks
19:30:47 <misc> #action saispo ask to a friend to look for mandriva-seed on 7 and vista
19:32:01 <ennael> any other question ?
19:33:05 <AL13N> should we try to find 2nd person
19:33:09 <AL13N> as failover?
19:33:17 <ennael> we will wait for answer
19:33:28 <saispo> about security fixes, when can do a checkpoint with misc, stewb and other people who wants to be in the secteam ?
19:33:30 <ennael> if not, we will mail on -dev
19:33:37 <ennael> saispo: next subject :)
19:33:40 <ennael> topic
19:33:41 <saispo> k
19:34:04 <saispo> ennael: the three main desktop supported for release is Kde, Gnome and Xfce ?
19:34:27 <ennael> for now we have KDE, GNOME, XFCE, LXDE
19:34:32 <saispo> ok
19:34:32 <mikala> saispo: we're supposed to supported every DE we have i would say
19:34:33 <pterjan> gnome, e17, xfce, lxde
19:34:35 <ennael> saispo: next subject :)
19:34:36 <pterjan> /o\
19:34:37 <ennael> oups
19:34:43 <ennael> e17 added indeed
19:34:54 * Nanar slaps pterjan
19:35:04 <saispo> pterjan: awesome, icewm, wmfs, openbox, xmonad no ? :)
19:35:19 <saispo> ok stop trolling
19:35:21 <ennael> ok
19:35:28 <ennael> #topic secteam review
19:35:52 <ennael> stewb: can you make a short summary on work done this last week ?
19:36:23 <stewb> I can try. As you know we have a tracker bug on possible security issues.
19:36:43 <stewb> Some folks have been kind enough to fix several packages, and there are a few yet outstanding
19:37:53 <stewb> Would certainly welcome anyone to look over the list and push additional fixes
19:38:27 <ennael> any volunteer here ?
19:38:31 <misc> https://bugs.mageia.org/show_bug.cgi?id=908
19:38:32 <erzulie> [ Bug 908 - [TRACKER] rollup bug for security related issues blocking release of Mageia 1 ]
19:38:39 <misc> saispo have been doing some work on it
19:38:59 <saispo> misc: to me in this list, just php is not fixed a this time
19:39:06 <misc> saispo: and samba
19:39:09 <misc> and streamer :)
19:39:10 <saispo> mount and nfs-utils have no patches
19:39:36 <mikala> samba should simply upgrade to the last release
19:40:11 <saispo> misc: i think we can sync with bodhi security updates and see if it's in Mageia packages no ? A good part of work will be done with this trick
19:40:35 <saispo> mikala: if nothing breaking it yep, samba 3.5 under mageia ?
19:40:50 <misc> we can also use http://security-tracker.debian.org/tracker/CVE-2011-1675
19:40:51 <erzulie> [ CVE-2011-1675 ]
19:41:31 <misc> anyway
19:41:48 <misc> #info help wanted to fix security issue and find patchs
19:42:11 <pterjan> I will look at nfs-utils
19:42:22 <saispo> misc: volunteer
19:42:53 <pterjan> and mount
19:42:58 <misc> first thing is to open separate bug report, so we can track what is missing and what is not directly
19:43:08 <saispo> i think a page on the wiki is a good place to put all links about security patches, where can found them, how to apply them, etc no ?
19:43:11 <misc> #action saispo and pterjan , open bugs reports, fix packages
19:43:15 <misc> saispo: yup
19:44:02 <ennael> we should also speak about the way we will handle update after stable release
19:44:50 <mikala> ennael: it should be handled by the security team, maybe?
19:45:03 <mikala> aka thoses members have the submit right
19:45:06 <misc> #action saispo add link to the wiki about various security patch tips
19:45:27 <saispo> misc: i really love how you assign action ;-)
19:45:28 <misc> i think all packagers have the right to submit updates
19:45:58 <mikala> misc: even for version upgrade?
19:45:58 <saispo> misc: i agree, but for security hole it must be restricted no ?
19:46:08 <misc> saispo: yeah, i tend to abuse to give work to skilled volunteer , yes :)
19:46:14 <stewb> Couple of ways we could approach it, secteam people could raise awareness to the maintainer (if they don't already know)
19:46:23 <mikala> misc: for example (bad one ) firefox
19:46:27 <misc> mikala: we can restrict this on youri
19:46:38 <stewb> until we gain access to the closed list, we don't have to worry about embargo issues
19:46:40 <misc> and add some acl on upload on stable release
19:46:43 <mikala> or i would like to push all kde bugfixes releases
19:46:56 <mikala> so we can end up with kde 4.6.5 for example
19:47:06 <ahmad78> it'll have to be judged
19:47:14 <mikala> by the end of mageia 1 life
19:47:19 <ahmad78> i.e. only updates fixing major issues
19:47:30 <misc> depend on the policy we want, I would favor keeping the one of madriva, ie no version upgrade, unless exception that should be specified somewhere
19:48:08 <misc> but this also depend on the release policy
19:48:52 * Nanar agree with misc
19:49:08 <saispo> me too
19:49:19 <misc> so let's push the discussion on the ml ?
19:49:22 <saispo> after it depends if we want to do Mageia a rolling release or not :)
19:49:23 <ennael> yep
19:49:25 <mikala> misc: so youri restriction
19:49:33 <mikala> saispo: no
19:49:58 <ennael> in fact speaking about updates was more about technical infrastructure needed
19:50:09 <ennael> as we have only 3 weeks left about
19:50:40 <misc> udates, backport, etc
19:50:53 <Kharec> fioou. I'm here.
19:50:59 <Nanar> we have to ensue stability, and rolling release make this goal hard to reach
19:51:17 <saispo> yep
19:51:45 <mikala> ennael: what do you mean by technical infrastructure?
19:51:57 <misc> mikala: buildsystem
19:52:09 <mikala> specific buildsystem ?
19:52:10 <ennael> yep
19:52:11 <mikala> ok
19:52:24 <misc> well, just adding the proper config
19:52:31 <misc> pterjan,boklm,blino ?
19:53:03 <pterjan> well I may look a it but probably not in the next few days
19:53:22 <pterjan> I'd like to implement support for several medias at upload
19:53:24 <misc> well, ust to know if there is something special to do besides config change :)
19:53:56 <pterjan> it it is a separate queue, no
19:53:58 <pterjan> if
19:54:28 <misc> ok
19:54:36 <misc> so on the secteam issue, anything to add ?
19:54:36 <pterjan> but if it is separate it will fight for resources on build nodes
19:55:02 <ennael> ok shall we start discussion about this on -dev ?
19:55:12 <mikala> ennael: yep
19:55:27 <misc> about ?
19:55:42 <ennael> how to handle updates
19:55:52 <ennael> so that it's ready on time when stable is out
19:56:17 <misc> ok
19:56:40 <misc> #action misc start discussion on how to handle update
19:57:25 <ennael> stewb: want to add something ?
19:57:44 <saispo> hi black_rez
19:57:51 <saispo> black_rez -> the mageia team
19:57:57 <black_rez> hello
19:57:59 <saispo> black_rez is the culprit for mandriva-seed ;-)
19:58:12 <ennael> black_rez: thanks for helping on this
19:58:24 <mikala> need to move
19:58:54 <black_rez> ennael, it could be worst
19:58:59 <Stormi> misc: does the discussion include what can go to backports, or is it a distinct topic ?
19:59:02 <misc> ok so can we close the topic of secteam ?
19:59:08 <ennael> I guess so
19:59:15 <saispo> misc: i think
19:59:36 <misc> Stormi: well, for backport, that's the same policy that mandriva, no ?
19:59:50 <Stormi> misc: implicitly, I guess
20:00:34 <zemo> misc: the meeting is over?
20:00:38 <misc> Stormi: but I think that whatever i write, people will ask the question
20:00:41 <misc> zemo: not yet
20:01:23 <misc> so no more topic ?
20:01:35 <ennael> not for me
20:02:03 <ennael> except 6 days left for submits :)
20:02:12 <shikamaru> moin
20:02:16 <Nanar> 6 hard days !
20:02:19 <shikamaru> 6 days ? :/
20:02:24 <spturtle> and a few hundred bugs to close
20:02:34 <Nanar> shikamaru: 10 - 4 = 6, then yes
20:02:41 <misc> ok so I can close the meeting
20:02:47 <ennael> yep
20:02:50 <misc> #endmeeting