19:05:56 <misc> #startmeeting
19:05:56 <Inigo_Montoya`> Meeting started Wed Apr 27 19:05:56 2011 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:05:56 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:05:57 <AL13N> o/
19:05:57 <erzulie> [ MeetBot - Debian Wiki ]
19:06:05 <misc> #name Packagers
19:06:43 <misc> #chait ennael shikamaru
19:06:47 <misc> #chair ennael shikamaru
19:06:47 <Inigo_Montoya`> Current chairs: ennael misc shikamaru
19:07:00 <misc> ok so the lists of topic is quite light
19:07:21 <misc> not to say almost empty
19:07:54 <misc> but ennael proposed "tests bugzilla", so I will let her ( if she is ready, which doesn't seems to be the case ) start
19:08:09 <ennael> well
19:08:23 <ennael> as we are very near from final release
19:08:47 <ennael> I just wanted to put a focus on fixing bugs in bugzilla
19:08:56 <ennael> and we need to organize things around it
19:09:02 <misc> #info focus on fixing bugs
19:09:38 <ennael> for now basically iso content is quite ok
19:10:03 <misc> ( fyi : https://bugs.mageia.org/buglist.cgi?priority=release_blocker&query_format=advanced&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED )
19:10:05 <erzulie> [ Bug List ]
19:10:48 <misc> especially https://bugs.mageia.org/show_bug.cgi?id=908 ( 2 bugs ) and  https://bugs.mageia.org/show_bug.cgi?id=56( 2 bugs again )
19:10:50 <erzulie> [ Bug 908 - [TRACKER] rollup bug for security related issues blocking release of Mageia 1 ] [ Invalid Bug ID ]
19:11:19 <misc> https://bugs.mageia.org/show_bug.cgi?id=56
19:11:20 <erzulie> [ Bug 56 - [TRACKER] tracker report for upgrade issues ]
19:13:10 <misc> so has anybody question ?
19:13:12 <Anssi> when we get https://bugs.mageia.org/show_bug.cgi?id=338 fixed, shall I go over the multimedia packages and disable obvious patent offenders (h264, mpeg2, etc) that are enabled simply because they were enabled in mdv?
19:13:13 <erzulie> [ Bug 338 - We need a way to have a package built for several targets ]
19:13:28 <Anssi> (well of course I can do it before as well)
19:13:39 <misc> I think starting before would not be bad, yes
19:14:54 <misc> question is "what do we do if the bug is not fixed before the release" ?
19:16:27 <AL13N> maybe making sure we don't get to that point
19:16:59 <misc> AL13N: sure, can I assign you the task of making sure we do go to that point ?
19:17:35 <AL13N> misc: you'll have to find a sysadmin team member for that
19:17:54 <AL13N> perhaps if we don't get there, we can just build with everything enabled
19:18:10 <AL13N> if this is the alternative, i'm sure we'll fine some chinese volunteers
19:18:27 <misc> AL13N: no, this can be done by anybody able to do it in perl
19:18:48 <misc> AL13N: the sysadmin repo is open to be cloned, as is the code, so someone can send a patch
19:19:03 <AL13N> misc: and knowledge of how this stuff works
19:19:21 <shikamaru> mmh I may take a look but I don’t know when it could be ready
19:19:22 <AL13N> misc: sorry, but i need to focus on other things first
19:20:06 <tmb> AL13N: building with "everything enabled" is not an option
19:20:22 <misc> keeping mplayer in tainted would be one
19:20:38 <obgr_seneca> Yes, but building without media players for those codecs isn't either
19:20:40 <misc> ( and related package )
19:21:09 <misc> and i think gstreamer would cope more gracefully from the situation than a monolitic player like mplayer
19:21:15 <AL13N> this discussion is useless imho, we should make sure we'll not get there... we'll get alot of heat from users if this doesn't work, imho
19:21:22 <Anssi> misc: the more important one is ffmpeg and the gstreamer codecs, as those are part of default installation
19:21:35 <Anssi> and used by most video players
19:21:56 <misc> gstreamer is already splitted in sub packages, iirc
19:22:03 <obgr_seneca> Anssi: Possible, but mplayer and vlc are de facto standards, no matter what is in the installation...
19:22:28 <spturtle> how is building supposed to work, if any part fails, the whole submission fails?
19:22:40 <misc> spturtle: yes, like when compiling on both arch
19:23:05 <misc> so that shouldn't requires much change to the scheduler
19:24:15 <anaselli> is there a meeting today?
19:24:36 <misc> anaselli: yes, as posted on the list :)
19:25:05 <anaselli> sorry i couldn't read much mails today
19:25:31 <Anssi> AL13N: yep... I guess the reason there is no heat now is because almost everything works because we have patented H264 / AC3 / MP3 decoders enabled
19:25:39 <Anssi> (like mdv)
19:26:15 <obgr_seneca> are mp3 decoders patented? I thought it only matters to encoders...
19:27:13 <AL13N> well, no patents in europe, so not that important for me personally...
19:27:29 <misc> the issue is more complex, the format is what is patented, IIRC ( until next year ) and someone one day claimed that the result of the pychoacoustic work done by fraunhaufer, used by mp3, was under copyright
19:27:39 <misc> thus making mp3 problematic in all case
19:27:45 <misc> AL13N: there is in germany for mp3
19:28:39 <spturtle> and mpeg audio layer 2 as well
19:30:24 <misc> anyway, so besides "we should fix the issue", does anyone has something to add on the subject ?
19:30:36 <AL13N> nope
19:31:09 <Anssi> I guess we should add some checkbox to installer to enable tainted or something?
19:31:57 <misc> I would rather push it to the firstboot
19:32:03 <Anssi> hm, that is a bit more difficult as the standard installer doesn't obviuosly contain tainted rpms
19:32:06 <Anssi> yes
19:32:16 <misc> ( and try to be smart with something based on country selected )
19:32:19 <Anssi> forgot about firstboot :)
19:32:51 <misc> but given that the whole world do not agree on the list of country, I am not sure we would agree on where should tainted be active and where should it not
19:33:03 <AL13N> tainted could be selected after country selection on summary
19:33:16 <shikamaru> mmh but you can add other medias during install ;)
19:34:11 <tmb> shikamaru: only if you have a network connection available
19:34:45 <misc> I also think that firstboot would be better as this is easier to develop
19:34:50 <Anssi> what do we do with NICs that need firmware?
19:34:51 <spturtle> selection of this "tainted" package medium is up to the user IMHO, researching the situation in each country is too much work and responsibility
19:34:51 <anaselli> that is not always true
19:34:55 <AL13N> what if we put a checkbox on the add media screen?
19:35:07 <AL13N> ie: checkbox tainted and non-free
19:35:07 <shikamaru> misc: how so ?
19:35:15 <shikamaru> maybe easier to test perhaps
19:35:30 <tmb> Anssi: maybe tell them to use livecd as install media :)
19:36:12 <AL13N> i don't think it's bad to put the checkboxes on the "add media screen" ?
19:36:18 <Anssi> tmb: I guess we should have a dialog early in the installation about that...
19:36:18 <misc> shikamaru: well, you do not need to go trought the whole installation, and the firstboot wizard could be run more than on just the first boot
19:37:04 <Anssi> tmb: and what each install media supports/has should be documented in http://mageia.org/en/downloads/
19:37:04 <erzulie> [ Download Mageia 1 beta2 ]
19:37:30 <misc> spturtle: i think we could divide the users in 2 groups, those that do not know the issue and do not know what to answer, and those that do not care and will say yes :)
19:38:06 <AL13N> misc: if it's unchecked by default?
19:38:14 <AL13N> in installer
19:38:17 <tmb> Anssi: or on release notes
19:39:51 <misc> ok so who is volunteer to send the change on rlease note or the web site ?
19:39:59 <AL13N> misc: i think you're thinking too much on what other people will or will not choose... they choose, and it's their responsibility, noone will have your head because of that
19:40:53 <misc> AL13N: personnaly, i think that everybody will choose tainted, and that tainted is here just to please mirrors maintainers
19:41:12 <AL13N> misc: sure, but i have absolutely no problems if that were true
19:41:46 <misc> ( mirrors maintainers, and commercial distributor , or derivate )
19:41:56 <AL13N> we can do no more than delegate responsibility to user
19:42:03 <obgr_seneca> Yep
19:42:16 <misc> well, pushing to user is precisely why people think linux is hard
19:42:22 <tmb> AL13N: well, when they add the mirror medias, all medias are added, but only core, updates, nonfree and nonfree updates are enabled by default
19:42:48 <obgr_seneca> How does for example Ubuntu handle that?
19:43:08 <obgr_seneca> Don't they have some kind of "tainted" repo as well?
19:43:17 <Anssi> obgr_seneca: ubuntu's default ffmpeg/mplayer have patented codecs enabled
19:43:18 <misc> there is multiverse, IIRC
19:43:30 <Anssi> multiverse is for non-free software
19:43:50 <misc> mhh, universe, multiverse, and the 3rd one ?
19:43:59 <misc> there is a supported , unsupported and non-free
19:44:06 <Anssi> https://help.ubuntu.com/community/Repositories/Ubuntu
19:44:07 <erzulie> [ Repositories/Ubuntu - Community Ubuntu Documentation ]
19:44:28 <AL13N> ok, so this topic is done? next?
19:44:30 <Anssi> they have a GUI where is a checkbox for each, with a description
19:44:48 <misc> and they also have lots of doc telling what to do
19:45:06 <Anssi> our rpmdrake has 40 checkboxes without any documentation...
19:45:31 <misc> which is bad
19:46:18 <misc> anyway, so who is volunteer to change release notes or website ?
19:46:58 <Anssi> there should be only checkboxes for:  { tainted, non-free }, { testing, backports }, { debug }
19:47:16 <Anssi> and use tags in the medias (there is some partial support in the underlying stuff for this)
19:47:26 <misc> Anssi: yup, that's the idea
19:49:46 <obgr_seneca> misc: about updating website and so on
19:49:52 <obgr_seneca> for rc and final?
19:49:58 <obgr_seneca> or for beta2 as well?
19:50:24 <misc> obgr_seneca: for explaing the different sections
19:50:29 <misc> ( as discussed before )
19:50:53 <obgr_seneca> I can do, but does it have to be maid befor next week thursday?
19:51:02 <obgr_seneca> I'm having an exam coming up...
19:51:49 <misc> well, I think the documentation should be done before the release, so that's not urgent
19:52:14 <AL13N> Anssi: misc: that's all very nice, but not likely for mageia 1
19:52:15 <obgr_seneca> Ok, I will do
19:53:11 <misc> #action obgr_seneca write a documentation ( release note or/and website ) explaining the different repositories
19:53:49 <misc> ok so anybody has anything to add ?
19:54:32 <tmb> http://mageia.org/wiki/doku.php?id=mirrors_policy
19:54:33 <erzulie> [ mirrors_policy [Mageia temporary wiki] ]
19:54:51 <misc> #url http://mageia.org/wiki/doku.php?id=mirrors_policy
19:54:52 <erzulie> [ mirrors_policy [Mageia temporary wiki] ]
19:55:22 <misc> ( keep in mind that discussions are better done on the ml, so if people think we need to do something like firstboot change ( which I agree would be needed ), etc, it would be better to post on ml )
19:55:38 <tmb> yep
19:55:50 <tmb> yep
19:56:22 * tmb blames the cat
19:57:46 <tmb> next ?
19:58:28 <misc> there is no next topic, so I guess that's the end of the meeting
19:58:37 <AL13N> hold
19:58:45 <AL13N> is Herbert the same as Bertl ?
19:58:55 <AL13N> if not, the Herbert seems to require mentor
19:59:03 <shikamaru> I have one :)
19:59:10 <misc> AL13N: yes, it is the same
19:59:25 <AL13N> then Welcome to Bertl, tmb's mentoree
19:59:32 <misc> shikamaru: one what ?
19:59:40 <shikamaru> on thing to add
19:59:47 <misc> go for it
19:59:52 <shikamaru> I just started a port of mageia
19:59:54 <shikamaru> for mips
20:00:09 <shikamaru> in case someone is interested
20:00:16 <AL13N> shikamaru: isn't rtp doing this?
20:00:19 <misc> on gdium ?
20:00:22 <shikamaru> misc: yep
20:00:32 <shikamaru> AL13N: afaik he’s working on ARM no ?
20:00:36 <shikamaru> misc: yep
20:00:37 <AL13N> shikamaru: ah, only arm
20:00:42 <misc> shikamaru: I would be interested into using it :)
20:00:55 <misc> ( but only because I have a gdium )
20:01:17 <shikamaru> misc: well, as I’m alone at the moment the goal is to have a working basesystem with X and keep that up to date
20:01:20 <tmb> shikamaru: will you have it done for Mageia 1 release ? :)
20:01:28 <shikamaru> tmb: of course no
20:01:45 <shikamaru> I didn’t want to start before the freeze because it’s not very powerful
20:02:03 <shikamaru> but I will try to keep a working basesystem
20:02:09 <misc> not very powerful is a understatement...
20:02:11 <shikamaru> but don’t expect to have libreoffice on it :)
20:02:19 <ennael> don't want to be negative but I guess we have some priorities until final release
20:02:24 <shikamaru> neither kde or gnome
20:02:58 <misc> yup, I think the release critical bug is still too big :)
20:03:02 <misc> ( ie, more than 0 )
20:03:07 <ennael> yep
20:05:03 <AL13N> misc: perhaps https://bugs.mageia.org/show_bug.cgi?id=338 should be release critical too
20:05:05 <erzulie> [ Bug 338 - We need a way to have a package built for several targets ]
20:05:18 <shikamaru> it is
20:05:23 <AL13N> oh nvm
20:05:27 <misc> it is release_blocker ...
20:05:42 <AL13N> mislooked
20:05:50 <AL13N> end of meeting?
20:05:58 <misc> AL13N: as said before, yes
20:06:38 <misc> thanks for coming, see you next week
20:06:53 <misc> #info shikamaru started to work on mips port
20:06:54 <ennael> 'sorry for not attending, i the middle of live cds tests)
20:07:00 <misc> #endmeeting