19:05:52 <misc> #startmeeting
19:05:52 <Inigo_Montoya> Meeting started Wed Mar 30 19:05:52 2011 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:05:52 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:05:53 <erzulie> [ MeetBot - Debian Wiki ]
19:06:00 <misc> #name Packager
19:06:04 <misc> #chair ennael
19:06:04 <Inigo_Montoya> Current chairs: ennael misc
19:06:32 <brianb_> hi
19:06:51 <misc> hi
19:06:59 <ennael> #topic review of last week tasks
19:07:02 <Ruperto> hola a todos :)
19:07:42 <ennael> ok
19:07:53 <ennael> so based on http://meetbot.mageia.org/mageia-dev/2011/mageia-dev.2011-03-23-20.02.html list
19:07:53 <erzulie> [ #mageia-dev Meeting ]
19:08:17 <ennael> I've tried to contact Blogdrake packagers
19:08:19 <Kharec> hi sorry for the hour :s
19:08:27 <ennael> for now not a lot of answers
19:08:43 <ennael> if you know some of them please do not hesitate to ping them
19:09:20 <misc> #info Blogdrake people were contacted by ennael, not much answer for now
19:09:37 <ennael> about VMs for upgrade, misc ?
19:09:53 <misc> they are on http://distrib-coffee.ipsl.jussieu.fr/pub/people/misc
19:09:53 <erzulie> [ Index of /pub/people/misc ]
19:10:05 <misc> lxde vm are currently be uploaded
19:10:25 <ennael> which version ?
19:10:28 <misc> that's raw disk image, I can convert if needed,
19:10:43 <misc> mandriva 2010.1 ( or 2, depend on how you count, since that's the same )
19:10:59 <misc> root password is mageia, user is mageia, password the same
19:11:15 <misc> and keyboard is qwerty ( so that's ,qgeiq )
19:11:40 <misc> I am quite new to vm distribution so if there is something missing, tell me, I still have the rest here
19:12:00 <ennael> can you mail it on -dev also ?
19:12:04 <misc> yup
19:12:31 <misc> but i wait to know if I need to convert them to another format ( and wait for the last one to appear )
19:12:46 <misc> #info test vms are on http://distrib-coffee.ipsl.jussieu.fr/pub/people/misc
19:12:46 <erzulie> [ Index of /pub/people/misc ]
19:12:56 <Ruperto> alkign about vmx, i may do mageia openvz template if needed
19:13:04 <misc> #info root password is 'mageia', keyboard is in qwerty
19:13:23 <misc> Ruperto: ?
19:13:36 <Ruperto> arent you talking about virtual machines?
19:14:06 <misc> yes but "alkign" is not a word that I know
19:14:18 <AL13N> heh
19:15:13 <Ruperto> talking, sorry :( misspelling
19:16:28 <ennael> about documentation, I guess no time for it this week
19:16:41 <misc> I didn't think of it :/
19:16:46 <ennael> still need to have xdg policy
19:16:56 <ennael> and packager knowledge base
19:17:00 <misc> #action misc mail -dev about vm for upgrade test
19:17:13 <misc> #info documentation still need to be done
19:17:35 <brianb_> what about the other policies?
19:17:47 <misc> brianb_: like ?
19:18:33 <brianb_> in the table relating to policies is see there are some which thus far have not been started
19:18:57 <misc> likely yes
19:19:46 <philippeM> the Python one is still a draft :(
19:20:08 <misc> philippeM: well, it was a draft since several years :)
19:21:13 <brianb_> so question is have they taken a lower pority?
19:21:41 <misc> brianb_: nope, jut no one have started the work on it
19:21:41 <philippeM> misc: I know,  may be we can plan to speak about later, at Solution Linux for instance
19:21:48 <brianb_> ok
19:22:10 <misc> brianb_: if you want to give a hand on this topic , do not hesitate
19:22:32 <brianb_> ok
19:22:46 <Nanar> Solution Linux is a  "french" meeting, excluding a lot of people from any discuss
19:22:49 <philippeM> or because not enough people involved and with no clear ideas on what to do
19:23:36 <philippeM> Nanar: I know, but is there a lot of people involved in Python packaging ?
19:23:44 <misc> Nanar: yup, we will summarize the idea on -dev
19:24:04 <misc> but I think there isn't much to do, just decide that the policy is no longer a draft
19:24:23 <Nanar> philippeM: some of them won't be at solution linux
19:24:26 <brianb_> what version python?
19:24:39 <misc> anyway, the goal is not to talk about the python policy
19:24:50 <misc> has someone something to had on the review part ?
19:24:58 <ahmad78> s/goal/topic/ ?
19:25:44 <ennael> nope
19:27:03 <misc> so next one
19:27:06 <ennael> looks like people are sleeping :)
19:27:32 <Nanar> not yet
19:27:40 <misc> #topic start setup for the secteam ( team for stable update, not limited to security in fact )
19:28:36 <Ruperto> i may help in that misc :) i do security most time of my work
19:29:07 <ennael> ok the point here is to setup team in charge of updates for stable releases
19:29:28 <ennael> it means bug fixes and security fixes
19:29:42 <ennael> I spoke with stewbintn and he is ok to help with that
19:29:48 <Ruperto> like the work that oden does in mandriva?
19:29:52 <ennael> yep
19:29:52 <misc> Ruperto: yes
19:30:00 <ennael> maybe some of you remember
19:30:00 <ahmad78> I am interested too in the sec/official-updates team (but I won't do qa stuff)
19:30:01 <Ruperto> i may if you want
19:30:09 <misc> except that oden is full time
19:30:12 <ennael> stewbintn was working with vincent danen in scteam in mdv
19:30:26 <misc> and I think that for this, we do not have someone full time, we do not have dedicated hardware
19:30:34 <ennael> so he knows the job quite well and this will be really helpful
19:30:44 <misc> and we also would likely all agree to have something that scale
19:31:28 <Nanar> and all packager must be able to provide an update for their software
19:31:38 <ennael> well in fact
19:32:00 <ennael> in mdv packagers were usualy helping in bug fixes for their packages
19:32:11 <Nanar> yup
19:32:12 <ennael> even for some sec fixes
19:32:24 <misc> mhh, I was never contacted for anything
19:32:26 <ennael> but all updates build were done only by secteam
19:32:34 <misc> maybe 1 time, when some stuff didn't built
19:32:37 <pterjan> secteam is more about tracking that everything get the proper update
19:32:43 <ennael> yep
19:32:54 <ennael> also they are the main contact for security advisories
19:33:09 <ennael> registered for some specific ML for information
19:33:27 <misc> ennael: if you speak of vendor-sec, it no longer exist
19:33:50 <pterjan> yeah that's sad :(
19:33:53 <ennael> rather about some project that prefers to have one contact for that stuff
19:33:53 <misc> http://en.wikipedia.org/wiki/Vendor-sec
19:33:54 <erzulie> [ vendor-sec - Wikipedia, the free encyclopedia ]
19:34:00 <ennael> yep I've seen that
19:34:04 <ennael> sad indeed
19:34:40 <Ruperto> i dont get your point, sorry
19:34:51 <ennael> my opinion is we need guys well organized
19:35:03 <ennael> have process
19:35:16 <ennael> and think about the way we can build all this
19:35:28 <pterjan> (and have enough people)
19:35:30 <ennael> in mdv updates are built in separate hosts
19:35:53 <ennael> so maybe think small but strong
19:36:19 <misc> well, using one buildsystem for verything seems to me more logical
19:36:23 <pterjan> it totally made sense at mandriva given that anyone could get root on the bs
19:36:26 <ahmad78> (there's a bit of difference, Mageia build nodes are fast, and don't break as often as mdv...)
19:36:41 <ennael> ahmad78: it's not about breaking
19:36:45 <ennael> rather about security
19:36:54 <ahmad78> which doesn't make sense
19:36:55 <ennael> as said pterjan
19:36:59 <misc> ennael: for oden, this is about reliability :)
19:37:23 <ennael> misc: also yes :) these days was helpful to have dedicated bs
19:37:23 <ahmad78> so, you have a different BS for sec team, which is "secure" but the main distro BS isn't "secure"
19:37:46 <ennael> there was also commercial updates
19:37:46 <ahmad78> so you build the kernel on a "not-so-secure" BS but you build a CVE update on a secure system?
19:38:00 <ahmad78> ok, you have more experience than me
19:38:08 <ennael> and bs was not setup to manage private and public updates
19:38:10 <pterjan> ahmad78: no one says we should follow that model :)
19:38:18 <Ruperto> thats not logical, i guess more than talkinga bout separate BS it is a matter of a process
19:38:20 <ennael> I'm not saying this is a good model :)
19:38:31 <ennael> just explaining what we had
19:38:53 <misc> ennael: also the issue of having a different BS for corpo product :)
19:39:06 <ahmad78> ok (/me turning off the flame throwser, sorry)
19:39:21 <ennael> misc: I called commercial one
19:39:36 <misc> ennael: oh yes, I was thinking of commercial package rather than distro
19:39:40 <misc> ( like flash, adobe )
19:39:51 <ennael> so if you are interested in joining we need to be able to rely on you
19:39:58 <ennael> and start discussion quickly
19:40:11 <pterjan> first send a sample of your dna
19:40:13 <ennael> goal is to be ready before launch of stable 1
19:40:23 <ennael> pterjan: a finger is better
19:40:41 <Nanar> do we have an idea of time it will need per people
19:40:51 <Ruperto> pterjan: whats dna jejeje  :P
19:41:09 <pterjan> Nanar: depends on the number of people
19:41:10 <Nanar> especially since only main is maintained at mdv, and mageia merged everything ?
19:41:19 <ennael> Nanar: if you look at mdv, 2,5 people full time were needed
19:41:23 <pterjan> but there is a lot of work
19:41:25 <ennael> but much more packages
19:41:32 <ennael> and more releases
19:41:39 <misc> yes but 2.5 because packager didn't care about stable release
19:41:42 <Nanar> ennael: only main is supported at mdv iirc
19:41:45 <misc> ( at least, I don't )
19:41:48 <ahmad78> Nanar: (but core in mga is still smaller than contrib in mdv)
19:41:57 <ahmad78> (contrib has a lot of old cruft, IIUC)
19:41:57 <pterjan> Nanar: yes but supported for like 5 distros
19:41:59 <ennael> Nanar: main but for 3 stable releases + 3 corpo one
19:42:05 <pterjan> ok 6
19:42:19 <Nanar> ahmad78: main is smaller then core
19:42:37 <Nanar> s/then/than/
19:43:05 <ahmad78> Nanar: ok, you have hard data/numbers on the mirrors and all, I differ to you
19:43:41 <Nanar> ahmad78: because a lot of packages were not yet imported
19:43:55 <misc> so let's try to find what we need to do
19:44:03 <misc> 1) gather a team
19:44:20 <Dr_ST_home> yo
19:44:24 <misc> 2) write procedure for update ( ie, who do the package, who test, who validate )
19:44:43 <ennael> add QA in the loop also
19:44:47 <pterjan> misc: before doing the update, there is "who looks at what needs to be updated"
19:44:55 <misc> pterjan: yup
19:44:58 <pterjan> there needs to be a tracking system
19:45:04 <ahmad78> s/differ/defer/
19:45:34 <brianb_> i take it that it will not be the same person for the three tasks in 2)
19:45:40 <tmb> and a priority list...
19:46:11 <ennael> yep
19:46:58 <misc> tmb: well, that depend on who is working, I will likely have a different priority for upgrade than you ( like I would not touch to kernel while you may prefer to not update python )
19:47:08 <Ruperto> wehn talkinga bout security, we shall see the 3 pillars: availiability, confidenciality and integrity. what i mean is that an app is not affected on one of these characteristis, it is not an security update
19:48:03 <pterjan> misc: you don't have to do the first one in the list, but the first one that you can do
19:48:16 <pterjan> a remote root is first priority
19:48:19 <tmb> misc: well I was more thinking of if qa/sec team is loaded with work, wich order to process the queued work.
19:49:02 <misc> I take not of the list of point
19:49:05 <Nanar> isn't to the secteam to define such priority ?
19:49:17 <pterjan> Nanar: yes
19:49:32 <misc> well, I think that's quite straighforward to decide
19:49:48 <ennael> maybe we can speak pecisely about that topic either on ML or IRC on dedicated meeting
19:49:52 <misc> yup
19:49:57 <ennael> still we need to identify interested people
19:50:07 <ennael> and start then discussion
19:50:18 <misc> I will post on -dev, and take care of gathering people,
19:50:22 <ennael> we just wanted to introduce this topic as it's an important one
19:50:37 <Ruperto> misc: include me
19:50:55 <ennael> misc: check also wiki list
19:51:03 <ennael> some people registered on security part
19:51:08 <misc> ennael: ok
19:51:18 <misc> #action misc send a call for meeting on -dev
19:51:25 <misc> #info look at the wiki to gather people
19:51:52 <ennael> misc: note that pterjan and Nanar are interested :)
19:51:59 * ennael tried
19:52:04 <ennael> ahmad78 also
19:52:05 <brianb_> will the secteam have a formal structure in relation to who can authorize formal changes?
19:52:22 <misc> brianb_: we do not know yet, we haven't decided anything
19:52:22 <ennael> what is formal changes ?
19:53:22 <Nanar> ennael: good try
19:53:35 <Nanar> ennael: but try again
19:54:45 <misc> ok so next topic ?
19:54:58 <ennael> yep
19:55:51 <misc> #topic review of planning , freeze management
19:55:55 <misc> so ennael
19:56:11 <ennael> yep
19:56:25 <ennael> so this is a quick reminder about coming planning
19:57:06 <ennael> so here is the official one:
19:57:26 <ennael> http://mageia.org/wiki/doku.php?id=iso_1_specifications#expected_milestones
19:57:27 <erzulie> [ iso_1_specifications [Mageia temporary wiki] ]
19:57:43 <ennael> we have beta1 coming next tuesday
19:58:00 <sebsebseb> ennael: Nice :)
19:58:09 <ennael> we should have live CDs for tests
19:58:17 <misc> ( thanks to blino )
19:58:23 <ennael> maybe not all but at least 1 KDE and 1 GNOME
19:58:23 <sebsebseb> good Live CD's :)
19:58:47 <ennael> just keep an eye on freeze planning
19:58:54 <ennael> pkg version freeze: April, 20th
19:59:29 <ennael> pkg release freeze: May, 10th
19:59:41 <Nanar> so still 20 days to break everythings ! :)
19:59:45 <ennael> it means by 20th we will block all new versions for packages
19:59:46 <misc> #info version freeze : 20/04/2011
19:59:57 <misc> #info release freeze : 10/05/2011
20:00:07 <misc> ennael: just for existing package ?
20:00:11 <ennael> you still will be able to ask for new version but only under strict conditions
20:00:16 <pterjan> ah I'll be on vacation from 21/04 to 3/05
20:00:23 <ennael> misc: good question
20:00:26 <Ruperto> i have q uestion regarding that.
20:00:40 <ennael> maybe allow new packages as we still have work on this
20:00:48 <Ruperto> some of my packages needs some dependencies of packages thata are still not imported
20:01:02 <Ruperto> and i dont know how to  maintian them, like netfilter stuff
20:01:12 <Ruperto> what shall we do on that?
20:01:32 <Nanar> importing missing packages ?
20:01:34 <pterjan> find someone
20:01:53 <Ruperto> i may import, but i dont want to maintain netfilter related stuff,
20:02:01 <Dr_ST_home> Ruperto: fill in the list -> http://mageia.org/wiki/doku.php?id=missing_packages
20:02:01 <erzulie> [ missing_packages [Mageia temporary wiki] ]
20:02:05 <ennael> Ruperto: there is no maintainer for now
20:02:15 <Dr_ST_home> I'm trying to close the gap for import
20:02:39 <Dr_ST_home> not becoming maintainer for all, but only the stupid monkey importer :-)
20:02:56 <AL13N> i would like to have netfilter-addons, perhaps if no maintainer is there, maybe i can be of assistance there
20:03:01 <Ruperto> Dr St: do you want to maitain netfilter?
20:03:17 <Ruperto> or AL13N?
20:03:35 <Nanar> Ruperto: just import it, at time there is just no maintainer
20:03:38 <AL13N> Ruperto: let's talk about your package after meeting
20:03:45 <Nanar> it will find a maintainer later
20:03:53 <AL13N> Ruperto: but you can import, following import and cleaning guidelines
20:03:55 <Ruperto> ok, :) got it
20:04:16 <Ruperto> AL13N_work: i know to import, i dont want to maintain some dependencies
20:04:17 <blino> misc: live CDs have been available for weeks, but can't be published because of included Mdv artwork (draklive-install)
20:04:27 <blino> rda: news? :)
20:04:52 <misc> well so on the planning, anybody has question ?
20:05:37 <Nanar> like everytime, deadline will come too early
20:05:40 <Nanar> :)
20:05:43 <AL13N> yes
20:05:52 <Nanar> that's what we call "the life'
20:06:12 <AL13N> or "42"
20:06:24 <Nanar> :)
20:07:05 <rda> blino: just discussing this with the team
20:07:21 <AL13N> ok, next then?
20:07:37 <ennael> ok anything else to add on this ?
20:08:24 <ennael> rrrzzzzzz
20:08:33 <AL13N> next topic?
20:10:19 <ennael> ok
20:10:20 <misc> so as people who followed council meeting
20:10:32 <misc> rtp brought the issue of a arm port
20:10:54 <misc> http://meetbot.mageia.org/mageia-meeting/2011/mageia-meeting.2011-03-28-18.33.log.html#l-381
20:10:54 <erzulie> [ #mageia-meeting log ]
20:11:06 <misc> we had some questions to dispatch to packager
20:11:15 <Stormi> no #topic ?
20:11:34 <Stormi> or is it in the same topic ?
20:11:43 <misc> Stormi: ?
20:11:46 <ennael> #topic ARM port for Mageia
20:11:54 <ennael> sorry wrong command
20:11:57 <misc> well, the topic was already changed
20:12:05 <misc> mhhh
20:12:23 <AL13N> heh
20:12:26 <ennael> :)
20:12:30 <ennael> chan topic :/
20:12:43 <AL13N> it's gone now, someone will have to reset it afterwards maybe
20:12:45 <misc> so http://mageia.org/wiki/doku.php?id=meeting:council_notes_2011_03_28#open_questions , we want to have feedback on it
20:12:45 <erzulie> [ meeting:council_notes_2011_03_28 [Mageia temporary wiki] ]
20:13:02 <AL13N> misc: feedback on the arm port?
20:13:07 <misc> AL13N: yes
20:13:22 <misc> like "who is interested'
20:13:48 <misc> "does it fit our objectives"
20:13:49 <AL13N> i'm not adverse to arm, considering it's getting increasingly popular on servers
20:13:50 <misc> etc
20:14:09 <misc> AL13N: you have seen a arm server yet ?
20:14:14 <AL13N> i am planning on buying an arm thingie, and i could test it then
20:14:33 <AL13N> misc: i'm not rich enough for servers
20:14:50 <misc> AL13N: well, you can see server without owning them
20:15:03 <AL13N> true, but i have none at dayjob either
20:15:55 <AL13N> i'm not sure i will be able to do anything more than testing
20:16:04 <misc> rtp: ?
20:16:04 <rda> is arm a good target for home appliances?
20:16:14 <misc> rda: I would say so
20:16:16 <AL13N> i think so
20:16:21 <ennael> also netbooks
20:16:23 <misc> the freedombox project target arm appliance, IIRC
20:16:26 <AL13N> power requirement is very very low
20:16:29 <rda> (and is it going to be used more - or at least as much as - than intel platforms?)
20:16:39 <misc> only time will tell :)
20:16:42 <AL13N> i'm planning on buying a 300EUR NAS on arm
20:16:53 <AL13N> power usages less than 30 watt
20:16:53 <ennael> as a quick note, rtp is wonrking on it since2 years now
20:17:10 <ennael> he should have everything ready for stable release 1
20:17:11 <AL13N> i know there are people using arm for webservers
20:17:43 <AL13N> saves alot of money on power and cooling
20:18:42 <misc> ok so apart from AL13N , no one is interested to do anything ?
20:18:49 <AL13N> and rtp
20:18:50 <brianb_> lower carbon footprint then
20:19:02 <tmb> I am interested
20:19:29 <AL13N> it would be nice if we could make something fit for home appliance
20:19:37 <ennael> what he proposed for now is to do as was done at the eginning of x86_64 in mdv
20:19:50 <AL13N> which is?
20:19:55 <misc> ennael: a mess where we lose contributors :) ?
20:19:58 <ennael> having regular rebuild of packages instead of formal host in bs
20:20:10 <ennael> misc: well at least until first release
20:20:18 <ennael> build host for arm are quite expensive
20:20:25 <ennael> if you want something powerfull
20:20:32 <ennael> otherwise it will take ages
20:20:43 <rda> expensive as ?
20:20:45 <Dr_ST_home> cross compilation is not possible ?
20:21:04 <ennael> rda: in fact rare ad expensive :)
20:21:06 <misc> Dr_ST_home: it does work that well with configure and test
20:21:09 <AL13N> ennael: perhaps just buying a few smaller ones would be good enough
20:21:10 <Dr_ST_home> ok
20:21:21 <AL13N> like 4 pluglike servers or something
20:21:22 <misc> even if I know from first hand that nokia use cross compiler
20:21:34 <ennael> AL13N: it's *slow*
20:21:38 <AL13N> it is
20:21:50 <ennael> it means whet you submit you will have to build on x86 and ARM
20:21:55 <AL13N> it's getting faster though
20:21:56 <misc> I do compile gsm firmware on arm, and this is slow
20:21:58 <ennael> and nothing happens until ARM is done
20:22:04 <Nanar> isn't qemu/arm emulation faster ?
20:22:12 <misc> anyway, technical details are left for later  I think
20:22:13 <AL13N> ennael: i see your point
20:22:15 <ennael> these are topics to be discussed
20:22:26 <misc> I will start a thread on "how to do" on the ml
20:22:33 <ennael> yep
20:22:37 <misc> ( later )
20:23:09 <misc> #info tmb and rtp are interested by arm, AL13N is also ok to help test
20:23:32 <misc> #info details to be discussed on ml later
20:24:21 <misc> so anything to add on this ?
20:24:32 <ennael> nope
20:24:53 <schultz> ping: blino I have a new bit of artwork for the draklive packages
20:25:27 <ennael> I guess we can close meeting before everybody sleep
20:25:35 <Nanar> :)
20:25:39 <AL13N> wait
20:25:48 <AL13N> ah no
20:25:53 <AL13N> that's not for this meeting
20:25:53 <ennael> misc: ?
20:26:29 <misc> ennael: ?
20:26:46 <ennael> #endmeeting