20:02:05 <ennael> #startmeeting
20:02:05 <Inigo_Montoya`> Meeting started Wed Mar 23 20:02:05 2011 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:05 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:02:06 <erzulie> [ MeetBot - Debian Wiki ]
20:02:11 <ennael> hi all
20:02:17 <sebsebseb> hi
20:02:27 <ennael> so let's start meeting
20:02:42 <ennael> #topic review of mentoring in progress
20:02:57 <ennael> ok first topicis about mentoring
20:03:13 <ennael> any comments on mentoring in progress ? from mentors or apprentice ?
20:03:18 <ennael> missing things, docs...
20:03:41 <shikamaru> missing docs yes,
20:03:53 <ennael> ok shoot
20:04:01 <shikamaru> about common packaging problems for instance (like overlinking, underlinking)
20:04:25 <shikamaru> the xdg policy should be imported too, but since there were 2 pages, I didn’t know which one to import
20:04:26 <ennael> could we start from mdv doc and complete it ?
20:04:30 <shikamaru> but now I know
20:04:32 <shikamaru> yes
20:04:45 <shikamaru> the chroot howto is a must have also
20:04:52 <ennael> wait :)
20:05:13 <ennael> #action write knowledge base about packaging problems
20:05:26 <ennael> #action add xdg policy in Mageia
20:05:31 <ennael> what about chroot ?
20:06:48 <ennael> argh we lost shikamaru
20:07:01 <AL13N> i have a chroot procedure that i used for building the BN VM
20:07:15 <misc> the chroot howto is on mdv wiki
20:07:16 <AL13N> I can send it to shikamaru for generalisation
20:07:21 <shikamaru> no, 64.83 seconds of lag but I’¯still here !
20:07:21 <shikamaru> :)
20:07:28 <ennael> shikamaru: ok :)
20:07:34 <ennael> can you be more prcise ?
20:07:55 <shikamaru> well, it would be nice if pupils could test their packages in a clean environment
20:08:18 <ennael> so explain what is a chroot, how it's work and how to build it ?
20:08:23 <shikamaru> it would lead to less failures due to missing BRs for instance
20:08:58 <AL13N> shikamaru: i'm still working on the buildnode VM
20:10:00 <ennael> #action add chroot howto to explain all about building chroot for local build environment
20:10:34 <shikamaru> it would help them testing their package in a clean environment
20:10:37 <shikamaru> yes, the mdv wiki page is already pretty good I think
20:10:58 <ahmad78> (the biggest hinderance in chroot, is bandwidth)
20:11:27 <ennael> ok so this is for docs
20:11:27 <shikamaru> (yes, that’s why I can’t afford having one when I’m not home :()
20:11:31 <ennael> anything to add on this ?
20:11:56 <shikamaru> well, about current pupils
20:13:07 <ennael> yep ?
20:13:12 <shikamaru> seems like some of them are doing well, but for some other things have not even started
20:13:38 <shikamaru> and some of them are slowing down a bit
20:13:58 <ennael> shall we have them on meeting to speak about it ?
20:14:12 <shikamaru> I’m not sure how we can do better at this
20:15:30 <ennael> shikamaru: what about your apprentices ? :)
20:15:36 <shikamaru> mmh what kind of meeting ?
20:15:54 <shikamaru> ennael: I think obgr_seneca could get submit rights :)
20:16:01 <shikamaru> he’s doing really well now
20:16:13 <shikamaru> andre999 too, but I haven’t seen him this week
20:16:27 <ennael> so just mail about obgr_seneca
20:16:45 <shikamaru> as for deap I have a hard time contacting him, looks like we’re not available at the same time :/
20:17:18 <ennael> what about Kharec ?
20:17:56 <Nanar> my own padawan already got submit permission /o\
20:18:03 <ennael> Nanar: !
20:18:05 <ennael> you bad guy
20:18:11 <ennael> http://mageia.org/wiki/doku.php?id=packages_mentoring#current_mentoring
20:18:11 <erzulie> [ packages_mentoring [Mageia temporary wiki] ]
20:18:14 <ennael> please clean here
20:18:26 <shikamaru> we’re doing some points, I don’t think he needs to be “mentored” in the sense of learning how to use the BS
20:18:31 <ennael> Nanar: can you then have new apprentice ?
20:18:43 <misc> i think people who get submit permission should be announced, so everybody can say "welcome on the group", etc, etc
20:18:46 <Nanar> not t time :\
20:18:47 <Kharec> mmmh?
20:18:49 <ennael> yep
20:18:50 <shikamaru> just need some guidelines, advices etc. :)
20:19:03 <ennael> misc: I'm adding it in mentoring process
20:19:13 <Nanar> ennael: strange I though I already filled a wiki page
20:19:14 <Kharec> shikamaru: okay for me :)
20:19:20 <ennael> shikamaru, Nanar : can you mail -dev about new packagers ?
20:19:34 <shikamaru> ennael: ok, will do right after the meeting
20:19:42 <ennael> mikala, Anssi, philippeM ?
20:19:48 <ennael> jq ?
20:19:53 <Nanar> ennael: I can, as soon everything got explained and clear
20:19:59 <Nanar> cleared
20:20:02 <ennael> Nanar: what ?
20:20:07 <misc> Nanar: tomorow once you are no longer drunk ?
20:20:14 <ennael> outch
20:20:23 <Nanar> misc: ?
20:20:33 <Anssi> ennael: ?
20:20:37 <misc> Nanar: no, nothing :p
20:20:47 <coincoin> I was not on the wiki (don't know why as I was announced as the dmorgan pupils during first meeting), I started today and all is going well
20:21:12 <ennael> Anssi: any comment on your apprentice ?
20:21:15 <Anssi> shikamaru: with dorileo work hasn't really started (I think a lack of time in his part), with tux99 progressing nicely, and for alien things are progressing (though commit rate is low)
20:21:31 <AL13N> myeah sorry, time is scarce
20:21:36 <Anssi> (Im on mobile, 8 pasted my earlier line)
20:21:45 <Anssi> I*
20:22:02 <ennael> ok :)
20:22:18 <Nanar> ennael: well, my padawan got submit access while trying to deal with error on BS side
20:22:19 <shikamaru> :)
20:22:34 <Nanar> some things still have to be done
20:22:58 <ennael> ok
20:23:34 <ennael> ok anything else to add ?
20:23:51 <ennael> apprentice want to speak and hit mentors ? :)
20:23:59 <Kharec> not for me :)
20:24:06 <coincoin> :)
20:24:26 <AL13N> i'm ok with my mentor
20:24:33 <grenoya> no, thanks :)
20:24:35 <AL13N> i will try to do more commits
20:24:54 <philippeM> nothing new for me about mentoring, I was not a lot on irc and didn't had contact with them this week
20:24:55 <Kharec> No more, but better ;)
20:25:15 <ennael> philippeM: can you try to ping him and see how it can go further ?
20:25:24 <AL13N> Kharec: well, my commits are perfect (because there is 0 this week, i think)
20:25:35 <philippeM> ennael: yes
20:25:42 <ennael> philippeM: thanks
20:26:08 <ennael> I guess having kind of weekly report may help to check mentoring process
20:26:11 <ennael> wdyt ?
20:26:35 <coincoin> iawt
20:26:41 <coincoin> :p
20:26:56 <AL13N> (i agree with that?)
20:27:13 <shikamaru> ennael: yes
20:27:29 <ennael> #action contact mentors once a week for review on pending mentor process
20:27:33 <shikamaru> another thing I would like to add is about blogdrake guys
20:27:38 <shikamaru> I cannot speak spanish
20:27:38 <ennael> ep
20:27:40 <ennael> yep
20:27:43 <coincoin> AL13N: yep :)
20:27:50 <shikamaru> but none of them are being mentored at the moment
20:28:05 <shikamaru> does anyone have contacts with them ?
20:28:15 <ennael> yep I can contact them
20:28:17 <ennael> in english
20:28:35 <ennael> I can ask them if some of them can have english spoken mentor
20:28:42 <ennael> then one of them could mentor others
20:29:04 <shikamaru> that would be nice !
20:29:12 <ennael> ok will do it
20:29:29 <ennael> #action ennael will contact blogdrake guys to organize mentoring among them
20:30:24 <ennael> anything else ?
20:31:41 <ennael> ok next topic then
20:31:53 <ennael> #topic upgrade tests to mageia
20:32:09 <ennael> this is one important and critical topic
20:32:31 <ennael> if we cannot insure safe upgrade from mdv we will loose people interest (and data)
20:32:54 <ennael> so we need for now to test upgrades very carefully
20:33:47 <ennael> we need to organize tests, corrections, add missing packages...
20:34:02 <ennael> wdyt? anybody volunteering to manage it ?
20:34:22 <Nanar> one thing is sure
20:34:34 <Nanar> a lot of mdv packages are missing
20:34:47 <Nanar> and will make update hardaest
20:35:04 * Kharec can make test with a cooker station
20:35:09 <ennael> we should try at least to have kind of list of priorities
20:35:16 <AL13N> i sent email with the upgrade test so far via DVD, and there is alot of work imho
20:35:17 <shikamaru> Kharec: not cooker
20:35:20 <dmorgan> Kharec: cooker is not supported for updates
20:35:27 <dmorgan> Kharec: 2010.0 2010.1 only
20:35:32 <Kharec> ok.
20:35:37 <dmorgan> Kharec: because of rpm5 we can't handle cooker
20:35:41 * Kharec hide
20:35:44 <shikamaru> remember our goal is to permit upgrade from mandriva 2010.1/2010.2
20:35:52 <ennael> yep
20:35:56 <dmorgan> shikamaru: 2010.0 too if possible
20:36:05 <dmorgan> shikamaru: my test 2010.0 -> mga worked well
20:36:26 <ennael> dmorgan: focus first on 2010.1/2
20:36:57 <dmorgan> ennael: ;)  i am i free electro :þ
20:37:20 <dmorgan> ennael: i will do more 2010.1 -> mga upgrade this week
20:37:20 <ennael> tsss
20:37:51 <ennael> any people still having 2010.1/2 installed ?
20:37:57 <misc> me
20:37:59 <AL13N> i have tested it
20:38:02 <Stormi> me
20:38:05 <Nanar> I did try cooker (pre-rpm5) to mga, was very hard
20:38:20 <AL13N> i will do a test with sources next
20:38:22 <Stormi> and I have a VM duplicated from my current install
20:38:25 <AL13N> (not via DVD)
20:38:25 <misc> Nanar: because you run a wm for hippie :)
20:38:27 <ennael> maybe we could try to collect rpm lists and check what is missin ?
20:38:28 <ennael> g
20:38:32 <Stormi> which I can migrate again andf again
20:38:38 <Nanar> ennael: it is possible to install 2010.1 in vm and have snapshot
20:38:41 <AL13N> ennael: i sent email and bug with missing rpms
20:38:42 <Nanar> misc: was apus
20:39:15 <ennael> AL13N: bugzilla please rather
20:39:41 <philippeM> my laptop is now under mga, without trouble , but I have some VM using Gnome that I can use for testing
20:39:53 <shikamaru> for those who have some bandwidth it could be worth trying installing as many packages as possible and try to perform the upgrade :)
20:39:58 <ennael> anybody to create VMs for 2010.1/2 32 and 64 ?
20:40:05 <ennael> to make it available
20:40:14 <misc> I can create them on rabiit
20:40:24 <ennael> in fact 6
20:40:24 <misc> or just use the current one on alamut
20:40:32 <misc> ennael: 6 ?
20:40:34 <ennael> GNOME, KDE, LXDE
20:40:40 <Nanar> misc: which virtual machine softwre ?
20:40:42 <ennael> not mixing all of them
20:40:47 <misc> Nanar: qemu
20:40:57 <Stormi> what about migration from 2010.2 will ALL backports installed ?
20:41:07 <Nanar> so eveyrone wan run it at home ?
20:41:07 <AL13N> ennael: https://bugs.mageia.org/show_bug.cgi?id=440
20:41:09 <erzulie> [ Bug 440 - missing rpms after update from mandriva ]
20:41:17 <shikamaru> Nanar: vmdk is portable isn’t it ?
20:41:19 <ennael> Stormi: we can try this from VM with backports added
20:41:32 <shikamaru> can be used in vbox, qemu and so on, no ?
20:41:37 <misc> yup
20:42:02 <misc> ( or vmware for those that use esx at $work )
20:42:15 * Nanar slaps misc
20:42:17 <misc> ( with a insane number of cpu and still brag about it in the living room )
20:42:34 * Nanar re-slaps misc
20:42:39 <misc> :(
20:43:04 <ennael> ok so misc builds VMs ?
20:43:14 <misc> ok
20:43:45 <ennael> #action misc will build some VMs for 32 and 64 and KDE, GNOME, LXDE to make it available for upgrade test
20:44:04 <ennael> do we have meta bug for upgrade ?
20:44:09 <misc> yes
20:44:09 <shikamaru> yup
20:44:09 <Stormi> ye
20:44:19 <misc> can someone give the bug number ?
20:44:22 <shikamaru> #56 IIRC
20:44:27 <ennael> we should have it as release_critical
20:44:41 <mitya> guys, I suggest not building "vanilla" VMs, but instead taking snapshots off some production boxes, and putting them into VMs
20:45:05 <Stormi> that's what I did with mine
20:45:11 <shikamaru> mitya: Stormi does have one
20:45:11 <Stormi> but I won't share it :)
20:45:11 <ennael> oh it's already tagged as release blocker
20:45:22 <Stormi> unless I remove /home, that is
20:45:42 <Stormi> and it's less useful without /home
20:45:59 <ennael> same thing we should have regular review on that one
20:46:02 <ennael> (bug)
20:46:31 <ennael> #info upgrade tracker bug : https://bugs.mageia.org/show_bug.cgi?id=56
20:46:32 <erzulie> [ Bug 56 - [TRACKER] tracker report for upgrade issues ]
20:47:04 <ennael> anything else to add on this ?
20:47:52 <Stormi> yes
20:48:10 <Stormi> I don't know how to treat the loads of orphans package I have after migration
20:48:26 <ennael> ?
20:48:31 <misc> Stormi: do like english, send them to australia
20:48:42 <dmorgan> :)
20:48:54 <Stormi> after upgrade, my mga box has many many orphan packages
20:49:14 <AL13N> i noticed a similar thing
20:49:21 <Stormi> I don't know how to push tests farther
20:49:24 <Stormi> about those
20:49:26 <AL13N> https://bugs.mageia.org/show_bug.cgi?id=70
20:49:27 <erzulie> [ Bug 70 - orphaned package immediately after installation ]
20:49:27 <Nanar> orĥans detection by urpmi is not perfected
20:49:47 <Stormi> yes, but they really seem orphan for the few I studied
20:50:04 <Nanar> can be, or not
20:50:22 <misc> so the question is "why are they installed ?"
20:50:45 <Nanar> suggested ?
20:50:52 <misc> possibly
20:50:56 <misc> someone should investigate
20:51:10 <Nanar> and urpmi see them as "orphans" ?
20:51:14 <Stormi> yes
20:51:31 <AL13N> not an easy thing to investigate... if our packages have less suggests than mdv...?
20:51:38 <Stormi> (about suggeted packages, I don't now)
20:51:48 <boklm> or Require(post) ?
20:51:50 <AL13N> or is it due to missing packages?
20:51:50 <misc> Stormi: what package are on this list ?
20:52:04 <dmorgan> misc: or better question: "what is for urpmi an orphaned package ?" "are detected orphan really orphans ?"
20:52:05 <Nanar> reuiqre(post) is a reuire
20:52:08 <Stormi> misc: lots of libs
20:52:09 <Nanar> require
20:52:26 <misc> dmorgan: the code know :)
20:52:30 <misc> teuf: ?
20:52:31 <boklm> Nanar: I think they can be removed once package is installed
20:52:58 <Nanar> boklm: for rpm, require(???) is a require
20:53:00 <teuf> when a package is installed because it's a dependency of another, it's written in a file
20:53:12 <teuf> then we can check this file to see if we can remove any of these deps
20:53:35 <boklm> Nanar: ah ok
20:53:40 <t_m_b> one thing comes to mind with all this... as we now have a working install of Mageia, should we start blocking submission of packages that would introduce more broken dependencies ?
20:53:42 <Nanar> teuf: but is this updated when package got installed by another one ?
20:53:54 <teuf> Nanar: what do you mean ?
20:53:59 <AL13N> t_m_b: i agree with that, actually
20:54:21 <ennael> t_m_b: what do you mean ?
20:54:26 <ennael> how could we check that ?
20:54:38 <misc> technically, we coud do it with youri
20:54:44 <misc> we just never wrote the module
20:54:45 <boklm> reject packages if they have one missing dependency ?
20:54:53 <ennael> ?
20:54:56 <Nanar> teuf: I think urpmi state package a is orphans if b is got unstalled (b pull a) but urpmi do not noticed a got pull by c in the meantime
20:54:57 <misc> ( using the caml stuff from edos project )
20:55:12 <Nanar> or some other side effect like this (more complex)
20:55:16 <teuf> Nanar: it should, since to detect if a package is an oprhan, it checks if it's uninstallable or not
20:55:18 <t_m_b> ennael: what boklm stated...
20:55:25 <ennael> outch
20:55:30 <ennael> that's a bit hard
20:55:56 <AL13N> it also means that the build process is done that much faster and immediately tells you why
20:55:56 <boklm> for packages with circular dependencies, it can be annoying
20:56:36 <Nanar> teuf: does urpmi take notice about orphans with suggested ?
20:57:03 <t_m_b> boklm: so lets fix the packages with circular dependencies to have a "bootstrap" flag
20:57:15 <teuf> Nanar: don't remember
20:57:20 <Nanar> :)
20:58:14 <t_m_b> Nanar: afaik as long as a package is suggested, it wont end up on orphan list...
20:58:50 <AL13N> t_m_b: i agree with the bootstrap flag as well, i sent email on -dev about this
20:58:59 <Nanar> t_m_b: if a suggested b, and i remove a, b is orphans for me
20:59:03 <misc> ok so we are drifting a bit from the topic
20:59:13 <misc> anything to add on it ?
21:00:21 <ennael> so what action on this topic ?
21:00:38 <misc> me doing vm
21:00:41 <misc> people post bugs
21:00:52 * misc will try again to upgrade clone of our server
21:01:21 <ennael> what about t_m_b suggestion ?
21:01:33 <misc> I am for it :)
21:02:03 <ennael> so not allowing package submission if all deps are not available ?
21:02:05 <ahmad78> some of the stuff in the missing-deps packages are bogus
21:02:30 <misc> ahmad78: pterjan and mikala have been looking at it, not sure of the status ( except "not deployed yet" )
21:02:34 * boklm agrees with suggestion from t_m_b
21:02:41 <misc> ( like pterjan network connexion, .. )
21:02:44 <ahmad78> http://pkgsubmit.mageia.org/data/missing-deps.x86_64.txt
21:02:50 <ahmad78> /usr/bin/python ?
21:02:59 <ahmad78> so that's a blocker for applying t_m_b suggestion
21:03:27 <misc> why ?
21:03:50 <ahmad78> because some packages are flagged as having missing deps while they don't have missing deps
21:04:26 <misc> well, I think in this case there is a wrong dep, it should not requires /usr/bin/python directly, we do have something to transform that in python
21:04:36 <AL13N> t_m_b: this was my suggestion about bootstrap flag: https://www.mageia.org/pipermail/mageia-dev/20110315/003345.html
21:04:36 <erzulie> [ [Mageia-dev] Packaging errors to fix ]
21:04:43 <t_m_b> ahmad78: well, then we need to find out why, and fix it...
21:05:03 <misc> again, mikala proposed something, and pterjan too, so we can investigate
21:05:13 <ahmad78> t_m_b: I agree, but it should be fixed _before_ rejecting uploaded packages that have missing deps
21:06:16 <AL13N> so the question remains on the "deployment of new format, so they can be fixed"
21:06:20 <misc> ahmad78: well, if everything is blocker, we can disable the check
21:06:45 <t_m_b> ahmad78: well, those packages that have introduced the missing deps are already available, so this is more about not adding more...
21:06:51 <mikala> AL13N: i've got an error to correct on my script because i found some strange result last time
21:06:57 <mikala> i'll try to do it tonight
21:06:57 <Dr_ST_home> lo
21:07:02 <AL13N> mikala: thanks
21:07:04 <dmorgan> Dr_ST_home: hi
21:07:10 <ahmad78> misc: sure, but if I get a "rejected" because of  missing deps that's not really missing I won't submit again?
21:07:10 <ennael> who would take care of this ?
21:07:13 <mikala> & i'll send it to misc/pterjan for review.
21:07:53 <mikala> AL13N: i'm talking about the missing requires on http://pkgsubmit.mageia.org/data/missing-deps.x86_64.txt
21:08:01 <mikala> to know which package is requiring what.
21:08:06 <AL13N> mikala: i know
21:08:23 <misc> ahmad78: so far, on the whole list, there is 1 bogus package, that's pretty low
21:08:31 <AL13N> so, #action mikala fix missing deps list :-D
21:09:41 <misc> ahmad78: and we could also do a test run to see what would be blocked
21:09:48 <mikala> hum need to move :/
21:10:39 <ahmad78> misc: well, if you reject uploaded packages for an extra . in the summary, why not for missing deps too? (as long as I can install it locally, should I care :)?
21:10:56 <misc> ahmad78: ideally, we should reject sooner
21:11:10 <misc> but technically, this may be harder
21:11:19 <misc> we could run rpmlint in svn commit
21:11:33 <ahmad78> misc: btw the two times I get packages rejected because of a . in the summary, they were packages imported from mdv
21:11:38 <Nanar> rpmlint don't check deps
21:11:46 <ahmad78> so either tv missed them in the big-summary-cleaning
21:12:00 <ahmad78> or the restriction has been removed from mdv build bots
21:12:23 <misc> Nanar: this could be done by perl-RPM4
21:12:31 <misc> but well, this is unrealted to pgrade tests
21:12:40 <Nanar> yup
21:13:26 <misc> so next topic ?
21:13:48 <ennael> #topic next test day
21:14:06 <ennael> would be nice to organize second test day
21:14:16 <AL13N> will we get an updated iso for this?
21:14:27 <ennael> we need to find a topic whish is a priority for us
21:14:27 <misc> AL13N: like alpha 2 ?
21:14:38 <AL13N> misc: i already tested alpha 2 :-)
21:15:41 <AL13N> ennael: imo the mdv upgrade is
21:16:07 <Dr_ST_home> sorry, gtg
21:16:12 <misc> we also need someone to manage the test day
21:16:16 <misc> any volunteer ?
21:16:43 <ennael> may depend on topic :)
21:17:14 <misc> if we say "upgrade from mdv", we would need a new iso
21:17:22 <misc> we could test each desktop, see if they work
21:17:46 <ennael> yep
21:18:08 <AL13N> misc: you mean desktop with all their respective apps?
21:18:12 <shikamaru> that’s fairly vague
21:18:15 <misc> AL13N: yes
21:18:31 <misc> so let's say "install 1 desktop, and try to do the following tasks : "
21:18:34 <misc> - surf the web
21:18:39 <misc> - listen to music
21:18:41 <misc> etc
21:18:53 <AL13N> could be doable
21:18:53 <shikamaru> yes, a list of items could be nice
21:18:57 <ennael> yep
21:20:04 <misc> ok so I start this on the wiki, send the list to be completed
21:20:15 <misc> and then we will do the test day ?
21:20:27 <ennael> yep mail on -dev ?
21:20:53 <AL13N> make sure there's enough time upfront
21:21:00 <AL13N> perhaps mail on -discuss ?
21:21:08 <misc> on -dev
21:21:22 <misc> people that want to forward on -discuss are welcome to do so and to manage it :)
21:21:34 <AL13N> -dev is fine
21:21:58 <shikamaru> ^^
21:22:02 <misc> #action misc post a list of test items on -dev
21:22:07 <ennael> ok
21:23:23 <ennael> anythiong else to add ?
21:23:50 <misc> nope
21:23:55 <ennael> guys ?
21:24:00 <shikamaru> yep
21:24:29 <ennael> ok so let's close meeting
21:24:30 <shikamaru> about maintdb
21:24:33 <ennael> oups
21:24:37 <shikamaru> sorry
21:24:42 <ennael> yep ? :)
21:25:02 <AL13N> i have also one point to add
21:25:14 <ennael> AL13N: first shikamaru
21:25:15 <shikamaru> will it be deployed with a readonly interface ?
21:25:37 <shikamaru> because at the moment anyone can add anything on http://www.maintdb2.mageia.org.uk/maintainers/
21:25:43 <erzulie> [ Mageia maintainers database ]
21:25:53 <ennael> I guess so
21:26:02 <misc> shikamaru: for the moment, this is a test installation, and not linked to our ldap, so no authentication so far
21:26:03 <trem> nite all, sweet dreams
21:26:19 <shikamaru> misc: but I heard it was not planned to add authentication
21:26:28 <shikamaru> because it’s supposed to be fed by the BS
21:26:34 <shikamaru> (partly)
21:26:50 <AL13N> shikamaru: afaik there was no agreement on that
21:27:06 <Kicer86> cy all
21:27:12 <misc> shikamaru: well, authentication was on the requirement, but that's up to webteam to handle that
21:27:24 <ennael> shikamaru: you should mail or ping rda on ric
21:27:25 <ennael> irc
21:27:30 <ennael> on -dev
21:27:51 <boklm> the specs are on http://mageia.org/wiki/doku.php?id=web:maintdb
21:27:52 <erzulie> [ web:maintdb [Mageia temporary wiki] ]
21:28:28 <proyvind> ps: on dealing with rpm5 packages, you prolly' want to merge this branch: http://svn.mandriva.com/cgi-bin/viewvc.cgi/soft/rpm/perl-URPM/branches/3.37-distepoch/
21:28:28 <erzulie> [ [soft] Index of /rpm/perl-URPM/branches/3.37-distepoch ]
21:28:33 <ennael> check it with rda if not clear enough
21:28:52 <ennael> maybe it's something that was not clear enough in specs
21:28:55 <misc> ok so anything to add on the topic of the meeting ?
21:28:59 <AL13N> ennael: upgrade testing would be easier if we had an applet for upgrade/update, but afaik it still has to be cleaned and we kind of need it
21:28:59 <misc> ennael: "logging in (authentication against Mageia LDAP)
21:29:09 <misc> ennael: in the v0.1, so i think this is clear :)
21:29:22 <ennael> misc: well if it can help shikamaru to sleep better :)
21:29:32 <shikamaru> hey ! :)
21:29:34 <ennael> AL13N: it's in todo list
21:29:45 <ennael> as soon as possible
21:29:50 <misc> AL13N: the applet would just run urpmi, and would not give the proper integration for bug report, so no
21:29:53 <AL13N> ennael: i'm just saying, it would bring more testers probably
21:30:00 <AL13N> misc: ah, ok
21:30:15 <proyvind> there's also the Db_conversion() function URPM.xs you might want to take a look at, or pick up http://rpm5.org/cvs/rlog?f=rpm/tools/dbconvert.c (standalone tool), this should help you convert back from rpm5 rpmdb if you want to upgrade from current cooker..
21:30:16 <erzulie> [ rpm package manager ]
21:30:28 <misc> proyvind: could you please wait we finish our meeting ?
21:30:34 <AL13N> misc: ok, but otoh, it's also a kind of crucial thing that needs to be tested well
21:30:49 <proyvind> oh, didn't notice there being a meeting, just noticed people talking about it earlier :)
21:30:50 <AL13N> misc: but i understand your point
21:30:53 <proyvind> sorry
21:30:58 <misc> proyvind: no problem :)
21:31:02 <ennael> ok any point to add ?
21:31:03 <Nanar> o/win 27
21:31:03 <AL13N> end of meeting then?
21:31:16 <boklm> Nanar: o/
21:31:28 <ennael> hanks guys for being there
21:31:32 <ennael> #endmeeting