20:06:10 <ennael> #startmeeting
20:06:10 <Inigo_Montoya> Meeting started Wed Mar  2 20:06:10 2011 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:06:10 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:06:11 <erzulie> [ MeetBot - Debian Wiki ]
20:06:25 <ennael> ready to start ?
20:06:45 <Nanar> yes
20:06:55 <ennael> ok
20:07:15 <ennael> so first one was proposed last meeting
20:07:23 <ennael> #calendar for mentoring
20:07:26 <AL13N> sorry i'm late
20:07:30 <ennael> #topic calendar for mentoring
20:07:46 <ennael> Just sent a blog post about mageia calendar
20:08:04 <ennael> http://mageia.org/en/calendar/
20:08:04 <erzulie> [ Mageia calendar ]
20:08:18 <brianb_> hi
20:08:21 <ennael> this is all about important dates of mageia project
20:08:36 <ennael> one of these calendars is about mentoring and training
20:08:45 <xrogaan> o/
20:09:02 <AL13N> nice
20:09:05 <ennael> it's not all ready yet as we will add all official packagers
20:09:28 <ennael> so that they can add entries when there are able to help on #mageia-mentoring
20:09:37 <ennael> will post on -dev just after this meeting
20:09:41 <andre999> it would be better if calendar times were utc (so those not utc or utc+1 don't have to keep 3 time zones)
20:10:00 <andre999> otherwise it is nice
20:10:06 <ennael> yep it's on the way
20:10:25 <ennael> later it will be self hosted but at least for now we have something working
20:10:28 <obgr_seneca> I do think they are partly...
20:10:38 <ennael> obgr_seneca: yep but not all of them
20:10:55 <obgr_seneca> e.g. webteam and i18n team meetings are, packager meeting is not
20:11:07 <Anssi> though it says "Events shown in time zone: Paris"
20:11:07 <ennael> yep I've been lazy and not finalized it yet :)
20:11:52 <baud> well, people can meet before and after each meeting, and even if there's not a meeting :)
20:11:52 <ennael> yes this will be fixed tonight
20:12:23 <ennael> about these calendars do you see something else to be added that could help us ?
20:12:58 <Nanar> no on my side
20:13:20 <obgr_seneca> i think it would get confusing if we added the i18n-language team meetings, so I don't see anything at the moment
20:13:41 <ennael> as you wish
20:14:05 <ennael> that's also why we did several calendars to avoid having too many things in one
20:14:14 <baud> well, open a topic about comments on the ML too so that people can tell everything they would like to be enhanced (icons, longer descriptions, links to the wiki...)
20:14:27 <ennael> yep
20:14:44 <ennael> any questions ?
20:14:49 <andre999> ideally we could select what group events we want to see
20:14:49 <AL13N> but that's more for the real version later on
20:14:59 <ennael> andre999: you can
20:15:06 <ennael> clic on agenda menu
20:15:11 <andre999> really how ?
20:15:20 <ennael> you can choose the one you want
20:15:32 <andre999> thanks for the info
20:15:48 <andre999> that means we can have one calendar for everything
20:15:58 <ennael> if you check all of them yes
20:16:18 <baud> FYI http://mageia.org/wiki/doku.php?id=web:calendar lists some requirements that were taken into account :-) (can be enhanced with actual calendar available now)
20:16:18 <erzulie> [ web:calendar [Mageia temporary wiki] ]
20:16:22 <andre999> those that we choose i mean :)
20:17:01 <ennael> baud: for now we have added events where mageia will do something
20:17:14 <ennael> conferences are planned for linuxtag, solution linux and RMLL
20:17:19 <andre999> I see - by default all are chosen - that,s good :)
20:17:35 <ennael> ok can we switch to next topic ?
20:17:43 <andre999> ok
20:18:04 <AL13N> ok
20:19:05 <ennael> #topic first mentors review
20:19:30 <ennael> ok as announced on last meeting what we need to do in coming weeks is to increase packagers team
20:20:05 <ennael> so the point is here is to see with actual mentors what are potential difficulties they have, how we can imporve, doc missing, ....
20:20:15 <ennael> who would like to start with ?
20:20:23 <Nanar> o/ ?
20:20:29 <ennael> ok
20:20:40 <mikala> regarding me it's more a timezone problem
20:20:47 <Nanar> first point: what a padawan is allow to do ?
20:20:48 <ennael> one by one :)
20:21:02 <Nanar> commiting ? submitting ?
20:21:08 <mikala> Nanar: commiting.
20:21:18 <rda> I'll fix the timezone displayed
20:21:21 <Nanar> and how giving permission to do this ?
20:21:44 <ennael> Nanar: did you have a look on wiki page ?
20:21:51 <mikala> rda: i was speaking about meeting with my padawan :)
20:21:54 <AL13N> (isn't it gradually, first see spec files, then see if commits are well, and last see if submission is ok?)
20:22:01 <Nanar> ennael: then which one ? /o\
20:22:04 <rda> mikala: ah, sorry :)
20:22:34 <ennael> http://mageia.org/wiki/doku.php?id=mentoring_start
20:22:34 <erzulie> [ mentoring_start [Mageia temporary wiki] ]
20:22:46 <Anssi> regardin this, I'd rather see that apprentices had submissions rights (if not in the very beginning, at least very shortly)
20:22:47 <ennael> maybe it's not complete so we can add missing items
20:23:12 <ennael> shall we do it automatically ? when ?
20:23:13 <Anssi> (of course they should ask permission from their mentor before submitting anything, but imo it'd be better if they did it themselves)
20:23:40 <obgr_seneca> I would consider it best for the mentor to decide and ask for it, when the padawan is ready?
20:23:41 <Nanar> I think some part are not clear but on sys admin side
20:23:53 <Nanar> as I am myself a sys admin...
20:24:09 <Anssi> obgr_seneca: seems reasonable
20:24:12 <andre999> there are slight inconsistancies with the start and spec pages - I think it would be better to have a "pure" mga example, with anotations
20:25:00 <ennael> so are you all agree on "mentor decides when apprentice can commit and ask for proper rights" ?
20:25:00 <AL13N> afaik, the identity needs to be in a group/role
20:25:09 <AL13N> separate for committing and submission
20:25:12 <Nanar> ennael: yes
20:25:14 <AL13N> yes
20:25:21 <andre999> I like the idea of us "padawans" being able to submit (after consulting mentor of course)
20:25:29 <AL13N> me too
20:25:30 <ennael> not submit but commit
20:25:38 <andre999> agreed
20:25:41 <Nanar> I had a pb with submitting
20:25:55 <ennael> who should be the contact for commit rights ?
20:25:58 <Nanar> my padawan did 130 packages (stardict*)
20:26:14 <Anssi> ennael: aren't commit rights automatic? I was talking about submission
20:26:14 <ennael> sysdamin team ?
20:26:28 <obgr_seneca> ennael: at least I do have commit rights
20:26:29 <andre999> the mentor
20:26:30 <ennael> then it's not that clear :)
20:26:40 <ennael> ok let start from the beginning
20:26:44 <ennael> commit rights
20:27:01 <ennael> as soon as apprentice has mentor shall we give him commits rights ?
20:27:08 <obgr_seneca> there's not much sense in telling people how to commit, when you have to tell them: you can't do that, but that's how it would work
20:27:10 <Anssi> yes, otherwise they can't do anything
20:27:12 <Nanar> I think yes
20:27:21 <ennael> ok it's just to make things clear
20:27:32 <ennael> who should ask for account and commit rights ?
20:27:33 <andre999> I think that the mentor should be the one to decide - they watch the trainee the closest
20:27:37 <philippeM> the main problem is that today we don't have a build only submit and no doc to setup iurt locally, so submit is to high
20:27:48 <xrogaan> ennael: no
20:27:58 <Nanar> andre999: w/o commit permission, you cannot work
20:28:02 <xrogaan> ennael: the mentor needs to check if the padawan can write proper spec files
20:28:20 <xrogaan> without that, it is useless for the padawan to commit anything
20:28:20 <Nanar> it is useless to be apprenctice w/o any permission
20:28:24 <AL13N> xrogaan: you mean before commit rights?
20:28:28 <ennael> ==> who should ask for account and commit rights ?
20:28:35 <ennael> apprentice or mentor ?
20:28:37 <obgr_seneca> the mentor?
20:28:38 <misc> the mentor
20:28:38 * boklm thinks mentor should ask
20:28:39 <Nanar> mentor
20:28:44 <ennael> ok thanks :)
20:28:45 <misc> as the mentor will likely know the procedure
20:28:45 <AL13N> mentor
20:28:47 <baud> ennael: the mentor :) with padawan in copy
20:28:54 <Nanar> apprentice ask to mentor, mentor ask to sys admin
20:28:59 <ennael> now about submit rights ?
20:29:01 <misc> and this will scale better than sysadmin endlessly asking to people how to create ssh key and so on
20:29:04 <boklm> I think we could use bugzilla to do it
20:29:09 <misc> ennael: the same, mentor
20:29:13 <ennael> ok
20:29:13 <Nanar> ennael: same things
20:29:18 <ennael> contact is sysadmin ?
20:29:21 <ennael> team
20:29:24 <Nanar> yes
20:29:26 <AL13N> same
20:29:28 <misc> the question is when should mentor say "it should have submit right"
20:29:34 <Nanar> only them have access to ldap...
20:29:36 <xrogaan> boklm: that's a brilliant idea
20:29:44 <boklm> I think contact can be sysadmin, using bugzilla
20:29:45 <ennael> #action mentors will ask for account creation and coommit and submit rights to sysadmin team
20:29:52 <baud> and mageia-dev in copy to welcome a new official packager ?
20:29:59 <AL13N> misc: mentor's freedom
20:30:01 <ennael> everubody ok about bugzilla use ?
20:30:16 <AL13N> misc: he has a document for skills that are required afaik
20:30:24 <philippeM> ok
20:30:47 <ennael> contact sysadmin team : ML or bugzilla ?
20:30:48 <xrogaan> ennael: yes for me, and it can provide a training for that tool too
20:30:53 <Nanar> I am not funny about usuing bugzilla for this
20:30:57 <AL13N> actually, another idea (maybe overkill) is to have mentors do it themselves through identity
20:31:02 <boklm> Nanar: why ?
20:31:12 <ennael> AL13N: wait please
20:31:13 <misc> well, bugzila per se, or a web interface ?
20:31:41 <ennael> web interface ?
20:31:48 <Nanar> I fear about overload... I just think bugzilla is to heavy for this
20:31:57 <Nanar> I can be wrong
20:32:00 <boklm> in bugzilla, Product: Infrastructure, Component: Account request
20:32:01 <misc> ennael: ie, the problem is bugzilla the product, or using a bts for that
20:32:17 <baud> misc: yet another web interface ? well, if bugzilla can dispatch new packages requests it may dispatch new packager creation :)
20:32:21 <xrogaan> Can't we get templates in bugzilla ?
20:32:22 <ennael> what about component as suggested by boklm ?
20:32:31 <xrogaan> I mean, ticket templates
20:32:33 <misc> Nanar: while it would be nice to have more packagers than bugs, I do not think this will be easy to achieve :)
20:32:40 <ennael> :)
20:33:06 <misc> so the bts will not be so overloaded by account creation ( especially since bugs have already a good advance )
20:33:11 <AL13N> misc: how about mentors use identity for it directly?
20:33:11 <Nanar> misc: I do my best to have more packagers
20:33:30 <Nanar> overload is maybe not the words
20:33:49 <Nanar> I just think bugzilla is a monster
20:33:51 <ennael> AL13N: I don't know if we can manage rights on svn
20:34:06 <boklm> Nanar: we already have bugzilla setup, so I think it's not a problem
20:34:21 <baud> Nanar: overkill perhaps yep, but well as boklm tells already available :)
20:34:30 <Nanar> baud: exactly overkill
20:34:31 <andre999> bugzilla is nice for tracking everything
20:34:36 <AL13N> ennael: i mean, instead of using bugzilla to have sysadmin team do something so trivial as to give person rights on committing/submitting ...
20:34:51 <AL13N> ennael: if mentor just directly sets role in identity
20:35:02 <AL13N> ennael: afaik that's how sysadmin does it
20:35:02 <ennael> not sure it's possible yet
20:35:10 <ennael> and we need short term solution
20:35:25 <Nanar> it is not, but we can decide goals to achieve
20:35:26 <misc> AL13N: I do use ldapvi ...
20:35:40 <AL13N> misc: tsssk, bypassing security
20:35:44 <xrogaan> actually, mentors just ask the sysadmin. So, keep it this way.
20:35:45 <andre999> do we want to track the creation of packagers ?
20:35:46 <misc> AL13N: no
20:35:46 <anaselli> ehm which is the subject? sorry if i'm late
20:35:51 <ennael> so send mail to sysadmin for now
20:36:00 <ennael> while functionnity is developped on identity ?
20:36:01 <boklm> using only email on mailing list is not easy for tracking, so we need something better for this, and I think bugzilla is good for this
20:36:02 <misc> AL13N: please, do not make assumption on the way I work without knowing
20:36:34 * boklm does not see the problem with using bugzilla
20:36:43 <AL13N> misc: it's just a little joke, mea culpa
20:36:44 <xrogaan> my either
20:37:15 <ennael> ok guys can we try to find a solution ?
20:37:20 <ennael> Anssi, philippeM ?
20:37:22 <baud> well, maybe renaming bugs.mageia.org to tickets.mageia.org would help understand that bugzilla does not only manage bugs :-)
20:37:23 <misc> well, bugzilla sound fine
20:37:44 <philippeM> for me bugzilla is ok
20:37:47 <xrogaan> so be it, bugzilla it is !
20:37:49 <misc> if it start to be not adapted ( ie, too complex because we try to manage everything with it ), we can later choose something else
20:37:59 <Nanar> I am not in favor of bugzilla, but not completly against, so let's go, we must advance
20:38:01 <andre999> it seems to me, if we want to track creation of package accts, that bugzilla is a good solution, otherwise not necessary
20:38:18 <andre999> s/that/then
20:38:18 <Anssi> I have no opinion on this one, whatever is fine
20:38:27 <misc> I do understand nanar concern and indeed, bugzilla may ask too much questions, or feel awkward for a creation of account
20:38:42 <misc> but we could then maybe have a wizard for that, or some kind of wrapper
20:38:58 <misc> ( after all, gnome do this for bug, we can perfectly do it by xml-rpc )
20:39:01 <ennael> shall we say we use bugzilla for now and think about more user-friendly solution ?
20:39:16 <Nanar> ok for me
20:39:19 <rda> sounds good
20:39:28 <andre999> ok
20:39:50 <ennael> #action bugzilla will be used for now for account creation requests and rights modification
20:40:10 <ennael> #action add in todo list user-friendly interface for account management
20:40:14 <baud> so, boklm will be in charge of configuring it as he said it was possible ?
20:40:15 <xrogaan> but how many tickets by padawan ?
20:40:36 <ennael> ok this is for account management
20:40:50 <ennael> other points to speak about ?
20:41:00 <boklm> we already have the "Accounts request" component in bugzilla
20:41:16 <anaselli> sorry identity.mageia.org is not valid any more?
20:41:25 <boklm> anaselli: ?
20:41:36 <xrogaan> anaselli: yes, but we're talking about packagers and apprentices
20:41:40 <brianb_> when will the people without packaging experience be allocated to a mentor? and currently how far down this list of people have mentors reached?
20:41:41 <anaselli> never mind, i will read all later :)
20:41:50 <anaselli> ok sorry again
20:41:57 <baud> anaselli: well, the functionality may be implemented later :)
20:42:06 <anaselli> i thought it was the same to create an account
20:42:29 <ennael> brianb_: http://mageia.org/wiki/doku.php?id=packages_mentoring
20:42:30 <erzulie> [ packages_mentoring [Mageia temporary wiki] ]
20:42:30 <boklm> anaselli: it is still used, but bugzilla is used to request more rights on an account
20:42:37 <rda> anaselli: identity is for creating an account. here the point was to how to grant this account specific privileges (packager ones)
20:42:42 <andre999> we're talking about packager privileges, aren't we ?
20:42:49 <ennael> ok next item, pb, improvement
20:42:56 <ennael> Nanar: any other thing to add?
20:43:06 <Nanar> I am searching
20:43:12 <Nanar> yes
20:43:31 <brianb_> ok ennael i send you a email on this isses
20:43:36 <Nanar> so new packager have first commit righs and later submitting ?
20:43:42 <ennael> yep
20:44:00 <brianb_> since it does not answer my question
20:44:01 <shikamaru> moin
20:44:04 <Nanar> in the case the apprentice will have an huge count of packages ?
20:44:08 <misc> brianb_: people without packaging experience could try to read the existing documentation on the web, I guess
20:44:20 <shikamaru> sorry I’m late
20:44:27 <Nanar> can we give submitting permissions and trust apprentices ?
20:44:28 <brianb_> ive heard all this before
20:44:29 <philippeM> other point : can we have a scratch-build on build system I mean a build without submitting ? or a doc about setting up iurt locally ?
20:44:42 <ennael> about what Nanar says
20:44:47 <misc> brianb_: because from my own experience of packaging, being autonomous is very important
20:44:48 <boklm> Nanar: when they are ready
20:45:05 <ennael> hum can we focus point by point :)
20:45:06 <brianb_> sorry i dont agree
20:45:26 <ennael> about what Nanar just said
20:45:27 <boklm> Nanar: when mentors decide apprentice has enough experience to submit directly
20:45:32 <andre999> a doc for setting up iurt locally would be great
20:45:42 <ennael> giving submit rights
20:45:43 <ennael> http://mageia.org/wiki/doku.php?id=mentoring_start#main_steps_of_mentoring_process
20:45:44 <erzulie> [ mentoring_start [Mageia temporary wiki] ]
20:45:49 <ennael> we have this list
20:45:58 <ennael> is it complete enough ?
20:46:12 <Nanar> the specific issue I had is 130 similar packages :)
20:46:13 <philippeM> about what nanar says if we can have a build right that is not a submit right, apprentice could commit and build and then mentor submit
20:46:25 <Nanar> maybe I had a too specific issue
20:46:26 <shikamaru> misc: well, I admit autonomous is a vague term
20:46:29 <misc> people can build most of the time without iurt
20:46:55 <Nanar> I did managed it perfectly
20:47:01 <philippeM> misc yes but iurt is the best way to check buildrequires
20:47:01 <shikamaru> brianb_: being autonomous does not mean you can’t ask questions
20:47:01 <misc> I do not have iurt setup anywhere, nor did I have when i started packaging, and this didn't prevent to learn anything :/
20:47:12 <ennael> what misc wanted to say
20:47:14 <ennael> is
20:47:15 <shikamaru> if that’s why you disagree
20:47:25 <ennael> you want to become packager
20:47:28 <shikamaru> but a mentor is not meant to be a teacher either
20:47:30 <Dr_ST_home> hi folks
20:47:32 <ennael> you will have mentor to help you
20:47:44 <ennael> but you do have also to read some docs
20:47:46 <anaselli> misc: yes and i do that often, but iurt sometimes does not make it pass for requirement for instance...
20:47:48 <ennael> and work on your side
20:47:53 <baud> brianb_: yep, I would recommend you to add more specific questions :)
20:48:00 <Nanar> I have a final point
20:48:04 <baud> s/add/ask/
20:48:11 <ennael> Nanar: wait
20:48:27 <ennael> can we finalize the current point
20:48:37 <ennael> about mentoring process
20:48:47 <baud> for example, wiki pages have been created, we can organize a session of questions/answers if they are not clear enough :)
20:48:52 <ennael> shall we have official one detailed maybe based on wiki page
20:48:57 <ennael> baud: please
20:49:04 <andre999> I've just heard that iurt helps - so far I've used rpmbuild, and it compiles ok locally
20:50:17 <Nanar> iurt do not change anything about writing a spec file
20:50:43 <misc> mikala: a opinion on the question of ennael ?
20:50:45 <misc> shikamaru: same
20:50:47 <baud> ennael: well, that would be one role of mentors to add anything their padawan ask, so that wiki pages are more precise and complete
20:51:00 <anaselli> andre999: a common mistake is that since you have installed all the develop dependencies you can miss a requirement and rpmbuild goes on while iurt no...
20:51:06 <baud> (and encouraging the padawan to edit the wiki on their own too)
20:51:15 <ennael> anaselli: please
20:51:27 <AL13N> TOO MANY PEOPLE SPEAKING OF DIFFERENT THINGS! I CANNOT FOLLOW!
20:51:28 <shikamaru> misc: sorry I have huge lags I don’t quite understand what your answer is related to :/
20:51:40 <ennael> 21:47 < ennael> about mentoring process
20:51:42 <ennael> 21:47 < ennael> shall we have official one detailed maybe based on wiki page
20:52:01 <Nanar> yes
20:52:06 <ennael> to answer question of a mentor "do I have to trust apprentice, when can I give him rights"
20:52:35 <shikamaru> ennael: there is no simple answer to this I’m afraid :/
20:52:36 <Nanar> yes we need guidance
20:52:37 <boklm> I think it can be useful
20:52:40 <Dr_ST_home> well, this point is easy
20:52:42 <andre999> anaselli : I know, it took me a long time to verify the dependancies, which is why I wondered about iurt
20:52:47 * blingme missed the earlier part, but is not aware of anything missing in CatDap/identity at present
20:52:52 <shikamaru> sometimes you have to give rights early to keep motivation intact
20:53:03 <Dr_ST_home> when he's confident enough, has proven enough skills, and is answering on a regular basis
20:53:05 <blingme> Account Admins, and the group owner of any group can add/remove members
20:53:18 <Dr_ST_home> I trained some people at mandriva, and I can tell you this is easy
20:53:22 <ennael> Dr_ST_home: you are new mentor how do you know what to do ?
20:53:24 <blingme> (account admins doesn't necessarily == sysadmins)
20:53:25 <Nanar> shikamaru: up to mentor to bypass if need, but I do think we need point as basis to follow
20:53:27 <shikamaru> sometimes you have to limit your padawan because he wants to put the charriot before the cows
20:53:34 <baud> ennael: "rights" for example being "commit to svn", should it be immediate ?
20:53:42 * ennael slaps baud
20:53:44 <anaselli> well ennael a kind of policy for that should be right
20:53:50 <andre999> ennael: I think that that is a great idea
20:54:00 <Dr_ST_home> ennael: well, mentoring is just about teaching a dev to use the build system, policies, etc, no?
20:54:05 <ennael> so again http://mageia.org/wiki/doku.php?id=mentoring_start#main_steps_of_mentoring_process
20:54:06 <erzulie> [ mentoring_start [Mageia temporary wiki] ]
20:54:12 <ennael> is that complete enough ?
20:54:13 <shikamaru> Dr_ST_home: I thought so too, at first
20:54:21 <ennael> does it help or should we complete it ?
20:54:26 <Dr_ST_home> baud: commit to svn, yes, but no submission rights
20:54:42 <philippeM> ennael: I think this page is ok and enough
20:54:57 <Nanar> ennael: this page is good start
20:55:02 <mikala> it's a good start
20:55:12 <ennael> good start so it needs to be completed ? :)
20:55:13 <anaselli> ennael: quick read, but it seem good for me
20:55:20 <anaselli> seems
20:55:27 <baud> ennael: yep, to follow my example, "once you think your trainee can commit in Mageia " is not precise enough, imho it should be nearly immediate (as long as the mentor has reviewed one spec file from the padawan)
20:55:36 <Nanar> ennael: probably but we'll discover with what later
20:55:39 <andre999> I would be nice if we could have documentation with annotations in a different colour
20:55:50 <ennael> baud: this was fixed already it needs to be updated
20:55:52 <andre999> (the way I make my notes)
20:55:53 <baud> Dr_ST_home: agree
20:55:57 <misc> ok so who is volunteer to collect and enhance the page ?
20:56:02 <misc> baud, andre999  ?
20:56:10 <mikala> misc: i'll try to update the iurt part
20:56:26 <anaselli> ennael: baud well we can trust mentors after all no?
20:56:28 <mikala> or at least to create a page to explain how to set up iurt
20:56:31 <baud> misc: only if we have suficient requests on #mageia-mentoring :)
20:56:35 <mikala> & link it there
20:56:39 <mikala> (on a local box)
20:56:41 <baud> anaselli: yep of course :)
20:56:44 <anaselli> otherwise... we need mentoring mentors :)
20:56:58 <Nanar> and why not ?
20:57:00 <Dr_ST_home> baud: no, some trainees need more time to ensure they work properly
20:57:04 <misc> baud: so you are ok to collect requests ?
20:57:11 <Dr_ST_home> and there is also the "confidence" in the packager
20:57:39 <baud> misc: on #mageia-mentoring no problem (and on ML -dev of course)
20:57:44 <Dr_ST_home> there is a security risk in giving someone a lot of rights without some controls, giving too much trust is "dangerous"
20:58:00 <misc> #action baud collect what to add to the wiki page
20:58:07 <misc> ennael: next topic ?
20:58:09 <Nanar> Dr_ST_home: everything is dangerous
20:58:10 <baud> misc: on conditions :)
20:58:22 <ennael> ok other points to be improved ?
20:58:26 <baud> I'll add them to mentoring_start :)
20:58:29 <ennael> shikamaru, Anssi , philippeM
20:58:33 <anaselli> Nanar: why not what exactly?
20:58:35 <ennael> from your experience for now
20:58:37 <Nanar> ennael: about doc or mentoring ?
20:58:49 <ennael> any points that can help us to improve it
20:59:02 <boklm> Maybe we could send commit emails of mentored people to their mentor ?
20:59:04 <Nanar> anaselli: metoring mentor :)
20:59:10 <blingme> hmm, doc seems unclear to me ....
20:59:13 <shikamaru> ennael: sorry I arrived in the middle of the discussion
20:59:20 <anaselli> ah agree Nanar but that requires more time :p
20:59:25 <shikamaru> ennael: but there is one point I want to stress
20:59:32 <ennael> yep ?
20:59:33 <blingme> I don't think the mentor needs to worry about supervising account creation
20:59:35 * anaselli is old :)
20:59:37 <shikamaru> I think I gave kharec submission rights to early
20:59:39 <Nanar> ennael: last point about mentoring ?
20:59:49 <shikamaru> and now he’s asking to be mentored
20:59:55 <ennael> ?
21:00:03 <shikamaru> because he’s also aware that training was too short
21:00:14 <blingme> bugzilla account creation, should rather be "log into bugzilla", but, if candidate needs to file a bug to request svn access ... that's taken care of ....
21:00:19 <Nanar> well so
21:00:30 <ennael> blingme: this is in logs already oin the beginning of this meeting
21:00:38 <ennael> shikamaru: so ?
21:00:43 <boklm> About mentoring, do you think it could be useful to send commit emails of mentored people to their mentor ?
21:00:48 <Nanar> just noticing there is a lot of techinical issue regarding ssh and commit/submitting scripts
21:00:51 <shikamaru> so like Dr_ST_home said just before, you have to take time sometimes
21:00:54 <baud> blingme: well, the mentor is one point of contact for his/her padawan :)
21:00:55 <misc> boklm: try again a 3rd time :)
21:01:02 <ennael> please guys
21:01:06 <ennael> one at a time
21:01:11 <ennael> too hard to follow
21:01:21 <shikamaru> a wrong commit can easily be reverted
21:01:31 <boklm> shikamaru: if noticed
21:01:33 <shikamaru> a wrong submit can bring down the entire buildsystem
21:01:44 <ennael> so what would you like ?
21:01:55 <xrogaan> shikamaru: really ?
21:02:27 <baud> xrogaan: yep :/ (we won't be giving any hints at it though)
21:02:44 <shikamaru> I don’t want to see rules written on marble concerning submit rights, it’s a question of feeling, trust, and experience that’s not easily translatable into a general rule
21:02:55 <ennael> sure
21:03:01 <ennael> and nobody said the contrary
21:03:02 <shikamaru> the answer is “when he’s ready”
21:03:16 <ennael> anythoing to suggest ?
21:03:17 <boklm> maybe explaining what "when he's ready" mean ?
21:03:18 <Nanar> (or she's ready)
21:03:22 <andre999> I think that padawans should build the packages on their own system first, to minimize potential problems -- preferably with tools that detect dependancies
21:03:25 <baud> commiting is simply reverted in the svn, when the mentor and padawan work collaboratively :
21:03:32 <brianb_> how and who judges who is a good or bad packager or mentor � what basis is used to judge this process and what sort of standards are applied?
21:03:51 <misc> brianb_: the mentor, using his experience
21:03:57 <ahmad78> brianb_: who says who fails or passes in your classes?
21:03:58 <shikamaru> a suggestion might be a kind of meeting
21:04:10 <andre999> we have to depend on the mentor
21:04:11 <shikamaru> of mentors
21:04:29 <shikamaru> where you can collectively decide on what “he’s ready means”
21:04:47 <xrogaan> Anakin wasn't
21:04:51 <andre999> right - collectively the mentors see all the common errors
21:04:59 <Dr_ST_home> ennael: on the policy, I think one point missing is that the packager must learn rpm tools
21:05:08 <anaselli> shikamaru: no easy anyway
21:05:11 <ennael> shikamaru: would it be to speak about apprentices or making policy ?
21:05:14 <Dr_ST_home> I've not seen any indication/pointer on this if I read correctly
21:05:25 <shikamaru> ennael: yes, about apprentices
21:05:26 <ennael> Dr_ST_home: can you add it ,
21:05:27 <ennael> ?
21:05:28 <Nanar> well, may I mention than nobody is perfect and I did lot of mistake when I start ?
21:05:35 <ennael> sure
21:05:43 <Nanar> and error is part of learning
21:05:45 <ennael> so exchanging experience between mentors ?
21:05:51 <Dr_ST_home> ennael: nope, not sure of my login on the wiki (otherwise I would have done it, of course :-)
21:05:55 <baud> shikamaru: well, it's easier if people (mentors and padawan discuss "regularly" either on #mageia-dev or #mageia-mentoring as we get to know each others at the same time
21:06:04 <Nanar> yes but also allow apprentice to do mistake in some ways
21:06:17 <ennael> ok
21:06:29 <AL13N> true, by failing you learn much better than not failing
21:06:30 <Nanar> there is a moment we should take risk
21:06:32 <anaselli> shikamaru: one who does'nt take risk and always ask maybe is ok, but maybe can't release a package by his own because he/she's never be sure of
21:06:33 <ennael> #action plan first meeting with mentors about current apprentices
21:06:38 <shikamaru> Nanar: yes, but do not let them do it twice or more
21:06:45 <ennael> shikamaru: ok ?
21:06:46 <andre999> one problem with irc is the time difference
21:06:56 <shikamaru> ennael: fine for me
21:07:09 <baud> Nanar: for me it's not a question of risk, it's a question of confidence :-) (and autonomy), we all make errors
21:07:13 <ennael> ok
21:07:16 <xrogaan> ennael: aren't we doing it now ?
21:07:18 <Dr_ST_home> andre999: you are not limited to irc, mail is fine too
21:07:21 <ennael> any other input in mentoring ?
21:07:29 <Nanar> yes
21:07:29 <genomega> What about people like myself that dont really need a mentor but more of a go to person with a question?
21:07:34 <baud> Dr_ST_home: yep too
21:07:36 * boklm has a question about mentoring
21:07:48 <AL13N> oi 4 questions
21:07:49 <Nanar> just mention some technical issues with ssh and curent script on mageia server
21:07:55 <Dr_ST_home> genomega: well, that's the role of the mentor
21:07:58 <rda> genomega: that would be like a mentor
21:08:03 <ennael> genomega: then you will work with you mentor as if he is a go to person with a question
21:08:04 <ahmad78> genomega: you need a mentor/tutor to show you how to use the tools/BS
21:08:05 <baud> Nanar: just send a bug request :)
21:08:22 <ennael> boklm: yes ?
21:08:26 <Dr_ST_home> or mentors if we share our expertise on a chan or on a mailing list (preferred)
21:08:26 <Nanar> baud: sometimes I not able to submit a package myself w/o any log
21:08:33 <boklm> About mentoring, do you think it could be useful to send commit emails of mentored people to their mentor ?
21:08:38 <Nanar> baud: and it seems pb is well know
21:08:38 <ennael> \o/
21:08:41 <Dr_ST_home> boklm: no
21:08:43 <ennael> 3d time :)
21:08:57 <boklm> to be able to check easily what mentored people are doing
21:09:00 <ennael> other opinion on this ?
21:09:08 <misc> would be complex to do IMHO
21:09:13 <blingme> does an experience Mandriva packagere (e.g. me) who reads the docs, and has sufficient (sysadmin) access, need a mentor
21:09:14 <Anssi> boklm: a must for me... on mdv I used procmail filters on commit mailing list, but do we have one on mga?
21:09:15 <shikamaru> boklm: yep
21:09:19 <AL13N> maybe a summarized verion of it IF the mentor wants it
21:09:27 <boklm> misc: I think it's possible to do
21:09:27 <misc> blingme: as we said before, no
21:09:28 <baud> boklm: the mentor is supposed to follow his/her padawan :)
21:09:30 <anaselli> ennael: 4th indeed :)
21:09:44 <misc> but could people please wait until we answered to 1 question before asking another one ?
21:09:53 <baud> (and the padawan to tell his/her mentor what he/she has achieved)
21:10:04 <ennael> STOP !
21:10:06 <anaselli> baud: how's about a filter on a commit mailing list?
21:10:13 <Dr_ST_home> blingme: yes, to have the internals be explained, and validated, but this 'training' step should be short
21:10:25 <ennael> boklm: if we can do it can we propose it as an option for mentors ?
21:10:43 <xrogaan> misc: solution: put the channel in moderated mode and voice people that can talk on one subjet ?
21:10:46 <boklm> yes
21:10:57 <misc> xrogaan: another solution, kill account of people who talk :)
21:11:12 <ennael> Anssi: so you could have it as an option
21:11:21 * blingme sees no need to go to effort to send commit logs to mentor ...
21:11:41 <blingme> it would be better to ensure "maintainer" gets commit logs to his packages, even if not getting all commits
21:11:46 * Nanar won't ever read thoses mails
21:11:49 <baud> blingme: well, if it's easily possible why not do it :)
21:11:54 <boklm> blingme: we can do that also
21:11:54 <Anssi> moreover, this allows easily following the apprentice for some time when they are no longer an apprentice
21:12:08 <AL13N> good point
21:12:30 <Dr_ST_home> well, as long as the trainee can commit to svn, this is easier to follow, just update the local copy so we can see if it works and just commit, or fix directly, and explain why to the trainee
21:12:32 <Nanar> Anssi: I'll be happy to forward you the 260 commit mails about stardict...
21:12:40 <blingme> baud: I don't necessarily trust all contributors with my packages any more than a padawan ...
21:12:42 <baud> is mentor defined as temporary maintainer as long as his/her padawan has not submit rights ?
21:12:48 <Anssi> Nanar: and I can happily rm them :)
21:12:58 <ennael> Nanar: don't make it general :)
21:13:06 <misc> ok so basically, some people want, some do not want
21:13:08 <baud> blingme: yep, good point
21:13:11 <misc> so we can do a optin system
21:13:23 <misc> ie, having people to subscribe to a packages svn commit
21:13:30 <Dr_ST_home> misc: could this be on a "trainee" basis?
21:13:40 <misc> be it his own, those of the trainee, or any reason ?
21:13:40 <ennael> ?
21:13:54 <Dr_ST_home> ha, you're not talking about this way :-(
21:13:56 <xrogaan> misc: could we do that with mgarepo ?
21:14:04 <misc> xrogaan: I doubt
21:14:20 <andre999> misc: good idea
21:14:34 <ennael> misc: can you sum up ? :)
21:14:38 <boklm> we can add an option somewhere
21:14:47 <boklm> (and see where later)
21:14:51 <baud> misc: should be automatic for maintainer and packager of this specific package
21:15:05 <philippeM> misc: subscribe to a package svn commit can be a good solution
21:15:16 <baud> (can unsubscribe afterwards though)
21:15:37 <baud> philippeM: indeed as a maintainer would package at least once :)
21:15:53 <misc> ennael: yep, I will post a email for the proposal
21:15:56 <anaselli> misc: you mean a per package subscription?
21:15:59 <andre999> automatic with unsubscribe option sounds good
21:16:14 <ennael> ok
21:16:47 <andre999> should be by apprentice
21:16:48 <AL13N> (maybe people who submit, should get commit logs of that package?)
21:17:01 <AL13N> (and optout?)
21:17:23 <andre999> AL13N: that should be at least an option
21:17:25 <boklm> AL13N: not people who submit, but maintainers
21:17:27 <misc> so any others points ?
21:17:37 <misc> Nanar: you add one about ssh, iirc ?
21:17:55 <Nanar> must I repeat ?
21:18:02 <ennael> yes please
21:18:05 <andre999> like the options for emails in bugzilla
21:18:28 <Nanar> some issues with mgarepo and ssh on server side
21:18:37 <boklm> about ssh agent forward ?
21:18:41 <Nanar> yes
21:18:55 <misc> #action misc send a email with proposal about receiving mail from trainee to -dev
21:19:25 <Nanar> just for the record
21:19:45 <boklm> Nanar: I plan to change some things so that ssh agent forward is no more required
21:20:03 <Nanar> I had the problem myself, a message refer to a wiki page that don't help
21:20:09 <Nanar> boklm: ok
21:20:20 <boklm> but before that we can improve documentation
21:20:43 <misc> well, the goal is to eliminate the need for ssh agent forwarding, no ?
21:21:02 <ahmad78> boklm: documentation is good :/
21:21:11 <boklm> misc: yes
21:21:26 <ahmad78> http://www.mageia.org/wiki/doku.php?id=basic_ssh_configuration_for_packagers
21:21:26 <erzulie> [ basic_ssh_configuration_for_packagers [Mageia temporary wiki] ]
21:21:30 <misc> #action boklm eliminate the need for ssh agent
21:21:31 <baud> ahmad78: perhaps not seen /o\
21:21:40 <ahmad78> I posted that link many times
21:21:46 <ahmad78> and it's linked from the svn-faq page
21:21:59 <anaselli> and does that work with a different login username? I mean different compared to mageia account
21:22:03 <misc> boklm: any ETA, or difficulty ? I wanted to do it myself but I didn't past the planning stage :)
21:22:14 <ahmad78> anaselli: yes, that point is taken care of
21:22:31 <anaselli> ahmad78: i know :)
21:22:42 <anaselli> but if we're going to change things...
21:22:56 <boklm> misc: it's related to adding branch support in mgarepo
21:23:30 <boklm> so that mgarepo only sends package name when submiting, instead of URL
21:23:52 <misc> ok so besides ssh, let's see, who has a remark to do ? ( one at a time please )
21:24:31 <Dr_ST_home> misc: there should be a more "executive" command for ssh
21:24:53 <Dr_ST_home> the page above is Ok, but I prefer more "functional" docs, even if simpler
21:25:10 <Dr_ST_home> so the format for commands should be more easily identified
21:25:53 <ahmad78> Dr_ST_home: for example?
21:25:58 <misc> Dr_ST_home: 1) I do not understand what you mean 2) when I said, besides ssh, I was meaning "next sub topic" ...
21:25:58 <ahmad78> (and hiya :))
21:26:06 <Dr_ST_home> ha, sorry
21:26:21 <Dr_ST_home> I'll come on this another time (and hiya ahmad78 !)
21:26:43 <ahmad78> ok
21:27:33 <misc> no one has anything to add ?
21:27:35 <olorin_> Dr_ST_home: I find those instructions simple enough and a packager should be able to follow.
21:29:00 <ennael> Anything to add or can we close that meeting for tonight ?
21:29:08 <ennael> if nobody asnwers I'll sing
21:29:18 <ahmad78> ok, no one?
21:29:18 <mikala> nothing to add then.
21:29:25 <ahmad78> end the meeting
21:29:30 <baud> seems fine for tonight :)
21:29:42 <ennael> ok we can add more on next one
21:29:52 * boklm notice a lot of people answered
21:29:58 <ennael> thanks guys for coming tonight
21:30:04 <ennael> boklm: they think I cannot sing
21:30:10 <ennael> #stopmeeting
21:30:15 <boklm> #endmeeting
21:30:16 <ennael> #endmeeting