20:02:13 <misc> #startmeeting
20:02:13 <Inigo_Montoya`> Meeting started Wed Feb  2 20:02:13 2011 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:13 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:02:14 <erzulie> [ MeetBot - Debian Wiki ]
20:02:20 <misc> #name packager
20:02:28 <misc> #chair ennael shikamaru
20:02:28 <Inigo_Montoya`> Current chairs: ennael misc shikamaru
20:02:32 <ennael> hi there
20:02:35 <Kharec> hi
20:02:37 <shikamaru> hello
20:02:52 <shikamaru> a chair for me ? :)
20:02:56 <misc> hi too ( for the record )
20:02:59 <gusyear> hello
20:03:13 <misc> ok, so the meeting will be likely quick ( as usual for 3 meeting out of 4 ), unless I am wrong
20:03:22 <brianb> hi
20:03:52 <misc> #topic review of task
20:04:17 <misc> so http://meetbot.mageia.org/mageia-dev/2011/mageia-dev.2011-01-26-20.03.html
20:04:17 <erzulie> [ #mageia-dev Meeting ]
20:04:29 <mitya> hi everyone
20:04:33 <misc> hi mitya
20:04:39 <misc> let's start by ahmad78 :)
20:04:52 <AL13N_ipv4> ahmad78: is here!
20:05:20 <misc> ahmad78: did you found the time for the ssh wiki page ?
20:05:31 <ahmad78> misc: I imported it on the same day
20:05:38 <ahmad78> misc: gave you a link here too BTW :0
20:05:40 <ahmad78> :)
20:05:49 <misc> ahmad78: yeah, but I forgot :/
20:05:52 <ahmad78> misc: np
20:06:14 <misc> and for bgusquad ? as you were not here, the meeting got cancelled, I think
20:06:42 <ahmad78> misc: I didn't send the mail, will do today, and set a new date
20:07:00 <ennael> ahmad78: I will help you for the meeting just need a date
20:07:01 <shikamaru> ahmad78: \o/
20:07:10 <misc> #info ahmad78 will reschedule the meeting, with the help of ennael
20:07:12 <ahmad78> ennael: you bet!
20:07:18 <ennael> :)
20:07:35 <pterjan> $info ennael needs a date
20:07:35 <misc> AL13N_ipv4: for appstream ?
20:07:57 <misc> ah ah
20:08:22 <AL13N_ipv4> well
20:08:26 <AL13N_ipv4> i sent email
20:08:29 <sebsebseb> Hi
20:08:36 <AL13N_ipv4> and some people reacted
20:08:47 <AL13N_ipv4> a few for stormi
20:08:56 <AL13N_ipv4> i don't think anyone for misc's part
20:09:11 <AL13N_ipv4> the wiki thing was also corrected on the same day
20:09:32 <misc> good
20:09:48 <AL13N_ipv4> perhaps i will help on misc's part
20:10:03 <misc> ( misc part => pkgkit )
20:10:11 <AL13N_ipv4> ah yes, sorry
20:10:30 <AL13N_ipv4> i think stormi may be handling the responses to his part
20:10:33 <AL13N_ipv4> not sure though
20:10:47 <misc> Kharec: faq, found answers ?
20:10:47 <Stormi> not yet, but I will :)
20:11:04 <AL13N_ipv4> Stormi: :-)
20:12:22 <misc> ok, let's see kharec later
20:12:33 <Stormi> I wrote the wiki page I said I would to gather information and tasks for the AppStream project seen from Mageia's side
20:12:39 <Stormi> It's there : http://www.mageia.org/wiki/doku.php?id=appstream
20:12:40 <erzulie> [ appstream [Mageia temporary wiki] ]
20:12:51 <Kharec> misc:
20:12:53 <Stormi> I will send a mail to the -dev list
20:12:59 <misc> #info page for appstream project was written http://www.mageia.org/wiki/doku.php?id=appstream
20:12:59 <erzulie> [ appstream [Mageia temporary wiki] ]
20:13:02 <Kharec> misc: Questions are in progress
20:13:08 <Kharec> and answers too.
20:13:11 <misc> ok
20:13:20 <Kharec> It will be finished for tommorow or friday.
20:13:23 <misc> Kharec: need some help maybe ( in which case, do not hesitate to ask )
20:13:34 <Kharec> misc: sure, thanks.
20:14:00 <misc> ok so my own task, I contacted mikala, he completed the wiki
20:14:12 <misc> and jq do not have trainee, IIRC
20:14:21 <anaselli> hi
20:14:26 <misc> jq: if you are here, can you confirm ?
20:14:55 <misc> ok, likely not here
20:15:02 <misc> Nanar: haskell policy ?
20:16:49 <Nanar> not yet done
20:16:50 <Nanar> still on my TODO list, thanks to remind me
20:16:59 <misc> ( network problem, sorry )
20:17:14 <misc> rtp: about the loop breaking stuff ?
20:18:20 <rtp> misc: you're talking about the bootstrap, right ?
20:18:35 <misc> rtp: yes
20:19:24 <misc> the idea of listof macros :)
20:21:13 <misc> rtp: you can post on -dev , nothing urgent :)
20:21:28 <misc> ( just that it seemed like a good idea when we talked )
20:21:55 <rtp> misc: oh, ok.
20:22:00 <rtp> misc: I believe it is a good idea too :)
20:22:19 <AL13N_ipv4> definately for new archs
20:22:24 <misc> next ( and last ) shikamaru
20:22:35 <misc> shikamaru: you finished to complete the wiki ?
20:23:29 <shikamaru> sad to say no, will do (right after the meeting)
20:23:45 <misc> well, no problem, people can be busy
20:24:01 <misc> and stormi already told about appstream
20:24:07 <misc> so, next topic
20:24:11 <AL13N_ipv4> ok
20:24:26 <misc> #topic proposal on what to import
20:24:59 <misc> so now, even if we didn't finish to bootstreap ( dmorgan is tirelessly working on the last part of java, we are cleaning drakx )
20:25:06 <misc> we can work on the rest
20:25:27 <pterjan> just a detail
20:25:32 <rtp> misc: we'll have to rebuild some apps too. I guess a lot still have the bootstrap flag set to 1
20:25:39 <AL13N_ipv4> (what about signing and repository?)
20:25:51 <misc> AL13N_ipv4: boklm is working on this at the moment
20:25:51 <pterjan> would be nice to have nice packager info (name/email/...) in package before importing too much
20:26:04 <misc> pterjan: a maintainer db ?
20:26:10 <pterjan> well
20:26:14 <pterjan> even without that
20:26:14 <boklm> pterjan: ah yes, something that needs to be done in mgarepo
20:26:27 <pterjan> getent passwd is already useful :)
20:26:36 <pterjan> we have to decide what info
20:26:49 <AL13N_ipv4> does the BS store the packagers details in the rpm?
20:26:49 <pterjan> we can use login@mageia.org maybe
20:26:51 <pterjan> etc
20:27:03 <pterjan> AL13N_ipv4: it should but we have a ganeric one currently
20:27:29 <AL13N_ipv4> pterjan: so noone knows who packaged it, even if they have the rpm
20:27:30 <misc> can't we simply use the login for now ?
20:27:40 <pterjan> yes we can
20:27:49 <pterjan> (reminds me something)
20:27:51 <misc> all informations are in the svn and will be regenerated later
20:27:52 <boklm> or Name and login
20:28:11 <pterjan> indeed we can have Foo Bar <foobar>
20:28:19 <AL13N_ipv4> or Name and email (from ldap)
20:28:39 <misc> sure, but that's detail :)
20:28:47 <rindolf> Hi all.
20:28:53 <misc> hi rindolf
20:29:00 <rindolf> misc: is the meeting in place?
20:29:04 <misc> rindolf: yes
20:29:41 <misc> so back to importing rpm
20:30:15 <misc> as we are all eager to import rpms I guess, I would like to propose to first not import too much
20:30:45 <pterjan> except for the ones needed as dependency, I only imported toilet so far
20:31:04 <AL13N_ipv4> toilet :-)
20:31:06 <ahmad78> yeah, I mostly import BR
20:31:07 <misc> but on the other hand, we want to have a compeling distribution for the first stable release
20:31:15 <pterjan> everyone will agree that you can need toilet
20:31:21 <shikamaru> mmh well, shall we understand s/import/submit/ ?
20:31:24 <rtp> pterjan: !
20:31:40 <shikamaru> we can still work on svn anyway no ?
20:31:41 <misc> and the sysadmin team may want to use mageia on server :) ( at least, we evocated the idea when in Marseille )
20:31:47 <misc> shikamaru: we can for sure
20:31:55 <baud> misc: you mean, first check that all dependancies are ready or correctly build on the bootstrap ? (like stratagus requiring lua ?)
20:31:57 <pterjan> shikamaru: well no point in importing if you don't submit
20:32:01 <misc> baud: no
20:32:07 <shikamaru> pterjan: for me it does
20:32:17 <pterjan> shikamaru: why ?
20:32:18 <misc> in fact, the problem is how to have enough package, but not too much
20:32:24 <shikamaru> I’m working a lot on ruby packaging, applying a new policy
20:32:34 <pterjan> shikamaru: you plan to include them, no ?
20:32:38 <shikamaru> imagine my hard disk got a failure, what should I do ? :/
20:32:50 <pterjan> no need to convert the ones that will never be imported
20:33:05 <pterjan> of course you can have things not submitted in svn
20:33:10 <pterjan> if they are not ready
20:33:23 <shikamaru> I don’t get your point there :)
20:33:29 <misc> well, the problem is not to import if they are used
20:33:40 <Nanar> I submitted myself some packages because they were only in svn but need by others
20:33:56 <pterjan> shikamaru: we are talking about what packages should be added to mageia
20:33:57 <baud> well, as long as people importing understands he/she becomes the maintainer, that should be ok ?
20:34:09 <Nanar> I think packages must be submit as soon they are ready
20:34:27 * misc may not have been clear
20:34:30 <pterjan> shikamaru: when you decide a package should be, you add it to svn
20:34:38 <pterjan> shikamaru: and when it is ready you submit it
20:34:57 <shikamaru> ok, I understood that we shouldn’t submit until we have a maintainer db :)
20:35:17 <AL13N_ipv4> why exactly do we not want too much? is there disk space limitation?
20:35:19 <shikamaru> of course every module I import will make its way through the BS sooner or later ;)
20:35:23 <ahmad78> baud: no, it's not like that; one imports alot of packages that are needed as BR by some others (e.g. mysql), doesn't mean he wants to maintain it
20:35:39 <AL13N_ipv4> ISO don't need to include anything, but that isn't a requirement on SVN or repos?
20:35:40 <misc> ahmad78: because it otherwise become a mess
20:36:02 <misc> AL13N_ipv4: because if we import lots of rpm, it become a mess
20:36:09 <ahmad78> AL13N_ipv4: this is a chance to filter the ancient/unused packages in mdv
20:36:23 <misc> we should usually send patches upstream
20:36:24 <baud> ahmad78: then before importing what depends on mysql the person should find someone to maintain it
20:36:25 <pterjan> AL13N_ipv4: not importing stuff that will not be maintained
20:36:34 <pterjan> AL13N_ipv4: or that no one will use
20:36:36 <AL13N_ipv4> we should make sure there are NO unfilled dependencies AND that the person submitting it WILL be it's maintainer
20:36:49 <ennael> ok guys
20:36:50 <AL13N_ipv4> other than that, personally i see no reason
20:36:56 <ennael> misc is fighting with network
20:37:01 <ahmad78> baud: If I did that with mysql, then most of the packages that require it wouldn't still have been built to this day :)
20:37:06 <ennael> about that topic what he wanted to say
20:37:19 <ennael> is finding a way to start more imports
20:37:34 <ennael> starting with much required deps
20:37:39 <baud> ahmad78: clearly :) I meant for new packages requiring odd dependancies
20:37:46 <ennael> as for example did ahmad78 with transifex
20:38:01 <ennael> but still we need to define who will do what
20:38:05 <Kharec> I'm forced to quit. ahmad78, can we speak tomorrow?
20:38:11 <ennael> and take opportunity to mahe things properly
20:38:11 <ahmad78> Kharec: sure
20:38:24 <Kharec> thx, my kernel is in panic..
20:39:12 <ennael> outch I killed everybody...
20:39:25 <AL13N_ipv4> so the point is how to decide what is needed?
20:39:25 <Stormi> you're frightening
20:39:26 <shikamaru> ^^
20:39:30 <ennael> :)
20:39:32 <ahmad78> ennael: we agree, but what can be done about that?
20:39:35 <misc> well, I would also remind to people to clean package before importing
20:39:42 <baud> ennael: well, a simple process telling "well I would like to import foobar and become the maintainer but depending on pkgIdontWanttoMaintain" "who could help ?" could do it at first ?
20:39:47 <misc> for exemple, http://svnweb.mageia.org/packages/cauldron/abrt/current/SPECS/abrt.spec?revision=21543&view=markup
20:39:47 <ennael> we can also make a list
20:39:47 <erzulie> [ [packages] Contents of /cauldron/abrt/current/SPECS/abrt.spec ]
20:39:58 <ennael> to put some priorities
20:40:08 <AL13N_ipv4> who decides what goes and what doesn't?
20:40:09 <misc> there is like 10 patchs, and 1 of them is noted "sent upstream"
20:40:13 <AL13N_ipv4> team leaders?
20:40:14 <anaselli> agree for priority
20:40:59 <pterjan> oh there is one from me
20:41:12 <ennael> can bs team and adminsys think about it ?
20:41:17 <anaselli> i believe you aren't sayng to avoid import packages, just start with the important one first right?
20:41:26 <ennael> so that at least we can have mageia infra
20:41:28 <misc> ennael: about ?
20:41:39 <misc> oh yes
20:42:01 <ennael> anaselli: we could have kde toys ready before server packages
20:42:02 <boklm> aoubt what ?
20:42:11 <ennael> but I guess we can organize things better :)
20:42:22 <misc> boklm: if we want to be self hosting, we should focus on getting sympa, bugzilla, etc
20:42:27 <boklm> ah ok
20:42:35 <Stormi> sysadm team could run rpm -qa on server and compare with what we have in mageia
20:42:35 <ennael> so have a list of all these
20:42:41 <AL13N_ipv4> well, someone can make a list of all that is used on mageia-servers
20:42:47 <ennael> find maintainers for all of them
20:42:51 <AL13N_ipv4> Stormi: indeed
20:43:01 <AL13N_ipv4> put that on #1
20:43:04 <anaselli> feeew... i have time then :D
20:43:08 <misc> Stormi: we can use puppet to have the node
20:43:09 <AL13N_ipv4> and #2 KDE and Gnome functionality
20:43:10 <baud> anaselli: that's part of my understanding, choosing appropriately between 10 packages having no dependencies and useful wrt 1 package having many not-so-widely-used dependencies
20:43:31 <ennael> misc: when can you provide this ?
20:43:32 <anaselli> maybe devel libraries...
20:43:47 <misc> ennael: i guess after fosdem
20:43:56 <misc> what I would propose is the following
20:44:00 <ennael> ok then copy it on a wiki page for example and ask for maintainers
20:44:06 <ennael> on -dev ML
20:44:14 <ennael> sounds reasonable ?
20:44:20 <misc> for each package, we assign it to 1 person, who import it ( and BR ), clean it and so on
20:44:21 <AL13N_ipv4> ok
20:44:24 <misc> ennael: yup
20:44:28 <ennael> ok
20:44:32 <AL13N_ipv4> #agreed
20:44:34 <misc> so we know who is in charge of tracking what packages
20:44:40 <ennael> yep
20:44:53 <ennael> it does not mean other guys cannot package
20:44:55 <misc> ( unlike the joyful anarchy of importing the bootstrap where people didn't know where to help )
20:45:01 <ennael> but still we tru to organize priorities
20:45:19 <misc> yup, we cannot force people of course :)
20:45:26 <AL13N_ipv4> i vote for someone from team leaders to prioritise that wiki list
20:45:41 <baud> to help with this (identifying interesting packages, listing, assigning...) is the plan still to use bugzilla for packaging requests ?
20:45:48 <misc> #action misc provides a list of package that are important to import and assign this for next week
20:46:16 <misc> baud: in the long run, mageia app db, but we are not yet at having _new_ rpm, just old one will suffice
20:46:28 <Stormi> an issue tracking system like bugzilla could help
20:46:39 <Stormi> create one issue per important package
20:46:43 <baud> misc: agreed, that's how I understand "import"
20:46:45 <AL13N_ipv4> but, noone pulls a funda at this time, agreed?
20:46:58 <baud> AL13N_ipv4: :)
20:47:02 <ahmad78> (no one can pull a Funda)
20:47:07 <ennael> :)
20:47:15 <AL13N_ipv4> you know what i mean
20:47:18 <ahmad78> (he makes patches for all sorts of code)
20:47:33 <AL13N_ipv4> we stick to the packages on wiki
20:47:40 <AL13N_ipv4> (i mean maintainers)
20:47:46 <misc> ok so anything to add on the topic ?
20:48:00 <misc> ( ie can we end the meeting, I will post on the ml after eating )
20:48:17 <AL13N_ipv4> can the wiki be added to,
20:48:19 <AL13N_ipv4> ?
20:48:27 <AL13N_ipv4> i mean, can other people add stuff to the wiki?
20:48:31 <AL13N_ipv4> in a second part?
20:48:38 <AL13N_ipv4> (ie: less important?)
20:48:50 <ennael> this is not less important
20:48:51 <AL13N_ipv4> or is that preferred not at this time
20:48:59 <ennael> this is a question of organize things
20:49:01 <AL13N_ipv4> ?
20:49:08 <ennael> so that stuff can be properly imported
20:49:20 <AL13N_ipv4> rephrasing:
20:49:24 <ennael> we have some priorities indeed for infrastructure
20:49:43 <ennael> but on desktop apps for example we need to clean zillions of applications
20:49:43 <AL13N_ipv4> can other people add other (new)packages on that wiki page in second part of that wiki page? or preferably not?
20:49:52 <ennael> yes they can
20:49:54 <ennael> (outch)
20:50:00 <AL13N_ipv4> lol
20:50:03 <AL13N_ipv4> ok
20:50:04 <ennael> but trying to make it properly
20:50:13 <ennael> having 1 guy / package
20:50:20 <AL13N_ipv4> ok
20:50:26 <ennael> and trying to work on desktop, server, devel apps...
20:50:29 <baud> AL13N_ipv4: well, yeah imho, but people may have to understand that their choice may not be prioritized higher :)
20:50:37 <ennael> yes
20:50:53 <misc> ok so nothing to add ?
20:51:03 <AL13N_ipv4> baud: i think you have to add your name to the maintaining of that package :-)
20:51:05 <ennael> misc is dying :)
20:51:14 <baud> AL13N_ipv4: which one ?
20:51:15 <AL13N_ipv4> misc: i'm ok, you're cleared for eating
20:51:16 <shikamaru> mmh need to think about that
20:51:27 <AL13N_ipv4> baud: if you add one, you are it's maintainer
20:51:36 <shikamaru> I mean, I understand the idea of prioritizing some packages
20:51:41 <ennael> we can split packages to be maintained in kind of pools
20:51:49 <ennael> desktop, server, devel, scientific apps...
20:52:46 <baud> ennael: good idea, that may help have teams building later on around those types of "pools"
20:52:52 <ennael> yep
20:53:00 <ennael> I will prepare a page
20:53:02 <ennael> wiki page
20:53:07 <ennael> then post on -dev
20:53:10 <ennael> is that ok ?
20:53:15 <AL13N_ipv4> yes
20:53:15 <baud> testers too (in the long run)
20:53:18 <baud> ok
20:53:22 <misc> #action ennael prepare a page about pools
20:53:35 <AL13N_ipv4> who prepares the rpm list?
20:53:50 <ennael> this can be discussed with everybody on ML
20:53:59 <misc> yup
20:54:06 <misc> AL13N_ipv4: i will try to do it
20:54:27 <AL13N_ipv4> ok
20:54:32 <misc> ok so we will continue on the ml
20:54:37 <AL13N_ipv4> end of meeting?
20:54:37 <misc> thanks for being there
20:54:41 <misc> yep
20:54:48 <misc> ( short meeting )
20:54:51 <AL13N_ipv4> k
20:54:51 <misc> #endmeeting