20:03:12 <misc> #startmeeting
20:03:12 <Inigo_Montoya`> Meeting started Wed Jan 26 20:03:12 2011 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:12 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:03:13 <erzulie> [ MeetBot - Debian Wiki ]
20:03:17 <Kharec> hi
20:03:21 <misc> #name Packagers
20:03:28 <misc> #chair ennael misc
20:03:28 <Inigo_Montoya`> Current chairs: ennael misc
20:03:37 <misc> so
20:03:44 <misc> ennael: ?
20:03:53 <Ruperto> helow
20:03:57 <misc> #topic review on buildsystem, distro bootstrap
20:04:34 <brianb> HI
20:04:52 <misc> so as you can see, the build system is working, we have even added some improvement ( like pascal check ) and we are open to various proposal ( with patch, it is better )
20:05:28 <misc> we plan to also add some more ( like rpmlint check ), but we will discuss this first on -dev, of course
20:05:48 <ennael> hi there sorry for the delay
20:05:55 <Kharec> ennael: hi
20:06:25 <misc> regarding the distribution bootstrap, it is also going quite well, as we are now up to 99% of package rebuilt, but the last percent is either tricky ( drakxtools ) or java related
20:06:33 <misc> java related is quite complex, since there is lots of deps
20:06:47 <Nanar> 99% of basesystem ?
20:06:51 <misc> for drakxtools, the issue is mainly to check license and source code, and usage of the M word
20:07:05 <misc> Nanar: well, 99% of what was needed to build basesystem :)
20:07:05 <Nanar> not the whole packages set availlable under mdv ?
20:07:13 <Nanar> k
20:07:34 <pterjan> 99% of what is in the repository currently :)
20:07:52 <pterjan> for example jq imported many perl packages, not needed by basesystem
20:08:20 <pterjan> we have imported (and built) 3849 src.rpm
20:08:36 <shikamaru> we also have kde and gnome rebuilt
20:08:42 <AL13N> afaik there are 22 java related packages, 4 drakxtools+ rpm, and 2 theming-related ones
20:08:45 <pterjan> and we have binaries coming from 28 mdv src.rpm
20:08:51 <misc> #info 99% of the bootstrap repository is currently rebuilded on mageia
20:09:11 <ennael> rebuilt :)
20:09:17 <misc> #undo
20:09:17 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Info object at 0x86a044c>
20:09:24 <misc> #info 99% of the bootstrap repository is currently rebuilt on mageia
20:09:25 <misc> #info 1% is either java, or tricky ( need to check for Mandriva word and copyright )
20:09:42 <pterjan> and I suggest giving a medal to dmorgan for the java stuff
20:09:50 <AL13N> #agreed
20:09:50 <mitya> no java-1.6.0-sun yet?
20:09:51 <shikamaru> yeah I agree
20:10:03 <shikamaru> kudos to dmorgan !
20:10:03 <misc> mitya: non free, afaik
20:10:04 <ahmad78> sun is easier than jdk
20:10:13 <ahmad78> ( I think)
20:10:22 <pterjan> mitya: the current problem is not the jdk
20:10:44 <mitya> just wondered; please go on guys
20:10:44 <pterjan> it is the hundred of maven-* packages and plexus-* packages with dependency loops
20:10:50 <misc> yup
20:10:59 <shikamaru> here is the list of remaining packages http://pkgsubmit.mageia.org/data/src.mdv.txt
20:11:19 <misc> so since some people ( like rtp and blino ) have in the past expressed interest in porting to others archs, we should keep a eye on bootstrap issue
20:11:38 <misc> ie, identify the loop, think of it, maybe do some kind of checks
20:12:08 <Nanar> bootstraping for another architecture will be harder, we'll don't have mdv packages to start
20:12:13 <pterjan> yep
20:12:25 <shikamaru> mmh we have for mips don’t we ?
20:12:26 <pterjan> only the noarch ones
20:12:30 <misc> well, that always hard
20:12:30 <Nanar> Sophie can compute the bootstrap list
20:12:38 <pterjan> shikamaru: yes arm and mips
20:12:38 <Nanar> it's just taking a long time
20:12:49 <shikamaru> I’ve got a 2009.1 mirror for mips packages
20:13:02 <rtp> Nanar: wrong. you only need linux running on the arch you want. I started arm and mips with boxes running debian :)
20:13:02 <shikamaru> as well as images
20:13:03 <pterjan> rtp has mirrors :)
20:13:13 <AL13N> we should try to fix all the bootstraps by some macros of automated things
20:13:19 * Nanar slaps rtp :)
20:13:23 <misc> well, for the exact detail of porting, that's not the topic, for now, we are just speaking of a review of bootstrap
20:13:32 <misc> AL13N: macros of ?
20:13:36 * pterjan will leave very soon
20:13:40 <AL13N> i have no idea how this works
20:13:51 <AL13N> but perhaps more levels are required? (i have no idea)
20:13:56 <misc> rtp: can you explain your idea of a list of macros ?
20:13:57 <rtp> misc: true. not being able to break circular build requires is bad
20:14:32 <ennael> ok maybe we can go on guys :)
20:14:57 <rtp> misc: I guess I need to "brain dump" it somewhere before talking about it imho /o\
20:15:14 <misc> #action rtp braindump the idea to break loop
20:15:21 <misc> ok so next topic, mentoring
20:15:27 <misc> #topic mentoring
20:16:02 <misc> so, as you may have seen the link given by ennael
20:16:15 <pterjan> bye
20:16:42 <misc> there is quite a lot of thing to do to start being a maintainer
20:17:00 <AL13N> yes
20:17:33 <ennael> the point was to improve all these docs
20:17:33 <misc> so first, did you find the doc useful, do someone have a remark, something that's missing ?
20:18:10 <gusyear> what about template for .spec ?
20:18:33 <misc> gusyear: there is one, no ?
20:18:35 <shika_mob> gusyear: see the spec file syntax page
20:18:41 <anaselli> gusyear: it should be in iirc
20:18:42 <shika_mob> (spec_syntax)
20:18:44 <misc> http://mageia.org/wiki/doku.php?id=rpm_start
20:18:45 <erzulie> [ rpm_start [Mageia temporary wiki] ]
20:18:59 <anaselli> spec_helper?
20:19:26 <AL13N> ah yes
20:19:28 <Nanar> spec-helper is transparent I think
20:19:31 <shika_mob> misc: yes this one is a thorough explanation of how to build a package
20:19:42 <AL13N> i'm worried that the preparation is obsolete
20:19:57 <ahmad78> AL13N: ?
20:20:00 <AL13N> i never made any rpmmacros file or made any directories
20:20:06 <shika_mob> obsolete ? how so ?
20:20:12 <AL13N> it all seemed to happen by itself in ~/rpmbuild
20:20:30 <anaselli> fc AL13N?
20:20:33 <misc> we should maybe test, yes
20:20:41 <ahmad78> there's "proper" and there's "works", you pick
20:20:42 <AL13N> anaselli: what is fc?
20:20:48 <anaselli> fedora core?
20:20:49 <shika_mob> AL13N: it's not obsolete, how would you define a distsuffix or a packager tag ?
20:20:55 <AL13N> i'm on mandriva
20:21:08 <shika_mob> try rpmlinting your package
20:21:23 <ahmad78> yes, having an .rpmmacros is useful, not obsolete
20:21:26 <anaselli> ah, i've always created my directories by hands
20:21:27 <AL13N> i have no idea, i suspect some rpmmacro was installed by some package
20:21:28 <shika_mob> you should have a no-packager-tag warning
20:21:41 <AL13N> (i was running on mdv)
20:21:59 <anaselli> iirc there is a kind of rpmbuild setup or something like
20:21:59 <Nanar> AL13N: rpm provides lot of macros itself
20:22:06 <misc> i think we could have a assistant that 1) create the dirs 2) set the macro in .rpmmacros, 2) set rpmlint config ( if needed ) 3) check that required packagers are installed
20:22:10 <Nanar> w/o any macros rpm is not working
20:22:14 <ahmad78> mdvsys/bm would create them, I think
20:22:23 <AL13N> my packages did have disttag stuff
20:22:25 <misc> 4) set up ssh keys and ssh-agent config, as this is the blocking point for a lot of people
20:22:31 <AL13N> i used mdvsys always
20:23:02 <ahmad78> but mdvys/bm works on a dir basis, i.e. creates RPMS/SRPMS/BUILD ... etc in the svn checkout, wherever it is
20:23:06 <anaselli> misc will check it, but i'm quite sure fc and rh/centos has it already
20:23:19 <misc> anaselli: yes
20:23:21 <shika_mob> agree for ssh
20:23:21 <shika_mob> though oliver managed to do it very well :)
20:23:27 <misc> anaselli: fedora-packager-setup
20:23:47 <brianb> on ssh keys what strength so the passphase be?
20:23:49 <anaselli> misc: but i can't remember the command line :D
20:23:49 <AL13N> i would advise we have a similar package that sets macros and stuff
20:23:54 <ahmad78> misc: ssh isn't a blocking point, they just have to read the wiki page about it
20:24:15 <ahmad78> (which is a very dumbed down version of what needs to be done)
20:24:23 <misc> ahmad78: well, as a admin, I had to answer to more than required question on ssh than needed :)
20:24:38 <anaselli> ahmad78: yes bm works
20:24:43 <ahmad78> (a page guillomovitch called "not needed", so it's useful for mortals and beginners)
20:25:02 <shika_mob> ahmad78: this one is not on the wiki yet afaik :)
20:25:11 <ahmad78> misc: point them to the wiki page, and if they have more questions we can improve the page
20:25:15 <misc> so, anyone wnat to import the ssh page on the wiki ?
20:25:22 <ahmad78> shika_mob: ok, I'll import it
20:25:22 <anaselli> ahmad78: i used to test some packages in mdv2010.1
20:25:28 <anaselli> with command bm --define "distsuffix .mga" --define "mandriva_release 1"
20:25:30 <shika_mob> thanks
20:26:21 <misc> ( no volunteer for import ? )
20:26:33 <shikamaru> misc: the wiki page ?
20:26:36 <anaselli> misc: what?
20:26:41 <shikamaru> ahmad78: stepped up :)
20:26:45 <ahmad78> misc: I said I'll do it :)
20:27:04 <misc> #action ahmad78 import the ssh wiki page
20:27:18 * anaselli hides
20:27:18 <ahmad78> (since I wrote it in the mdv wiki, at least I'll correct my mistakes and no one will notice)
20:27:46 <misc> anything to add on that topic ?
20:27:56 <brianb> dont forget to cover the strength of the passphase!
20:28:21 <misc> yup
20:28:33 <ennael> we asked also some help for a FAQ
20:28:50 <brianb> isee that fordora had its ssh keys compromised
20:28:51 <ennael> give some ideas of questions you would have as beginners
20:28:55 <ahmad78> brianb: covered http://wiki.mandriva.com/en/Development/Basic_SSH_Configuration, but can be improved indeed
20:28:56 <erzulie> [ Development/Basic SSH Configuration - Mandriva Community Wiki ]
20:28:59 <Kharec> what kind of faq?
20:29:10 <ennael> that was on our last meeting...
20:29:12 <misc> Kharec: well, the question that new packagers always ask :)
20:29:23 <misc> that's the F of FAQ :)
20:29:24 <brianb> 1 char = 1.4 bits
20:29:28 <Kharec> okay
20:29:30 <ennael> We did ask some help on this and it seems nobody has question :)
20:29:36 <ennael> so it means we don't need doc
20:29:38 <ennael> :)
20:29:54 <baud> eh I added one answer at least!
20:30:05 <Kharec> ennael: i will write some questions for this FAQ
20:30:29 <anaselli> ahmad78: about ssh ForwardAgent you need to add 2 hosts pkgsubmit.mageia.org and svn.mageia.org if your home login is different
20:30:29 <Kharec> And send you it by mail
20:30:34 <misc> this can be like "is misc really able to move faster than light", or "is chuck norris weaker than ennael", this kind of stuff ( and in both case, the answer is "yes" )
20:30:38 <ennael> Kharec: it's on wiki
20:30:46 <misc> #action Kharec write question for FAQ
20:30:49 <ahmad78> anaselli: yes, will add that
20:30:50 <misc> #undo
20:30:50 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Action object at 0x86cf7ec>
20:30:50 <ennael> http://mageia.org/wiki/doku.php?id=packaging#faq
20:30:51 <erzulie> [ packaging [Mageia temporary wiki] ]
20:30:59 <misc> #action Kharec write question for FAQ on the wiki ( http://mageia.org/wiki/doku.php?id=packaging#faq )
20:31:01 <brianb> not yet ennael im slowly working through the packaging so i will have some FAQ's soon
20:31:01 <erzulie> [ packaging [Mageia temporary wiki] ]
20:31:09 <ennael> no need to write answer we can do it
20:31:11 * anaselli fell there ;)
20:31:17 <ennael> but still we need questions
20:31:19 <shikamaru> well this link is not well suited :/
20:31:26 <shikamaru> packaging page becomes a mess
20:31:27 <Kharec> ennael: OK.
20:31:36 <shikamaru> it should be better on a dedicated page
20:31:42 <misc> agree
20:32:00 <ennael> about this we have to kick webteam
20:32:09 <ennael> we need really our wiki
20:32:10 <AL13N> #agreed
20:32:14 <brianb> also what about some better navigationfor the wiki
20:32:31 <misc> AL13N: you are not chair, so using #agreed is not gonna do much, you know ?
20:32:41 <AL13N> misc: i know :-D
20:32:50 <shikamaru> that’s not a problem of navigation, but organisation
20:32:50 <misc> brianb: this will wait on the wiki migration
20:32:50 <brianb> unless you know the links its a not very user friendly
20:33:21 <shikamaru> and btw there’s a search textarea :)
20:33:30 <misc> anyway, anything to add on mentoring ?
20:33:41 <AL13N> on more thing
20:33:43 <AL13N> *one
20:33:59 <soig> mediawiki is better for organizeing
20:34:02 <AL13N> someone just told me there is only link to cooker mgarepo and not to the 2010.1 (or it isn't clear)
20:34:04 <Ruperto> yes, on mentoring,  what shall i do when i decided that my padawan is read?
20:34:06 <soig> (categories, portals, ...)
20:34:13 <brianb> well it appears that most you guys are at an advantage compaired to new people since you know all the links
20:34:22 <ennael> hey soig
20:34:38 <Stormi> brianb: a new wiki is on its way
20:34:41 <baud> brianb: and an index http://mageia.org/wiki/doku.php?do=index
20:34:42 <erzulie> [ start [Mageia temporary wiki] ]
20:34:47 <AL13N> Ruperto: ennael posted some links, one is about helping mentors to tell them what to do with their padawans
20:34:50 <ennael> brianb: that's why we need to organize doc so that you can a list of all these usefull links
20:35:10 <misc> AL13N: there is a 2010.1 , just need to change the url
20:35:18 <Ruperto> iread, then i didnt understand jeje
20:35:43 <AL13N> misc: yes, i know, but it wasn't clear from the text on the wiki
20:35:52 <misc> AL13N: that's a wiki...
20:35:54 <AL13N> misc: or at least not for that beginner
20:36:13 <AL13N> so maybe it needs to be on FAQ or not, or just being made clearer
20:36:19 <AL13N> i'm asking
20:36:21 <misc> and I think we agreed to first mentor people with enough skills, not complete beginner
20:36:34 <misc> #action AL13N fix the wiki on the mgarepo stuf
20:36:44 <AL13N> >_<
20:36:48 <ennael> Ruperto: http://mageia.org/wiki/doku.php?id=mentoring_start
20:36:49 <erzulie> [ mentoring_start [Mageia temporary wiki] ]
20:37:05 <misc> so nothing more on mentoring ?
20:37:09 <AL13N> i'm good
20:37:17 <ennael> nope
20:37:17 <shikamaru> mmh yes
20:37:21 <Ruperto> tanks
20:37:36 <shikamaru> on the packaging page
20:37:54 <shikamaru> some mentors don’t have trainees
20:37:57 <shikamaru> and there’s a demand I think
20:38:07 <shikamaru> I’m not sure it’s uptodate
20:38:18 <shikamaru> jq: do you have some trainees ?
20:38:21 <shikamaru> mikala: ?
20:38:25 <shikamaru> Kharec: ?
20:38:36 <misc> mhh, someone should contact people them outside of the meeting
20:38:42 <misc> shikamaru: can you send them a mail ?
20:38:51 <brianb> is there  list of people who are presently being mentored, and a list of people who will be the next intake for mentoring and those who  - binginers will have some indication as to when they will be selected ?
20:38:53 <shikamaru> I can’t :(
20:39:03 <misc> ok, i will
20:39:04 <Kharec> Don't have trainees
20:39:16 <shikamaru> seems like attila broke the 9box…
20:39:23 <misc> #action misc contact jq & mikala for seeing it they have a trainee
20:39:28 <ennael> brianb: please try to follow all information provided
20:39:29 <misc> so nothing more on mentoring ?
20:39:41 <baud> maybe first step of the mentoring process would be to ask his/her trainee to edit the wiki :) identifying trainee/mentor
20:39:57 <ennael> as said in 2 previous meeting see http://mageia.org/wiki/doku.php?id=packaging#current_mentoring
20:39:58 <erzulie> [ packaging [Mageia temporary wiki] ]
20:40:06 <shikamaru> no, it’s up to the maintainer to do that IMHO
20:40:10 <AL13N> yes
20:40:17 <AL13N> the mentor decides
20:40:19 <shikamaru> the trainee has already a whole lot of things to understand
20:40:34 <shikamaru> let’s simplify the task a bit don’t you think ? :)
20:40:39 <AL13N> noone assigning himself to any mentor without prior knowledge
20:41:29 <misc> ok so next topic
20:41:40 <misc> #topic coming roadmap packaging / isos
20:43:04 <misc> as said on various channels ( ml, irc ), we do have a server for building iso, and ennael was tasked to do that
20:43:04 <brianb> AL13N what do you consider as a beginer?
20:43:04 <AL13N> brianb: let's do this after meeting
20:43:04 <brianb> ok
20:43:06 <misc> we are working on having a first iso ready asap, with objectives of simply booting and getting bash
20:43:12 <misc> ( ie, the bare minimum )
20:43:30 <Ruperto> is nt' more easy if we do virtualization so we can get more "servers" than phisical machines?
20:43:34 <misc> ennael: something to add or explain ?
20:43:48 <misc> Ruperto: it just split ressources
20:43:50 <anaselli> so misc there's no packages priority but bootstrap right?
20:43:55 <ennael> nope
20:44:01 <brianb> will the iso initially be limited to certian people?
20:44:09 <ennael> the only thing we have to spread
20:44:11 * anaselli is a bit late with his ones :/
20:44:17 <ennael> is isos can be tested by everybody
20:44:21 <Ruperto> misc: yes i know, but iso  can be built at 3am not at 2pm     and with other priority, it is not a rolling task
20:44:21 <misc> brianb: no, except it will just be as functionnal as a gentoo one :)
20:44:27 <ennael> *but* it's a devel iso in very alpha stage
20:44:31 <shikamaru> a stage3 :)
20:44:32 <misc> ie, just bash
20:44:36 <misc> nothing more
20:44:43 * Kharec will love that.
20:44:43 <ennael> no design, icons missing
20:44:52 <misc> maybe irssi to say on irc "i use mageia"
20:44:55 <ennael> some bugs inside and very few packages
20:45:01 <misc> but maybe you will have to use telnet for that :)
20:45:10 <anaselli> ennael: ssh and svn?
20:45:18 <ennael> what ?
20:45:19 <misc> anaselli: telnet and rcs
20:45:23 <Kharec> misc: ifwe have telnet on iso :)
20:45:28 <anaselli> misc: useful :p
20:45:32 <shikamaru> well, as long as we have good old rpm-build it’s ok :)
20:45:33 <AL13N> ennael: perhaps enough to build a virtual local buildnode for it?
20:45:44 <baud> will there be a boot.iso prior to the ISO for testing minimal network installation ?
20:45:56 <ennael> yep
20:46:00 <blino> misc: sure, I am interested in sh4 port
20:46:03 <misc> well, at the same time
20:46:18 <baud> (so there will be rpm trees too before the iso ?)
20:46:20 <shikamaru> are packages signed ?
20:46:30 <misc> baud: rpm tree != boot.iso
20:46:30 <AL13N> yes, are they signed?
20:46:37 <misc> AL13N: not yet
20:46:45 <AL13N> will they be?
20:47:06 <misc> boklm is working on that, but as discussed on -sysadmin, that's quite a complex task ( ie, not signing per itself, but ensuring the key is secured, etc )
20:47:22 <shikamaru> are the remaining packages blocking for this iso ? (ie maven)
20:47:34 <brianb> will there be a freenodes testing channel for the iso feedback?
20:47:48 <misc> brianb: -dev, i guess, unless bugzilla is ready
20:47:50 <Nanar> brianb: here I guess
20:48:15 <misc> ( but even with bugzilla, we need to have people to assign bug, ie, a maintainer database, see webteam report for that, didn't have time to read it )
20:48:23 <AL13N> shika: drakxtools and rpm-manbo-setup definately are
20:48:39 <misc> shikamaru: more the fact that we have to clean lots of thing, like drakx itself
20:48:42 <shikamaru> mmh I thought manbo stuff would be dropped
20:48:45 <misc> ie remove icons, remove trademark
20:49:03 <shikamaru> and drakxtools isn’t strictly necessary for a minimal iso :)
20:49:04 <AL13N> shikamaru: manbo thing is in process of being merged by blino IIRC
20:49:14 <AL13N> shikamaru: it's a buildrequire
20:49:16 <misc> shikamaru: needed for kernel installation ( bootloader-config )
20:49:33 * misc think he should add more #info
20:49:36 <shikamaru> ah yep you’re right :/
20:49:40 <misc> #info boklm is working on key
20:49:49 <misc> #info ennael is working on creating iso
20:50:03 <misc> #info boot.iso should be on the mirror at the same time
20:50:06 <AL13N> misc: who is doing rpm-mageia-setup?
20:50:15 <AL13N> blino or tmb or ?
20:50:25 <misc> AL13N: dunno,
20:50:28 <misc> blino: ?
20:50:30 <shikamaru> mmmh supposed to be done already I think
20:50:51 <AL13N> i tink pterjan told me it wasn't complete yet, (partial)
20:50:56 <misc> #info iso will be quite minimal and not ready
20:51:04 <misc> AL13N: check svn changelog ?
20:52:08 <misc> anyway, anything to add ?
20:52:22 <ennael> nope
20:52:48 <misc> ok, next topic
20:52:51 <AL13N> misc: all of them (even shikamaru)
20:52:52 <misc> #topic triage team: how we can help and get sufficient numbers
20:53:22 <misc> so, yesterday was the meeting of triage team
20:53:33 <shikamaru> oops I missed it :/
20:53:39 <misc> and few people come, which is quite disappointing
20:54:03 <misc> ( as triage is something that is greatly helpful to everybody and that was quite prepared by ahmad78 )
20:54:31 <ahmad78> (which is also quite historically correct, triage team is always a few people, bugzilla has that repelling effect on ppl)
20:54:36 <AL13N> hmm, i wasn't aware of it; was it announced somewhere?
20:54:43 <misc> as a bugzilla without triage is a bugzilla that is quite useless, ( too much duplicate, user and developpers frsutration ), we should find a way to have more people to help
20:54:59 <shikamaru> yes on the bugsquad mailing list
20:55:03 <ahmad78> an email was sent to the ppl who registered their names in the triage page on the wiki
20:55:10 <baud> maybe add it to http://mageia.org/wiki/doku.php?id=meetings#time_table_utc
20:55:11 <erzulie> [ meetings [Mageia temporary wiki] ]
20:55:20 <misc> maybe send it on -dev too, or -discuss ?
20:55:21 <AL13N> perhaps it could have been mentioned on -dev or -discuss
20:55:31 <AL13N> heh
20:55:42 <Stormi> indeed, some people could be interested now that haven't put their names on the wiki (I hope)
20:56:01 <ahmad78> from 30 names in the wiki, only two showed up
20:56:10 <shikamaru> sorry ahmad78
20:56:15 <misc> ahmad78: that's the rules of rda
20:56:18 <ahmad78> shikamaru: you were on the channel :D
20:56:19 <shikamaru> will be there now
20:56:22 <brianb> is there a triage channel on freenodes?
20:56:30 <shikamaru> ahmad78: well, but after the meeting no ? :)
20:56:43 <ahmad78> of course tv is considered online at all times (Big Brother, so, actually 3 ppl)
20:56:54 <Nanar> what can motivate people to sort bugs ?
20:56:56 <ahmad78> shikamaru: nope, at the time of the meeting, I saw you
20:57:27 <misc> ok so first, announcing the meeting on -dev and -discuss ?
20:57:32 <ennael> yep
20:57:38 <AL13N> and timetable
20:57:40 <misc> ( at least for the first time, until a critical mass is reached )
20:57:40 <ahmad78> brianb: #mageia-bugsquad
20:57:42 <Kharec> I'm motivate to help ahmad78 and the triage team, and will pit my name on wiki :)
20:57:45 <Kharec> *put
20:58:14 <misc> #action ahmad78 announce the meeting on more ml
20:58:44 <Stormi> and maybe sent another mail to those who put their names in the wiki, insisting on how few you were last time
20:59:03 <ennael> agree
20:59:06 <ahmad78> I ain't gonna beg 'em, son!
20:59:08 <ahmad78> :)
20:59:16 <misc> ahmad78: ok, threathen them, plf style
20:59:16 <Stormi> threaten them then :)
20:59:24 <ahmad78> misc: \o/
20:59:43 <Stormi> I won because I wrote "threaten" correctly
21:00:05 <AL13N> >_<
21:00:12 <Nanar> Stormi: now pronounce it correctly :)
21:00:15 <misc> ok so anything on triage team ?
21:00:18 <AL13N> so when is it?
21:00:21 <AL13N> the meeting?
21:00:24 <AL13N> so i can put on wiki?
21:00:28 <AL13N> timetable?
21:00:30 <brianb> maybe your have more intrest when the iso is released
21:00:46 <misc> brianb: but we shouldn't wait on iso to start the team :)
21:01:02 <brianb> i understand that
21:01:13 <AL13N> so, tue 2000UTC? or 1900? or?
21:01:16 <misc> but indeed, the team will start for iso
21:01:18 <misc> ahmad78: ?
21:01:27 <ahmad78> misc: no, nothing
21:01:33 <AL13N> ahmad78: when is it?
21:01:36 <misc> ahmad78: the question of AL13N :)
21:01:37 <ahmad78> AL13N: 20UTC
21:01:39 <AL13N> k
21:01:56 <Kharec> I'll try to be there
21:01:58 <misc> ok so on triage team, anything else ?
21:02:03 <baud> yep, processes and specific requests concerning bugzilla can begin before there are bugs :)
21:02:30 <brianb> is there a wiki page on bugzilla
21:02:32 <shikamaru> misc: about the state of bugzilla
21:02:49 <misc> shikamaru: yes ?
21:02:51 <shikamaru> apparently it’s linked to ldap
21:02:57 <misc> yes
21:03:07 <shikamaru> but is there also mail notifications working for instance ?
21:03:11 <misc> dmorgan: ?
21:03:30 <ahmad78> brianb: yes; links will be in the email I'll send to -dev ML
21:03:35 <shikamaru> will bugs be sent to mageia-bugsquad ? or something else
21:03:41 <dmorgan> sorry i was in the john
21:03:59 <brianb> hope u pulled the flush :)
21:04:04 <misc> shikamaru: to a ml, but not created yet ( a bit late for this, sorry )
21:04:12 <dmorgan> brianb: :) not now my irc highlighed :þ
21:04:24 <shikamaru> no problem :)
21:04:28 <tumbeliina> hi
21:05:04 <dmorgan> baud: i still need to do things for the bugzilla like think about a dedicated ML
21:05:11 <ahmad78> misc: not late, we have no bugs yet \o/
21:05:11 <AL13N> timetable is updated
21:05:12 <shikamaru> and well, we already know we need a maintainer db :)
21:05:23 <misc> ok so anything on triage team ?
21:05:26 <Kharec> good night all ;)
21:05:26 <dmorgan> ahmad78: there 2 bugs :þ
21:05:33 <ahmad78> dmorgan: "test" bugs
21:05:34 <tumbeliina> how take care of screensavers?  i got photos for slideshow
21:05:55 <misc> tumbeliina: ask on the ml, we are in a meeting right now, thanks :)
21:06:01 <dmorgan> ahmad78:21:06:08 <shikamaru> misc: well, I guess we’ll discuss this on bugsquad meeting, ok for me :)
21:06:15 <misc> ok so next topic ?
21:06:30 <anaselli> ok
21:06:38 <misc> #topic Review on policies import
21:06:41 <misc> shikamaru: ?
21:06:46 <shikamaru> ok
21:07:04 <shikamaru> well, nothing evolved a lot since last week in the wiki
21:07:08 <tumbeliina> misc, ok sorry :)
21:07:14 <shikamaru> I imported and amended the ruby packaging policy
21:07:31 <shikamaru> seems like it’s in a good shape now since I didn’t received complaints :p
21:07:50 <shikamaru> java policy is kinda hard to define
21:07:51 <misc> #info ruby packaging policy is imported
21:07:59 <shikamaru> there’s a topic on this at fosdem
21:08:13 <shikamaru> it would be good if people interested in this attend the conference if they can
21:08:32 <shikamaru> (let me find the link
21:09:22 <shikamaru> http://fosdem.org/2011/schedule/event/distrohate
21:09:22 <erzulie> [ fosdem.org ]
21:09:44 <misc> shikamaru: that's java, not ruby
21:09:51 <misc> oh yes
21:09:58 <AL13N> dmorgan: lol @ "Why Linux Distributions Hate Java"
21:10:00 <misc> missed the part
21:10:17 <misc> #info nothing changed much for the rest
21:10:27 <misc> shikamaru: how much review are needed ?
21:10:31 <philippeM> and sorry I'm late on the Python one
21:10:37 <shikamaru> I’m not that worried because some links in the table are a bit obsolete
21:10:39 <misc> philippeM: no problem :)
21:10:45 <shikamaru> maybe I should just remove them
21:10:50 <shikamaru> like charset
21:12:01 <shikamaru> there are some policies that can wait for import atm
21:12:06 <shikamaru> like freeze policy
21:12:10 <misc> yup
21:12:32 <shikamaru> and since there are no volunteers for haskell or OCaml packages, these can wait too
21:12:35 <ofaurax> ho, there's a meeting here (just saw the blog)
21:12:55 <Nanar> shikamaru: I'll try to have a look on haskell one
21:13:07 <shikamaru> Nanar: thanks ! :)
21:13:16 <Nanar> shikamaru: but there is no emergency since I still don't know how to import haskell
21:13:20 <misc> #action Nanar look at haskell policy
21:13:26 <shikamaru> my main concern is the library policy
21:13:44 <shikamaru> it’s still work in progress, I started it but did not finish it
21:13:53 <shikamaru> and this one is very useful
21:14:04 <misc> and important
21:14:14 <shikamaru> yes
21:14:18 <Nanar> shikamaru: send me link, I'll look too (by mail)
21:14:36 <shikamaru> Nanar: internet connection broken and no backup postfix :/
21:14:53 <Nanar> shikamaru: when it will be possible for you
21:15:03 <shikamaru> ok
21:15:13 <shikamaru> a thing you could assign to me though
21:15:20 <Nanar> just we'll not talk about this right now
21:15:20 <ennael> anything to add there ?
21:15:23 <baud> Nanar: http://mageia.org/wiki/doku.php?id=libraries (bookmark it)
21:15:24 <erzulie> [ libraries [Mageia temporary wiki] ]
21:15:32 <shikamaru> is to write down on the wiki what’s been agreed in the discussions on the mailing list
21:15:32 <Nanar> baud: thanks
21:15:56 <misc> #action shikamaru wrte in the wiki what was agreed on the ml, with reference
21:16:06 <misc> ok so last topic ?
21:16:12 <shikamaru> go on :)
21:16:46 <misc> #topic nuremberg meeting
21:17:10 <misc> so, people may have read the ml ( -discuss ), or the various planet, or our blog about the meeting
21:17:37 <misc> so I will skip this part, unless people have questions, and go directly to the important part
21:18:38 <misc> so we have worked with others distribution ( http://lists.freedesktop.org/archives/distributions/2011-January/000411.html ), and some people have expressed interest into reusing part of the plan, like Stormi for mageia-app-db
21:18:38 <erzulie> [ Results of the App Installer Meeting ]
21:19:18 <misc> so first, do someone have concern regarding this ?
21:20:04 <shikamaru> I read some things about ubuntu CLA
21:20:06 <AL13N> no general concern, but then i only know it's about metadata, so what exactly are you planning?
21:20:07 <shikamaru> what is this ?
21:20:29 <Nanar> AL13N: at least pushing this metadata for Mageia
21:20:29 <misc> shikamaru: contributer license agreement, but that's quite long to explain, i will do it after the meeting :)
21:20:43 <shikamaru> which would prevent reusing ubuntu software center IIUC is that right ?
21:20:44 <AL13N> Nanar: ok, but _what_ metadata
21:20:46 <misc> AL13N: that's explained in the mail, and in the various webpages
21:21:02 <Stormi> shikamaru: not using but contributing to
21:21:13 <Nanar> so if a tools get out of this work, it will work for Mageia
21:21:24 <brianb> i have concerns about suse
21:21:27 <misc> AL13N:  http://distributions.freedesktop.org/wiki/AppStream/MetadataNotes
21:21:29 <erzulie> [ distributions Wiki - AppStream/MetadataNotes ]
21:21:32 <misc> brianb: ie ?
21:21:39 <shikamaru> anyway, before asking questions, I think we should first read pages there http://distributions.freedesktop.org/wiki/AppStream/
21:21:41 <erzulie> [ distributions Wiki - AppStream ]
21:21:47 <shikamaru> didn’t have time to dig into it
21:22:05 <brianb> the sell out of novel
21:22:18 <shikamaru> and www.youtube.com/watch?v=BHeP2ZBwS_U
21:22:25 <AL13N> misc: what i want to know is: what exactly from this do we want to use for us?
21:22:36 <Nanar> if AppStream works well, maybe rpmdrake will become obsolete (maybe...)
21:22:41 <brianb> and that lurking in the background is microsoft
21:22:43 <misc> AL13N: for mageia app dbn for example, to have screen shot on the website
21:22:49 <Stormi> brianb: this is out of topic
21:23:10 <AL13N> misc: yes, but what else? i would like to know some details
21:23:16 <shikamaru> my main concern is that I heard some skills in python, perl and php would be needed
21:23:28 <shikamaru> how could we help the project from the mageia side
21:23:29 <shikamaru> ?
21:23:53 <misc> AL13N: well, for mageia-app-db, ask to sotrmi, for software center, just look at the video, it should be quite self explantory, for the rest, it is up to what people will do
21:24:05 <Nanar> I don't think we can summarize three full days of work at 16 people right now
21:24:14 <AL13N> misc: are we planning on using that software center too?
21:24:15 <misc> shikamaru: good question , i will explain once I have finished to answer question
21:24:16 <Stormi> one step is, once the .desktop specification has been enhanced, help upstream completing them
21:24:34 <misc> AL13N: using by default, not until we discussed, proposiing it, like any software, why not
21:24:49 <AL13N> misc: instead of rpmdrake you mean?
21:25:01 <misc> AL13N: well they do not have the same focus
21:25:13 <misc> rpmdrake list package, software center list application
21:25:15 <AL13N> misc: oh, then i seem to have misunderstood
21:25:53 <AL13N> misc: so, they will work together, you mean?
21:25:59 <Nanar> for instance, AppStream don't care about command line tools
21:26:05 <misc> AL13N: well, yes, like urpmi and rpmdrake
21:26:28 <AL13N> if it doesn't conflict with rpmdrake, i see no reason why not to package
21:26:38 <AL13N> to be used as default, i need more info to judge on it
21:26:50 <AL13N> for mageia-app-db, i see no troubles
21:26:50 <misc> well, using as default is not to be discussed now
21:27:08 <Nanar> rpmdrake has never denied to make packages of other concurrent tools...
21:27:12 <AL13N> misc: in any case, those are my thoughts on it
21:27:27 <misc> ok so as shikamaru asked, how could we help
21:27:41 <misc> the first stuff is helping mageia-app-db, ie, code in php
21:27:59 <Nanar> so helping Sophie too
21:28:14 <Nanar> /o\
21:28:17 <AL13N> misc: is this something to be asked of -dev team?
21:28:18 <shikamaru> I could help for Sophie
21:28:29 <AL13N> i can help in php, if required
21:28:40 <shikamaru> I know perl, but not modern perl like Moose and I don’t know Catalyst yet
21:28:41 <AL13N> misc: but i think we need -dev team for this decision
21:28:58 <misc> AL13N: there is no -dev team at the moment
21:29:10 <shikamaru> Nanar: maybe we can speak of that after the meeting :)
21:29:11 <misc> another thing to do would be to enhance package kit support
21:29:14 <AL13N> yes, but not all people expressing interest in -dev are in this meeting
21:29:20 <misc> but it requires someone who know perl and perl-URPM
21:29:20 <brianb> whats the advantage for mageia in this collaboration?
21:29:24 <Nanar> shikamaru: if you're interest to work in, send me mail with login and your Mail (when possible)
21:29:54 <Nanar> shikamaru: yes after ;) but also after eating (for me)
21:29:56 <misc> brianb: sharing ressources with others distribution ( screenshot, comments, ), using a tools shared by others distribution ( collaboration, etc )
21:29:59 <AL13N> misc: i have interest in perl-URPM, but not really package-kit (i don't know exactly what it is either)
21:30:14 <misc> AL13N: that's a package manager abstraction
21:30:26 <Stormi> and there's some work to do to produce the .xml files containing metadata that should be made available on mirrors for use from the software managers
21:30:27 <misc> ie, you can use the same dbus and command line on supported distribution
21:30:41 <misc> and this is used by gnome and kde for integration of package
21:30:51 <AL13N> misc: that could be beneficial
21:30:53 <misc> ( like "here is some specific font, do you want to install" )
21:30:59 <misc> AL13N: yup, that's why i propose it
21:31:00 <brianb> so how would that place the mageia mandriva long term relationship?
21:31:12 <misc> i have done part of the work 1 years ago, but some stuff are missing
21:31:36 <misc> see http://packagekit.org/pk-intro.html
21:31:37 <erzulie> [ PackageKit - What is PackageKit? ]
21:31:38 <Nanar> brianb: ?
21:31:40 <AL13N> misc: ah yes, was mandriva people present too? or were they not asked?
21:31:54 <misc> AL13N: they were asked on the distribution ml, like the others
21:31:59 <Nanar> AL13N: yes, us /o\
21:32:14 <AL13N> so same people represented mandriva and mageia
21:32:25 <misc> well, technically, we were contacted as part as mageia, even if everybody tought we were mandriva, but no official from the company was here
21:32:27 <AL13N> can i ask what mandriva plans to do with this?
21:32:32 <Nanar> from a technical point of view, it make sense
21:32:37 <misc> ( but redhat, canonical, novell did send people )
21:32:45 <Nanar> politically... well...
21:32:45 <misc> AL13N: ask to mandriva, not us
21:32:59 <AL13N> misc: ok, but did you tell them about it and stuff?
21:33:00 <baud> AL13N: Stormi already forwarded to cooker ML :)
21:33:05 <AL13N> misc: did you get reactions?
21:33:09 <AL13N> ok
21:33:11 <misc> AL13N: no
21:33:13 <AL13N> i'll look into it later
21:33:19 <AL13N> ic
21:33:24 <misc> AL13N: anyway, interested by packagekit ?
21:33:27 <AL13N> too busy with rpm5 i suppose
21:33:37 <misc> there is a perl module to complete
21:33:37 <AL13N> misc: i am a bit interested in it
21:33:42 <Nanar> AL13N: something like that I guess :)
21:33:56 <AL13N> misc: which one?
21:33:59 <misc> AL13N: http://packagekit.org/pk-matrix.html
21:34:00 <erzulie> [ PackageKit - Feature Matrix ]
21:34:14 <AL13N> misc: i'll look into it, maybe i can spare some time, i'll have to see
21:34:20 <AL13N> misc: let's continue meeting, k?
21:34:25 <Stormi> misc: shouldn't we create an AppStream page on the wiki with TODO list on it ? Or another way to add actions to the roadmap ?
21:34:34 <misc> AL13N: http://cgit.freedesktop.org/packagekit/tree/backends/urpmi/helpers
21:34:35 <AL13N> misc: i still maintain that there are -dev people who aren't present here...
21:34:35 <erzulie> [ packagekit - System package management service ]
21:34:46 <misc> Stormi: there is one on the freedesktop wiki
21:34:54 <misc> but yes, another one would be nice
21:35:01 <Stormi> misc: I meant from the mageia side
21:35:04 <Nanar> AL13N: too early, we have to wait the spec get written on AppStream side
21:35:20 <misc> AL13N: well, the topic was sent on -dev, what should be done ?
21:35:22 <Stormi> (may be linked each from the other)
21:35:30 <misc> Stormi: can you do it ?
21:35:32 <Stormi> yep
21:35:44 <misc> #action Stormi add a page on wiki about appstream project
21:35:49 <AL13N> misc: ok, that is true, but -dev people (who aren't interested in packaging could have just skipped the whole conv)
21:36:18 <misc> AL13N: ok, can you contact them ?
21:36:21 <AL13N> misc: i'm just saying, perhaps more people have interest in this
21:36:31 <AL13N> misc: i'll go over the wiki
21:36:36 <AL13N> and contact them
21:36:52 <misc> #action AL13N contact people for working on the appstream project
21:37:06 * AL13N feels he's being pushed into doing stuff
21:37:09 <AL13N> :-)
21:37:12 <misc> that's the goal of meeting
21:37:28 <misc> if I wanted to do stuff, i wouldn't do meeting to announce "i am doing this", i would just do it :)
21:37:34 <AL13N> misc: maybe your goal ;-)
21:37:46 <misc> AL13N: for packagekit, you should see with Aurelien Lefebvre alkh@mandriva
21:37:55 <AL13N> misc: ah, but there you are wrong, you should announce it, so we know!
21:37:58 <misc> that's a cross distro tool, so this will benefit us and them
21:38:05 <AL13N> ah, ic
21:38:29 <AL13N> misc: is there a packagekit-appstream path proposed?
21:38:37 <AL13N> or was this not talked about?
21:39:03 <misc> AL13N: the goal is to port sotware center to packagekit, i have looked, it should not be too complex
21:39:11 <misc> like 1 week of python hacking, maybe ?
21:39:17 <brianb> this cross dev tool who will be developing it?
21:39:19 <misc> the code is quite clean and separated
21:39:51 <AL13N> misc: you know more of this, so if i work on this, you'll have to guide me
21:40:01 <misc> brianb: depend, the interface was done by canonical, the backend by rh, and the various part are based on technlogy from a debian guy, and from a kde guy
21:40:08 <shikamaru> Stormi: btw, could you give me back the link of the test instance of mageia-app-db ?
21:40:14 <ennael> :win12
21:40:17 <misc> AL13N: well, the packagekit developers may be more suited
21:40:17 <shikamaru> to see how are things going :)
21:40:30 <AL13N> misc: but they weren't at the meeting?
21:40:35 <Nanar> ennael: touchpad ?
21:40:39 <Stormi> shikamaru: everything is available from there : http://www.canalblog.com/cf/my/?nav=blog.upload.picture&bid=40475
21:40:40 <erzulie> [ Blog photo, blog audio ou video. Creer un blog gratuit ]
21:40:40 <misc> AL13N: they were
21:40:44 <AL13N> ah, ok
21:40:45 <AL13N> sorry
21:40:48 <Stormi> oooooops
21:40:50 <shikamaru> Stormi: ty
21:40:53 <misc> AL13N: see the list of attendees
21:40:57 <ennael> Nanar: :)
21:41:03 <Stormi> what happened to me copy-paste ? :)
21:41:04 <AL13N> misc: i will look
21:41:06 <misc> AL13N: like richard hugues, for a start
21:41:09 <Stormi> shikamaru: http://mageia-app-db.tuxette.fr/projects/mageia-app-db/wiki
21:41:10 <erzulie> [ mageia-app-db - Wiki - Mageia App Db project ]
21:41:11 <shikamaru> haha :)
21:41:58 <misc> anyway, any others questions, something that I didn't answered ?
21:42:13 <AL13N> not at this time for me
21:42:27 <misc> ( if any do not hesitate to ask on the ml project )
21:43:08 <Stormi> I think people need some time to read about this AppStream stuff :)
21:43:13 <baud> ok for me :)
21:43:45 <shikamaru> Stormi: agree
21:43:47 <misc> ok so that's the closing of the meeting, I will send the log on -dev later ( or you can do it if you want )
21:43:51 <brianb> is it envistage that more disto will sign up to this package centric approach?
21:43:53 <misc> as I am hungry
21:43:57 <ennael> :)
21:44:04 <Stormi> brianb: they are invited to, at least
21:44:06 <Nanar> time to drink too
21:44:12 <ennael> (nice to see misc working)
21:44:16 <AL13N> time to pee
21:44:22 <misc> #endmeeting